New Page 2

This page uses frames, but your browser doesn't support them.


Untitled

Редактируем BIOS (Award Modular v.4.51)

AMIBIOS Setup

Описание настроек BIOS Setup

Все, что полезно знать о BIOS

Описание настроек Setup BIOS

Загрузка BIOS

Как определить, что установленный на материнской плате BIOS, прошит во Flash ROM?

FAQ по системным платам IBM PC


Untitled

DOS — долгожитель среди операционных систем


Help 1

Help 1.3

Дополнены разделы Dos и Реестр Wibdows.


Untitled

Введение

Реестр Windows

Настройка и оптимизация Windows

Internet

Bios

DOS

Windows XP

Windows ME, 98

Windows 2000

Разное

История


Untitled

Соединение двух компьютеров по телефонной линии

Секреты Internet

Анонимный серфинг

Настройка и оптимизация модемного соединения


Untitled

Что скрывается в автозагрузке

Ускорение загрузки Windows

Секретные приемы автозагрузки

Очистка списка недавно используемых прграмм

Переустановка Windows со всем софтом за 15 минут

Оптимизация памяти

Советы "Народной мудрости -1"

Советы "Народной мудрости -2"

Советы "Народной мудрости -3"

Советы "Народной мудрости -4"

Команды Rundll32 и возможность их использования

Быстродействие

Восстановление системы

Ускорение

Оптимизация памяти


Untitled

НЕКОРРЕКТНОЕ ОТОБРАЖЕНИЕ ТЕКСТА


Untitled

Настройки Windows с помощью реестра


Untitled

Особенности операционной системы Windows 2000 Professional


Untitled

Win9x/ME FAQ


Untitled

Секреты ХР

Стоит ли ставить Windows XP?

Независимая установка WinXP от WinME/9x

Оптимизация MS Windows XP

Windows XP FAQ

20 секретов Windows XP

Подборка советов по настройке и работе в Windows XP

Интеграция SP1 в дистрибутив Windows XP

Взлом активации Windows XP


20 секретов Windows XP: 1

20 секретов Windows XP:

1. Если предыдущие версии Windows скрывали, как долго они способны работать без перезагрузки, то ХР в этом плане есть чем гордиться. Войдите в командную строку из меню Accessories, которое вызывается стартовой кнопкой All Programs, и наберите systeminfo. Компьютер выдаст много полезной информации, в том числе время бесперебойной работы. Для сохранения этих данных в файле наберите systeminfo > info.txt.

2. Для того чтобы удалять файлы, не сохраняя их в "мусорной корзине", выберите Run... из меню Start и наберите gpedit.msc, затем выберите User Configuration, Administrative Templates, Windows Components, Windows Explorer и отметьте флажком Do not move deleted files to the Recycle Bin. Покопавшись в gpedit, можно найти массу параметров интерфейса и системы, однако будьте осторожны: некоторые из них могут привести к нежелательному поведению компьютера. (Это работает только в Professional Edition.)

3. Рабочую станцию ХР можно запереть двумя щелчками мыши. Кликнув на рабочем столе правой кнопкой, создайте новый ярлык и введите в поле location строку rundll32.exe user32.dll,LockWorkStation. Присвойте этому ярлыку какое-нибудь имя. Теперь двойным щелчком по нему вы сможете блокировать свой компьютер. Того же эффекта можно добиться сочетанием клавиш Windows + L.

4. XP скрывает отдельные элементы системного ПО, которые кто-то, возможно, захочет удалить. Это может быть, например, Windows Messenger. Пользуясь редактором Notepad или Edit, исправьте текстовый файл /windows/inf/sysoc.inf, найдя и удалив в нем слово hide. Затем войдите в меню Add or Remove Programs на панели управления, выберите Add/Remove Windows Components - и вам откроется все, что было сокрыто.

5. Тем, кто владеет искусством работы с пакетными файлами DOS, ХР предлагает ряд интересных новых команд. В их числе eventcreate и eventtriggers для создания системных событий и слежения за ними, typeperf для контроля за производительностью различных подсистем и schtasks для управления запланированными задачами. Как обычно, /? после имени команды выдает список опций - их слишком много, чтобы перечислять здесь все.

6. В ХР есть поддержка IP версии 6 - интернет-протокола нового поколения. К сожалению, такой поддержки нет у вашего ISP, поэтому экспериментировать с ней можно лишь в пределах локальной сети. Введите ipv6 install в поле Run... (не беспокойтесь, текущие сетевые настройки от этого не пострадают), а затем наберите ipv6 /? в командной строке, чтобы получить дополнительную информацию. Если вы не знаете, что такое IPv6, не переживайте и не утруждайте себя.

7. Наконец-то появилась возможность снимать задачи из командной строки. Наберите taskkill /pid и номер задачи или просто tskill и номер процесса. Номер можно узнать, набрав команду tasklist, которая вдобавок сообщит многое о том, что происходит в вашей системе.

8. XP считает файлы Zip папками - это удобно, если у вас быстрая машина. На более медленных системах можно заставить ХР отказаться от такой практики, набрав в командной строке regsvr32 /u zipfldr.dll. Позднее, если вы передумаете, можно все вернуть назад командой regsvr32 zipfldr.dll.

9. В ХР встроена технология сглаживания шрифтов на экране ClearType, но по умолчанию она выключена. Ее стоит попробовать, особенно если вы начинали с DOS и пялились на экран все эти годы, заработав астигматизм. Чтобы включить ClearType, кликните правой кнопкой мыши на десктопе, выберите Properties, Appearance, Effects, затем найдите во втором падающем меню ClearType и разрешите эту опцию. Лучшие результаты получаются на лаптопах. Если вы хотите использовать ClearType и на экране приветствия Welcome, присвойте параметру HKEY_USERS/.DEFAULT/Control Panel/Desktop/FontSmoothingType в реестре значение 2.

10. Вы можете помочь приятелю, который работает в домашней сети и пользуется трансляцией сетевых адресов (NAT), применив механизм удаленного доступа - но не сразу. Сначала попросите друга прислать вам e-mail с приглашением Remote Assistance, предварительно отредактировав файл. В атрибуте RCTICKET указан IP-адрес NAT, например 192.168.1.10. Его надо заменить действительным IP-адресом вашего приятеля - он может определить его, посетив сайт www.whatismyip.com, - и пусть он убедится, что в его брандмауэре порт 3389 открыт и переадресован на проблемный компьютер.

11. Вы можете исполнять программы от имени другого пользователя - без выхода из системы и повторной регистрации. Кликните на значке правой кнопкой, выберите Run As... и введите имя пользователя и пароль. Они будут действовать до окончания текущего сеанса работы. Это особенно полезно, когда нужно получить права администратора для установки программы, что случается очень часто. Имейте в виду, что многократно исполнять программы под разными именами - занятие увлекательное, но оно может привести к непредсказуемым эффектам.

12. Windows XP проявляет настойчивость в отношении автоматической проверки апдейтов, регистрации в системе Passport, использования Windows Messenger и т.п. Со временем вы привыкните, но, если чувствуете, что не доживете до этого момента в здравом уме, запустите Regedit, войдите в HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer/Advanced и создайте параметр DWORD с именем EnableBalloonTips и значением 0.

13. Можно начинать работать, не набирая имени пользователя и пароля. Выберите Run... из стартового меню и наберите control userpasswords2, что приведет к открытию приложения, управляющего учетными записями пользователей. На вкладке Users удалите флажок у позиции Users Must Enter A User Name And Password To Use This Computer и кликните ОК. Появится диалоговое окно Automatically Log On; введите имя пользователя и пароль для нужной учетной записи.

14. Internet Explorer 6 можно настроить на автоматическое удаление временных файлов. Запустите браузер, выберите Tools / Internet Options... и Advanced, спуститесь до раздела Security и отметьте позицию Empty Temporary Internet Files Folder When Browser is Closed.

15. К ХР прилагается бесплатный индикатор работы сети - на тот случай, если вам не видно светодиодов на сетевой плате. Кликните правой кнопкой на My Network Places на рабочем столе и выберите Properties. Кликните правой кнопкой на ярлыке своей локальной сети или dial-up соединения, выберите Properties и активизируйте значок Show в зоне оповещения о работе в сети. Теперь при наличии сетевого трафика в правой части панели задач вам будет весело подмигивать маленький значок сети.

16. Меню Start, когда оно решит появиться, может показаться медлительным, но этот процесс можно ускорить, уменьшив значение параметра реестра HKEY_CURRENT_USER/Control Panel/Desktop/MenuShowDelay, которое по умолчанию равно 400. Сделайте его, например, нулевым.

17. В Windows Explorer файлы можно переименовывать скопом. Выделите в окне группу файлов, кликните правой кнопкой по одному из них и, если нужно, переименуйте его. Все выделенные файлы получат имя указанного файла с индивидуальными номерами в скобках. Кроме того, значки в папке можно организовать в упорядоченные по алфавиту группы - для этого выберите View, Arrange Icon By... Show In Groups.

18. Windows Media Player в процессе воспроизведения треков отображает обложки альбомов - если находит их изображение в интернете во время копирования трека с CD. В противном случае, а также если у вас большая библиотека музыкальных файлов WMP, вы можете поместить свою собственную копию изображения обложки в тот же каталог, где хранятся записи. Просто назовите ее имя_каталога.jpg, и Windows Media Player найдет и выведет эту картинку.

19. Сочетание клавиш Windows + Break открывает системный аплет Control Panel; сочетание клавиш Windows + D открывает рабочий стол; сочетание клавиш Windows + Tab переключает кнопки панели задач.

20. Следующая версия Windows XP с кодовым названием Longhorn должна выйти в конце следующего или в начале 2003 года, но в ней будет мало изменений. Принципиально новая версия с кодовым названием Blackcomb появится в 2003/2004 году.

Прислал Alex Golubovsky
Автор: Reviews.ru


Интеграция SP1 в дистрибутив Windows XP

Microsoft вскоре начнет выпускать копии Windows XP с интегрированным Service Pack, что, со-гласитесь, очень удобно, но уже сейчас можно самому сделать загрузочный диск, с помощью ко-торого можно установить ОС с включенным SP. Рассмотрим эту процедуру на примере програм-мы Ahead Nero Burning Rom.
Для создания загрузочного диска нам понадобится: копия дистрибутива WinXP, сам SP (network installation), загрузочный файл xpboot.bin (доступен на www.winall.ru), и, собственно, сама программа Nero Burning Rom.

Создадим папку "XP" в корневой директории диска, в которой создаем ещё 3 папки под названиями: CD-ROOT, XP-BOOT, XP-SP1. Создание этих 3 каталогов в корневой категории вовсе не обязательно, но это мы делаем для дальнейшего удобства.

Скопируем дистрибутив Windows XP в папку CD-Root. Переименовываем файл SP в XP-SP1.EXE (делаем это для облегчения нашего труда) и копируем его в папку C:\XP, после чего в меню Пуск - Выполнить (Start - Run) выполняем команду: "C:\XP\XP-SP1.EXE /U /X:C:\XP\XP-SP1".

Эта команда распакует содержимое файла SP в папку C:\XP\XP-SP1. Ведь СП - это всего навсего навороченный архив. Теперь необходимо провести непосредственно интеграцию, для чего вводим в окне "выполнить" следующую команду: "C:\XP\XP-SP1\UPDATE\UPDATE.EXE /S:C:\XP\CD-ROOT". Выполнится совмещение файлов ОС и пакета обновлений.

Затем скопируем файл xpboot.bin в папку XP-BOOT. Запускаем программу Nero Burning Rom. Создаем новый проект, выбрав пункт CD-Rom (Boot). На вкладке Boot, в пункте Image File указываем путь к нашему файлу xpboot.bin, в пункте Kind Of Emulation выбираем: "No Emulation" и меняем значение "Number of loaded sectors:" на 4. На вкладке ISO оставляем все по умолчанию и переходим на вкладку Label.

Устанавливаем Volume Label, System Identifier, Volume Set и Application на "WXPVOL_EN";
А пункты Publisher и Data Preparer на "MICROSOFT_CORPORATION".

На вкладке Burn отмечаем пункты:

  • Write,
  • Finalize CD,
  • JustLink (BurnProf) и
  • Track-At-Once.

Жмем кнопку "New".

В появившемся окне проводника находим папку CD-ROOT, затем перетаскиваем все файлы в область CD write. Затем просто выполняем процесс записи диска. Более подробный способ прожига загрузочного диска с Windows XP доступен у нас здесь - все снабжено скриншотами и объяснено более подробно.

Отныне у Вас будет загрузочный диск с операционной системой Windows XP с интегрированным Service Pack


вернуться к оглавлению

AMIBIOS Setup

Предисловие...

Обратите внимание: Так как любой изготовитель системной платы изменяет AMIBIOS, чтобы учесть особенности своих плат, эта информация о Setup'е может быть, а может и не быть правильной для вашей системной платы, так же как и опции, перечисленные здесь могут или не могут быть доступными для вашей системной платы. Чтобы получить соответствующую информацию о Setup'e, пожалуйста свяжитесь с изготовителем вашей системной платы. Если на вашем компьютере установлен AMIBIOS, это вовсе не означает, что ваша системная плата произведена American Megatrends.

Все Спецификации, могут быть изменены без предшествующего уведомления.
Все названия компаний и программ - это товарные знаки соответствующих компаний изготовителей.

Ограничения Гарантии:

Компания American Megatrends, inc (AMI) не несет никакой ответственности за ошибки или опечатки в этих материалах. ЭТИ МАТЕРИАЛЫ ПРЕДСТАВЛЕНЫ " КАК ЕСТЬ" БЕЗ ГАРАНТИИ ЛЮБОГО ВИДА, ЯВНОЙ ИЛИ НЕЯВНОЙ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯ, ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ ВЫСОКОГО СПРОСА, ПРИГОДНОСТЬ ДЛЯ СПЕЦИФИЧЕСКОЙ ЦЕЛИ, ИЛИ не-нарушения. Далее AMI не гарантирует точность или законченность информации, текста, графики, связей или других элементов, содержащихся в этих материалах. AMI не должна нести ответственность за любые специальные, косвенные, случайные, или последующие повреждения, включая без ограничения, потерянные доходы или потерянную прибыль, которая может следовать из использования этих материалов. AMI может делать изменения в этих материалах, или в программах, описанным там, в любое время без примечания. AMI не делает никакое блокирование, чтобы модифицировать информацию, содержащуюся здесь.

Главное меню

Главное меню WINBIOS Setup организовано в четыре окна. Каждое окно соответствует разделу в этой главе. Каждый раздел содержит несколько иконок. Щелчок на каждую иконку активизирует специфическую функцию. Иконки WINBIOS Setup и функции описаны в этой главе.

Разделы:

Windows

                Функция

Setup | Этот раздел содержит пять иконок, которые разрешают Вам устанавливать параметры конфигурации системы типа даты, времени, типа жесткого и гибкого диска, и многих другие.
Utilities | Содержит четыре иконки, которые выполняют функции системы.
Security | Содержит две иконки, которые управляют AMIBIOS свойствами защиты.
Default | Этот раздел содержит три иконки, которые разрешают Вам выбирать группу устаноаок для всех опций WINBIOS Setup'a.

Установки по умолчанию

Каждая опция WINBIOS Setup имеет две установки по умолчанию. Эти параметры настройки могут применяться ко всем установкам WINBIOS Setup, когда Вы выбираете Заданный по умолчанию раздел в главном меню WINBIOS Setup.

Типы значений по умолчанию:

Значения по умолчанию | Описание
OptimalOptimal настройка по умолчанию | Эти параметры настройки обеспечивают самые лучшие характеристики эффективности.
Fail-SafeFail-Safe настройка по умолчанию | Эти параметры настройки, более вероятно, конфигурируют работающий компьютер, когда что-то неисправно. Если Вы не можете успешно загрузить компьютер, выберите Отказоустойчивые параметры WINBIOS Setup'a, и пробуйте диагностировать проблему после начальной загрузки компьютера. Эти параметры настройки не обеспечивают оптимальную эффективность.

Типы Setup'а

WINBIOS Setup может иметь до шести отдельных экранов. Различные типы параметров конфигурации системы установливаются на каждом экране.

Тип | Описание
Standart Setup | Установка времи и даты. Выбор конфигурации дисководов.
Advanced Setup | Конфигурирация базисных параметров эффективности системы.
Chipset Setup | Конфигурация свойств, специфических для микросхем, используемых в компьютере.
Power Management Setup | Конфигурируйте свойства сохранения мощности.
PCI/PnP Setup | Конфигурируйте свойства Plug-and-Play и PCI.
Peripheral Setup | Конфигурация поддержки Ввода - вывода.

Standard Setup

Опции Standard Setup отображаются при выбире Standard иконки из меню WINBIOS Setup. Все Стандартные опции Setup'а описаны ниже.

Date/Time Выбор опции Дата/Время , позволяет изменить дату или время. На дислее отображаются текущая дата и время. Введите новые значения через представленное окно.

Floppy Drive A, B Выбор иконки дисковода для гибких дисков - дискет А или B,дает возможность определить тип этого дисковода. Параметры настройки - 360 KB 5ј", 1.2 MB 5ј", 720 KB 3Ѕ", 1.44 MB 3Ѕ", или 2.88 MB 3Ѕ".

Pri Master

Pri Slave

Sec Master

Sec Slave Выбор этих иконок, позволяет конфигурировать жесткий диск - винчестер, определенный в опции. Если щелкнуть по иконке,то далее будут перечислены следующие параметры: Type, LBA/Large Mode, Block Mode, 32Bit Mode, and PIO Mode. Все параметры касаются винчестеров с IDE интерфейсом за исключением параметра Type.

Configuring an MFM Drive При конфигурировании старого MFM винчестера, вы должны знать параметры этого диска (число головок, число цилиндров, число секторов, стартового цилиндра предварительной компенсации записи, и пропускной способности диска). Выберите Type, и выберите соответствующий тип винчестера. Старые типы MFM винчестера в этом документе не рассматриваются.

User-Defined Drive Если вы конфигурируете винчестер с интерфейсами SCSI или MFM, RLL, ARLL, или диск ESDI с параметрами, которые не соответствуют стандартным типам винчестеров, то можно выбирать User в поле Type. Затем ввести параметры диска на экране, который появится. Параметры диска включают:

  • Cylinder (число цилиндров),
  • Hd (число головок),
  • WP (начинающийся цилиндр предварительной компенсации),
  • Sec (число секторов),
  • Size (Объем диска),
    Параметр | Описание
    Type | Номер диска с некоторыми параметрами идентификации.
    CylindersNumber of Cylinders | Число цилиндров на диске
    HeadsNumber of Heads | Число головок
    Write PrecompensationWrite Precompensation | Размер сектора становит прогрессивно меньшим, поскольку диаметр дорожки уменьшается. Все же каждый сектор должен все еще содержать 512 байт.Схема предварительной компенсационной записи на жестком диске компенсирует физическое различие в размере сектора, увеличивая запись, текущую для секторов на внутренних дорожках. Этот Параметр - номер дорожки, где предварительная компенсационная запись начинается.
    Landing ZoneLanding Zone | Это номер цилиндра, где обычно паркуются головки при выключенной системе.
    SectorsNumber of Sectors | Число секторов на дорожку. MFM диски имеют 17 секторов на дорожку. RLL диски имеют 26 секторов на дорожку. ESDI диски имеют 34 сектора на дорожку. SCSI и диски IDE имеют большее количество секторов на дорожку.
    CapacityHard Disk Drive Capacity | Полезная емкость диска - (Число головока) x (Число цилиндров) x (Число секторов на дорожку) x (512 байт на сектор)

    Конфигурирование IDE винчестеров Если винчестер конфигурирован как диск с интерфейсом IDE, необходимо выбрать соответствующую иконку диска (Pri Master, Pri Slave, Sec Master, or Sec Slave). Можно выбрать иконку IDE Detect, для автоматического определения всех параметров диска.

    AMIBIOS автоматически определяет параметры диска IDE (включая ATAPI CD-ROM диски) и выводит их на дисплей. Нажмите на кнопку OK, чтобы принять эти параметры, или вы можете устанавливать параметры вручную, если абсолютно уверенны, что знаете правильные параметры диска IDE.

    Щелкните по LBA/Large Mode, и выберите ON поддержки дисков IDE с емкостями более чем 528 МБ.

    Щелкните по Block Mode, и выберите ON для поддержки дисков IDE использующих Блочный режим. В данном режиме в буфер с диска читается блок состоящий из нескольких секторов, во-первых - те которые запросил CPU, а во-вторых несколько следующих после, в результате при новом обращении, если чтение идет последовательно, новые сектора уже будут взяты из буфера, что естественно позволяет уменьшить время обращния к диску.

    Щелкните по 32Bit Mode, и выберете ON для поддержки дисков IDE, которые используют 32-разрядный доступ.

    Щелкните по PIO Mode, чтобы выбрать IDE Программируемый режим Ввода - вывода. Программирование ПРОГРАММИРУЕМОГО КОНТРОЛЛЕРА также работает с ATAPI CD-ROM дисками. Параметры настройки Auto, 0, 1, 2, 3, 4, или 5. Выберите Auto, чтобы позволить AMIBIOS автоматически найти режим ПРОГРАММИРУЕМОГО КОНТРОЛЛЕРА совместимый с конфигурацией дисков IDE конфигурируемых пользователем. Если Вы выбираете 0-5, Вы должны делать абсолютно уверенным, что Вы выбираете режим ПРОГРАММИРУЕМОГО КОНТРОЛЛЕРА, совместимый с конфигурацией диска IDE.

    Configuring a CD-ROM Drive Соответственно иконке диска (Pri Master, Pri Slave, Sec Master, or Sec Slave). Выберите параметр Type, и выберите CDROM. Вы можете загружать компьютер с CD-ROM диска. Вы можете также выбирать Auto и позволить AMIBIOS, автоматически установить корректные параметры диска.

    Quick Boot Установка этой опции в Enable, заставляет AMIBIOS выполнить быструю загрузку , при включении питания компьютера. Эта опция заменяет старую Above 1 MB Memory Test Advanced Setup. Параметры настройки:

    Параметр

                Описание

    Disabled Тестирование AMIBIOS'ом всей памяти системы. AMIBIOS ждет до 40 секунд сигнала READY от IDE винчестера. AMIBIOS ждет .5 секунды после посылки сигнала RESET на IDE винчестер, чтобы дать время IDE винчестеру снова подготовится. AMIBIOS проверяет клавишу Del на нажатие, и заходил в бы WINBIOS Setup, если клавиша была нажата.
    Enabled AMIBIOS не тестирует память системы выше чем 1 MB.

    AMIBIOS не ждет до 40 секунд сигнала READY от IDE винчестера. Если сигнал READY не поступил немедленно от IDE винчестера, AMIBIOS не конфигурирует этот диск. AMIBIOS не ждет .5 секунд после посылки сигнала RESET на IDE винчестер, чтобы позволить IDE винчестеру время снова подготавиться.

    Вы не можете зайти в WINBIOS Setup при начальной загрузке системы, потому что нет никакой задержки при сообщении Hit <Del> to run Setup.

    Оптимальная и Отказоустойчивая установка по умолчанию Enabled.

    Boot Up Sequence Эта опция устанавливает последовательность дисков начальной загрузки (дисковод для гибких дискет A:, диск C: жесткого диска, или диск CD-ROM) c которого AMIBIOS попытается загрузиться, после того, как закончится этап начальной загрузгии AMIBIOS. Параметры настройки - C:,A:,CDROM, CDROM,A:,C:, или A:,C:, CDROM.. Установки по умолчанию - C:, A:, CDROM.

    Boot Up CPU Speed Эта опция, позволяет определить быстродействие процессора при начальной загрузке системы. Параметры настройки Low или High. Оптимальная и Отказоустойчивая установка по умолчанию High.

    Boot Up Num Lock При установки этой опции в Off , при загрузке компьютера отключается режим Num Lock клавиатуры, можно использовать клавиши курсора как обычные так и на цифровой клавиатуре. Параметры настройки могут быть On или Off. Установки по умолчанию On.

    Turbo Switch Устанавка этой опции в Enabled, разрешает AMIBIOS управлять аппаратным Турбо переключателем. Параметры настройки Enabled или Disabled. Оптимальная и Отказоустойчивая установка по умолчанию Disabled.

    Floppy Drive Swap Устанавка этой опции в Enabled, меняет местами диски A: и B:. Параметры настройки Enabled или Disabled. Установки по умолчанию Disabled.

    Floppy Drive Seek Устанавка этой опцию в Enabled, специфична для дисковода A:, выполнять операцию Seek (позиционирования головок) при начальной загрузке системы. Параметры настройки Enabled или Disabled. Оптимальная и Отказоустойчивая установка по умолчанию Disabled.

    Mouse Support При установке этой опции в Enabled, AMIBIOS, поддерживает мышь типа PS/2. Параметры настройки Enabled или Disabled. Установка по умолчанию Disabled.

    Typematic Rate Определяет быстродействие, с которым будет производится повтор нажатия клавиши клавиатуры. Параметры настройки Fast или Slow. Оптимальные и Отказоустойчивая установка по умолчанию Fast.

    System Keyboard Определяет, что клавиатура присутствует на компьютере. Параметры настройки Present или Absent. Оптимальная и Отказоустойчивая установка по умолчанию Present.

    Primary Display Определяет тип дисплея и адаптера в компьютере. Параметры настройки Mono, CGA40, CGA80, EGA/VGA, or Absent.

    Password Check Опция допускает постоянную проверку пароля при начальной загрузке компьютера или выполнению WINBIOS Setup. При выборе Always, приглашение к вводу пароля будет появлятся при включении компьютера. При выборе Setup, приглашение к вводу пароля будет появляться при заходе в WINBIOS Setup. Оптимальная и Отказоустойчивая установка по умолчанию - Setup.

    Parity Check Устанавка этой опции в Enabled, позволяет проверить на четность всю память системы. Параметры настройки Enabled или Disabled. Оптимальная и Отказоустойчивая установка по умолчанию Disabled.

    OS/2 Compatible Mode Установка этой опции в Enabled, разрешает AMIBIOS работать с IBM OS/2. Параметры настройки Enabled или Disabled. Установка по умолчанию Disabled.

    Wait For F1 if Error AMIBIOS ПРЕДСТАВЛЯЕТ сообщения об ошибках следом за сообщениемby: Press <F1> to continue.

    Если эта опция установлена в Disabled, AMIBIOS не пока вы нажмете на клавишу F1 после сообщения об ошибках. Параметры настройки Enabled или Disabled.Оптимальные и Отказоустойчивые установки по умолчанию Enabled.

    Hit Del Message Display Установка этой опции в Disabled, предотвращает появление сообщения: Hit <DEL> if you want to run Setup на первом экране AMIBIOS, при загрузке компьютера. Параметры настройки Enabled или Disabled. Оптимальная и Отказоустойчивая установка по умолчанию Enabled.

    CPU Selection Позволяет выбирать тип ЦЕНТРАЛЬНОГО ПРОЦЕССОРА, установленного на компьютер. Параметры настройки Auto (AMIBIOS, автоматически определяет тип ЦЕНТРАЛЬНОГО ПРОЦЕССОРА) или Intel. Оптимальная и Отказоустойчивая установка по умолчанию Auto.

    Internal Cache Определяет алгоритм кэширования, используемый для L1 внутренней кэш-памяти. Параметры настройки:

    Установка | Описание
    Disabled | Никакая L1, внутренняя кэш-память ЦП, или L2, кэш-память второго уровня, не допускается.
    WriteBack

    (default)

             Использутся алгоритм кэширования типа Обратная Запись.
    WriteThru | Используется алгоритм кэширования типа Сквозная Запись.

    External Cache Определяет алгоритм кэширования, используемый для L2, вторичной (внешней) кэш-памяти. Параметры настройки: см. предыдущую таблицу.

    System BIOS Shadow Cacheable Когда эта опция установлена в Enabled, содержание сегмента памяти системы F0000h, может обслуживаться L2 вторичной кэш-памятью. Содержание F0000h сегмента памяти всегда скопируется из BIOS ROM в ОП системы для более быстрого выполнения. Параметры настройки Enabled или Disabled. Оптимальная настройка по умолчанию Enabled. Отказоустойчивая настройка по умолчанию Disabled.

    C000,16K Shadow

    C400,16K Shadow

    C800,16K Shadow

    CC00,16K Shadow

    D000,16K Shadow

    D400,16K Shadow

    D800,16K Shadow

    C000,16K Shadow

    Эти параметры управляют расположением содержания 16КБ ROM, начинающегося в определенном месте памяти. Если адаптер ROM использует приведенные выше области ROM, то эти области памяти не доступны локальной шине. Параметры настройки:

    Установка | Описание
    Shadow | Содержание C0000h - C3FFFh будет записано в тот же самый адрес в памяти системы для более быстрого выполнения.
    Cache | Содержание приведенные выше области ROM будет записано в тот же самый адрес в памяти системы для более быстрого выполнения, если адаптер ROM будет использовать именованную область ROM. Также, содержание области ОП может обслуживаться кэш-памятью.
    Disabled | Видео ROM не скопирован в ОП. Содержание видео ROM не может обслуживаться кэш-памятью.

    Настройка по умолчанию - Cache.

    В AMIBIOS для Intel Triton chipset, E000h страница используется, как ROM в течении POST, но затенение заблокировано и ROM CS# сигнал заблокирован, чтобы сделать страницу E000h доступной локальной шине.

    P6 Microcode Update Устанавливка этой опции в Enabled, позволяет обновить микропрограмму Pentium Pro. Параметры настройки Disabled или Enabled. Оптимальные и Отказоустойчивые установки по умолчанию Disabled.

    Chipset Setup

    Memory Hole Эта опция определяет область в памяти, которая не может быть адресована на ISA шину. Параметры настройки Disabled, 512-640K, or 15-16MB. Настройка по умолчанию Disabled.

    DRAM Speed Определяет быстродействие доступа RAS к SIMM, установленного в системную плату как память системы. Параметры настройки - 60ns или 70 ns. Значение по умолчанию - 70ns.

                  Предостережение

    Если Вы установили SIMM с различными скоростями на системную плату, выберите быстродействие самых медленных SIMM.

    Вы должны всегда использовать SIMM, которые имеют то же самое быстродействие внутри банка памяти.

    IRQ12/M Mouse Function При установке в Enabled, определяет, что IRQ12 будет использоваться для мыши. Параметры настройки Disabled или Enabled. Оптимальная и Отказоустойчивая установка по умолчанию Enabled.

    8-Bit I/O Recovery Time (SYSCLK) Эта опция определяет длину задержки (в SYSCLK) вставляемой между последовательными 8-разрядными операциями I/O. Параметры настройки 1, 2, 3, 4, 5, 6, 7, или 8. Оптимальная и Отказоустойчивая установка по умолчанию - 2.

    16-Bit I/O Recovery Time (SYSCLK) Эта опция определяет длину задержки (в SYSCLK) вставляемой между последовательными 16-разрядными операциями I/O. Параметры настройки 1, 2, 3, 4, 5, 6, 7, или 8. Оптимальная и Отказоустойчивая установка по умолчанию - 2.

    # # # Copyright © 1996 American Megatrends, Inc.

    Copyright © 1997 Miguel Bo (перевод был осуществлен с испольсованием системы Stylus v3.0)

    вернуться к оглавлению


Анонимный серфинг... :

Steganos Internet Anonym 6.0.4 - программа для анонимного серфинга в сети и уничтожения следов серфинга на компьютере. Почему я выбрал эту софтину? Ответ прост - простота в использовании и практическое отсутствие настроек. Работать с софтом может Юзер с любой степенью подготовки. Вместе с тем, это продукт высочайшего качества. Наличие русификатора и в нем дополнительной информации выводит софт в разряд "необходимо иметь". И еще: прога может безвозвратно удалить любые файлы и папки.
Для начала качаем : Steganos Internet Anonym 6.0.4 - пакет 10 метров. А вот и скрин (часть красочно оформленного окна программы):

Все понятно и красиво.
Первая вкладка - "Комфорт и Безопасность". Здесь можно блокировать : идентификацию браузера, ActiveX - обьекты, cookies, с какого сайта ты пришел, выполнение различных скриптов. В сноске " Детали" все это подробно расписано

Интересная вкладка - "Частное Избранное". Здесь можно запоролить те места куда ты любишь ходить. На вкладке "Уничтожить следы" нужно просто поставить "птицы" в тех местах, которые необходимо удалить после серфинга. Вкладка "Затиратель" - как удалить файлы и папки на твоем компе.
Ну и к настройкам. Вкладка "Установки" :

Если хочешь работать с анонимными прокси поставь "птицу" и из списка выбери нужный адресс. Для использования в процессе серфинга смены анонимного адреса включи рулетку и подвинь ползунок (регулировка скорости смены камуфляжных адресов). Вот и все!
И последняя вкладка. Кликнув по "Проверить анонимность" ты увидишь на странице сайта разработчика как меняется твой ИП - адресс. Подробный хелп на русском мы делали для предыдущей версии и ты его можешь найти в разделе нашего сайта Русификаторы. Удачи!


Что скрывается в автозагрузке?

Ну, что, очередной раз решили включить компьютер и полазить в Интернет? Ну и как компьютер грузится? Медленно? И при этом жужжит винчестером как майский жук? Ничего удивительного. А что у вас грузится каждый раз при старте системы? Как не знаю?! Тогда пора просвещаться, а заодно проверим, нет ли где хитрых троянов, нагло ворующих пароли от Интернет.

Сперва выясним, как Windows узнает о программах, которые надо запустить во время старта системы. Всего есть три места, где хранятся эти сведения: папка Автозагрузка из меню "Пуск", файл win.ini и реестр. Ну, с Автозагрузкой все понятно - это наиболее простое и доступное место для запуска программ, а вот на win.ini и реестре стоит остановиться поподробнее.

Начнем, пожалуй, с файла. Хоть Microsoft и усиленно призывает разработчиков хранить все настройки в реестре, отказываясь от INI-файлов, уверяет пользователей в том, что эти файлы оставлены только для совместимости со старыми программами, тем не менее, сами продолжают ими пользоваться. Сам файл находится в каталоге, где установлена операционная система. Откройте его любым текстовым редактором. В самом начале файла вы увидите раздел [windows]. В этом разделе есть два параметра, отвечающие за автоматическую загрузку программ - load и run. Обычно они пустые, но если там есть какая-то запись, обязательно проверьте, что за программу она запускает, и не затесалось ли туда что-то вроде kernel16.exe :).

С win.ini все просто - там есть только одно интересующее нас в данный момент место. С реестром дело обстоит несколько сложнее. Там уже гораздо больше пространства, куда может спрятаться незваный гость. Итак, открываем реестр и начинаем поиски.

Сперва откройте раздел HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion. Найдите там подразделы Run, RunOnce, RunOnceEx, RunServices, RunServicesOnce. В этих разделах есть строковые ключи (некоторые разделы пустые), отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве значения у них указывается запускаемая программа, если надо - то с параметрами. Обратите внимание на разделы, в названии которых присутствует "Once". Это разделы, в которых прописываются программы, запуск которых надо произвести всего один раз. Например, при установке новых программ некоторые из них прописывают туда ключи, указывающие на какие-нибудь настроечные модули, которые запускаются сразу после перезагрузки компьютера. Такие ключи после своего запуска автоматически удаляются.

Внимательно проверьте, что за программы у вас запускаются. Сразу после установки Windows в разделе Run присутствуют ключи с названиями internat.exe, LoadPowerProfile, ScanRegistry, SystemTray, TaskMonitor. В разделе RunServices - ключ LoadPowerProfile. Другие разделы пустые. Остальные ключи, которые могут присутствовать у вас в реестре, были добавлены другими установленными программами. Подумайте, все ли они нужны вам при загрузке и лишнее просто удалите. Это позволит значительно ускорить загрузку Windows.

Но это не единственный раздел, откуда запускаются программы. Перейдем к другой ветви, а именно к HKEY_CURRENT_USER и откроем там раздел SOFTWARE\Microsoft\Windows\CurrentVersion. Там есть только два подраздела, отвечающие за автозагрузку: Run и Runonce. Изначально они пустые, так что все записи там сделаны другими программами.

Следует помнить, что из реестра программы запускаются в первую очередь, затем из файла win.ini и самыми последними из "Автозагрузки". Так что если у вас стоит в автозагрузке антивирусный монитор, то это еще не факт, что он отловит запуск троянца, т.к. вирусы имеют гораздо меньший по размеру файл и грузятся не в пример быстрее.

Вот, пожалуй, и все об автоматически запускаемых в Windows программах. Если вы хотите ускорить загрузку вашего компьютера, то удалите все лишнее из перечисленных разделов. А когда вы устанавливаете какую-то подозрительную программу или запускаете неизвестный файл, проверьте, не добавилось ли там чего лишнего: уж больно много в последнее время развелось троянов и слишком широкие массы пользователей получили к ним доступ. Так что лишняя осторожность никогда не повредит.


Безотказный компьютер

Автор: Дмитрий Турецкий

Думаю, что найти в Сети пользователя, у которого ни разу не "падал" компьютер, невозможно. Компьютерные форумы забиты сообщениями "помогите", "начал глючить", "пришлось переустанавливать" и всевозможными их модификациями. А ведь избежать всех этих (и, кстати, многих других!) проблем не так уж и сложно - достаточно потратить всего пару часов...
Для начала, определимся с тем, что может испортить нам жизнь. С одной стороны, это "железные" сбои, с другой - софтовые, с третьей - всевозможные непредвиденные вещи типа (тьфу-тьфу-тьфу) пожара. При этом мы держим в памяти, что создаем не сверхсекретный сервер для управления ракетными войсками, а обычную домашнюю машину...
Защита железа.
Компьютерное железо - вещь удивительно вредная. Компьютер может работать (и работает) годами, исподволь расслабляя пользователя, а потом, с легким "паф-ф-ф" вдруг отказывается запускаться... И парикмахеры лишаются работы, т.к. клиенты ходят с уже вырванными волосами...
Основной причиной выхода компьютерного железа из строя являются банальные скачки и пропадания напряжения в розетке. Поэтому одним из необходимых предметов я бы назвал UPS (также известный как ИБП - Источник Бесперебойного Питания). Прошли, к счастью, те времена, когда этот прибор был дорогой экзотикой - сейчас достаточно приличную для дома модель вполне можно приобрести за приемлемую сумму (порядка 1500 руб). Разумеется, желание сэкономить на, вроде бы, не являющимся необходимом устройстве присутствует у всех пользователей, но задумайтесь о том, что практически любая "железная" поломка обойдется вам дороже...
По адресу www.rissa.ru/production/ups/ups.html вы найдете неплохую заметку, которая расскажет о типах ИБП и поможет выбрать подходящий. От себя добавлю, что надо брать UPS, имеющий интерфейс для связи с компьютером: домашние UPS'ы обладают не очень большой емкостью и могут поддерживать работу компьютера всего несколько минут. А если электричество в розетке совсем кончится, то перед тем как разрядится батарея, они смогут отдать компьютеру команду на "грамотное" завершение работы, что очень полезно для тех, кто любит оставлять компьютер все время включенным.
Следующей причиной сбоев я бы назвал перегрев компьютера. В абсолютном большинстве случаев он вызывается поломкой одного из вентиляторов. К окончательному выходу из строя компьютера это приводит редко, но может вызвать непредсказуемые перезагрузки и зависания, что тоже неприятно. Поэтому, если ваш компьютер начал как-то странно жужжать или гудеть, то не поленитесь смазать "карлсона". Или почистить от пыли... Или заменить...
Кстати, насчет пыли. Ее в компьютер набивается огромное количество. Не поленитесь раз в полгода - год снять крышку корпуса и, как минимум, пропылесосить... А еще лучше - полностью повытаскивать все платы, разобрать блок питания и все это почистить...
Кроме того, стоит воспользоваться какой-нибудь утилитой-монитором системной платы типа MProbe или Motherboard Monitor - эти утилиты (помимо прочего) показывают информацию о температуре платы и скорости вращения вентиляторов и могут вам просигнализировать, если что-то выходит за пределы допустимого.
Защита данных и программ
Когда компьютер по каким-либо причинам выходит из строя, то одна из наиболее неприятных вещей для пользователя - это потеря информации. До сих пор не понимаю, почему столь многие этим пренебрегают - видимо, пресловутая надежда на "авось". Но ведь совсем не сложно потратить пол- часа на установку и настройку какой-либо утилиты резервного копирования - эти полчаса ого-го-го как окупятся, когда произойдет что-то неприятное...
Одним из наиболее оптимальных способов организации резервирования данных является регулярное копирование рабочих файлов (возможно, с попутным архивированием). Частоту такого копирования надо выбирать в зависимости от того, как часто данные изменяются, но, как правило, раз в сутки вполне достаточно. Многие утилиты позволяют хранить не только последнюю резервную копию ваших документов, но и несколько предыдущих - иногда это тоже оказывается полезным. Идеальным вариантом является установка двух винчестеров в компьютер и копирование данных с одного диска на другой - таким образом вы сможете защитить свои документы не только от случайного удаления, но и от поломки винчестера. И дополнительно, скажем, раз в неделю стоит сохранять backup на внешних носителях - например, записать на CD-R.
Такой метод практически не тратит ваше время - копирование с диска на диск происходит достаточно быстро, вдобавок его можно полностью автоматизировать и запускать по расписанию. Запись на CD-R тоже, конечно, можно автоматизировать, но редко у кого наберется полный диск данных, так что можно вместе с backup'ом записать и еще что-нибудь. Многие используют для backup'ов CD-RW и пишут прямо на него, не создавая копий на диске, но мне это метод не очень нравится: во- первых, вероятность какого-либо сбоя при автоматической записи на CD-RW несколько выше, чем при записи на винчестер, а во-вторых, очень часто пользователи вытаскивают "резервный" CD-RW диск, чтобы записать что-то еще, а потом забывают поставить его обратно... Впрочем, решать вам.
Кстати, второй винчестер позволит еще и несколько ускорить работу компьютера - если операционную систему разместить на одном диске (физическом), а ее файл подкачки (swap) - на другом, то скорость работы увеличивается. По крайней мере у меня это ускорение достаточно заметно, хотя если покопаться в Сети, то можно найти и множество мнений, что, мол, все это ерунда...
Помимо данных, на компьютере живут также программы, которые эти данные создают: игрушки, операционная система и т.д. и т.п. Оставлять их без защиты тоже не годится, тем более, что переустановка системы и всего используемого вами ПО занимает кучу времени. Поэтому тут очень удобно использовать специальные утилиты, которые создают "образ" целого диска или его раздела, и при необходимости могут его восстановить. Очень удобными являются Norton Ghost, Paragon Drive Backup и т.д.
Таким образом, действия по настройке компьютера заключаются в следующем:
разбиваем диск на два (или больше) логических - скажем, C и D.
устанавливаем и настраиваем операционную систему.

· устанавливаем и настраиваем все нужные программы (на этом этапе я обычно пропускаю игрушки и прочие не требующиеся для работы вещи).

· настраиваем программы таким образом, чтобы ваши документы сохранялись на диске D.

· настраиваем утилиту резервного копирования на регулярное копирование данных с диска D на второй физический диск (например, E).

· создаем образ раздела C и сохраняем его на втором физическом диске, а заодно копируем на компакт(ы).
Теперь, если вдруг вы случайно удалили нужный документ, вы можете его сразу восстановить из резервной копии на втором диске (занимает пару минут): если повредился диск (например, из-за вирусов или просто система "устала" от ваших экспериментов с новыми программами), то вы восстанавливаете его из образа, сохраненного на втором диске или на CD-R (занимает минут 15) и сразу получаете настроенную и готовую к работе систему.
Единственное, что надо помнить - это создавать новые образы диска при "мажорных" обновлениях ОС (например, новые драйвера устройств, новое "железо") и при обнаружении программ, которые вы бы хотели включить в свою "систему по умолчанию".
Дополнительное преимущество: вы можете сделать образы нескольких операционных систем и, скажем, безопасно проверять подходит ли вам Линукс, или стоит ли переходить на XP с любимой 98-й...
Форс-мажорные обстоятельства
Бывают, к сожалению, в нашей жизни всякие неприятности... И если уж случится, скажем, пожар, то все ухищрения, описанные выше, вам, увы, не помогут. Поэтому единственное, что тут можно придумать - это держать копию CD с вашими данными где-то в другом месте, скажем, на работе.
Заключение
Описанные выше методики потребуют совсем немного вашего времени на первоначальную настройку (порядка двух часов), зато помогут сэкономить кучу времени и нервов на переустановках, поисках убитых документов и т.п. Кроме того, вы сможете без опаски тестировать новые программы, игры и операционные системы, пускать к компьютеру домашних и знакомых... На мой взгляд, оно того стоит!

Источник: http://www.softkey.info/


Редактируем BIOS (Award Modular v

Редактируем BIOS (Award Modular v.4.51)

Многие относятся к BIOS (имеется в виду именно программа) как к чему-то незыбленно-потаённому, известному только узкому кругу разработчиков и совершенно не подлежащему самостоятельной правке. Однако реально не всё так страшно, я бы даже сказал – всё достаточно просто, надо только чётко понимать и осознавать, что ты делаешь. И тогда вы сможете получить моральное удовольствие от собственной картинки в BIOS да повеселиться, увидев при загрузке «Pentium 12 - 33.33GHz». или, если серьёзно, добавить дополнительные возможности вашей плате – будь то поддержка «больших винтов» или каких-то новых, незнакомых вашей старенькой маме, других устройств (если, конечно, вы – программист).

Попробуем разобраться. Чтоб не опростоволоситься, нужно чётко знать две вещи: как устроен биос, что делать и чем.

Для начала – «чем» – инструментарий:

· CBROM (например, v.2.15 - http://yusoft.kulichki.com/russian/doc/biosedit/award/cbrom_2_15.rar) - программа для просмотра/распаковки различных модулей биос. (Стандартная утилита от самого Award-а).

· Modbin (например, v.4.50.80C - http://yusoft.kulichki.com/russian/doc/biosedit/award/modbin_4_50_80c.rar) - программа, позволяющая редактировать некоторые регистры чипсета, а так же изменять надписи/опции в BIOS Setup. (Стандартная утилита от самого Award-а).

· LHA - старый(1988)-добрый архиватор от Haruyasu Yoshizaki, алгоритм которого и лёг в основу упаковки модулей Award BIOS. (http://yusoft.kulichki.com/russian/doc/biosedit/award/lha.rar).

В начале кратко, но достаточно точно рассмотрим основные части биоса. Он состоит из двух главных частей:

1. BootBlock.

В его функцию входят самые первые шаги по инициализации регистров чипсета и распаковка главной части в память для последующего исполнения. При несовпадении подсчитанной контрольной суммы биоса он же (bootblock) запускает программу аварийного восстановления биоса (с дисковода).

2. Основная часть.

Главный исполняемый код. Состоит из нескольких «модулей» и хранится в запакованном виде как архив LHA с немного изменёнными заголовками (не принципиально для нас). Как правило, используются следующие названия для составных частей (модулей) этого «архива» (детально можно посмотреть с помощью утилиты cbrom):

- original.tmp – главная часть, всегда размером 128k, она нас и интересует. Именно в ней происходит вся инициализация компьютера, в ней же подпрограмма BIOS Setup

- awardext.rom – «расширение» главной части, в т.ч. в нём подпрограмма вывода конфигурации компьютера - табличка, появляющаяся сразу же перед «Starting Windows (DOS, linux и т.д.) …»

- awardepa.bin – «картинка» Energy Star

Другие встречающиеся части:

- cpucode.bin – таблица микрокодов для Intel-процессоров (PPro, P2/P3/P4, Celeron)

- acpitbl.bin – подпрограмма поддержки ACPI

Так же, бывает, попадаются всякие VGA.rom (при интегрированном видео), logo.bin и др., что есть либо не принципиально, либо банально-понятно. Названия могут меняться производителем, но по смыслу-размеру-названию всегда можно догадаться.

Как теперь стало понятно, «просто» редактировать биос нельзя, т.к. это архив. Поэтому, если мы хотим что-то изменить – сначала надо распаковать нужную часть, исправить, что нужно и запаковать обратно. «Главная» часть, как уже говорилось, это original.tmp. Его и будем править.

Рецепт 1 (описан в интернете).

Берём modbin, открываем в нём нужный файл биоса (прошивки, которую будем править). modbin создаёт два временных файла – bios.rom и original.tmp. bios.rom – это просто копия открытого файла, а вот original.tmp – это и есть уже распакованный наш «главный» модуль (см. выше). Т.е. распаковка – просто.

Если мы выберем в modbin верхний пункт «Update File», то «временный» файл original.tmp запаковывается назад в файл биоса. Напрашивается простое решение: если это сделать (открыть файл биоса в modbin) из-под винды, а потом просто переключиться по Alt-Tab в любой другой файлменеджер (VC, Explorer, Far и т.п.) – то у нас появится возможность внести любые изменения в original.tmp. Сделав, что нужно, переключаемся назад в modbin и тискаем “update”. modbin берёт исправленный нами original.tmp и сам запаковывает его в биос. Всё – радуемся. (Особенно, ежели после перешивки исправленная версия заработает:)

Однако описанный способ имеет важный недостаток – он не позволяет исправлять второй сегмент, т.е. можно менять лишь первые 64k – 00000-0FFFFh. Просто во вторых 64k лежат изменяемые модбином всякие регистры, потому он вторые 64k заменяет «своими», и все изменения по адресам 10000-1FFFFh игнорируются. Этого недостатка лишён второй способ. Кроме этого, в отличие от первого, здесь всё делается под «голым» ДОСом, а также можно распаковать и изменить любой «модуль».

Рецепт 2 (©apple_rom;)

Придётся чуть более подробно поговорить о структуре биос. Как было сказано выше, биос представляет собой архив. Но правильнее и точнее – это последовательность заархивированных с помощью LHA файлов с bootblock-ом в конце. Он (bootblock), конечно же, не заархивирован, т.к. именно он и распаковывает все эти «модули» в оперативную память. В применении к конкретными адресам структура примерно такова:

Таблица 1. Структура и адреса для 1Mbit-ного (128kB) биоса.

00000 – xxxxx+1 | Файл запакованного original.tmp плюс один байт («дополнительного» CRC)
xxxxx+1 – yyyyy | Cразу же дальше (т.е. без разрыва) идёт файл следующего запакованного модуля, например, awardext.rom (на конце уже никаких «дополнительных» байтов)
yyyyy – zzzzz | Дальше (также без разрыва) – следующий. И так все имеющиеся в конкретном биосе модули
zzzzz - ~17FFEh* | Свободное место, обычно заполняется «00» или «FF»
~1C000* – 1FFFFh | Бутблок

* - адреса могут отличаться, т.к. бывают прошивки с разными по величине бутблоками.

Теперь о том, что представляет собой заголовок LHA-архива. Мы не будем вникать в подробности, а лишь отметим те моменты, которые нам помогут точно определить его начало (ведь все «модули» идут друг за другом «без пробелов»). Зная адрес начала каждого модуля, мы будем знать, соответственно и его конец. Начало любого файла, заархивированного с помощью LHA, выглядит примерно так: "%·-lh5...". Главный и постоянный отличительный признак здесь – “lh5”, эти три символа присутствует всегда. Три символа левей “lh5” – и есть начало. Т.е. просто введя несколько раз подряд поиск “lh5” мы запросто вычислим вышеуказанные xxxxx+1 (отнимая тройку от адреса найденного “lh5”), yyyyy, zzzzz… Разберём на конкретном примере - прошивка для платы Zida 5SVA v.1.4:

Начало:
00000000: 25 E6 2D 6C-68 35 2D B3-4D 01 00 00-00 02 00 00 %ц-lh5-│M☺ ☻
00000010: 00 00 50 20-01 0C 6F 72-69 67 69 6E-61 6C 2E 74 P ☺♀original.t
00000020: 6D 70 07 08-20 00 00 2D-08 8E 1E FD-AC 49 4B DA mp•◘ -◘О▲¤мIK┌

Тут и так понятно, начало файла заархивированного original.tmp – 00000. Ищем следующее “lh5”:

Следующее найденное “lh5”:
00014DD0: 39 0B F8 01-C1 E8 07 61-FA 50 00 B9-25 73 2D 6C 9♂°☺┴ш•a·P ╣%s-l
00014DE0: 68 35 2D 79-02 00 00 42-06 00 00 00-00 02 40 20 h5-y☻  B♠ ☻@
00014DF0: 01 0C 41 57-41 52 44 45-50 41 2E 42-49 4E 29 49 ☺♀AWARDEPA.BIN)I

Как видно, дальше идёт файл заархивированной картинки EnergyStar – AWARDEPA.BIN. Он начинается с адреса 14DDCh. Соответственно, файл заархивированного original.tmp – 0-14DDAh. На байт 14DDBh (CRC) не обращаем внимания, его позже пересчитает и установит сам modbin.

Следующее найденное “lh5”:
00015070: 0F 68 CF 55-8F 4F 88 8C-9B 96 B5 80-00 25 B3 2D ☼h╧UПOИМЫЦ╡А %│-
00015080: 6C 68 35 2D-E1 1D 00 00-98 2B 00 00-00 00 00 41 lh5-с↔  Ш+ A
00015090: 20 01 0C 61-77 61 72 64-65 78 74 2E-72 6F 6D 51 ☺♀awardext.romQ

Нашли по адресу 1507Dh начало awardext.rom. Получается, AWARDEPA.BIN – 0-14DDCh. Кстати, как уже заметно, последний байт LHA-архива всегда “00”.

Последнее найденное “lh5”:
0001E860: 8E D8 8E C0-66 BE 00 00-0E 00 67 66-81 7E 02 2D О╪О└f╛ ♫ gfБ~☻-
0001E870: 6C 68 35 74-07 66 81 CE-00 00 F0 FF-66 BF 00 00 lh5t•fБ╬  Ё f┐
0001E880: 01 00 66 B9-00 80 00 00-67 F3 66 A5-0F 20 C0 24 ☺ f╣ А gєfе☼ └$

Последнее найденное “lh5” отбрасываем, так как видно даже по адресам, что это область бутблока. Чтоб найти конец awardext.rom, просто пролистываем прошивку после предпоследнего “lh5” до начала пустого места (заполнено “00” или “FF”).

00016E70: 11 85 2A F7-D0 82 2D 90-76 0A E6 27-39 FB FC 17 ◄Е*ў╨В-Рv◙ц'9√№↨
00016E80: 5B EC 16 B0-C0 00 FF FF-FF FF FF FF-FF FF FF FF [ь▬░└
00016E90: FF FF FF FF-FF FF FF FF-FF FF FF FF-FF FF FF FF

Т.е. с 16E86h начинается пустое место, значит awardext.rom – 1507D-16E85h.

Если записать найденные куски кода в файлы, дать им расширение “*.lha”, то с помощью LHA (или любого другого «современного» архиватора) сможем их разархивировать и получить нужные нам файлы для просмотра/правки.

Теперь, подробно зная «скелет» прошивки нам не составит труда её разобрать и собрать. После наших (ваших;) исправлений, отредактированный файл original.tmp запаковываем с помощью LHA (название архиву можно дать любое). В конец полученному “*.lha”-файлу дописываем предварительно сохранённый кусок кода 14DDB-16E85h, т.е. все остальные «модули» (в т.ч. байт CRC), кроме original.tmp. Это можно сделать с помощью любого hex-редактора или, например, выбрав “Append” вместо “Overwrite” в WindowsCommander-е. Таким образом получим новый «слепок» заархивированных «модулей». Его и записываем в начало файла прошивки (поверх имеющегося). Конечно, после наших действий изменится контрольная сумма, поэтому для того, чтоб пересчитать/перезаписать CRC полученной прошивки, просто открываем её в модбине и, ничего не изменяя, нажимаем “Update File”. Если модбин при открытии не «возмутится», значит, всё было проделано правильно.

Мы рассмотрели алгоритм замены для 1Mbit-ных (128kB) биосов. Для 2Mbit- ных всё ещё проще, т.к. original.tmp лежит отдельно от других модулей:

Таблица 2. Структура и адреса для 2Mbit-ного (256kB) биоса.

00000 – xxxxx | Файл одного из запакованных «модулей», например, awardext.rom
xxxxx – yyyyy | Cразу же дальше (т.е. без разрыва) идёт файл следующего запакованного модуля, например, cpucode.bin. Дальше (также без разрыва) – следующий. И так все имеющиеся в конкретном биосе “модули” (кроме original.tmp)
yyyyy – 1FFFFh | Свободное место, обычно заполняется «00» или «FF»
20000 – zzzzz+1 | Файл запакованного original.tmp плюс один байт («дополнительного» CRC)
zzzzz+1 - ~37FFEh* | Свободное место, обычно заполняется «00» или «FF»
~3C000* – 3FFFFh | Бутблок

* - адреса могут отличаться, т.к. бывают прошивки с разными по величине бутблоками.

И значит, не надо дополнительно мучаться с оставшимися «модулями» - заархивированный LHA модуль original.tmpзаписываем по адресу 20000h в нашу прошивку (поверх, конечно) и для пересчёта CRC «пересохраняем» (“Update File”) в модбине.

Правка BootBlock-а.

BootBlock, располагающийся в самом конце биоса, как уже говорилось, не запакован (ведь кто-то должен всё распаковывать:). Поэтому с правкой тут особых проблем нет – берём любой hex-редактор и правим. CRC считается вплоть до 17FFFh для 1M-bit и 37FFFh для 2M-bit, так что если вы исправили что-то по более старшим адресам, обновлять CRC не нужно.

Примечание для программистов: не забывайте – в бутблоке не используется стэк (он на первой стадии инициализации запрещён), поэтому для исполнения своих подпрограмм пользоваться указателем sp «вручную». Как? – проще взглянуть на любой кусок кода оттуда от любой прошивки и станет понятно.

Дата: 4.11.2003
Автор: Севко Роман
Источник: http://yusoft.kulichki.com


Быстродействие

Очень сильно увеличить быстродействие компьютера путем системных настроек можно, только если у вас есть явные ошибки в этих самых настройках. Поэтому, в первую очередь, проверьте правильность написания файлов AUTOEXEC.BAT и CONFIG.SYS: в них не должны находиться ДОСовские драйвера типа MSCDEX.EXE, MOUSE.COM, SBIDE.SYS или SMARTDRV.EXE. Это легко сделать с помощью программы Msconfig.exe, которая находится в папке C:\WINDOWS\SYSTEM.

Далее, откройте Панель Управления, меню "Система" и просмотрите вкладку "Устройства" (Device Manager), если там вы увидите отметки в виде восклицательных знаков, значит необходимо установить верные драйвера для некоторых устройств (скачайте их из Интернета). Иногда помогает удаление конфликтующего устройства и перезагрузка компьютера, после которой, винды, переустановив драйвера, могут устранить конфликт. Просмотрите внимательно свойства каждого устройства в этом списке - возможно, вы увидите какие-нибудь дополнительные настройки на закладках "Settings". Например, для звуковой карты можно включить трехмерный звук и режим Full-Duplex, у CD-ROMa надо включить режим DMA (если он поддерживается приводом), включить для всех дисков "Sync Data Transfer" - это тоже может избавить от некоторых глюков. В настройках COM-портов нужно увеличить максимальную скорость до 921600 бит в секунду, и установить:
Data Bits = 8
Parity = none
Stop Bits = 1
Flow Control = hardware
На вкладке "Дополнительно" настройки портов включите использование FIFO буфера и задайте максимальные значения размеров приемного и передающего буферов.
Полезно будет посмотреть вкладку "Устройства" меню "Система" в режиме "Safe Mode" ("Безопасный Режим" или "Режим защиты от сбоев") - некоторые глюки бывают из-за того, что в этом режиме появляются, вдруг, лишние устройства, например, еще один монитор или винчестер.

Откройте еще раз вкладку "Устройства" (Device Manager) меню "Система" и найдите в системных устройствах настройки Контроллера DMA (Direct Memory Access Controller) на странице "Settings" его свойств установите флажок "Reserve DMA Buffer", после чего установите размер буфера равным 64 килобайтам - если есть запас оперативки, это тоже прибавит жизни вашей машине.

На вкладке "Система"/"Быстродействие"/"Файловая Система" определите роль компьютера как "сервер", это отведет больше памяти под пути к папкам и файлам, что уменьшит обращение к дискам (утилита Cacheman позволяет выделить под кэш еще больше памяти). Отмените поиск флоппи-диска при включении компьютера, а для CD-ROMa отведите больше памяти под кэш. На вкладке "Виртуальная Память" можно установить постоянный размер файла подкачки, что заметно ускорит работу машины. Для этого установите максимальный размер свап-файла равным минимальному в пределах 40-80 мегабайт (некоторые приложения требуют памяти более 100 мегабайт, например игра "SiN"), а если у вас два винчестера (но не один, разбитый на два диска!), то можно переместить свап-файл на другой винт, это тоже даст выигрыш в скорости. После этого проведите дефрагментацию (ее вообще надо проводить регулярно) дисков с помощью Norton SpeedDisk, эта утилита поместит файл виртуальной памяти в начало диска, что также прибавит быстродействия.

Загляните на вкладку "Конфигурация" диалога "Сеть" в панели управления и, если вы не подключены к сети, то оставьте только следующие сетевые компоненты: Dial-Up adapter, TCP/IP, Microsoft Family Logon (естественно, если вы подключены при этом к Интернету, а если нет, то и эти компоненты не нужны, но как, тогда, вы это читаете?), это может избавить от некоторых глюков.

Можно кое-что подправить в разделе [vcache] файла SYSTEM.INI, увеличив, тем самым, размер дискового кеша. Для этого надо вставить в раздел [vcache] строки (при оперативке 64 метра):
MinFileCache=16384
MaxFileCache=16384
ChunkSize=512
Размер кеша должен быть примерно равен 25% оперативной памяти. Но для подбора оптимального размера кеша лучше всего все-таки поэкспериментировать самому, не полагаясь особенно на чужие советы, иначе эффект для конкретного компьютера может быть обратным, и часто больший выигрыш в скорости дает экономия оперативки, а не увеличение кеша. Посмотреть, в каких пределах меняется размер дискового кеша и какова его эффективность можно с помощью программы VCache Monitor. Существует небольшая утилитка для автоматизации настройки дискового и файлового кеша, очень наглядная, простая и удобная: Cacheman. Прочитайте небольшую статейку на эту тему, поэкспериментируйте с настройками, например, увеличение с ее помощью буфера кеша, отводимого под пути к файлам и папкам, сократит в несколько раз число обращений к винчестеру при навигации по дискам. При этом регулируются те же параметры, что и на вкладке "Жесткие диски" свойств файловой системы меню "Система"-"Быстродействие", но в более широких пределах, чем задают винды. Если на этой вкладке вы определили роль компьютера, как "Сервер сети", то NameCache=2729 и PathCache=64 - это максимум, что может предложить Windows. Однако, если размер оперативки больше 48 мегабайт, лучше выставить NameCache=4096 и PathCache=96. В реестре эти параметры выставить вручную сложнее: создайте ключ
[HKEY_LOCAL_MACHINE \Software\Microsoft\Windows\CurrentVersion\FS Templates\Cacheman]
@="Cacheman Settings" "NameCache"=hex:00,10,00,00 "PathCache"=hex:60,00,00,00 , после этого, на вкладке "Жесткие диски" свойств файловой системы выберите новую строку "Cacheman Settings" в списке вариантов для роли компьютера.

Один из недостатков Windows состоит в том, что система, записывая файл на диск, располагает его на первых попавшихся свободных кластерах, сильно фрагментируя большие файлы. Для того, чтобы система сначала нашла для нового файла подходящее по размеру место на диске и поместила его туда не фрагментируя, необходимо добавить в реестр параметр:
[HKEY_LOCAL_MACHINE \System\CurrentControlSet\Control\FileSystem]
"ContigFileAllocSize"=dword:000001f4. Это можно сделать с помощью программы WinBoost 2000 - один из ее пунктов включает этот режим, очень полезный при работе с мультимедиа (уменьшается нагрузка на диск при воспроизведении видео или звуковых файлов).

Если у вас больше 64 метров оперативки, то попробуйте сократить количество обращений системы к файлу подкачки, прописав в файле System.ini параметр:
[386Enh]
ConservativeSwapfileUsage=1
система будет работать со свап-файлом только когда закончатся ресурсы оперативки, а не когда ей вздумается, в результате размер свапа будет стремиться к нулю, если у вас 128 мегабайт памяти. В SYSTEM.INI можно дописать в секцию [386Enh] и еще один параметр для своп-файла
PagingFile=C:\WINDOWS\Win386.swp
он может уменьшить вероятность зависания ПК при выключении.

Некоторые "товарищи" рекомендуют увеличить размер буфера очереди с 8К до 32К:
[windows]
DefaultQueueSize=32
Изменить параметры DMA и увеличить количество буферов виртуальной памяти:
[386enh]
DMABufferSize=64
PageBuffers=32
Потестируйте некоторое время систему с новыми параметрами, чтобы определить, увеличилось ли быстродействие или лучше все вернуть к исходному варианту.

А в MSDOS.SYS весьма желательно отключить протоколирование загрузки, двойную буферизацию и загрузку драйверов сжатых дисков (смотри примеры файлов). Некоторые параметры, значения которых надо проконтролировать, в этом файле такие:
Logo=1 - разрешена заставка при загрузке
BootMulti=0 - отключен Dos по нажатию F4 при загрузке
BootGUI=1 - разрешен графический интерфейс
DoubleBuffer=0 - отключает двойную буферизацию некоторых SCSI устройств
DisableLog=1 - Не создавать файл протокола загрузки в корневом каталоге (BootLog.txt) - рекомендую включать создание файла отчета только при необходимости его просмотреть!
AutoScan - отвечает за то, как будет вести себя система, если до этого система завершила работу аварийно, т.е будет ли проводиться сканирование дисков и как:
AutoScan=0 - несмотря на аварийное завершение работы файловая система проверяться не будет.
AutoScan=1 - файловая система после предыдущего аварийного завершения работы проверяться будет, но предупредит об этом.
AutoScan=2 - файловая система после аварийного завершения проверяеся без запроса разрешения на это
DblSpace=0 - отключено использование драйвера сжатых дисков DoubleSpace
DrvSpace=0 - отключено использование драйвера сжатых дисков DriveSpace
BootDelay=0 - при загрузке система не будет ждать несколько секунд.
LoadTop=1 - разрешена загрузка Command.Com или Drvspace.Bin в верхнюю память Значение по умолчанию 1.
Все эти изменения может вносить в файл MSDOS.SYS утилита Tweak UI , а программа MSDOS.SYS Editor предоставит вам удобный и простой графический интерфейс для изменения всех параметров этого файла. Полный список параметров MSDOS.SYS можно узнать в этой статье: Msdossys.zip.

В папке C:\WINDOWS\SYSTEM есть утилита WALIGN.EXE, она особым образом "выравнивает" некоторые программные файлы, чтобы они запускались непосредственно из кэша, что ведет к повышению производительности компьютера, хотя файлы несколько увеличиваются в размере. Однако, если у вас не стоит MS-Office эта утилита не хочет работать. Чтобы ее обмануть добавьте в реестр WALIGN.REG, но только, если у вас не установлен MS-Office!!! Подробнее об этой утилите можно узнать на сайте http://www.winmag.com/win98/alignwma.htm.

Пример системных файлов:

AUTOEXEC.BAT
CONFIG.SYS
DOSSTART.BAT
MSDOS.SYS

Статейки о быстродействии :

Speed.zip
 Vcache.zip
Msdossys.zip

Заметно облегчает работу на компьютере увеличение скорости "всплывания" меню, в том числе и меню "Пуск" и добавление в меню "Пуск" подменю "Панель управления" (Скриншот). Эту доработку делают программы WinBoost 2000 и Tweak UI , которые позволят изменить и много других скрытых настроек для уменьшения времени загрузки компьютера и ускорения его работы.

Сильно облегчит жизнь отключение в свойствах корзины раздражаощего подтверждения на удаление файла.

Если слишком часто происходит перерисовка иконок, то установите
[HKEY_LOCAL_MACHINE \Software\Microsoft\Windows\CurrentVersion\explorer]
"Max Cached Icons"="5000", это заметно увеличит скорость работы компьютера (Icons.reg).

Сильно замедляют работу программы (и вирусы), запускаемые автоматически при старте виндов, исправить их список можно в реестре (поможет в этом Msconfig.exe):
HKEY_LOCAL_MACHINE \Software\Microsoft\Windows\CurrentVersion\Run,
HKEY_CURRENT_USER \SOFTWARE\Microsoft\Windows\CurrentVersion\Run,
HKEY_LOCAL_MACHINE \Software\Microsoft\Windows\CurrentVersion\RunServices,
в файле WIN.INI:
[windows]
load=
run=
и, естественно, в папке "Автозагрузка" меню "Пуск", файле AUTOEXEC.BAT и WINSTART.BAT. А в файле SYSTEM.INI, в строках [386Enh] иногда прописывают себя вирусы.
Чтобы увидеть полный список запущенных процессов, воспользуйтесь программой Process Viewer. Вот небольшой список приложений, чаще всего зря занимающих ресурсы процессора, и автоматический запуск которых следует отменить, воспользовавшись System Configuration Utility или удалив соответсвующие ключи в реестре:
"MS WebCheck Monitor" - он же "Loadwc" - создает установки Microsoft Explorer при первом запуске,
"System Agent" - он же "Mstask" - планировщик задач (если вы его не используете, то отключите),
"System Tray" - он же "Systray" - индикатор разряда батарей - естественно, для настольного ПК абсолютно не нужен,
"Microsoft Office Wrapper" - он же "Osa" (Office Speed Access) - сомнительный ускоритель запуска программ MS-Office (запуск из "Автозагрузки"),
"File Open" - он же "Findfast" - вроде бы ускоряет поиск в документах Офиса (запуск из "Автозагрузки"),
"LoadPowerProfile" - загрузка схемы управления питанием, вещь местами нужная, если бы не грузилась почему-то два раза (!) - из раздела реестра "Run" и из "RunServices", поэтому один экземпляр можно удалить.
"TaskMonitor" он же "TaskMon" - в принципе, полезная программа и ее вполне можно оставить, так как она создает протоколы запуска приложений для последующей оптимизации расположения файлов на диске при дефрагментации. Эти файлы вы можете просмотреть в папке C:\WINDOWS\APPLOG. Отключить запуск TaskMonitor лучше с использованием утилиты System Configuration Utility, так как ее автозапуск прописан в реестре, кроме того, в этом случае легко отменить изменения.
Кроме того, можно отключить индикатор раскладки клавиатуры Internat.exe (через свойства клавиатуры), регулятор громкости (через свойства мультимедиа) и системные часы (в диалоге свойств времени и даты).

Довольно много ресурсов занимают обои на рабочем столе, анимационные эффекты при открытии различных окон, сглаживание экранных шрифтов - все это отключается в настройках свойств дисплея. Замедлять работу машины может даже использование управления питанием и звуковые эффекты.

Одна из особенностей файловой системы Windows в запоминании даты последнего обращения к файлу. По умолчанию эта функция используется для файлов на жестких дисках и не используется для дискет и для режима защиты от сбоев. Если хотите ее отключить (может пару тысячных долей процента к общему быстродействию это и прибавит) добавьте в CONFIG.SYS команду
"ACCDATE=C- D-"
этим вы отключите регистрацию доступа к файлам на дисках C: и D:.


FDISK

FDISK.exe - как правильно разбить свой жесткий диск

Если у вас возникла необходимость разбить свой диск или вы прикупили новый, и вы не знаете с чего начать здесь вы найдете ответ на все вопросы и обойдете многие подводные камни.

Как правильно разбить свой диск:

  1. Программа fdisk находится в папке Windows\Command. ВНИМАНИЕ: Запустив эту программу и выполнив все действия для разбиения диска, вы уничтожите ВСЮ информацию на своем жестком диске.
  2. После запуска программа спросит у вас "Включить поддержку больших дисков". Я думаю, что это стоит включить. Во-первых, в таком случае у вас будет осуществлена поддержка дисков более 2 Гб. Во-вторых, у вас сократятся потери места на диске. На больших дисках экономия составляет в ряде случаев до 100 Мб и более.
  3. После этого на экране будет показано меню из 4 пунктов. Пунк 4 - вывод сведений об имеющихся разделах. Можете посмотреть.
  4. Перед созданием новых дисков необходимо удалить старые диски. Правило: создание идет сверху вниз по пунктам программы, удаление снизу вверх.
  5. Итак, в начале работы вам необходимо создать основной раздел DOS. Размер указывать лучше в процентах от общего размера жесткого диска. Не рекомендую создавать один логический диск, т.к. например, при полной установке Windows вы можете свои документы скопировать на другой логический диск.
  6. После создания основного раздела вам необходимо будет создать дополнительный раздел. Дополнительный раздел вы можете так же поделить на части.
  7. Не забудьте указать какой диск у вас будет активным, обычно С. См. пункт 2 программы
  8. После работы вам будет предложено перезагрузить ваш ПК для вступления изменений в силу.
  9. Следующий шаг - форматирование дисков и установка операционной системы.


Ускорь свой Интернет!

Автор: Владимир Степанов
http://spacesoft.narod.ru/

Каждый из нас желает добиться максимальной, для своего модема, скорости передачи данных в Интернете. Существует немало программ для оптимизации модема и интернет-соединения, и сегодня мы о них поговорим.

Я решил представить вам две программы из этого класса, лучшие, на мой взгляд, это Modem Booster и Throttle.

Modem Booster 3.0 (ShareWare, английский интерфейс, Win 9x/Me/NT/2000/XP, 1.74 мб)
Throttle v.5.11.17.2003 (ShareWare, английский интерфейс, All Windows, 842 кб)

С установкой программ проблем, думаю, не будет, поэтому описывать ее не буду и сразу перейду к самому процессу оптимизации.

Итак, для того чтобы Modem Booster оптимизировал ваш модем необходимо наличие соединения с Интернетом на протяжении всего процесса оптимизации. Modem Booster будет подстраивать параметры вашего модема, до тех пор, пока они не будут соответствовать настройкам вашего провайдера. Программа не требует вашего вмешательства в процесс оптимизации. Просто выберете Автооптимизация (есть и ручная), и программа все сделает за вас. После запуска, программа в автоматическом режиме выполнит нужные настройки и сохранит их в системе. Процесс оптимизации может занять от 1 до 2 часов и может изменяться.

После того как Modem Booster выполнит все необходимые операции появиться окно результатов.

В окне результатов будет приведена статистика оптимизации:

Extreme Performance - результат сравнения между самой быстрой и самой медленной скоростью вашего модема ПЕРЕД оптимизацией. Если процент очень высокий, это означает, что вашу скорость модема можно на много увеличить.

Average Performance - результат сравнения средней скорости модема при первоначальных значениях и при оптимизированных значениях. Если Вы получаете 0%, то средняя скорость вашего модема до оптимизации равна средней скорости после оптимизации. Следовательно, ваши первоначальнальные параметры модема оптимальны, но если у вас больше 0%, это означает что параметры модема не оптимальные

Best of the Best Performance - результат сравнения лучшей скорости модема до оптимизации и после. Если Вы получаете 0%, то ваши параметры модема были оптимальны, но если вы получаете не 0%, то ваш модем был оптимизирован на то количество %, которое указано в этой строке.

Для того чтобы Moodem Booster использовал оптимальные параметры модема необходимо выходить в Интернет при помощи встроенной в Modem Booster звонилки.

Полнофункциональная trial-версия программы работает только 21 день.
Скачать Modem Booster можно здесь.

Теперь рассмотрим более простую программу Throttle.

В окне программы выбираете свою операционную систему и тип соединения (modem, DSL/ADSL modem, cable modem, ISDN modem). Функция Speed Setting оптимизирует ваш модем. Speed Setting содержит два уровня оптимизации:

Fast - быстро
Fastest - самый быстрый

Передвигаете указатель в нужное положение и нажимаете Go, после чего программа потребует перезагрузить компьютер. После перезагрузки параметры вашего модема будут настроены на оптимальную работу.

В не зарегистрированной версии указатель в положение Fastest передвинуть нельзя.
Скачать Throttle можно отсюда.

И от себя добавлю, что необходимо перепробовать не одну пару подобных программ, чтобы добиться от своего модема максимальной скорости.

***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>
***
Copyright © Internet Zone, info@izcity.com


DOS — долгожитель среди операционных

Открылась Компьютерная Ярмарка Expo-com.ru на Тульской
6000 кв.м, 20 000 покупателей в день.
Удачное расположение (м. "Тульская"), большой ассортимент, автостоянка, лифты, кафе, туалеты, телефонная связь, интернет.
Арендаторам: 1 месяц бесплатно
Режим работы и проезд см. здесь >>
***

DOS — долгожитель среди операционных систем

Автор: Михаил Федотов, aka $ky$pe@R

По моим наблюдениям, около 50 процентов рядовых пользователей сегодня не знают, что такое DOS :-(. А из оставшейся половины далеко не все умеют им пользоваться. Поэтому, когда нужно выполнить такую простейшую операцию, как переустановка Windows из "чистого" DOS'а, многие трясутся от ужаса и негодования, вызванных появлением непонятного черно-белого экрана, да еще без мышки 8-).

В принципе, это вполне естественно. Постоянно пользуются DOS'ом теперь лишь очень немногие, и те преимущественно из-за недостатка системных ресурсов для работы с Windows (сторонникам Linux, Unix, OS/2 и т.п. эта статья вряд ли покажется полезной). А те из пользователей, кому доводилось иметь дело лишь с Windows NT/2000/XP, вообще слабо представляют себе DOS. Причина очень проста: операционные системы этой линейки выполнены на ядре OS/2, работу над которой IBM до поры до времени вела совместно с "Майкрософт". Вот почему совместимость этих систем c DOS намного хуже, чем у Windows 9x (к этой группе относится и Me), сделанных на его ядре. Это обстоятельство для пользователей Windows XP ухудшается еще тем, что в ней, как и в Millennium, нельзя перезагрузиться в DOS'е стандартными средствами. Проще всего создать загрузочный диск (Панель управления -> Установка и удаление программ -> Загрузочный диск -> кнопка Создать диск) и грузиться с него (подробней об этом см. статью "Floppy. Прошлое и настоящее" в IZone 473).

Многие могут спросить: а кому, собственно, нужен этот самый DOS? Если "накрылась" Windows, то ее можно переустановить только из другой Windows либо из DOS'а при помощи загрузочной дискетки. В первом случае есть определенные нюансы: например, Windows 98 и "Линолеум" не хотят уживаться под одной крышей, потому что, по существу, являют собой практически одно и то же; Windows 9x никогда не установятся из NT'шных систем и т.д. Во втором же случае единственная проблема может заключаться в незнании старого доброго DOS'а. Другой пример, когда этот маленький недостаток становится комом в горле, — если какая-то старая программа (игра, например) не хочет запускаться из-под "Винды".
Надеюсь, что, если вы принадлежите к когорте пользователей, плохо представляющих себе "деда" "Окон", то я смог вас убедить в том, что пора бы получить элементарнейшие навыки работы в нем. Если нет, то, боюсь, моя статья будет для вас совершенно бесполезна.
Итак, ближе к делу. Командная строка DOS так называется потому, что в ней вводятся команды ;-). Сегодня мы поговорим главным образом именно о них.

Запускайте окошко DOS (Пуск -> Программы -> Стандартные -> Сеанс MS-DOS) или перезагружайтесь в него. Вообще главная программа DOS — command.com, но в NT-системах вместо нее используется 32-битный интерпретатор DOS'овских команд. Но это не так уж и важно. Лучше давайте посмотрим, что у нас там на экране.

Примерно картина должна выглядеть так:

[Всякий бред, который нас не интересует и которого может и не быть]
X:\directory\>

Последняя строка называется приглашением DOS. Здесь X — текущий диск (на котором находится запущенная ОС), directory — папка или папки, где она расположена. Короче, просто путь. Сразу после вывода приглашения система ожидает ввода ваших команд.
Самая простая "команда" — путь к какой-нибудь программе и ее имя без расширения — запускает указанное приложение.

Одна из наиболее часто вводимых инструкций DOS — dir [путь][маска][ключ]. Она выводит на экран содержимое папки с указанным адресом или, если путь не назван, текущей папки. Параметр [маска] задает шаблон поиска файлов. Если он не указан, выводятся все файлы папки. В противном случае вы увидите только те из них, которые соответствуют шаблону. Знак * заменяет любое количество любых символов, ? — один неопределенный символ. Скажем, шаблону ?a*.* соответствуют любые файлы с любым расширением, в которых "a" — вторая буква. Кстати, не стоит забывать, что максимальная длина имени файла в DOS — 8 символов, а расширения — 3 символа. Более длинные имена урезаются до шести букв, к которым прибавляется знак ~ и число, соответствующее номеру файла среди других, начинавшихся так же. И, наконец, последний параметр команды dir — ключ. Ключи способны значительно повлиять на работу команды, и они есть почти у всех инструкций DOS. Скажем, ключ /? (единственный "универсальный" ключ, характерный для DOS) выдает справку по данной команде. Остановимся пока на наиболее интересных dir'овских ключах. Если вам кажется, что содержимое папки не влезет на экран, примените ключ /P. При использовании этого ключа после заполнения каждого экрана будет производиться пауза. Как только прочтете, жмите на любую клавишу, чтобы перейти на очередной экран. Ключ /W позволяет писать по несколько слов в строку и, значит, уместить на экран больше файлов. Используя ключ /S, вы можете просмотреть не только файлы и папки в данной директории, но и ее подпапки. Остальные ключи можно узнать, набрав dir /?.

Еще одна распространенная команда — chdir, она же cd (к компактам не имеет никакого отношения). Она позволяет изменить текущую папку (т.е. ту, в которой выполняется поиск подключаемых к программе файлов) и избежать сообщений типа: "File not found", "No such file or directory" и т.п. Ее параметр — имя папки. Никаких ключей, кроме /?, не имеет.

Большинство пользователей привыкли использовать различные файловые менеджеры, и им необходимость производить элементарные операции вручную кажется ужасной. Однако лично я предпочитаю пользоваться командной строкой, нежели Norton или Volcov Commander. Впрочем, часто оболочки могут то, что недоступно из командной строки, тогда альтернативы просто нет. И все-таки я считаю, что основные файловые операции DOS знать стоит независимо от того, используется файловый менеджер или нет. К ним и перейдем.
Команда mkdir, или, проще, md, предназначена для создания директории. Параметр, как и в случае с cd, имя папки.

Несложно догадаться, какие функции выполняет команда copy. Важно помнить, что сначала указывается файл для копирования, а уж затем адрес и имя "клона". Ключи у copy такие: /A — указывает на то, что файл — текст в понимаемом DOS'ом формате (советую использовать ключ только в том случае, если файл ДЕЙСТВИТЕЛЬНО является простым текстовым файлом DOS), /B — указывает на то, что файл двоичный (предпочтительнее ставить именно этот ключ), /V — заставляет DOS сравнивать файлы после копирования, чтобы проверить их идентичность. Между прочим, если указать вместо файла результата параметр prn, то файл будет выведен на принтер.

Для того, чтобы удалить файл, воспользуйтесь командой del (она же erase). Ее обязательный параметр — файл, файлы или папка для удаления. А единственный ключ — /P — включает уточнение насчет того, действительно ли вы хотите удалить каждый из указанных вами файлов.

А команда rename (или, проще, ren) служит одновременно для переименования файлов и для их перемещения. В первом случае достаточно указать путь к файлу для переименования первым параметром, а вторым — просто имя файла. Для перемещения же, как нетрудно догадаться, требуется указать два пути.

Вот, пожалуй, и все наиболее важные команды для работы с файлами в DOS. Давайте поговорим о других полезных инструкциях, таких, например, как type, не имеющая ключей, кроме /?, и предназначенная для вывода на экран содержимого текстового файла. Правда, пользоваться ею не очень удобно, потому что стандартный экран DOS'а имеет 25 строк и никаких полос прокрутки. Вся информация выдается сразу, и, если текст содержит большее количество строк, чем умещается на экране, то целиком его при помощи type не просмотришь.
А инструкция prompt предназначена для изменения структуры приглашения. Хотите, скажем, сделать так, чтобы вместо адреса текущей папки DOS приветствовал вас надписью "Hello"? Достаточно набрать: prompt <новое приглашение>, причем можно использовать сочетания символов $T для вывода текущего времени, $D для вывода даты и ряд других. Скажем, строка prompt Time: $T, Date: $D придаст приглашению DOS следующий вид: Time: <время>, Date: <дата>.

Кстати, последовательность команд DOS можно сохранить в текстовый файл с расширением .BAT (такие файлы называются пакетными), и он будет функционировать почти как полноценная программа ("почти" потому, что .BAT-файлы, как макросы на Visual Basic или любые Script'ы, интерпретируются системой, т.е. все ошибки и недочеты обнаруживаются только в процессе выполнения).

Есть ряд команд, которые почти не используются сами по себе, но в .BAT-файлах бывают очень полезны. Это прежде всего pause (не имеет параметров), которая приостанавливает выполнение пакетного файла, и echo, выводящая на экран сообщение, которое указывается как параметр и без кавычек.

Впрочем, подробнее о пакетных файлах и о многом другом мы поговорим в следующий раз.
За свою историю DOS по-разному назывался (сначала PC-DOS — так его назвала создавшая эту ОС IBM, затем MS-DOS — это название присвоила системе купившая ее Microsoft), его по-разному характеризовали: сначала называли требовательным к ресурсам, а потом экономным, глючным до безобразия и идеальным во всех отношениях, и удобным, и сложным. Тем не менее, он всегда оставался одним и тем же DOS'ом и пережил множество своих конкурентов. Надеюсь, что он еще проживет не один год.

Продолжение следует.

Источник: http://www.nestor.minsk.by/kg/

***
Флиртанические вечеринки Flirtanica Party - это новый стиль общения между мужчинами и женщинами.
Это клубные вечеринки, где люди знакомятся, улыбаются, танцуют, пьют вино и, конечно же, флиртуют. Flirtanica - это прямое общение, это место, где Вас ждут интересные люди, которые специально пришли знакомиться, общаться и, главное, - флиртовать!
Подробности о вечеринке вы можете узнать на сайте http://www.flirtanica.ru/. На вечеринке разыгрывается большое количество призов. Посещение вечеринки возможно только по пригласительному билету.
***
***
Copyright © Internet Zone, info@izcity.com


DOS — долгожитель среди операционных систем. Часть 2

Автор: Михаил Федотов, aka $ky$pe@R

Если вы читали прошлую статью, то, должно быть, помните, что я там рассказывал о некоторых командах ДОСа и их использовании в пакетных файлах. С этим я тогда немного забежал вперед, так как BAT-файлы — главная тема сегодняшнего материала. Если же вы не знакомы с содержанием предыдущей статьи, то рекомендую прочесть ее перед тем, как приступать к этой.

Итак, BAT-файлы — это текстовые файлы, состоящие из команд ДОС, интерпретируемых при запуске. Во многом BAT'ы похожи на программы.

Кроме команд pause, echo и пр., описанных в предыдущей части, есть и ряд других инструкций, которые могут быть полезны при создании пакетного файла .BAT. Причем эти инструкции, по сути, командами не являются, они выполняют функции операторов в языках программирования.

Одна из них — IF — классический оператор, в том или ином виде присутствующий практически в любом языке программирования. Позволяет проверять правильность условия, заданного пользователем. Например, строка if exist readme.txt echo There is a readme.txt file in the current directory выдаст сообщение "There is a readme.txt file in the current directory" в случае, если в текущей папке есть файл readme.txt. Эту команду можно условно разделить на три части: вызов команды (слово "IF"), условие для проверки (в данном случае — строка exist readme.txt, проверяющая наличие файла readme.txt в текущей папке) и команда, выполняемая, если условие соблюдено (здесь это — echo There is a readme.txt file in the current directory). В данном примере можно изменить имя файла и команду, и он будет работать.

Большинство программ при закрытии оставляют после себя какое-либо значение, называемое возвращаемым, которое указывает на результат работы приложения. Скажем, если какая-либо софтина вырубилась с возвращаемым значением -1, то, скорее всего, имел место глюк или сбой. Инструкция if errorlevel 1 echo Errorlevel 1 напишет "Errorlevel 1", если последняя запущенная программа возвратила значение 1. Также при помощи IF можно сравнивать числа и строки (при сравнении используется двойной знак "равно", т.е. "=="). Кстати, сравнивать можно и параметры, с которыми был запущен командный файл: первый параметр (до первого пробела) обозначается знаком %1, второй — %2 и т.д. Например:

echo off
if %1== hello echo Hello!

Командный файл, запущенный с параметром hello, ответит аналогичной любезностью, т.е. поздоровается. Первая строка — echo off — отключает вывод на экран текущей строки кода bat-файла перед ее выполнением.

Маленькое предупреждение: если параметров не будет вообще, то ДОС не преминет об этом сообщить.

К любому из выражений можно подставить слово NOT, которое, как несложно догадаться, заставляет инструкцию IF'а выполняться, только если ее условие ложно. Простейший пример выглядит так:

if exist command.com echo There is a command.com file in the current directory
if not exist command. com echo There is NO file named command.com in the current directory

Какие действия он выполняет, по-моему, вполне очевидно.
Помимо оператора условия IF, в командном языке ДОС присутствует и оператор циклов FOR, предназначенный для циклического выполнения определенных инструкций. Правда, интерпретация этой команды несколько нестандартна — она имеет вид:

for %%A in (TXT CPP H EXE) do copy mygame.%%A C:\games\mygame

Не пугайтесь. На самом деле все достаточно просто. Вышеназванная инструкция просто скопирует файлы mygame.txt, mygame.exe, mygame.cpp, mygame.h из текущей папки, если они там есть, в папку C:\GAMES\MYGAME. Цикл выполняется следующим образом: вместо параметра %%A или любого другого, стоящего сразу после инструкции for, подставляется первое слово из скобок после in, а затем выполняется действие, стоящее после слова do, затем на место %%A становится уже второе слово из in'овских скобок и с результатом выполняется то же действие и т.д. Например, инструкция for %%FILE_NUMBER in (00 01 02) do del noname%%FILE_NUMBER.obj удалит из текущей папки файлы noname00.obj, noname01.obj, noname02.obj.

Зачастую при выполнении пакетного файла возникает необходимость перейти от одной части кода к другой, независимо от того, раньше или позже она расположена, пропуская все инструкции, стоящие между этими двумя участками BAT'а. Это реализуется с помощью команды goto. Чтобы обозначить нужный участок кода, его нужно пометить знаком :x, где вместо x стоит название метки. Например:

<…кусок кода…>
:metka
<…код метки…>
goto metka

В этом примере инструкции кода метки будут выполняться ad infinitum, т.е. до бесконечности, потому что каждый раз, когда команды будут выполнены, указание goto metka заставит ДОС снова вернуться к началу метки. В таких случаях описанное безобразие прекращается по нажатию на Ctrl-C или Ctrl-Break. Например, если нужно напечатать какой-то документ в нескольких экземплярах, можно воспользоваться следующим кодом:

echo off
: print
echo A copy of readme.txt is being printed…
echo Press Ctrl-Break or Reset if when you get tired of this:-)…
copy readme.txt prn
pause
goto print

В данном случае DOS будет печатать документ readme.txt, если, конечно, таковой имеется в текущей папке, до полного истощения расходников принтера и даже дальше;-).
Есть еще весьма примечательная команда SHIFT, обеспечивающая сдвиг формальных параметров относительно фактических. Говоря по-русски, если пакетный файл был вызван с тремя параметрами, например: view readme.txt please, то формальному обозначению %1 изначально соответствует параметр view, %2 — readme.txt, %3 — please. После вызова инструкции SHIFT %1 будет соответствовать слову readme.txt, а %2 — please. После еще одного вызова параметру %1 будет соответствовать слово please, а если инструкция будет выполнена еще раз, то вообще ничего не останется 8-].

И последняя часто употребляемая в BAT'ах команда — exit. Если вы из одного пакетного файла запустили другой, то без использования этой команды обратно в первый командный файл управление не возвращается.

Ну вот мы и получили необходимый минимум знаний о пакетных файлах. Теперь продолжим начатую мной в прошлой статье тему — команды ДОС. На этот раз обсудим инструкции, используемые несколько реже, но тоже достаточно полезные.

В прошлый раз, говоря о файловых операциях, я забыл упомянуть команду RD (или RMDIR), служащую для удаления папки. Ее параметр — имя папки, а ключей нет.

Команды DATE и TIME выводят на экран текущую дату и время соответственно, кроме того, если задать им в качестве параметра новое значение даты или времени, то системным часам будут установлены введенные величины.

Зачастую приходится искать в текстовых файлах какую-то строку. Сделать это можно с помощью инструкции find. Первый ее параметр — строка для поиска, второй — файлы, в которых его требуется выполнить. Ключ /V заставляет DOS выводить все файлы, НЕ содержащие строку. Если нужно искать текст без учета регистра символов, воспользуйтесь ключом /I.

Команда sort, имеющая вид: sort <файл для сортировки> > <файл конечного результата> предназначена для сортировки слов в текстовом файле в алфавитном порядке и сохранения результатов в файл, указанный после знака ">". Более подробно об инструкциях find и sort можно узнать, набрав "find /?" или "sort /?".

Чтобы узнать версию установленной ОС, введите команду ver.
Команда format предназначена для форматирования флоппи- или жесткого диска. Ее параметр — имя диска. Ключ /Q включает быстрое форматирование, занимающее несколько меньше времени, чем стандартное, и невозможное в случае, если диск никогда не форматировался ранее. Весьма часто используется ключ, задающий емкость диска — /F:X, где вместо X ставится объем форматируемого диска (e.g. 160, 320, 720 Кб, 1.2, 1.4 Мб). Ключ /1 позволяет отменить двустороннее форматирование, попробуйте использовать его, если что-то глючит.

Если возникает необходимость перенести системные файлы на какой-либо диск, воспользуйтесь командой sys X:, где X: — диск для переноса.

В следующий раз мы немного поговорим об устройстве ДОС, Esc-последовательностях и еще о множестве непонятных терминов, значение которых я постараюсь объяснить8-). А на сегодня все. До новых встреч!

Источник: http://www.nestor.minsk.by/kg/

***
Флиртанические вечеринки Flirtanica Party - это новый стиль общения между мужчинами и женщинами.
Это клубные вечеринки, где люди знакомятся, улыбаются, танцуют, пьют вино и, конечно же, флиртуют. Flirtanica - это прямое общение, это место, где Вас ждут интересные люди, которые специально пришли знакомиться, общаться и, главное, - флиртовать!
Подробности о вечеринке вы можете узнать на сайте http://www.flirtanica.ru/. На вечеринке разыгрывается большое количество призов. Посещение вечеринки возможно только по пригласительному билету.
***
***
Copyright © Internet Zone, info@izcity.com


iXBT: FAQ по материнским платам

FAQ по системным платам IBM PC

Russian LinkExchange Advertising Network
  • Я хотел бы кое-что узнать о моей плате - как мне описать ее?
  • Что такое Chipset?
  • Что такое IRQ и DMA и как их распpеделять?
  • Что такое BIOS и зачем он нужен?
  • Что такое Bus Mastering?
  • Чем отличаются шины XT-Bus, ISA, EISA, VLB, PCI, PCMCIA и MCA?
  • Какие типы микросхем памяти используются в системных платах?
  • Что такое DIP, SIP, SIPP, SIMM, DIMM, CELP, COAST?
  • Что такое кэш и зачем он нужен?
  • Что такое Shadow Memory?
  • Что такое Memory Relocation?
  • Что такое VRM?
  • Что означает термин "Green Motherboard"?
  • Как расшифровать "RAS to MA Delay", "DRAM Read WS" и пр.?
  • Что обозначают другие параметры Setup?
  • Почему при установке VLB-плат иногда начинаются сбои?
  • Почему некоторые платы не любят SIMM по 512 кб, 2 и 8 Мб?
  • На что следует обратить внимание при покупке системной платы?
  • У меня на DX2-80 Sysinfo показывает 158, а у друга - 173!
  • Я забыл пароль на Setup (на загpузку) - что делать?
  • Что происходит при замыкании контактов разъема Turbo?
  • Что такое PnP?
  • Я попытался перешить у себя Flash и запорол его :( Что делать?
  • Можно ли поставить процессор Intel 486 с суффиксом &W, AMD с суффиксом B, 5x86, если в книжке на плату таких нет?
  • Можно ли поставить на плату P5-200, если в документации его нет?
  • Почему процессоры AMD 5k86 на некоторых платах работают нестабильно?
  • Поставил новую плату, а на ней X00 вешает мышь. Что делать?
  • Что такое USB, AGP, ACPI?
  • Что такое IR Connector?
  • Чем отличаются наборы Intel Triton FX, VX, HX и TX?
  • Чем отличаются наборы VIA Apollo VPX, VP2, VP3?
  • Что за Chipset'ы VX-Pro, HX-Pro, TX-Pro?
  • Как лучше выбрать частоту платы и внутренний множитель процессора?
  • Как подключить к плате мышь PS/2?
  • Как подключить мышь с другим типом интерфейса?
  • Какая плата нужна для работы процессора MMX?
  • Как использовать режим DMA/Bus Master на контроллере SiS496?
  • Как использовать режим DMA/Bus Master на контроллерах i371?
  • Что такое DMI?
  • Что такое SPP, ECP, EPP?
  • Можно ли поменять умолчания в AWARD BIOS?
  • Можно ли использовать на плате прошивку BIOS от другой платы?
  • Что такое ATX?
  • Чем импульсный стабилизатор отличается от линейного?
  • Почему плата на 440LX не понимает некоторые DIMM?
  • Что такое PC/PCI и DDMA?

Автор: Евгений Музыченко (Eugene Muzychenko) 2:5000/14@FidoNet, music@spider.nstu.nsk.su

Copyright (C) 1996-97, Eugene V. Muzychenko

Все права в отношении данного текста принадлежат автору. При воспроизведении текста или его части сохранение Copyright обяза- тельно. Коммерческое использование допускается только с письмен- ного разрешения автора.

Я хотел бы кое-что узнать о моей плате - как мне описать ее?

Прежде всего - привести ее фирменное название. Если его нет - привести надписи на плате, которые могут быть похожи на название. Описать основные признаки платы (под какой процессор, какие шины, сколько разъемов каждой шины, сколько каких разъемов под кэш/память, что написано на больших микросхемах и т.п.). Если плата не имеет фирменного названия, имеет смысл привести строку идентификации BIOS, которая выводится при перезагрузке внизу экрана, и тип самого BIOS (AMI, AWARD, Phoenix, Acer и т.п.). Чем больше информации - тем выше вероятность верного опознания платы другими и получения ответов на заданные вопросы.

Что такое Chipset?

Chip Set - набор микросхем. Это одна или несколько микросхем, таймеры, систему управления пспециально разработанных для "обвязки" микропроцессора. Они содержат в себе контроллеры прерываний, прямого доступа к памяти,амятью и шиной - все те компоненты, которые в оригинальной IBM PC были собраны на отдельных микросхемах. Обычно в одну из микросхем набора входят также часы реального времени с CMOS-памятью и иногда - клавиатурный контроллер, однако эти блоки могут присутствовать и в виде отдельных чипов. В последних разработках в состав микросхем наборов для интегрированных плат стали включаться и контроллеры внешних устройств.

Внешне микросхемы Chipset'а выглядят, как самые большие после процессора, с количеством выводов от нескольких десятков до двух сотен. Название набора обычно происходит от маркировки основной микросхемы - OPTi495SLC, SiS471, UMC491, i82C437VX и т.п. При этом используется только код микросхемы внутри серии: например, полное наименование SiS471 - SiS85C471. Последние разработки используют и собственые имена; в ряде случаев это - фирменное наз- вание (Neptun, Mercury, Triton, Viper), либо собственная маркировка чипов третьих фирм (ExpertChip, PC Chips).

Тип набора в основном определяет функциональные возможности платы: типы поддерживамых процессоров, структура/объем кэша, возможные сочетания типов и объемов модулей памяти, поддержка режимов энергосбережения, возможность программной настройки параметров и т.п. На одном и том же наборе может выпускаться несколько моделей системных плат, от простейших до довольно сложных с интегрированными контроллерами портов, дисков, видео и т.п.

Что такое IRQ и DMA и как их распpеделять?

IRQ (Interrupt ReQuest - запрос прерывания) - сигнал от одного из узлов компьютера, требующий внимания процессора к этом узлу. Возникает при наступлении какого-либо события (например, нажатии клавиши, завершении операции чтения/записи на диске и т.п.). На PC AT предусмотрено 15 (на XT - 8) линий IRQ, часть которых используется внутренними контроллерами системной платы, а остальные заняты стандартными адаптерами либо не используются:

0  - системный таймер
1  - контроллер клавиатуры
2  - сигнал возврата по кадру (EGA/VGA), на AT соединен с IRQ 9
3  - обычно COM2/COM4
4  - обычно COM1/COM3
5  - контроллер HDD (XT), обычно свободен на AT
6  - контроллер FDD
7  - LPT1, многими LPT-контроллерами не используется
8  - часы реального времени с автономным питанием (RTC)
9  - параллельна IRQ 2
10 - не используется
11 - не используется
12 - обычно контроллер мыши типа PS/2
13 - математический сопроцессор
14 - обычно контроллер IDE HDD (первый канал)
15 - обычно контроллер IDE HDD (второй канал)

На AT и всех современных платах сигнал IRq 2 схемно поступает на вход, соответствующий IRq 9 и вызывает запуск обработчика прерываний, связанного с IRq 9, который программно эмулирует прерывание по IRq 2. Таким образом, программы, работающие с IRq 9, будут работать всегда, а использующие IRq 2 - могут не работать, если не установлен правильный обработчик IRq 9.

DMA (Direct Memory Access - прямой доступ к памяти) - способ обмена данными между внешним устройством и памятью без участия процессора, что может заметно снизить нагрузку на процессор и повысить общую производительность системы. Режим DMA позволяет освободить процессор от рутинной пересылки данных между внешними устройствами и памятью, отдав эту работу контроллеру DMA; процессор в это время может обрабатывать другие данные или другую задачу в многозадачной системе. На PC AT есть 7 (на XT - 4) независимых каналов контроллера DMA:

0 - регенерация памяти на некоторых платах
1 - не используется
2 - контроллер FDD
3 - контроллер HDD на XT, на AT не используется
5 - не используется
6 - не используется
7 - не используется

Каналы 0-3 - восьмиразрядные, каналы 5-7 - шестнадцатиразрядные.

С учетом этого, новые адаптеры следует настраивать прежде всего на полностью свободные каналы IRQ (10, 11) и DMA (1, 5-7), а затем - на свободные в конкретной системе (например, IRQ 5 или 12, DMA 3). Возможность использования одного IRQ несколькими адаптерами зависит от типа шины и требует поддержки со стороны драйверов этих адаптеров. Использование разными адаптерами одного канала DMA в принципе возможно, но связано со множеством проблем и потому не рекомендуется.

Что такое BIOS и зачем он нужен?

Это Basic Input/Output System - основная система ввода/вывода, зашитая в ПЗУ (отсюда название ROM BIOS). Она представляет собой набор программ проверки и обслуживания аппаратуры компьютера, и выполняет роль посредника между DOS и аппаратурой. BIOS получает управление при включении и сбросе системной платы, тестирует саму плату и основные блоки компьютера - видеоадаптер, клавиатуру, контроллеры дисков и портов ввода/вывода, настраивает Chipset платы и загружает внешнюю операционную систему. При работе под DOS/Windows BIOS управляет основными устройствами, при работе под OS/2, UNIX, WinNT BIOS практически не используется, выполняя лишь начальную проверку и настройку.

Обычно на системной плате установлено только ПЗУ с системным (Main, System) BIOS, отвечающим за саму плату и контроллеры FDD, HDD, портов и клавиатуры; в системный BIOS практически всегда входит System Setup - программа настройки системы. Видеоадаптеры и контроллеры HDD с интерфейсом ST-506 (MFM) и SCSI имеют собственные BIOS в отдельных ПЗУ; их также могут иметь и другие платы - интеллектуальные контроллеры дисков и портов, сетевые карты и т.п.

Обычно BIOS для современных системных плат разрабатывается одной из специализирующихся на этом фирм - Award Software, American Megatrends Inc. (AMI), реже - Phoenix Technology, Microid Research; в данное время наиболее популярен Award BIOS 4.51G. Некоторые производители плат (например, IBM, Intel, Acer) сами разрабатывают BIOS'ы для них. Иногда для одной и той же платы имеются версии BIOS от разных производителей - в этом случае допускается копировать прошивки или заменять микросхемы ПЗУ; в объем же случае каждая версия BIOS привязана к конкретной модели платы.

Раньше BIOS зашивался в однократно программируемые ПЗУ либо в ПЗУ с ультрафиолетовым стиранием; сейчас в основном выпускаются платы с электрически перепрограммируемыми ПЗУ (Flash ROM), которые допускают перешивку BIOS средствами самой платы. Это позволяет исправлять заводские ошибки в BIOS, изменять заводские умолчания, программировать собственные экранные заставки и т.п.

Тип микросхемы ПЗУ обычно можно определить по маркировке: 27xxxx - обычное ПЗУ, 28xxxx или 29xxxx - flash. Если на корпусе микросхемы 27xxxx есть прозрачное окно - это ПЗУ с ультрафиолетовым стиранием, которое можно "перешить" программатором; если окна нет - это однократно программируемое ПЗУ, которое в общем случае можно лишь заменить на другое.

Что такое Bus Mastering?

Способность внешнего устройства самостоятельно, без участия процессора, управлять шиной (пересылать данные, выдавать команды и сигналы управления). На время обмена устройство захватывает шину и становится главным, или ведущим (master) устройством. Такой подход обычно используется для освобождения процессора от операций пересылки команд и/или данных между двумя устройствами на одной шине. Частным случаем Bus Mastering является режим DMA, который осуществляет только внепроцессорную пересылку данных; в классической архитектуре PC этим занимается контроллер DMA, общий для всех устройств. Каждое же Bus Mastering-устройство имеет собственный подобный контроллер, что позволяет избавиться от проблем с распределением DMA-каналов и преодолеть ограничения стандартного DMA-контроллера (16-разрядность, способность адресовать только первые 16 Мб ОЗУ, низкое быстродействие и т.п.).

Чем отличаются шины XT-Bus, ISA, EISA, VLB, PCI, PCMCIA и MCA?

XT-Bus - шина архитектуры XT - первая в семействе IBM PC. Относительно проста, поддерживает обмен 8-разрядными данными внутри 20-разрядного (1 Мб) адресного пространства (обозначается как "разрядность 8/20"), работает на частоте 4.77 МГц. Совместное использование линий IRQ в общем случае невозможно. Конструктивно оформлена в 62-контактних разъемах.

ISA (Industry Standard Architecture - архитектура промышленного стандарта) - основная шина на компьютерах типа PC AT (другое название - AT-Bus). Является расширением XT-Bus, разрядность - 16/24 (16 Мб), тактовая частота - 8 МГц, предельная пропускная способность - 5.55 Мб/с. Разделение IRQ также невозможно. Возможна нестандартная организация Bus Mastering, но для этого нужен запрограммированный 16-разрядный канал DMA. Конструктив - 62-контактный разъем XT-Bus с прилегающим к нему 36-контактным разъемом расширения.

EISA (Enhanced ISA - расширенная ISA) - функциональное и конструктивное расширение ISA. Внешне разъемы имеют такой же вид, как и ISA, и в них могут вставляться платы ISA, но в глубине разъема находятся дополнительные ряды контактов EISA, а платы EISA имеют более высокую ножевую часть разъема с дополнительными рядами контактов. Разрядность - 32/32 (адресное пространство - 4 Гб), работает также на частоте 8 МГц. Предельная пропускная способность - 32 Мб/с. Поддерживает Bus Mastering - режим управления шиной со стороны любого из устройств на шине, имеет систему арбитража для управления доступом устройств у шине, позволяет автоматически настраивать параметры устройств, возможно разделение каналов IRQ и DMA.

MCA (Micro Channel Architecture - микроканальная архитектура) - шина компьютеров PS/2 фирмы IBM. Не совместима ни с одной дру- гой, разрядность - 32/32, (базовая - 8/24, остальные - в качестве расширений). Поддерживает Bus Mastering, имеет арбитраж и автоматическую конфигурацию, синхронная (жестко фиксирована длительность цикла обмена), предельная пропускная способность - 40 Мб/с. Конструктив - одно-трехсекционный разъем (такой же, как у VLB). Первая, основная, секция - 8-разрядная (90 контактов), вторая - 16-разрядное расширение (22 контакта), третья - 32-разрядное расширение (52 контакта). В основной секции предусмотрены линии для передачи звуковых сигналов. Дополнительно рядом с одним из разъемов может устанавливаться разъем видеорасширения (20 контактов). EISA и MCA во многом параллельны, появление EISA было обусловлено собственностью IBM на архитектуру MCA.

VLB (VESA Local Bus - локальная шина стандарта VESA) - 32-разрядное дополнение к шине ISA. Конструктивно представляет собой дополнительный разъем (116-контактный, как у MCA) при разъеме ISA. Разрядность - 32/32, тактовая частота - 25..50 МГц, предельная скорость обмена - 130 Мб/с. Электрически выполнена в виде расширения локальной шины процессора - большинство входных и выходных сигналов процессора передаются непосредственно VLB-платам без промежуточной буферизации. Из-за этого возрастает нагрузка на выходные каскады процессора, ухудшается качество сигналов на локальной шине и снижается надежность обмена по ней. Поэтому VLB имеет жесткое ограничение на количество устанавливаемых устройств: при 33 МГц - три, 40 МГц - два, и при 50 МГц - одно, причем желательно - интегриpованное в системную плату.

PCI (Peripheral Component Interconnect - соединение внешних компонент) - развитие VLB в сторону EISA/MCA. Не совместима ни с какими другими, разрядность - 32/32 (расширенный вариант - 64/64), тактовая частота - до 33 МГц (PCI 2.1 - до 66 МГц), пропускная способность - до 132 Мб/с (264 Мб/с для 32/32 на 66 МГц и 528 Мб/с для 64/64 на 66 МГц), поддержка Bus Mastering и автоконфигурации. Количество разъемов шины на одном сегменте ограничего четырьмя. Сегментов может быть несколько, они соединяются друг с другом посредством мостов (bridge). Сегменты могут объединяться в различные топологии (дерево, звезда и т.п.). Самая популярная шина в настоящее время, используется также на других компьютерах. Разъем похожа на MCA/VLB, но чуть длиннее (124 контакта). 64-разрядный разъем имеет дополнительную 64-контактную секцию с собственным ключом. Все разъемы и карты к ним делятся на поддерживающие уровни сигналов 5 В, 3.3 В и универсальные; первые два типа должны соответствовать друг другу, универсальные карты ставятся в любой разъем.

Существует также расширение MediaBus, введенное фирмой ASUSTek - дополнительный разъем содержит сигналы шины ISA.

PCMCIA (Personal Computer Memory Card International Association - ассоциация производителей плат памяти для персональных компьютеров) - внешняя шина компьютеров класса NoteBook. Другое название модуля PCMCIA - PC Card. Предельно проста, разрядность - 16/26 (адресное пространство - 64 Мб), поддерживает автоконфигурацию, возможно подключение и отключение устройств в процессе работы компьютера. Конструктив - миниатюрный 68-контактный разъем. Контакты питания сделаны более длинными, что позволяет вставлять и вынимать карту при включенном питании компьютера.

Какие типы микросхем памяти используются в системных платах?

Из микросхем памяти (RAM - Random Access Memory, память с произвольным доступом) используется два основных типа: статическая (SRAM - Static RAM) и динамическая (DRAM - Dynamic RAM).

В статической памяти элементы (ячейки) построены на различных вариантах триггеров - схем с двумя устойчивыми состояниями. После записи бита в такую ячейку она может пребывать в этом состоянии столь угодно долго - необходимо только наличие питания. При обращении к микросхеме статической памяти на нее подается полный адрес, который при помощи внутреннего дешифратора преобразуется в сигналы выборки конкретных ячеек. Ячейки статической памяти имеют малое время срабатывания (единицы-десятки наносекунд), однако микросхемы на их основе имеют низкую удельную плотность данных (порядка единиц Мбит на корпус) и высокое энергопотребление. Поэтому статическая память используется в основном в качестве буферной (кэш-память).

В динамической памяти ячейки построены на основе областей с накоплением зарядов, занимающих гораздо меньшую площадь, нежели триггеры, и практически не потребляющих энергии при хранении. При записи бита в такую ячейку в ней формируется электрический заряд, который сохраняется в течение нескольких миллисекунд; для постоянного сохранения заряда ячейки необходимо регенерировать - перезаписывать содержимое для восстановления зарядов. Ячейки микросхем динамической памяти организованы в виде прямоугольной (обычно - квадратной) матрицы; при обращении к микросхеме на ее входы вначале подается адрес строки матрицы, сопровождаемый сигналом RAS (Row Address Strobe - строб адреса строки), затем, через некоторое время - адрес столбца, сопровождаемый сигналом CAS (Column Address Strobe - строб адреса столбца). При каждом обращении к ячейке регенерируют все ячейки выбранной строки, поэтому для полной регенерации матрицы достаточно перебрать адреса строк. Ячейки динамической памяти имеют большее время срабатывания (десятки-сотни наносекунд), но большую удельную плотность (порядка десятков Мбит на корпус) и меньшее энергопотребление. Динамическая память используется в качестве основной.

Обычные виды SRAM и DRAM называют также асинхронными - потому, что установка адреса, подача управляющих сигналов и чтение/запись данных могут выполняться в произвольные моменты времени - необходимо только соблюдение временнЫх соотношений между этими сигналами. В эти временные соотношения включены так называемые охранные интервалы, необходимые для стабилизации сигналов, которые не позволяют достичь теоретически возможного быстродействия памяти. Существуют также синхронные виды памяти, получающие внешний синхросигнал, к импульсам которого жестко привязаны моменты подачи адресов и обмена данными; помимо экономии времени на охранных интервалах, они позволяют более полно использовать внутреннюю конвейеризацию и блочный доступ.

FPM DRAM (Fast Page Mode DRAM - динамическая память с быстрым страничным доступом) активно используется в последние несколько лет. Память со страничным доступом отличается от обычной динамической памяти тем, что после выбора строки матрицы и удержании RAS допускает многократную установку адреса столбца, стробируемого CAS, а также быструю регенерацию по схеме "CAS прежде RAS". Первое позволяет ускорить блочные передачи, когда весь блок данных или его часть находятся внутри одной строки матрицы, называемой в этой системе страницей, а второе - снизить накладные расходы на регенерацию памяти.

EDO (Extended Data Out - расширенное время удержания данных на выходе) фактически представляют собой обычные микросхемы FPM, на выходе которых установлены регистры-защелки данных. При страничном обмене такие микросхемы работают в режиме простого конвейера: удерживают на выходах данных содержимое последней выбранной ячейки, в то время как на их входы уже подается адрес следующей выбираемой ячейки. Это позволяет примерно на 15% по сравнению с FPM ускорить процесс считывания последовательных массивов данных. При случайной адресации такая память ничем не отличается от обычной.

BEDO (Burst EDO - EDO с блочным доступом) - память на основе EDO, работающая не одиночными, а пакетными циклами чтения/записи. Современные процессоры, благодаря внутреннему и внешнему кэшированию команд и данных, обмениваются с основной памятью преимущественно блоками слов максимальной ширины. В случае памяти BEDO отпадает необходимость постоянной подачи последовательных адресов на входы микросхем с соблюдением необходимых временных задержек - достаточно стробировать переход к очередному слову отдельным сигналом.

SDRAM (Synchronous DRAM - синхронная динамическая память) - память с синхронным доступом, работающая быстрее обычной асинхронной (FPM/EDO/BEDO). Помимо синхронного метода доступа, SDRAM использует внутреннее разделение массива памяти на два независимых банка, что позволяет совмещать выборку из одного банка с установкой адреса в другом банке. SDRAM также поддерживает блочный обмен. Основная выгода от использования SDRAM состоит в поддержке последовательного доступа в синхронном режиме, где не требуется дополнительных тактов ожидания. При случайном доступе SDRAM работает практически с той же скоростью, что и FPM/EDO.

PB SRAM (Pipelined Burst SRAM - статическая память с блочным конвейерным доступом) - разновидность синхронных SRAM с внутренней конвейеризацией, за счет которой примерно вдвое повышается скорость обмена блоками данных.

Микросхемы памяти имеют четыре основные характеристики - тип, объем, структуру и время доступа. Тип обозначает статическую или динамическую память, объем показывает общую емкость микросхемы, а структура - количество ячеек памяти и разрядность каждой ячейки. Например, 28/32-выводные DIP-микросхемы SRAM имеют восьмиразрядную структуру (8k*8, 16k*8, 32k*8, 64k*8, 128k*8), и кэш для 486 объемом 256 кб будет состоять из восьми микросхем 32k*8 или четырех микросхем 64k*8 (речь идет об области данных - дополнительные микросхемы для хранения признаков (tag) могут иметь другую структуру). Две микросхемы по 128k*8 поставить уже нельзя, так как нужна 32-разрядная шина данных, что могут дать только четыре параллельных микросхемы. Распространенные PB SRAM в 100-выводных корпусах PQFP имеют 32-разрядную структуру 32k*32 или 64k*32 и используются по две или по четыре в платах для Pentuim.

Аналогично, 30-контактные SIMM имеют 8-разрядную структуру и ставятся с процессорами 286, 386SX и 486SLC по два, а с 386DX, 486DLC и обычными 486 - по четыре. 72-контактные SIMM имеют 32-разрядную структуру и могут ставиться с 486 по одному, а с Pentium и Pentium Pro - по два. 168-контактные DIMM имеют 64-разрядную структуры и ставятся в Pentium и Pentium Pro по одному. Установка модулей памяти или микросхем кэша в количестве больше минимального позволяет некоторым платам ускорить работу с ними, используя принцип расслоения (Interleave - чередование).

Время доступа характеризует скорость работы микросхемы и обычно указывается в наносекундах через тире в конце наименования. На более медленных динамических микросхемах могут указываться только первые цифры (-7 вместо -70, -15 вместо -150), на более быстрых статических "-15" или "-20" обозначают реальное время доступа к ячейке. Часто на микросхемах указывается минимальное из всех возможных времен доступа - например, распространена маркировка 70 нс EDO DRAM, как 50, или 60 нс - как 45, хотя такой цикл достижим только в блочном режиме, а в одиночном режиме микросхема по-прежнему срабатывает за 70 или 60 нс. Аналогичная ситуация имеет место в маркировке PB SRAM: 6 нс вместо 12, и 7 - вместо 15. Микросхемы SDRAM обычно маркируются временем доступа в блочном режиме (10 или 12 нс).

Ниже приведены примеры типовых маркировок микросхем памяти; в обозначении обычно (но не всегда) присутствует объем в килобитах и/или структура (разрядность адреса и данных).

Статические:

61256           - 32k*8 (256 кбит, 32 кб)
62512           - 64k*8 (512 кбит, 64 кб)
32C32           - 32k*32 (1 Мбит, 128 кб)
32C64           - 64k*32 (2 Мбит, 256 кб)

Динамические:

41256           - 256k*1 (256 кбит, 32 кб)
44256, 81C4256  - 256k*4 (1 Мбит, 128 кб)
411000, 81C1000 - 1M*1 (1 Мбит, 128 кб)
441000, 814400  - 1M*4 (4 Мбит, 512 кб)
41C4000         - 4M*4, (16 Мбит, 2 Мб)
MT4C16257       - 256k*16 (4 Мбит, 512 кб)
MT4LC16M4A7     - 16M*8 (128 Мбит, 16 Мб)
MT4LC2M8E7      - 2M*8 (16 Мбит, 2 Мб, EDO)
MT4C16270       - 256k*16 (4 Мбит, 512 кб, EDO)

Микросхемы EDO часто (но далеко не всегда) имеют в обозначении "некруглые" числа: например, 53C400 - обычная DRAM, 53C408 - EDO DRAM.

Что такое DIP, SIP, SIPP, SIMM, DIMM, CELP, COAST?

Это обозначения корпусов микросхем и типов модулей памяти. DIP (Dual In line Package - корпус с двумя рядами выводов) - классические микросхемы, применявшиеся в блоках основной памяти XT и ранних AT, а сейчас - в блоках кэш-памяти. SIP (Single In line Package - корпус с одним рядом выводов) - микросхема с одним рядом выводов, устанавливаемая вертикально. SIPP (Single In line Pinned Package - модуль с одним рядом проволочных выводов) - модуль памяти, вставляемый в панель наподобие микросхем DIP/SIP; применялся в ранних AT.

SIMM (Single In line Memory Module - модуль памяти с одним рядом контактов) - модуль памяти, вставляемый в зажимающий разъем; применяется во всех современных платах, а также во многих адаптерах, принтерах и прочих устройствах. SIMM имеет контакты с двух сторон модуля, но все они соединены между собой, образуя как бы один ряд контактов.

DIMM (Dual In line Memory Module - модуль памяти с двумя рядами контактов) - модуль памяти, похожий на SIMM, но с раздельными контактами (обычно 2 x 84), за счет чего увеличивается разрядность или число банков памяти в модуле. Применяется в основном в компьютерах Apple и новых платах P5 и P6.

На SIMM в настоящее время устанавливаются преимущественно микросхемы FPM/EDO/BEDO, а на DIMM - EDO/BEDO/SDRAM.

CELP (Card Egde Low Profile - невысокая карта с ножевым разъемом на краю) - модуль внешней кэш-памяти, собранный на микросхемах SRAM (асинхронный) или PB SRAM (синхронный). По внешнему виду похож на 72-контактный SIMM, имеет емкость 256 или 512 кб. Другое название - COAST (Cache On A STick - буквально "кэш на палочке").

Модули динамической памяти, помимо памяти для данных, могут иметь дополнительную память для хранения битов четности (Parity) для байтов данных - такие SIMM иногда называют 9- и 36-разрядными модулями (по одному биту четности на байт данных). Биты четности служат для контроля правильности считывания данных из модуля, позволяя обнаружить часть ошибок (но не все ошибки). Модули с четностью имеет смысл применять лишь там, где нужна очень высокая надежность - для обычных применений подходят и тщательно проверенные модули без четности, при условии, что системная плата поддерживает такие типы модулей.

Проще всего определить тип модуля по маркировке и количеству микросхем памяти на нем: например, если на 30-контактном SIMM две микросхемы одного типа и одна - другого, то две первых содержат данные (каждая - по четыре разряда), а третья - биты четности (она одноразрядная). В 72-контактном SIMM с двенадцатью микросхемами восемь из них хранят данные, а четыре - биты четности. Модули с количеством микросхем 2, 4 или 8 не имеют памяти под четность.

Иногда на модули ставится так называемый имитатор четности - микросхема-сумматор, выдающая при считывании ячейки всегда правильный бит четности. В основном это предназначено для установки таких модулей в платы, где проверка четности не отключается; однако, существуют модули, где такой сумматор маркирован как "честная" микросхема памяти - чаще всего такие модули производятся в Китае.

72-контактные SIMM имеют четыре специальных линии PD (Presence Detect - обнаружение наличия), на которых при помощи перемычек может быть установлено до 16 комбинаций сигналов. Линии PD используются некоторыми "Brand name"-платами для определения наличия модулей в разъемах и их параметров (объема и быстродействия). Большинство универсальных плат производства "третьих фирм", как их выпускаемые ими SIMM, не используют линий PD.

В модулях DIMM, в соответствии со спецификацией JEDEC, технология PD реализуется при помощи перезаписываемого ПЗУ с последовательным доступом (Serial EEPROM) и носит название Serial Presence Detect (SPD). ПЗУ предствляет собой 8-выводную микросхему, размещенную в углу платы DIMM, а его содержимое описывает конфигурацию и параметры модуля. Системные платы с chiset'ами 440LX/BX могут использовать SPD для настройки системы управления памятью. Некоторые системные платы могут обходиться без SPD, определяя конфигурацию модулей обычным путем - это стимулирует выпуск рядом производителей DIMM без ПЗУ, не удовлетворяющих спецификации JEDEC.

Что такое кэш и зачем он нужен?

Cache (запас) обозначает быстродействующую буферную память между процессором и основной памятью. Кэш служит для частичной компенсации разницы в скорости процессора и основной памяти - туда попадают наиболее часто используемые данные. Когда процессор первый раз обращается к ячейке памяти, ее содержимое параллельно копируется в кэш, и в случае повторного обращения в скором времени может быть с гораздо большей скоростью выбрано из кэша. При записи в память значение попадает в кэш, и либо одновременно копируется в память (схема Write Through - прямая или сквозная запись), либо копируется через некоторое время (схема Write Back - отложенная или обратная запись). При обратной записи, называемой также буферизованной сквозной записью, значение копируется в память в первом же свободном такте, а при отложенной (Delayed Write) - когда для помещения в кэш нового значения не оказывается свободной области; при этом в память вытесняются наименее используемая область кэша. Вторая схема более эффективна, но и более сложна за счет необходимости поддержания соответствия содержимого кэша и основной памяти.

Сейчас под термином Write Back в основном понимается отложенная запись, однако это может означать и буферизованную сквозную.

Память для кэша состоит из собственно области данных, разбитой на блоки (строки), которые являются элементарными единицами информации при работе кэша, и области признаков (tag), описывающей состояние строк (свободна, занята, помечена для дозаписи и т.п.). В основном используются две схемы организации кэша: с прямым отображением (direct mapped), когда каждый адрес памяти может кэшироваться только одной строкой (в этом случае номер строки определяется младшими разрядами адреса), и n-связный ассоциативный (n-way associative), когда каждый адрес может кэшироваться несколькими строками. Ассоциативный кэш более сложен, однако позволяет более гибко кэшировать данные; наиболее распространены 4-связные системы кэширования.

Процессоры 486 и выше имеют также внутренний (Internal) кэш объемом 8-16 кб. Он также обозначается как Primary (первичный) или L1 (Level 1 - первый уровень) в отличие от внешнего (External), расположенного на плате и обозначаемого Secondary (вторичный) или L2. В большинстве процессоров внутренний кэш работает по схеме с прямой записью, а в Pentium и новых 486 (Intel P24D и последние DX4-100, AMD DX4-120, 5x86) он может работать и с отложенной записью. Последнее требует специальной поддержки со стороны системной платы, чтобы при обмене по DMA можно было поддерживать согласованность данных в памяти и внутреннем кэше. Процессоры Pentium Pro имеют также встроенный кэш второго уровня объемом 256 или 512 кб.

В платах 386 чаще всего использовался внешний кэш объемом 128 кб, для 486 - 128..256 кб, для Pentium - 256..512 кб. На платах 386, 486 и ранних Pentium весь кэш набирался из асинхронных микросхем SRAM. Сейчас в последних используется конвейерный кэш с блочным доступом (PBC - Pipelined Burst Cache) на основе микросхем PB SRAM; другое его название - синхронный кэш. Для хранения признаков по-прежнему используются асинхронные SRAM. Применение синхронного кэша совместно с обычной памятью примерно на 15% ускоряет последовательный обмен, однако использование совместно с EDO RAM часто не приводит к сколько-нибудь заметному выигрышу в скорости - для этого нужны достаточно крупные задачи, в которых постоянно пересылаются большие (сотни килобайт) массивы данных.

Что такое Shadow Memory?

Это так называемая теневая память. В адресах памяти от 640 кб до 1 Мб (A0000-FFFFF) находятся "окна", через которые видно содержимое различных системных ПЗУ. Например, окно F0000-FFFFF занимает системное ПЗУ, содержащее системный BIOS, окно C0000-C7FFF - ПЗУ видеоадаптера (видео-BIOS), и т.п. При включении для каких-либо окон режима Shadow содержимое их ПЗУ копируется в участки ОЗУ, которые затем подключаются к этим же адресам вместо ПЗУ, "затеняя" их; запись в эти участки аппаратно запрещается для полной имитации ПЗУ. Это дает в первую очередь ускорение работы с программами/данными ПЗУ за счет более высокого быстродействия микросхем ОЗУ. Кроме этого, появляется возможность модифицировать видимое содержимое ПЗУ (почти все современные системные BIOS используют это для самонастройки). В области видео-BIOS можно поменять экранные шрифты и т.п.

Управлением теневой памятью занимается Chiрset платы, поэтому не все платы позволяют это делать (хотя сейчас таких плат практически не осталось). Есть различные программы для создания средствами теневой памяти UMB-блоков в MS DOS или для загрузки экранных шрифтов в область видео-BIOS (например, S_FONT).

Что такое Memory Relocation?

Это перенос неиспользуемой памяти из системной области (640 кб - 1 Мб) в область расширенной (Extended) памяти. В первых IBM PC устанавливалось 640 кб основной памяти и отдельно - расширенная память, поэтому со старшими 384 кб проблем не возникало. В современных платах вся память представляет собой непрерывный массив, поэтому системную область приходится аппаратно исключать, теряя при этом 384 кб. Большинство Chiрset'ов позволяют использовать часть этой памяти под Shadow Memory, однако некоторые (Neat, OPTi495, SiS471 и т.п.) могут переносить ее за пределы пеpвого мегабайта, пpисоединяя к pасширенной памяти. Одни Chipset'ы могут переносить все свободные от Shadow участки, другие - только все 384 кб целиком (в этом случае должны быть отключены все Shadow).

Что такое VRM?

Voltage Regulator Module - модуль регулятора напряжения. Служит для формирования нужных напряжений питания процессора. Разработан для того, чтобы существующие системные платы могли поддерживать новые типы процессоров, которые появятся в будущем. На платах, поддерживающих VRM, для него есть специальный двухрядный разъем с пластмассовым обрамлением, расположенный обычно рядом с процессором или его стабилизатором питания.

Что означает термин "Green Motherboard"?

Системная плата с поддержкой энергосбережения. Chipset и BIOS платы поддерживают снижение частоты процессора при перерывах в работе, отключение винчестера и монитора при отсутствии обращений к ним, и т.п. Отношение специалистов к данным режимам неоднозначное: при чрезмерно частом (десятки раз в сутки) отключении монитора или винчестера экономия энергии будет мизерной, зато заметно возрастет шанс выхода их из строя.

Как расшифровать "RAS to MA Delay", "DRAM Read WS" и пр.?

Это параметры управления внешним кэшем и системной памятью, описывающие временнЫе диаграммы циклов чтения/записи. Все значения задаются в тактах - периодах системной тактовой частоты (частоты платы, а не внутреннеей частоты процессора).

Простой цикл обращения к памяти выполняется за два такта. В пакетном цикле (burst) первый обмен занимает два такта, остальные - по одному такту. Например, диаграмма 2-1-1-1 обозначает четырехсловный пакетный цикл без дополнительных задержек, 3-1-1-1 - с одной задержкой после первого обращения, 3-2-2-2 - с задержками после каждого обращения, и т.п.

Поскольку задержки задаются дискретно, при увеличении системной тактовой частоты общая производительность иногда может упасть. Например, при частоте 40 МГц длительность такта - 25 нс, что позволяет обмениваться с внешним кэшем 20 нс без задержек, а при 50 МГц такт занимает 20 нс, и такой кэш может перестает успевать. Добавление же одного такта задержки резко снижает пиковую производительность системы, хотя средняя производительность за счет достаточно медленной памяти изменяется незначительно.

Полный перечень всех возможных пунктов настройки слишком велик, к тому же он постоянно меняется. Кроме этого, для сознательного управления этими параметрами нужно хорошо представлять себе механизмы работы статических и динамических микросхем памяти, организации страничного обмена, конвейеризации и т.п. Описание параметров конкретной платы обычно можно найти на FTP/WWW-сервере производителя платы или ее BIOS. Вкратце можно сказать, что "WS" обозначает "Wait States" (такты задержки до или после операции), а "Clocks" или "Clk" - такты на саму операцию. Таким образом, увеличение параметров приводит к замедлению работы при возрастании надежности взаимодействия блоков платы, а уменьшение - к ускорению ценой снижения запаса по устойчивости (возможны значения, при которых плата не сможет работать вообще). Обычно ничем страшным слепой перебор параметров не грозит, так что можно попробовать слегка ускорить работу платы, однако заметного реального выигрыша по сравнению с Auto Configuration это не даст.

Что обозначают другие параметры Setup?

  • ISA Clock Frequency

    Тактовая частота шины ISA. На большинстве плат она получается делением основной частоты платы (25/33/40/50 МГц) на указанный в параметре делитель. Стандартом предусмотрена частота 8 МГц, однако большинство плат успешно работает на 10-13 МГц, а некоторые - и на 16-20-25 МГц. Повышение частоты ускоряет обмен с платами (на другие шины она никак не влияет), но возрастает риск ошибок при работе (особенно это опасно для контроллеров дисков - могут искажаться передаваемые данные).

  • COMn MIDI

    Для переключения портов COM1 или COM2 в режим совместимости с MIDI (Musical Instrument Digital Interface - цифровой интерфейс музыкальных инструментов). В этом режиме частота тактирования приемопередатчика порта повышается, чтобы при настройке на стандартную скорость 28800 бит/с (делитель частоты 4) порт фактически работал на стандартной для MIDI скорости 31250 бит/с. Однако это не делает последовательный порт программно совместимым с MIDI-портом звуковых карт - кроме адаптера, понадобится еще и программная поддержка обычного COM-порта.

  • Memory Hole at 15-16 Мb

    Буквально - дыра в памяти в диапазоне 15-16 Мб, для чего в ней запрещается или переносится один мегабайт. Это нужно для совместимости со старыми картами, использующими отображение памяти на область под 16 Мб (например, некоторые ранние видеокарты высокого разрешения).

  • CPU Burst Write, PCI Read/Write Burst

    Режим блочных чтения/записи с памятью или PCI. В обычном режиме на каждое считываемое или записываемое слово выдается отдельный адрес, в блочном адрес выдается один раз, а затем подряд выполняется серия чтений/записей, что работает быстрее.

  • IDE Prefetch Buffer

    Буфер предвыборки IDE. Служит для ускорения чтения из буфера диска, сокращая время занятия шины компьютера. На контроллере SiS496 (платы для процессоров 486) при одновременной работе двух устройств (неважно, на одном или разных каналах) возникают конфликты, приводящие к искажению передаваемых данных. Из-за этого новые BIOS стараются отключать этот буфер при обнаружении второго устройства, однако не все версии BIOS это проверяют. Похожие ошибки имеются в контроллерах RZ-1000 и CMD-640.

  • CAS Before RAS Refresh

    Метод регенерации памяти, когда сигнал CAS устанавливается раньше сигнала RAS. В отличие от стандартного способа регенерации, это не требует перебора адресов строк извне микросхем памяти - используется внутренний счетчик адресов. Благодаря этому обеспечивается полная регенерация даже в том случае, когда конфигурация памяти не поддерживается Chipset'ом платы. Однако, этот способ регенерации должен поддерживаться микросхемами памяти (большинство микросхем его поддерживает).

  • PCI Latency Timer

    Таймер, ограничивающий время занятия устройством-задатчиком шины PCI. По истечении заданного времени (в тактах шины) арбитр принудительно отбирает шину у задатчика, передавая ее другому устройству. Полезен для систем с несколькими интенсивно работающими в режиме Bus Mastering PCI-устройствами.

  • Passive Release

    Способность арбитра chipset'ов Triton VX/HX отбирать шину у Bus Mastering-устройств при отсутствии в течение какого-то времени запросов на передачу с их стороны. Для корректной работы ISA-карт, использующих DMA (звуковые карты, Arvid-1020) режим должен быть отключен (disabled).

    • Почему при установке VLB-плат иногда начинаются сбои?

    Основная причина - в перегрузке выходных каскадов процессора. Вначале Можно попробовать поискать на системной плате перемычки, управляющие работой VLB; если они не помогают - снизить входную частоту процессора, особенно если она равна 40 или 50 МГц, переставить VLB-платы в разъемах, заменить VLB-платы или сам процессор (иногда бывает, что у процессора "не тянет" один из выходных каскадов, или одна из входных цепей конкретной VLB- платы слишком нагружает шину). Поскольку память нередко располагается непосредственно на локальной шине - может помочь замена модулей на другие или сокращение их количества (например, один модуль 16 Мб вместо четырех по 4 Мб).

    Почему некоторые платы не любят SIMM по 512 кб, 2 и 8 Мб?

    Потому, что это - так называемые "нечетные" модули. Память в SIMM организована в виде матрицы, и в идеале число строк и столбцов равно (например, 30-контактный SIMM на 256 кб имеет по 9 строк и столбцов, а 72-контактный на 4 Мб - по 10). В "нечетных" модулях одной строки нет, что может приводить к ошибкам определения размера в платах, которые этого не предусматривают. Кроме этого, 72-контактные SIMM используют так называемую "двухбанковую" (Double Bank, Double Sided) систему, когда один модуль содержит как бы два независимых банка половинного размера, и работает, как два параллельных модуля (это не имеет никакого отношения к физическому расположению микросхем на сторонах модуля). Поддержка таких модулей, особенно в сочетании с другими, есть не во всех системных платах.

    На что следует обратить внимание при покупке системной платы?

    Прежде всего - на ее внешний вид. Детали должны быть установлены ровно и аккуратно, пайка - блестящей, ровной и однородной. Криво установленные детали, "пузыри" припоя и непропаяные выводы обычно встречаются на платах китайского производства и говорят об общем качестве работы. Если плата заметно выгнута в одну сторону - есть вероятность наличия микротрещин в дорожках или кристаллах микросхем. Также могут быть неровно впаяны разъемы для SIMM, что гpозит плохим контактом или вообще невозможностью вставить некоторые модули.

    Желательно, чтобы на микросхемах Chipset'а были собственные обозначения (OPTi895, SiS496, UMC8881 и т.п.). Надписи типа "PC Chips" обычно наносятся на немаркированные микросхемы, полученные окольными путями - здесь высока вероятность брака. Вообще, чем больше технических обозначений - тем лучше. Не приветствуются наклейки, особенно с надписями типа "Write Back" вместо названий. При сомнениях можно снять наклейку, чтобы посмотреть настоящую маркировку чипа.

    Микросхемы кэша (для 386/486 - обычно 28/32-выводные DIP-корпуса) должны быть установлены на панельках и иметь правдоподобные обозначения (например, UM61256-15, 9512 - это означает микросхему UMC, 256 кбит, 15 нс, выпущенную на 12 неделе 95 года). Если на плате для 486 микросхемы впаяны или на них что-то написано словами - это наверняка просто корпуса с выводами, и никакого кэша у вас не будет. Это не относится к платам для Pentium, которые часто имеют впаянные микросхемы синхронного кэша с выводами по четырем сторонам корпуса, однако и такие микросхемы помимо словесного должны иметь буквенно-цифровое обозначение. Для верности можно запустить программу CCT - при наличии кэша на графике должен быть линейный спад за его границей.

    На качество платы может косвенно указывать ее упаковка и документация. Хорошие платы обычно имеют названия, поставляются в коробках и снабжаются подробной документацией в хорошо оформленной книжке. Однако бывает и так, что безродная плата с невзрачной книжечкой по совокупности характеристик оказывается лучше, чем фирменная - последнее слово должно быть за тестированием.

    Можно также обратить внимание на детали, установленные сразу же за разъемами шин: нередко они не позволяют нормально вставить платы в эти разъемы; с другой стороны, процессор и/или стабилизаторы питания могут мешать установке длинных плат.

    Имеется в продаже довольно большое количество плат с неработающим 16-разрядным DMA (High DMA). Это не позволяет использовать платы Арвид модели 1020 и большинство звуковых плат. Проще всего проверить это установкой 16-разрядной звуковой платы и попробовать запись/воспроизведение 16-разрядного звука.

    Также в последнее время распространены платы, для которых в документации заявлена поддержка процессоров со внутренним WB-кэшем (Intel P24D, Intel 486 с обозначением "&EW", AMD DX4 с суффиксом "B", Cyrix, процессоры 5x86), но реально этой поддержки нет. Простейшая проверка - вставить такой процессор (не забыв выставить перемычки), записать пару десятков мелких файлов-архивов на дискету, после чего вынуть дискету, вставить обратно, перечитать, проверить файловую структуру (командой Chkdsk) и целостность архивов (обычно ключом "t" или "-t"). Если поддержка WB-кэша не работает - файловая структура почти наверняка окажется разрушенной, а сами файлы - записаны с ошибками.

    У меня на DX2-80 Sysinfo показывает 158, а у друга - 173!

    Дело в различных настройках Chipset'а. Точно так же на DX4-100 (с WT-кэшем) максимум - 199, а бывает и 132. Поскольку Sysinfo измеряет _пиковую_ производительность всей системы - процессора, кэша, памяти, Chipset'а - то один лишний такт ожидания на обращение к памяти или кэшу может сильно сказаться на результатах измерения. Реально потеря средней производительности ничтожна - от долей до единиц процентов, а иногда Sysinfo может и на более быстром (реально!) процессоре показать худшие результаты, чем на более медленном. Лучше всего измерять скорость на реальных задачах - например, архивированием файлов, компиляцией больших программ (не забывая о влиянии скорости обмена с винчестером) и т.п.

    Я забыл пароль на Setup (на загpузку) - что делать?

    Если забыт пароль на Setup, можно воспользоваться различными программами для снятия пароля типа AMIPASS, PASSCMOS и т.п. Если забыт пароль на загрузку - придется открывать компьютер. Почти на всех современных системных платах рядом с батарейкой есть перемычка для сброса CMOS-памяти (обычно - 4 контакта, нормальное положение - 2-3, сброс - 1-2 или 3-4; иногда - 3 или 2 контакта). Если такой перемычки найти не удалось, нужно взять кусок провода, один конец прижать к некрашеному участку корпуса, чтобы был хороший электрический контакт, а другим концом медленно провести по выводам всех больших микросхем (кроме процессора); если на плате есть микросхема с 24 выводами в два ряда - начать следует с нее. После этого включить компьютер - CMOS-память с большой вероятностью будет сброшена вместе с паролем.

    Выпаивать и тем более замыкать батарейку не имеет смысла - это чаще всего не приводит к успеху из-за конструкции схемы питания CMOS-памяти, а замыкание батарейки сильно сокращает срок ее службы.

    Если на плате нет батарейки, нужно поискать пластмассовый модуль с надписью "DALLAS" (это монолитный блок с батарейкой и микрос- хемой CMOS) - перемычка может быть возле него. Если перемычки нет - вам не повезло (к счастью, таких плат было выпущено не так много). Единственное, что в этом случае остается сделать - отключить FDD, HDD или вообще вынуть контроллер дисков; есть шанс, что BIOS, не найдя дисководов, сам предложит войти в Setup. На некоторых AMI BIOS можно сразу после включения держать нажатой клавишу Ins - при этом в CMOS-память загружаются стандартные параметры.

    Если на компьютере стоит Award BIOS 4.50G - можно попробовать "инженерный" пароль AWARD_SW (большими буквами). Также может сработать комбинация Ctrl-Alt-Del, Ins, но довольно трудно уловить правильный момент для нажатия Ins.

    Что происходит при замыкании контактов разъема Turbo?

    В компьютерах Turbo XT и ранних AT-286 кнопка Turbo была предназначена для повышения тактовой частоты процессора сверх номинальной с целью ускорения его работы; при этом устойчивая работа на этой частоте не гарантировалась. На более поздних и быстрых AT-286 и ранних 386 она, наоборот, снижала частоту, чтобы приблизить быстродействие к PC XT - многие старые программы пользовались для измерения времени скоростными параметрами XT, отчего на AT начинали работать с ошибками.

    В начале 90-х годов, на последних AT-286 и 386/486 был введен другой способ управления скоростью: частота системного генератора была постоянной, а при замыкании контактов Turbo принудительно замедлялась работа с внешним кэшем и памятью. Для большинства программ это не давало заметного эффекта, поскольку сам процессор и его внутренний кэш продолжали работать с обычной скоростью.

    На многих современных платах для Pentium и Pentium Pro контакты Turbo выполняют функцию Suspend - приостановки работы платы и внешних устройств путем перехода в режим энергосбережения (Green Mode). Suspend обычно может быть запрещен опцией в Setup - тогда кнопка Turbo не влияет на работу системы. На некоторых новых платах замыкание контактов снова понижает частоту системного генератора.

    Что такое PnP?

    Plug And Play - "вставь и играйся". Обозначает технологию, которая сводит к минимуму усилия по подключению новой аппаратуры. PnP-карты не имеют перемычек конфигурации или особых программ настройки; вместо этого общий для компьтера PnP-диспетчер (отдельная программа либо часть BIOS или ОС) сам находит каждую из них и настраивает на соответствующие адреса, линии IRQ, DMA, области памяти, предотвращая совпадения и конфликты.

    PnP BIOS обычно обозначает BIOS с поддержкой такой настройки, однако настройка карт на различных шинах различается, и PnP BIOS на плате с шинами ISA/PCI, может уметь настраивать только PCI-карты, а для ISA потребуется поддержка со стороны ОС или отдельный настройщик (например, ISA PnP Configuration Manager от Intel).

    PnP Manager записывает параметры конфигурации в ESCD (Extended System Configuration Data - данные расширенной системной конфигурации). Внешний PnP Manager использует для данных файл на диске, а PnP BIOS - собственное Flash-ПЗУ. Если в процессе конфигурации PnP-устройств обнаружены изменения - выдается сообщение "Updating ESCD..." и делается попытка записать изменения в ПЗУ. В случае успеха выдается сообщение "Success", отсутствие которого означает невозможность перепрограммирования Flash-ПЗУ (не установлена перемычка, стоит ПЗУ обычного типа или неисправны цепи программирования Flash-ПЗУ на системной плате).

    Я попытался перешить у себя Flash и запорол его :( Что делать?

    Прежде всего - выяснить, уцелел ли в ПЗУ так называемый Boot Block - небольшая стартовая программа, позволяющая восстановить прошивку в подобных случаях. Boot Block работает только с простейшими устройствами - видеокартой ISA и контроллером FDD. Если после установки видеокарты на экране появляются сообщения Boot Block'а - нужно подготовить загрузочную дискету с DOS минимальной конфигурации (без config.sys и autoexec.bat), записать на нее заведомо работающую версию программы прошивки Flash и подходящую прошивку BIOS, после чего загрузить систему с дискеты и запустить программу прошивки. Иногда Boot Block может оказаться не в состоянии запустить клавиатурный контроллер платы - в этом случае придется создать на дискете autoexec.bat, запускающий программу в автоматическом режиме.

    Если Boot Block не запускается - можно воспользоваться методом, предложенным Lesha Bogdanow, 2:5095/9:

  • Беpем любую pаботающую мать, поддеpживающую флэш (совеpшенно необязательно, чтоб она была на том же чипсете, на котоpый pассчитан BIOS, котоpый мы хотим записать). Можно пpосто найти флэш или ПЗУ от матеpи, аналогичной той, флэш из котоpой мы будем пеpеписывать, и вpеменно поставить его (пеpеставив, если нужно, джампеpа типа флэша). Или, если есть пpогpамматоp, только он не умеет писать флэш - найти ПЗУ подходящего pазмеpа и записать его.

  • Вынимаем флэш или ПЗУ из этой матеpи, обвязываем его с двух концов двумя кольцами МГТФа (чтоб можно было его легко извлечь) и неплотно втыкаем назад в панельку.

  • Загpужаемся в "голый" ДОС, выдеpгиваем за эти два кольца стоящий в матеpи флэш или ПЗУ (все pавно он нужен только пpи загpузке), если нужно, пеpеставляем джампеpа типа флэша, и вставляем флэш, котоpый нужно записать. Главное тут - ничего не замкнуть :)

  • Запускаем пpогpамму записи, pассчитанную на мать, на котоpой пишем, BIOS с котоpым гpузились и флэш, котоpый нужно записать (пpогpамма должна уметь пеpеписывать флэш целиком, напpимеp, из комплекта mr-bios или asusовский pflash). Пишем, выключаем питание и вынимаем готовый флэш. Все.

    • Можно ли поставить процессор Intel 486 с суффиксом &W, AMD с суффиксом B, 5x86, если в книжке на плату таких нет?

    В ряде случаев - можно. i486 &W является аналогом P24D с питанием 3.3 В; AMD с суффиксом B и AMD/Cyrix 5x86 совместимы с ним, работая при напряжении питания 3.5-3.6 В.

    Если плата поддерживает P24D - остается лишь установить напряжение питания. На тех платах, где перемычки напряжения питания не описаны отдельно, их можно найти по таблице: например, для Intel SX/DX/SX2/DX2 и UMC U5S питание всегда 5 В, для Intel DX4 - 3.3 В, для AMD DX4 - 3.45 В; перемычки питания обычно выделены в отдельную группу и расположены вблизи стабилизатора. Для AMD 5x86 нужно также включить учетверение - перемычкой, которая задает удвоение для P24D.

    Если в документации на плату не указан P24D, или указан, но плата на самом деле его не поддерживает - нужно установить перемычки для Intel DX4-100 и перевести внутренний кэш в режим сквозной записи, соединив вывод B-13 с землей (иногда это можно сделать перемычкой, переключающей AMD DX4-100 в режим удвоения, лиао найти нужную перемычку омметром, либо соединить соответствующие контакты разъема процессора). В этом режиме процессор будет работать несколько медленнее, чем в режиме обратной записи. Учетверение в AMD 5x86 включается при соединении с землей вывода R-17 (перемычка режима удвоения для Intel DX4-100 и P24D).

    После установки нужно обязательно проверить правильность согласования внутреннего кэша с памятью - методом, описанным в рекомендациях по выбору системной платы.

    Можно ли поставить на плату P5-200, если в документации его нет?

    Можно. Дело в том, что аппаратура системной платы никогда не знает, на какой внутренней частоте работает процессор - она пос- тавляет ему только основную частоту (50, 60, 66, 75 или 80 МГц) и сигналы для выбора коэффициента умножения - BF0 и BF2 (Bus Frequency). На платах, разработанных до появления процессора P5-150, можно задавать только сигнал BF0 (1.5-2.0), а на современных платах - и BF2 (2.5-3.0). Для того, чтобы запустить умножение на 2.5 или 3 на старой плате, достаточно подать низкий уровень на вывод BF2 (X-34) в совокупности с установкой перемычки для BF0. Это можно сделать, например, соединив BF2 с ближайшим земляным выводом X-36, предварительно убедившись, что BF2 не соединен напрямую с питанием +3.3 В (в противном случае поможет только разборка разъема, удаление контакта, и соединение выводов прямо на процессоре тонким проводом).

    Если в документации на плату не выделены отдельно перемычки установки частоты и множителей - их можно определить по таблице стандартных частот:

     75 - 50 x 1.5
 90 - 60 x 1.5
100 - 66 x 1.5
120 - 60 x 2
133 - 66 x 2
150 - 60 x 2.5
166 - 66 x 2.5
180 - 60 x 3
200 - 66 x 3

    Единственная причина, по которой плата может не поддерживать процессоры с высокими внутренними частотами - недостаточная мощность стабилизатора питания.

    Почему процессоры AMD 5k86 на некоторых платах работают нестабильно?

    Причина, чаще всего - в недостаточности напряжения питания и плохом охлаждении процессора. Большинство процессоров 5k86 нуждается в напряжении питания не ниже 3.5 В, а многие платы с автоматическими регуляторами дают только 3.4 В. В то же время, у распространенных процессоров с суффиксами ABQ и ABR рабочая температура корпуса составляет 60 и 70 градусов - для ее поддержания нужен плотно прилегающий радиатор с достаточно хорошим вентилятором.

    Поставил новую плату, а на ней X00 вешает мышь. Что делать?

    Поставить X00 версии 1.53.

    (Для тех, кто не знает, что такое X00: это драйвер такой, у вас его нет и беспокоиться вам не о чем).

    Что такое USB, AGP, ACPI?

    USB (Universal Serial Bus - универсальная последовательная магистраль) - новый интерфейс для подключения различных внешних устройств. Предусматривает подключение до 127 внешних устройств к одному USB-каналу (по принципу общей шины), реализации обычно имеют по два канала на контроллер. Обмен по интерфейсу - пакетный, скорость обмена - 12 Мбит/с.

    AGP (Accelerated Graphics Port - ускоренный графический порт) - интерфейс для подключения видеоадаптера к отдельной магистрали AGP, имеющей выход непосредственно на системную память. В системной памяти размещаются преимущественно параметры трехмерных объектов (текстуры, альфа-канал, z-буфер), требующие быстрого доступа со стороны как процессора, так и видеоадаптера. Интерфейс выполнен в виде отдельного разъема, в который устанавливается AGP-видеоадаптер.

    ACPI (Advanced Configuration Power Interface - интерфейс расширенной конфигурации по питанию) - предложенная Microsoft единая система управления питанием для всех компьютеров, наподобие используемой в NoteBook. В частности, позволяет предусмотрено сохранение состояния системы перед отключением питания, с последующим его восстановлением без полной перезагрузки.

    Что такое IR Connector?

    Infrared Connector - разъем для инфракрасного излучателя/приемника. Подключен к одному из встроенных COM-портов (обычно - COM2) и позволяет установить беспроводную связь с любым устройством, снабженным подобным излучателем и приемником. Работает по тому же принципу, что и пульты управления бытовой радиоаппаратурой.

    Чем отличаются наборы Intel Triton FX, VX, HX и TX?

    Название Triton объединяет семейство chipset'ов i430FX/VX/HX/TX для процессоров Pentium. Таблица основных характеристик наборов:

    FX | HX | VX | TX
    Типы RAM | FP/EDO | FP/EDO | FP/EDO/SD | FP/EDO/SD
    PCI | DataStream 2.0 | Concurrent 2.1 | Concurrent 2.1 | Concurrent 2.1
    Макс RAM | 128 Мб | 512 Мб | 128 Мб | 256 Мб
    Кэшируемая RAM | 64 Мб | 512 Мб | 64 Мб | 64 Мб
    Диагр FPM | 7-3-3-3 | 6-3-3-3 | 6-3-3-3 | 6-3-3-3
    Диагр EDO | 7-2-2-2 | 5-2-2-2 | 6-2-2-2 | 5-2-2-2
    Диагр SDRAM | 7-1-1-1 | 5-1-1-1
    ECC | Нет | Есть | Нет | Нет
    USB | Нет | Есть | Есть | Есть
    EIDE | PIIX | PIIX3 | PIIX3 | PIIX4

    Диаграммы обмена с памятью приведены для случая отсутствия дополнительных тактов ожидания. В отношении внешнего кэша все наборы работают с диаграммой 3-1-1-1.

    В наборах Triton используется три типа контроллеров EIDE (PIIX - PCI/ISA IDE Xcelerator): PIIX (i371FB) - ATA-2 без возможности раздельной установки режимов PIO/DMA для устройств Master/Slave (режим выбирается по наиболее медленному из устройств), PIIX3 (i371SB) - ATA-2 с возможностью раздельной установки, и PIIX4 (i371AB) - Ultra ATA с поддержкой режима Ultra DMA-33.

    Набор HX поддерживает как микросхемы ECC в модулях памяти, так и формирование ECC из разрядов четности.

    Наборы VX и TX ориентированы Intel на офисные и домашние компьютеры, набор HX - на серверы и мощные рабочие станции.

    Чем отличаются наборы VIA Apollo VPX, VP2, VP3?

    VPX | VP2 | VP3
    Макс RAM | 512 Мб | 512 Мб | 1 Гб
    ECC | Нет | Есть | Есть
    AGP | Нет | Нет | Есть

    Максимальный объем внешнего кэша для всех наборов - 2 Мб, кэшируется полный объем системной памяти. Все наборы поддерживают SDRAM, микросхемы памяти объемом 64 Мбит, режим UDMA/33, ACPI, имеют контроллер USB, интегрированный контроллер клавиатуры (KBC) и контроллер часов реального времени с CMOS-памятью RTC). Для набора VPX декларирована поддержка системной частоты 75 МГц.

    Диаграммы работы с памятью для всех наборов: FPM/EDO - 4-2-2-2 SDRAM - 5-1-1-1, при двух банках - 3-1-1-1

    Что за Chipset'ы VX-Pro, HX-Pro, TX-Pro?

    Наборы VX-Pro и HX-Pro производятся малоизвестными фирмами в Юго-Восточной Азии (предположительно PC Chips), имеют низкую надежность и предназначены для установки в дешевые системные платы местного производства; названия наборов происходят исключительно из рекламных предпосылок и не имеют ничего общего с наборами Intel Triton.

    TX-Pro - перемаркированный теми же фирмами набор Aladin IV фирмы ALI.

    Как лучше выбрать частоту платы и внутренний множитель процессора?

    Если одну и ту же внутреннюю частоту процессора можно задать несколькими способами, то на более высокой входной частоте (на которой работает сама системная плата) обычно достигается более высокая производительность. Чаще всего это делается на недокументированных частотах - 75 или 83 МГц. Например, при работе программ, интенсивно пересылающих данные между памятью и шиной (анимация, игры, обработка больших баз данных и т.п.) конфигурация 75 x 2.5 = 187 превосходит конфигурацию 66 x 3 = 200, а 83 x 2.5 = 208 превосходит 75 x 3 = 225. Однако выигрыш будет только в том случае, если системная плата и PCI- устройства стабильно работают на повышенной частоте; если, например, на ней не успевает память или внешний кэш, то придется вводить дополнительные такты ожидания, которые могут свести на нет преимущество высокой частоты. Кроме этого, может потребоваться понижение на ступень скорости PIO в связи с тем, что временнЫе параметры PIO вычисляются из системной частоты и при ее завышении могут выйти за допустимые пределы.

    Как подключить к плате мышь PS/2?

    На многих современных платах есть разъем для мыши PS/2, однако в комплект не входит переходник для установки на заднюю стенку. Разводка разъема для мыши - 6-контактный разъем типа Female (гнездо) - такова (ключ снизу):

    Разводка совпадает с разъемом для клавиатуры PS/2. Соединитель на плате обычно представляет собой один ряд из пяти или шести контактов; стандарта на его разводку не существует. Если назначение сигналов не описано в документации, для определения соответствия достаточно найти контакты земли и питания, а сигналы Data и Clock можно затем найти экспериментально - их перестановка на короткое время не опасна.

    На некоторых системных платах потребуется также включить поддержку интерфейса PS/2 в BIOS Setup (страницы BIOS Features, Advanced Chipset или Integrated Peripherals), а также проследить за тем, чтобы была свободна используемая интерфейсом линия IRq 12.

    Как подключить мышь с другим типом интерфейса?

    Подключить обычную мышь для COM-порта (Serial Mouse) к порту PS/2 и наоборот в общем случае невозможно по причине разных ти- пов интерфейса. Некоторые модели Serial Mouse (например, Logitech) и PS/2 Mouse (MouseMan) имеют возможность работы по обоим интерфейсам и могут подключаться к интерфейсу другого типа через специальный переходник. Приблизительно определить поддержку двух интерфейсов можно по количеству задействованных контактов в разъеме - для работы по каждому типу интерфейса используется четыре сигнала.

    Какая плата нужна для работы процессора MMX?

    Для этого достаточно, чтобы плата обеспечивала двойное электропитание процессора напряжениями 2.5-2.9 В для ядра (core) и 3.3 В - для выходных буферов (I/O).

    Как использовать режим DMA/Bus Master на контроллере SiS496?

    Никак. Этот контроллер - только PCI EIDE, поддержки Bus Master там нет.

    - Как использовать режим DMA/Bus Master на контроллерах i371?

    Установить драйверы Bus Master от Triones или Intel, взяв их с программной дискеты от любой платы с таким же контроллером (FB или SB), или в Internet (файлы обычно называются BMIDE* или BUSMASTE).

    Что такое DMI?

    Desktop Management Interface - интерфейс управления рабочим местом. Служит для сбора информации о составе и работе компьютеров сети с целью накопления статистики или ведения базы данных по компьютерам организации. Поддержка DMI может быть также встроена в системный BIOS, что облегчает операционной системе отслеживание изменений в аппаратной конфигурации компьютера.

    Что такое SPP, ECP, EPP?

    Это режимы работы параллельного (LPT) порта:

    SPP (Standard Parallel Port - стандартный параллельный порт) - обычный интерфейс PC AT. Осуществляет 8-разрядный вывод данных с синхронизацией по опросу или по прерываниям. Максимальная скорость вывода - около 80 кб/с. Может использоваться для ввода информации по линиям состояния, максимальная скорость ввода - примерно вдвое меньше.

    EPP (Enhanced Parallel Port - расширенный параллельный порт) - скоростной двунаправленный вариант интерфейса. Изменено назначение некоторых сигналов, введена возможность адресации нескольких логических устройств и 8-разрядного ввода данных, 16-байтовый аппаратный FIFO-буфер. Максимальная скорость обмена - до 2 Мб/с.

    ECP (Enhanced Capability Port - порт с расширенными возможностями) - интеллектуальный вариант EPP. Введена возможность разделения передаваемой информации на команды и данные, поддержка DMA и сжатия передаваемых данных методом RLE (Run-Length Encoding - кодирование повторяющихся серий).

    Можно ли поменять умолчания в AWARD BIOS?

    В версиях, начиная с 4.50G - можно. Для этого нужно считать прошивку ПЗУ при помощи любой подходящей утилиты (PFlash, AwdFlash, 28C010 и т.п.) либо обычного программатора, и воспользоваться программами AwardBin или ModBin. Таким образом можно изменить стандартные временнЫе параметры для различных системных частот, умолчания, устанавливаемые командой "Load BIOS Defaults", инженерный пароль и прочее. Полученную в результате обновленную прошивку остается записать в ПЗУ утилитой или программатором.

    Можно ли использовать на плате прошивку BIOS от другой платы?

    Чаще всего - можно, если обе платы собраны на одинаковом Chipset'е и имеют одинаковые универсальные контроллеры ввода/вывода (Super I/O). Однако возможны несоответствия в нумерации разъемов PCI, SIMM, назначении сигналов внешнего контроллера 8042 и других тонкостях построения плат.

    Что такое ATX?

    AT Extension (расширение AT) - стандарт корпуса и системной платы для настольных компьютеров. Корпус представляет собой доработанный вариант корпуса Slim; плата (стандартный размер - 305 x 244) располагается в нем длинной стороной вдоль задней стенки. Блок питания имеет приточную систему вентиляции, процессор устанавливается в непосредственной близости от него для минимизации длины питающих цепей и охлаждения от встроенного вентилятора (для мощных процессоров все же требуется собственный вентиля- тор). Некоторые блоки имеют автоматическую регулировку скорости вращения вентилятора в зависимости от температуры.

    Блок питания ATX, кроме стандартных для AT напряжений и сигналов, обеспечивает также напряжение 3.3 В и имеет возможность включения и отключения основного питания по сигналу с платы, которая имеет для этого программный интерфейс. Имеется также отдельная линия слаботочного питания 5 В, напряжение на которой поддерживается постоянно и используется в цепях управления основным питанием для отслеживания внешних сигналов запуска по сети, модему и т.п.

    Для соединения блока питания с платой используется единый 20-контактный разъем. В стандарте ATX оговорен также необязательный разъем, через который с блока питания на плату подается информация о частоте вращения вентилятора, а с платы в блок питания - сигнал управления вентилятором и контрольный уровень напряжения 3.3 В для более точной его стабилизации.

    Наружные интерфейсные разъемы располагаются в области верхнего правого угла платы и могут устанавливаться друг над другом. Для разъемов расширения отведена левая половина платы (до семи разъемов); за счет вынесения процессора на правую сторону ограничения на длину устанавливаемых плат отсутствуют. Разъемы для модулей памяти расположены посередине, а интерфейсные разъемы дисков - в правом нижнем углу, в непосредственной близости от самих дисков.

    Выпускаются также стандартные платы формата AT, имеющие разъем для блока питания ATX и поддерживающие управление сетевым питанием.

    Чем импульсный стабилизатор отличается от линейного?

    Классический линейный стабилизатор напряжения питания процессора представляет собой активный регулирующий элемент (транзистор или микросхему), компенсирующий избыток питающего напряжения и рассеивающий его в виде тепла. С ростом тока, потребляемого процессором, мощность рассеяния такого стабилизатора достигает 10-15 Вт, что требует установки радиатора большой площади, принудительного охлаждения от процессорного вентилятора и, к тому же, ухудшает температурную картину внутри корпуса.

    Импульсный стабилизатор содержит реактивно-индуктивный LC-фильтр, на который короткими импульсами подается полное напряжение питания, и за счет инерции емкости и индуктивности выравнивается до требуемой величины, причем бесполезных потерь энергии практически не происходит. Стабильность напряжения поддерживается путем управления частотой и шириной импульсов (широтно-импульсная модуляция, ШИМ).

    Применение импульсных стабилизаторов позволяет значительно сократить тепловыделение, однако создает дополнительный источник помех, который может влиять на работу видео- и звуковых адаптеров.

    Почему плата на 440LX не понимает некоторые DIMM?

    Многие платы на 440LX, особенно производства Intel и других "элитных" производителей, используют для определения параметров DIMM только механизм SPD, что требует обязательного наличия на модулях конфигурационного ПЗУ. "Облегченные" модули без ПЗУ в таких платах работать не будут.

    Что такое PC/PCI и DDMA?

    Это аппаратные протоколы для обеспечения совместимости PCI-карт с традиционным способом прямого доступа к памяти (DMA). В стандартной реализации контроллера DMA он не может обслуживать устройства шины PCI - для этого в каждом устройстве реализуется протокол Bus Master. Протоколы PC/PCI и DDMA разработаны для совмещения контроллера DMA с PCI-устройствами; в первую очередь это сделано для разработки звуковых PCI-карт, совместимых с Sound Blaster и Windows Sound System.

    Протокол PC/PCI основан на выборочном переназначении на шину PCI сигналов запроса/выдачи данных, выведенных от каналов контроллера DMA на шину ISA, что позволяет PCI-устройству обмениваться с памятью под управлением основного контроллера DMA.

    Протокол DDMA (Distributed DMA - распределенный DMA) основан на выборочной передаче обращений к регистрам каналов контроллера DMA на шину PCI, где эти регистры эмулируются PCI-устройствами с поддержкой DDMA. Сам обмен с памятью в этом случае выполняется в режиме Bus Master, стандартном для PCI-устройств.

    Из распространенных chipset'ов протоколы PC/PCI и DDMA поддерживается в Intel 430TX, ALI Aladdin IV+, Aladdin V.

    Copyright (c) by iXBT, 1998. Produced by pavel@ixbt.com & gavric@ixbt.com
    Дизайн (с) 1998 студия РусАрт


Мистификация

В этой статье я расскажу о компьютерных методах обмана (в частности подмена IP-адресов, отправка анонимной почты и т.д.). Нужно это для того, чтобы выдать себя за другого и, следовательно, получить доступ к системе.

Типы мистификации:

- Подмена IP-адреса. Хакер использует IP-адрес другой машины (которая имеет доступ к цели хакера)

- Обман с помощью подделки идентификации личности – мистификация с помощью Web(на коммерческих сайтах). На коммерческих сайтах всегда используют идентификацию личности (т.е. Login и пароль), которые записываются в файлы cookies. Можно выдать себя за другого спомощью этих cookies или другим способом(см.ниже)

- Подделка адреса отправителя электронной почты. Любимый способ выдачи себя за другого.

- Социальная инженерия. Здесь без всяких компьютеров хакеру нужно выдать себя за другого (например, при разговоре по телефону).

ПОДМЕНА IP-АДРЕСА.

Подмена адреса заключается в том, что взломщик изменяет IP-адрес своего компа таким образом, чтобы его машину считали какой-то другой. Но не всё так легко, компьютер жертвы отвечает только машине с IP-адресом, который был подменён, а не машине хакера. Таким образом, взломщик будет отправлять пакеты жертве, а ответов от неё получать не будет ?. Но хакер может вклиниться между двумя машинами и получать сообщения обеих машин.

Чтобы изменить свой IP – адрес(Windows):

Хоть толку с этого и мало, но при DoS – атаках может помочь (т.к. с фальсифицированным IP-адресом злоумышленника найти сложнее). Кроме того, в соответствии с протоколом TCP-IP, связь устанавливается в три этапа. И поэтому комп жертвы будет “общаться” только с машиной, чей IP-адрес был подменён.

1. Открываем Пуск -> Настройка -> Панель управления.

2. Выбираем Сеть.

3. Выбираем пункт TCP-IP -> После этого откроется окно IP-адрес.

4. Там взломщик должен выбрать “Назначить IP-адрес” и ввести нужный IP.

Для Unix/Linux:

Пишем ifconfig eth0 x.x.x.x

(x.x.x.x – нужный адрес).

МИСТИФИКАЦИЯ С ПОМОЩЬЮ WEB

Здесь есть множество способов.

Например, вы видели, что при посещении некоторых адресов URL выглядит вот так:

http://www.xxx.ru/order/id=911199

Это означает, что вы пользователь с индификатором сеанса 911199. Если угадать номер другого сеанса, то можно вклиниться в активный сеанс.

Далее, когда кто-нибудь вводит свой логин и пароль на сайте, то они(логин и пароль) записываются в файлы cookie, чтобы в при следующем посещении можно было не вводить свои данные. Фишка в том, что можно угадать эти cookie (при многократном посещении) или просто своровать их у пользователя.

Существует ещё множество способов мистификации при помощи WEB(например, выдача своего сайта за сайт крупной банковской компании, т.е. у них сайт www.superbank.xxx.ru, а вы создадите www.sperbank.xxx.ru , то довольно много пользователей придут к вам и введут свои номера кредиток ;-)), но объёмы не позволяют описать всё...

ПОДДЕЛКА АДРЕСА ОТПРАВИТЕЛЯ ЭЛЕКТРОННОЙ ПОЧТЫ

Любимый способ, например, вы знаете, что в компанию наняли нового сотрудника с емэйлом ivan@company.ru. Можно отправить письмо начальнику компании (с емэйлом boss@comapny.ru) с текстом (предварительно создав почтовый аккаунт ivam@company.ru):

“Ля-лялялял (вы дурите босса жалобными словами) не могли бы вы мне ещё раз повторить мой логин и пароль... “

Если босс не заметить фальши (между ivan и ivam), то может и откликнется.

Для подделки почты используют AnonimityMail, Plasma или обычный клиент(типа Bat), но с заранее подменённым адресом.

СОЦИАЛЬНАЯ ИНЖЕНЕРИЯ

Вот здесь нужно постараться (комп вам не поможет). Если вы ходили на актёрские курсы, то вам повезло?. Заключается социнженерия вот в чём: вы звоните в компанию, уверяете что вы их сотрудник, и они отдают вам логин с паролем ;-). Этому искусству посвящено множество книг, я же дам несколько советов:

1. Будьте вежливы ( ну это естественно).

2. Не будьте слишком умными и слишком тупыми (а то могут неладное заподозрить) .

3. Не употребляйте слова админ(а употребляйте администратор), комп (- употребляёте компьютер),

юзер (пользователь) и т.п.

4. Желательно, чтобы вы сидели рядом с компьютером (чтобы ваш собеседник слышал как вы стучите по клаве).

5. Найдите слабое место собеседника (футбол, лети и др.)

Ну вот вроде и всё. Удачи!

Дата: 4.11.2003
Источник: HackZona


Настройка и оптимизация модемного соединения

Очень важным моментом в настройке Windows является оптимизация соединения с Интернет. Ведь от качества связи напрямую зависит время, проведенное вами в сети и соответственно затраты денег на это. Можно попытаться настроить соединение наилучшим образом, с минимальными потерями данных. Прежде, чем приступить к редактированию реестра, надо узнать несколько специальных терминов и уяснить соотношения между ними.

MTU

Это максимальный размер пакета данных, который может быть передан за один физический кадр по протоколу TCP/IP. Дело в том, что данные от компьютера к компьютеру в Интернете идут не сплошным потоком, а этими самыми кадрами - пакетами строго определенного размера. Если бы все компании и фирмы, имеющие хоть какое-то отношение к Интернету, договорились о едином стандарте на размер этих пакетов, то мы бы использовали каждый такой кадр по максимуму, полностью заполняя каналы передачи данных своими битами. Однако это не так. Мало того, что при установке нового соединения два удаленных компьютера должны согласовать между собой размер кадра, так еще и по пути к месту назначения пакет преодолевает целый ряд промежуточных серверов и маршрутизаторов, настройки MTU которых могут быть совершенно различными. При этом слишком большой пакет в пути, скорее всего, будет фрагментироваться и заполняться "воздухом", "балластом", что негативно скажется на эффективности связи. Так, если ваш провайдер имеет установки MTU=576, а у вас в Windows задано MTU=1500, то каждый ваш пакет будет им разбиваться на три по 576 байт: 576+576+576=1728 - то есть 228 байт балласта будут добавляться к каждому вашему пакету. Но даже если провайдер тоже поставил у себя MTU=1500, то при связи с удаленным сервером вполне может попасться маршрутизатор с меньшим значением MTU и пакеты опять-таки будут фрагментироваться, замедляя передачу данных.

Также нельзя забывать, что в процессе приема пакета может произойти сбой, тогда пакет придется принимать заново. Казалось бы, что чем меньше пакет, тем лучше, но в каждом пакете присутствует 40 байт служебной информации (об этом ниже), т.е. вам приходится принимать лишние байты, что не есть хорошо. Исходя из этих соображений, можно порекомендовать выставлять максимальное значение (1500) тем, у кого хорошее качество связи, что позволит избежать получения лишней служебной информации. Для тех, у кого качество связи оставляет желать лучшего, и часто происходят потери пакетов, можно порекомендовать выставлять значение MTU по минимому. В любом случае, лучше это значение подобрать экспериментально, выставляя его и проверяя скорость работы.

MSS

Каждый пакет данных в действительности состоит из нескольких сегментов - нескольких заголовков и фактических данных. Та его часть, в которой содержатся только фактические данные, называется MSS (Maximum Segment Size) - это еще один параметр протокола TCP, определяющий самый большой сегмент данных TCP, которые могут быть переданы за один раз. То есть, MTU = MSS + заголовки TCP/IP. Для заголовка тоже имеется общепринятый размер - это 40 байт (20 байт IP и 20 байт TCP), следовательно, обычно MSS = MTU - 40. По этой причине в определении оптимального размера MTU есть некоторые тонкости.

RWIN

RWIN (receive window, окно приема) - размер буфера, в котором накапливается содержимое области данных (MSS) нескольких полученных пакетов, прежде чем передается дальше, например, в браузер. При недостаточном размере этого буфера иногда происходит его переполнение, и поступающие пакеты отвергаются и теряются. Размер RWIN обязательно должен быть кратен MSS и обычно для лучшей эффективности модемного соединения кратность рекомендуется устанавливать равной 4-8. Однако чрезмерно большой размер буфера также нежелателен, особенно на плохих линиях - при потере всего одного пакета в случае сбоя на линии будет повторно затребован не один потерянный пакет, а все пакеты из этого буфера, что займет некоторое время.

TTL

TTL (time to live, время жизни) - количество хопов, то есть промежуточных серверов, через которые может пройти ваш пакет в поисках своего места назначения. Каждый такой сервер добавляет единицу к специальному счетчику в заголовке вашего пакета, и, когда счетчик достигает максимально разрешенного значения, пакет считается заблудившимся и прекращает свое существование. По умолчанию TTL равен 32, что сегодня явно недостаточно для разросшегося Интернета: нередки случаи, когда удаленный сервер находится более чем в 32 переходах, поэтому TTL следует увеличить как минимум до 64.

NDI Cache

NDI Cache (Network Device Interface Cache) - кэш, в котором хранятся данные о маршрутах движения пакетов, по умолчанию его размер равен нулю. Чтобы его задействовать наиболее оптимально, необходимо установить его размер равным 16 при модемном соединении или 32 при более скоростных подключениях.

Пожалуй, пора приступать к настройкам. Часть данных хранится в ветви HKEY_LOCAL_MACHINE в разделе System\CurrentControlSet\Services\Class\NetTrans\0000. Здесь 0000 - номер профиля (их может быть несколько, например, 0001, 0002,...). Значение MTU выставляется с помощью строкового ключа MaxMTU (1500, 1002, 576, 552).

Для настройки следующих параметров откройте раздел System\CurrentControlSet\Services\VxD\MSTCP. Значение MSS устанавливается строковым ключом DefaultMSS: его значение равно MaxMTU - 40.

RWIN настраивается в строковом ключе DefaultRcvWindow. Поэкспериментируйте с этим значением, но помните, что оно должно быть кратно MSS (MSS*4 или MSS*8).

TTL настраивается с помощью строкового ключа DefaultTTL.

Вы можете разрешить Windows самой определять оптимальное значение MTU.

Если опция включена, то Windows сама подбирает оптимальное значение MTU, однако процедура вычисления MTU для каждого соединения требует немало времени, что чуть тормозит работу при закачке небольших файлов и веб-серфинге. Для установки этого параметра добавьте строковый ключ PMTUDiscovery. Значение "1" включает его, "0" - выключает.

Обнаружение черных дыр. Установка этого параметра разрешает протоколу TCP пытаться обнаружить никуда не ведущие роутеры и те, что не возвращают ICMP-сообщений о необходимости фрагментации при определении наилучшего MTU. Это также, как и любая дополнительная процедура, может замедлять работу в Интернете - попробуйте поэкспериментировать с ее отключением. Для этого добавьте строковый ключ PMTUBlackHoleDetect со значением "1" для включения и "0" для выключения.

Для настройки NDI Cache откройте раздел System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\cachesize и в значении по умолчанию пропишите нужное число (16 или 32).

Вы можете увеличить количество одновременных подключений к серверу, включив эту опцию, что часто бывает весьма полезно, с помощью DWORD ключей MaxConnectionsPer1_0Server (установите его значение в 10) и MaxConnectionsPerServer (прировнять к 8). Эти ключи надо добавить в раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings. Удаление их приведет к отключению возможности.

Все настройки вступают в силу после перезагрузки компьютера. Поэкспериментируйте с различными значениями, и вы сможете увеличить скорость подключения на 20-40%.


Реестр Windows, советы по работе на компьютере

Настройка процесса загрузки Windows с помощью msdos.sys

Оказывается, управлять настройками Windows можно не только используя реестр, но и другими средствами. Одним из таких средств являются ini-файлы (например, win.ini, system.ini). По клятвенным заверениям Microsoft настройки в ini-файлах оставлены только для совместимости со старыми версиями программ, тем не менее, и многие современные программы продолжают их активно использовать. Однако в этой статье речь пойдет не о них, а еще об одном способе настройки Windows, предоставляющем возможность управлять загрузкой Windows, а именно о файле msdos.sys и его параметрах.

Файл находится в корне загрузочного диска и имеет атрибуты "Только для чтения", "Скрытый" и "Системный", так что, если вы собираетесь редактировать его, скажем, в Norton Commander или Volcov Commander, то вам надо предварительно снять эти атрибуты, а после окончания редактирования вновь восстановить их. В FARe этого делать не обязательно: он может редактировать такие файлы без проблем, просто при сохранении выдает запрос о том, что файл только для чтения и спрашивает, нужно ли его переписывать.

Файл должен иметь размер не меньше 1024 байт, поэтому в конце него есть строки типа

;хххххх...хххха

;хххххх...ххххb

.......

;xxxxxx...xxxxs

Точка с запятой в начале строки означает комментарий и игнорируется. Так что когда будете вносить изменения, на всякий случай старые записи не удаляйте, а комментируйте. Тогда вам не будет мучительно больно, если что-то получится не так, и не придется вспоминать, что же вы там удалили.

Ну, после такой длинной вводной части, пожалуй, можно перейти непосредственно к рассказу о параметрах этого файла. Все параметры разбиты на два раздела: [Paths] и [Options]. В первом разделе расположены параметры, указывающие пути, необходимые для загрузки, во втором - параметры, непосредственно управляющие загрузкой.

[Paths]

WinDir - путь, куда был установлен Windows.

WinBootDir - путь к каталогу с файлами, необходимыми для загрузки. В общем случае значение этого параметра и WinDir совпадают.

HostWinBootDrv - диск, с которого производится загрузка. В 99% это диск "С".

UninstallDir - этот параметр присутствует только в том случае, если вы устанавливали ОС поверх другой, с сохранением предыдущей версии. В качестве значения прописан путь к файлам W9xundo.dat и W9xundo.ini, необходимым для деинсталляции Windows.

[Options]

BootMulti - если равно 1 (жирным выделено значение по умолчанию), то во время загрузки, когда появляется надпись "Идет загрузка Windows 9x", позволяет нажать F4 и загрузить предыдущую версию DOS. 0 - F4 не сработает. Лучше выставить это значение равным 0, все равно вы не пользуетесь этой возможностью, о система ждет несколько секунд нажатия этой клавиши.

BootGUI - 1 - загрузка Windows с графической оболочкой. 0 - при загрузке попадете в DOS. Если надо загрузить графический интерфейс пользователя (GUI), надо ввести команду win (запустить файл win.com в каталоге Windows).

DoubleBuffer - 1 - разрешает двойную буферизацию для SCSI-контроллеров. 0 - соответственно, запрещает. Если SCSI-контроллера нет, лучше выставить значение 0.

Autoscan - управляет поведением ScanDisk'a во время загрузки при некорректном выходе из Windows: 0 - блокирует запуск ScanDisk; 1 - запускает ScanDisk, с уведомлением о начале проверки; 2 - запускает ScanDisk автоматически без всяких уведомлений. Стоит отключать или нет, решать вам. Если хотите перестраховаться, то не отключайте (лучше выставить 2, чтобы не ждало нажатия кнопки для начала сканирования), всем остальным рекомендую отключить.

WinVer - из названия несложно догадаться, что в качестве значения прописана версия Windows.

BootKeys - 1 - разрешает пользоваться при загрузке управляющими клавишами (F5, F8 и т.д.). 0 - запрещает.

BootDelay - устанавливает задержку в секундах при загрузке, в течение которой система ожидает нажатия управляющих загрузкой клавиш (F5, F8 и т.д.). По умолчанию установлено значение 2.

BootMenuDefault - устанавливает, какой пункт в загрузочном меню, вызываемом по F8, будет выбран по умолчанию по истечении установленного времени. Значение по умолчанию - 3 для компьютеров без сетевых компонент и 4 для сетевых компьютеров.

BootMenuDelay - время, в течение которого компьютер ждет выбора из загрузочного меню. По умолчанию это 30 секунд. Если в период ожидания был выбран другой пункт меню, счетчик исчезает и компьютер ожидает нажатия на Enter для продолжения загрузки.

BootMenu - 1 - при каждой загрузке Windows, появляется загрузочное меню. 0 - соответственно, не появляется.

BootSave - 1 - каждый раз при загрузке Windows стартует в Safe Mode. 0 - Windows стартует нормально.

BootWarn - 1 - разрешает предупреждение о загрузке в Safe Mode. 0 - запрещает.

BootWin - 1 - при загрузке будет загружаться Windows. 0 - загрузка предыдущей версии DOS.

Logo - 1 - во время загрузки будет показан рисунок с логотипом Windows. 0 - запрещает вывод заставки при загрузке. Если вам надоела эта заставка, ты вы можете отключить ее вывод. Так же можно заменить эту заставку своей. Стандартная картинка "зашита" в файле io.sys, но вы можете создать в корне загрузочного диска файл logo.sys и он будет иметь преимущество перед io.sys. Более подробно об этом написано в одном из советов {"Народной мудрости"} от 13.11.01.

DblSpace - 1 - разрешает автоматическую загрузку Dblspace.bin. 0 - запрещает загрузку Dblspace.bin. Если вы не пользуетесь сжатыми дисками, отключите этот параметр, как и следующий за ним (так у вас высвободится лишняя оперативная память, которая никогда лишней не бывает).

DrvSpace - 1 - разрешает автоматическую загрузку Drvspace.bin. 0 - запрещает загрузку Drvspace.bin.

LoadTop - 1 - разрешает загрузку Command.com и Drvspace.bin в верхнюю память. 0 - запрещает. Это лучше не менять.

NetWork - 1 - показывает пункт "Safe Mode With Networking" в загрузочного меню. При отсутствии сетевой поддержки должно быть установлено в 0.

DisableLog - 0 - создание лог-файла загрузки Windows (bootlog.txt - скрытый файл в корневом каталоге системного диска). 1 - лог-файл не создается. Если у вас возникают проблемы во время загрузки, включите создание лог-файла и посмотрите, что у вас выдаст. Возможно, это поможет устранить проблемы.

Файл msdos.sys нечувствителен к регистру букв, так что записи "Logo" и "logo" эквивалентны.

Главное, помните одно правило: перед тем, как изменять что-то в файле, создайте резервную копию. Предосторожности лишними никогда не бывают, зато это может сохранить множество времени и нервов, если что-то пойдет не так (правда, испортить что-либо окончательно и бесповоротно вам не удастся, так что экспериментируйте смело).


Пользователи компьютеров давно вывели новый закон природы: "оперативной памяти не может быть много"

Пользователи компьютеров давно вывели новый закон природы: "оперативной памяти не может быть много". Для более рационального использования всех типов оперативной памяти рекомендую в CONFIG.SYS прописать строку DOS=HIGH,UMB,NOAUTO, чтобы не загружались SETVER.EXE (нужен для старых ДОС-программ) и DBLBUFF.SYS (нужен для SCSI-дисков) - чем меньше грузится всякой хрени - тем лучше. Желательно использовать в конфигурационных файлах команды с приставками HIGH типа DEVICEHIGH, LOADHIGH, INSTALLHIGH, BUFFERSHIGH, FCBSHIGH, FILESHIGH, LASTDRIVEHIGH, STACKSHIGH (если они вам нужны), для освобождения базовой памяти. Для этого впишите сначала в CONFIG.SYS строки

DEVICE=C:\WINDOWS\HIMEM.SYS /V /TESTMEM:Off

DEVICE=C:\WINDOWS\EMM386.EXE NOEMS V

для использования верхней памяти. Внимание! Если вы при этом не добавите в CONFIG.SYS строку

DEVICEHIGH=C:\WINDOWS\IFSHLP.SYS,

то ваш компьютер может не загрузиться, так как команда DOS=NOAUTO отключает загрузку и этого драйвера файловой системы. Используйте в этом случае загрузочный флоппи-диск или компакт для добавления в конфиг этой строки. Параметр HIGHSCAN (может еще немного добавить свободной верхней памяти) для EMM386 лучше не использовать, так как высока вероятность того, что это приведет к ошибкам и система зависнет.

Необходимо отметить, что Винды сами загружают по умолчанию (если в конфиге не прописано DOS=NOAUTO) как бы "невидимый" CONFIG.SYS, в котором такие строки:

dos=high, auto

device= c:\windows\himem.sys

device= c:\windows\ifshlp.sys

device= c:\windows\setver.exe

fileshigh=30

lastdrivehigh=z

buffershigh=30

stackshigh=9,256

shell=command.com /p

fcbshigh=4

Эти драйвера грузятся, даже если в вашем конфиге они не прописаны (и, даже, если отсутствуют файлы AUTOEXEC.BAT и CONFIG.SYS), при этом, если у вас уже записаны в CONFIG.SYS команды без приставок HIGH (например files), то выполняться все равно будут команды с этими приставками (типа fileshigh), для использования старших адресов памяти (вернее, винда сама решает - использовать старшие адреса памяти или нет, и чаще всего окончания "HIGH" к командам добавляет). Значения, задаваемые командами files, lastdrive, buffers, stacks, fcbs и драйвер SETVER.EXE нужны только приложениям MS-DOS, Windows'98 эти параметры не требуются. Существует и "скрытый" AUTOEXEC.BAT:

@echo off

net start

set tmp=C:\windows\temp

set temp=C:\windows\temp

set COMSPEC=C:\COMMAND.COM

prompt $p$g

path c:\windows; c:\windows\command

Изменяя значения конфигурационных параметров, используемых "виндами" по умолчанию, можно добиться более рационального распределения памяти. Немного базовой памяти можно высвободить, если задать командой LASTDRIVEHIGH букву реально последнего дисковода (по умолчанию памяти выделяется больше: резервируется под все диски от A до Z) - на каждый дополнительный диск расходуется 80 байт. Желательно командой STACKSHIGH=0,0 отменить выделение памяти под стеки, отводимые для временного хранения различной системной информации и нужные только старым ДОСовским программам. Командой BUFFERSHIGH=20 можно ограничить количество буферов дискового ввода-вывода (каждый занимает 532 байта), так как "винды" используют собственную систему кеширования дисковых данных VCache, а для MS-DOS MODE этого значения вполне обычно хватает. Еще один параметр, нужный в режиме эмуляции MS-DOS досовским программам - FCBS, задающий количество неких блоков управления файлами, на что, естественно, опять уходит ценная память (64 байта на каждый), его значение можно изменить на FCBSHIGH=1. Базовую память можно сберечь, задав параметр FILESHIGH=10, уменьшив тем самым число обработчиков файлов с 30 до 10 (на каждый по 60 байт, примерно). Если вы никогда не загружаете режим эмуляции MS-DOS, то можете выставить еще меньшие значения этих параметров, мой же вариант расчитан на поддержку и зтого режима. Если же вы используете какую-нибудь устаревшую программу, которая хочет работать только из режима эмуляции MS-DOS, то вам, возможно, придется изменить эти параметры, опять увеличив их значения, иначе некоторые из ДОСовских программ не запустятся, или даже включить поддержку устаревшей EMS-памяти, добавив параметр RAM к драйверу EMM386! Например:

DEVICE=C:\WINDOWS\EMM386.EXE RAM VERBOSE,

при этом, возможно, придется отказаться от драйвера си-ди-рома и некоторых других досовских драйверов для максимального увеличения обьема базовой памяти - лучше всего это сделать, не меняя основные файлы конфигурации, а создав для этой программы свой PIF-файл, в котором и задать нужные значения.

При наличии в корне системного диска файла dblspace.bin или drvspace.bin Windows загрузит соответствующий драйвер сжатых дисков, даже если вы не используете эту функцию, поэтому не забудьте удалить эти файлы!

Очень полезно посмотреть, что грузится, выбрав в загрузочном меню (нажать кнопку F8, при загрузке ПК, для его вызова) режим "Step-by-step confirmation". При этом вы сможете увидеть и исправить ошибки в конфигурационных файлах которые обычно возникают из-за неправильного написания путей к драйверам и файлам. А проверить, насколько эффективно распределяется память, можно с помощью команды "MEM /P/C", которую надо набрать в меню "Выполнить" ("Run") кнопки "Пуск". Если в появившемся окне вы увидите примерно такие значения:

Largest executable program size=614032 (600k)

Largest free upper memory block=0 (0K)

MS-DOS is resident in the high memory area,

то все в порядке. Еще одна полезная команда "MEM /D/P" более детально покажет использование памяти.

Иногда нужно выделить больше памяти под переменные окружения (например, если вы хотите задать дополнительные параметры для видеоускорителя от 3dfx в автоэкзеке, а получаете сообщение "Out of environment space"), в этом случае пропишите строку в конфиге:

SHELL=C:\COMMAND.COM /P /E:1024

Обьем свободной оперативной памяти может резко уменьшится при использовании буфера обмена, особенно если в нем хранится большая картинка, поэтому не забывайте после работы с буфером в мощных программных пакетах очистить его, скопировав всего одну букву из блокнота, например.


Оптимизация памяти

Автор статьи: Сергей Трошин

e-mail: stnvidnoye@chat.ru

http://stnvidnoye.chat.ru

Пользователи компьютеров давно вывели новый закон природы: "оперативной памяти не может быть много". Для более рационального использования всех типов оперативной памяти рекомендую в CONFIG.SYS прописать строку DOS=HIGH,UMB,NOAUTO, чтобы не загружались SETVER.EXE (нужен для старых ДОС-программ) и DBLBUFF.SYS (нужен для SCSI-дисков) - чем меньше грузится всякой хрени - тем лучше. Желательно использовать в конфигурационных файлах команды с приставками HIGH типа DEVICEHIGH, LOADHIGH, INSTALLHIGH, BUFFERSHIGH, FCBSHIGH, FILESHIGH, LASTDRIVEHIGH, STACKSHIGH (если они вам нужны), для освобождения базовой памяти. Для этого впишите сначала в CONFIG.SYS строки

DEVICE=C:\WINDOWS\HIMEM.SYS /V /TESTMEM:Off

DEVICE=C:\WINDOWS\EMM386.EXE NOEMS V

для использования верхней памяти. Внимание! Если вы при этом не добавите в CONFIG.SYS строку

DEVICEHIGH=C:\WINDOWS\IFSHLP.SYS,

то ваш компьютер может не загрузиться, так как команда DOS=NOAUTO отключает загрузку и этого драйвера файловой системы. Используйте в этом случае загрузочный флоппи-диск или компакт для добавления в конфиг этой строки. Параметр HIGHSCAN (может еще немного добавить свободной верхней памяти) для EMM386 лучше не использовать, так как высока вероятность того, что это приведет к ошибкам и система зависнет.

Необходимо отметить, что Винды сами загружают по умолчанию (если в конфиге не прописано DOS=NOAUTO) как бы "невидимый" CONFIG.SYS, в котором такие строки:

dos=high, auto

device= c:\windows\himem.sys

device= c:\windows\ifshlp.sys

device= c:\windows\setver.exe

fileshigh=30

lastdrivehigh=z

buffershigh=30

stackshigh=9,256

shell=command.com /p

fcbshigh=4

Эти драйвера грузятся, даже если в вашем конфиге они не прописаны (и, даже, если отсутствуют файлы AUTOEXEC.BAT и CONFIG.SYS), при этом, если у вас уже записаны в CONFIG.SYS команды без приставок HIGH (например files), то выполняться все равно будут команды с этими приставками (типа fileshigh), для использования старших адресов памяти (вернее, винда сама решает - использовать старшие адреса памяти или нет, и чаще всего окончания "HIGH" к командам добавляет). Значения, задаваемые командами files, lastdrive, buffers, stacks, fcbs и драйвер SETVER.EXE нужны только приложениям MS-DOS, Windows'98 эти параметры не требуются. Существует и "скрытый" AUTOEXEC.BAT:

@echo off

net start

set tmp=C:\windows\temp

set temp=C:\windows\temp

set COMSPEC=C:\COMMAND.COM

prompt $p$g

path c:\windows; c:\windows\command

Изменяя значения конфигурационных параметров, используемых "виндами" по умолчанию, можно добиться более рационального распределения памяти. Немного базовой памяти можно высвободить, если задать командой LASTDRIVEHIGH букву реально последнего дисковода (по умолчанию памяти выделяется больше: резервируется под все диски от A до Z) - на каждый дополнительный диск расходуется 80 байт. Желательно командой STACKSHIGH=0,0 отменить выделение памяти под стеки, отводимые для временного хранения различной системной информации и нужные только старым ДОСовским программам. Командой BUFFERSHIGH=20 можно ограничить количество буферов дискового ввода-вывода (каждый занимает 532 байта), так как "винды" используют собственную систему кеширования дисковых данных VCache, а для MS-DOS MODE этого значения вполне обычно хватает. Еще один параметр, нужный в режиме эмуляции MS-DOS досовским программам - FCBS, задающий количество неких блоков управления файлами, на что, естественно, опять уходит ценная память (64 байта на каждый), его значение можно изменить на FCBSHIGH=1. Базовую память можно сберечь, задав параметр FILESHIGH=10, уменьшив тем самым число обработчиков файлов с 30 до 10 (на каждый по 60 байт, примерно). Если вы никогда не загружаете режим эмуляции MS-DOS, то можете выставить еще меньшие значения этих параметров, мой же вариант расчитан на поддержку и зтого режима. Если же вы используете какую-нибудь устаревшую программу, которая хочет работать только из режима эмуляции MS-DOS, то вам, возможно, придется изменить эти параметры, опять увеличив их значения, иначе некоторые из ДОСовских программ не запустятся, или даже включить поддержку устаревшей EMS-памяти, добавив параметр RAM к драйверу EMM386! Например:

DEVICE=C:\WINDOWS\EMM386.EXE RAM VERBOSE,

при этом, возможно, придется отказаться от драйвера си-ди-рома и некоторых других досовских драйверов для максимального увеличения обьема базовой памяти - лучше всего это сделать, не меняя основные файлы конфигурации, а создав для этой программы свой PIF-файл, в котором и задать нужные значения.

При наличии в корне системного диска файла dblspace.bin или drvspace.bin Windows загрузит соответствующий драйвер сжатых дисков, даже если вы не используете эту функцию, поэтому не забудьте удалить эти файлы!

Очень полезно посмотреть, что грузится, выбрав в загрузочном меню (нажать кнопку F8, при загрузке ПК, для его вызова) режим "Step-by-step confirmation". При этом вы сможете увидеть и исправить ошибки в конфигурационных файлах которые обычно возникают из-за неправильного написания путей к драйверам и файлам. А проверить, насколько эффективно распределяется память, можно с помощью команды "MEM /P/C", которую надо набрать в меню "Выполнить" ("Run") кнопки "Пуск". Если в появившемся окне вы увидите примерно такие значения:

Largest executable program size=614032 (600k)

Largest free upper memory block=0 (0K)

MS-DOS is resident in the high memory area,

то все в порядке. Еще одна полезная команда "MEM /D/P" более детально покажет использование памяти.

Иногда нужно выделить больше памяти под переменные окружения (например, если вы хотите задать дополнительные параметры для видеоускорителя от 3dfx в автоэкзеке, а получаете сообщение "Out of environment space"), в этом случае пропишите строку в конфиге:

SHELL=C:\COMMAND.COM /P /E:1024

Обьем свободной оперативной памяти может резко уменьшится при использовании буфера обмена, особенно если в нем хранится большая картинка, поэтому не забывайте после работы с буфером в мощных программных пакетах очистить его, скопировав всего одну букву из блокнота, например.


Перенос системы с данными с жёсткого диска на новый диск и

создание образов, и не только…:

Программы фирмы Acronis явились для меня настоящим открытием.

А началось весьма прозаично, как бы не был велик жесткий диск,

его всегда будет мало, с этой аксиомой знакомы все юзеры. С

тоской смотрел, как заканчивается свободное пространство на

двух двадцатках на которых мирно уживались три системы,

мысленно готовя себя к кошмару переустановки на новый диск. В

рассылке и на сайте Clubrus, привлекли незнакомые программы

Acronis с многообещающими фишками, которым поначалу не придал

большого значения, сколько мы видели таких обещаний, которые

на поверку оказывались не так уж и хороши. И так, ближе к

телу, начал с Acronis MigrateEasy 6.0 Rus, предварительно

причесал Windows Me, убрал всё лишнее с диска С:, все

остальные системы, загрузочные сектора, хоть специалисты и не

рекомендуют такую установку (с крахом диска, не получите

доступ к другим системам), но привычка вторая натураJ, а с

использованием программ Acronis это вообще не имеет никакого

значения. Перенос диска С: на новый, оказался до безобразия

прост и быстр, выбирайте только режим "автоматический"

загрузочный и Acronis Migrate Easy v.6.0 Rus перенесёт весь

диск один ко одному. Запутаться там невозможно, в прекрасном

графическом русском интерфейсе всё предельно ясно, что сделать

со старым диском программа вежливо спросит Если есть такая

возможность, рекомендую оставить по умолчанию "оставить данные

без изменений" и только не запускайте две системы вместе,

после переноса, (в противном случае на одной разделы "Windows"

и "Program Files" окажутся спрятанными в папку "BOOTWIZ"), всё

будет работать и не требовать нового Update, ни новой

установки драйверов и настройки самой системы, офиса, ни

программ работающие под Windows Me - всё это меня приятно

поразило.

Оставались ещё две системы, которые в придачу работали на

другом физическом диске. С этой задачей прекрасно справилась

вторая программа Acronis TrueImage 6.0 Standard - это

фантастика, это лучшее, что когда либо видел, это

действительно, программный продукт нового поколения. В

создании образов жёстких дисков и его разделов, за короткое

время позволила мне создать образ диска, (который я хочу

сохранить, регулярно обновляя, на случай, краха системы или

диска) и прямо из работающей системы Windows XP и образ

Windows 2000 c последующим переносом на новый диск (не

забудьте указать при перенесении образа на новый диск,

присвоить ему имя "первичный", в противном случае,

"логический", вычистит на новом диске разделы "Windows" или

"Windows NT" и "Program Files" и операцию переноса с образа

придётся повторить, пожалуйста, напоминаю ещё раз: не

запускайте две системы вместе, в противном случае на одной

разделы "Windows" или "Windows NT" и "Program Files" окажутся

спрятанными в папку "BOOTWIZ") Из всех настроек, что я сделал

после всех перемещений - это на диске С: в загрузочном

системном разделе

"BOOT"

[boot loader]

timeout=300

default=C:\

[operating systems]

C:\="Microsoft Windows Millennium Edition"

multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows

XP Professional" /fastdetect

multi(0)disk(0)rdisk(1)partition(1)\WINNT="Microsoft Windows

2000 Professional" /fastdetect

поменял rdisk(1) на rdisk(0), поскольку большой диск у меня

сейчас один и partition - это адрес загрузочного раздела

системы

[Boot Loader]

Timeout=300

Default=C:\

[Operating Systems]

multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows

XP Professional" /fastdetect

multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows

2000 Professional" /fastdetect

C:\="Microsoft Windows Millennium Edition"

Для справки, поскольку мне трудно описать все конфигурации,

которые могут быть у вас. Думаю, Вы уже поняли, что в данном

файле содержится вся конфигурация загрузчика. Первая секция

[boot loader] определяет, сколько секунд Вам предоставляется

для выбора ОС и название системы по умолчанию, а в [operating

systems] каждая строчка представляет какую-то ОС. Системы

вроде Windows ХР и Windows 2000 записываются в специальном

формате: multi(0)disk(0)rdisk(0)partition(1)\WINNT. Параметры

multi и disk почти всегда равны нулю, и их не стоит изменять,

а вот значения rdisk и partition - это адрес загрузочного

раздела системы (т. е. того, где находится Win 2000 и ХР).

rdisk должен иметь номер диска в системе, он присваивается

таким образом: primary master - 0, primary slave - 1,

secondary master - 2, secondary slave - 4.

Правда, тут требуется учитывать несколько моментов. Во-первых,

необходимо, чтобы Ваша система была правильно собрана, а то,

может, в ней окажется Secondary Slave CD-COM, но ничего не

будет на канале Secondary Master. И хотя это и заработает -

глюков не избежать. Либо, допустим, у Вас установлено больше 4

устройств (например, используется внешний контроллер). И

наконец, параметр partition - он описывает номер раздела.

Заметьте, нумерация дисков начинается с 0, а разделов - с 1.

И ещё одна программа Acronis Partition Expert 2003, явилась

прекрасным дополнением ко всему сказанному: под любой системой

создаёт, складывает, перемещает, конфигурирует разделы и

логические диски, без потери данных с такой лёгкостью, чего

доселе не видел ни разу, вы легко добавите свободного места,

для одной системы, урезав у другой, смена любых файловых

систем и её красочный интерфейс, который выгодно отличает все

программы Acronis, напоминает игру в пазл, сбоев Partition ни

разу не делал.

Последнее, что сделал, поставил Acronis OS Selector 8.0

Standard Russian - программа с считанные минуты создала

красочный менеджер загрузки, в котором оказалось много

полезных функций. Менеджер разделов позволяет изменить

структуру разделов жесткого диска без потери данных, а также

Администратор дисков, помогающих работать с диском, и его

разделами, и не только, останавливаться на этом не буду,

поскольку фирма Acronis сама позаботилась, оснастив все свои

программы, подробными инструкциями на русском в файле .pdf

(читать можно в AcrobatReader) и краткую справку в самой

программе (мечта любого пользователя!). Также легко

записываются загрузочные дискеты, которые желательно иметь при

работе с программами.

Сайт программ http://www.acronis.com

Александр Голубовский

Здесь должен стоять твой баннер! - реклама на сайте.

URL: http://clubrus.kulichki.netE-mail: Clubrus


Переустановка Windows со всем софтом за 15 минут.

Ранее, было описание как переустановить Windows 98, затратив при этом минимум времени. Эта статья является продолжением. И в заключении прошлой статьи я просил воздержаться от установки не столь важных приложений. Нужно установить тот софт, который плотно завязан с системой, тот же MS Office, какой-нибудь Интернет обозреватель или почтовый клиент, достаточно много программ, это решает каждый для себя сам. Но должны уложиться примерно в 1,5- 1,7 ГБ. Нужно постараться не делать лишних настроек системы, это может оказать плохое влияние на дальнейшую работу. Должен быть здравый смысл во всех действиях, связанный с работой с реестром. Не переусердствуйте! Ну, а теперь к делу.

Для дальнейшей работы понадобится маленькая программа Norton Ghost, размер которой не превышает 750 кБ. Эта маленькая программка входит в состав большого приложения Norton Ghost, которое имеет размер более 10 МБ. Увольте меня давать ссылку на весь пакет, т.к. я не знаю. Попробуйте поискать на Yandex или на другой поисковой машине. Но то, что Вы найдете и скачаете, на 90 % не понадобится. Достаточно этой маленькой программки из большого пакета, которую можно скачать здесь (только хочу предупредить, что в архиве более старая версия, но она особо не отличается от новой по своим характеристикам). В архиве содержится драйвер мыши и файл ngb.bat для запуска программы Norton Ghost и мыши. Ничего с этим БАТоном делать не нужно, все уже сделано. Архив желательно распаковать на другой диск или раздел диска.

Программа Norton Ghost делает образ диска или раздела. Ее можно запустить из среды Windows, но лучше с ней работать в DOS, меньше проблем. Как рекомендовалось выше, нужно перезагрузиться в DOS, т.е. при загрузке машины нужно удержать клавишу F8 и выбрать пункт меню Command promt only. После чего нужно перейти на диск, на котором вы распаковали Norton Ghost. Т.к. упаковка уже содержит папку NG, то буду придерживаться всех имен из этого архива. К примеру Вы распаковали архив на раздел винчестера D, перезагрузились в DOS, выбрали Command promt only и оказались на диске C. Напишите следующее (что нужно написать отмечу красным, регистр значения не имеет):
C:>d:
D:>cd ng
D:>NG\ngb
После этих незатейливых манипуляций запустится программа Norton Ghost и мышь.

После запуска программы нужно мышью выбрать меню Local - Partition - To Image. В следующем окне соглашаемся и жмем ОК.

Далее нужно будет выбрать раздел, с которого нужно сделать образ, в данном случае диск C (не забудьте его отметить мышью) - ОК.

Здесь нужно ввести имя и указать папку, в которой сохранится образ (выбирайте для сохрания диск, чтобы места на нем было достаточно, из 1,1 ГБ получается файл 550 МБ).

Следующим этапом выбирается сжатие файла образа: No - Без сжатия, Fast - быстрое, High - высокое. Выбираем High и отправляемся пить кофе. В зависимости от размера установленныйх файлов на диске уходит некоторое время, можно сказать, что на 1,1 ГБ уходит 14 минут, а на 760 МБ 6,5 минуты.

После того, как все будет сделано нужно выйти из приложения и перезагрузить компьютер, хотя перезагружать не обязательно. После закрытия программы Norton Ghost нужно вернуться на диск С и запустить Windows.Напишите следующее (что нужно написать отмечу красным, регистр значения не имеет):
D:>NG\cd\
D:>c:
C:>win
После чего запустится Windows. Сохраните свой образ с диска и оставьте его до лучших времен, но лучше всего его записать на копакт-диск. Об этом в следующей статье, а сейчас немного продолжим.

Допустим, что система стала со временем глючить, работать не ровно. Обычно забивается реестр, в котором появляются ссылки на несуществующие файлы. Чистить реестр вручную? Неблагодарное это занятие. При помощи какой-нибудь программы? Тоже как-то не оправдывают старанее, к тому же, есть риск, что программа сработает с ошибкой и удалит лишнее. Значит нужно систему сносить и инсталлировать заново. Инсталляция системы тоже дело нудное и утомительное, но не сколько инсталляция, сколько установка приложений и драйверов устройств. Только от одних перезагрузок компьютера можно сдуреть!

Если вы сделали образ диска свежей системы с установленным софтом, то когда наступят черные дни для вас, а для синих экранов экранов белые, верните сделанный ранее образ диска на место. Но для этого нужно будет загрузиться с Загрузочной дискеты. Загрузочная дискета создается в Панели управления - Установка и удаление программ - вкладка Загрузочный диск. После загрузки компьютера с дискеты напишите следующее (что нужно написать отмечу красным, регистр значения не имеет):
A:>format c:
A:>sys c:
После чего диск С будет отформатирован и на него скопируются системные файлы. Если вы не перемещали Norton Ghost и сделанный ранее образ диска (см. выше), то наберите следующее:
A>d:
D:>cd ng
D:>NG\ngb

Запустится Norton Ghost и из его меню нужно выбрать Local - Partition - From Image. Далее нужно будет найти ваш файл образа диска, который вы сделали ранее, и дождаться выполнения операции. Закройте Norton Ghost и перезагрузите компьютер, переключив загрузку с винчестера.

Понятное дело, что огромный файл образа диска держать на винчестере нет смысла, поэтому его лучше записать на компакт диск. Об этом пойдет речь в следующей статье

Korsar.


Команды Rundll32 и возможность их использования

Все мы знаем, что все процессы во время работы запускаются и останавливаются с помощью комманд, которые ОС постоянно выполняет. Но сейчас это уже не так актуально и интересно, но несмотря на это нами было получено несколько писем с просьбой дать описание всех команд Rundll32 в Windows, что мы и делаем.

Команда | Действие
rundll32 user.exe,ExitWindows | Завершение работы Windows
rundll32 user.exe,ExitWindowsExec | Перезагрузка Windows
rundll32 shell32.dll,SHExitWindowsEx | Завершение сеанса работы Windows
rundll32 user,RepaintScreen | Обновить экран (F5)
rundll32 user,WNetDisconnectDialog | Вызвать окно "Отключение сетевого диска"
rundll32 user,disableoemlayer | Провоцировать сбой системы (черный экран и мигающий курсор)
rundll32 user,WNetConnectDialog | Вызвать окно "Подключение сетевого диска"
rundll32 user,SetCursorPos | Переместить курсор мыши в левый верхний угол
rundll32 diskcopy,DiskCopyRunDll | Вызвать окно "Копирование диска"
rundll32 shell,ShellExecute | Открыть корневой каталог в проводнике
rundll32shell32,OpenAs_RunDLL файл.расширение | Открыть диалоговое окно "Открыть с помощью..." и связать указанную программу с файлами с расширением, указанном в команде
rundll32 shell32,SHFormatDrive | Вызвать окно форматирования диска
rundll32 shell32,ShellAboutA | Показать окно About Windows
rundll32 shell32,Control_RunDLL | Открыть Панель управления
rundll32 shell32,Control_RunDLL set.cpl | Вызвать определенное окно на Панели управления. Вместо set.cpl в команде нужно вписать необходимый файл с расширением .cpl.
rundll32 krnl386.exe,exitkernel | Выход из Windows без любых сообщений/вопросов
rundll32 user,SwapMouseButton | Поменять местами клавиши мыши (работает только в одну сторону)
rundll32 keyboard,disable | Отключить клавиатуру
rundll32 mouse,disable | Отключить мышь
rundll32 user,TileChildWindows | Расположить все несвернутые окна по вертикали
rundll32 user,CascadeChildWindows | Расположить все несвернутые окна каскадом
rundll32 msprint2.dll,RUNDLL_PrintTestPage | Выбрать принтер и распечатать пробную страницу
rundll32 user,SetCaretBlinkTime | Сильно увеличить частоту мигания курсора
rundll32 user, SetDoubleClickTime | Изменить скорость двойного щелчка мыши
rundll32 rnaui.dll,RnaWizard | Вызвать диалог "Установка связи"
rundll32 sysdm.cpl,InstallDevice_Rundll | Установить оборудование
rundll32 shell32,SHExitWindowsEx 0 | Перезагрузить Windows без перезагрузки компьютера
rundll32 shell32,SHExitWindowsEx 1 | Завершить работу Windows
rundll32 shell32,SHExitWindowsEx 2 | Перезагрузить компьютер

К сожалению, большинство этих команд не работают в Windows XP, но тем не менее, стоит их изучить, дабы ускорить свою работу в Windows 9x.

Самый простой способ - это создать ярлык на рабочем столеи в строке адреса файла вписать одну из команд. После чего назначить горячую клавишу - таким образом за пару нажатий можно сделать то, для чего бы требовалось не одна минута.


Секретные приемы автозагрузки

Автозагрузка в Windows 9x
Специфика Windows NT / 2000 / XP
Неявные способы автозагрузки

Сергей Трошин

В Windows различных версий имеется несколько способов автоматического запуска определенной программы или открытия документа во время загрузки операционной системы. Это обусловлено разными причинами: требованиями совместимости с приложениями для DOS и для Windows 3.11, наличием в системе нескольких зарегистрированных пользователей с индивидуальными настройками, необходимостью разграничения пользовательских привилегий и так далее.
В последних версиях Windows имеется довольно неплохая утилита для управления программами из автозагрузки - msconfig.exe. Правда, вся прелесть этой программы в том, что она уже есть в составе Windows, и что она предельно проста: практически не дает пользователю возможности привести операционную систему в неработоспособное состояние.
На вкладке "Автозагрузка" (StartUp) утилиты msconfig.exe можно увидеть текущий список автоматически загружаемых программ и, сняв тот или иной флажок, отключить автозагрузку какой-либо из них. При этом отключенный элемент не удаляется из списка, и его можно в любой момент снова вернуть в автозагрузку.
Отключаемый элемент списка лишь перемещается в необрабатываемый системой раздел реестра RunServices или Run либо в папку "Отключенные элементы автозапуска" меню Пуск, в соответствии с тем, каким способом изначально проводилась его автозагрузка. Также на вкладке "Автозагрузка" программы msconfig.exe имеется кнопка CleanUp, при задействовании которой производится проверка путей к файлам автоматически загружаемых программ.
И в случае, если обнаруживается неверный путь, ошибочная запись удаляется из списка. К сожалению, эта программа не только не позволяет добавить в автозагрузку какое-то новое приложение, но и сам список автоматически загружаемых программ в ней может быть не полон. Дело в том, что она не учитывает некоторые довольно важные способы автозагрузки, в частности, содержимое подразделов реестра RunOnce: RunOnceEx, RunOnce\Setup и RunServicesOnce, - в этой программе не отображается.
Чуть больше возможностей дают аналогичные утилиты от сторонних производителей, например, программа Starter (codestuff.virtualave.net), поэтому я советую при активной работе с автозагрузкой пользоваться именно такими, более продвинутыми программами. Однако в тех случаях, когда даже с их помощью не удается выявить способ загрузки какой-либо программы или необходимо определить причину сбоя, следует вручную проконтролировать все возможные пути автоматической загрузки программ. Эти пути в Windows 9x и в Windows NT немного различаются.

Автозагрузка в Windows 9x

Самый первый способ автоматической загрузки программы в Windows 9x - использование рудиментарного файла autoexec.bat. Разумеется, таким образом можно запустить только приложение для DOS или какой-то пакетный bat-файл. В Windows Me обработка этого файла уже не производится, а потому в этой системе этот способ не работает.
Сразу оговорюсь, что такие используемые вирусами способы автозагрузки, как, например, внедрение чужеродного исполняемого кода в обычную программу (например, в command.com, win.com или даже в драйвер мыши) или подмена файла легитимной программы файлом вируса, мы рассматривать не будем.
Хотя, пожалуй, в контексте вирусологии стоит упомянуть о системном файле wininit.exe: эта программа тоже запускается в самой начальной стадии загрузки системы в том случае, если в папке Windows присутствует файл wininit.ini, инструкции из которого она и призвана выполнить. В принципе, не только возможна подмена самого файла wininit.exe файлом вируса, но и создание деструктивных инструкций в файле wininit.ini, результатом которых окажется, например, полное удаление папки My Documents сразу после загрузки компьютера.
Так что, имейте это в виду. Далее по ходу загрузки операционной системы автоматически исполняется еще один недокументированный командный файл - winstart.bat - если он имеется в директории Windows. Из него так же, как и из autoexec.bat, можно загрузить некоторые резидентные DOS-программы или выполнить последовательность команд (в "Миллениуме" этот файл также не обрабатывается). Не забывайте, что при перезагрузке системы Windows 9х в режим эмуляции MS-DOS используется также пакетный файл dosstart.bat.
Затем при загрузке операционной системы доходит очередь до обработки еще одного конфигурационного файла - system.ini. Напрямую с его помощью можно запустить только одну программу, а именно, оболочку Windows. Изначально такой оболочкой является Проводник explorer.exe, что вы и можете наблюдать, если посмотрите значение параметра SHELL в разделе [BOOT], однако ничто не мешает указать дополнительные программы как аргументы командной строки самого файла explorer.exe - Проводник сам при запуске загрузит эти программы или документы.
Впрочем, вполне возможна и замена самой оболочки explorer.exe на любой другой файл, собственно, именно для этого и предназначен этот параметр.
Далее в процессе загрузки Windows появляется еще одна возможность запуска программ - доставшийся от Windows 3.11 файл win.ini содержит в разделе [windows] специальные параметры load и run, которые могут использоваться для задания автозапуска (для обеспечения совместимости эти параметры по-прежнему обрабатываются самыми последними версиями ОС).
По умолчанию значением этих параметров должна являться пустая строка.
Поскольку файлы system.ini и win.ini - наследие Windows 3.11, то, если вы вдруг захотите использовать эти параметры, не забывайте, что указывать путь к исполнимому файлу (или имя файла) в их значении следует в стандарте MS-DOS - без пробелов и длинных имен. Если требуется поместить в автозагрузку сразу несколько программ, то допускается перечисление через запятую имен файлов этих программ.
Поскольку этот путь загрузки обычными пользователями уже изрядно подзабыт, его нередко используют доморощенные создатели троянских вирусов.
Теперь во время загрузки операционной системы начинает обрабатываться системный реестр, в котором существует целый ряд разделов, обеспечивающих загрузку приложений в определенном порядке и в контексте определенного пользователя.
Подразделы реестра, отвечающие за автозапуск, носят следующие имена: Run, RunOnce, RunOnceEx, RunServices, RunServicesOnce.
Располагаться они могут в следующих разделах реестра, в зависимости от того, в каком контексте производится автозапуск:
HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows\Current
Version\
HKEY_USERS\.DEFAULT\SOFTWARE\
Microsoft\Windows\Current
Version\
HKEY_CURRENT_USER\SOFTWARE\
Microsoft\Windows\Current
Version\.
В том случае, если в Windows 9x зарегистрирован только один пользователь, содержание раздела HKEY_USERS\.DEFAULT дублирует раздел HKEY_CURRENT_
USER. Полный путь к этим параметрам может выглядеть, например, так: HKEY_LOCAL_MACHINE\
SOFTWARE\Microsoft\Windows\
CurrentVersion\Run.
То есть, для того, чтобы просмотреть автозагрузку, в каждом из корневых разделов реестра следует открыть ветвь
SOFTWARE\Microsoft\Windows\CurrentVersion\
и найти вышеперечисленные подразделы Run*. Каждый из этих подразделов может содержать перечень строковых параметров (порядок запуска приложений, расположенных в одном подразделе, обычно соответствует расположению по алфавиту имен этих параметров), значением которых являются пути к программам, которые и надо загрузить на старте Windows. Эти пути могут содержать длинные имена и пробелы.
Первыми при загрузке системы обрабатываются параметры Run* из раздела HKEY_LOCAL_MACHINE, причем ключи RunServices и RunServicesOnce обрабатываются раньше, чем Run и RunOnce. Программы из подразделов RunServices и RunServicesOnce запускаются еще до входа пользователя в систему в так называемом асинхронном режиме, независимо от запуска других программ и процесса регистрации пользователя в системе.
Подразделы RunServicesOnce и RunOnce служат для однократного запуска программ, и их содержимое очищается непосредственно перед самой загрузкой программ, указанных в этих разделах (раздел реестра RunOnce не поддерживается в Windows NT 3.5).
Специальные разделы RunOnceEx отличаются от разделов RunOnce и Run. Эти разделы позволяют запускать программы в заранее определенном порядке, последовательно. Напрямую параметры, расположенные в разделе RunOnceEx, не запускаются. Внутри раздела RunOnceEx для автоматически запускаемых с его помощью программ создается дополнительный подраздел, в котором уже и указываются параметры с именами приложений и путями к исполнимым файлам.
При этом подразделы внутри RunOnceEx обрабатываются системой в алфавитном порядке, что и позволяет задать порядок запуска приложений или групп приложений, что может быть крайне важно при инсталляции некоторых программ. При обработке такого списка программ система будет терпеливо ожидать завершения работы каждого элемента списка и только после этого произведет запуск уже следующего элемента, стоящего в очереди.
Кроме того, в подразделе реестра RunOnce может содержаться специальный раздел Setup, используемый при установке компонентов Windows либо некоторых прикладных программ.
Параметры внутри этого раздела обрабатываются системой так же, как и обычные параметры раздела RunOnce, то есть происходит однократный запуск указанных в них программ, однако в ходе этого запуска отображается индикатор (в его диалоговом окне указано имя соответствующего параметра из раздела Setup) с прогресс-баром, то есть показывается, на сколько процентов завершено копирование файлов устанавливаемой программы.
После обработки раздела HKEY_LOCAL_MACHINE приходит черед аналогичной обработки общего для всех пользователей многопользовательских конфигураций раздела HKEY_USERS\.DEFAULT, а после регистрации пользователя в системе - раздела HKEY_
CURRENT_USER.
В Windows Me, Windows 2000 / XP появились новые разделы для автозагрузки программ:
HKEY_LOCAL_MACHINE\ Software\Microsoft\Windows\
CurrentVersion\Policies\Explorer\Run и HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\Explorer\Run.
Особенность этих разделов заключается в том, что имена параметров, прописанных в них, должны быть представлены в виде порядковых номеров, начиная с единицы.
Также после регистрации пользователя в системе происходит запуск программ, ярлыки к которым помещены в папку "Автозагрузка" меню Пуск. Следует учитывать, что для текущего пользователя реальное местоположение на диске этой папки с ярлыками может быть изменено с помощью программы типа TweakUI либо вручную, при изменении значения параметра Startup в разделе реестра HKEY_CURRENT_USER\ SOFTWARE\Microsoft\
Windows\CurrentVersion\ Explorer\User Shell Folders.
По умолчанию же ярлыки автозапуска текущего пользователя располагаются в папке \WINDOWS\Start Menu\Programs\StartUp для Windows 9x либо \
Documents and Settings\ИМЯ ПОЛЬЗОВАТЕЛЯ\Start Menu\
Programs\Startup для Windows XP (путь этот также задан в реестре - параметр Startup раздела HKEY_CURRENT_USER\ SOFTWARE\Microsoft\Windows\
CurrentVersion\Explorer\ShellFolders).
Кроме этой папки, ярлыки автоматически запускаемых программ могут располагаться и в папке, общей для всех пользователей многопользовательской конфигурации. В Windows XP - это папка \Documents and Settings\All Users\ Start Menu\Programs\Startup, а в Windows 9x - \WINDOWS\All Users\Start Menu\
Programs\StartUp.
Путь к этой папке тоже может быть изменен в реестре - Common Startup раздела HKEY_LOCAL_MACHINE\
SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Shell Folders. Эти папки могут обрабатываться даже в однопользовательских конфигурациях.

Специфика Windows NT / 2000 / XP

В операционных системах серии Windows NT способы автозапуска программ в целом почти идентичны системам Windows 9x, однако имеется ряд разделов в реестре, специфичных только для Windows NT.
Кроме того, в этих ОС отсутствует возможность запуска программ с помощью файлов autoexec.bat (при запуске DOS-приложения, правда, происходит автоматическая обработка файла %SystemRoot%\SYSTEM32\AUTOEXEC.NT, если в настройках свойств этой DOS-программы не указан другой файл), winstart.bat, dosstart.bat.
Итак, в Windows NT могут иметь место дополнительные параметры автозапуска в разделах реестра:
HKEY_CURRENT_USER\ Software\Microsoft\Windows NT\CurrentVersion\Windows\Run и
HKEY_LOCAL_MACHINE\ Software\Microsoft\Windows NT\CurrentVersion\Windows\Run.
В разделе HKEY_CURRENT_USER\ Software\Microsoft\Windows NT\
CurrentVersion\Windows или в
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows могут присутствовать строковые параметры Load (программы, запуск которых в нем прописан, загружаются минимизированными) и Run, в которые при установке Windows NT поверх Windows 9x переносится соответствующий список программ автозапуска из аналогичных параметров файла win.ini.
К этим параметрам реестра применимы те же правила написания, что и к соответствующим параметрам win.ini. Если же наследования этого списка из предыдущей ОС не происходит, то по умолчанию значением этих параметров является пробел.
В разделе HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows NT\
CurrentVersion\Winlogon также содержится ряд строковых параметров, отвечающих за автозапуск различных приложений при входе пользователя в систему:
Userinit - определяет список программ, запускаемых процессом WinLogon в контексте пользователя при его регистрации в системе. По умолчанию это userinit.exe, nddeagnt.exe для Windows NT и userinit.exe для Windows 2000 / XP.
Shell - задает оболочку (вернее, список программ, формирующих пользовательский интерфейс) Windows (по умолчанию taskman, progman, wowexec для Windows NT и explorer.exe для Windows 2000 / XP).
System - определяет список программ, запускаемых процессом WinLogon в контексте системы во время ее инициализации. По умолчанию - lsass.exe, spoolss.exe для Windows NT и lsass.exe для Windows 2000 / XP.
VmApplet - определяет список программ или программу, запускаемую процессом WinLogon для оперативной настройки параметров виртуальной памяти -по умолчанию его значение rundll32 shell32, Control_
RunDLL "sysdm.cpl".

Неявные способы автозагрузки

К сожалению, операционные системы семейства Windows и их внутреннее устройство довольно сложны для рядового пользователя - к копанию в реестре расположен далеко не каждый. Тем более, что помимо вышеперечисленных способов автозапуска программ на старте системы существует еще и такой вариант, как запуск исполнимого модуля одной программы при загрузке другого, вполне легитимного приложения.
Подобный симбиоз (или, скорее, что-то типа паразитирования) можно наблюдать при использовании утилит класса ad-ware, то есть таких программ, в которых вы расплачиваетесь с их авторами не живыми деньгами, а своими нервными клетками, попорченными из-за просмотра рекламных баннеров внутри интерфейса самой программы.
За примером таких программ далеко ходить не надо - это и ReGet, и ICQ, и Opera. Закачкой этих баннеров обычно занимается отдельный исполнимый модуль, запускаемый вместе с основной программой.
Подобных модулей-баннерососов создано уже довольно много, и отловить их вручную слишком сложно даже для опытного пользователя, а потому всегда полезно периодически сканировать систему не только антивирусным сканером, но программами типа Ad-Aware www.lavasoft.de/free.html, или Opt Out grc.com/optout.htm, или SpyBot - Search & Destroy (security.kolla.de), призванными находить и удалять из системы эти модули.
Такие программы обычно абсолютно бесплатны и имеют в своих постоянно обновляемых базах данных информацию о десятках известных шпионско-рекламных модулях и даже троянских вирусах. Учтите только, что некоторые программы не работают без таких "пауков" (тот же ReGet) - в этом случае можно либо заблокировать баннеры персональным файрволлом, например, AtGuard или Norton Internet Security, либо найти альтернативную программу аналогичного назначения, но уже без мерзопакостной нагрузки.
Всеми обожаемый браузер от повсеместно любимой корпорации Microsoft также имеет мало известную, но достаточно коварную возможность вместе со своим запуском загружать посторонние модули, так называемые Browser Helper Objects (BHO) - небольшие программы, не имеющие пользовательского интерфейса и автоматически запускаемые вместе с Internet Explorer.
Эти самые BHO могут быть как действительно ценными дополнениями (например, модуль, который прописывает в систему программа FlashGet), так и зловредными троянскими вирусами или шпионскими модулями, а потому при проверке автозагрузки нелишним будет проконтролировать и список установленных в системе BHO. Список этот можно увидеть в разделе реестра HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Windows\
Currentersion\Explorer\Browser Helper Objects.
Подозрительные или явно зловредные Browser Helper Objects можно удалить из этого списка (ленивым пользователям желательно предварительно сделать резервную копию реестра, а добросовестным - обязательно) - это их полностью дезактивирует.
Например, если в этом разделе вы обнаружите подраздел HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows\CurrentVersion\ Explorer\Browser Helper Objects\{A5366673-E8CA-11D3- 9CD9-0090271D075B}
то произведите поиск во всем реестре найденного идентификатора Browser Helper Objects - {A5366673-E8CA-11D3-9CD9-0090271D075B} - обнаружите его упоминание также и в разделе HKEY_CLASSES_ROOT\CLSID\
{A5366673-E8CA-11D3-9CD9-0090271D075B}.
Просмотрите все содержимое найденного раздела, чтобы определить, к какой программе относится этот Browser Helper Objects. В данном случае вы найдете такую запись: HKEY_CLASSES_ROOT\CLSID\
{A5366673-E8CA-11D3-9CD9-0090271D075B}\
InprocServer32@= "C:\PROGRAM FILES\FLASHGET\
JCCATCH.DLL", - из которой можно сделать вывод, что обнаруженный Browser Helper Objects создан программой FlashGet (менеджер закачек) и никакой угрозы совершенно не представляет.
Если же обнаружится упоминание библиотеки непонятного происхождения (например, в свойствах этого файла нет никаких данных о его разработчике), то попробуйте удалить в реестре все упоминания данного Browser Helper Objects - скорее всего, именно он и является причиной неприятностей.
Удобнее же всего для поиска и идентификации установленных Browser Helper Objects использовать специально для этого предназначенные программы, такие как BHODemon (http://www.definitivesolutions.com/) или BHOCaptor (http://www.xcaptor.org/), которые выдадут всю информацию об установленных модулях Browser Helper Objects и помогут деактивировать подозрительные модули.
Конечно, существуют и другие доступные способы загрузить программный код без ведома пользователя, например, с помощью плагина какой-либо программы, хотя бы того же всеми любимого браузера Internet Explorer. Файлы подключаемых модулей-плагинов Internet Explorer находятся в папке \Program Files\Internet Explorer\Plugins, по свойствам каждого файла можно выяснить его предназначение.
Не исключено также, что зловредной программе удастся прописать себя в системе как системный драйвер или сервис, одним словом, борьба с вирусами или другими, запускающимися без ведома пользователя программами, весьма и весьма непроста.
А самый лучший способ помочь самому себе в этой борьбе - постоянный мониторинг состояния файлов на диске, реестра и конфигурационных файлов с помощью хорошего деинсталлятора. Только так вы получите реальную картину того, что пишется на диск и в реестр при установке новых программ или при посещении находящихся на отшибе Сети веб-сайтов. Догадайтесь с трех раз, какой деинсталлятор я использую? Конечно, Ashampoo Uninstaller (http://www.ashampoo.com/) - мои постоянные упоминания этой программы, вероятно, уже изрядно всем надоели, но ничего лучшего лично для себя я пока не подобрал, тем более, что результаты ее работы меня более чем устраивают. Настоятельно рекомендую!
Вот, собственно говоря, и практически все, что касается способов автозагрузки приложений и документов в операционных системах семейства Windows (не все, конечно же, на самом деле, вы прочитали все, что мне вспомнилось на данный момент, по частным же вопросам, пишите мне лично).
С некоторой натяжкой, правда, к автозапуску можно отнести еще и возможность использования файла autorun.inf в корневой директории жесткого диска, но этому файлу уже была посвящена довольно большая статья в нашем журнале.
В особо же тяжелых случаях я советую попробовать определить имя исполнимого файла непонятно каким образом запущенного процесса с помощью программы типа TaskInfo (www.iarsn.com/download.html), а затем произвести тщательный поиск этого файла на диске и его упоминаний в системном реестре. Утилита эта вообще очень примечательна.
Она в реальном времени показывает информацию обо всех запущенных процессах (использование памяти и CPU, открытые файлы, используемые библиотеки и прочее).
Иконка программы помещается в системный трей и показывает загрузку процессора. С ее помощью также можно устанавиливать уровень приоритета для запущенных приложений.
Эта программа позволяет не только просмотреть почти все способы автозагрузки, но обладает еще целым рядом полезных функций. Например, с помощью утилиты Starter вы легко отредактируете любую запись в реестре, относящуюся к автоматически загружаемым программам, удалите, временно отключите или добавите в автозагрузку любое новое приложение или документ.
Также эта программа позволяет делать резервную копию автозагрузочных разделов реестра в виде текстового файла, документа HTML или стандартного reg-файла и, естественно, восстанавливать их из нее. Любую замеченную в автозагрузке программу можно запустить непосредственно из интерфейса Starter, просмотреть свойства исполнимого файла этой программы и открыть ее папку на диске.
Кроме того, с помощью Starter можно просмотреть и список запущенных процессов, задать любому из них нужный приоритет или принудительно выгрузить его из памяти. Словом, возможностей даже у далеко не идеального, на мой взгляд, Starter гораздо больше, чем у msconfig (впрочем, msconfig - более универсальная программа, призванная решать и другие задачи настройки системы), а пользоваться ей заметно удобнее, что, конечно, не исключает наличия и более продвинутых утилит мониторинга автозагрузки.
Поэтому я советую при активной работе с автозагрузкой пользоваться именно такими, более мощными программами. Однако, в тех случаях, когда даже с их помощью не удается выявить способ загрузки какой-либо программы или необходимо определить причину сбоя, следует вручную проконтролировать все возможные пути автоматической загрузки программ. Эти пути в Windows 9x и в Windows NT немного различаются.

На главную
Источник: http://www.computery.ru/upgrade/ http://www.izcity.com/ журнал"IZone"


Борис Леонтьев

Тонкости, хитрости и секреты Internet

---------------------------------------------------------------

Copyright Борис Леонтьев

Home page: http://members.rotfl.com/bobleon/ і

http://members.rotfl.com/bobleon/

Email: bobleon@uniinc.msk.ru

---------------------------------------------------------------

Тонкости, хитрости и секреты Internet

ББК 32.973

УДК 681.3

Главный редактор

Дмитрий Царик

Корректор

Ирина Царик

Художник-дизайнер

Борис Леонтьев

Леонтьев Б.

Л80 Тонкости, хитрости и секреты Internet. -- М.: Познавательная книга,

1998. -- 192 с.

ISBN 5-88548-065-6

В новой книге московского автора Бориса Леонтьева в легко доступной и

понятной форме описаны тонкости, хитрости и секреты глобальной компьютерной

сети Internet.

Copyright й Борис Леонтьев, 1998.

Copyright й Издательство "Познавательная книга плюс", 1998.

Copyright й Издательство "МиК", 1998. Серия и название серии.

Copyright й Design Studio M&C, 1998. Оформление серии и этой книги.

Copyright й Издательство "Утро" совместно с фирмой "Олег и Павел",

1998.

Авторские права на настоящую книгу, название серии "Кратко, доступно,

просто" и оформление самой серии принадлежат Борису Леонтьеву и издательству

"МиК". Полное или частичное копирование книги без разрешения правообладателя

является нарушением авторского права и может иметь юридические последствия в

соответствии с действующим законодательством.

Все названия продуктов, упомянутые в этой книге, являются товарными

знаками или зарегистрированными товарными знаками соответствующих

организаций.

Программное обеспечение, описанное в этой книге, поставляется

исключительно по лицензионному договору и может использоваться или

копироваться только в соответствии с условиями этого договора. Копирование

этого программного обеспечения на какой-либо носитель информации, если на

это нет специального разрешения по лицензионному договору, является

нарушением Закона Российской Федерации "О правовой охране программ для ЭВМ и

баз данных" и норм международного права.

ЛР No 069954 от 01.12.1991 г. Сдано в набор 06.07.98. Подписано в

печать 06.09.98. Формат 60X84/16.

Бумага типографская. Гарнитура "Newton". Печать офсетная. Физ. печ. л.

12. Тираж 5 000 экз. Заказ 48.

Internet

Вначале была ARPAnet. Сеть такая. Ее создало Министерство обороны США.

В этой сети каждый компьютер связывался с другим компьютером на равных.

Описание работы этой сети содержалось в протоколе. Так появился IP. Вскоре

были созданы рабочие станции и операционная система UNIX. Только UNIX

понимала IP. И случилось так, что все эти рабочие станции воссоединились с

сетью ARPAnet. Так UNIX стала самой классной операционкой мира. Потом на

сцене появился Национальный научный фонд. У этого фонда было пять

компьютерных центров. Попробовали и их объединить с ARPAnet. Ничего не

вышло. Попытались через телефонные провода. Тот же результат. Все вставало в

деньги. Точнее, их не было. Но кто-то оказался самым умным. Он решил так:

зачем объединять компьютеры всей страны, когда можно связать между собой

сети. Так появилась Сеть сетей Internet.

Чтобы попасть в эту Сеть сетей, вам нужно найти так называемого

провайдера. Так что теперь вопрос, связанный с деньгами будет стоять у вас.

Так как провайдеру нужно платить деньги. И порой немалые. Вы хотите сами

стать провайдером? Тогда вам нужны большие деньги, умные головы и выделенные

телефонные линии. Не хотите? Тогда все гораздо проще. Вам нужен модем,

обыкновенная телефонная линия и провайдер со SLIP или PPP. Это такие

протоколы. Что-то вроде посредников между линией связи и протоколом IP.

Будущее Internet

Это, что касается прошлого и настоящего. А теперь немного о будущем. По

данным весьма осведомленных источников на октябрь 1998 года в Internet

насчитывалось около 12 миллионов узлов. С одной стороны, это хорошо. Но!

Весьма авторитетный комитет IETF думает иначе. Дело в том, что ежедневный

рост узлов способен произвести катастрофу. Связано это с тем, что сетевые

маршрутизаторы в один прекрасный момент просто не смогут переваривать такой

объем информации. Вышеупомянутый комитет предлагает изменить четвертую

тридцатидвухразрядную версию протокола IP на новую

стодвадцативосьмиразрядную. Представляете, как в этом случае будет выглядеть

IP-адрес?!

Большие возможности Internet

В Internet скрыты весьма большие возможности. И это действительно так,

ибо Internet это масса бесчисленных локальных сетей (в том числе сетей

банков, бирж, общественных и коммерческих организаций). Здесь вы можете

найти все, что захотите. Различную информацию, архивы файлов, базы данных.

Службы Internet

Различную информацию, архивы файлов, базы данных вы можете найти через

так называемые службы Internet.

Archie . Через эти сервера вы можете по ключевому слову найти нужный

файл и FTP-сервер, на котором этот файл находится.

E-mail . Электронная почта Internet. Удобно, дешево и сердито. Сообщения

передаются через почтовый протокол SMTP (Simple Mail Transport Protocol).

FTP . Протокол передачи файлов. Это дело позволяет вам загружать файлы с

выбранных серверов на ваш винчестер.

Gopher . Через серверы Gopher вы можете осуществлять поиск информации в

Сети в сетей при помощи меню-ориентированного интерфейса.

Usenet . Конференции Usenet позволяют вам опубликовать в электронном

виде статью с тем, чтобы ее прочли и обсудили.

Telnet . Вы можете эмулировать терминал на удаленном хост-компьютере.

WAIS . Wide Area Information Service. При помощи этих серверов вы можете

найти информацию, содержащуюся внутри файла.

IRC . Селекторная болтовня. Чем-то напоминает работу в конференциях

Usenet или даже кое-что -- в Telnet. Но если в Usenet вы общаетесь не в

реальном времени, то здесь идет живой разговор.

Понятие узла Internet

Введем еще один термин. Будем считать, что узел -- это компьютеры,

через которые коннектятся различные сети Internet. Наличие узлов позволяет

построить сеть так, что она становится единым целым.

Как подключиться к Internet

Подключиться к Internet можно или через модем (медленная линия) или

напрямую (весьма быстрая работа). Нет, это не означает, что Internet

является стандартной или выделенной телефонной линией.

Internet -- это электронная линия связи, очень-очень напоминающая

обыкновенную почту (пакет корреспонденции отправляется в соответствующий

регион, там он сортируется и рассылается по адресатам).

Следовательно, подключиться к Сети сетей можно через несколько

протоколов, т. е. используя несколько методов, посредством которых

информация передается от хоста к вашему компьютеру.

Универсальный локатор ресурса

Документ в Internet ищется по так называемому адресу URL (Uniform

Resource Locator), синтаксис которого следующий:

protocol ://hostport/path

hostport -- адрес сервера с соответствующим номером порта. Этот

параметр отображает так называемую машинную адресацию. Машинная адресация

может быть числовой или буквенной.

path -- путь.

Вместо аргумента protocol может стоять:

http -- любая гипертекстовая информация.

ftp -- протокол передачи файлов.

telnet -- терминальный доступ.

gopher -- "предшественник" WWW.

afs -- файловая система Internet.

news -- конференции Usenet.

wais -- система баз данных Internet.

Способы подсоединения к Internet

В настоящее время существует пять основных способов подсоединения к

Internet:

1 . Прямое подключение к провайдеру.

2 . Подключение через SLIP/PPP.

3 . Подключение через терминал.

4 . Подключение в интерактивном режиме.

5 . Доступ через ISDN.

Прямое соединение

Прямое подсоединение к Internet обеспечивает самую быструю работу с

этой сетью. Вам не нужно набирать телефонный номер. Internet доступна любому

компьютеру вашей локальной сети 24 часа в сутки 7 дней в неделю.

Одно из наиболее существенных преимуществ прямой связи с Internet -

способность без особых проблем использовать GUI (графический интерфейс

пользователя), например обозреватель Microsoft Internet Explorer.

Подключение через SLIP/PPP

Если вы не можете подключиться к Internet напрямую, то лучше всего

воспользоваться вторым способом подключения к этой сети, а именно через

SLIP, PPP/SLIP (Serial Line Internet Protocol) или PPP (Point to Point

Protocol). Через эти протоколы связи вы можете быть присоединенными к

Internet в течение продолжительного времени. SLIP и PPP соединяются с

Internet по обычной телефонной линии. PPP более современный протокол, чем

SLIP. Поэтому требуйте у провайдера PPP, а не SLIP.

SLIP/PPP неплохо поддерживает GUI. Но! Скорость модема должна быть

определенной. Быстродействующий модем особенно полезен при работе с WWW.

Минимально

это --9.6Kbps или 14.4, весьма неплохо -- 28.8. Кроме того, модем

должен поддерживать протоколы коррекции ошибок и сжатия данных V. 42 и V.

42bis.

Нужно сказать, что реальная скорость модема очень сильно зависит от

качества телефонной линии. То есть, если ваш модем по паспорту имеет

скорость 28.8 Килобит в секунду, не факт, что он будет работать с такой же

скоростью на славных российских телефонных линиях. Самый классный модем это

тот модем, который способен автоматически обнаружить ошибки, уменьшить

скорость передачи, но не оборвать связь.

Этот тип доступа требует пакет программ TCP/IP. Как правило, эти

программы распространяются бесплатно. Поэтому плох тот провайдер, который

потребует у вас за них деньги.

Подключение через терминал

Доступ через терминал весьма популярен. Популярен потому, что его можно

получить практически бесплатно, например через научно-исследовательский

институт.

Основной недостаток -- отсутствие интерфейса GUI. А это означает, что:

n вы должны знать определенные виды команд

n вы не можете загружать файлы непосредственно

на свой компьютер

n текст электронной почты не может быть вставлен

из какого-либо буфера обмена

n при просмотре WWW вы видите только текст

Подключение в интерактивном режиме

Такой доступ предоставляют некоторые крупные коммерческие компании,

например, Demos или Sovam Teleport. В этом случае ваш выбор служб Internet

ограничен прайсом такой компании.

Доступ через ISDN

Доступ к Internet через цифровую сеть интегрированных услуг (ISDN)

означает подсоединение к этой сети по коммутируемой линии. На таких линиях

налажена цифровая связь. Поэтому информация передается на ваш компьютер со

скоростью от 28.8 до 128 килобит в секунду. Ошибки исключены.

Хакеры и Internet

Очевидно, что смысл Сети сетей состоит в разумности ограничения круга

пользователей того или иного сервера. Если подобный сервер закупорен

полностью, то и работать может с ним лишь тот, кто его закупорил. Поэтому,

любая компания, прежде чем принять решение о вступлении в сообщество

Internet , дает себе отчет в том, что существует возможность проникновения в

свой главный сервер неких посторонних лиц. Вот эти посторонние лица и

называются хакерами.

Да, хакеры -- это те, кто взламывают сети.

Делается это разными способами. Например, через порт терминала или порт

электронной почты.

Выбрав жертву, хакер прежде всего определяет, имеются ли на сервере

плохие пароли, плохо настроенный софт или испорченная операционка. Затем

выбирается метод собственной безопасности. Самый распространенный способ

проникнуть в сеть так, чтобы остаться незамеченным -- это взлом по цепочке.

Существуют тонны программ, посредством которых компьютер может вести

поиск пароля через перебор некоторого словаря имен. Сложнее вскрыть сеть,

если пароль логина имеет больше шести символов, чувствителен к регистру или

содержит цифры.

Но! В настоящее время многие сети открывают к себе доступ через

автоматическое прохождение системы паролей. Эта система построена на так

называемом файле паролей. В этом файле перечисляются доступные компьютеры и

пароли сети. Что делает хакер? Он вламывается в сеть и скачивает этот файл.

Все!

Другой способ взлома -- взлом через отладочные переключатели

операционных систем. Как известно эти переключатели могут иногда находиться

во включенном состоянии. Кроме всех этих вышеперечисленных приблудов,

конечно же, широко используется предварительная вирусная атака.

Взломав сеть, хакер заметает следы и уничтожает всю компрометирующую

себя информацию. И через некоторое время сматывается.

Любой квалифицированный хакер через обыкновенный факс-модем может

проникнуть даже в компьютер правительственного учреждения и, при желании,

настолько внедриться в любую как бы то ни было защищенную систему, что

просто-напросто разрушит ее. Так оно и было. Достаточно вспомнить

злополучный сегмент Milnet сети сетей и всем известную лабу Rome ВМС США.

Да, это был настоящий кошмар, когда один из этих чудаков-хакеров творил

безобразия в течение недели на одной из самых секретных военных баз Америки!

Вскрыть сеть можно и с помощью обыкновенного факс-модема или даже

факс-аппарата. Ведь в любой достаточно крупной компании факс подключен к

LAN! А это значит, что через номер факса хакер открывает доступ к заветному

шлюзу. Любой более или менее серьезный (или даже несерьезный) хакер Internet

ориентируется на локальную сеть. Ему интересен софт защиты от

несанкционированного доступа. Он спит новыми версиями firewall. Он смеется

при упоминании дурацкого "брандмауэр". Sun! Sun! Sun! На мир Робин-Гудов

надвигается шерифовский Sun! Все! Все погибли! Все хакеры стали системными

администраторами! Они исправились. Они больше не будут...

Да-да, системные администраторы утверждают, что именно брандмауэр и

есть то самое устройство, размещенное между локальной сетью и Internet,

позволяющее разного рода придуркам отстать от нашего сервера. Вот именно,

что только придуркам. Настоящим придуркам! Лицезреете пакетики для остановки

шпионского трафика? А хакер давно завладел всеми функциями подтверждения

полномочий! На самом деле хакер может сам проверить входные и выходные

данные.

Многие сисады боятся прощупывания их хакерами. И многие знают, что

закупорка пакетов UDP может остановить вскрытие.

Почему? Потому что сработает защита! Да, хакер блокирует пакеты, а

поэтому любые входы через TCP так же блокируются. Но проблема в том, что в

разработке самых умных брандмауэров участвуют те самые хакеры! А почему бы и

нет? Почему бы и не написать код вирусной программы, а потом придумать

соответствующий антивирус! Многие считают, что все-таки существует

возможность вызвать мастера, который поставит стальную дверь с цветным

домофоном. И многие надеются на эти самые брандмауэры Internet. Это далеко

не так. Да, Firewalls способны изолировать локальные сети от вскрытия из

Internet посредством экранирующих маршрутизаторов, двусторонних шлюзов и

барьерной хост-машины. Но! Проблема в том, что это известно каждому хакеру.

Экранирующие маршрутизаторы? Прекрасно! Проверка адреса IP и закупорка

фальшивого трафика? А кто говорит, что это не так? Все верно! Купорим

трафик. А как насчет Telnet и username/password logon?! Terminal Access

Controller Access System? Включайте! Но это стоит больших денег.

Многие компании защищаются электронными карточками. Поэтому их

вскрывают меньше других. Это дело действительно грамотно сконфигурировано.

SecurID Card имеет только тот юзер, который имеет право доступа!

Соответствующая прикладнуха идентифицирует истинность юзера через двойную

проверку счета и персональный код.

Это все, действительно, хорошо, за исключением тех случаев, когда

простой народ подает в суд. Не проще ли, господа, просто повесить трубку?

Пусть всегда будет занято? Или нет?

А многие, ради эксперимента, допускают к своим сетям хакеров. Результат

бывает плачевным. Хакеры проникают в массу секретных систем, получают полный

контроль и делают так, что их никто не может обнаружить в течение долгого

времени.

Хакеры пользуются ошибками софта. Они знают, что система заработает

сама по себе и конфиденциальная информация будет качаться туда, куда ей

необходимо качаться. Бывают, конечно, и "случайные ошибки". А почему бы и

нет? Могут быть в софте такие ошибки. Преднамеренные... Программные

закладки, программные закладки... Хакеры используют их для тех или иных

операций на удаленной машине. Да, действительно, хакеры используют эти самые

закладки в своих межсетевых махинациях! И если ваша система есть узел

коммутации телекоммуникационной сети, то хакеры могут расчленить сеть и

воспользоваться расчлененным файлом паролей. Именно таким образом на Венеру

не полетел космический корабль! Почему? Да потому, что оператор вместо

запятой поставил точку. А как насчет 100 000 долларов, которые были

позаимствованы неким анонимным подлецом во Внешэкономбанке нерушимой

республики свободной?

Хакеры, действительно, могут свести на нет безопасность информации

любого сервера! Кто же они такие? Хорошие программисты? Бывшие системные

администраторы? Обыкновенные студенты? Нигилисты? Оскорбленные юзеры?

Вундеркинды из компьютерной школы?

Несколько слов о так называемом бесплатном доступе в Internet

Оказывается, что в Москве существует два необычных сервера,

пpедоставляющие доступ в Internet, причем, кроме обыкновенных юзеров,

услугами этих серверов пользуются хакеры, фрикеры и другой подобный народ.

Речь идет о CompuServe и America-On-Line.

CompuServe считается самой легкой системой, т.е. легко ломающейся. Для

этого хакер находит дистрибутивные дискеты с программным обеспечением для

доступа к CompuServe и софт типа CreditWizard или Credit Master Comfake,

затем дозванивается до Scitor по телефону 9563589 и спокойно входит в сеть.

Scitor, как говорят хакеры, хорош тем, что доступ к ресурсам сети

предоставляется через сгенерированный выше описанным способом эккаунт, в то

время как SprintNet высылает информацию о логине и пароле пользователя на

адрес электронной почты.

В Москве сеть America-On-Line доступна через SprintNet (9280985,

9286344 или 5789119).

Непонятно, о чем и чем думают системные администраторы этих серверов.

Действительно бесплатный доступ в Internet

MTU Inform

Через guest/mtu и dialup.mtu.ru

Телефоны: 9955555, 9955556.

Caravan

Через caravan/caravan www.caravan.ru

Телефон: 9951070.

Caravan 2

Через caravan/free и DNS 194.190.218.2

Телефон: 9951070.

Caravan 3

Через caravan/demo и DNS 193.232.120.226

Телефон: 3324768.

Caravan 4

Через free/caravan

Телефон: 3324768.

Data Force

Через 2889340 для получения демонстрационного доступа в сеть

Телефон: 9566749.

Glas Net

Через demo/demo123 или 2220990 для получения демонстрационного доступа

в сеть

Телефоны: 7194457, 9274111, 9953535.

IBM Net

Через e-mail: ispp@patron.com для получения демонстрационного доступа в

сеть

Телефоны: 2586435.

Microdin

Через guest/guest

Телефон: 9951001.

Demos

Через _demo/demo

Телефон: 9613200.

Mega Electronics

Через test/test или guest/guest и www.mega.ru

Телефон: 9951070.

World Wide Web

World Wide Web -- система Internet, позволяющая получать доступ к

гипертекстовой информации через так называемые перекрестные ссылки. В WWW вы

можете читать текст, видеть картинки, наслаждаться музыкой или даже смотреть

видео-фильмы. Просматривая гипертекст, вы можете простым нажатием

клавиши мыши найти практически любую информацию. Это означает, что из WWW вы

можете получить доступ к Telnet, E-mail, FTP, Gopher, WAIS, Archie или

конференциям Usenet.

Но за все это придется платить качественным модемом и совершенным

компьютером. Кроме того, необходимо помнить о том, что на гнилой или

медленной линии блуждание по Web равносильно работе в среде Windows на

машине PC/AT c 286-м процессором.

Как был создан Web

Создал WWW Тим Бернерс-Ли. За это ему наше большое человеческое

спасибо. Сейчас WWW объединяет около 30 миллионов пользователей и 30 000

сетей, взамодействующих между собой через TCP/IP.

В древние времена, когда всемирной паутины еще не существовало, было

всего два способа получения и чтения сетевой информации. Пересылались и

принимались либо текстовые файлы, либо связанные бинарные файлы. Все это

дело загружалось (через xmodem, zmodem) на компьютер и обрабатывалось только

в автономном режиме. Что касается бинарных файлов, то прежде чем работать

дальше, эти файлы посредством специального приложения подвергались

восстановительным операциям.

Терпеть этого дальше никто не мог. И тогда в 1990 году в Женеве физик

Тим Бернерс-Ли разработал нечто. А именно -- систему для глобальной

компьютерной сети. Эта система была с единственным графическим интерфейсом,

через который удаленный пользователь в интерактивном режиме мог обращаться к

различным типам баз данных и технической документации.

Так был создан Web.

С чего начинался Web

Web начинался с 500 различных серверов или так называемых домашних

страниц, а позднее, уже в 1993 году их стало около 12000.

Уникальная схема адресации

WWW часто называют всемирной паутиной, подразумевая под этим понятием

тот факт, что блуждая по WWW вы можете запутаться. Это действительно так,

если вы новичок. Опытный пользователь, искушенный в поисковых системах Web,

способен достаточно быстро отыскать нужную информацию.

Узлы Web используют уникальную схему адресации, которая включает в себя

так называемый универсальный локатор ресурса (URL). Через модем

Web-информация попадает к вам на компьютер сразу после того, как вы набрали

телефонный номер сервера, на котором размещены странички, содержащие эту

информацию.

Классификация узлов Web

Все узлы Web классифицированы Международным центром сетевой информации

(NIC) на шесть доменов:

com -- коммерческие предприятия, например, провайдеры Internet

edu -- образовательные учреждения, колледжи и университеты

net -- действующие сети, например, Network Information Center

org -- непрофессиональные организации

mil -- военные сети

gov -- правительственные учреждения, например, whitehouse.gov

Кроме этого, все доменные имена имеют указатели на страну, в которой

расположен данный узел. Например, доменные имена .uk, .jp и .us представляют

соответственно Великобританию, Японию и США.

Как ищется информация в

документах WWW

Информация в документах Web может быть найдена по ключевым словам. Это

означает, что каждый обозреватель Web содержит определенные ссылки, через

которые образуются так называемые гиперсвязи, позволяющие миллионам

пользователей Internet вести поиск информации по всему миру.

WWW и другие ресурсы Internet

Web может открывать доступ к другим ресурсам Internet, например к

электронной почте, FTP, Gopher, WAIS или конференциям Usenet. Одно из таких

средств серфинга по Web обеспечивает встроенный в Windows 98 обозреватель

Microsoft Internet Explorer 4.0.

Используя, например, электронную почту, вы также можете вести поиск по

документам WWW. Для этого вы должны послать электронное сообщение, например,

по адресу agora@mx.nsu.nsk.su, указать в тексте письма send или rsend

<обратный адрес> и, наконец, получить запрошенный документ.

Постоянный IP-адрес

Постоянный IP-адрес обязателен, если вы хотите подключить локальную

сеть, работающую в сеансном режиме.

Cервер WWW под Windows NT

Вы можете загрузить сервер www под Microsoft Windows NT c ftp.cern.com.

IRC-клиент под Windows

Вы можете найти IRC-клиент под Windows на

http://www.tucows.com/software.html.

Различные приложения Internet для Windows

Вы можете скачать их со знаменитого сервера http://www.tucows.com/ или

с http://www.tucows.com/software.html.

SLIP и UUCP

Помните, что SLIP использует 8 бит. Cовpеменные системы аттестованные

на звание UNIX, обязаны поддерживать 8 бит во всех встроенных приложениях.

Где можно получить Netscape Communicator

На сервере ftp.netscape.com.

Вирусы и просмотр Web

Вы не можете заразиться вирусом, просматривая Web. Но при выполнении

загрузки новой программы компьютер может заразиться.

Достаточно простой осторожности, то есть не использовать файлы с

расширениями .EXE и .COM, различные драйверы, файлы Microsoft Word и не

пользоваться почтовыми программами, которые сами запускают вышеприведенные

вещи.

Сеть FIDONET и FTP

Вы можете найти на сервере ftp.kiae.su программное обеспечение,

позволяющее загружать файлы с FIDONET.

Конвеpтирование HTML в удобочитаемый текст

Любой обозреватель HTML способен сохpанять страницу в виде текстового

файла.

Подключение к провайдеру через IP

Чтобы подключиться к провайдеру через IP, нужен канал до этого

пpовайдеpа. Этот канал можно пpедставить в виде шланга, на концах котоpого

имеются pазъемы RS232/V.35/RS449/. Установка канала стоит от нескольких

сотен долларов (выделенная МГТС и модемы) до 12 тысяч долларов (pадиомодемы

и pегистpация в Минсвязи), месячная плата -- от нуля (pадиомодемы) до 1000

долларов (GoldenLine).

Hужен маршрутизатор, в котоpый воткнется втоpой конец канала. Пpоще

всего иметь дело с асинхpонным RS232 -- его можно воткнуть даже в COM-поpт

286 PC и поставить туда KA9Q. Для более навеpнутых интеpфейсов понадобится

более крутое железо и софт. От PC+Cronyx+FreeBSD/BSDi до Cisco 4700. Таким

обpазом, маршрутизатор будет стоить или 300 долларов (286 PC+сетевая каpта),

или 2500 долларов (PC+Cronyx+FreeBSD), или 5000 долларов (Cisco 2501) или,

наконец, 25000 долларов (Cisco 4000). Что именно нужно, -- зависит от ваших

потpебностей. Обычно удается все-таки обойтись либо KA9Q, либо PC+UNIX. UNIX

хоpош тем, что на него можно повесить электронную почту, конференции Usenet,

сервер WWW и пpочее.

WWW по электронной почте

Вы можете просматривать web, используя электронную почту. Для этого

пошлите в электронном письме help по адpесу: w3mail@elvis.ru.

Telnet

С помощью Telnet вы можете входить в другой компьютер и запускать на

нем тот или иной софт. Обычно, вы заходите на удаленный компьютер с целью

запустить shell или другую утилиту. Для того, чтобы зайти на компьютер, вы

должны знать его имя. Некоторые сервеверы требуют коннектиться к ним через

специфический порт.

Finger

Просто вызвав эту UNIX-команду, можно получить информацию о

пользователях, работающих в данный момент на конкретной системе. Некоторые

системы имеют различные команды finger. Некоторые finger не понимают

аргументов, некоторые понимают только User Id (вместо регистрационного имени

пользователя), а некоторые ищут только первое или последнее имя.

Как найти электpонный адpес

Существуют пpогpаммы, котоpые помогают отслеживать электpонные адpеса.

Эти сpедства включают Netfind, X.500, rtfm (поиск адpесов в Usenet) и WHOIS.

Как найти адpес узла по его имени

Для этого в вашей системе должен быть name resolver. В UNIX эта

пpогpамма nslookup. Кроме этого, вы можете послать сообщение на

dig@monolit.kiev.ua и в теле письма указать соответствующий домен, напpимеp

site foo.bar.baz. Вы получите IP-адpес соответствующего хоста или набоp MX.

Последние указывают на соответствующего пpовайдеpа запpашиваемого хоста.

Как послать электpонное письмо в Белый Дом

По следующим адpесам: president@whitehouse.gov или

vice.president@whitehouse.gov.

Как получить инфоpмацию о фондовом pынке

Если вы используете эмулятоp теpминала VT100 или ANSI, вызовите telnet

rahul.net и войдите в систему под именем guest.

Как получить доступ к Библиотеке Конгpесса

Через машинный адрес 140.147.254.3. Вы пpиконнектитесь к инфоpмационной

системе Библиотеки Конгpесса или к pаспpеделенной системе на основе

Gopher-сеpвеpа. Также существует сервер FTP (seq1.loc.gov).

Зайдите анонимно и задайте ваш электронный адрес в качестве паpоля.

Как получить доступ к Internet в своем pегионе

Если вы живете в ноpмальной стpане, то воспользуйтесь списком

news.answers. Это список доступных пpовайдеpов, пpедоставляющих доступ к

Internet по телефонной линии.

Программа dMail для Windows

Этот пакет предназначен для чтения, обработки и архивирования

полученной корреспонденции, для отправки писем и бинарных файлов по

протоколам UUCP, SMTP или POP3, а также для чтения и пересылки новостей с

использованием серверов NNTP. Все подготавливаемые и пришедшие письма

обрабатываются в соответствии с требованиями MIME.

Оплата услуги Internet по кредитной карточке российского банка

Все зависит от типа кридитной карточки. Например, VISA ELECTRON

Столичного банка сбережений работает и в MSN, и в Internet (оплата

программного продукта в США), а STB/Cirrus/Maestro -- нет.

Netscape Navigator и нормальное отображение русских букв в формах ввода

Это зависит от вашей кодировки. Если вы работаете с KOI-8, то нужно

установить соответствующую раскладку клавиатуры. При этом будут проблемы с

программами Windows. Если же вы работаете с кодировкой Windows (CP1251), то

нужно установить обратное перекодирование клавиатуры. Проще

всего -- поставить на машине исключительно русские шрифты.

Киберпространство и собственное рекламное агентство

Самые посещаемые места в Internet -- поисковые службы WWW. Там можно

опубликовать рекламу как тривиальным образом: прямо на форме ввода. Но так

всем места не хватит. Более точно адресуемая реклама, к тому же более емкая

по объему -- это печать рекламы при предоставлении результатов поиска.

Как по имени сервера узнать IP-адрес

IP-адрес сервера легко идентифицируется через команду PING (эта команда

существует в UNIX, Windows и Windows NT). Например, PING WWW.PTS.MIPT.RU.

Обозреватель WWW и неанонимный доступ к серверу FTP

Для доступа на FTP-сервер вы можете воспользоваться следующей

конструкцией ftp://login@FTP-name. Например, для доступа к FTP-серверу

Ritmpress (ftp.ritmpress.ru), в качестве логина, требующего ввести ftp, в

поле ввода URL можно ввести ftp://ftp@ftp.ritmpress.ru. Или можно задать не

только логин, но и пароль: ftp://login:password@ftp.ritmpress.ru.

Доступ к Internet и факсовые сообщения

Подобный сервис предоставляет компания Elvis. Для получения более

подробной информации отправьте письмо по адресу faxgate@elvis.ru. В тексте

сообщения напишите: help.

Два компьютера и один FTP

Для того, чтобы напрямую связать двух пользователей можно использовать

протокол FTP. Для этого нужно знать IP-адрес, логин и пароль.

Последовательность действий в UNIX:

ftp xxx.yyy.zzz.qqq

login: aaaaa

password: bbbbb

type binary

put имя_файла

bye

FTP: не один файл, а несколько сразу

Воспользуйтесь командной утилитой FTP. Она есть в Windows 95 и

WindowsNT. Примерная последовательность команд:

ftp

open

cd

binary

prompt

tatus

mget

Определение адреса компьютера, подключенного к Internet через домен

В UNIX воспользуйтесь командой nslookup, которая предназначена для

просмотра доменов. В Windows NT такая команда входит в состав сервера DNS.

Microsoft Windows и доступ к Internet через модем

Просто настройте Dial-Up Networking. Затем в Control Panel в Network

добавьте сервис TCP/IP и настройте его. После этого щелкните кнопкой мыши на

пиктограмме Dial-Up Networking и подключитесь к серверу. Введите имя, пароль

и путешествуйте по Internet с помощью Netscape Navigator или другой

программы.

Докачка файла в случае разрыва связи

За поддержку HTTP byte range отвечает WWW сервер. Из существующих

серверов различных производителей byte range поддерживают менее 10%.

Многие программы не умеют докачивать файлы. Гораздо проще и быстрее

качать их в старом стиле, используя Zmodem. Это вполне работает в нынешнем

варианте BBS, например на сервере www.aha.ru. Для особого удобства есть

очередь отмеченных файлов, которые вы можете получить быстро и без проблем

из главного меню BBS. Особо продвинутые пользователи могут даже написать

скрипт для своей терминальной программы, который будет делать это

автоматически.

Hемного сложнее обстоит дело с получением большого файла из Internet.

Скорость работы с некоторыми серверами невелика, ftp-соединение рвется и

замирает.

Поэтому если у вас возникла проблема при скачивании большого файла

через FTP, то отставьте в сторону Netscape и позвоните на узел простой

терминальной программой или зайдите на станцию через telnet поверх SLIP/PPP.

(Trumpet Winsock для этого не пойдет). Пользуясь текстовым режимом BBS, вы

можете указать тот URL, который хотите посетить. Нажмите g и напишите

ftp://ftp.gde.to.tam/koe/chto.zip. После этого вы можете прервать связь.

Файл будет перекачан и положен на диск удаленного узла. При очередном

посещении просто укажите тот же URL, и файл будет качаться намного быстрее.

Такой вариант весьма прост и полезен, но если порвется логическое соединение

с удаленным сервером, то файл будет докачан не до конца.

Длительность воспроизведения документа HTML

Это зависит от скорости вашего модема. Обычно модем со скоростью 14,4

Кбит/с загружает килобайт данных около секунды.

Как разделить одну телефонную линию на две физические

Разделить одну телефонную линию на две физические линии можно, поставив

аппаратуру уплотнения, которая честно пустит по одной паре от телефонной

станции до абонента два канала связи и у абонента разделит на две пары так,

что каждая из них будет иметь собственный телефонный номер. Делается это

через телефонную станцию и стоит ненамного дешевле, чем установка нового

телефонного номера! Одновременно разговаривать по телефону и работать с

модемом через один канал связи можно только между двумя абонентами, у

которых стоит оборудование, позволяющее это делать. Работать по модему на

один телефонный номер и одновременно звонить на другой через обычную

телефонную линию нельзя. Нужно или использовать вышеупомянутую аппаратуру

уплотнения, или ISDN.

Фрикерство

Под этим термином компьютерщики понимают генерацию тонов определенной

частоты, позволяющую проводить махинации с оплатой разговоров и сканирование

телефонной сети на предмет обнаружения модемных входов.

Как получить имена доменов и адреса IP

Обратитесь в Сетевой информационный центр (NIC). Это организация

обладает полномочиями по предоставлению имен и адресов IP. Вам нужно будет

оправить на рассмотрение одну из так называемых форм NIC.

Как защитить систему

Прежде всего убедитесь в том, что в вашей системе есть то, что может

заинтересовать взломщиков!

Как сделать на собственной web-страничке счетчик посещения

Попытайтесь найти в http://www.yahoo.com строку: HTML Counter.

Cохранение "чужой" web-страницы вместе с картинками

Воспользуйтесь редактором Netscape Navigator Gold.

Как организовать сервер доступа DNS, FTP, Usenet и почтовый сервер при

постоянном подключении к Internet

Воспользуйтесь Windows NT 4.0. Тут вы найдете полный набор служб для

работы в Internet и Intranet -- TCP/IP, DNS, DHCP, WINS, RAS. Для

организации Web-сервера -- IIS2.0 (FTP, Gopher, WWW).

Сетевые адаптеры, позволяющие организовать беспроводную работу

Оказывается и такие адаптеры существуют.

Сетевой адаптер WaveLAN, беспроводной сетевой мост WavePoint, сетевой

адаптер для переносных компьютеров WaveLAN/PCMCIA и сетевой адаптер ARLAN

655.

Сетевой адаптер WaveLAN предназначен для организации беспроводных

сетей. Вставляется в свободный разъем ISA любого персонального компьютера.

Работает на частоте 915 МГц (half-size) или 2.4 ГГц (full-size).

Обеспечивает пропускную способность 2 Мбит/с. Кодирует передаваемую

информацию по методу растянутого спектра (spread spectrum). Обеспечивает

дальность связи от 30 до 250 метров в помещении. При подключении внешних

антенн дальность связи возрастает до 15-20 км. Поставляются драйверы сетевых

операционных систем, Windows, OS/2 Warp, LAN Server, FTP, TCP/IP, DEC

Pathworks, Banyan Vines, Artisoft Lantastic, SCO UNIX, UNIXWARE, FreeBSD.

Поставляется в комплекте с комнатной всенаправленной антенной.

Беспроводный сетевой мост WavePoint обеспечивает связь между

беспроводной и кабельной частями локальной сети (radio-bridge, access

point). Может использоваться для подключения беспроводных сегментов к

кабельной сети и для организации беспроводного моста между двумя кабельными

сегментами, а также для создания сотовой беспроводной вычислительной сети в

рамках организации. Допускает настольную установку и настенный или

потолочный монтаж. По радиотехническим параметрам, дальности связи и

пропускной способности беспроводной связи совпадает с WaveLAN. Логически

представляет собой прозрачный мост на MAC-уровне. Поддерживает протокол

Spanning Tree IEEE 802.1d.

Обеспечивает управление сетью в рамках SNMP. Взаимодействует с

кабельным Ethernet 802.3 CSMA/CD в соответствии со стандартами 10Base2,

10Base5, 10BaseT. Обеспечивает интеллектуальную фильтрацию пакетов по

сетевым адресам, протоколам и содержимому. Поставляется с программными

средствами организации сотовой беспроводной сети WaveAROUND и WaveMONITOR, а

также средствами диагностики и настройки радиоканала. В комплект поставки

входит комнатная всенаправленная антенна.

Сетевой адаптер для переносных компьютеров WaveLAN/PCMCIA предназначен

для организации беспроводных компьютерных сетей с мобильными пользователями.

Может использоваться в конфигурации все-со-всеми и в сотовых беспроводных

сетях. Состоит из карты PCMCIA Type II и внешней антенны. Совместим со

стандартом PCMCIA Release 2.0. Сохраняет работоспособность при перемещении

со скоростью до 14 км/ч. По радиотехническим параметрам, дальности связи и

пропускной способности беспроводной связи совпадает с WaveLAN. Не допускает

возможности использования внешних антенн с высоким коэффициентом усиления.

Поставляются драйверы сетевых операционных систем NetWare, Windows, OS/2

Warp, LAN Server, FTP, TCP/IP, DEC Pathworks, Banyan Vines, Artisoft

Lantastic, SCO UNIX, UNIXWARE. Поставляется с программным средством

организации сотовой беспроводной сети WaveAROUND.

Сетевые адаптеры ARLAN 655 предназначены для организации беспроводных

сетей. Вставляются в свободный разъем ISA любого персонального компьютера.

Полностью совместимы с кабельными сетями. Электротехнические параметры,

дальность связи и пропускная способность совпадают с соответствующими

параметрами ARLAN 630-900 и 630-2400. Поставляются с драйверами NDIS, ODI,

Packet. В комплект поставки также входит комнатная антенна.

Это далеко не полный перечень оборудования. Детали вы можете получить в

CompTek International (телефоны в Москве: 135-4193, 135-4194, 135-4195) или

на http://www.cti.ru/radioethernet.

Полный список конференций Usenet

Любой сервер Mail-News при получении письма со строкой LIST отошлет на

ваш адрес этот список.

Изменение списка телефонов в Trumpet Winsock

В меню Dialer выбеpите функцию Setup.cmd. Здесь вы можете изменить

стаpые и внести новые телефонные номеpа, pазделяя их двоеточием.

Tcpman и терминальный режим Manual Login

Когда вы начинаете работать с Trumpet Winsock, то в момент набора

номера, при соединении с сервером и при ответах на вопросы нельзя нажимать

ESC. Если это сделать, то Winsock зависнет и на этом все прекратится.

Клавишей ESC можно воспользоваться только в нужный момент, то есть выбираете

Manual login и при удачном соединении вводите логин, затем пароль и,

наконец, устанавливаете протокол Slip или PPP. Когда увидите непонятные

символы на экране, нажмите ESC.

Чтение электронных сообщений, написанных на KOI-8

Вы пишите письмо в кодировке CP1251 MS Windows. От вас письмо приходит

на сервер и, проходя перекодировщик, отправляется дальше в кодировке KOI-8,

являющейся стандартом в системах электронной почты Internet. Чтобы не

использовать KOI-8, вам нужно в Eudora при написании письма нажать кнопку

QP.

Сообщение "Anonymous access denied"

Вход для анонимного пользователя запрещен! Вы пытаетесь зайти на этот

сервер в качестве незарегистрированного пользователя. На данном сервере для

таких пользователей сервис недоступен, поэтому скачать файлы с него у вас не

получится.

Электронные сообщения Uuencode-файлы в конференциях Fidonet

Письма с атрибутом Attachments Uuencode посылать нельзя. И самое

главное, не нужно надоедать людям. Fidonet -- интересная сеть, в ней живет

общением большое количество людей. Но она, как и все сети, имеет свои

законы.

Список каналов, имеющихся на сервере IRC

Воспользуйтесь командой /names.

Подсоединение к каналу IRC

Наберите в командной строке программы IRC команду /join #имя_канала.

Если этот канал существует, то вы подключитесь к нему. Если же канал не

существует, то вы его создадите.

Имена всех людей, находящихся в данный момент в канале IRC

Воспользуйтесь командой /who имя_пользователя.

Изменение псевдонима в IRC

В командной строке программы IRC введите команду /nick ххх. Вместо

аргумента ххх впишите свой новый псевдоним. Если на сервере уже присутствует

человек с данным псевдонимом, то выскочит соответствующее сообщение.

Псевдоним не может состоять из более, чем девяти символов.

Призраки в IRC

Ghost -- призрак. Это происходит тогда, когда вы отключились и опять

сразу же пытаетесь попасть на сервер. Сеанс вашей программы закончился, но

сервер этого не уловил. Ваш псевдоним продолжает висеть в канале. Снять

призрак может только оператор IRC-сервера.

Как через IRC послать файл своему собеседнику

Воспользуйтесь командами /dcc send псевдоним имя_файла (послать файл

пользователю) или /dcc get псевдоним имя_файла (принять файл от

пользователя).

Как в Internet найти IRC-cервер

Чтобы разыскать последние серверы IRC, читайте alt.irc. Вопросы и

ответы для этой группы новостей включают в себя список серверов. В рамках

IRC присоединитесь к каналу #irchelp или #wasteland, чтобы спросить о

серверах, либо введите команду /links, чтобы увидеть длинный список серверов

IRC, к которым в настоящее время подключен ваш сервер.

Undernet

Под этим термином понимают отдельную сеть серверов IRC. Домен

undernet.org. На них обычно находится меньшее количество пользователей, чем

в обычном IRC. Подсоединиться к ним можно так же, как и к обычным IRC

серверам. Просто наберите /server undernet.org.

Кто изобрел IRC

IRC был создан Джарко Ойкариненом (Jarkko Oikarinen) в Финляндии в 1988

г. IRC -- это система, позволяющая тысячам людей беседовать в реальном

времени. Для предотвращения всеобщей путаницы люди объединяются в каналы,

поддерживающие различные темы обсуждения. Любые символы, введенные через

программу IRC, появляются на экранах всех остальных участников вашего

канала.

Создание мультипликационных картинок для гипертекстового документа

Существует несколько способов. Вы можете включить в свою страничку

файлы GIF89, MPEG, дополнительные модули QuickTime, Shockwave или

мультипликационные проекты, сделанные посредством Java.

В настоящее время широко распространены мультяшки GIF89, которые хорошо

смотрятся на броузерах фирмы Netscape. Вы можете взять GIFMake --

инструмент, позволяющий создавать GIF89-мультипликации на платформе PC:

http://www.fastlane.net/~samiel

1. Анимированные GIF-картинки хорошо получаются

с помощью GIF Construction Set компании Alchemy

Mindworks. Shareware-версию можно взять на

http://www.mindworkshop.com.

2. GIF-аниматор: PhotoImpact GIF Animator

(www.ulead.com).

3. В Internet имеется хороший сервер для WEB-

дизайнеров. Там есть практически все.

Его адрес: http://web.canlink.com/webbesign.

4. Недавно Microsoft разместил на своем бесплатном

FTP сервере два продукта, предназначенных для

анимации GIF:

ftp://ftp.microsoft.com/msdownload/frontpage/image

composer/micsetup.exe -- мощная рисовалка с

возможностью создания ряда GIF-images.

ftp://ftp.microsoft.com/msdownload/gifanimator/gifset

up.exe -- программа создания анимированного GIF

файла из набора простых GIF-images (которые

можно сделать с помощью Microsoft Image

Composer). Обе программы работают под Windows 95 и

Windows NT 4.0.

Переход из Internet в X.25

Возможна организация шлюза на уровне приложений -- вы делаете Telnet на

некий IP-адрес, там стоит устройство, которое делает вызов X.25 и в

результате вы работаете в терминальной сессии через Telnet, а ресурс X.25

работает через X.3/X.28 (сесиию PAD). В качестве устройства может быть

маршрутизатор Cisco, Unix или NT c подключением к X.25 (например, через

EiconCard). Такие решения часто применяются в частных сетях, но об

общедоступных таких шлюзах информации нет. Может кто-то из поставщиков,

имеющих подключение к X.25 и Internet одновременно (Sprint, Роснет) такую

услугу оказывать и решит, но вряд ли. Если речь идет о терминальных сессиях

-- просто воспользуйтесь ближайшим узлом доступа X.25. Вам нужен только

компьютер с последовательным портом и терминальной программой и модем.

Если речь идет о других сервисах -- опять же надо искать приложение,

доступное в Internet и сети X.25. Скажем, почта между Internet и абонентами

сети Global X.25 (Sprint) может пересылаться через почтовую систему Sovmail,

живущую в сети X.25, и имеющую шлюзы в почту Internet (RFC-822) и другие

почтовые системы через X.400.

Как заставить Netscape Navigator реально перезагрузить страницу

При запросе Reload держите нажатой кнопку Shift.

Где можно взять программу для раскодирования формата BASE 64

1. Программу для перекодировки формата Base 64

можно получить на следующих серверах FTP:

Для DOS -- glas.apc.org/pub/tools/mime64.zip.

Для Windows -- ftp.ru/pub/os/windows/util/wncode26.zip.

2. Программа DMail (ftp.demos.su).

3. Очень хорошее средство для

кодирования/раскодирования файлов в различных

форматах -- программа Wincode.

Чем отличается протокол SLIP от PPP

Поверх PPP можно передавать не только IP, но и IPX.

PPP имеет встроенные протоколы аутентификации PAP и CHAP, так что

можно, например, делать модемные входы без login/password, но сразу с

запуском PPP.

PPP поддерживает динамическое назначение IP-адресов.

PPP передает меньше служебной информации чем SLIP , что чуть-чуть

увеличивает скорость обмена

Запуск в одном DOS-окне коммуникационной пpогpаммы

Просто добавьте в секции [386Enh] файла system.ini следующую

конструкцию:

Com<номер_порта>AutoAssign=<сколько_секунд_

удерживать_порт>.

Маршрутизация IP и Microsoft Windows

Windows 95 не умеет роутить IP. Решается эта проблема установкой на

машину, подключенную к Internet пакета WinGate. Этот пакет вы можете

загрузить с http://nz.com/NZ/Commerce/creative-cgi/special/qbik/wingate.htm

и использовать его в локальной сети в качестве proxy.

Фиктивный удаленный web-сервер

Это можно сделать через Web Server Front Page 98. Но тогда работа будет

весьма медленной. А можно воспользоваться Web App Server Baikonur. Именно в

этой программе существует параметр, ассоциирующий каталог со страничкой

HTML. URL для Baikonur является exe-файл, код которого написан на Borland

Delphi. Поэтому вы можете сгенерить практически любую функциональность. Если

в каталоге много файлов, то генерация такой страницы будет очень долгой. А

так все работает быстро.

Чтение конференций Usenet в автономном режиме

Некоторые программы для чтения конференций позволяют это делать,

например FreeAgent.

Если у вас Dial-Up IP и Windows 95, то поставьте Internet Mail&News

(входит в комплект Internet Explorer). В Internet News отметьте все письма

из конференций, которые хотите читать.

Relcom и некоторые другие провайдеры (в основном те, кто подключает

клиентов по UUCP без предоставления IP) позволяют получать новости почтой.

Для работы с таким сервером надо послать письмо, содержащее одну строку со

словом "HELP". После этого сервер новостей пришлет описание команд

управления им по почте.

Если ваш провайдер не имеет доступа к серверу Usenet, то скорее всего

он пользуется услугами провайдера более высокого уровня, у которого имеется

сервер новостей. Попробуйте обратиться к нему.

Самый простой и быстрый способ найти серверы

новостей -- зайти на домашнюю страничку Netscape в раздел net search.

Далее в любой системе поиска (Lycos, Infoseek и т.д.) зайти в раздел

Internet, и там поискать указатели на news. Существует много списков

news-серверов. Однако многие из них не пускают людей с улицы. Так что

потребуются некоторые усилия, чтобы найти "демократичный" сервер.

Подписка на русскоязычные конференции Usenet

Поищите русскоязычные конференции на следующих бесплатных серверах

NNTP:

news.ichange.com

news.uwsuper.edu

online.magnus1.com

news.ak.net

Можно также подписаться по UUCP (новости -- почтой) и по NNTP при

наличии подключения к Internet.

MSN

MSN -- типичная on-line система (как Compuserve, AOL, etc.), работающая

фактически в терминальном режиме, то есть сидит она на Dial-Up для локальных

пользователей и на старом добром X.25 для дальних. В России MSN доступна,

например, через Sprint. То, что у нее есть IP-адрес на который можно войти

Telnet'ом -- не факт. Может иметься исключительно почтовый шлюз с Internet.

Есть сервер WWW.MSN.COM, но к услугам MSN он имеет отношение, похоже, весьма

отдаленное.

Как сжимать графику для ее передачи по E-mail

Если это штриховая картинка, неплох GIF-формат, если с переливами

цветов, то JPEG. И в любом случае, -- сжать архиватором ARJ, ZIP или UC2. И

не забудьте преобразовать в UUENCODE или Base64, или воспользоваться

командой UUCP вместо RMAIL.

Если картинка растровая и речь идет только о том, чтобы корреспондент

мог посмотреть ее на экране, то стоит пользоваться форматом GIF (без потери

качества, максимум 256 цветов) или JPEG (с потерей качества, но без потери

количества цветов). Какой из вариантов даст меньший размер файла и лучший

результат надо выяснять в каждом случае экспериментально. В среднем картинки

с большим количеством цветовых переходов (градаций яркости) лучше берутся

JPEG (переходы цвета при этом сглаживаются). Стоит также сохранить картинку

с разрешением не выше 100 dpi (все равно экран больше не дает). Все эти

преобразования можно делать, например, с помощью утилиты LView. Найти ее

можно на http://www.lview.com или ftp://ftp.std.com/ftp/vendors/mmedia.

Радикальное решение -- конвертация в формат JPG (или MPG). Даже при

сохранении 100% качества truecolor-картинка становится в 2-3 раза меньше.

При типичном 32% качестве (на фотографиях отличия практически незаметны) --

в 5-20 раз. Конвертировать в JPG позволяют практически все современные

программы.

Как отправить письмо в CompuServe и America Online

Для посылки сообщения в Compuserve необходимо заменить запятую на

точку. Кроме того -- возможно, что этого не понадобится -- там пытаются

"очеловечить" имена. Все, что вам остается -- это набрать следующее:

имя@compuserve.com.

По поводу AmericaOnline. Вы должны знать всего-навсего условное имя

вашего респондента, после чего адрес указывается не просто, а очень просто:

имя@aol.com.

Бесплатное размещение собственной web-страницы

Свою страницу можно открыть бесплатно на www.geocities.com.

Internet и разговор с абонентом по обычному телефону

Разговаривать через Internet c абонентами телефонной сети теоретически

можно. Продукт называется VocalTec Telephony Gateway. Для этого надо, чтобы

кто-то где-то организовал соответствующий шлюз, т.е. поставил телефонный

сервер, одной ногой стоящий в Internet, а другой, через специальную

аппаратуру сопряжения (например, платы Dialogic), подключенный к телефонной

сети. Создание такого шлюза (железо плюс разработка софта плюс все прочие

затраты) будет стоить недешево, т.е. услуги его скорее всего должны быть

платными. Но это все теория. Информации же о реально существующих таких

шлюзах нет. Скорее всего и самих шлюзов пока нет и не понятно, будут ли.

Если вам на домашний телефон позвонят через Internet, вы, скорее всего,

обидитесь. Качество и разборчивость в большинстве случаев очень плохие. Вся

информация находится по адресу: http://www.tario.com.

Отключение набора номера в Windows 98 при работе с выделенной линией

Существует драйвер, прикидывающийся модемом для Direct Connection.

Устанавливается как модем, ведет себя как модем, но не требует набора. Вы

можете также написать новый modem.inf или найти этот файл в готовом виде в

Internet.

Internet-сервер на базе Windows 95

IBM открыл программу бета-тестирования ПО для создания Web-сервера под

Windows 95. Существуют варианты: "нормальный" и с повышенной защитой.

Остальная информация находится здесь:

http://www.ics.raligh.ibm.com/ics/icsbetas.htm.

Windows 95 и работа с Internet по выделенной линии связи

Никакого специального софта не требуется. При конфигурации Windows 95 в

локальной сети нужно только установить поддержку TCP/IP, указать IP-адреса

DNS сервера и Gateway (обычно это роутер типа Cisco или ему подобный).

Если речь идет о том, что на Com-порт машины с Windows 95 подключена

выделенная линия, идущая к поставщику услуг Internet (через модем или

нуль-модемный кабель, воткнутый прямо в порт маршрутизатора, стоящего

рядом), то ситуация достаточно неприятная. Microsoft в заботе об удобстве

пользователя много сделал для установления телефонного соединения, но

вариант direct connection предусмотреть забыл. Dial-Up Networking

обязательно хочет перед запуском PPP обменяться набором команд с модемом,

заставить последний набрать номер, установить соединение и прочее.

Естественно, на выделенной линии всего этого делать не надо.Теоретически

решение может быть таким: раскопать в Windows 95 файл скриптов,

ответственный за работу с модемами и понять как он устроен, то есть написать

собственный скрипт для direct connection, являющийся пустым.

Две конфигурации для двух разных провайдеров в Windows 95

Не надо ничего устанавливать! Протокол TCP/IP должен быть "голый".

Конфигурация для конкретного провайдера устанавливается в настройках

удаленного доступа.

Как найти работу с помощью Internet

Просмотрите справочник "Возможности трудоустройства и источники работы

в Internet" (Employment Opportunities and Job Resources on the Internet)

автора Маргарет Е. Райли. Эта сокровищница информации

(http://www.wpi.edu/~mfriley/jobguide.html) предлагает ищущим работу легкий

доступ ко всему, что в Internet имеет отношение к занятости.

MIME-файлы

Поскольку Internet ограничивает электронную почту только ASCII-текстом,

вы не можете использовать ее для пересылки файлов в двоичном коде, например,

таких как графические, файлы текстовых процессоров и программные,

использующие 8-й бит. Решение заключается в преобразовании этих файлов в

текст перед пересылкой их по Internet. Имеется несколько обычных способов

делать это, в том числе с помощью программ MIME (Multipurpose Internet Mail

Extensions -- Многоцелевого расширения почты Internet) или UUENcode.

Когда вы получаете MIME-файл, необходимо декодировать его перед

просмотром. На Internet есть множество декодирующих программ, как

бесплатных, так и условно-бесплатных. Например, ZR File Works фирмы Scandere

Software. Эта условно-бесплатная программа декодирует MIME- и

UUENCODE-файлы. Кроме того, она позволяет разархивировать файлы, сжатые

программами PKZIP, ARC, ARJ, LZH и ZOO, просматривать множество графических

файлов разных форматов, включая GIF, PCX и JPEG, даже проигрывать видео и

звук.

Программу ZR File Works можно получить как файл zrfw.zip через сетевую

службу PC World Online или непосредственно от фирмы Scandere Software.

Пересылка файлов через Internet

С помощью FTP или протокола передачи файлов вы можете получить доступ к

файловой системе удаленного компьютера. Это означает, что вы можете передать

файл (через FTP, например, вы можете пересылать файлы в бинарном виде или

как текст, то есть в виде ASCII) на удаленный компьютер или получить

необходимый файл с этого компьютера.

FTP был специально создан для того, чтобы пользователи Intrenet имели

доступ к терабайтам данных и бесчисленным архивам софта, различным

руководствам, звуковым файлам и картинкам. Любой уважающий себя сервер имеет

службу FTP, услуги которой, как правило, всегда бесплатные (достаточно

указать логин в виде anonymous, а в качестве пароля ввести свой адрес

электронной почты).

В настоящее время в Internet существует три разновидности FTP-серверов:

l Internet-style (доступ ко всем файлам

сервера).

l Listserver (ограниченный доступ).

l FTPmail (доступ через электронную почту).

Серверы ftpmail наиболее интересны для тех пользователей, у которых

доступ к Internet весьма ограничен, то есть они могут пользоваться только

электронной почтой. Вы вводите в своем письме несколько специальных команд,

которые должен выполнить выбранный вами FTPmail-сервер. Если все введено

правильно и ваше письмо пришло по назначению, то FTPmail-сервер начнет

искать необходимый файл практически во всех закоулках Internet. Если файл

найден, то вам его перешлют, в противном случае вам придет письмо с

информацией о том, что этого файла в природе не существует. Вещь, конечно,

хорошая, но если у вас полный доступ к ресурсам Internet, она вам ни к чему.

Профессионалы Internet работают с FTP не через Nescape Navigator или

Microsoft Explorer (несмотря даже на то, что в WWW уже содержится протокол

передачи файлов), а через специальную программу (такие программы называются

FTP-клиентами). Одной из лучших, на наш взгляд, является CuteFTP для Windows

95. Ниже мы приводим полное описание этой программы.

Итак, вы должны иметь доступ к Internet на уровне SLIP или PPP.

Загружаем FTP-клиент под славным именем CuteFTP.

При работе с CuteFTP у вас не будет необходимости знать все подробности

протокола передачи файлов. Вы можете получить каждый доступный бит

информации из каталогов удаленной системы, используя простой и итуитивно

понятный графический интерфейс.

CuteFTP для Windows

Основные возможности CuteFTP:

l интуитивный дружественный интерфейс.

l полноэкранный локальный и удаленный

просмотр директорий.

l интегрированная обработка индексных

файлов.

l кэширование уже посещенных каталогов и

индексных файлов для них.

l автоматическая загрузка дерева каталогов.

l FTP Site Manager. С помощью этой

встроенной программы вы можете

организовывать любую коллекцию

узлов FTP в иерархический порядок, причем

каждый узел будет иметь свои

собственные настраиваемые параметры.

l отмена любой активной операции не

выходя из Internet.

l продолжение прерванного соединения.

l закладки.

l использование нестандартных команд FTP.

Команды меню

В CuteFTP наборы команд и опций, использующиеся в процессе работы с

протоколом передачи файлов, содержатся в:

l меню FTP (Протокол передачи файлов).

l меню Session (Сессия).

l меню Bookmarks (Закладки).

l меню Commands (Команды).

l меню View (Просмотр).

l меню Directory (Каталог).

l меню Window (Окно).

l меню Help (Подсказка).

FTP (Протокол передачи файлов)

Опции меню FTP позволяют:

l получить доступ к диалоговому окну FTP

Site Manager. С помощью этого

диалогового окна вы можете поддерживать

базу данных FTP-узлов и оперировать

параметрами соединения этих узлов.

l получить доступ к диалоговому окну Quick

Connect. С помощью опций этого диалога

вы можете осуществить соединение без

дополнительных настроек FTP Site

Manager.

l завершить текущий сеанс FTP и закрыть

все активные соединения с удаленным

сервером.

l настроить программу CuteFTP.

l установить режим передачи файлов.

l выйти из программы CuteFTP.

Site Manager (Менеджер узла)

Выбранная команда FTP к Site Manager открывает доступ к диалоговому

окну FTP Site Manager, с помощью которого вы можете поддерживать базу данных

FTP-узлов и оперировать параметрами соединения этих узлов.

Опции диалогового окна FTP Site Manager

Крайний левый список

Этот список может содержать папки или группы узлов. Все папки

организованы в иерархическое дерево. Вы можете просмотреть содержимое каждой

папки посредством двойного нажатия кнопки мыши.

Крайний правый список

Этот список отображает содержание выбранной папки. В списке находятся

имена узлов FTP. Если вы дважды щелкните на имени, произойдет попытка

соединения с соответствующим узлом.

Add Folder

Добавить папку с узлами FTP в список через диалоговое окно Create new

folder. Вы можете также выбрать эту опцию посредством нажатия правой кнопки

мыши.

Delete folder

Удалить папку с узлами FTP из списка. Вы можете также выбрать эту опцию

посредством нажатия правой кнопки мыши.

Rename folder

Дать новое имя папке с узлами FTP. После двойного щелчка мышью

отображается диалоговое окно Rename folder. Вы можете также выбрать эту

опцию посредством нажатия правой кнопки мыши.

Import

Нажав эту кнопку, вы попадете в диалоговое окно Open. С помощью этого

диалогового окна вы можете импортировать в программу базу данных узлов FTP

из более ранних версий CuteFTP или из пакета WS_FTP. Все импортированные

узлы окажутся в корневой папке FTP Sites.

Add Site

Добавить узел FTP в список через диалоговое окно FTPSite Edit

(описание опций этого диалогового окна смотрите ниже). Вы можете также

выбрать эту опцию посредством нажатия правой кнопки мыши.

Delete Site

Удалить узел FTP из списка. Вы можете также выбрать эту опцию

посредством нажатия правой кнопки мыши.

Edit Site

Модифицировать узел FTP через диалоговое окно FTPSite Edit (описание

опций этого диалогового окна смотрите ниже). Вы можете также выбрать эту

опцию посредством нажатия правой кнопки мыши.

Quck Connect

(Немедленное соединение)

Выбранная команда FTP к Quick Connect открывает доступ к диалоговому

окну Quick Connect. Здесь вы можете ввести минимум необходимой информации

относительно удаленного узла и соединиться с ним без дополнительных настроек

FTP Site Manager. Введенная информация не сохранится в базе данных узлов

FTP. Поэтому рекомендуется пользоваться не этой командой, а менеджером узла.

Опции диалогового окна Quick Connect

Site Label

В это поле данных вводится имя, которое будет идентифицировано

менеджером узла проограммы CuteFTP.

Host Address

Полное доменное имя удаленного узла FTP, с которым вы хотите начать

сессию.

User ID и Password

В поля данных User ID и Password вводится информация позволяющая вас

идентифицировать. Пароль, введенный в поле Password, отобразится звездочками

и будет хранится на диске в зашифрованном виде. Впрочем, имеются много

способов расшифровать введенный пароль. Поэтому не сохраняйте важные пароли

в базе данных CuteFTP.

В большинстве случаев, чтобы войти в систему, достаточно активизировать

опцию Anonymous. В этом случае CuteFTP идентифицирует ваше имя как

анонимное, а пароль, как ваш адрес электронной почты, который задается в

диалоговом окне Options. Большинство узлов поддерживают именно такую схему

идентификации.

Login type

Кнопки Login type позволяют определить программе CuteFTP метод

идентификации удаленным сервером.

Normal

Отождествление пользователя

системы по идентификатору.

Вы должны ввести в поля

данных UserID и Password

достоверную информацию

относительно своего имени

пользователя и пароля.

Anonymous

Анонимный вход в систему.

Ваше имя идентифицируется

как анонимное, а пароль, как

ваш адрес электронной почты.

Double

Режим двойной регистрации.

Используется некоторыми

системами безопасности на

удаленных узлах. В этом

режиме пользователь

регистрируется два раза:

сначала как анонимный

пользователь, а затем

посредством ввода в поля

данных User ID и Password

соответственно своего имени и

пароля.

Transfer type

Определить тип передачи файлов. Установка по умолчанию соответствует

опции Auto-Detect.

ASCII

Режим передачи текстовых

файлов. Используется при

передаче текстовой

информации на узлы, не

поддерживающие

операционную систему DOS.

Помните, что любой бинарный

файл, переданный при

активизированной опции

ASCII, будет испорчен при его

конвертировании на удаленной

системе.

Image

Режим передачи бинарных

файлов. Любой тип файла,

переданный на удаленную

систему в этом режиме, не

подвергается дополнительной

обработке. Некоторые

отформатированные текстовые

файлы должны пересылаться

при активизированной опции

Image.

Auto-detect

Автоматический режим

передачи файлов. В этом

режиме программа будет

пересылать любые файлы с

расширением .TXT как

ASCII-файлы, а передача

всех остальных файлов будет

осуществляться в режиме

Image.

Initial Remote Directory

Используется для определения полного названия каталога на удаленной

системе. В этом каталоге вы окажетесь сразу после соединения с узлом. Если

вы не введете в это поле информацию, то в этом случае удаленная система

поместит вас в свой каталог по умолчанию.

Initial Local Directory

Полное название каталога, в котором вы можете хранить файлы для их

передачи на удаленную систему. Если вы не заполните это поле данных, то

программа будет использовать каталог по умолчанию из диалогового окна

Options.

Port

Это не последовательный порт. Это один из двух компонентов сетевого

адреса удаленной системы.

Retry

Количество попыток соединиться с удаленной системой. Используется в

случае, если узел в данный момент времени занят.

Delay

Количество времени (в секундах), по истечении которого будет

происходить следующая попытка соединиться с удаленным узлом.

Max Safe Index Size

Размер (в килобайтах) самого большого индексного файла, который будет

загружен без каких-либо дополнительных сообщений. Если размер индексного

файла будет превышать этот лимит, то CuteFTP выдаст соответствующую

подсказку.

Logical Parent Dirs

Переключатель, который может определить исходный каталог для следующей

сессии.

Auto-Load Index Files

Активизировать режим автоматической загрузки индексных файлов. В этом

режиме на удаленную систему будут передаваться все файлы из указанного

списка. Рекомендуется использовать этот переключатель при работе с

медленными узлами.

Use Firewall

Активизировать межсетевое устройство защиты, то есть CuteFTP будет

работать через собственный брандмауэр.

Resolve Links

Активизировать так называемый режим идентификации указателей связи.

Этот параметр, предназначенный для систем UNIX иногда помогает устранить

некоторые проблемы с удаленными узлами, которые не поддерживают UNIX.

AutoRename

Активизировать режим автоматического изменения некоторых особенностей

передачи файлов на удаленный узел.

Comments

Здесь вы можете ввести любое описание узла FTP.

Disconnect (Отсоединение)

Выбранная команда FTP к Disconnect прерывает текущую сессию FTP и

закрывает все активные соединения с удаленным серверoм. Вы также можете

выбрать эту команду через комбинацию клавиш Ctrl+X.

Options Settings

(Установка параметров)

Выбранная команда FTP к Settings к Options открывает доступ к

диалоговому окну Options, с помощью опций которого вы можете установить

некоторые параметры программы CuteFTP.

В диалоговом окне Options вы можете изменить параметры программы,

переключаясь между закладками General, Advanced, Display, Promts и Firewall.

Опции диалогового окна Options при выбранной закладке General

Mail address

Ввести ваш полный адрес электронной почты. Этот адрес будет

использоваться в качестве пароля при анонимной регистрации на удаленном

узле. Если у вас нет электронного адреса, то вы можете ввести в поле данных

Mail Address любую комбинацию символов, но помните, что этикет сетевого

общения требует от вас действительного адреса электронной почты.

Default Download Directory

Задать каталог по умолчанию, в котором будут находится файлы для их

передачи на удаленную систему. Для каждого узла вы можете переопределить

этот параметр в диалоговом окне FTP Site Edit.

Text Files Viewer

Имя программы, которая будет выполнять просмотр текстовых файлов. По

умолчанию этой программой является Notepad.

Log File

Файл, в который в процессе работы будет производиться необязательная

запись таких функций, как пересылка файла, работа с командами FTP и

сообщения с сервера. Если вы щелкните на знаке вопроса, то попадете в

диалоговое окно. Здесь вы можете указать полный путь к файлу и сохранить его

на диске.

Max safe index size

Размер (в килобайтах) самого большого индексного файла, который будет

загружен без какких-либо дополнительных сообщений. Если размер индексного

файла будет превышать этот лимит, то CuteFTP выдаст соответствующую

подсказку.

Default Retry

Установка по умолчанию для количества попыток соединиться с удаленной

системой. Используется в случае, если узел в данный момент времени занят.

Retry Delay

Установка по умолчанию для количества времени (в секундах), по

истечении которого будет происходить следующая попытка соединиться с

удаленным узлом.

Log FTP Commands

Записывать в файл с расширением .LOG команды FTP, которые были

использованы при работе с удаленным узлом.

Log server responses

Записывать в файл с расширением .LOG любые сообщения с сервера, которые

были получены в процессе работы.

Log transefers to file

Записывать в файл с расширением .LOG имена файлов, которые были

переданы на удаленный узел или получены с этого узла.

Auto-save view settings

Сохранить все модифицированные параметры при выходе из программы.

Show directory messages

Отображать информационные сообщения относительно каталогов удаленного

узла.

Show login messages

Отображать любые сообщения сервера.

Auto-load index files

Автоматически начать загрузку любых индексных файлов при соединении с

узлом.

Resolve links

Активизировать так называемый режим идентификации указателей связи.

Этот параметр для систем UNIX иногда помогает устранить некоторые проблемы с

удаленными узлами.

Опции диалогового окна Options при выбранной закладке Advanced

Use logical parent dir

Определить исходный каталог для следующей сессии.

ASCII transfers on View

Просмотреть удаленный файл в режиме ASCII. Вы можете не выбирать эту

опцию, а использовать свою программу просмотра.

Confirm file names

Использовать при пересылке файлов процедуру подтверждения.

Auto-refresh remote dir

Перезагрузить перечень файлов каталога сразу, после того как

завершились файловые операции с сервером.

Double-Click Action

Активизировать режим двойного щелчка кнопкой мыши.

Connect Sound

Подать звуковой сигнал в случае удачного соединения с узлом. Опция

Predefined позволяет использовать для этого звуковые файлы операционной

системы Windows.

End Transfer Sound

Подать звуковой сигнал в случае выхода из сессии. Опция Predefined

позволяет использовать для этого звуковые файлы операционной системы

Windows.

Опции диалогового окна Options при выбранной закладке Display

ToolBar

Использовать большие или маленькие кнопки на инструментальной панели.

Через параметр Customize вы можете настроить полосу командных кнопок по

своему желанию.

Font

Выбрать гарнитуру, кегль и размер шрифта, который будет использован при

отображении стандартных диалоговых окон.

Colors

Этот параметр оформления позволяет изменить цвет некоторых элементов и

функций программы. В соответствии с иерархией параметров ими могут быть:

n информационная панель.

n индикатор прохождения обработки.

n состояние регистрации.

n вывод комманд.

n сообщения об ошибках.

Опции диалогового окна Options при выбранной закладке Promts

Overwrite confirmation

Выдавать сообщение на информационной панели перед перезаписью файла.

Transfer binary file in ASCII mode warning

Выдавать сообщение при установке неверного режима передачи файлов.

Delete confirmation

Выдавать сообщение перед удалением файла.

Drag-drop operations confirmation

Выдать сообщение перед транспортировкой файла мышью.

Опции диалогового окна Options при выбранной закладке Firewall

Опции диалогового окна Options при выбранной закладке Firewall

позволяют вам работать через брандмауэр CuteFTP.

Host

Полное доменное имя удаленного узла FTP, с которым вы хотите начать

сессию.

Port

Один из двух компонентов сетевого адреса удаленной системы или его

номер сокета. Первым из этих компонетов является IP-адрес узла, а второй --

его логический порт TCP.

Сервис FTP организован таким образом, что по умолчанию данные протокола

передачи используют 20-й логический порт, а команды -- 21-й.

Номера логических портов могут быть изменены или размультиплексированы

системным администратором удаленного сервера. В этом случае у вас возникнут

проблемы, так как нарушится связывание портов.

Как правило, все узлы Internet поддерживают так называемую стандартную

таблицу портов. Перед началом сессии происходит двойная идентификация.

Сначала определяется IP-адрес узла, затем ваш компьютер соединяется с

удаленным логическим портом TCP и, если его номер имеется в стандартной

таблице, устанавливается связь.

Нужно сказать, что именно блокировка трафика логическими портами в

диапазоне по умолчанию от 0 до 1023 позволяет взломать практически любую с

ног до головы защищенную систему. Достаточно добавить, например, на порт

1024 любого демона telnet, зарегистрироваться в собственной программе,

спокойно войти в систему, переустановить параметры в маршрутизаторе

программой inetd и, наконец, настроить все службы системы по своему желанию.

User ID и Password

Информация, позволяющая идентифицировать пользователя удаленным узлом.

Пароль, введенный в поле Password, отобразится звездочками и будет храниться

на диске в зашифрованном виде.

Type PASV mode

Пассивный режим защиты. По умолчанию этот режим отключен.

В этом режиме CuteFTP инициализирует все соединения с сервером без

использования брандмауэра. Это означает, что между вашим компьютером и

удаленным узлом нет дополнительного шлюза защиты.

Type SITE site

Стандартный режим защиты узла. В этом случае весь входящий трафик

блокируется фильтрацией пакетов TCP.

OPEN Site

Открытый режим защиты узла. В этом режиме трафик может блокироваться

различными способами.

USER user@site

Блокировка трафика адресом электронной почты.

USER with logon

Блокировка трафика регистрационным именем.

Enable firewall access

Включить систему защиты между локальным компьютером и удаленным узлом

FTP.

Transfer type (Тип передачи)

При выборе команды FTP к Transfer type появляется падающее меню, с

помощью опций которого вы можете определить режим передачи файлов.

При пересылке файлов на удаленную систему программа CuteFTP позволяет

использовать следующие опции:

ASCII

Режим передачи текстовых файлов. Используется при передаче текстовой

информации на узлы, не поддерживающие операционную систему DOS. Помните, что

любой бинарный файл, переданный при активизированной опции ASCII, будет

испорчен при его конвертировании на удаленной системе.

Image

Режим передачи бинарных файлов. Любой тип файла переданный на удаленную

систему в этом режиме не подвергается дополнительной обработке. Некоторые

отформатированные текстовые файлы должны пересылаться при активизированной

опции Image.

Auto-detect

Автоматический режим передачи файлов. В этом режиме программа будет

пересылать любые файлы с расширением .TXT как ASCII-файлы, а передача всех

остальных файлов будет осуществляться в режиме Image.

Exit (Выход)

Выбранная команда FTP к Exit позволяет прервать все соединения и выйти

из программы CuteFTP.

Session (Сессия)

Опции меню Session позволяют:

n запустить другую копию CuteFTP

с параметрами текущей сессии.

n используя параметры текущей сессии,

добавить новый компонент в базу данных

менеджера узла.

n сохранить текущий путь к локальному

каталогу в базе данных менеджера узла.

n сохранить текущий путь к удаленному

каталогу в базе данных менеджера узла.

Spawn Session (Создать сессию)

Выбранная команда Session к Spawn Session позволяет запустить другую

копию CuteFTP с параметрами текущей сессии.

Add to Database (Добавить в базу данных)

Выбранная команда Session к Add to Database позволяет, используя

параметры текущей сессии, добавить новый компонент в базу данных менеджера

узла.

Save Local path (Сохранить путь к локальному каталогу)

Выбранная команда Session к Save Local Path позволяет сохранить текущий

путь к локальному каталогу в базе данных менеджера узла.

Save Remote path (Сохранить путь к удаленному каталогу)

Выбранная команда Session к Save Remote path позволяет сохранить

текущий путь к удаленному каталогу в базе данных менеджера узла.

Bookmarks (Закладки)

Опции меню Bokmarks позволяют:

n добавить закладку в список.

n редактировать закладки в списке.

Add (Добавить закладку)

Выбранная команда Bookmarks к Add позволяет добавить закладку узла FTP

в список существующих закладок.

Edit (Редактировать закладку)

Выбранная команда Bookmarks к Edit позволяет редактировать закладки

узлов FTP в списке.

Commands (Команды)

Опции меню Commands позволяют:

n загрузить выделенные файлы или каталоги

(в том числе и подкаталоги) из удаленного

узла на жесткий диск.

n переслать выделенные файлы на удаленный

узел.

n загрузить файл из удаленного узла во

временную область и просмотреть его

содержимое.

n загрузить выделенный файл с узла и

запустить его, используя программу,

которая предварительно была сопоставлена

этому типу файла.

n загрузить файл вместе с его указателем на

связи.

n вручную ввести имя файла для загрузки из

удаленного узла.

n изменить вручную путь к локальному или

удаленному каталогу.

n стереть выделенные локальные или

удаленные файлы и/или незаполненные

каталоги.

n переименовать выделенные локальные или

удаленные файлы.

n создать новый каталог на локальной или

удаленной системе.

n прервать любые активные процессы задания.

n определить команды, не описанные в

оригинальном стандарте FTP.

Download (Загрузить из узла)

Выбранная команда Commands к Download позволяет загрузить выделенные

файлы или каталоги (в том числе и подкаталоги) из удаленного узла на ваш

жесткий диск. Вы также можете выбрать эту команду через комбинацию клавиш

Ctrl+PgDn или через двойной щелчок мышью на имени необходимого файла.

Upload (Переслать на узел)

Выбранная команда Commands к Upload позволяет переслать выделенные

файлы на удаленный узел. Эта команда доступна лишь в том случае, если

локальное средство просмотра имеет так называемый фокус ввода. Вы также

можете выбрать эту команду через комбинацию клавиш Ctrl+PgUp.

View (Просмотреть содержимое файла)

Выбранная команда Commands к View позволяет загрузить файл из

удаленного узла во временную область и просмотреть его содержимое через

Notepad. Вы также можете выбрать эту команду через комбинацию клавиш Ctrl+V.

Execute (Выполнить)

Выбранная команда Commands к Execute позволяет загрузить выделенный

файл с узла и запустить его, используя программу, которая предварительно

была сопоставлена этому типу файла.

Команда Commands к Execute доступна лишь в том случае, если передача

соответствующего файла была завершена. Вы также можете выбрать эту команду

через комбинацию клавиш Ctrl+G.

Get link as file (Получить ссылку в качестве файла)

Выбранная команда Commands к Get link as file позволяет загрузить файл

вместе с его указателем на связи. Как правило, все связи трактуются в

качестве путей к соответствующим каталогам.

Manual get (Загрузить вручную)

Выбранная команда Commands к Manual Edit позволяет вручную ввести имя

файла для загрузки из удаленного узла.

Change dir (Изменить каталог)

Выбранная команда Commands к Change dir позволяет изменить вручную путь

к локальному или удаленному каталогу. Вы также можете выбрать эту команду

через комбинацию клавиш Ctrl+D.

Delete (Удалить)

Выбранная команда Commands к Delete позволяет удалить выделенные

локальные или удаленные файлы и/или незаполненные каталоги. Вы также можете

выбрать эту команду через клавишу Del.

Rename (Переименовать)

Выбранная команда Commands к Rename позволяет переименовать выделенные

локальные или удаленные файлы. Вы также можете выбрать эту команду через

комбинацию клавиш Ctrl+N.

Make new dir (Создать новый каталог)

Выбранная команда Commands к Make new dir позволяет создать новый

каталог на локальной или удаленной системе. Вы также можете выбрать эту

команду через комбинацию клавиш Ctrl+M.

Stop (Команда останова)

Выбранная команда Commands к Stop позволяет прервать любые работающие

задания. Процесс закончится сразу после того, как из окна индикатора

обработки исчезнет сообщение "Trashed response data received". Вы также

можете выбрать эту команду через клавишу F8.

Нежелательно использовать команду останова сразу после соединения с

сервером. Это связано с тем, что любые операции, кроме отправки файлов,

каталогов и списков, работают через так называемый отклик на первую

командную строку FTP.

В зависимости от типа связи работающее задание может остановиться

немедленно или только после того, как на вашем экране погаснет сообщение

"Trashed response data received". Это связано с тем, что после того как вы

выбрали команду останова, удаленный сервер FTP должен подтвердить ее и

послать на ваш компьютер соответствующий ответ. Однако, CuteFTP не ждет

этого ответа. Программа будет пытаться прервать активное задание немедленно.

Если тип связи совместим с CuteFTP, то это произойдет. В противном случае

вам придется запастись терепением и ждать.

После того как вы измените локальный или удаленный каталог, а затем

прервете работу командой останова, нарушится трассировка между CuteFTP и

удаленным сервером. Помните, что трассировка восстановится лишь в том

случае, если вы запустите регенерируемый модуль программы через команду View

к Refresh.

Custom (Специальные команды)

Выбранная команда Commands к Custom открывает доступ к диалоговому окну

Custom Commands, с помощью которого вы можете определить команды, не

описанные в оригинальном стандарте FTP.

Стандарт для протокола передачи файлов был установлен еще в древние

времена. С тех пор он так и не пересматривался. В результате, накопилось

множество операций связанных с передачей файлов, которые могут быть

выполнены лишь через дополнительные команды, расширяющие оригинальный

стандарт FTP. В CuteFTP для этого разработан так называемый механизм

специальных команд.

Все установки специальных команд, которые вы определите с помощью этого

механизма будут сохранены в файле COMMANDS.DAT.

В CuteFTP любые параметры командной строки могут быть представлены в

одной из двух форм:

=

или

Буквенный регистр символов игнорируется.

Ниже представлен список доступных параметров.

Host=<host address>

Этот параметр устанавливает адрес удаленного узла. Аргумент <host

address> может иметь доменное имя или IP-адрес (например, 194.18.87.57).

User=<user ID> и Pass=

Эти строковые параметры устанавливают соответственно регистрационное

имя и пароль пользователя. Если сервер требует пароль, но последний

отсутствует, то CuteFTP выведет соответствующее поле данных для ввода. Из

соображений безопасности это поле не блокируется лишь в режиме

автоматической регистрации.

Retry=<retry count>

Счетчик повтора. Десятичное число.

Port=<port number>

Порт сокета удаленного узла. Десятичное число.

Local=<local directory>

Установить каталог на локальном компьютере.

Remote=<remote directory>

Установить каталог на удаленном узле.

Get=<remote file name>

Загрузить файл/каталог из удаленного узла и сохранить его в текущем

каталоге локального компьютера. Аргумент <remote file name> есть полное имя

пути к соответствующему файлу/каталогу или само имя файла. В последнем

случае удаленный каталог должен быть объявлен текущим.

Put=<local file name>

Переслать файл и сохранить его в текущем каталоге удаленного сервера.

Аргумент <local file name> есть полное имя пути к соответствующему

файлу/каталогу или просто имя файла. В последнем случае локальный каталог

должен быть объявлен текущим.

Anonym

Использовать анонимную регистрацию. В этом случае аргументы параметров

User=<user ID> и Pass= игнорируются.

Script=<script file>

Запустить из командной строки программу, сохраненную файле <script

file>. Аргумент <script file> является текстовым файлом ASCII, в каждой

строке которого записаны команды. Если текст в файле предваряется знаком #,

то он программой CuteFTP игнорируется. Скрипты могут быть вложенными.

Все вышеперечисленные параметры обрабатываются последовательно.

Параметры Host, User, Pass, Port, Retry и Anonym работают лишь в том

случае, если соединение инициализировано. Поэтому, не имеет смысла

определять хотя бы один из этих параметров более одного раза.

Параметры Local и Remote имеют силу для всех последующих команд Get и

Put до тех пор, пока эти параметры не переопределены. Например,

последовательность команд

Local=c:\work

Get=/pub/report1.txt

Get=/pub/report2.txt

Local=c:\temp

Get=/pub/report3.txt

загрузит файлы report1.txt и report2.txt в локальный каталог c:\work, а

файл report3.txt в каталог c:\temp.

В CuteFTP имеется один параметр, который отличается от вышеупомянутых.

Этот параметр разработан для того, чтобы упростить интеграцию CuteFTP с

другими программами Internet. Через этот параметр вы можете определить

строку URL в следующем формате:

ftp://[user ID:password@]<host name> [:port]/[path name/][get file

name]

Это одна строка (возврат каретки отсутствует) без лишних пробелов.

Теперь перейдем к описанию опций диалогового окна Customs Commands.

Опции диалогового окна Custom Commands.

Commands

Окно со списком установленных команд. Щелкнув мышью на имени команды вы

можете изменить ее свойства в поле Command text.

Label

Поле данных для идентификаторов команд. Текст, введенный в это поле

будет отображен в окне Listbox и в ниспадающем меню Custom Commands.

Command Text

Код команды FTP, которая перешлется на сервер и начнет на нем

выполняться. В это поле вы также можете ввести один или несколько макросов.

Макросы представляются в следующем виде:

%[ prompt ]

Когда этот макрос запустится на сервере, программа CuteFTP отобразит в

диалоговом окне дисплей с полем для ввода данных. Пользователь может ввести

в это поле любую текстовую информацию, которая будет воспринята выполняемой

командой FTP.

В качестве аргумента prompt может быть любой текст, но без квадратных

скобок, так как они будут использованы в поле для ввода.

Show server's response

Отобразить любые, поступающие с сервера, сообщения относительно

выполняемой команды.

Hot Key

Комбинация клавиш, назначенная команде FTP.

Ниже приводятся два примера некоторых общих специальных команд

протокола передачи файлов.

SITE CHMOD %[New Access Mask] %f

Эта команда выдаст запрос New Access Mask (Новая маскировка доступа) и

будет использовать этот запрос для каждого выделенного файла. Если

пользователь, например, в ответ введет аргумент =rwx, то файлы FILEA.TXT,

FILEB.TXT и FILEC.TXT будут выбраны, и следующая последовательность команд

будет послана на сервер:

SITE CHMOD =rwx FILEA.TXT

SITE CHMOD =rwx FILEB.TXT

SITE CHMOD =rwx FILEC.TXT

SITE INDEX %[Search Text]

Эта команда выдаст запрос Search Text (Поиск текста) и перешлет на

сервер одну команду. Если в ответ, например, ввести cuteftp, то следующая

команда будет передана на сервер:

SITE INDEX cuteftp

View (Просмотр)

Опции меню View позволяют:

n просмотреть информацию о файлах и

каталогах в сокращенном виде.

n просмотреть информацию о файлах и

каталогах в подробном виде.

n просмотреть различную детализированную

информацию о файле или каталоге.

n выбрать метод сортировки для

загруженных файлов или каталогов.

n автоматически загрузить индексный файл

при модифицировании соответствующего

каталога.

n вывести индексный файл для текущего

каталога.

n восстановить трассировку между CuteFTP и

удаленным сервером.

Short listing (Сокращенный список)

Выбранная команда View к Short listing позволяет просмотреть информацию

о файлах и каталогах в сокращенном виде. Вы также можете выбрать эту команду

через клавишу F2.

Long listing (Подробный список)

Выбранная команда View к Long listing позволяет просмотреть информацию

о файлах и каталогах в подробном виде. Вы также можете выбрать эту команду

через клавишу F3.

File details (Детализированная информация)

Выбранная команда View к File details позволяет просмотреть различную

детализированную информацию о файле или каталоге.

Вы можете отобразить информацию относительно файла или каталога в

следующем виде:

n размер.

n дата создания.

n время (в часах и секундах) последнего

обновления.

n описание.

Sorting (Сортировка)

Активизированная команда View к Sorting позволяет с помощью

ниспадающего меню выбрать метод сортировки загруженных файлов или каталогов.

Загруженные файлы или каталоги вы можете:

n упорядочить по имени.

n упорядочить по расширению.

n упорядочить по размеру.

n упорядочить по дате создания.

Auto-load index (Автоматически загрузить индексный файл)

Выбранная команда View к Auto-load index позволяет автоматически

загрузить индексный файл, когда изменяется новый каталог. Эта установка

также доступна из диалогового окна FTP Site Edit.

Retrieve index (Вывести индекс)

Выбранная команда View к Retrieve index позволяет вывести индексный

файл для текущего каталога. Используйте эту команду при неактивизированной

опции Auto-load index.

Refresh (Восстановить)

Выбранная команда View к Refresh позволяет восстановить трассировку

между CuteFTP и удаленным сервером посредством включения регенерируемого

модуля программы. Это означает, что будет производится обновление текущего

каталога или списка файлов. Вы также можете выбрать эту команду через

клавишу F5.

Window (Окно)

Опции меню Window позволяют:

n переключиться из локального режима

просмотра в удаленный.

n включить или отключить режим локального

просмотра.

n включить или отключить режим удаленного

просмотра.

n скопировать в буфер промежуточного

обмена содержимое информационной

панели.

Switch Browser (Переключить просмотр)

Выбранная команда Windows к Switch Browser позволяет переключиться из

локального режима просмотра в удаленный.

Toggle Local (Режим локального просмотра)

Выбранная команда Windows к Toggle Local позволяет включить или

отключить режим локального просмотра.

Toggle Remote (Режим удаленного просмотра)

Выбранная команда Windows к Toggle Remote позволяет включить или

отключить режим удаленного просмотра.

Copy Log (Скопировать содержимое информационной панели)

Выбранная команда Windows к Copy Log позволяет скопировать в буфер

промежуточного обмена содержимое информационной панели.

Directory (Каталог)

Опции меню Directory позволяют:

n найти имя файла и его дескриптор в

текущем каталоге.

n вывести результат последней команды Find

и начать новый поиск.

n отфильтровать файлы.

n выбрать большую группу подобных файлов

с масками трафаретных символов.

n отменить выборку группы.

n обратить в предыдущее состояние выборку

группы.

n отобразить суммарную информацию

относительно файлов активизированного

каталога.

Find (Найти)

Выбранная команда Directory к Find позволяет найти имя файла и его

дескриптор в текущем каталоге. Вы также можете выбрать эту команду через

комбинацию клавиш Ctrl+F.

Find Next (Найти следующий)

Выбранная команда Directory к Find next позволяет вывести результат

последней команды Find и начать новый поиск согласно введенной информации.

Вы также можете выбрать эту команду через комбинацию клавиш Ctrl+G.

Filter (Поставить фильтр)

Выбранная команда Directory к Filter открывает доступ к диалоговому

окну Define Filter, с помощью опций которого вы можете отфильтровать файлы

таким образом, что на экране для данного каталога отобразится лишь

необходимая информация.

Эта команда может быть использована при просмотре больших каталогов.

Опции диалогового окна Define filter позволяют:

Filter Mask

Ввести символ универсального сопоставления для маски файла.

Local Filtering

Загрузить выведенный список файлов и произвести фильтрацию в локальном

режиме. Этот метод работает быстро до тех пор, пока вы не перезагрузите

список файлов, изменив в этом списке маску каждого файла. Эта опция также

позволяет вам в режиме локального просмотра применять UNIX-стили трафаретных

символов к файлам DOS.

Remote Filtering

Режим постудаленной фильтрации. Если удаленный узел отфильтровал свой

список файлов, то с помощью этой опции вы можете перезагрузить необходимый

список для каждой измененной маски файла. Вы можете воспользоваться этой

опцией в случае, если вы получили слишком мало информации относительно

заведомо большого каталога или если у вас возникли проблемы совместимости

между CuteFTP и софтом сервера.

Filter Dirs

Определить каталоги и связи для фильтрации. Эта опция доступна лишь в

том случае, если вы работаете в режиме локальной фильтрации.

Group Select (Выбрать группу)

Выбранная команда Directory к Group Select открывает доступ к

диалоговому окну Select group, с помощью которого вы можете выбрать большую

группу подобных файлов с масками трафаретных символов.

Опции диалогового окна Select group позволяют:

Filter Mask

Ввести для маски файла трафаретный символ.

Mask Directorie

Применить функции маскирования к выбранным каталогам.

Remove selection

Установить в исходное состояние выборку данной группы.

Group Deselect (Отменить выборку группы)

Выбранная команда Directory к Group Deselect открывает доступ к

диалоговому окну Deselect group, с помощью опций которого вы можете отменить

произведенный выбор группы файлов.

Например, если вы хотите выбрать все GIF-файлы, но исключить файлы

HTML, откройте диалоговое окно Group Select и в качестве маски установите

*.GIF. Если же вы хотите выбрать все файлы каталога, исключив при этом

только файлы HTML, установите в качестве маски символ *, а затем примените

команду Group deselect с маской *.HTML.

Invert selection (Инвертировать выборку)

Выбранная команда Directory к Invert selection позволяет инвертировать

(обратить в предыдущее состояние) выборку группы.

Dir Info (Информация о каталоге)

Выбранная команда Directory к Dir Info открывает доступ к диалоговому

окну Directory Information, которое содержит суммарную информацию

относительно файлов выбранного каталога.

Netscape Navigator Gold для Windows

Web может открывать доступ к другим ресурсам Internet, например к

электронной почте, FTP, Gopher, WAIS или конференциям Usenet. Одно из таких

средств серфинга по мировой паутине было предложено в январе 1993 года

Марком Андерсоном (marca@ncsa.uiuc.edu). Называлось оно Mosaic -- первый

бриллиант Internet. Именно благодаря этому драгоценному камню и был

разработан язык гипертекстовых документов (HTML), который позволял

просматривать в Web не только текстовую информацию, но и картинки. Вскоре

Mosaic пришел в Microsoft Windows, Apple Macintosh и X Windows.

Позднее Марк Андерсон начал работать в компании Netscape

Communications, в которой Mosaic превратился в знаменитый броузер Netscape

Navigator Gold.

Netscape Navigator Gold поддерживает следующие форматы файлов:

n гипертекстовые файлы протокола HTML.

n текстовые файлы c расширением .TXT.

n исполняемые файлы c расширением .EXE.

n файлы Lightning Strike Imge

c расширением .COD.

n файлы VRML Worlds

c расширением .WRL.

n файлы Quick Time для Windows

c расширением .MOV.

n аудиофайлы c расширением .AU.

n файлы AIFF c расширением .AIFF или AIF.

n звуковые файлы c расширением .WAV.

n файлы MIDI c расширением .mid или midi.

n файлы Video для Windows c расширением

.AVI.

Используя этот броузер вы можете сохранить текущий документ как:

n файл HTML.

n текстовой файл с расширением .TXT.

n файл с любым расширением.

Чтобы записать на диск файлы GIF или JPEG, вам достаточно щелкнуть

правой клавишей мыши на соответствующей картинке.

Netscape Navigator позволяет вам через протокол FTP пересылать файлы на

удаленный сервер. Вы можете также передавать файлы через FTP посредством

перетаскивания соответствующей пиктограммы из рабочего стола Windows в окно

броузера.

В этой программе вы можете настроить параметры печати текущей страницы

и просмотреть документ перед его выводом на печать.

В Netscape встроена функция поиска слов или фраз на текущей странице.

Любая гипертекстовая страница может быть отображена в формате HTML и

затем скопирована в буфер промежуточного обмена.

Посредством встроенной программы Bookmark вы можете создавать и

модифицировать файлы закладок, добавлять титул текущей страницы в список

файла закладок или манипулировать иерархией закладок.

Через Netscape Navigator Gold вы можете работать с электронной почтой,

конференциями Usenet или гибким и мощным гипертекстовым редактором Netscape

Editor.

Netscape позволяет вам настроить карту форматов файлов под конкретное

приложение так, что вы можете задать:

n типы файлов MIME.

n вспомогательные приложения.

n новую ассоциативность данному

приложению.

Netscape Navigator способен информировать сервер относительно выбранной

вами модели языка.

Вы можете оснастить Netscape Navigator Gold кэш-памятью и кэшем диска.

Благодаря этой встроенной возможности, скорость загрузки некоторых страниц

значительно возрастает, так как обращения к кэш-памяти или кэшу диска

осуществляются напрямую, то есть данные моментально попадают в процессор.

В общем случае, Netscape не требует параметров близлежащих узлов или

так называемых Proxy-серверов, то есть тех сетевых служб, через которые вы

непосредственно работаете с Internet. С другой стороны, конфигурация

некоторых сетевых соединений блокируется брандмауэрами. При этом,

брандмауэры могут ограничивать способность Netscape обмениваться информацией

с внешними источниками. Чтобы преодолеть это ограничение, Netscape позволяет

вам взаимодействовать только с тем программным обеспечением, которое вам

предоставляет ваш провайдер Internet. Вам достаточно указать сервисные

службы, которые поддерживает Proxy-сервер вашего провайдера.

Netscape Navigator поддеpживает технологию Java и способен запускать

сценарии Tcl в окне программы просмотра.

В Netscape используется система шифрования, основанная на использовании

40-битового ключа. Вы можете также идентифицировать конкретного пользователя

Internet.

Встроенная программа Address Book позволяет вам создавать и

модифицировать файлы, содержащие адреса электронной почты.

Netscape позволяет отображать список, содержащий титулы и URL страниц,

с которыми вы работали в данной сессии. Данные о каждой просмотренной

странице вносятся в список хронологии и сортируются.

Приятной стороной этого броузера являются расширения. Расширений для

Netscape Navigator существует бесчисленное множество. Это переводчики,

программы проверки орфографии, мультимедийные приложения, средства

воспроизведения трехмерной графики, различные трассировщики и т.д.

Практически всю эту коллекцию вы можете приобрести или просто скачать с

сервера Netscape.

Установка

Netscape Navigator Gold является 32-разрядным приложением для Windows

95 или Windows NT 4.0. Если вы хотите запустить эту программу в Windows 3.1,

то вы должны инсталлировать Win32s и использовать только 16-разрядную версию

Netscape Navigator.

Для запуска 32-разрядной версии Netscape Navigator, вы должны

установить в среде Windows 32-разрядный пакет TCP/IP, который входит в

комплект Microsoft Windows 95/98 и Windows NT 4.0.

Чтобы у вас не возникало проблем при подключении к Internet через

Trumpet Winsock и работе с этим пакетом в Netscape Navigator, вы должны

установить в поле данных Network Buffer (доступ: OptionsрNetwork

Preferences) величину, равную 31.

Если у вас возникли проблемы с записью файла ctl3dv.dll, и выскочило

сообщение: "Could not write to the file named:

C:\Windows\system\ctl3dv2.dll. This is a shared application file. Please

close all other applications", то помните, что файл ctl3dv2.dll используется

системой Windows, которая не позволяет устанавливать новый ctl3dv2.dll

поверх исходного файла. Попробуйте выйти из Windows и переименовать файл в

оболочке DOS.

Если вы хотите использовать Netscape Navigator только в автономном

режиме, то вы должны получить с

ftp://ftp.netscape.com/pub/unsupported/windows/ файл mozock.dll и сохранить

его как файл winsock.dll.

Инсталляция Netscape Navigator Gold осуществляется через запуск файла

setup.exe.

Запуск программы

Перед тем как работать с Netscape Navigator Gold, вы должны

подключиться к Internet на уровне SLIP или PPP. Если вы загрузите Netscape

без установки связи с Internet, то броузер самостоятельно обратится к вашим

средствам доступа, то есть к Dial-Up или Winsock (файл WINSOCK.DLL должен

находиться в каталоге Windows).

Для того, чтобы запустить Netscape Navigator Gold в Windows 95 или

Windows NT 4.0 достаточно дважды щелкнуть по пиктограмме программы. Если у

вас удаленный доступ к Internet, то перед тем как загрузится окно броузера,

будет вызвано диалоговое окно Connect to, через которое устанавливается

связь с удаленным узлом. После того, как вы войдете в Internet, броузер

загрузит в свое главное окно так называемую домашнюю страницу.

Если вы хотите использовать Netscape Navigator при работе с несколькими

провайдерами или адресами электронной почты, то откройте в программе regedit

папку HKEY_CURRENT_USER\Software\Netscape. Выберите FileрExport и сохраните

Netscape.reg. Откройте Windows Explorer и запишите этот файл для нескольких

пользователей, указывая в качестве названия файла имя соответствующего

пользователя. Произведите в каждом из полученных файлов необходимые

изменения Mail directory, News directory, User name, Pop name и так далее.

Теперь создайте (двойной щелчок мышью на файле с расширением .reg) для

каждого пользователя пиктограмму Netscape Navigator.

Настройка программы

В интерактивном режиме Netscape Navigator Gold работает только через

Internet. Это означает, что ваш компьютер должен быть подключен к Internet

по локальной сети или по телефонной линии.

Любым гипертекстовым документам характерны ссылки. Ими могут быть

слова, строки слов или картинки. Текстовая ссылка оформляется особым цветом

и форматируется подчеркиванием. Ссылка для картинки идентифицируется так

называемым указателем руки. Netscape Navigator Gold может запомнить ход

вашей работы и сформировать список посещенных узлов или закладок.

Перед тем как работать с Netscape Navigator Gold этот броузер

необходимо настроить. Поэтому выберите в меню Options опцию General

Preferences. В этом диалоговом окне особое внимание обратите на выбор

шрифтов. Именно здесь и только здесь вы должны установить русские шрифты. В

Internet русские шрифты существуют в нескольких кодировках. Серверы UNIX

поддерживают кодировку KOI-8, серверы Windows -- CP1251, DOS -- CP866,

Macintosh -- Mac.

Если вам не хватает приложений, которые поддерживает Netscape Navigator

Gold, то в диалоговом окне General Prefernces через закладку Helpers

установите соответствующие расширения для файлов, получаемых из Internet.

Если у вас плохой модем или медленная линия, то отмените в диалоговом

окне General Preferences автоматическую загрузку картинок при получении

гипертекстовых документов из Internet.

Помните, что в броузерах Netscape вы можете правой кнопкой мыши

вызывать всплывающее меню, опции которого позволяют выполнять некоторые

полезные функции.

Netscape работает через FTP весьма плохо (опция Upload File позволяет

переслать на удаленный узел за раз только один файл). Поэтому воспользуйтесь

нижеописанной программой CuteFTP.

И напоследок. Начните свой серфинг по Internet с лучшей поисковой

службой Сети www.altavista.com.

Интерфейс пользователя

Netscape Navigator Gold является средством просмотра гипертекстовых

документов. Это означает, что вы можете выполнять переходы на различные

ссылки и получать таким образом доступ практически ко всем ресурсам Web.

В поле данных, находящееся под панелью инструментов, вы можете ввести

URL или адрес интересующего вас узла Internet.

На панели инструментов Netscape Navigator находятся специальные кнопки,

позволяющие вам управлять броузером:

Back

Возвратиться на одну страницу назад.

Forward

Перейти на одну страницу вперед.

Home

Возвратиться на домашнюю страницу. Домашняя

страница -- это стандартный документ, который автоматически открывается

при запуске Netscape Navigator.

Reload

Перезагрузить текущую страницу.

Images

Загрузить все текущие картинки доступного документа. Это делается в том

случае, если у вас в меню Options отключена опция Auto Load Image.

Open

Получить доступ к диалоговому окну Open Location, с помощью которого вы

можете открыть необходимый файл.

Print

Распечатать текущую страницу.

Find

Найти текстовую информацию на текущей странице.

Stop

Прервать загрузку текущей страницы.

С помощью стрелок полос прокрутки или посредством клавиш PgUp и PgDn вы

можете перемещать текущую страницу в вертикальном или горизонтальном

направлении.

Внизу экрана находится информационное меню, которое может отображать

имя загружаемого файла, путь к нему, а также ссылку на соответствующий

Web-документ.

При загрузке документа в правом верхнем углу экрана должна светиться

эмблема Netscape.

Доступ к командам броузера осуществляется через щелчок мышью на

соответвующем имени меню.

Всплывающее меню

Если вы щелкните правой клавишей мыши, то появится так называемое

всплывающее меню, элементы которого могут выполнять некоторые команды и

функции, в том числе:

n Back (аналог команды GoрBack).

n отобразить предыдущую страницу в списке

хронологии.

n Forward (аналог команды GoрForward).

n отобразить следующую страницу в списке

хронологии.

n открыть ссылку.

n отобразить заданную страницу.

n создать закладку для определенной

страницы.

n открыть новое окно для данной ссылки.

n отобразить определенную страницу в новом

окне.

n сохранить ссылку определенным образом.

n сохранить определенную страницу на диск.

n скопировать локализацию ссылки.

n скопировать локализацию страницы в

буфер.

n открыть картинку.

n отобразить определенную картинку.

n сохранить картинку определенным образом.

n сохранить картинку на диск.

n скопировать определенную картинку в

буфер.

n скопировать локализацию картинки.

n скопировать локализацию заданной

картинки в буфер.

n загрузить картинку.

n создать сокращенную комбинацию данной

страницы.

Кроме всего этого, вам необходимо знать, что когда указатель находится

на ссылке, он преобразуется в указатель руки. Это означает, что вы можете

щелкнуть мышью и, тем самым, выбрать ссылку, адрес которой отображается

внизу экрана на информационной панели. Если текст ссылки окрашен красным

(установка по умолчанию) цветом, то ее адрес уже был посещаем, если же

ссылка голубая, то соответствующий документ еще не был загружен в броузер.

И наконец, помните, что российские серверы Web поддерживают русский

язык либо через кодовую страницу 1251 (Windows 95) либо через раскладку

клавиатуры KOI-8 (Unix).

Клавиатурные эквиваленты

Ctrl+A

Выбрать загруженный документ.

Ctrl+Insert

Скопировать выбранный текст в буфер.

Ctrl+F

Отобразить диалоговое окно Find.

Ctrl+B

Редактировать закладки.

Ctrl+H

Открыть диалоговое окно History.

Ctrl+L

Отобразить диалоговое окно Open Location.

Ctrl+M

Загрузить программу Netscape Mail.

Ctrl+O

Отобразить диалоговое окно Open.

Ctrl+R

Перезагрузить текущий документ.

Ctrl+S

Сохранить текущий документ.

Ctrl+W

Выйти из программы.

Ctrl+Z

Отменить последнее действие.

Ctrl+End

Перейти в конец документа.

Ctrl+Home

Перейти в начало документа.

Alt+Tab

Переключиться между окнами открытых документов.

Esc

Прервать загрузку документа.

Команды меню

В Netscape Navigator Gold наборы команд и опций, использующиеся в

процессе работы с Internet содержатся в:

n меню File (Файл).

n меню Edit (Редактирование).

n меню View (Просмотр).

n меню Go (Переход).

n меню Bookmarks (Закладки).

n меню Options (Параметры).

n меню Directory (Каталог).

n меню Help (Подсказка).

File (Файл)

Опции меню File позволяют:

n открыть еще один броузер с новым

списком хронологии. Параметры работы

новой программы задаются по умолчанию.

n открыть незаполненный документ,

шаблонный документ или получить

новый документ с сервера

корпорации Netscape.

n закрыть окно документа и войти в

редактор гипертекстовых страниц

Netscape Editor с тем, чтобы

модифицировать текущую Web-страницу.

n сформировать новое электронное

сообщение в программе Netscape Mail.

n сформировать электронное сообщение, тело

которого будет содержать URL текущего

документа, а тема -- название документа.

n открыть любой документ, находящийся в

сети и загрузить его в окно броузера или

редактора Netscape Editor.

n загрузить в окно программы находящийся

на вашем жестком диске документ.

n загрузить с жесткого диска в окно

редактора Netscape Editor любой

гипертекстовый документ.

n сохранить текущий документ как файл

HTML, как текстовый файл с расширением

.TXT или как файл с любым расширением.

n переслать файл на удаленный узел.

n настроить параметры печати текущей

страницы.

n получить распечатку текущего документа.

n просмотреть текущий документ перед его

выводом на печать.

n закрыть текущее окно документа.

n закрыть все активные окна и выйти из

программы.

New Web Browser (Новый Web-броузер)

Выбранная команда File к New Web Browser позволяет открыть еще одну

программу с новым списком хронологии. Параметры работы новой программы

заданы по умолчанию. Вы также можете выбрать эту команду через комбинацию

клавиш Ctrl+N.

New Document (Новый документ)

Выбранная команда File к New Document позволяет с помощью ниспадающего

меню открыть незаполненный документ (Blank Document) или документ, созданный

на основе шаблона (From Template), или получить документ с сервера

корпорации Netscape (From Wizard).

Edit Document (Редактировать документ)

Выбранная команда File к Edit Document позволяет закрыть окно документа

и войти в редактор гипертекстовых документов Netscape Editor с тем, чтобы

модифицировать текущую Web-страницу.

New Mail Message (Новое почтовое сообщение)

Выбранная команда File к New Mail Message позволяет сформировать новое

электронное сообщение в программе Netscape Mail. Вы также можете выбрать эту

команду через комбинацию клавиш Ctrl+M.

Mail Document (Переслать URL текущего документа)

Выбранная команда File к Mail Document позволяет сформировать

электронное сообщение, тело которого будет содержать URL текущего документа,

а тема (Subject) -- название.

Open Location (Открыть размещение)

Выбранная команда File к Open Location открывает доступ к диалоговому

окну Open Location, с помощью которого вы можете открыть любой документ,

находящийся в сети и загрузить его в окно броузера или редактора Netscape

Editor.

В поле данных диалогового окна Open Location вы можете ввести в

цифровой форме IP-адрес интересующего вас удаленного узла или ввести любую

информацию через следующий синтаксис:

protocol: //hostport/path

Вместо аргумента protocol может стоять:

http -- любая гипертекстовая информация.

ftp -- протокол передачи файлов.

telnet -- терминальный доступ.

gopher -- "предшественник" WWW.

afs -- файловая система Internet.

news -- конференции Usenet.

wais -- система баз данных Internet.

Под аргументом hostport понимается адрес сервера с соответствующим

номером его логического порта TCP/IP.

Под аргументом path понимается полный путь к соответствующему ресурсу

Internet.

Cовет: Через команду File к Open Location вы можете также обратиться к

собственной информации, размещенной на вашем жестком диске. Если вы введете

в поле данных Open Location полный путь к необходимому каталогу, то

программа отобразит интерфейс FTP c файлами из выбранного вами каталога.

Open File in Browser (Открыть локальный документ)

Выбранная команда File к Open File in Browser открывает доступ к

диалоговому окну Open, с помощью которого вы можете загрузить в окно

программы находящийся на вашем жестком диске документ в одном из следующих

форматов:

n гипертекстовые файлы протокола HTML.

n текстовые файлы c расширением .TXT.

n исполняемые файлы c расширением .EXE.

n файлы Lightning Strike Imge

c расширением .COD.

n файлы VRML Worlds

c расширением .WRL.

n файлы Quick Time для Windows

c расширением .MOV.

n аудиофайлы c расширением .AU.

n файлы AIFF c расширением

.AIFF или AIF.

n звуковые файлы c расширением .WAV.

n файлы MIDI c расширением .mid.

n файлы Video для Windows

c расширением .AVI.

n файлы с любым расширением.

Open File in Editor (Открыть локальный гипертекстовый документ для

редактирования)

Выбранная команда File к Open File in Editor открывает доступ к

диалоговому окну Open, с помощью которого вы можете загрузить с вашего

жесткого диска в окно редактора Netscape Editor любой гиперетекстовый

документ.

Save As (Сохранить как)

Выбранная команда File к Save As открывает доступ к диалоговому окну

Save As, с помощью которого вы можете сохранить текущий документ как:

n файл HTML.

n текстовой файл с расширением .TXT.

n файл с любым расширением.

Важно: Чтобы сохранить картинки GIF или JPEG на диск, щелкните на

соответствующей картинке правой кнопкой мыши и в появившемся меню выберите

Save Image As.

Upload File (Переслать файл)

Выбранная команда File к Upload File открывает доступ к диалоговому

окну File Upload, с помощью которого вы можете переслать файл на удаленный

узел.

Команда File к Upload File доступна лишь в том случае, если вы

соединились с удаленным сервером FTP через Netscape Navigator Gold или любую

другую клиентскую программу, поддерживающую работу с протоколом передачи

файлов.

Вы можете также передавать файлы через FTP посредством перетаскивания

соответствующей пиктограммы из рабочего стола Windows в окно прораммы

Netscape Navigator Gold.

Если вы хотите зарегистрироваться на сервере FTP через Netscape

Navigator, то в диалоговом окне Open Location (доступ: FileрOpen Location)

введите ваше имя пользователя в виде

ftp://username@ftpsrvrname.company.domain,

а пароль как ftp://username:password@

ftpsrvrname.company.domain.

Page Setup (Настройка страницы для печати)

Выбранная команда File к Page Setup открывает доступ к диалоговому окну

Page Setup, с помощью опций которого вы можете настроить параметры печати

текущей страницы.

Print (Вывод на печать)

Выбранная команда File к Print открывает доступ к диалоговому окну

Print, с помощью которого вы можете получить распечатку текущего документа.

Print Preview (Просмотреть документ перед выводом на печать)

Выбранная команда File к Print Preview открывает доступ к

дополнительному модулю программы, с помощью которого вы можете просмотреть

текущий документ перед его выводом на печать.

Close (Закрыть текущее окно)

Выбранная команда File к Close позволяет закрыть текущее окно

документа.

Exit (Выйти из программы)

Выбранная команда File к Exit позволяет закрыть все активные окна и

выйти из программы.

Edit (Редактирование)

Опции меню Edit позволяют:

n возвратиться к последнему выполненному

действию.

n удалить текущую выборку и поместить ее в

буфер промежуточного хранения.

n поместить копию текущей выборки в буфер

промежуточного хранения.

n поместить содержимое буфера на текущую

страницу в позицию, соответствующую

выбору маркера.

n создать выборку, состоящую из

содержимого области, отметку которой

сделал маркер.

n найти слово или фразу на текущей

странице.

n задать другое вхождение текста после

применения команды Edit к Find.

Undo (Отменить)

Выбранная команда Edit к Undo позволяет возвратиться к последнему

выполненному действию.

Cut (Вырезать)

Выбранная команда Edit к Cut позволяет удалить текущую выборку и

поместить ее в буфер промежуточного хранения.

Copy (Скопировать)

Выбранная команда Edit к Copy позволяет поместить копию текущей выборки

в буфер промежуточного хранения.

Paste (Вставить)

Выбранная команда Edit к Paste позволяет поместить содержимое буфера

промежуточного хранения на текущую страницу в позицию, соответствующую

выбору маркера.

Select All (Выделить все)

Выбранная команда Edit к Select All позволяет создать выборку,

состоящую из содержимого области, отметку которой сделал маркер.

Find (Найти)

Выбранная команда Edit к Find открывает доступ к диалоговому окну Find,

с помощью которого вы можете найти слово или фразу на текущей странице. В

Netscape Navigator Gold вы можете вести корректный поиск только с начала

документа.

Find Again (Найти снова)

Выбранная команда Edit к Undo позволяет задать другое вхождение текста

после использования команды Edit к Find.

View (Просмотр)

Опции меню View позволяют:

n удалить из окна программы оргинал

страницы и загрузить ее новую копию.

n загрузить новую копию выбранной

страницы с одним блоком на страницу,

содержащую другие блоки.

n отобразить картинки текущей страницы.

n удалить из окна программы загруженный

оригинал страницы и поместить в него

новую копию страницы из локальной

памяти компьютера.

n просмотреть текущую страницу в формате

HTML.

n отобразить статистическую информацию о

загруженном документе.

n просмотреть код загруженного фрейма в

формате HTML.

n отобразить статистическую информацию о

загруженном фрейме.

Reload (Перезагрузить)

Выбранная команда View к Reload позволяет загрузить новую копию текущей

страницы с одновременным удалением ее оригинала. Программа проверяет сервер,

если на нем произошли какие-нибудь модификации. Если никаких изменений не

произошло, то новая копия будет искаться в кэше. Если же изменения

произошли, то новая копия будет получена с сервера и произойдет обновление

содержимого соответствующей страницы.

Если вы при выборе команды View к Reload будете держать кнопку Shift,

то программа будет пытаться искать новую версию страницы только на

соответствующем сервере, то есть не используя технологию кэширования.

Reload Frame (Перезагрузить блок)

Выбранная команда View к Reload Frame позволяет загрузить новую копию

выбранной страницы с одним блоком на страницу, содержащую другие блоки.

Load Images (Загрузить картинки)

Выбранная команда View к Load Images позволяет отобразить картинки

текущей страницы. Как правило, картинки грузятся на страницу в

автоматическом режиме. Однако, если в диалоговом окне Options опция Auto

Load Images не выбрана, то вместо картинок вы увидите лишь небольшие

пиктограммы.

После выполнения команды View к Reload Images, все маленькие

пиктограммы заменятся на соответствующие картинки, которые будут загружены

на страницу из файлов исходных картинок, но сама страница не перезагрузится

(связи для картинок не обновляются).

Refresh (Обновить)

Выбранная команда View к Refresh позволяет удалить из окна программы

загруженный оригинал страницы и поместить в это окно новую копию страницы из

локальной памяти.

Document Source (Исходный код документа)

Выбранная команда View к Document Source позволяет просмотреть текущую

страницу в формате HTML (Hyper Text Markup Language).

Текст исходника HTML содержит команды и стили, которые использовались

при создании гипертекстовой страницы.

Вы можете назначить другое приложение, которое будет отображать

исходный текст HTML. Выберите команду меню OptionsрGeneral Preferences,

щелкните на закладке Apps и в поле View Source укажите полный путь к файлу

соответствующей программы.

Document Info (Информация о документе)

Выбранная команда View к Document Info позволяет отобразить следующую

статическую информацию о загруженном документе:

n структура документа.

n название документа.

n локализация (URL).

n дата последней модификации.

n кодировка.

n статус системы безопасности.

Frame Source (Исходный код блока)

Выбранная команда View к Frame Source позволяет просмотреть код

загруженного фрейма в формате HTML (Hyper Text Markup Language).

Frame Info (Информация о блоке)

Выбранная команда View к Frame Info позволяет отобразить статическую

информацию о загруженном фрейме.

Go (Переход)

Опции меню Go позволяют:

n отобразить предыдущую страницу, данные

о которой содержатся в списке хронологии.

n отобразить следующую страницу, данные о

которой содержатся в списке хронологии.

n отобразить гипертекстовую страницу,

установленную по умолчанию.

n прервать загрузку текущей страницы.

n перейти к публикации по умолчанию.

Back (Назад)

Выбранная команда Go к Back позволяет отобразить предыдущую страницу,

данные о которой описаны в списке хронологии.

Forward (Вперед)

Выбранная команда Go к Forward позволяет отобразить следующую страницу,

данные о которой содержатся в списке хронологии.

Home (Перейти на домашнюю страницу)

Выбранная команда Go к Home позволяет отобразить гипертекстовую

страницу, определенную в поле Home Page Location диалогового окна

Preferences при выбранной закладке Apperance (доступ: General Preference к

Appearance).

Stop Loading (Прервать загрузку)

Выбранная команда Go к Stop Loading позволяет прервать загрузку текущей

страницы.

Default Publish Location (Размещение публикации по умолчанию)

Выбранная команда Go к Default Publish Location позволяет перейти к

публикации по умолчанию.

Bookmarks (Закладки)

Опции меню Bookmarks позволяют:

n добавить титул текущей страницы в список

файла закладок.

n отобразить окно с текущими закладками.

Add Bookmark (Добавить закладку)

Выбранная команда Bookmarks к Add Bookmark позволяет добавить титул

текущей страницы в список файла закладок.

Go to Bookmarks (Перейти к закладке)

Выбранная команда Bookmarks к Go to Bookmarks позволяет отобразить окно

с текущими закладками.

Вы можете манипулировать иерархией закладок следующим образом:

1. Загрузите Netscape.

2. В меню Bookmarks выберите View

Bookmarks.

3. Чтобы создать заголовок, щелкните правой

кнопкой мыши, в появившемся меню

выберите ItemрInsert Header и введите в

поле данных имя вашего заголовка.

4. Выделите мышью закладку и переместите

ее в нужное место. Обратите внимание на

то, что папки с заголовками вы можете

сворачивать или разворачивать.

Options (Параметры)

Опции меню Options позволяют:

n изменить параметры работы с программой

Netscape Navigator Gold.

n установить параметры работы с

гипертекстовым редактором

Netscape Editor.

n установить параметры работы с

электронной почтой и конференциями

Usenet.

n установить параметры работы c Internet.

n установить параметры работы с системой

безопасности Netscape Navigator Gold.

n отобразить на экране программы ее

инструментальную панель.

n отобразить поле данных, содержащее URL

удаленных узлов.

n отобразить кнопки каталогов.

n отобразить окно с пультом Java.

n загружать в окно программы только

текстовую часть документа HTML.

n выбрать и переустановить кодировку

символов для всех документов программы.

General Preferences (Общие настройки)

Выбранная команда Options к General Preferences открывает доступ к

диалоговому окну General Preferences, c помощью опций которого вы можете

изменить параметры работы с программой Netscape Navigator Gold.

В диалоговом окне General Preferences вы можете изменить параметры

программы, переключаясь между закладками Appearance, Font, Colors, Images,

Apps, Helpers и Language.

Опции диалогового окна General Preferences при выбранной закладке

Appearance

Все установки в этом диалоговом окне влияют на первый запуск программы.

Toolbars

Опции Pictures, Text или Pictures and Text позволяют соответствующим

образом оформить панель инструментов.

Startup

Опции Netscape Browser, Netscape Mail или Netscape News позволяют

определить окно для запуска программы. По умолчанию установлен параметр

Netscape Browser.

Blank Page и Home Page Location

Определить самую первую страницу, которую загрузит программа. В

соответствующее поле данных вводится URL для домашней страницы. Если вы

выберите опцию Blank Page, то после первого старта Netscape загрузится

только незаполненная страница.

Link Styles

Опция Underlined, которая установлена по умолчанию, оформляет все

текстовые ссылки подчеркнутым начертанием.

Опции в разделе Followed Links позволяют обновить посещенные ссылки.

При выбранной опции Never Expire все ссылки не переопределяются.

В поле данных Expire After задается время, по истечении которого цвет

посещенной ссылки изменится на первоначальный. По умолчанию выбрана опция

Expire After 30 Days.

Опция Never Expire позволяет немедленно переопределить все ссылки.

Опции диалогового окна General Preferences при выбранной закладке Fonts

Fonts and Encodigs

Выбрать параметры кодировки символов шрифта и использовать эту

кодировку в документах. Кодировка представляет собой карту образов символа в

компьтерных кодах.

Каждый символ, установленный кодировкой из меню For the Encoding

ассоциируется с пропорциональным и фиксированным шрифтами, посредством

которых оформляется текст на экране вашего монитора. Вы можете менять эту

ассоциативность посредством опций Use the Proportional Font и Use the Fixed

Font. Например, по умолчанию установлена кодировка Latin1, которая

ассоциирована с пропорциональным шрифтом Times с кеглем 12 и фиксированным

шрифтом Courier с кеглем 10.

Большинство страниц отображают текст, оформленный пропорциональным

шрифтом. Поэтому чаще всего вам придется выбирать шрифт из ниспадающего меню

Use the Proportional Font. Вы можете создать выборку для каждой кодировки.

Из ниспадающего меню Use the Fixed Font вы можете выбрать так

называемый второй тип шрифта. Фиксированный шрифт используется при

оформлении текста в табличных редакторах и некоторых параграфах,

отформатированных авторами гипертекстовых страниц. Здесь вы также можете

создать выборку для каждой кодировки.

Опции диалогового окна General Preferences при выбранной закладке

Colors

Colors

Задать цвет для ссылок, текста и фона. Вы можете это сделать, щелкнув

на кнопке Choose Color и выбрав из появившейся палитры подходящий цвет.

Links

Изменить цвет ссылки. По умолчанию все ссылки окрашены в голубой цвет.

Followed Links

Изменить цвет посещенной ссылки. По умолчанию все посещенные ссылки

окрашены в фиолетовый цвет.

Text

Изменить цвет текста. По умолчанию текст окрашен в черный цвет.

Background

Изменить фон документа. По умолчанию используется серый фон. Вы можете

задать в качестве фона любую картинку, полный путь к файлу которой

вписывается в поле Image File или просматривается на диске через кнопку

Browse.

Always Use My Colors, Overriding Document

Применить пользовательские установки цветов для других гипертекстовых

страниц.

Опции диалогового окна General Preferences при выбранной закладке

Images

Images

В этом разделе опции Automatic, Dither или Substitute Colors позволяют

установить режим отображения цветов картинок на экране вашего монитора.

По умолчанию выбрана опция Automatic, при которой все поддерживаемые

программой типы картинок будут отображаться во всей палитре цветов. Если

выбрать опцию Substitute Colors или Dithered, то цветные картинки будут

отображаться только в ограниченном диапазоне цветов, причем опция Dithered

размывает цвета картинки и медленно восставливает их в процессе загрузки

документа.

Display Images

В этом разделе опция While Loading прорисовывает картинку на экране в

процессе загрузки документа, а опция After Loading отображает картинку

только после загрузки документа. По умолчанию установлена опция After

Loading.

Опции диалогового окна General Preferences при выбранной закладке Apps

Supporting Application

В этом разделе вы можете определить специфические приложения, которые

поддерживает Netscape.

Чтобы идентифицировать новое приложение, щелкните на кнопке Browse и

укажите полный путь к приложению и его запускающий модуль.

Telnet Application

Указать локализацию приложения Telnet. Telnet позволяет осуществить

соединение с другим компьютером и работать с ним в интерактивном режиме,

используя стандартный протокол Internet.

Важно: Если вы хотите работать с удаленным компьютером в режиме On-line

через Netscape Navigator, скачайте расширение Carbon Copy/Net, которое

находится на сервере Microcom (www.microcom.com/cc/ccdnload.htm/).

TN3270 Application

Указать локализацию приложения TN3270. Приложения для TN3270

используются при соединениях через Telnet с базовыми компьютерами IBM.

View Source

Указать локализацию приложения, позволяющее просматривать документы

HTML в исходных кодах.

Temporary Directory

Указать временную область на диске, в которой программа будет хранить

файлы вспомогательных приложений. После того, как соответствующее приложение

прекратит работу, эти файлы будут удалены из временного каталога.

Опции диалогового окна General Preferences при выбранной закладке

Helpers

Netscape Navigator обрабатывает файлы через протоколы HTTP, NNTP, SMTP

и FTP. Каждый протокол поддерживает различные форматы файлов. Поэтому в

Netscape Navigator встроена дополнительная возможность, позволяющая

правильно интерпретировать файлы некоторых форматов. Когда приложение для

Netscape обрабатывает файл, формат которого несовместим с программой, то

исходное приложение будет пытаться использовать вспомогательную программу,

способную прочитать этот файл.

Диалоговое окно General Preferences при выбранной закладке Helpers

позволяет вам настроить карту форматов файлов под конкретное приложение. В

этом диалоге содержатся несколько полей данных и кнопок, позволяющих задать:

n типы файлов MIME (Multipurpose Internet

Messaging Extensions -- формат, который

при формировании файла использует

суффиксацию имен).

n вспомогательные приложения.

n новую ассоциативность данному

приложению.

В основном списке данных содержатся вспомогательные приложения,

доступные программе. В каждой строке этого списка имеется информация

относительно вспомогательного приложения. Щелкнув мышью на этой строке, вы

можете отобразить, а затем модифицировать установки соответствующего

приложения.

Нижние опции и поля данных позволяют произвести настройку нового

приложения или модифицировать существующее. Здесь вы можете также добавить к

файлу новое расширение или изменить ассоциативность данного приложения.

Например, чтобы для данного типа файла автоматически запустить

приложение, которое не поддерживается Netscape, достаточно нажать кнопку

Create New Type, в появившемся диалоговом окне задать тип MIME и определить

это приложение.

File/MIME

Определить для данной выборки файл или тип MIME.

Subtype

Классифицировать формат текущей выборки.

File Extensions

Задать для данной выборки суффиксацию, которая будет использоваться в

данном типе файла.

Здесь имеется одна тонкость. Например, вы можете ассоциировать

программу Microsoft Word с расширением .DOC и затем заразиться довольно

известным макровирусом. Поэтому не используйте такую привязку, а скачайте с

www.microsoft.com/msoffice специальное средство просмотра файлов Microsoft

Word в Internet.

Create New Type

Эта кнопка открывает доступ к диалоговому окну Configure New Mime Type.

Два текстовых поля данных этого диалогового окна предназначены для ввода

типа и подтипа MIME.

Action

Указать способ выполнения вспомогательного приложения.

View in Browse

Открыть загруженный файл в содержимое области лишь в том случае, если

формат этого файла не поддерживается вспомогательным приложением.

Save to Disk

Сохранить файл после его загрузки.

Unknown: Prompt User

При несовместимости вывести сообщение об ошибке.

Launch Application

Открыть выделенное приложение, используя загруженный файл в качестве

документа. Через кнопку Browse вы можете выбрать соответствующее приложение.

Опции диалогового окна Preferences при выбранной закладке Language

Accept Language

Netscape Navigator способен информировать сервер относительно выбранной

вами модели языка. Когда вы загружаете страницу, выбранная вами модель языка

передается как отдельная часть в заголовке HTTP. Если сервер поддерживает

вашу модель языка, то он передает к вам на компьютер корректную информацию.

Language/Region

Определить язык и код соответствующего региона.

User define

Определить специфическую модель языка и код региона.

Accept List

В этом списке содержится информация относительно выбранной модели

языка.

Editor Preferences (Настройка гипертекстового редактора)

Выбранная команда Options к Editor Preferences открывает доступ к

дилоговому окну Editor Preferences, опции которого позволяют установить

параметры работы с гипертекстовым редактором Netscape Editor.

Mail and News Preferences (Настройка почты и конференций)

Выбранная команда Options к Mail and News Preferences открывает доступ

к дилоговому окну Mail and News Preferences, опции которого позволяют

установить параметры работы с электронной почтой и конференциями Usenet.

Network Preferences (Настройка сети)

Выбранная команда OptionsрNetwork Preferences открывает доступ к

диалоговому окну Network Preferences, опции которого позволяют установить

параметры работы c Internet.

В диалоговом окне Network Preferences вы можете установить параметры

работы с Internet, переключаясь между закладками Cache, Connections,

Proxies, Protocols и Languages.

Опции диалогового окна Network Preferences при выбранной закладке Cashe

Cache

Оснастить Netscape Navigator Gold

кэш-памятью и кэшем диска. Под кэшем понимается специальная подсистема

памяти, в которой запоминаются часто используемые картинки, текст и другая

информация, считываемая броузером. Благодаря этой встроенной возможности,

скорость загрузки некоторых страниц значительно возрастает, так как

обращения к кэш-памяти или кэшу диска осуществляются напрямую, то есть

данные моментально попадают в процессор.

Помните, что броузер кэширует гипертекстовые документы даже в том

случае, когда отключена опция Auto Load Images в меню Options.

Memory Cache

Задать размер кэш-памяти в килобайтах. В этом случае происходит не

обычный доступ к памяти, а через кэш. Кэш-память работает быстрее основной

памяти. Поэтому, чем больше размер кэш-памяти, тем быстрее будут выводиться

дублированные данные. По умолчанию размер кэш-памяти соответствует 600

килобайтам.

Clear Memory Cache

Очистить кэш-память.

Disk Cache

Задать размер кэша диска в килобайтах. В этом случае происходит не

обычный доступ к диску, а через кэш диска. Кэшем диска является область

оперативной памяти. В эту область броузер записывает данные, которые

считываются с жесткого диска при загрузке гипертекстовой страницы. Память

кэша диска работает быстрее, чем винчестер. Поэтому, когда броузер будет

пытаться считать данные с диска, которые находятся в кэше, на самом деле он

их считает с кэша диска, что, разумеется, намного быстрее.

По умолчанию размер кэша диска соответствует 5000 килобайтам.

Clear Disk Cache

Очистить кэш диска. Это означает, что здесь вы можете удалить с

жесткого диска кэшированные страницы Internet.

Disk Cache Directory

Определить локализацию кэша диска.

Verify Documents

Определить время, в течение которого из сервера будет получена новая

информация для данной страницы, а не те данные, которые Netscape извлекает

из кэша диска.

Once per Session

Произвести пересмотр кэшированных документов во время загрузки

программы и в тот момент, когда вы из нее выходите. По умолчанию выбрана

именно эта опция.

Every Time

Неоднократно проверять изменения для данной страницы. Если выбрать эту

опцию, то ваша работа будет более корректной, но весьма медленной.

Never

Не производить проверку загружаемых страниц, если соответствующие

данные имеются в кэше диска.

Опции диалогового окна Network Preferences при выбранной закладке

Connections

Network Connections

Текстовые файлы и файлы каждой картинки на странице весьма различны.

Netscape при открытии сессии доставляет каждый из этих файлов. При этом

Netscape может отображать одновременно как текст, так и картинки. Определяя

количество соединений с сервером вы тем самым задаете предел информации,

получаемой из Internet.

Number of Connections

Определить максимальное число сетевых соединений. По умолчанию это

число равно четырем порциям информации, полученной из Internet. Если это

число уменьшить до двух, то скорость работы значительно возрастет.

Network Buffer Size

Размер сетевого буфера.

Размер сетевого буфера определяет количество килобайт информации,

которое распределяется в основной памяти компьютера для передачи этих данных

по сети, то есть эта величина, которая по умолчанию равна 32 килобайтам,

определяет количество данных, которое может поступить в сеть. Большой размер

сетевого буфера усредняет большинство данных, но в то же время способен

перенасытить ваш компьютер.

Опции диалогового окна Network Preferences при выбранной закладке

Proxies

Proxies

В общем случае, Netscape не требует параметров близлежащих узлов или

так называемых Proxy-серверов, то есть тех сетевых служб, через которые вы

непосредственно работаете с Internet. С другой стороны, конфигурация

некоторых сетевых соединений блокируется брандмауэрами. Как известно,

информация защищается брандмауэрами в компьютерах внутренних сетей от

всеобщего доступа. При этом, брандмауэры могут ограничивать способность

Netscape обмениваться информацией с внешними источниками. Чтобы преодолеть

это ограничение, Netscape позволяет вам взаимодействовать только с тем

программным обеспечением, которое вам предоставляет ваш провайдер Internet.

Все это дело работает по мудреной схеме.

Proxy-сервер ретранслирует брандмауэр и обеспечивает связь с заданным

протоколом сетевой службы. Поэтому, если вы запустили Netscape через

брандмауэр, вам необходимо указать номера логических портов и ассоциировать

номер каждого порта под соответствующую службу сервера.

No Proxies

Не устанавливать параметры ретранслятора. Эта опциия предназначена для

тех пользователей, которые имеют прямой доступ к Internet.

Manual Proxy Configuration

Вручную определить службы и задать номера соответствующих логических

портов. Для этого нажмите кнопку View и в диалоговом окне Manual Proxy

Configuration установите параметры для каждой службы Internet.

Automatic Proxy Configuration

Определить службы и задать номера соответствующих логических портов

через файл конфигурации ретранслятора. URL этого файла вписывается в поле

данных Configuration Location URL.

Опции диалогового окна Manual Proxy Configuration

Proxies

В этом разделе вам необходимо указать сервисные службы, которые

поддерживает ретранслятор. Ими могут быть:

n FTP (File Transfer Protocol).

n Gopher.

n HTTP (HyperText Transfer Protocol).

n Security (Secure Sockets Layer protocol).

n WAIS (Wide Area Information System).

n SOCKS (Сокеты).

В полях данных Proxies вы должны указать имя хоста для каждого

протокола соответствующей службы. Как правило, один Proxy-сервер работает с

тремя основными протоколами: HTTP, FTP и Gopher. В это поле вы также можете

ввести IP-адрес Proxy-сервера.

Port

На одном компьютере может быть запущено несколько сетевых служб, каждая

из которых идентифицируется логическим портом. Этот порт принадлежит

Proxy-серверу, такому как HTTP или FTP. Как правило, в Internet используются

стандартные номера логических портов. Например, протокол HTTP использует

80-й порт, а FTP -- 21-й.

No Proxy for:

Не использовать параметры сетевых служб локального домена. Например,

если вы определите в HTTP Proxy: bob.leon.com и укажите в No Proxy for:

abob,bbob,leon.com, то все необходимые протоколы HTTP для abob, bbob и

leon.com будут использоваться напрямую, то есть игнорируя параметр,

введенный в поле HTTP Proxy.

Опции диалогового окна Network Preferences при выбранной закладке

Protocols

Show an Alert Before

Вывести предупреждение при обнаружении некорректного протокола.

Accepting a Cookie

Пытаться соединиться через любой протокол.

Subbmitting a Form by Email

Ассоциировать форму HTML с адресом электронной почты.

Send Email Address as Anonymous FTP Password

При анонимном входе на сервер FTP передать адрес электронной почты

вместо пароля.

Опции диалогового окна Network Preferences при выбранной закладке

Languages

Java/Java Script

Поддеpживать или не поддерживать технологию Java.

Если не вдаваться в подробности, то структуру языка программирования

Java можно охарактеризовать так:

n объектно-ориентированный язык

программирования.

n приложения создаются через

интерпретатор.

n межплатформная совместимость

приложений.

n не нужно управлять регистрами памяти.

n многопотоковость вводимой информации.

n простая и удобная модификация

приложения.

n встроенная система безопасности.

Enable Java

Поддеpживать технологию Java.

Enable Java/Script

Поддеpживать технологию Java и запускать сценарии Tcl в окне программы

просмотра.

Security Preferences (Настройка системы безопасности)

Выбранная команда Options к Security Preferences открывает доступ к

диалоговому окну Security Preferences, опции которого позволяют блокировать

несанкционированный доступ к собственной системе брандмауэром Netscape и

установить параметры работы с системой безопасности Netscape Navigator Gold.

В диалоговом окне Security Preferences вы можете установить параметры

работы с системой безопасности Netscape Navigator Gold, переключаясь между

закладками General, Passwords, Personal Sertificates и Site Certificates.

Опции диалогового окна Security Preferences при выбранной закладке

General

Нужно сказать, что во всех версиях Netscape имеется, мягко говоря,

небольшая лазейка, позволяющая переконфигурировать его брандмауэр, так как

вы это пожелаете. Именно через этот пресловутый брандмауэр вы можете,

например, без особого труда вакцинировать систему. Кстати, это многими и

очень многими делалось. Причем, взлом защиты Netscape может быть осуществлен

несколькими способами, каждый из которых совершенно не связан с предыдущими.

Netscape даже не определит того, кто хотел взломать вашу систему. В этой

программе невозможно определить так называемую зону риска. Поэтому, именно

через брандмауэры Netscape ищутся отправные точки захвата всей системы.

Например, простейшая атака программой rlogin через отдельный компьютер

большой сети позволяет перечеркнуть двумя жирными полосами нижепубликуемое

описание опций системы защиты Netscape Navigator.

Эти опции предназначены для тех, кто хочет использовать технологию

языка программирования Java, но боится опасных Java-приложений, которые, как

известно, могут вызвать хаос в сети. Это означает, что если вы все-таки

хотите организовать защиту, то, для начала, необходимо отключить все опции в

диалоговом окне Network Preferences в разделе Languages.

Show an Alert Before

Все эти опции позволяют вам выводить или не выводить предупреждающие

сообщения в том случае, когда вы оказываетесь в подозрительных местах

Internet. В противном случае, Netscape всякий раз будет пытаться вас

предупредить о том, что вы входите в небезопасное место.

SSL

Использовать или не использовать систему шифрования. В Netscape

придумана система шифрования, основанная на использовании 40-битового ключа.

Этот алгоритм весьма трудно вскрыть, но можно, так как текст этих программ

доступен через Internet. Впрочем, этим никто не занимался. Netscape

взламывается другими, более простыми способами.

Если пользоваться параметром SSL, то всякий раз, когда вы будете

входить на подозрительный узел HTTP, к нему добавится буква S. Например,

shttp://www.bobleonbob.com.

Опции диалогового окна Security Preferences при выбранной закладке

Passwords

Security Password

Установить на систему парольную защиту.

Это самая больная тема всех системных администраторов и актуальная для

хакеров и крэкеров.

В природе не существует идеальных паролей. Если вы придумаете

замысловатый пароль, то есть с многочисленными апострофами, запятыми и

точками, то в один прекрасный день вы его потеряете или просто забудете. Все

же остальные пароли взламываются легко и быстро через так называемые

генераторы словарей парольной защиты.

Самое лучшее решение -- парольная фраза. Парольные фразы в настоящее

время трудно поддаются взлому, так как пока не существует генераторов

мировой литературы.

Ask for Password

Требовать или не требовать пароль при входе в систему.

Опции диалогового окна Security Preferences при выбранной закладке

Personal Sertifications

Идентификация конкретного пользователя Internet. Например, когда вы

передаете информацию посредством формы HTML, то сертификация позволяет

сделать так, чтобы данные пришли точно в пункт назначения.

Опции диалогового окна Security Preferences при выбранной закладке Site

Sertifications

Site certificates

Идентификация узла Internet.

Edit Certificate

Через эту кнопку вы можете создать для себя несколько сертификаций. По

умолчанию выбрана опция All Certificates.

Delete Certificate

Удалить сертификацию из списка.

Show Toolbar (Показать инструментальную панель)

Выбранная команда Options к Show Toolbar позволяет отобразить на экране

программы ее инструментальную панель.

Show Location (Показать локализацию)

Выбранная команда Options к Show Location позволяет отобразить поле

данных, содержащее URL удаленных узлов.

Show Directory Buttons (Показать кнопки каталогов)

Выбранная команда Options к Show Derectory Buttons позволяет отобразить

кнопки каталогов.

Show Java Console (Показать пульт Java)

Выбранная команда Options к Show Java Console позволяет отобразить окно

с пультом Java. В этом окне некоторые программы Java отображают различную

информацию.

Auto Load Images (Автоматическая загрузка картинок)

Выбранная команда Options к Auto Load Images позволяет загружать в окно

программы только текстовую часть документа HTML.

Document Encoding (Кодировка документа)

Выбранная команда Options к Document Encoding позволяет выбрать и

переустановить кодировку символов для всех документов программы.

Directory (Каталог)

Опции меню Directory позволяют:

n связаться с узлом корпорации Netscape

для того, чтобы получить дополнительную

информацию.

n получить доступ к новой информации,

появившейся в Internet за последнее время.

n узнать о самых интересных местах Internet.

n просмотреть каталог интерактивных услуг

и предложений от заказчиков сервера

Netscape.

n просмотреть каталог поисковых служб

Internet.

n найти пользователя Internet по его имени и

адресу электронной почты.

n получить доступ к основной информации

относительно Internet.

Netscape's Home (Домашняя страница Netscape)

Выбранная команда Directory к Netscape's Home позволяет связаться с

сервером корпорации Netscape с тем, чтобы получить дополнительную

информацию.

What's New! (Что нового!)

Выбранная команда Directory к What's New! позволяет получить доступ к

странице, на которой имеется новая информация, появляющаяся в Internet

практически каждый день.

What's Cool! (Что хорошего!)

Выбранная команда Directory к What's Cool! открывает доступ к

гипертекстовой страничке, на которой вы узнаете о самых интересных местах

Internet.

Netscape Galleria (Галерея Netscape)

Выбранная команда Directory к Netscape Galleria позволяет просмотреть

каталог интерактивных услуг и предложений от заказчиков сервера Netscape.

Internet Directory (Каталог Internet)

Выбранная команда Directory к Internet Directory позволяет просмотреть

главный каталог узлов Internet.

Internet Search (Поиск в Internet)

Выбранная команда Directory к Internet Search позволяет просмотреть

ссылки на поисковые серверы Internet.

В Internet поисковые серверы предназначены для общего поиска по

Internet и поиска по базам данных. Самый лучший список баз данных и

поисковых серверов вы найдете здесь: www.search.com.

Другие популярные поисковые службы:

n AltaVista (www.altavista.com). Понимает

русский язык.

n Yahoo (www.yahoo.com).

n Infoseek (www.infoseek.com).

n Lycos (www.lycos.com).

n Excite (www.excite.com).

Internet White Pages (Белые страницы Internet)

Выбранная команда Directory к Internet White Pages позволяет

просмотреть каталог служб, позволяющих найти пользователя Internet по его

имени и адресу электронной почты.

About the Internet (Об Internet)

Выбранная команда Directory к About the Internet открывает доступ к

гипертекстовой странице, на которой содержится основная информация

относительно Internet, содержащая ссылки на страницы, объясняющие принципы

Сети сетей.

Window (Окно)

Опции меню Window позволяют:

n открыть окно программы Netscape Mail.

n открыть окно программы Netscape News.

n отобразить окно со встроенной

программой Address Book, в которой вы

можете создавать и модифицировать

файлы с адресами электронной почты.

n отобразить окно со встроенной

программой Bookmarks, в которой вы

можете создавать и модифицировать файлы

закладок.

n отобразить окно со встроенной программой

History.

Netscape Mail (Программа Netscape Mail)

Выбранная команда Window к Netscape Mail позволяет открыть окно

программы Netscape Mail.

Netscape News (Программа Netscape News)

Выбранная команда Window к Netscape News позволяет открыть окно

программы Netscape News.

Address Book (Адресная книга)

Выбранная команда Window к Address Book позволяет отобразить окно со

встроенной программой Address Book, в которой вы можете создавать и

модифицировать файлы, содержащие адреса электронной почты.

Bookmarks (Закладки)

Выбранная команда Window к Bookmarks позволяет отобразить окно со

встроенной программой Bookmarks, в которой вы можете создавать и

модифицировать файлы закладок.

Закладки позволяют запоминать титулы страниц Web таким образом, что вы

всегда можете вернуться к необходимому гипертекстовому документу.

Вы также можете запустить программу Bookmarks, выбрав из меню Bookmarks

команду Add Bookmark.

В программе Bookmarks новая закладка создается посредством нажатия

клавиши Ctrl и вводом буквы A или выбором команды ItemрAdd Folder.

Сортировка списка ссылок осуществляется командой Item к Sort Bookmarks.

Перемещать ссылки можно, используя метод буксировки.

В диалоговом окне Bookmarks Properties (доступ: Item к Bookmarks

Properties) вы можете дать новое имя закладке и изменить ее другие

параметры.

Удалить закладку из списка можно простым нажатием клавиши Delete.

Создать так называемое имя-псевдоним закладки вы можете посредством

команды Item к Make Alias.

Если вы хотите сохранить картотеку ссылок в виде текстового файла, то

выберите команду File к Save As и в появившемся диалоговом окне Save

bookmarks file дайте имя вашему файлу и укажите для него расширение .txt.

Через команду FileрImport вы можете затем импортировать этот файл в

программу Bookmarks.

History (Хронология)

Выбранная команда Window к History позволяет отобразить окно со

встроенной программой History.

Программа History отображает список, содержащий титулы и URL страниц, с

которыми вы работали в данной сессии. Данные о каждой просмотренной странице

вносятся в список хронологии и там соответственно сортируются. Посредством

нажатия на кнопку Go to или двойного нажатия клавишей мыши на элементе

списка вы можете загрузить соответствующий гипертекстовый документ в окно

броузера. Если вы нажмете кнопку Add to Bookmark, то выбранная страница

окажется в списке закладок.

Help (Подсказка)

Опции меню Help позволяют:

n получить доступ к самой полной

информации о программных продуктах

корпорации Netscape.

n отобразить информацию об установленных

дополнительных модулях программы.

n отобразить гипертекстовую страницу,

содержащую регистрационный номер вашей

копии Netscape Navigator Gold.

n отобразить страницу с информацией о

новых версиях и модернизациях программы

Netscape Navigator Gold.

n просмотреть в интерактивном режиме

последнюю версию документации

программы Netscape Navigator Gold.

n получить доступ к гипертекстовой

страничке, на которой вы можете найти

советы по использованию специфических

версий Netscape Navigator.

n получить доступ к гипертекстовой

страничке, на которой вы можете найти

ответы на часто задаваемые вопросы по

использованию программного обеспечения

корпорации Netscape.

n получить доступ к гипертекстовой

страничке, на которой вы можете найти

вопросы и ответы по использованию

системы безопасности в продуктах

корпорации Netscape.

n получить доступ к гипертекстовой

страничке, на которой вы можете

заполнить так называемый бланк

обратной связи и переслать его в

корпорацию Netscape.

n получить доступ к гипертекстовой

страничке с информацией,

которая поможет вам

получить помощь от Netscape.

n получить доступ к гипертекстовой

страничке с ссылками, которые помогут

вам создавать и публиковать в Internet

свои гипертекстовые странички, используя

программное обеспечение Netscape.

About Netscape (Информация относительно программного обеспечения

корпорации Netscape)

Выбранная команда Help к About Netscape позволяет получить доступ к

самой полной информации о программных продуктах корпорации Netscape.

About Plug-ins (О дополнительных модулях)

Выбранная команда Help к About Plug-ins позволяет отобразить информацию

об установленных дополнительных модулях программы. Дополнительные модули

являются специальным программным обеспечением, которое расширяет возможности

Netscape Navigator Gold.

Ниже приводится информация относительно этих расширений.

Корпорация Netscape вовремя воспользовалась ажиотажем вокруг Internet и

выпустила свое приложение для сети сетей, которое оказалось лучшим из

лучших. Приятной стороной этого броузера являются расширения plug-in. Эти

вещи чем-то напоминают платформенно-зависимые модули QuarkXPress. Разве что

здесь может еще и быть платформенно-независимый язык программирования Java.

Расширения бывают скрытые, встраиваемые и полноэкранные.

Встраиваемые расширения проявляются только при открытии гипертекстового

документа, например, когда проигрываются звуковые файлы. Полноэкранные

расширения проявляют себя при загрузке ассоциированных файлов, например,

документов Adobe Acrobat. Скрытые расширения никак себя не проявляют, эти

вещи просто работают тогда, когда им нужно работать.

Расширений для Netscape Navigator существует бесчисленное множество.

Это переводчики, программы проверки орфографии, мультимедийные приложения,

средства воспроизведения трехмерной графики, различные трассировщики и т.д.

Практически всю эту коллекцию вы можете приобрести или просто скачать через

сервер Netscape. Некоторые из расширений уже входят в состав программы,

например Live3D воспроизводит трехмерную графику, CoolTalk позволяет вам

через Internet разговаривать с удаленным абонентом. Другие расширения делают

интерфейс пользователя более наглядным и удобным. Например, HotPage

добавляет в меню программы пункт HotPage, с помощью опций которого вы можете

сохранить документ в виде графического файла или как файл HTML. Расширение

HistoryTree отображает просмотренный гипертекстовый документ в окне

программы в виде замысловатого графа. HindSite позволяет вести поиск среди

ваших ссылок в автономном контекстно-зависимом режиме. CyberSpell проверяет

английские орфографические ошибки в документах и электронных сообщениях

Netscape Mail. Web Translator переводит текст загруженной странички с

английского языка на испанский, немецкий или французский. Zip-It

просматривает содержимое удаленных архивных файлов и, в случае

необходимости, может производить разархивирование любого файла. Look@Me

шпионит за экраном удаленного узла, а Carbon Copy вообще позволяет работать

на этом узле.

Все, что вам нужно знать о расширениях Netscape Navigator:

n лучшие расширения находятся на сервере

компании Macromedia

(www.macromedia.com/shockwave/plugin/

plugin.cgi).

n неплохие расширения Real Audio лежат на

сервере Progressive Networks

(www.realaudio.com).

n если вы хотите воспроизводить AVI-файлы

во время загрузки документа, то скачайте

с сервера Iterated Systems

(www.iterated.com/CoolFusion) расширение

CoolFusion.

n если у вас медленная линия, то вам

необходимо сжимать мультимедийные

штучки расширением FutureSplash

(www.futurewave.com/downloadfs.htm).

n на сервере Micrografx

(www.micrografx.com/products/

qui-cksilver/quicksilver.html) вы можете

скачать QuickSilver и затем

манипулировать объектами VRML в окне

Netscape Navigator Gold.

Поиск необходимых расширений

Поместите на страницу, содержащую список расширений в раздел

следующий тэг:

PLUGINSPAGE=[URL]

Параметр PLUGINSPAGE определяет URL поиска неустановленных расширений.

Если программа не найдет на данном сервере новое расширение, то появится

соответствующее сообщение. Если же расширение найдено, то Navigator сообщит

URL, с которого вы можете загрузить недостающий plug-in.

Registration Information (Информация о регистрации)

Выбранная команда Help к Registration Information позволяет отобразить

гипертекстовую страницу, содержащую регистрационный номер вашей копии

Netscape Navigator Gold. Если вы еще не зарегистрировали свою программу, то

здесь вы найдете информацию о том, как это можно сделать.

Software (Программное обеспечение)

Выбранная команда Help к Software позволяет отобразить страницу с

информацией о новых версиях и модернизациях программы Netscape Navigator

Gold.

Handbook (Справочник)

Выбранная команда Help к Handbook Netscape позволяет просмотреть в

интерактивном режиме последнюю версию документации программы Netscape

Navigator Gold.

Release Notes (Последние замечания)

Выбранная команда Help к Release Notes позволяет получить доступ к

гипертекстовой страничке, на которой вы можете, например, найти советы по

использованию специфической версии Netscape Navigator.

Frequently Asked Questions (Вопросы и ответы)

Выбранная команда Help к Frequently Asked Questions позволяет получить

доступ к гипертекстовой страничке, на которой вы можете найти ответы на

часто задаваемые вопросы по использованию программного обеспечения

корпорации Netscape.

On Security (Информация о системе безопасности)

Выбранная команда Help к On Security позволяет получить доступ к

гипертекстовой страничке, на которой вы можете найти вопросы и ответы по

использованию в продуктах корпорации Netscape системы безопасности Internet.

How to Give Feedback (Обратная связь)

Выбранная команда Help к How to Give Feedback позволяет получить доступ

к гипертекстовой страничке, на которой вы можете заполнить так называемый

бланк обратной связи и переслать его в корпорацию Netscape. Вы можете

включить в этот бланк ваши комментарии, пожелания или любую другую

информацию, которая, как вам кажется, будет интересна Netscape.

How to Get Support (Поддержка пользователей)

Выбранная команда Help к How to Get Support позволяет получить доступ к

гипертекстовой страничке, на которой вы найдете информацию, которая поможет

вам получить помощь от Netscape. Например, там содержатся адреса электронной

почты ведущих специалистов корпорации.

How to Create Web Services (Как создать собственную

службу Web)

Выбранная команда Help к How to Create Web Services позволяет получить

доступ к гипертекстовой страничке, на которой вы найдете ссылки, которые

помогут вам создать и опубликовать в Internet свои гипертекстовые странички,

используя программное обеспечение Netscape.

Telnet

В Telnet, как правило, вкладывают два смысла. Во первых, Telnet -- это

протокол эмуляции терминала, через который осуществляется удаленный доступ в

Internet. А во вторых,

telnet -- это программа UNIX с аналогичными функциями (пишется с

маленькой буквы, ибо в UNIX это важно).

Запустив такую программу, вы увидите на экране своего монитора

удаленный терминал.

Все это может быть реальностью только за деньги, то есть вы должны

получить доступ в Internet на уровне Dial-up. Впрочем, в Internet существуют

сервера, которые предоставляют бесплатный ограниченный доступ через Telnet к

некоторым базам данных.

Программа telnet через определенные команды позволяет управлять

параметрами сеанса связи только через командный режим. Это означает, что

сначала вы коннектитесь с удаленным хостом и после того как нажимаете

escape-последовательность, попадаете в командный режим telnet. Сеанс связи

поддерживается как вашим софтом, так и софтом удаленной машины. Если копать

глубже, то связь осуществляется через протокол TCP посредством пакетов UDP.

Таким образом Telnet это:

n Регистрация на удаленном компьютере

n Использование софта Internet, в том числе клиентских

программ на удаленном компьютере

n Запуск доступного софта на удаленном компьютере

NSCA Telnet через Windows 98

Многие, говоря о Telnet, подразумевают UNIX. А те, кто считают, что

знают UNIX, работают в Internet через Telnet. Мы уходим от тех и от других.

На время. Мы погрузимся в старый добрый DOS, так как NCSA Telnet работает в

стандартной MS-DOS, а значит и в Windows 98.

Запуск NCSA Telnet осуществляется после ввода следующей команды:

telnet hostname

Если все набрано правильно, то вы соединитесь с хостом hostname . Этот

хост попросит вас ввести регистрационное имя и пароль.

NCSA Telnet эмулирует терминал VT100. Но операционка удаленного хоста

не может определить тип вашего терминала. Вы должны определить его сами. Для

удаленных UNIX-компьютеров введите:

newton% set term=vt100;tset

Выход из NCSA Telnet зависит от того количества сессий, которое вы

имеете в данный момент, то есть, вы должны разорвать связь с каждым хостом.

Результатом ваших действий должно быть обычное приглашение вашей

операционки.

Вы также можете завершить сеанс через комбинацию клавиш Alt-X . Эта

команда закрывает только текущую сессию.

Непонятный VT100 и ясный локальный терминал

В NCSA Telnet терминал вашего компьютера отображается на удаленном

компьютере как терминал VT100. Вы же работаете на PC. Поэтому некоторые

клавиши вашего компьютера отличаются от аналогичных на VT100.

Сразу несколько сессий? ОК!

NCSA Telnet позволяет открывать несколько сессий одновременно. Для

этого вы должны ввести:

telnet hostname hostname ...

Здесь hostname -- имя компьютера, с которым вы коннектитесь.

Что там есть в нашей строке состояния? Все!

Терминал VT100 удаленного компьютера требует 24 строки. В 25 строке

локального компьютера вы можете видеть состояние собственной сессии.

Выделенные символы отображаются в нижнем левом углу. Все эти символы

соответствуют удаленному хосту. Остальные символы могут отображать все что

угодно.

Открываем еще одну сессию

Открыть еще одну сессию на текущем удаленном хосте или на другом хосте

можно через клавиатурную комбинацию Alt-A .

Указываем на хоста

Вы можете телнетиться только через IP-адрес. Поэтому ваша первая задача

-- определить IP-адрес удаленного компьютера. Для этого настройте программу

на поиск имен посредством соответствующей службы удаленного сервера.

Прокручиваем в режиме обратной прокрутки

Клавиша Scroll Lock позволяет не прокручивать экран, когда идет

получение данных и включать/отключать режим обратной прокрутки. Режим

обратной прокрутки дает вам возможность перемещать данные на экране

стрелками или клавишами PgUp и PgDn .

Помните, что в режиме обратной прокрутки нельзя оперировать командами

telnet.

Вырезаем и вставляем

Находясь в режиме обратной прокрутки, вы можете копировать части текста

одной сессии и вставлять эти части в другую. Попробуем скопировать текст в

буфер и затем вставить его из буфера в новую сессию.

1 . Включим режим обратной прокрутки посредством нажатия клавиши Scroll

Lock .

2 . Передвиньте курсор в начало текста и нажмите клавишу пробела.

3 . Передвиньте курсор в конец текста и нажмите клавишу пробела.

4 . Нажмите Alt-C . Выделенный текст скопирован в буфер.

5 . Выходим из режима обратной прокрутки и переключаемся на новую сессию

посредством нажатия клавиш Alt-N или Alt-B .

6 . Помещаем курсор в желаемое место и нажимаем

Alt-V . Выделенный текст помещен в новую сессию.

Переключаемся между сессиями

Переключиться между двумя активными сессиями можно через команду Alt-N .

Имя активизированной сессии вы можете увидеть в левой нижней части экрана.

Если вы хотите вернуться в старую сессию, то вы можете это сделать через

команду Alt-B .

Просматриваем сообщения экрана консоли

Экран консоли отображает информацию, связанную с локальным и удаленным

компьютером. Вызвать экран консоли, то есть сделать сессию невидимой, но

активизированной, вы можете через Alt-Z .

Закрываем текущую сессию

Командой Alt-X закрывается текущая сессия. Используя эту команду, мы

наблюдали сбои на удаленном компьютере.

Перехватываем текст экрана

Если нажать Alt-C , то можно перехватить текст экрана и направить его в

файл (то есть добавить текст к файлу capfile) или распечатать. Если вы

повторно выберите команду Alt-C , вы отключите режим перехвата.

Если в меню Parameters вместо стандартного файла для перехвата указать

prn , то можно распечатать перехваченный текст.

Невозможно перехватить текст активной сессии, если включен перехват в

фоновой сессии. Решить эту проблему можно командой Alt-D .

Игнорируем бесконечный текст

Если вы хотите пропустить идущий бесконечным потоком текст, нажмите

Alt-S . Вы пропустите текст только на экране, то есть сам текст будет

находиться в буфере перехвата.

Перезагружаем экран VT100

Если вам не понравился текущий тип терминала и вы желаете установить

новые параметры VT100 (точнее их установит удаленный компьютер), нажмите

Alt-R . Параметры вашего экрана VT100 в этом случае переустановятся таким

образом, что отключится режим упаковки, разблокируется графический режим, а

табуляторы установятся на каждую восьмую позицию.

Все! Надоело! Больше не могу!

Команда Ctrl-Shift-F3 применяется в том случае, когда ни одна из сессий

не работает, Scroll Lock не горит, нажатие клавиш ALT-R и/или ALT-X

не

приводит ни к какому результату. После выполнения команды Ctrl-Shift-F3 вы

выйдите из Telnet в DOS.

Не разрывая связь, выходим в старую добрую DOS

Если вы хотите выйти в DOS и при этом оставаться в сессиях, нажмите

Alt-E . В досовской оболочке вы можете использовать любые программы, кроме

сетевой версии NCSA Telnet, сетевой версии программы FTP пользователя и

программы format. Возврат в Telnet осуществляется командой exit .

Устанавливаем параметры

Если вы хотите изменить цвета, задать новый эхо-режим, настроить

клавишу стирания символов, управлять режимом экрана и режимом пересылки

файлов, дать другое имя сессии, типу терминала и файлу перехвата, нажмите

Alt-P . После того, как вы в появившемся диалоговом окне Parameters

модифицируете необходимые опции, нажмите клавишу F1 (для сохранения

изменений) или Esc (для сохранения предыдущих параметров).

Символы или строки? Вот в чем вопрос!

Вы можете воспользоваться достоинствами построчного режима в случае,

если вам долго отвечает удаленный компьютер. Вы просто втаскиваете данные в

буфер и пересылаете их единым пакетом на удаленный компьютер через нажатие

клавиши Return . При этом вы можете воспользоваться следующими клавиатурными

комбинациями:

n если вы нажмете Ctrl-U , то буфер очистится

n удаление последнего символа, добавленного в буфер

осуществляется клавишей Backspace

n после нажатия клавиши Tab данные буфера вместе с

символом табуляции немедленно отправятся на

удаленный компьютер

Два замечания относительно построчного режима:

n любой управляющий символ можно отправить на

удаленный компьютер лишь в том случае, если этот

символ снабдить приставкой ^

n нельзя переслать на удаленный компьютер комбинации

Ctrl-U или Backspace .

В случае символьного режима ваши данные передаются на удаленный

компьютер непосредственно в процессе их набора. Этот режим позволяет

использовать весь экран вашего монитора для редактирования данных.

А что если нажать Backspace?!

По умолчанию, клавиша Backspace преобразовывается в код клавиши Delete .

Некоторые удаленные компьютеры работают только с клавишей Backspace . Чтобы

добиться совместимости, необходимо открыть меню Parameters и переустановить

код клавиши Backspace .

Хочу другое имя сессии!

Вы можете изменить имя сессии, появляющееся в строке состояния в правом

нижнем углу через меню Parameters . В соответствующее поле данных вы можете

ввести до 13 символов.

Хочу другой терминал!

В большинстве сессий эмулируется терминал VT100. У вас имеются другие

возможности эмуляции:

n выбрать VT100 с графикой Tektronix 4014

n использовать только команды VT100

n игнорировать коды VT100 и Tektronix 4014

Автоматический перенос строки

Если вы не хотите смотреть на беспорядочный поток символов, используйте

символы конца строк. При включенной опции автоматического переноса строки

переполненный текст автоматически переходит на следующую строку.

Адаптирумся к графическому интерфейсу

Как правило, режим быстрого вывода текста через буфер экрана

несовместим с Windows. В файле конфигурации посредством опции bios вы можете

установить так называемый режим адаптации. В этом режиме текст на экране

выводится через специальную программу, использующую доступ к BIOS.

Команда finger и ее демон

Через команду finger вы можете получить информацию о пользователях,

находящихся в сети. Синтаксис этой команды следующий:

finger [parameters] [name]@hostname

Без каких-либо ключей-свичей через команду finger вы можете отобразить

на экране своего монитора:

n регистрационное имя пользователя сети

n полное имя пользователя сети

n время регистрации пользователя

n идентификатор пользователя

n тип терминала

При наличии нескольких аргументов перед name вы можете отобразить

информацию относительно удаленного пользователя. Эта информация может

включать:

n каталог удаленного пользователя

n оболочка удаленного пользователя

n время первой или последней регистрации удаленного

пользователя

n тип терминала удаленного пользователя и комментарий

для этого терминала из /etc/tty

n время получения последней почты

n время последнего чтения почты

n информацию, содержащуюся в файле .plan в основном

каталоге удаленного пользователя

n проект, содержащийся в файле .project в основном

каталоге удаленного пользователя

Если вы хотите установить связь с удаленным компьютером и запустить на

нем демона команды finger , то попробуйте вставить вместо name символ кваквы,

то есть @ , а после кваквы указать имя удаленного компьютера или его

IP-адрес.

Опции команды finger

-l

Расширенная информация для локалки.

-w

Общая информация для демона finger .

-t

Изменение времени ожидания ответа.

-h

Изменение имени файла config.tel .

Режимы переноса файла

В NCSA Telnet под режимом переноса файла понимают две функции FTP и

rcp.

Посредством опций Enabled или Disabled меню Parameters вы можете

переносить или блокировать перенос файлов.

Если вы немедленно хотите прервать процесс передачи файла, нажмите

Ctrl-C . Если же вы желаете прервать процесс получения файла, пошлите на

удаленный компьютер команду ABOR .

NSCA Telnet позволяет пересылать файлы через FTP. Вы можете:

n Передать текстовые файлы или файлы бинарного

формата

n Создать, изменить или удалить каталог

n Распечатать текущий каталог

n Просмотреть файлы в текущем каталоге

n Получить или отослать несколько файлов

n Удалить файл

Для того, чтобы установить ftp, войдите в меню Parameters и

разблокируйте режим переноса файлов. Теперь вы можете запустить программу

ftp. Помните, что режим переноса файлов должен поддерживать удаленный

компьютер.

Telnet и передача файлов через Internet

С помощью FTP или протокола передачи файлов вы можете получить доступ к

файловой системе удаленного компьютера. Это означает, что вы можете передать

файл (через FTP, например, вы можете пересылать файлы в бинарном виде или

как текст, то есть в виде ASCII) на удаленный компьютер или получить

необходимый файл с этого компьютера.

FTP был специально создан для того, чтобы пользователи Intrenet имели

доступ к терабайтам данных и бесчисленным архивам софта, различным

руководствам, звуковым файлам и картинкам. Любой уважающий себя сервер имеет

службу FTP, услуги которой, как правило, всегда бесплатные (достаточно

указать логин в виде anonymous, а в качестве пароля ввести свой адрес

электронной почты).

В настоящее время в Internet существует три разновидности FTP-серверов:

n Internet-style (доступ ко всем файлам сервера)

n Listserver (ограниченный доступ)

n FTPmail (доступ через электронную почту)

Серверы ftpmail наиболее интересны для тех пользователей, у которых

доступ к Internet весьма ограничен, то есть они могут пользоваться только

электронной почтой. Вы вводите в своем письме несколько специальных команд,

которые должен выполнить выбранный вами FTPmail-сервер.

Если все введено правильно и ваше письмо пришло по назначению, то

FTPmail-сервер начнет искать необходимый файл практически во всех закоулках

Internet. Если файл найден, то вам его перешлют, в противном случае вам

придет письмо с информацией о том, что этого файла в природе не существует.

Вещь, конечно, хорошая, но если у вас полный доступ к ресурсам Internet, она

вам ни к чему.

Пересылаем файлы

Пересылка файлов по сети осуществляется через команду ftp . Эта команда

устанавливает соединение с сервером FTP. Если соединение не установлено, то

на вашем экране отобразится внутренний командный интерпретатор с

соответствующим приглашением ftp. Синтаксис команды ftp следующий:

ftp [-name] [hostname]

Параметры для пересылаемых файлов

-d [level]

Переход в режим отладки.

-f

Выполнять только команды файла filename .

-g

Блокировка автоматического расширения имени файла.

-h

Указать файл конфигурации.

-i

Блокировка приглашений для групповых переносов файлов.

-m

Включить программу more .

-n

Блокировка режима автоматической регистрации.

-p

Выполнить команды, содержащиеся в файле filename . Эти команды

выполнятся сразу после того, как вы зарегистрируетесь.

-r

Отключить переадресацию вывода.

-s

Отключить переключение слэша.

-v

Отображать любые сообщения удаленного компьютера.

Команды для передаваемых файлов

[command]

Если команда не указана -- выйти в DOS. Если команда указана --

выполнить ее в DOS.

account [password]

Получить пароль доступа к дополнительным ресурсам сервера FTP.

ascii

ASCII-режим передачи данных.

bell

Переслать данные и издать писк.

bget

Бинарный режим передачи данных. Аналог команды get .

binary

Бинарный режим передачи данных.

bput

Переслать файл в бинарном режиме. Аналог

команды put .

bye

Закончить выполнение ftp .

cd

Изменить каталог на удаленном компьютере.

close

Закрыть соединение с сервером FTP и выйти в DOS.

delete

Уничтожить файл на удаленном компьютере.

debug [mode]

Активизировать режим отладки, то есть ставить перед каждой командой,

посланной на удаленный компьютер символы -> .

dir [other_directory][my_file]

Распечатать содержимое локального каталога на удаленном компьютере. Вы

можете сохранить полученную таким образом информацию в файле на своем

компьютере. Если вы ввели эту команду без аргумента other_directory , то на

удаленном компьютере будет выведен текущий каталог. Если отсутствует

аргумент my_file , то вся информация отобразится на экране вашего монитора.

get other_file [my_file]

Получить файл с удаленного компьютера и сохранить его на локальном

компьютере. Если у этой команды отсутствует аргумент, то имя сохраняемого

файла на локалке будет таким же, каким оно было на удаленном компьютере.

glob

Посредством этой команды вы можете оперировать расширениями файлов, то

есть использовать команды mdelete , mget и mput не только вместе с именами

файлов, но и с их расширениями. Вы можете применять стандартные символы ( * и

& ) в расширениях передаваемых файлов.

hash

Активизировать режим печати символов # при передаче блоков, размер

каждого из которых равен 1024 байта.

help [command]

Отобразить описание команды.

interactive

Активизировать режим выдачи сообщений во время приема или передачи

файла.

lcd [directory]

Перейти в другой каталог локального компьютера. Если у этой команды

отсутствует аргумент, то вы перейдете в каталог по умолчанию.

lls [directory]

Просмотреть каталог локального компьютера.

ls [other_directory][my_file]

Отобразить содержимое каталога удаленного компьютера. Если у команды

нет аргумента other_directory , то отобразится содержимое каталога по

умолчанию. Если же отсутствует аргумент my_file , то отобразится файл, в

который будет помещена информация с удаленного компьютера. Если же вместо

последнего аргумента стоит дефис, то вся информация с удаленного компьютера

будет выведена на экран вашего монитора.

mdelete [other_files]

Уничтожить файлы other_files удаленного компьютера.

mdir other_files my_file

Распечатать локальные файлы other_files на удаленном компьютере.

mget other_files

Найти на удаленном компьютере файлы other_files , расшифровать и

активизировать команду get для переноса этих файлов в рабочий каталог

локального компьютера.

mkdir name_directory

Создать каталог на удаленном компьютере.

mls other_files my_files

Отобразить содержимое файлов удаленного компьютера.

mode [name_mode]

Активизация режима переноса файлов в определенное место. По умолчанию

установлен режим stream.

more

Включить режим more, то есть через паузу разбивать содержимое каталогов

на части. Почти как конвейер в UNIX.

mput files

Найти и расшифровать локальные файлы files и запустить команду put для

переноса этих файлов в рабочий каталог удаленного компьютера.

noninteractive

Не выдавать сообщения во время пересылки или приема файлов.

open host [port]

Соединиться с сервером FTP.

prompt

Показывать интерактивные сообщения.

put my_file [other_file]

Поместить локальный файл my_file на удаленный компьютер. Если у этой

команды отсутствует аргумент other_file , то будет использован исходный файл.

pwd

Распечатать имя текущего каталога на удаленном компьютере.

quit

Аналог команды bye .

quote arg1 arg2 ...

Передать аргументы arg1 arg2 ... на сервер FTP и получить только код

ответа.

recv other_file [my_file]

Аналог команды get .

remotehelp [name_command]

Получить список доступных команд удаленного

сервера FTP.

rename old_name new_name

Дать другое имя файлу old_name удаленного компьютера.

rm other_file

Аналог команды delete .

rmdir name_directory

Стереть каталог name_directory на удаленном компьютере.

send my_file [other_file]

Аналог команды put .

sendport

Активизация режима команд PORT . Это позволяет ускорить пересылку

файлов. Если PORT не работает, то через протокол передачи файлы поступят на

порт данных по умолчанию.

slashflip

Изменить режим смены слэша.

status

Отобразить состояние программы ftp в данный момент времени.

struct [name_struct]

Эта команда позволяет установить соответствие между структурой файла и

указанным именем. В установке по умолчанию имя структуры есть file .

type [name_type]

С помощью этой команды вы можете установить тип ascii для текстов и тип

binary или image для графики. Если аргумент у этой команды отсутствует, то

вы увидите тип по умолчанию, то есть ascii .

user name_user [password][access]

Весьма полезная команда. Вы сообщаете серверу FTP кто вы есть. Если

аргумент у этой команды отсутствует, то вы увидите запрос на ввод пароля.

Если указан только аргумент access , то после того как вы зарегистрируетесь,

можно будет воспользоваться командой доступа account .

verbose

Активизация так называемого режима сообщений, то есть режима, при

котором вы можете получать полную информацию с сервера FTP. Этот режим

активизирован по умолчанию.

? [command]

Аналог команды help .

Что может программа ftp и какие у нее параметры

Посредством программы ftp вы можете представлять файлы для передачи в

виде ascii или binary

n конструкция передаваемого файла основана на типе file ,

record или page (тип file выбран по умолчанию).

n файлы передаются в режиме stream , block или

compressed (режим stream выбирается по умолчанию)

Пути и слэши для программы ftp

Прием файлов через FTP осуществляется в ваш каталог по умолчанию. Вы

можете изменить этот каталог, используя досовский синтаксис, так как все

равно обратные слэши \ будут преобразованы в прямые /.

Одновременно передаем и работаем

Вы можете передавать файлы и одновременно работать с другой активной

сессией, перейти из одной сессии в другую или создать новую. Это не

означает, что можно в двух сессиях вести две передачи файлов, так как один

из процессов передачи будет игнорироваться.

В процессе передачи файлов не следует выгружаться из программы, иначе

вы доставите большую неприятность удаленному компьютеру.

Правила для имен пересылаемых файлов

Именуйте файлы следующим образом:

n имя файла должно состоять максимум из восьми

символов, а его расширение должно быть

трехсимвольным. Имя файла отделяется от расширения

только точкой

n переносимые файлы не чувствительны к регистру

n имя файла обязано быть без спецсимволов (к ним

относятся: * , $ , # , -) и управляющих символов

Информация с сервера FTP

Нажмите Alt-Z . Перед вами информация с сервера FTP. Если вы соединитесь

с удаленным компьютером, то вы можете увидеть имя этого компьютера и его

IP-адрес. Если вы дадите команду USER , то перед вами появится

регистрационное имя пользователя.

FTP на локальном компьютере

Команды FTP зависят от софта удаленного узла. В общем случае после

ввода команды ftp вам нужно ввести имя локального компьютера или IP-адрес,

затем регистрационное имя и пароль (или просто нажать Enter ).

Общие команды FTP

help

Показать список команд FTP локального компьютера.

remotehelp

Показать список команд FTP удаленного компьютера.

ascii

Перенос файлов ASCII.

binary

Перенос файлов с бинарными данными.

cd

Установить на локальном компьютере новый каталог.

dir

Отобразить файлы из каталога локального компьютера.

get filename

Получить файл с локального компьютера и переслать его на удаленный.

put filename

Переслать файл с удаленного хоста на локальный компьютер.

pwd

Отобразить на локальном компьютере имя каталога по умолчанию.

quit

Выйти из FTP.

Состояние протокола передачи файлов

Введите команду put или get . Обратите внимание на нижний правый угол

экрана. Перед вами имя файла и количество переданных байтов, (если вы ввели

put ) или количество байтов готовых к передаче (если вы ввели get ).

Через эти числа вы можете изучать процесс передачи файла. После

передачи, имя файла пропадет и удаленный компьютер выведет соответствующее

подтверждение.

Первый файл пошел, второй пошел... в очередь!

Через команду mput или mget вы можете передавать файлы по очереди.

Файлы обзываются посредством спецсимволов. Знак вопроса -- любой символ,

звездочка -- несколько символов. Например, вы можете ввести mget bob.*

и передать кучу файлов bob.1 , bob.2 и т.д.

Internet Relay Chat

IRC или релейный разговор чем-то напоминает работу в конференциях

Usenet. Но если там вы общаетесь не в реальном времени, то здесь может

вестись живой разговор. Разве что, -- вас никто не слышит. Вас могут

прочитать. Вы набиваете текст на клавиатуре. Ваша информация попадает на

общий дисплей. Различные группы видят ваш бред. Если интересно -- отвечают.

Если -- нет, то, в лучшем случае, молчат. В худшем... Именно так и

начинаются войны и наезды в рамках Internet.

Вы можете создать новую релейную группу. Для этого вам нужно

подсоединится к каналу, к которому еще никто не подключен, и выбрать

какую-нибудь новую тему для базара.

Вы можете так же застолбить себе комнатку на двоих, передать файл со

своей фотографией по каналу IRC своему собеседнику или играть в компьютерные

игры с чудаком на том берегу океана.

Выясните у вашего поставщика услуг Internet о доступных каналах IRC.

Но! Если у вас имеется доступ к Telnet, то у вас имеется доступ и к

релейному разговору с юзерами всего мира.

В IRC возможно наличие большого количества каналов. В отличии от

адресов Сети сетей каналы имеют исключительно нецифровые имена. Список

каналов содержит имя самого канала и количество юзеров этого канала.

В IRC только идиоты пользуются реальными именами. Здесь в моде

псевдонимы. Именно между этой тонной псевдонимов и ведется разговор. Если вы

не знаете английский, то лучше не суйтесь. Здесь над вами будут издеваться.

Эти люди не понимают даже так называемого хорошего английского. Русских

здесь воспринимают примерно так, как русские относятся к чукчам из Ненецкой

республики. Но, впрочем, попытка -- не пытка. Бавает и наоборот. Наверное,

зависит от их настроения. Вас могут принять в свой круг. Вот только тогда вы

сможете ощутить ритм работы релейного канала. В любом случае, начните свое

знакомство с тривиального "Hi All".

Как подключиться к IRC

IRC -- это соединенные между собой серверы мира. Если вы пользователь

UNIX, то наберите irc. Если у вас доступ через SLIP/PPP, то вам необходима

соответствующая программа. Командой /server [server_address] вы выбираете

сервер. Теперь пoпpoбуйте /join #newbie.

Добро пожаловать в IRC!

Команды IRC

/away

Подождите, я сейчас приду.

/help

Вывести подсказку.

/invite

Присоединяйся к базару, чудак!

/join

Создать канал.

/list

Вывести список всех каналов и количество пользователей (кроме

анонимных).

/m name

Получи, чудак, вот это дело!

/mode

Собственная цензура. Вы определяете тех, кто может приконнектиться к

вашему каналу.

/mode #channel +s

Создать скрытый канал.

/mode #channel +p

Сделать канал привелигированным.

/nick

Сменить собственный общедоступный псевдоним.

/query

Идет приватный базар.

/quit

Выйти из IRC.

/summon

Присоединяйся к нам, чудак!

/topic

Создание нового канала и информирование других доступных юзеров

относительно новой темы релейного разговора.

/who

Хочу посмотреть адреса юзеров на выбранном канале!

/whois

Хочу получить информацию о том или ином юзере IRC.

/whois *

Получить полный список юзеров канала.

MUD

MUD означает так называемые многопользовательские темницы (Multiple

User Dungeons). Эти дела уводят релейные чаты в нечто невообразимое.

Некоторые называют это сетевым бредом. Но, по-моему, именно в этом сетевом

бреде и плодятся хакеры. А бредом это дело называют те, кто ненавидит

хакеров из-за зависти. Ну кому захочется быть идиотом только из-за того, что

на свете есть очень умный народ. Итак, MUD -- это нечто новое, даже, можно

сказать, новая реальность. Как сюда попасть? Вы шастаете по IRC? Да?! Тогда,

вы уже в ней. Оглянитесь! Вы рядом с Богом IRC. Он дает добро на "Пропасти и

драконы". А вот пошли MUCK и MUSE. Здесь масса игр. Здесь вы найдете

знаменитую HoloMuck, Танстаафл и планету Холо.

При связи с MUD выбирайте пароль так же тщательно, как и для своей

местной системы -- к сожалению, существуют взломщики MUD, которые любят

вламываться в чужие разделы. И никогда, никогда не используйте пароль своей

местной системы!

Конференции Usenet, в которых обсуждаются вопросы связанные с IRC

alt.irc

alt.irc.42

alt.irc.alumni

alt.irc.announce

alt.irc.ascension

alt.irc.bots

alt.irc.bots.eggdrop

alt.irc.cori.die.die.die

alt.irc.dalnet

alt.irc.epic

alt.irc.games

alt.irc.gnn-sucks

alt.irc.hottub

alt.irc.iaonet

alt.irc.ircii

alt.irc.nofun

alt.irc.opers

alt.irc.ops.kiss.my.ass

alt.irc.questions

alt.irc.recovery

alt.irc.romance

alt.irc.texas

alt.irc.undernet

alt.irc.undernet.30plus

alt.irc.undernet.bards

alt.irc.undernet.chatzone

alt.irc

Поисковые службы Internet

Yahoo!

Самая грандиозная поисковая система.

http://www.yahoo.com.

Infoseek

InfoSeek представляет собой подробную и довольно точную систему для

поиска информации в WWW. Запрос может быть набран в виде простого

предложения на английском языке или в виде ключевых слов и фраз.

http://www.infoseek.com.

AltaVista

Вы можете блуждать по 30 миллионам страниц, размещенных на 225000

серверах или вылавливать информацию из трех миллионов статей, опубликованных

в 14000 конференциях Usenet. Поддержка русского языка.

http://www.altavista.com.

WebCrawler

С помощью WebCrawler вы можете найти и обнаружить все, что вы хотите.

WebCrawler является великолепной поисковой службой, которая поможет вам

найти нужную информацию в море Web. Черпайте вдохновение через WebCrawler!

http://query.webcrawler.com.

Lycos

С помощью Lycos вы можете найти конкретного человека или интересущую

вас страницу Web. Попробуйте, вам понравится!

http://www.lycos.com.

Magellan

Вы можете вести свой поиск по действительно существующим местам и базам

данных. Искусство. Бизнес. Коммуникации. Компьютеры. Современная жизнь.

Экономика. Образование. Занятость. Развлечения. Окружающая среда.

Продовольствие. Здоровье. Человечество. Internet. Дети. Закон. Математика.

Музыка. Новости. Политика. Знаменитости. Наука. Четвертое измерение.

Спортивные состязания. Технологии. Путешествия.

http://www.mckinley.com.

World Wide Yellow Pages

Стартуйте в киберпространство вместе с желтыми страницами мировой

паутины.

http://www.yellow.com/.

World Wide Web Yellow Pages

Желтые страницы WWW. Введите ключевые слова в поле данных и тогда

начнется поиск по всему киберпространству. Ключевым словом может быть имя

ссылки, унифицированный локатор ресурсов или дескриптор. Чем больше вы

введете слов, описывающих запрос, тем точнее будет результат поиска.

http://www.mcp.com/nrp/wwwyp/.

Deja News

Поиск по конференциям Usenet.

http://www.dejanews.com:80.

Starting Point

Поиск ведется по огромным базам данных WWW.

http://www.stpt.com.

Who Where?

Огромный WWW-каталог электронных адресов. Вы можете совершенно

бесплатно включить в этот каталог свой адрес.

http://www.whowhere.com.

OpenText

Усовершенствуйте свой результат или начните искать по-новому. Это

приятный поиск!

http://search.opentext.com/omw/simplesearch.

Eric's Super Search 5.0

Что-то ищете? Это просто классно!

http://www.geocities.com/SiliconValley/8748/search.htm.

Коллекция эффективных модемных прошивок

Aceex 1414 v.32bis

AT&F&D0\N3\Q3

Apple Express Modem

AT&F&D0&Q0

Apple Express Modem

AT&F\N3&K3

AT&T DataPort 14.4

AT\N7%C1&C1&D0\Q3

Asian Micro Sources Modem

AT&F1V1E1X4\Q4

Best Data Smart One 14.4

AT&Q5%C1&C1&D0&K0

Boca 14.4Kbps v.32bis

AT&F&C1\N3

Boca Research V.32bis

AT&Q5%C1&C1&D0&K3

Cardinal 14.4

AT&F&C1&D0&Q5

Compudyne 1442F

AT&F&C1

CPC Turbo Modem+

AT\N6%C1&C1&D0\Q3\V1

Data Race Apex V.32/V.32bis

AT\N7%C1&C1&D0\Q3

Data Race APL 1496

AT\N7%C1&C1&D0\Q3

Digicom Eagle 9600/Scout Plus

AT&F&D0

Focus 14.4

AT&Q5%C1&C1&D0&K3S36=7

Global Village PowerPort

AT\J0\N3%C1&C1&D0\V1\Q3

Global Village PowerPort Gold/Silver

AT&F1\Q3

Global Village TelePort Gold

AT&F1%C1W1

Global Village TelePort Mercury

AT&F1&K3

Global Village TelePort Silver

AT\J0\N3%C1&C1&D0\Q3\V1

Hayes Accura 144

AT&F

Hayes Optima 14400 v.32bis

AT&F&D0

Hayes V-Series/Ultra

AT&Q5S36=7&C1&D0&K3

Intel 14.4 EX

AT&F&D0

Intel 96EX

AT\N3%C1&C1&D0\Q3

Macintosh Express Modem

AT&F\N3&D3&Q5

Macronix

ATS36=7&Q5%C1&C1&D0&K3

Macronix Maxlite 14.4

AT&F&C1&Q9\N3

Magic 14.4

V.32bis AT&F&C1

Megahertz 14400/P2144

AT&F&C1&D0

MegaHertz V.32bis

ATS36=7&Q5%C1&C1&D0&K3

Microcom Desk Porte/QX/4232 bis

AT&F&D0

Microcom QX/V.32c

AT&Q5%C3&C1&D0\J0\Q3

Multitech MT 932 Series

AT&F&D0&E4

Multitech MT1432 Series

AT&F&D0&Q1&E11

MultiTech MultiModem 224E/V.32

AT&E1&E15&C1&D0&E4$BA0

PowerUser 14.4E

AT&F&C1

Practical Peripherals 14400 FXMT

AT&F&C1

Prometheus Pro Modem Ultima

AT&F&D0

Prometheus Ultima/Home Office

AT\N3%C1&C1&D0\J0\V1\Q3

Prometheus V.32/V.32bis

AT&C1&D0*E1*F3*S1

PSI Comstation V

AT&F&C1&D0&K3&Q5\N3

PSI PowerModem II/IV

AT&Q5%C1&C1&D0&K3

Quicktel Xeba 14.4

AT&F&C1

Spectra Pocket Modem 14.4

AT&F

SpectraCom V.32bis PocketFax

AT&Q3S36=7%C1&C1&D0&K3

Supra 14.4 LC

AT&F1

SupraFAXModem v32/32 bis

AT&F1&Q5S36=7%C1&C1&D0&K3

SupraFAXModem v.32bis

AT&F1

Telebit QBlazer

AT&FS58=2S180=1S190=0

Telebit WorldBlazer

AT&F9X2

UDS Fastalk V.32 bx

AT&F&C1\N3\Q3

UDS Motorola V.3225L/V.3229L

AT&F&C1\Q3

USRobotics Courier HST Dual

AT&F&C1&D0

USRobotics Courier V.32 bis/as

AT&F&D0&H1&K2

USRobotics Sportster 14.4

AT&F&H1&C1&D0

Wang 14.4

AT&F&C1&D0

Zoltrix 14.4

AT&F&C1&D0

Zoom 14.4 V.32/V.32 bis

AT&F&C1

Серверы, совершенно бесплатно предлагающие web-пространство для вашей

web-страницы

http://www.geocities.com

http://www.xoom.com

http://www.hypermart.net

http://members.tripod.com

http://www.angelfire.com

http://www.crosswinds.net/index.html

http://www.fortunecity.com

http://www.fsn.net

http://a1bbs.dzone.co.kr

http://www.easyspace.com

http://www.cynetcity.com

http://www.cybercities.com

http://www.royaltystudios.com

http://www.internet-club.com

http://www.student.toplinks.com/freehome.htm

http://rampage.ml.org/freeinfo.html

http://www.cybercity.hko.net/

http://bip.concept.se/user

http://www.nether.net/

http://www.metrocity.net

http://mkn.co.uk/

http://www.nettaxi.com

http://home.onestop.net/

http://www.yi.com/

http://www.howdyneighbor.com/

http://www.schlund.de/

http://www.cqws.com/rates.html

http://jungle.fapema.br/

http://free.prohosting.com/

http://www.home.ch

http://www.earthonline.net/

http://www.freenation.com/

Бесплатные сepвepы Usenet

news.corvis.ru

news.infotecs.ru

news.enet.ru

news.portal.ru

ddt.demos.su

news.beta.kz

news.caravan.ru

news.com2com.ru

news.reference.com

news.maxnet.ru

news.lucky.net

news2.new-york.net

news.comtel.ru

news.solaris.ru

news.leivo.ru

info.tsu.ru

Совершенно бесплатные русскоязычные доски объявлений

http://www.copris.com/pinboard/WIN/Default.htm

http://kulichki.rambler.ru/baraholka/barrazn.html

http://web.megaplus.ru/guestbook.html

http://next.hypermart.net/wwwboard1/book1.html

http://tt.mbt.ru/

http://www.yinvest.com/bboard/r9.phtml

http://www.trader.ru/index1.htm

http://www.vshop.ru/messages/search.pyhtml

http://www.serve.com/andrey/russian/ad/add.cgi

http://www.rikon.com/guestbook/guestbook.html

http://bbs.trifle.net/

http://www.intercom.ru:8101/cgi-bin/mag/misc

http://www.ase.ee/board/board.html

http://www.aha.ru/~stream_d/wwwboard/wwwboard.html

http://apps.vantagenet.com/aforums/

http://inter.net.ru:8080/faq.html#anons

http://www.israland.com/do/index.html

http://www.mezen.com/Advert

http://pirit.sibtel.ru/cgi-bin/board.cgi

http://www.tomsk.net/bboard/desk.htm

http://www.saransk.sitek.net/win/note/default.htm

http://194.186.81.132/raid/owa/mamba.g_begin

http://aurinko.karelia.ru

http://www.kazakcom.ic.ru/1advert.htm

http://www.bboard.nsk.su/notice.htm

http://www.orc.ru/~omen/OBJS.HTM

http://www.skiftel.ru/cgi-bin/board.cgi

http://mir.glasnet.ru/cgi-bin/adv.cgi

http://www.animals.ru/baraholka

http://www.labas.cl.spb.ru

http://bbs.trifle.net

http://www.mtm.msk.ru/bin/default.asp

http://venus.beseen.com/boardroom/l/17286

http://www.virtualpages.ru

http://www.nalogi.da.ru

http://foryou.hypermart.net/wwwboard/wwwboard.html

http://www.fbanking.com/bbs

http://www.infotecs.ru/doska

http://www.stroikom.ural.ru/trade/tradeframe.html

http://www.fido7.com/wmclub/forum/

http://www.orc.ru/~alateie/b.htm

http://forum.centre.ru

http://addon.hypermart.net/russian/board/

http://users.rosweb.ru:777/dvs/freedosk.htm

http://www.goods.ru/_-0/mob/

http://www.triza.ru/cgi-bin-triza/board/triza.ru

Список использованной литературы

10 Minute Guide to the Internet & World Wide Web

Grimes, Galen

Access the Internet

Peal, David

Accountant's Guide to the Internet

Cohen, Eric E.

Activities for the Internet: Introductory Course

Perkins

Advertising on the Internet

Barrett, Neil

Big Basics Book of the Internet

Habraken, Joe

Building an Internet

Evans, Tim


С чего начать?

Во-первых. Сразу хочу предупредить, что я не супер-мупер

профессионал, а скажем так, продвинутый юзер.

Итак.

Часть 1.

Подготовка к установке системы.

Сначала давайте определим, а нужно ли вам вообще ставить Windows 2000.

Ставить стоит, если:

· Вы работаете под управлением Windows 9x и у вас слишком часто происходят сбои, замедления работы и необъяснимые конфликты.

· Вам нужна более надежная защита на входе в систему и при доступе к файлам, чем имеющаяся в Windows 9x.

· Вы намучились с Windows NT 4.0 на портативном ПК.

· Вы работаете с NT 4.0 или Windows 95 на настольном компьютере с DVD-, USB- или другими устройствами, которые эти операционные системы не поддерживают или поддерживают плохо.

· У вас самая ранняя версия Windows 95 (без поддержки USB и без FAT32), и вы подумываете о переходе на Windows 98, но хотели бы получить больше возможностей.

Устанавливать Windows 200 не стоит, если:

· У вашего ПК меньше 64 Мбайт памяти или слишком медленный процессор (для комфортной работы необходим хотя бы Pentium II).

· Windows 2000 не поддерживает определенные ключевые программы или устройства, с которыми вы сейчас работаете на своей машине.

· Вы удовлетворены стабильностью и защищенностью Windows 9x, а компьютер используете в основном для игр и других «домашних» целей. В таком случае вам, возможно, лучше подождать версии Millennium.

· Изготовитель вашего ПК не обеспечивает необходимую для установки Windows 2000 модернизацию BIOS.

Перед установкой нам потребуется, собственно говоря, сам дистрибутив Windows 2000 Professional. Они бывают всякие разные. Большинство дистрибутивов, находящихся на пиратских дисках – это "русифицированные" Бета-версии, которые некоторое время проработают нормально, но затем начнутся проблемы. Поэтому будьте осторожны. В "нормальном" дистрибутиве уже "зашит" Service Pack 1. Можно попробовать обратить внимание на серийный номер. Например, такой - DDTPV-TXMX7-BBGJ9-WGY8K-B9GHM, но всё-таки, какой это дистрибутив – вы наверняка узнаете только после установки. Делается это следующим образом «мой компьютер – > свойства» - и если там содержится следующая информация: "Microsoft Windows 2000 5.00.2195 Service Pack 1" – значит это то что, надо. Главным здесь является билд - 2195. Если после установки вы обнаружите отличную от этой информацию, значит у вас в лучшем случае нормальная рабочая версия, но без Service Pack, а в худшем случае – именно бета-версия.

Чем плоха бета-версия? Во-первых, это не окончательный релиз. Во-вторых, через 90 дней, она обычно прекращает нормально функционировать. И, в-третьих, она вся сплошь косяченная. Кому-то повезёт и на его машине она будет работать нормально, а кто-то будет долго мучаться, и грешить на «сырость и стрёмность» продуктов от «Мелко-мягкий».

Что касается того, какой дистрибутив лучше, то я рекомендую именно тот, который с «вшитым» Service Pack (SP). По моим личным наблюдениям, после установки дистрибутива БЕЗ «вшитого» SP в журнале системы обычно всегда есть 2-3 некритичные ошибки, от которых не всегда легко избавиться. После же установки системы с «вшитым» SP, ошибок в журнале вообще нет. Да и по общим наблюдениям работы Windows NT 4, чем больше на неё ставишь заплаток, тем не стабильней работает система.

Перепишите всю информацию о вашей машине - что у вас за видеокарта, аудиокарта и т.д. и проверьте - есть ли у вас на всё это драйвера под Windows 2000. Конечно, многое оборудование при установке определит система и поставит более подходящие (по крайней мере по мнению Microsoft) драйвера, но - на бога надейся - а сам не плошай. А ещё лучше – проверить на совместимость ваше оборудование одним из следующих способов:

1) запустите установочный файл Windows 2000 со следующим ключом - winnt32.exe /checkupgradeonly.

2) посмотреть на сайте http://www.microsoft.com/hcl/ , есть ли ваше «железо» в списке совместимого с Windows 2000.

Но первая возможность есть только если у вас уже установлены Win95/98/NT.

Теперь переходим к самому главному - резервному копированию данных. Да-да. К той самой тягомотине, которую многие не любят делать, но однажды попав в неприятную ситуацию - становятся заядлыми "архиваторщиками". Итак. Проверяем - сохранены ли у нас все рабочие файлы, почтовые базы

данных, адресные книги, настройки почтовой программы...

Для тех, кто работает в корпоративной сети или использует специальные настройки для подключения к интернет - обязательно выпишите все ваши данные из настроек сети: IP адрес, маска подсети, имя домена (если таковой есть), имя компьютера, посмотрите по каким протоколам в сети вы работаете... В общем, лучше располагать максимум информацией о вашем компьютере, пусть даже избыточной, чем потом оказаться на бобах и в муках вспоминать – что же здесь должно быть прописано и каким образом вы это используете.

Не плохо было бы посетить сайт производителя вашей материнской платы и скачать последние обновления для BIOS. Это будет не лишним даже если вы не будите устанавливать Windows 2000. Во-первых, обновив BIOS вы можете неожиданно обнаружить прирост в работе компьютера, во-вторых в новой версии BIOS могут быть реализованы новые возможности настройки системы, которые раньше вам были недоступны и в-третьих, данная рекомендация (обновить BIOS) – рекомендуется фирмой Microsoft перед установкой Windows 2000, а уж особенности их продукта они знают лучше всех нас вместе взятых.

НО! Постарайтесь обновить BIOS максимально безопасно. Если на компакт диске, поставляемом с материнской платой есть специальная программа для обновления BIOS лучше всего воспользоваться ей. Если вы сделаете что-то неправильно, то в лучшем случае у вас будет большой головняк по перепрошивке BIOS, а в худшем - придётся покупать новую материнскую плату.

Теперь переходим к жёсткому диску. Во-первых, решите для себя - сколько систем у вас будет стоять на компьютере - только Windows 2000 или ещё Windows 95/98/Me или какой-нибудь там Unix-Linux. Если будет ещё одна операционная система, кроме Windows 2000 - сначала нужно установить Windows 95/98/Me, а уж затем - Windows 2000. Это не единственный вариант, но на мой взгляд наиболее безпроблемный и не требующий установки программ от сторонних разработчиков (например Power Quest Boot и т.д. и т.п.).

Так как большинство игр всё-таки более благосклонны к Windows 9X, чем к системам на базе NT будем исходить из того, что у вас на компьютере будут сосуществовать две системы. Если у вас два жёстких диска - вы счастливчик, если же один - нужно всё хорошенько продумать. Диск С - автоматом "забивается" под Windows 95/98/ME. Связанно это с тем, что данные системы ну очень хотят, чтобы их ставили в основной загрузочный раздел и кроме диска C ни каких других не признают (опять же, про решения сторонних разработчиков здесь мы речь вести не будем). Что же до Windows 2000 – она более всеядна и не требует для себя определённого размещения. Главное – что бы свободного места на данном разделе было достаточно для нормального существования системы. Под диск С: вполне достаточно 2 Гбайт (я сужу по своим потребностям). Но не меньше 1 Гбайта. Один логический диск примерно на 3-5 Гбайт - под Windows 2000. И ещё настоятельно советую один логический диск под документы.

Лично у меня сделано так:

Диск C - Windows 98 - 2.5 Гбайта

Диск D - Pagefile for Windows 2000 (под файл подкачки и временные файлы для Windows 2000) - 900 Мбайт

Диск E - Windows 2000 - 3,7 Гигабайт

Остальное пространство - под документы.

Теперь нужно определится с файловой системой - NTFS или FAT32? Windows 2000 работает с любой из этих файловых систем, а вот WIN 98/98/ME не могут работать с NTFS. NTFS надёжнее и быстрее. Поэтому

думайте сами. Я бы посоветовал логический раздел диска, на который будет установлена Windows 2000 сделать NTFS, а дальше - уже на ваше усмотрение. Опять же, если говорить про файл подкачки Windows 2000, то по моему сугубо личному мнению, на файловой системе NTFS он работает быстрее, тем более, если размер кластера = 32 Кбайтам. Но всё-таки решать вам.

Все манипуляции с жёстким диском, тем более с тем, который находиться в работе и содержит важную информацию (вы же сделали резервную копию всех своих данных, не так ли?), проще и комфортнее сделать утилитой Partition Magic. Только будьте осторожны - раньше времени не переводите диски в NTFS, тем

более, если там есть данные. Это необратимый процесс. После установки Windows 2000 внимательно посмотрите на версию Partition Magic. С новой файловой системой NTFS, которая используется в Windows 2000 работает только версия 5 и выше (проверено на горьком опыте). Да и при установке Windows 2000 скажет вам, что раздел с файловой системой NTFS не читабелен и предложит единственный вариант – отформатировать его. Перевести файловую систему в NTFS всегда можно будет и после установки Windows 2000.

И в завершении - не забудьте проверить диски на ошибки. На всякий случай...

Ну вот в принципе и всё. Будем считать, что вы полностью готовы к тому, чтобы установить Windows 2000.

Часть 2.

Ставим систему.

Перед установкой системы рекомендую сделать загрузочные дискетки. Делается это следующим способом: на CD-ROM в папке BOOTDISK в зависимости от того, работаете вы в DOS или в Windows, запускаем файл makeboot.exe или makebt32.exe.

Установить Windows 2000 можно несколькими способами: с компакт-диска, с жёсткого диска, с сетевого ресурса. Я обычно люблю копировать дистрибутив на диск, а уж с него плясать. Но... это личные предпочтения каждого...

Непосредственно сама установка бывает двух типов - из под DOS-а, либо из под Windows. В первом случае установочным файлом является winnt.exe, во втором - winnt32.exe

winnt.exe можно запустить со следующими параметрами: /s /t /u /r /rx /e /a

- /s[:исходный путь] - указать путь к дистрибутивным файлам. Данный ключ используют в основном при запуске установки из сети. Например \\server\i386

- /t[:путь] - указать путь для временных файлов. Если не выбрано - система автоматом копирует на любой подходящий диск (обычно C:)

- /u[:файл ответов] - для автоматической установки с использованием файла ответов. Требует ключ /s

- /r[:папка] - указать необязательную папку для установки.

- /rx[:папка] - указать необязательную папку для копирования установочных файлов, после установки будет стёрта

- /e:команда - указать команду, которая будет выполнена автоматически, после установки.

- /a - активизировать специальные опции для людей с ограниченными физическими возможностями.

winnt32.exe: /s /tempdrive /unattend /cmd /chekupgradeonly /cmdcons /makelocalsourse /noreboot

- /s[:исходный путь] - указать путь к дистрибутивным файлам. Данный ключ используют в основном при запуске установки из сети. Например, \\server\i386

- /tempdrive:[диск] - указать, куда размещать временные файлы установки

- /unattend - выполнить обновление предыдущей версии Windows в автоматическом режиме. Все пользовательские настройки будут взяты из текущей системы. Вмешательства в процесс установки не требуется.

- /cmd:команда - указать команду, которая будет выполнена автоматически, перед началом завершающей стадии установки (после второй перезагрузки, но до завершения работы программы установки).

- /chekupgradeonly - проверка компьютера на совместимость "железа" с Windows 2000

- /cmdcons - установить консоль восстановления (Recovery Console). Данная команда может выполнится только после того, как будет установлена Windows 2000

- /makelocalsourse - указывает на необходимость скопировать все дистрибутивные файлы на локальный жёсткий диск

- /noreboot - не перезагружать компьютер после завершения процедуры копирования файлов.

Теперь, в зависимости от того, из под какой системы мы устанавливает систему, запускаем winnt.exe или winnt32.exe с требуемыми параметрами. Или без каких либо параметров, что более типично.

Если установка происходит с помощью winnt32.exe на экране появится диалоговое окно, которое предложит обновить данную систему до Win2000 или скажет о невозможности этого. Лучшим вариантом, на мой взгляд - отказаться от обновления и установить новую копию. Имейте под рукой серийный номер Win 2000.

После того, как вы введёте серийный номер - выйдет диалоговое в котором предлагается выбрать дополнительные параметры. Я рекомендую в разделе копирования файлов поставить галочки на следующих пунктах:

- скопировать установочные файлы на жёсткий диск

- выбрать раздел, в который будет установлена система.

После процедуры копирования программа предложит произвести перезагрузку - ответьте утвердительно.

Установка с помощью winnt.exe выглядит несколько иначе.

Программа установки предложит вам указать точный путь к дистрибутивным файлам Windows 2000. Если этот путь указан правильно, и на жестком диске имеется достаточный объем свободного пространства, то программа установки скопирует часть дистрибутивных файлов на локальный диск.

На этом разница заканчивается.

Что в первом, что во втором случае после перезагрузки системы вы обнаружите, что программа установки установила в систему мультизагрузчик. После стандартной проверки оборудования компьютера (так называемая процедура POST) до запуска операционной системы вы увидите примерно следующее:

Выберите требуемую операционную систему:

1. Windows 2000 Professional Setup

2. Microsoft Windows

Загрузка подсвеченной системы начнётся через 2 секунд.

Вряд ли вы успеете выбрать какой-либо другой пункт, кроме первого. Это требует некоторой сноровки и хорошей реакции, которая у вас наверняка появится, но чуть позже :0)

После перезагрузки система загружается уже под управлением Windows 2000, которая принимает управление и выполняет распознавание установленных на компьютере аппаратных средств. На экране при этом появляется сообщение:

Программа установки проверяет конфигурацию оборудования...

Последующие экраны, выводимые программой установки, чрезвычайно сильно напоминают текстовый режим MS-DOS. Тем не менее, установка уже выполняется под управлением ядра Windows 2000, хотя и в текстовом режиме. Если установка происходила из DOS, программа установки отображает на экране лицензионное соглашение, которое нужно пролистать и нажать F8, чтобы согласиться с ним. Вы конечно можете с ним не соглашаться, но в таком случае Windows 2000 обидеться и не станет устанавливаться :0).

Далее программа установки выполняет поиск уже существующих на компьютере инсталляций Windows 2000. Если такие версии будут обнаружены, программа установки предложит пользователю следующие варианты действий:

- восстановить существующую инсталляцию (если она повреждена)

- выполнить новую инсталляцию

- завершить работу без установки Windows 2000.

Если установленные версии Windows 2000 на компьютере не обнаружены, или пользователь выбрал опцию новой инсталляции, то программа установки отобразит список разделов, уже существующих на жестком диске. Пользователю будет предложено выбрать раздел для инсталляции из числа уже существующих, удалить один из существующих разделов, чтобы создать новые разделы на основе освободившегося пространства, или (при наличии достаточного объема свободного пространства, не принадлежащего ни одному разделу) создать новый раздел. Если выбран один из существующих разделов, программа установки предложит на выбор пользователя следующие варианты:

- отформатировать раздел с использованием файловой системы FAT

- отформатировать раздел с использованием файловой системы NTFS

- преобразовать существующую файловую систему к формату NTFS

- оставить существующую файловую систему без изменений

Вновь создаваемые разделы подлежат обязательному форматированию, и в этом случае пользователь имеет возможность выбора файловой системы. Если выбрана опция преобразования раздела к формату NTFS, то фактическое преобразование будет выполнено при следующей перезагрузке системы.

Лучше всего, с моей точки зрения форматнуть раздел сразу в NTFS. Дальше программа установки выполняет проверку имеющихся в системе дисков, что, как правило, не занимает много времени. По завершении проверки дисков программа установки копирует на жесткий диск остальные файлы, которые потребуются для завершающей, графической фазы инсталляции. Этот этап достаточно продолжителен. Копирование файлов производится выборочно, в соответствии с данными, полученными при распознавании аппаратных средств компьютера. По завершении копирования конфигурация инициализируется и компьютер перезагружается.

Теперь настала пора установки в графическом режиме.

Обратите внимание, что на данном этапе вы уже имеете установленную, но еще не конфигурированную копию Windows 2000 Professional. Графическая фаза инсталляции завершает этот процесс, после чего на компьютере будет установлена полнофункциональная версия операционной системы.

После загрузки графической оболочки, Windows запускает Мастера установки Windows 2000 (Windows 2000 Setup Wizard). Работа мастера установки продолжается довольно долго. Мастер установки Windows 2000 предпринимает попытки распознать все аппаратные компоненты, имеющиеся на компьютере, включая СОМ-порты, последовательные порты, джойстик, клавиатуру, мышь, и т.д… После обнаружения всех возможных устройств, на экране появится диалоговое окно Язык и стандарты (Regional Settings), в котором пользователю предоставляется возможность установки локальных параметров, поддержки дополнительных языков и раскладки клавиатуры. ТОЛЬКО НЕ ПЕРЕПУТАЙТЕ УСТАНОВКУ ПАРАМЕТРОВ ДЛЯ КЛАВИАТУРЫ И УСТАНОВКУ ЯЗЫКА!!! Я очень люблю по умолчанию ставить раскладку клавы на английский язык (что и вам советую) и однажды по запарке установил язык на английский, вместо раскладки. Как результат – переустановка Windows 2000 с самого начала.

Далее программа установки предложит пользователю идентифицировать свою копию программного обеспечения Windows 2000, выведя диалоговое окно Настройка принадлежности программ (Personalize Software), в котором пользователь должен заполнить поля Имя (Name) (обязательно) и Организация (Organization) (по желанию), указав в них свое имя и организацию, в которой он работает. Информация, введенная в этом окне, будет затем предоставляться операционной системой запрашивающим ее прикладным программам.

Затем пользователю предлагается указать имя компьютера, а также ввести и подтвердить пароль администратора. Обратите внимание, эта часть является едва ли не самой важной во всей графической фазе инсталляции. ОБЯЗАТЕЛЬНО ЗАПОМНИТЕ, ПРИ КАКОЙ РАСКЛАДКИ КЛАВИАТУРЫ ВЫ ВВЕЛИ ПАРОЛЬ.

ОБРАТИТЕ ВНИМАНИЕ НА РЕЖИМ CAPS LOCK. Если вы забудете этот пароль - вы не сможете войти в систему и придётся всё устанавливать заново. Пользователь Администратор (Administrator) имеет доступ ко всем возможностям и функциям операционной системы, поэтому постарайтесь ввести не слишком простой и очевидный пароль. Помимо этого, Microsoft не рекомендует пользователям выполнять повседневную работу, будучи зарегистрированными, в системе от имени администратора, поскольку это создает брешь в системе безопасности. Кроме пароля администратора, вам будет предложено ввести имя для данного компьютера (и в качестве образца будет предложено имя, случайным образом сгенерированное на основе ранее введенных вами данных). Можно согласиться с предложенным вариантом или ввести собственный (тем более что впоследствии имя компьютера можно изменить).

При установке Windows 2000 Professional существует одна особенность: программа установки не предоставляет возможности выбора стандартных и необязательных компонентов системы (игры, мультимедиа и т. д.), а устанавливает их все. Хотя возможность выбора имеется при установке Windows NT 4.0, Windows 95, Windows 98 (включая Windows 98 Second Edition) и Windows 2000 Server.

Далее появляется окно Дата и время (Date and Time), в котором можно уточнить дату, время и параметры часового пояса (местного времени). Информацию о дате и времени система получает от системной BIOS, поэтому, как правило, эти данные точны.

Наконец, когда все эти параметры будут указаны, начинается установка сетевых служб, которая по сравнению с предыдущими версиями Windows NT существенно упрощена. Пользователю на выбор предлагаются два варианта установки сети: Типичные параметры (Typical) и Особые параметры (Custom). В случае типичных параметров мастер устанавливает Клиента для сетей Microsoft (Client for Microsoft Networks), Службу доступа к файлам и принтерам сетей Microsoft (опция File and Printer Sharing), и Протокол Интернета (TCP/IP) (опция Internet Protocol) со стандартными параметрами настройки (при которых IP-адрес и другие параметры задает сервер DHCP). В случае, если выбраны особые параметры, пользователь имеет возможность выбрать устанавливаемые сетевые службы и протоколы, и задать их параметры.

По окончании установки сетевых параметров необходимо указать, будет ли устанавливаемый компьютер принадлежать к рабочей группе или домену. Ограничимся той же не слишком информативной рекомендацией, которая давалась и для установки Windows NT 4.0: если вы затрудняетесь в выборе, выберите рабочую группу, а если ваш компьютер подключен к локальной сети предприятия - обратитесь к системному администратору.

С этим моментом у меня был косяк. У меня на работе сеть из 10 машин и сервера и тем более домена нет и в помине. Для работы в сетевом BEST-е это не страшно. Так вот. После того, как я прописал параметры TCP и установка была закончена моя машина по умолчанию подцеплялась к группе "Worgroup". После того, как я менял с помощью сетевой идентификации имя рабочей группы, машина просилась перезагрузится. И

после этого при попытке обзора соседних компьютеров надолго зависала, затем плевалась фразой "исчерпан лимит подключения к Workgroup" и на этом всё успокаивалось. Потом выяснилось, что моя машина цеплялась

к двум сетям - к той, на которую я менял Workgroup и к энтой самой Workgroup. После 30 минутных мучений я снёс на фиг систему, переустановил, причём протокол TCP/IP дисаблил. Потом настраивал сетевую идентификацию, и потом уже подцеплял TCP/IP. Если кто знает, как это лечить - поделитесь рецептом.

На этом интерактивная часть графической фазы установки завершается. Мастер установки Windows 2000 начинает копирование файлов и выполнение "завершающих операций". Эти заключительные операции состоят в установке компонентов меню Пуск (Start), регистрации установленных компонентов операционной системы, сохранении установленных параметров настройки и удалении временных файлов, созданных в процессе инсталляции. Процедура довольно продолжительная, протекает она в автоматическом режиме, не требующем никакого вмешательства, и полчаса или минут 40 свободного времени вам обеспечено.

После этого шага мастер установки предложит извлечь компакт-диск из устройства CD-ROM и нажать кнопку Готово (Finish), чтобы перезагрузить систему. Можно поздравить себя с успешным завершением процедуры инсталляции и перезагрузиться. Тем не менее, это еще не все. При первой загрузке Windows 2000 Professional пользователи должны выполнить еще один дополнительный шаг, который не повторится больше никогда: запустится Мастер сетевой идентификации (Network Identification Wizard), который предоставляет пользователю возможность создать новую учетную запись пользователя, отличную от учетной записи Администратор. Будет ли загружаться система автоматически, или будет появляться окно, с приглашением ввести имя пользователя и пароль - будет зависеть от установки флажка "Требовать ввода имени пользователя и пароля" или "Всегда использовать следующее имя пользователя". В последствии добавить новых пользователей, а так же изменить права у уже созданных учётных записей можно будет через стандартные средства администрирования.

Вот и всё. Если всё прошло хорошо - вы получили нормально работающую систему.

Часть 3.

Файл boot.ini и другие особенности при запуске Windows2000

Процесс загрузки системы можно разделить на несколько этапов:

1. Самотестирование машины при включении. Этот процесс не зависит от установленной на компьютере системы. Происходит тестирование "железа" стандартными средствами BIOS. Запускается так называемая утилита POST (Power-On Self-Test). Кстати, один "чайник" спрашивал меня - как работать с BIOS и постоянно

путался в понятиях - DOS и BIOS. С трудом получилось втолковать, что в BIOS не работают, её можно только настроить. :0).

Если у вас начались проблемы на этом этапе, то это значит, что с вашим железом не всё в порядки. Берём отвёртку и...

2. Инициализация при запуске. Это уже ближе к запуску Windows :0).

Для нормальной загрузки ОС требуются следующие файлы:

  • NTDLR - находится в корневом каталоге загрузочного диска

  • Boot.ini - находится в корневом каталоге загрузочного диска

  • Bootsect.dos (Для систем с двойной загрузкой, в которой в качестве альтернативной ОС используются DOS, Windows 3.1x или Windows 9x) - находится в корневом каталоге загрузочного диска

  • Ntdetect.com - находится в корневом каталоге загрузочного диска

  • Ntbootdd.sys (если в машине стоит SCSI) - находится в корневом каталоге загрузочного диска

  • Ntoskrnl.exe - %SystemRoot%\System32 (где %SystemRoot% - путь до каталога с установленной Windows 2000 (например E:\WINNT))

  • Hal.dll - %SystemRoot%\System32

  • Раздел реестра SYSTEM - %SystemRoot%\System32\Config

  • Драйверы устройств - %SystemRoot%\System32\Drivers

После успешного окончания процесса POST системная BIOS ищет и загружает в память загрузочный сектор (boot sector), инструкции которого затем загружаются в файл NTLDR. Для запуска огромное значение имеет первый сектор жёсткого диска, который содержит главную загрузочную запись (Master Boot Record, MBR) и таблицу разделов (partition table).

Системная BIOS считывает главную загрузочную запись и загружает ее в память, а затем передаёт ей управление. Код, содержащийся в главной загрузочной записи, сканирует таблицу разделов в поисках системного раздела и найдя его загружает в память его нулевой сектор и исполняет код, содержащийся в этом секторе. В нулевом секторе находится загрузочный код операционной системы, который и осуществляет запуск операционной системы.

Загрузочный сектор раздела системы Windows 2000 отвечает за выполнение следующих действий:

  • Распознавание используемой файловой системы и её применение для поиска загрузчика операционной системы (NTLDR) в корневом каталоге системного диска.

  • Нахождение загрузчика операционной системы NTLDR и его загрузка в память

  • Начало исполнения кода самозагрузки.

3. Работа загрузчика (Boot Loader Process)

NTLDR управляет процессами выбора операционной системы и распознавания аппаратных средств перед инициализацией ядра Windows 2000. Загрузчик должен находится в корневом каталоге системного диска.

В начале работы NTLDR очищает экран и выполняет следующие действия:

  • Переключает процессор в режим 32-разрядной модели памяти с прямой адресацией.

  • Запускает соответствующую минифайловую систему. Код, предназначенный для доступа к файлом на томах FAT, FAT32 и NTFS, встроен в NTFS. Этот код позволяет загрузчику читать файлы, получать доступ к ним и выполнять копирование.

  • Читает файл Boot.ini, расположенный в корневом каталоге системного диска и отображает на экран меню для выбора загружаемой операционной системы. Если выбирается ОС отличная от Windows2000, то считывает файл Bootsect.dos и передаёт ему управление. Другая операционка стартует как обычно, так как в этом файле (Bootsect.dos) содержится копия загрузочного сектора раздела, который находился в основном разделе до инсталляции Windows 2000. Теперь понятно, почему при мультиситемном варианте - Windows 2000 нужно ставить последней? :0)

  • Если выбрана Win2000, то выполняется Ntdetect.com, чтобы собрать информацию о физических устройствах, подключённых на ДАННЫЙ момент к компьютеру (отсюда косяк с модемом - если не включен, то не будет опознан).

  • Загружает и запускает ядро ОС Win2000 Ntoskrnl.exe и передаёт ему информацию, собранную Ntdetect.com

Настало время поговорить о файле BOOT.INI

Выглядит он например вот так:

[boot loader]

timeout=3

default=multi(0)disk(0)rdisk(0)partition(3)\WINNT

[operating systems]

multi(0)disk(0)rdisk(0)partition(3)\WINNT="Microsoft Windows 2000 Professional RUS" /fastdetect

C:\="Microsoft Windows"

C:\CMDCONS\BOOTSECT.DAT="Консоль восстановления Microsoft Windows 2000" /cmdcons

Как и для всех файлов .ini данный файл поделён на логические разделы: [boot loader] и [operating systems].

В разделе [boot loader] содержится информация о величине интервала ожидания(тайм-аута) и указатель на выбираемую по умолчанию операционную систему. Тайм-аут определяет промежуток времени (в секундах), в течении которого пользователи могут выбрать один из пунктов экранного меню начальной загрузки. По умолчанию на выбор отводится 30 секунд, по истечении которого загружается операционная система по умолчанию. Можно изменить умолчания либо редактированием файла, либо следующим способом: щёлкнуть правой кнопкой на значке "мой компьютер", выбрать закладку "дополнительно" и перейти в раздел "загрузка и восстановление". Windows 2000, в отличии от Windows NT 4 не понимает параметр

timeout=-1, используемый обычно для ожидания системой выбора операционной системы пользователем. И после перезагрузки автоматически меняет его на предыдущее значение.

Раздел [operating system] содержит путь или пути к операционной системе или системам, которые установлены на данной машине. В кавычки заключён текст, который будет отображаться при выборе

системы. Его можно безболезненно править. Информация о местоположении операционной системы представлена в формате, определённом спецификацией Advanced RISC Computing (ARC). Windows 2000 распознаёт три структуры пути ARC: мультисинтаксическую, с SCSI-синтаксисом и с сигнатурным синтаксисом.

Мультисинтаксис

На машинах с жестким диском IDE в файле boot.ini обычно используется мультисинтаксис. Использование мультисинтаксиса означает, что загрузка системных файлов Windows 2000 происходит под управлением BIOS. Операционная система вызывает прерывания INT 13 BIOS, чтобы отыскать диск, на котором находится ntoskrnl.exe и другие файлы, необходимые для загрузки системы.

Строка мультисинтаксиса выглядит следующим образом:

multi(<A>)disk(<B>)rdisk(<C>)partition(<D>) ,где:

A - Порядковый номер загрузочного адаптера. Первый адаптер, который обычно играет роль загрузочного, имеет номер 0.

B - содержит информацию о характеристиках диска. В мультисинтаксической строке значение этой переменной всегда 0, так как в ней используется вызов INT 13, а не метод самоопределения.

C - порядковый номер, указывающий диск, подключённый к адаптеру. Его значение может быть от 0 до 3, в зависимости от числа, связанного с адаптером накопителей.

D - номер раздела. Первый возможный номер 1 (в отличие от адаптеров и накопителей, нумерация которых начинается с 0).

Т.е., данная строчка multi(0)disk(0)rdisk(0)partition(3) расшифровывается как - первый адаптер IDE, с вызовом через INT 13, 1 диск, подключённый к данному адаптеру и 3 раздел, в который установлена Windows 2000.

Синтаксис для SCSI

Если загрузка происходит с SCSI-устройства, то обычно используется синтаксис SCSI (хотя можно использовать и мультисинтаксис, при условии, что устройство SCSI настроено на использование прерывания INT 13). Данный синтаксис указывает, что для доступа к загрузочному разделу следует использовать драйвер контроллера, а не системный BIOS или вызовы INT 13. Драйвер устройства всегда называется ntbootdd.sys и расположен в корневом каталоге системного раздела. Процедура установки Windows 2000 Setup создаёт ntbootdd.sys, копируя специальный драйвер SCSI-устройства на жёсткий диск. Затем Windows 2000 переименовывает файл в ntbootdd.sys. Обычно Windows 2000 копирует драйвер со своего установочного компакт-диска, но может скопировать и переименовать драйвер, предоставленный изготовителем устройства.

Синтаксис следующий:

scsi(<A>)disk(<B>)rdisk(<C>)partition(<D>) , где

A - порядковый номер адаптера, связанного с драйвером ntbootdd.sys

B - SCSI ID для целевого диска на этом адаптере

С - логический номер устройства (LUN) SCSI, содержащего загрузочный раздел.

D - номер раздела.

С данным типом устройств мне пока работать не доводилось, поэтому ни чего дополнительно сказать не могу.

ПАРАМЕТРЫ В ФАЙЛЕ BOOT.INI

Во-первых, данный файл является "суперскрытым". Данное понятие впервые было введено в Windows 2000. Это означает, что он является системным и скрытым и имеет дополнительный "скрывающий" параметр в Проводнике. Чтобы отыскать этот файл, требуется в настройках проводника – сервис - свойства папки - вид - убрать галочку с параметра "скрывать защищённые системные файлы" и переместить переключатель на "показывать скрытые и системные файлы".

После проведения данной процедуры снимите с данного файла атрибут "Только чтение". На всякий случай сделайте резервную копию. И только после этого можно приступать к его редактированию.

Допустимы следующие параметры:

/FASTDETECT* - Новый параметр, появившийся в Windows 2000. Если на компьютере установлены ОС Windows NT 4.0 и Windows 2000, то в процессе загрузки обеих операционных систем будет использоваться версия Ntdetect.com из состава Windows 2000. На этапе распознавания аппаратных средств в Windows 2000 некоторые устройства распознаются драйверами Plug and Play, в то время как Windows NT 4.0, вследствие ограниченности поддержки Plug and Play, выполняет распознавание только с помощью Ntdetect. Если параметр /FASTDETECT указан, то Ntdetect не пытается распознавать такие устройства. Если нет, то Ntdetect будет выполнять энумерацию аппаратных средств в полном объеме. Таким образом, если вы имеете систему с двойной загрузкой, где на одном компьютере установлены Windows NT 4.0 и Windows 2000, этот переключатель должен быть установлен для строк файла Boot.ini, запускающих Windows 2000, и пропущен для строк, осуществляющих запуск Windows NT 4.0. Данный параметр можно отключить, что ускорит загрузку, НО МОГУТ ВОЗНИКНУТЬ ПРОБЛЕМЫ ПРИ ЗАГРУЗКЕ, ТАК ЧТО СОВЕТУЮ НИ ЧЕГО НЕ ТРОГАТЬ.

/BASEVIDEO - Компьютер загружается с использованием стандартного драйвера VGA. Если вы инсталлируете новый драйвер видеоадаптера, но он работает некорректно, выбор режима загрузки Windows 2000 с этим параметром позволит загрузить компьютер и заменить драйвер

/BAUDRATE - Указывает скорость в бодах, которая будет использоваться для отладки. Если вы не установите скорость в бодах, то по умолчанию будет принята скорость 9600 (если к компьютеру подключен модем), и 19200- для нуль-модемного кабеля. Параметр оказывает побочный эффект, устанавливая также параметр /DEBUG вне зависимости от того, используете вы /DEBUG или нет

/BOOTLOG* - Если указан этот параметр, то Windows 2000 будет записывать протокол загрузки в файл %Systemfloor%\Ntbtlog.txt. Этот файл указывает, какие драйверы были загружены, и какие остались незагруженными

/CRASHDEBUG - Отладчик загружается при запуске Windows 2000, но остается в неактивном состоянии

до тех пор, пока не произойдет ошибка ядра. Этот режим особенно полезен, если в процессе вашей работы имеют место редкие непредсказуемые ошибки ядра

/DEBUG - Отладчик загружается при запуске Windows 2000 и может активизироваться в любой момент хостом отладчика, подключенным к компьютеру. Этот режим рекомендуется использовать при отладке регулярно возникающих проблем

/DEBUGPORT=COMx - Указывает СОМ-порт для использования при отладке, где х - номер коммуникационного порта, который вы собираетесь использовать. Как и параметр /BAUDRATE, этот параметр принудительно переводит компьютер в отладочный режим

/МАХМЕМ - Определяет максимальный объем памяти (RAM), доступный для использования Windows 2000.

Этот параметр полезен, если вы подозреваете повреждение чипа памяти

/NODEBUG - При использовании этого параметра отладочная информация на экран не выводится

/NOGUIBOOT* - Новый параметр Windows 2000. Если он указан, то драйвер VGA, выполняющий вывод графической заставки в процессе загрузки Windows 2000, не инициализируется. Поскольку этот драйвер используется не только для отображения графической заставки, но и для отображения "синего экрана" (BSOD, Blue Screen of Death), то его блокировка приведет также к блокировке этой диагностической возможности

/NOSERIALMICE=[COMx,y,z,...] - Блокирует определение последовательной мыши на указанных СОМ-портах. Этот режим рекомендуется использовать, если вы имеете другой компонент (не мышь), подключенный к последовательному порту в процессе запуска. Если использовать параметр /NOSERIALMICE без указания СОМ-порта, то определение последовательной мыши будет блокировано для всех СОМ-портов

/SAFEBOOT* - Новый параметр, появившийся в Windows 2000. Стоит отметить, что практически никогда нет необходимости устанавливать его вручную, т. к. при нажатии клавиши <F8> загрузчик (NTLDR) автоматически использует его для выполнения загрузки в безопасном режиме (safe boot). Чтобы задать одну из опций безопасного режима загрузки, укажите двоеточие после этого параметра и задайте один из трех дополнительных переключателей: MINIMAL (опция Safe Mode), NETWORK (опция Safe Mode with Network) или DSREPAIR (опция Directory Service Repair).

/SOS - данный параметр используется для отображения на экране в процессе загрузки имён всех драйверов, загружаемых системой. Рекомендуется для выявления проблем при загрузке операционной системы.

Часть 4

Типичные проблемы, появляющиеся при и после установки Windows 2000 Pro

До появления экрана загрузчика (меню выбора системы, которую требуется загрузить):

  • Сразу после завершения фазы самотестирования (POST) компьютер "зависает"

  • Экран загрузчика не появляется.

  • На экране появляются сообщения об ошибках следующего типа:

v Missing operating system (Отсутствует операционная система)

v A disk read error occurred (Ошибка чтения диска)

v Insert a system diskette and restart the system (Вставьте системную дискету и перезагрузите систему)

v Invalid partition table (Неверная таблица разделов)

v Hard Disk Error (Ошибка жёсткого диска)

v Hard Disk Absent/Failed (Жёсткий диск отсутствует/отказ)

Вполне возможно, что при таком раскладе компьютер вообще не удастся запустить. Если вы предварительно отформатировали все разделы для использования файловой системы NTFS - применить утилиты MS-DOS для решения данных проблем вы не сможете. Советую под рукой держать загрузочные дискеты от Windows 2000.

Данный тип проблем может быть вызван следующими вещами:

1. Отсутствие системного раздела на жёстком диске.

Обычно возникает при неправильном конфигурировании только что купленного жёсткого диска либо при некорректном его форматировании. Поправить сию проблему можно с помощью утилиты FDISK.

2. Повреждена главная загрузочная запись.

Для чего она нужна?

а) Считывает таблицу разделов, расположенной в этом секторе диска

б) Определяет местоположение загрузочного сектора раздела

в) Загружает и выполняет код, расположенный в загрузочном секторе раздела.

Если код главной загрузочной записи оказывается не в состоянии выполнить сии задачи, появляется одно из сообщений:

v Missing operating system (Отсутствует операционная система)

v Invalid partition table (Неверная таблица разделов)

Для восстановления повреждённой главной загрузочной записи можно воспользоваться командной консолью восстановления (Recovery Console) Windows 2000. Делается это с помощью команды Fixmbr:

fixmbr [имя_устройства]

Параметр

имя_устройства

Устройство (диск), на которое требуется записать новую основную загрузочную запись. Для получения имени можно воспользоваться командой map. Имя устройства может выглядеть следующим образом:

\Device\HardDisk0.

Пример:

В следующем примере новая основная загрузочная запись записывается на указанное выше устройство.

fixmbr \Device\HardDisk0

Примечания:

Если имя устройства не указано, новая основная загрузочная запись будет записана на устройство загрузки, которое является диском, с которого была загружена основная система. Если обнаружена неправильная или нестандартная подпись таблицы разделов, выводится сообщение, запрашивающее подтверждение на запись. Если доступ к дискам осуществляется без сбоев, на подтверждение следует ответить отрицательно. Запись новой основной загрузочной записи в системный раздел может привести к повреждению таблиц разделов, в результате чего разделы могут стать недоступными.

Повреждение загрузочного сектора раздела обычно характеризуется "синим экраном" и STOP ошибкой следующего содержания:

INACCESSIBLE_BOOT_DEVICE.

либо машина "зависает" в процессе загрузки и экран остаётся пустым. Даже если очевидных грубых повреждений не наблюдается – загрузочный сектор раздела может работать неправильно.

Проблема может быть в том, что испорчен/повреждён файл NTLDR, либо повреждён загрузочный сектор. Для диагностики проблемы поступаем следующим способом: Пробуем переименовать файл NTLDR и запустить Windows 2000 с этого жёсткого диска. Если загрузочный сектор - в норме, а проблема в повреждённом файле загрузчика появится следующее сообщение:

Couldn't find NTLDR - если файл загрузчика находится в разделе NTFS

или

A kernel file is missing from the disk - если файл загрузчика NTLDR находится в разделе FAT.

Соответственно, требуется заменить повреждённый файл NTLDR на рабочий (либо с загрузочной дискеты, либо с рабочей машины)

Сразу предупреждаю, что файл NTLDR по умолчанию имеет атрибуты "скрытый", "системный" и "только чтение". Если он находится на разделе FAT - изменить атрибуты из под DOS-a можно с помощью команды attrib -s -h -r ntldr.

Если после замены файла NTLDR вы таких сообщений об ошибке не получите и машина всё равно не хочет грузиться, значит поврежден сам загрузочный раздел. Для устранения данной неприятности нужно загрузить консоль восстановления (т.е. снова начать установку Windows 2000 и после того, как процедура копирования установочных файлов на жёсткий диск будет окончена выбрать НЕ установку, А ВОССТАНОВЛЕНИЕ СИСТЕМЫ).

После того, как консоль будет загружена воспользоваться следующей командой:

Fixboot

Запись в системный раздел нового загрузочного сектора. Команда fixboot доступна только на консоли восстановления Windows 2000, которая запускается из программы установки Windows 2000.

fixboot [диск]

Параметр:

диск

Диск, на который требуется записать загрузочный сектор. По умолчанию используется системный раздел, с которого была осуществлена загрузка системы. Имя диска может выглядеть следующим образом:

D:

Пример:

В следующем примере новый загрузочный сектор будет записан в системный раздел диска D:

fixboot d:

ПРОБЛЕМЫ, ВОЗНИКАЮЩИЕ ПОСЛЕ ЗАПУСКА ЗАГРУЗЧИКА, НО ДО РЕГИСТРАЦИИ ПОЛЬЗОВАТЕЛЯ В СИСТЕМЕ.

Windows 2000 Resource Kit содержит отладочную версию Ntdetect.com, которая называется Ntdetect.chk. Если Ntdetect.com не может обнаружить все аппаратные устройства, которые он, по вашему мнению, должен находить, вы сможете использовать отладочную версию, которая поможет локализовать проблему.

Отладочная версия устанавливается с помощью файла Installd.cmd который выполняет следующие действия:

v переименовывает стандартный Ntdetect.com

v копирует Ntdetect.chk в Ntdetect.com

После выполнения этих операций нужно перезагрузить компьютер. При запуске системы с отладочной версией Ntdetect на экране будет появляться информация обо всех обнаруживаемых аппаратных средствах. После заполнения каждого информационного экрана необходимо нажимать клавишу Enter. Когда необходимость в отладочном варианте отпадёт - выполните команду installd /not.

Параметр SOS в файле Boot.ini.

В файл Boot.ini можно добавить параметр /sos, что заставит NTLDR отображать на экране имена ядра (Ntoskrnl.exe) и драйверов по мере их загрузки. Это поможет продиагностировать проблемы с отсутствующим или повреждённым драйвером устройства.

ПРОДОЛЖЕНИЕ СЛЕДУЕТ.


НЕКОРРЕКТНОЕ ОТОБРАЖЕНИЕ ТЕКСТА

В случае если вместо русских букв вы видите квадратики или кракозяблы (в кнопках и меню программ, или в созданном документе), попытайтесь исправить эту проблему.

Причина конфликта шрифтов может возникнуть в случаях, когда произошли изменения в реестре системы или в системе не зарегистрированы несколько типов шрифтов используемых в англоязычных версиях некоторых программ.

Если произошли изменения в реестре системы

Что бы устранить эту проблему необходимо сделать изменение реестра. Для этой цели создайте себе папку на любом диске (С, D или Дискете) с дежурными (лечебными) файлами и назовите ее /Кракозяблы, или как сами пожелаете. Создайте в Блокноте два файла и переименуйте их, как указано ниже. В результате получаете папку с двумя файлами: NT_2000_XP.reg (для WinNT/2000/XP) и 95_98_ME.reg (для Win95/98/ME). Процесс создания лечебных файлов для реестра закончен. Теперь можно приступить к самому процессу лечения. Выбираем файл в зависимости от операционной системы на вашем ПК и запускаем его прямо из папки, появится окошко <Редактор реестра> с запросом <Вы действительно хотите добавить информацию из папки... Кнопки ДА и НЕТ> и нажимаете кнопку ДА.

Этот файл сам внес изменения в ваш реестр. Больше ничего делать не надо. При этом с русскими буквами должно быть все в порядке. Положите эти файлы в дежурную папку, они всегда пригодятся в трудную минуту. Так что эти файлы-выручалочки лучше оставить себе на дискетке. В случае если система будет переустановлена и вдруг у вас произойдет подобный случай, а у вас уже есть эти файлы и вы всегда сможете в автоматическом режиме сделать поправки в своем реестре.

Создаем лечебный файл NT_2000_XP.reg для Win NT/2000/ XP

Открываем программу Блокнот (или ей подобную) и копируем текст приведенный ниже этого абзаца (----от сюда ----до сюда), естественно сами строки со словами ----от сюда ----до сюда исключаем и сохраняем. Далее переименовываем этот файл в NT_2000_XP.reg. Имя файла может быть и другим, главное, чтобы расширение файла было .reg. При необходимости (при появлении абракадабры запускаешь этот файл) просто запускаешь этот файл, он делает исправление в реестре (все это работает даже в плохой русификации программ и справедливо в Win NT, 2000, XP):

---- от сюда
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"
---- до сюда

Создаем лечебный файл 95_98_ME.reg для Win95/98/ME

Открываем программу Блокнот (или ей подобную) и копируем текст приведенный ниже этого абзаца (----от сюда ----до сюда), естественно сами строки со словами ----от сюда ----до сюда исключаем и сохраняем. Далее переименовываем этот файл в 95_98_ME.reg. Имя файла может быть и другим, главное, чтобы расширение файла было .reg. При необходимости (при появлении абракадабры запускаешь этот файл) просто запускаешь этот файл, он делает исправление в реестре (все это работает даже в плохой русификации программ и справедливо в Win Win95, 98, ME):

--- от сюда
REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Nls\Codepage]
"1250"="cp_1251.nls"
"1251"="cp_1251.nls"
"1252"="cp_1251.nls"
"1253"="cp_1251.nls"
"1254"="cp_1251.nls"
"1257"="cp_1251.nls"
--- до сюда

Если не получается сделать эти файлы самостоятельно, тогда скачайте готовые файлы и при необходимости запустите один из них, подходящий именно к вашей операционной системе: скачать файл!

Автор: Zoya Gureeva


Ускорение загрузки Windows, программ, устранение ошибок

Замечали ли вы когда-нибудь такую тенденцию: чем дольше вы работаете на компьютере без переустановки Windows, тем больше начинают тормозить программы, дольше идет процесс загрузки, количество ошибок возрастает лавинообразно. Некоторые горячие головы сразу начинают переустанавливать систему (а самые одаренные при этом еще и форматируют винт). После переустановки все начинает грузиться и работать очень быстро, но через пару месяцев ситуация повторяется. Опять все переустанавливать? Это не выход. Раз вначале все работает быстро, значит, что-то в системе изменяется, заставляя ее работать медленнее. А что можно сделать, чтобы таких изменений не было или как вернуть все назад без переустановки?

Давайте пойдем в обратном порядке, т.е. определим следствие, найдем причину и попробуем ее устранить. Итак, наиболее частые проблемы при работе:

- медленная загрузка компьютера;

- замедление работы программ;

- частые сообщения о недопустимых ошибках.

Медленная загрузка.

На это может повлиять большое количество причин. Изначально можно попробовать ускорить процесс, поиграв параметрами файла msdos.sys, описание которых дано в статье http://www.winhowto.ru/reg_n15.shtml. Но это постоянная причина, которая не зависит от того, сколько времени прошло с момента установки системы (да и не самая весомая). Основное влияние оказывает раздувшийся реестр и запускаемые при загрузке Windows программы.

Пока не загрузятся все программы из автозагрузки, нормально работать не удается, так что их смело можно включить в процесс загрузки операционки. К тому же они сильно сказываются на замедлении работы всех программ (вторая неприятность из списка), т.к. отъедают часть оперативки. Задумайтесь, все ли они вам нужны? Уверен на 100%, что хотя бы пару-тройку лишних программ вы найдете. Безжалостно удаляйте их (в смысле не сами программы, они-то еще могут пригодиться, а из автозагрузки). Где посмотреть, что у вас грузится? Об этом уже была статья http://www.winhowto.ru/reg_n2.shtml. Просто кратко перечислю основные места: реестр (раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\ в подразделах, где первым словом идет Run и раздел HKEY_CURRENT_USER), win.ini, system.ini, Пуск -> Программы -> Автозагрузка.

Здорово влияет на длительность загрузки размер реестра. Чем он больше, тем медленнее загружается компьютер. А происходит это по той простой причине, что каждый раз идет проверка реестра на наличие ошибок. Если таковых не обнаружено, создается резервная копия. На размер файлов реестра напрямую влияет количество установленных программ. Можно удалить весь ненужный софт, но это не выход. Большая часть размера уходит на записи, оставшиеся от уже удаленных программ. Ради интереса посмотрите раздел HKLM\Software. Наверняка вы найдете там записи оставшиеся от ранее стоявших программ. Можно попробовать удалить их все вручную, но где гарантия, что вы найдете все оставшиеся "хвосты"? Лучше для этих целей использовать специальные программы. Парочка их была описана ранее. Это RegCleaner и NBG Clean Regisrty. Ужав размер реестра можно добиться значительного увеличения скорости загрузки.

Замедление работы программ.

Опять же, возможно несколько причин. Не секрет, что недостаток оперативки ведет к более медленной работе программ. А оперативки много никогда не бывает. Чем больше программ запущено одновременно, тем медленнее будут они работать. Каждой программе для работы необходим определенный объем оперативной памяти, который она берет из общего объема. Когда суммарный объем таких кусочков превысит физический размер оперативки, начнется так называемое свопирование, т.е. часть данных из оперативки будет записана на жесткий диск в файл win386.swp (для Win9x) или pagefile.sys (NT,2000). Записываться будут в первую очередь те данные, к которым реже всего обращаются. На самом деле этот процесс гораздо сложнее, но примерная суть именно такова. Когда становятся необходимы данные, записанные на жесткий диск, они оттуда считываются, но, как вы понимаете, доступ к данным на диске происходит гораздо дольше, чем к данным из оперативки, поэтому и наблюдается это жуткое торможение, да еще и винт трещит немилосердно. Следовательно, чтобы все работало шустрее, надо высвободить как можно больше оперативки. В первую очередь стоит выгрузить лишние программы, о чем я уже написал выше. Затем оптимизировать загрузку драйверов (статья http://www.winhowto.ru/reg_n16.shtml). Также не рекомендуется использовать большую по объему картинку в качестве обоев на Рабочем столе, т.к. она тоже занимает место в памяти.

Одной из немаловажных причин является высокая фрагментация файлов на диске. Если у вас файл разбит на несколько кусочков, которые разбросаны по всему диску, то загружаться он будет гораздо дольше, потому что помимо простого чтения файла надо будет еще несколько раз позиционировать считывающую головку, а это требует заметных временных затрат. Поэтому желательно при интенсивной работе с жестким диском (частая запись и удаление файлов) время от времени проводить дефрагментацию.

Участившиеся ошибки и сбои.

Часто, когда устанавливается новая программа, в каталог Windows кидаются файлы (библиотеки) необходимые для работы этой программы. Вносятся исправления в реестр, настройки системы. И, к сожалению, иногда эти изменения могут вызывать сбои в работе ОС. Иногда заменяются стандартные файлы библиотек собственными или устаревшими версиями. Это тоже не лучшим образом сказывается на работе. Ну, а если после деинсталляции эти библиотеки будут удалены, последствия могут быть непредсказуемыми. Я не призываю отказаться от установки нового софта, просто этим надо заниматься с умом, особенно, если вы любите поэкспериментировать. Существуют утилиты, призванные устранить последствия "кривой" установки или деинсталляции программы. Описание их выходит за рамки данной статьи (возможно, когда-нибудь такой материал появится на сайте), но наводку дать могу: весьма неплохой программкой считается Professional Uninstaller. Найти ее можно без проблем в любом поисковике. Также есть программы, способные откатить все изменения в системе до контрольной точки, но это скорее пригодится для исследователей нового софта.

Еще можно воспользоваться советом IPWarrior'a от 18.10.01 в "Народной мудрости" (http://www.winhowto.ru/nd_w98.shtml). Он как раз пригодится, чтобы исследовать какую-то новую неизвестную программку, а главное вы будете уверены, что ничего неприятного с системными файлами не произойдет.

А главное, попытайтесь определить, после чего у вас посыпались ошибки. Как правило, на пустом месте они не происходят - этому предшествует либо установка какой-то программы, либо удаление. Ну, а, поняв, что повлекло сбои в работе, устранить их гораздо проще.

И помните - переустановка системы - это последний шаг, на который надо идти только в том случае, когда все другие методы себя исчерпали. Windows способен нормально работать несколько лет. Любите его, и он ответит вам взаимностью ;).


Ускорение Интернета

По умолчанию, Винды не настроены под современные компьютеры с новыми модемами, поэтому необходимо изменить вручную некоторые параметры. Просмотрите содержимое файлов WIN.INI, SYSTEM.INI - в них можно кое-что подправить. Например, в файле WIN.INI - выставить скорость портов:
в разделе [Ports] прописать
COM1:=921600,n,8,1,p
COM2:=921600,n,8,1,p
COM4:=921600,n,8,1,p
COM3:=921600,n,8,1,p

В SYSTEM.INI можно дописать в секцию [386Enh] параметры для портов
COMBoostTime=1
COM2Buffer=1024
Эти параметры увеличивают быстродействие портов и размер буфера очереди порта, к которому подключен модем. Разные источники рекомендуют устанавливать параметр COM2Buffer (равный, по умолчанию 128 байт) от 512байт до 16 килобайт, но оптимально, по моему мнению будет от 1024 байт до 4 килобайт, так как при очень больших значениях может произойти обратный эффект и связь ухудшится, а малый размер буфера, также может привести к потере информации при хорошей связи на быстрых линиях. Но лучше всего поэкспериментировать с разными значениями, и выбрать наиболее подходящее для конкретного ПК и модема.

Пример скриптов для провайдеров:

МТУ
Demos

Статейки о скриптах, и некоторых параметрах
Scripts
maxMTU
Connect
Modem
Modemtun

Если вы подключены к Интернету, то проверьте настройки вашего соединения. В меню свойств соединения с провайдером на вкладке "Тип Сервера" отключите вход в сеть и неиспользуемые протоколы, оставив только TCP/IP (если вы не подключены к локальной сети). В меню свойств модема на страничке "Дополнительно" поставьте флажки "Use Error control", "Compress Data", "Use Flow control"-"Hardware" и отключите протоколирование процесса соединения, а на вкладке "Соединение"-"Настройки порта" установите движки, регулирующие размер ФИФО-буферов, в максимально правое положение.
Скорость порта на закладке "Общие" тоже надо выставить в максимум, обычно это 115200 бит в секунду, однако можно сделать так, что появится возможность выбора вплоть до 921600. Гарантии, правда, что ваш модем сможет работать с такой настройкой порта нет (внутренний даже скорее всего не заработает), поэтому еще раз напоминаю: зарезервируйте реестр, так как для установки максимально возможной скорости придется его редактировать, а ошибки в этом деле могут "обрушить" всю систему. Создайте в Блокноте файл MODEM921600.REG с таким содержанием (постарайтесь без опечаток - изменение исходного значения выделено красным цветом!):

REGEDIT4

[HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\Class\Modem\0000]
"Properties"=hex:80,01,00,00,ff,00,00,00,ff,00,00,00,07,00,00,00,0f,00,00,00,\
77,07,00,00,00,10,0e,00,00,fa,00,00

Нажав на значке полученного файла левую кнопку мыши, вы внесете эту информацию в реестр, после чего в свойствах модема появятся еще и скорости 230400, 460800, 921600 бит в секунду. Если модем не заработает, вернитесь к 115200, или выбросите его (кергуду - шутка).
Теперь, в Панели управления выберите "Сеть" и откройте меню свойств Dial-UP Adapter'а, перейдите на закладку "Advanced" (Дополнительно) и установите параметры:
"Enable Point to Point IP" - YES;
"IP Packet Size" - LARGE;
"Record a log file" - NO;
"Use IPX header compression" - NO;
на вкладке "Driver Type" (Тип драйвера) выберите
"Enhanced mode [32 and 16 bit] NDIS driver"
- эти настройки еще немного добавят жизни вашему модему.

Часто, процесс входа в Интернет ускоряет использование скриптов, если вы не можете составить скрипт сами, возьмите его у вашего провайдера.

С помощью программ NetBoost 99 и iSpeed можно изменить некоторые сетевые параметры, оптимизируя их под модемное соединение (очень хороши программы Internet Tweak 2000 и MTUSpeed). При этом, правда, очень желательно проконсультироваться в службе технической поддержки провайдера об оптимальных значениях параметров, изменяемых этими программами. Работу в Интернете поможет ускорить программа Legion-The Host Master, она записывает IP адреса часто посещаемых серверов в специальный файл, что сокращает время поиска сервера на несколько секунд. А с помощью супер-программы ATGuard вы избавитесь от загрузки баннеров, скриптов, всплывающих окон, что может ускорить получение полезной информации в несколько раз!!!!!!

Замедлять работу IE5 может очень большой кеш (т.н. "Временные интернет-файлы"), размер которого задается в панели "Общие" диалога "Свойства Интернета". Обычно, вполне достаточно уменьшить его до 10 мегабайт.

Некоторые настройки, повышающие удобство и скорость работы, можно вручную сделать в реестре: например, в разделе
[HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\Class\Modem\0000\Init]
содержится скрытая строка инициализации модема.

В строке
[HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\Class\Modem\0000]
есть параметр Reset, который, обычно равен AT&F1, из-за чего модем, в некоторых программах, может набирать номер тоновым набором, поэтому его лучше изменить на AT&F1Z, чтобы после ресета модем инициализировался вашими установками (конечно, если вы занесли их в память модема для вызова командой ATZ), а не фабричными.

Для более точной подстройки протокола TCP/IP и устранения некоторых ошибок мелкософтом рекомендуется добавить в реестр:
[HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\VxD\MSTCP]
"Tcp1323Opts"=dword:00000003
"SackOpts"="1"
"BSDUrgent"="1"

Количество одновременных подключений к серверу HTTP1.0 ограничено четырьмя, к серверу HTTP1.1 по-умолчанию может быть только два одновременных подключения. Можно увеличить эти цифры до восьми:
[HKEY_CURRENT_USER \SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPer1_0Server "=dword:00000008
"MaxConnectionsPerServer"=dword:00000008

Навязшая в зубах беда модемов Sportster (и некоторых других) с определением (или, скорее, с неопределением) сигнала "ЗАНЯТО", лечится, на самом деле, очень легко: просто после набора номера должна быть пауза в пару секунд - благодаря ей количество правильно понятых сигналов "ЗАНЯТО" возрастает на порядок! Для создания этой паузы надо после номера в свойствах соединения с провайдером поставить две-три запятых, например: ,995-5555,,, - эти паузы перед набором номера и после него отсекают помехи и щелчки переходных процессов наших замшелых телефонных линий, благодаря чему и улучшается работа модема.


IZONE

Восстановление системы

Автор: Вячеслав Серов

В статье Германа Иванова "Устанавливаем операционные системы" (Izone415) он посетовал на то, что создать-то архив Виндовоза для быстрого восстановления системы можно, а вот распаковать архив трудно т.к. либо файлы заняты какой-то прогой (если из Винды) либо проблема длинных имен (если из Доса). Попробую поделиться.
Есть некие софтинки: Универсальный Backup (MultiWorks Tehnology http://www.mwt.ru), Ultimate Backup (Chertov Roman hGroup http://www.hgroup.dax.ru). Остановился на второй. Прога имеет демо и комерческий вариант. Демо стественно бесплатное. Ограничение на размер архива - 4Гб. Маловато будет!!!
"Откусил" кусочек Commandera для наглядного примера работы Ultima: arc0221.bpf - архив папок Windows и Program Files, файлов command.com, io.sys, msdos.sys и autoexec+cofig. ubackup.exe - Сама прога, ddeml.dll, остальное не важно. Про dll потом.

Помимо винды с драйверами перед архивацией установлены Office2000, FineReader V4, ACDSea. Итого архив весит 311Мб с хвостиком. Действия для восстановления: format c: /q, т.е. на чистый диск, загружаюсь с дискеты, запускаю ubackup.exe, вынимаю загрузочную дискету, засекаю время, иду курить, прихожу из курить и жду еще минут 5. В мое отсутствие Ultimat все что смог распаковал из Доса (короткие имена), перезагрузился уже с С: Виндовозом, но не полностью, а как хитрый Нортон Утиль перед оптимизацией свопера, и пошел писать длинные имена. Итого все восстановление занало 13 минут (на Пне 850 128Мб) и никаких шуток. Все встало 1 в 1 за исключением...

В результате экспериментов выявилось "нечто", в чем я разбираться не стал - файл ddeml.dll оказался на 4 минуты старше своего оригинала, поэтому при загрузке Виндовоз все время пишет типа "файл был заменен более поздней версией". Дык я его сначала сохранил отдельно (см картинку) а после восстановления копирую врукопашную.

Еще парочку замечаний. Виндовый своп первоначально прячется в паке System и для архива является мусором, причем не хилым. Отключаем (Мой комп-правый клик-Свойства-Быстродействие-Виртуальная память-Не использовать). Перегруз. Возвращаемсвопсmin=max=120M. Теперь он на корне и от архива отсекается. Кроме того надо убрать временные файлы и почистить паку Sysbckup - там тоже мусора метров на 10-20 валяется.

Теперь немного не по теме. Не ставлю проги по умолчанию в C:\Program Files, а насильно в D:\PrgWin. Некоторым прогам начхать - чего там в реестре "наинсталировалось", а некоторые капризничают. Причем чем круче и "размернее" прога, тем больше хвостов в реестре. Рухнул Вынь - начинай все с начала. А установи их в D:\PrgWin, сделай архивчик Ultimatom и нет проблем. Из тех же соображений на всех компах в конторе "С:\Мои документы" перекочевали на D:\Mdoc. Все сказанное обкатано на Вынь98. На Windows2000 Server пробовал только 1 половину задачи. Архивчик получился 2Гб с хвостом. И Демо ничего - сдюжил. Если еще в обратную раскатает... Кто попробует, прошу поделиться впечатлениями.

Copyright © Internet Zone, info@izcity.com
Условия использования материалов смотрите здесь.


Восстановление данных со сбойных компакт-дисков

Автор: Земсков Юрий
www.СomputerLibrary.info

Предисловие

У многих наверняка возникала необходимость в восстановлении данных с частично нечитаемого (сбойного) CD или DVD диска. Решение этой проблемы и является темой данной статьи. В начале рассмотрим различные степени испорченности поверхности компакт-дисков, общие рекомендации по решению проблемы, а потом, собственно, перейдем к описанию программ, которые помогут восстановить данные с «умирающего» носителя.

В последнее время эта проблема приобрела особую актуальность: цены на CD-RW приводы упали до неприлично малых отметок, тоже самое происходит и с «болванками» (матрицами для записи). А как и у любого «ширпотреба», вместе с ценой часто падает и качество. В мире рыночной экономики чудес не бывает. Все больше и больше «умельцев» пишут восьмирублевые CD-R болванки от «могучей» Noname и Ко на 32 скоростях. Что это? Экономия времени или может быть подростковый максимализм? Однако торопиться как раз и не стоит. Возможно, такой диск и удастся записать, но вот, что с ним будет через 5–6 месяцев, одному богу известно.

В качестве предисловия самые общие рекомендации по чтению сбойных компактов. Если ничего не выходит, попробуйте программно понизить скорость считывания данных (например, с помощью Nero Drive Speed и других подобных утилит) или использовать другой привод — со считыванием данных проблем может и не быть у новых приводов в отличие от «затертых» CD-ROM'ов пятилетней давности или у дорогих аппаратов с хорошей коррекцией ошибок.

Определение качества компакт-диска

Как и йогурты в рекламе, в жизни не все диски одинаково читаемы. Для определения качества носителя я пользуюсь программой Nero CD Speed (вообще-то, она предназначена для определения технических характеристик CD-приводов, но у программы есть и одна важная в рамках этой статьи функция). Скорее всего, Nero CD Speed есть и на вашем компьютере — программа идет в комплекте с Nero Burning ROM (пожалуй, самой популярной программой для записи дисков) и Nero Express (упрощенной версией Nero Burning ROM, которая довольно часто идет в комплекте с пишущими приводами). Если что, Nero CD Speed можно загрузить с www.cdspeed2000.com.

Итак, для начала необходимо разобраться с качеством копируемого диска. Вставляем компакт-диск, запускаем CD Speed, в меню выбираем Extra -> Scandisc, внизу отмечаем опцию «Surface Scan» (проверка поверхности диска) и запускаем тест. В результате получаем карту поверхности диска:

  • зеленым цветом на ней отмечены нормальные сектора, которые читаются без проблем,
  • желтым — поврежденные (damaged) сектора, их скорее всего удастся считать,
  • красным отмечены полностью нечитаемые сектора.

Карта поверхности диска зависит от конкретного привода — более дорогие и новые модели с лучшим алгоритмом коррекции ошибок и более качественной оптикой, естественно, дадут лучшие результаты.

Для полностью «зеленых» дисков проблем быть не должно. Можно спокойно пользоваться стандартными средствами Windows для работы с файламы или своим любимым файл-менеджером. Собственно, такие диски никакого отношения к теме статьи не имеют. Они полностью исправны — с чем я вас и поздравляю :)

А вот дисками, где есть желтые или красные сектора, мы займемся вплотную. С «желтыми» дисками, где есть поврежденные сектора, особых проблем не будет — данные с них восстанавливаются относительно легко и безболезненно.

Нечитаемые (красные) области диска — это уже проблема. Рассматриваемые ниже программы восстановления данных просто будут заменять несчитанные биты из этих областей нулями. Если для диска с divx-фильмом это не так важно (не думаю, что потеря 5 секунд очередного голливудского блокбастера — большая проблема), то для дистрибутива программы или какого-либо архива такая замена имеет значение. Так что, решайте сами, возможно, проще достать где-то похожий диск, если он не существует в одном лишь экземпляре. Также стоит помнить, что восстановление даже некритичных данных (те же фильмы) с сильно испорченного диска, где много нечитаемых секторов, похоже на борьбу с ветряными мельницами как по количеству затраченного на это времени, так и по конечному результату.

Программы для восстановления данных со сбойных дисков

На этом рассмотрение степени испорченности дисков закончено. Теперь посмотрим, что с ними можно сделать. Рассматриваемых программ всего две, однако, они полностью решают поставленные задачи. Обе утилиты бесплатны и имеют русский интерфейс.

Super Copy

Как пишет сам автор: «Данная программа предназначена для копирования файлов большого размера с неисправных носителей. Программа заменяет несчитанные байты копируемого файла на нули. Например, программа может пригодиться для копирования фильмов с повреждённых компакт-дисков. При просмотре фильма практически не будет заметно повреждений в изображении.»

С определением можно согласиться, только вот вместо «неисправных носителей» следует читать «поврежденных носителей». Super Copy хорошо работает с дисками, где есть поврежденные (желтые) сектора. А вот компакты с красными нечитаемыми областями программе не под силу, копирование останавливается с выводом ошибки. Каких-либо специальных исследований по этому поводу не проводил, возможно, это особенности моего привода LG 8520B, хотя не думаю…

В целом программа производит благоприятное впечатление — предельно простой и понятный русскоязычный интерфейс — несколько формочек, несколько пунктов меню и немногочисленные настройки — в этих двух соснах не заблудишься. Super Copy работает в любыми файлами (hdd, cd, dvd, floppy…), не обязательно находящимися на компакт-диске. Divx-фильм размером около 700 mb с поврежденного компакт-диска Super Сopy «передирает» примерно минут за 9. Программа распространяется бесплатно (220 kb, windows, freeware).

CDCheck

CDCheck — мощная и интересная программа. Она предназначена не только для восстановления данных со сбойных компакт дисков (равно как и с любых других носителей), но и для проверки степени повреждения носителя и возможности копирования с него определенной папки или файла. Программа обладает понятным интерфейсом: кнопочки говорят сами за себя, в настройках можно включить русский интерфейс, возможности настройки вас тоже не разочаруют.

В отличие от Super Copy, CDCheck копирует и диски с нечитаемыми (красными) секторами, хотя и очень медленно — на копирование стандартного компакт-диска в 700 mb уйдет несколько (в зависимости от специфики алгоритма коррекции ошибок вашего привода) часов. Биты, которые после нескольких попыток, количество которых настраивается, не удалось считать, заменяются нулями.

Очень хорошая программа с прекрасными возможностями и функциональным интерфейсом. Копирует файлы и папки с любых носителей. В ходе восстановления данных пользователь получает подробную статистику о скорости работы, прошедшем времени и ожидаемом до истечения результата, скорости чтения и количестве уже считанной информации, а также подробные сведения о поврежденных и нечитаемых секторах.

Все бы хорошо, однако CDCheck подойдет только для «крепких духом» пользователей — даже на неповрежденных областях диска программа не спешит разгоняться выше 150 кб/сек (1x), на поврежденных секторах скорость еще ниже. Так что, собираясь восстанавливать какой-нибудь семьсотмегабайтный фильм с помощью CDCheck, подумайте, возможно, проще попросить у знакомых диск. У меня процедура копирования фильма заняла 2:50 (и не подумайте, что это время в формате минуты:секунды!).

Все же CDCheck прекрасно подойдет для файлов меньшего размера и в тех случаях, когда во что бы то ни стало необходимо восстановить информацию с испорченного носителя. CDCheck бесплатна для некоммерческого использования. Подробнее о программе написано на официальном сайте. Скачать можно по этой ссылке (830 кб, windows, free for personal use).

Подведем итоги

Лично мне для восстановления данных с испорченных компактов полностью хватает описанных выше программ. В основном приходится «возиться» с divx-фильмами. Исходя из практического опыта, подведу итоги, «раздам слонов» и каждому «сверчку» укажу на его «шесток» :)

Сначала делаю проверку поверхности подозрительного компакт-диска с помощью Nero CD Speed. Если диск полностью «зеленый», то в ход идут стандартный проводник или TotalCommander, который эти 700 mb фильма скопирует минуты за две.

Если на диске есть поврежденные «желтые» сектора, в бой идет Super Copy, теперь 7–10 минут компьютер можно не беспокоить (все равно не откликнется ;о) ), можно сходить покурить или попить там чаю…

Если хотя бы один сектор диска нечитаемый (красный по результатам тестирования поверхности), глубоко и обреченно вздыхаем и запускаем CDCheck. Теперь у вас уйма свободного (от компьютера) времени, сходите погулять или почитайте книжку… :)

Удачи! И да прибудут с вами нули и единицы (правильно восстановленные, хотелось бы заметить…)!

  • Читать статью онлайн.
  • Версия статьи для печати.

Оставить отзыв, комментарии к статье.


Microsoft Windows XP Service Pack 1 - Установка

Предупреждение: Вся нижеизложенная информация может быть использована только для ознакомления, автор не несет никакой ответственности за возможные негативные последствия.

Предисловие:

Вот, что пишет Compulenta по поводу Service Pack 1.
Что же предлагает пользователю первый Service Pack для Windows XP? Во-первых, огромное количество патчей, решающих проблемы с безопасностью различных компонентов системы, как обнаруженных с момента выпуска ОС, так и исправленных в ходе двухмесячной работы над кодом Windows XP в Microsoft в рамках инициативы Trustworthy Computing.

И, наконец, новости для пользователей пиратских копий Windows XP со взломанной активацией. Как известно, обойти процесс активации продукта удалось путем использования корпоративной версии Windows XP, в которой активации просто не существует. Среди пиратских копий операционной системы широко распространена корпоративная версия Windows XP, с серийным номером, начинающимся на "FCKGW".

Первый Service Pack при установке проверяет, не принадлежит ли конкретная копия Windows XP к числу пиратских, именно с таким серийным номером. В случае совпадения, программа выводит сообщение об ошибке, после чего пользователь сможет пользоваться ОС, но не будет иметь возможности обновить операционную систему на сайте WindowsUpdate.

www.winall.ru: "это теоритически, на самом деле обойти защиту и установить Service Pack для WIndows XP не является трудным делом".

Надеемся, что вы уже прочитали наиболее полную информацию о первом пакете исправлений здесь и захотели его установить, но почему-то процесс установки прерывается и появляется это сообщение:

Но, оказывается, что это вовсе не значит, что пакет обновлений больше никогда не установится, надо просто убедить SP, что Windows XP - самая, что ни на есть лицензионная.

Существует несколько, а точнее 3 способа "убеждения" - правка реестра, деактивирование Windows XP с последующей реактивацией и, самый приемлемый и простой способ - с помощью утилиты update_xp_cd_key.exe и стандартного окна активации.

Как это делается

Мы будем рассматривать самый простой и доступный способ. Способ, который работает на 100% на всех корпоративных версиях (а их большинство) Windows XP. Для процесса нам понадобится утилита ViewKeyXP.exe, которая позволит узнать текущий ключ установки ОС

Затем эта же утилита понадобится нам для удостоверения в том, что серийный ключ действительно изменился.

После этого, запускаем программу update_xp_cd_key.exe, которая и сделает нехорошую работу. В появившемся окне DOS необходимо согласится с тем, что у вас нет ещё нового ключа, тем самым, запустив генератор.

.
В пункте "Software" необходимо выбрать свою версию Windows XP, а в следующем, "Mode" выбираем "FIND KEY". Устанавливаем произвольное количество попыток найти ключ, после чего жмем пимплу "Process". Обычно ключ находится в одной из первых 20 попыток, о чем программа не забудет вам дать знать следующим появлением окна:

Таким образом рабочий и лицензионный ключ у нас появился. Теперь необходимо его изменить, чтобы у SP не возникало никаких подозрений. Для этого вводим в пункт стартового меню "Выполнить" (Run) команду: %systemroot%\system32\oobe\msoobe.exe /a - эта команда вызывает окно активации Windows XP. Если вдруг это окно встречает вас следующим образом:

то необходимо в реестре по адресу: HKey_Local_Machine\Software\Microsoft\WindowsNT\Current Version\WPAEvents изменить параметр oobetimer (заменить любую цифру), для ленивых предлагаем скачать заплатку. После этого опять вызываем окно активации, где выбираем "Yes, I want to telephone.....". Затем в появившемся окне выбираем вкладку "Change CD Key" и вводим наш сгенерированный ключ. Запускаем утилиту ViewKeyXP.exe, удостоверяемся, что ключ изменен и начинаем устанавливать Service Pack... но это уже другая история.

На рассмотренном примере мы убедились, что защита Microsoft для первого сервис пака оставляет желать лучшего, и надо заметить, что это не единственный способ взлома защиты - воспользуйтесь утилитой xpda.exe и придете к тому же результату. А пока можно порадоваться, увидев в свойствах компьютера наличие установленного Service Pack (a).


Здравствуйте, дорогие подписчики

Советы "Народной мудрости":

1. "Турбо-Интернет" с сайта http://www.optimizator.ru/ не только оптимизирует работу, но и занимается раскруткой одного сайта. У меня после оптимизации при неправильном наборе адреса в IE рядом с сообщением "Невозможно отобразить страницу" грузится страница "найти на "Бегуне", которую, в общем-то, никто не звал...
Пролечить эту беду можно, переустановив с системного диска файл c:\windows\system\Shdoclc.dll например с помощью программы c:\windows\system\sfc.exe
Создает ли optimizator другие нехорошие изменения, не проверял.
Причем таким безобразием грешат и некоторые сайты. Возможно, что этот трюк поможет и против них.
Прислал: Валерий Андреев

2. Интеллектуальное меню в Windows XP
Скрытие строк редко используемых программ, что очень удобно, в кнопке "Пуск" в Windows XP осуществляется так.
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced]
Параметр "IntelliMenus": "Yes" включает интеллектуальное меню, "No" выключает.
В том же разделе еще много интересных параметров, названия которых говорят сами за себя.
Прислал: Eugene KRUGLOFF

3. Copyright (c) THE UnForGiven (ufg@ukrpost.net)
В интернете есть очень удобная служба, которая позволяет заказывать html-страницы, включая графику, подписываться на рассылку страниц и осуществлять поиск в WWW. Доставку других файлов ни с http, ни с ftp-серверов она не обеспечивает. Для начала можно послать пустое письмо на адрес www@web2mail.com, и нам придёт файл помощи на английском языке в виде html-страницы. Далее на тот же адрес посылаем письмо с командой в поле Тема (Subject).
Для заказа страницы без графики команда представляет собой лишь адрес страницы. Писать приставку http:// необязательно. Проще не придумаешь. Для заказа страницы со всей присущей ей графикой дописываем к адресу два слова - with images:
http://www.webhowto.ru/reg/reg_nd01.shtml with images
Пребольшое удобство - все ссылки на получаемой странице переделываются таким образом, чтобы при нажатии на них почтовый клиент создавал новое письмо для службы web2mail уже с командой в поле Тема для заказа этой страницы. Остаётся только отправить созданное письмо!
Абсолютно новый вид услуг - подписка на страницы. К примеру, мы хотим еженедельно получать какую-то страницу, чтобы отслеживать новую информацию на ней. Для этого перед адресом страницы пишем слово subscribe, а после - weekly:
subscribe http://www.webhowto.ru/reg/reg_nd01.shtml weekly
Для ежедневного получения вместо weekly надо указать daily, для ежемесячного - monthly. Причём сразу можно заказать сколько угодно страниц, перечислив их адреса через пробел. Ещё один плюс: служба не будет слать страницу, на которую подписались, если на ней не произошли изменения со времени предыдущей рассылки.
Ну и под конец - поиск. Всё так же просто, как и выше. Создаём письмо на уже известный адрес, в Теме пишем команду search и нужное словосочетание, например: search Billy Gates. Убедительная просьба: не забивайте службу сразу пятью заказами, дождитесь прихода предыдущих. Именно из-за жадности людей такие службы и сидят в дауне, не отвечая несколько дней, или вовсе закрываются. Поэтому, давайте хоть немного думать о других и о дне завтрашнем.
Прислал: Eugene KRUGLOFF

4. Плавная прокрутка текста в word'e:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\8.0\Word\Options
параметр LiveScrolling = 1
Выделенное "8.0" - версия офиса. 8.0 - Офис97, 9.0 - Офис2000....
Прислал: biolog666

5. При загрузке страницы с ошибкой Internet Explorer в строке состояния в левом нижнем углу окна отображает значок ошибки и текст, предупреждающий об этом. Чтобы узнать какая именно ошибка произошла и где, надо дважды шелкнуть левой кнопкой мыши по этому значку ошибки. Появится сообщение о типе ошибки и строке, где она произошла. Если вы хотите, чтобы такое сообщение появлялось автоматически при каждой обнаруженной ошибке, надо в настройках браузера (Сервис->Свойства обозревателя->Дополнительно) отметить галочкой пункт: "Показывать уведомление о каждой ошибке сценария".
Прислал: O1eg (http://www.hostsearch.ru/)


Здравствуйте, дорогие подписчики

Народная мудрость:

1. При загрузке ХР после неправильного выключения запускается проверка дисков. При этом пишется что-то вроде "Через 10 секунд начну проверять...". Чтобы уменьшить время ожидания надо в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager создать или отредактировать параметр AutoChkTimeOut типа DWORD. Значение - пауза в секундах.

2. Последние версии FARa позволяют просматривать скрытые общие ресурсы (у которых в конце имени стоит символ $). К таким, в частности, относятся автоматически создаваемые Win2000/XP шаринги с именами C$, D$, ... для администраторского доступа. Чтобы включить эту возможность надо в F9 -> Параметры -> Параметры внешних модулей -> Просмотр сети отметить крестиком пункт Показывать скрытые общие ресурсы. Не забудьте сохранить настройки для следующих запусков.

3. Если The Bat! запустить с параметром /CHECKALL, то The Bat! проверит почту всех незапарольеных ящиков после чего закроется.
P.S. Не лениться прочитать все советы дня (там много интересного)
Прислал: ffaster

4. Чтобы убрать ограничение на доступ к сайтам в IE достаточно удалить все параметры из раздела HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\ Ratings

5. Где хранится код активации Windows XP?
Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\ System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.
Прислал: Е.Соболев (http://www.softodrom.ru/)

6. Как автоматизировать вход в систему - без ввода логина и пароля?
Старт - Выполнить, вводим команду
control userpasswords2
После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Пользователи флажок напротив "Требовать ввод имени пользователя и пароля". После нажатия на кнопку ОК появится диалоговое окно "Автоматический вход в систему", где нужно будет указать имя пользователя и пароль.
Прислал: Е.Соболев (http://www.softodrom.ru/)


1

1. Настройка удаленного соединения TCP/IP через реестр в Windows XP.
Для настройки запускаем RegEdit (Пуск -> Выполнить -> regedit).
HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Tcpip\Parameters
Строковый параметр DefaultTTL (TTL - Time To Live) - время жизни пакета. TTL может принимать значения 32, 64, 128. Он предусмотрен для того чтобы при поиске места назначения пакета маршрутизаторы не зацикливались. Как только значение этого параметра превышает допустимое, пакет считается попавшим в цикл и уничтожается. Рекомендованное значение (64).
Строковый параметр TcpWindowSize (RWIN - Receive Window) - окно посылки. Значение RWIN рассчитывается по формуле DefaultMSS * n, где n - 4, 6, 8 (1460 * 8=11680). Когда ты посылаешь запрос на сервер, то он имеет право отправить тебе RWIN количество байт, не дожидаясь подтверждения об удачном приеме. Если RWIN будет равным DefaultMSS, то сервер после каждой отправки пакета будет ждать подтверждения. Если указать DefaultMSS * 20, то сервер будет отправлять сразу 20 пакетов, что увеличит их потерю. Рекомендованное значение (5840)
Строковый параметр PMTUDiscovery (Maximum Transmission Unit) - максимальный передаваемый пакет. Возможные значения для MaxMTU: 552, 576, 1002, 1500. По умолчанию в Win XP стоит значение (1) автоматический режим. Чем больше значение, тем больше пакет и больше данных получешь. С максимальным значением модем будет отправлять больше данных, но при плохой связи пакеты теряются и на повторную отправку больших пакетов понадобиться больше времени. Еще одна проблема - стандартом для маршрутизаторов долгое время являлось значение MaxMTU = 576. Сейчас везде по разному. Рекомендованное значение MaxMTU (1) автоматичекий режим.
Строковый параметр DeadGWDetectDefault - нахождение черных дыр. Если этот параметр поставить в (1), то перед началом соединения будет происходить проверка на мертвые маршрутизаторы по пути до сервера. Этот параметр сильно тормозит протокол за счет лишних затрат на поиск. Рекомендованное значение (0).
Дубль параметры располагаються в разделе:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
Строковый параметр TcpWindowSize, PMTUDiscovery рекомендую установить по параметрам сервера провайдера. Если не знаете поставте рекомендованные значения.
Заключение:
Данные настройки могут увеличить скорость от 10 до 40 %. Эти настройки являются индивидуальными для каждого в зависимости от качества вашей связи.
Для автоматической настройки можно воспользоваться специальной программой TweakMASTER Pro. Другие программы не рекомендую. Проверено.
Прислал: Григорий (http://reestr.hotmail.ru/)

2. Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.
Прислал: Sebulba

3. Совет по поводу закрытия Flash-BIOS на запись может оказаться вредным. Дело в том, что БИОС перешить все-таки чаще всего можно (хотя бы на горячую у специалистов в практически любой нормальной компьютерной конторе), а вот восстановить информацию на винчестере, которую смешивает в кашу Win95.CIH и его клоны при условии, что ему не удалось обнулить бивис буде значительно труднее, а чаще всего и просто невозможно.
Прислал: Serg


Народная мудрость

1. Любителям Word'a: Если нажать alt и начать выделение мышкой, то будет выделятся прямоугольный фрагмент текста.
Прислал: Сергей К

2. Для того чтобы поставить знак промилле (показывающий уровень солености), нужно при любой раскладке клавиатуры удерживая Alt на дополнительной клавиатуре нажать 0137, затем отпустить Alt и должно получится что-то типа - ‰
Для того чтобы поставить знак параграфа, нужно при любой раскладке клавиатуры удерживая Alt на дополнительной клавиатуре нажать 789, затем оптпустить Alt и должно получится что-то типа - §.
Для того чтобы поставит знак "•" (без кавычек) надо удерживая Alt на дополнительной клавиатуре нажать 0321456789 и все.
Прислал: 0X0THuK (http://www.rotten7.narod.ru/)

3. Если при записи через микрофон громкость очень слабая и слышатся посторонние шумы, нужно отодвинуть монитор подальше от системного блока и подальше отойти с микрофоном от монитора, лично мне это помогло.
Прислал: 0X0THuK (http://www.rotten7.narod.ru/)

4. Всплывающая панель.
- Создаем какую-нибудь панель со своими ярлычками (эта тема неоднократно обсуждалась в советах) потом временно перетаскиваем ее на рабочий стол, пусть пока повисит как простое окно.
- Затем перетаскиваем главную панель (т.е. ту на которой панель задач, трей и кнопка "Start") на сторону противоположную той где она у вас обычно. (Обычно у людей она внизу, поэтому перетаскиваем наверх).
- Вместо нее ставим нашу новую панель и даем ей свойства "Auto-hide" и "Always on Top"
- Теперь перетащим главную панель на место и...
Мы видим панель задач в полную ширину, но как только подведем курсор к самому краю экрана поверх нее всплывает наша панель. Как-то еще можно указать время всплытия, но я не занимался этим вопросом.
Прислал: Mikhail

5. Автозамена.
Один хороший человек недавно здесь рассказывал про автозамену в MSWorde. Это правильно, НО! я предпочитаю делать это на уровне всей системы. Например, PuntoSwitcher'ом или HotKeyboard'ом (по-моему, в данном отношении (и только в данном!) HotKeyboard гораздо лучше). Подумайте сколько слов вы регулярно набиваете зря. А ведь вместо, например, vasya_pupkin234@mail.karaganda.eu.ru можно ввести просто vp@ и нажать на пробел.
Попробуйте, потратьте на настройку час свободного времени и вы сбережете много часов более драгоценного времени.
Прислал: Mikhail

6. В "Народных советах" я встречал рекомендацию о том как в разных версиях Windows переименовать "Корзину". Хочу предложить еще более простой способ, работающий во ВСЕХ версиях Windows (98-XP), после применения которого в контекстном меню "Корзины" появится стандартный пункт "Переименовать". Тогда можно будет делать то, что мы задумали хоть каждый день... А если надоест - вернуть все обратно.
Итак в разделе реестра
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
Параметр Attributes
Тип REG_BINARY
Значение 40 01 00 20
Меняем в значении 40 на 70 и все готово...
Выходим из реестра, кликаем правой кнопкой мыши на ярлыке "Корзины" и видим пункт "Переименовать"...
Прислал: Bubinga

7. Far manager - автоопределение кодировки.
Многие удивляются - почему Far даже при включенном свойстве автоопределения кодировки ее не "автоопределяет". Очень просто - их надо установить. Они лежат в папке Far/Addons/Tables - те какие вам нужны, я думаю, Вы сами разберетесь, но Windows-1251 лучше установить в любом случае.
Прислал: Mikhail

8. В последнее время очень много стал наблюдать трагических случаев связанных с установкой Linux. Предполагая, что на этот сайт заходят люди, которые любят экспериментировать, позволю себе их предостеречь - не ставьте Linux, если не знаете, что такое MBR, как ее восстановить, чем одна файловая система отличается от другой и что такое "загрузчик". Linux, безусловно замечательная Ось, НО(!) не стоит начинать знакомство с ней с ее установки. Попросите об этом более опытного знакомого или купите LiveCD (например KNOPPIX) они не требуют установки на жесткий диск (они его вообще не требуют).
Прислал: Mikhail

9. Если вы делаете CHM с помощью HTML Help Workshop, то наверняка удивляетесь - как же вставить кнопку Font. Очень просто - File/Open в поле ввода имени файла вводим
I'm MSDN
Прога "примет Вас за своего" и откроет много новых галочек, но(!) не все они работают.
Прислал: Mikhail

10. Если Вам лень или стыдно "ломать" HTML Help Workshop, то размер шрифта в CHM (как, впрочем, и в любом окне IE - знаете, многие программы, и особенно Autorun'ы встраивают его в себя) можно поменять сфокусировав это окно и покрутив колесо мыши, удерживая Ctrl.
Прислал: Mikhail


НАРОДНАЯ МУДРОСТЬ

1. Очистка списка недавно использованных команд
Windows поддерживает списки недавно использованных команд, для различных функций оболочки. Один из списков содержит последние команды, выполненные при помощи пункта Выполнить меню Пуск; этот список может быть отображён на экране, если нажать стрелочку, открывающую список, в диалоге Запуск программ.
Этот список называется Run MRU. Список содержится в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\RunMRU
Вот атрибуты списка Run MRU:
Параметр MRUList содержит строку, определяющую порядок, в котором остальные записи будут появляться в списке. Сами команды храняться как строки (оканчивающиеся символом \1) в параметрах с именами a, b, c, и т.д. Допускается не более 26 записей. Эта структура используется в различных списках MRU. Можно очистить список, используя REG-файл, заменяющий значение параметров в разделе RunMRU пустыми строками.
Файл, листинг которого приведён ниже:

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\RunMRU]
"a"=" "
"MRUList"=""

Можно создать аналогичные файлы, очищающие остальные 26 записей - a, b, и т.д. вплоть до z, но это не является необходимым. Достаточно очистить первый параметр "a" и параметр "MRUList", что и делает файл, приведённый выше. После следующего перезапуска системы с пустым значением параметра MRUList система не сможет определить последовательности записей и, следовательно, покажет пустой список в диалоге Запуск программы. Строка Открыть также будет пустой.
Прислал: Пухнарь

2. Простой и быстрый способ восстановления Win9x.
Очень часто сбои операционной системы Windows 9x связаны с ошибками в системном реестре или повреждением файлов, входящих в состав операционной системы Windows т.е. в основном тех файлов, которые находятся в папке WINDOWS. Я делаю так: после начальной установки Windows, установки всех необходимых драйверов и программ, делаю копию папки WINDOWS с другим именем, например WIN_COPY, в корневом каталоге или в том каталоге, где у Вас находится эта папка.
Когда у Вас происходит сбой операционной системы, проделываем следующие действия:
- перезагружаем компьютер в режиме MS-DOS;
- переименовываем папку WINDOWS в любую другую, например WIN_OLD, а папку WIN_COPY в WINDOWS;
- перезагружаем компьютер.
После загрузки удаляем папку WIN_OLD (чтоб не занимала место на диске) и снова создаём копию папки WINDOWS, как указано в начале. Возможно придется переустановить некоторые программы, установленные после создания копии папки WINDOWS. Весь секрет в том, что если в ДОСе папку с файлами, имеющими длинные имена не копировать а переименовать, то эти самые длинные имена сохраняются.
Совет: почаще обновляйте рабочую копию Windows, потом будет меньше работы.
Этим методом часто пользовался в компьютерном клубе, чем исключались вероятные простои компьютеров. Недостаток: копия папки WINDOWS занимает до 500 Mb дискового пространства.
Прислал: Сергей

3. С помощью правки реестра в Windows XP можно отключить пользовательский интерфейс настройки приложения "System Restore", чтобы предотвратить изменение настройки этого приложения пользователем, а также отключение и включение этого свойства для системных и несистемных дисков. Для этого надо в разделе реестра HKEY_LOCAL_MACHINE \SOFTWARE \Policies \Microsoft \Windows NT создать подраздел "SystemRestore", а в нём dword-параметр "DisableConfig" со значением 1.
Прислал: OLEG

4. Ключ, с помощью которого шифруются данные в Windows 2000/XP, имеет длину до 128 байт и уникален для каждого пользователя в каждой инсталляции системы. Ключ хранится в профиле пользователя, поэтому после переустановки системы или удалении пользователя он теряется. Расшифровать файлы, зашифрованные этим пользователем, становится невозможно. Пытаться создавать для этого другого пользователя с таким же именем и паролем для входа в систему абсолютно бесполезно. Одно из возможных решений - это создание диска аварийного восстановления (Emergency Repair Disk). Вся необходимая информация по существующим пользователям будет сохранена на ERD-диске, и после переинсталляции системы надо будет только восстановиться с него. Кроме этого, можно заранее сохранить необходимые сертификаты и ключи или заблаговременносоздать агента по восстановлению (Encrypted Data Recovery Agent).
Прислал: OLEG

5. Систему шифрования EFS (Encrypted File System) можно выключать/включать на Windows 2000 и Windows XP Pro. Для этого достаточно в разделе реестра:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\EFS key
создать или отредактировать уже существующий dword-параметр "EfsConfiguration". Присвоив этому параметру значение 1, вы выключите EFS, а присвоив 0, включите обратно. Для того чтобы изменения вошли в силу, необходимо перезагрузить компьютер. Очевидно, что, отключив EFS, вы потеряете возможность не только шифровать файлы, но и расшифровывать ранее зашифрованные. Как очевидно и то, что включение/отключение EFS влияет сразу на всех пользователей. Но на ключи пользователей (как открытые, так и личные) это действие не окажет абсолютно никакого влияния, поэтому после того как EFS будет включена вновь, никаких проблем с доступом к своим файлам пользователи не испытают.
Прислал: OLEG


Особенности операционной системы Windows 2000 Professional

Поль Тюрро, <Профессионалам Windows NT/2000>

Лучшая ОС для предпринимателей и мобильных пользователей

Операционная система Windows 2000 Professional (Windows 2000 Pro) имеет очень

много коренных отличий от Windows NT Workstation 4.0 и Windows 98. Однако для

того, чтобы в полной мере оценить все возможности этой версии, необходимо четко

осознавать цели, которые ставили разработчики. Осенью 1996 г., когда в Microsoft

приступили к созданию Windows 2000 (тогда она еще называлась Windows NT 5.0),

руководство корпорации поставило перед разработчиками следующую задачу: сделать

операционную систему простой и надежной. Несколько позже было решено, что

Windows 2000 должна превосходить по надежности и удобству работы с ней все

предыдущие версии, оптимально подходить для пользователей переносных

компьютеров, а также обеспечивать снижение такого показателя, как общая

стоимость владения. Удалось ли это сделать, давайте посмотрим.

Хотя интерфейс Windows 2000 во всем подобен интерфейсу ее предшественниц, он

более систематизирован. Например, порядок работы с меню Start персонализирован

посредством встроенной функции Personalized Menus, отслеживающей все выполняемые

операции. В результате значки редко используемых программ будут из стандартного

меню удалены, а из меню регулярно запускаемых приложений исчезнут редко

выбираемые пункты, которые порой вносят путаницу. Когда же они все-таки

понадобятся, нужно будет только щелкнуть на небольшом символе шеврона в нижней

части каждого меню или в течение нескольких секунд задержать указатель мыши над

меню.

Кроме того, разработчики преобразовали хорошо знакомую команду Find в

базирующийся на стандарте HTML мастер Search, который работает в

специализированном окне Windows Explorer (см. Экран 1) и позволяет выполнять

детализированный поиск внутри локальных и удаленных дисков или иных ресурсов.

Надо сказать, что в новом поисковом средстве наконец устранен ранее так

раздражавший пользователей недостаток: после отображения найденных файлов теперь

можно правой кнопкой мыши щелкнуть на нужном файле и открыть его.

Хотя в предыдущих версиях Windows и поддерживались различные языки, возможности

многоязыковой версии Windows 2000 Pro MultiLanguage просто поражают:

операционная система переключается с одного языка на другой даже без

перезагрузки. Кроме того, имеется возможность одновременной работы приложений,

интерфейс которых написан на французском и английском языках. В частности, можно

использовать французский в интерфейсе большинства задач, а английский -- при

просмотре, печати или создании документов. Когда появятся новые пакеты

расширений, такой же сервис будет обеспечен еще для двух десятков языков.

По сравнению с Windows 98, в новой ОС лучше реализована поддержка современного

оборудования, в частности в состав операционной системы включен

усовершенствованный Диспетчер устройств (Device Manager) (см. Экран 2,

позволяющего контролировать конфигурацию компьютера и состояние задействованной

аппаратуры. Что же касается мастера установки оборудования (Add/Remove Hardware

Wizard), то, несмотря на внешнее сходство с аналогичным компонентом Windows 98,

он стал намного мощнее. С помощью этого мастера можно установить новое

оборудование, осуществить его диагностику, произвести отключение как

стационарных, так и подсоединяемых в "горячем" режиме устройств. Разумеется,

Windows 2000 Pro поддерживает режим подключения Plug-and-Play (PnP), в котором

выполняет автоматическое конфигурирование аппаратуры и "горячее" подключение

модулей PC Card, аккумуляторов портативных компьютеров, а также использующих

шину USB периферийных устройств. Вместе с тем, операционная система больше не

работает с так называемыми унаследованными устройствами и некоторыми видами

мультимедийного оборудования.

Мастер сетевого подключения Network Connection Wizard, показанный на Экране 3,

тоже заметно упрощает работу с операционной системой. Как известно, в Windows

2000 Pro модуль панели управления Network and Dial-up Connections управляет

всеми видами сетевых соединений, включая коммутируемые и прямые, а также

осуществляемые через виртуальную частную сеть (VPN), сеть Ethernet и сетевую

плату. Что же касается мастера, то он облегчает выполнение процедур установки и

управления такими соединениями. В Windows 2000 два логически связанных модуля

объединены в рамках одного, поэтому работать с сетевыми компонентами здесь

намного удобнее. Вместе с тем, в Windows 2000 Pro нет средств создания различных

профилей для одного соединения. Например, вполне может возникнуть необходимость

в использовании параметров TCP/IP, которые задаются для подключения переносного

компьютера к локальной сети с настройками, отличными от мобильного варианта

подсоединения. Впрочем, в следующих версиях это ограничение обещают снять, а

выпускаемый независимыми компаниями инструментарий, например программа

NetSwitcher, должен помочь в управлении многочисленными сетевыми сеансами.

Целый ряд новых возможностей получили сетевые администраторы благодаря таким

технологическим компонентам, как групповые политики (Group Police), служба

каталогов Active Directory (AD), а также система централизованной синхронизации

данных в сетях Windows 2000 Pro, реализованная на базе технологии IntelliMirror.

Групповые политики облегчают администрирование пользователей с перемещаемыми

профилями, поскольку дают возможность прикрепить к их учетным записям или

учетным записям компьютеров конкретные программные приложения. Что же касается

технологии IntelliMirror, то она тоже поддерживает перемещающиеся профили и

предоставляет средства автоматизированной установки программного обеспечения.

При этом удаленная установка программ на компьютере с Windows 2000 Pro возможна

только тогда, когда аппаратное обеспечение поддерживает режим удаленной

загрузки. Здесь следует отметить, что для подготовки миграционных процедур в

масштабе предприятия можно использовать утилиту System Preparation.

Кроме того, Windows 2000 Pro, как и Windows 98, поддерживает стандарты Direct X

и OpenGL, а также включает программу дефрагментации диска, новое приложение

резервного копирования и утилиту очистки диска, подобную той, которая входила в

состав пакета Microsoft Plus! 98. Очень важно, что обеспечена поддержка

используемой в Windows 98 файловой системы FAT32 и, наконец, покончено с уже

надоевшей несовместимостью файловых стандартов Windows NT и Windows 9x. (Хотя

Windows 98 до сих пор не может читать тома NTFS, Windows 2000 и Windows NT

успешно обслуживают диски FAT32.) Здесь необходимо добавить, что Windows 2000

Pro теперь способна одновременно управлять несколькими мониторами и видеоплатами

и гарантирует полноценную работу оборудования соответствующего самым современным

стандартам, включая USB, IEEE 1394 (FireWire), AGP, DVD и Device Bay.

Итак, можно ли после всего этого сказать, что Windows 2000 Pro -- самая удобная

в использовании версия семейства Windows? Очевидно, да, поскольку разработчики

Microsoft ускорили выполнение многих процедур и упростили пользовательский

интерфейс. Вместе с тем, несколько очевидных упрощений разработчики все-таки не

сделали. Например, зачем профессиональным пользователям такая громоздкая система

помощи? Или, почему корпоративная операционная система использует такие общие

наименования, как My Computer и My Network Places, вместо того, чтобы

автоматически задействовать известные ей имена компьютера и домена? Тем не

менее, как уже говорилось, несмотря на ряд недостатков, Windows 2000 Pro заметно

усовершенствована по сравнению с предыдущими версиями.

Возникает вопрос: зачем использовать Windows 98, когда есть Windows 2000 Pro?

Здесь прежде всего нужно вспомнить о проблемах совместимости с имеющимся

оборудованием и программным обеспечением. Например, реализованная в Windows 2000

Pro аппаратная поддержка видеоплат, работающих со стандартами Direct3D и OpenGL,

мягко говоря, носит неупорядоченный характер. Так, у меня стоит включающая 12

Мбайт памяти видеокарта Voodoo 2, с которой Windows 2000 Pro не может полноценно

работать, ибо все имеющиеся для нее драйверы написаны еще для Windows NT 4.0.

Поскольку эти драйверы Direct3D не поддерживают, вопрос о том, можно ли будет

поиграть в современные игры, задавать просто бесмысленно. Однако нет сомнений,

что Microsoft со временем исправит положение, и Windows 2000 Pro, получив

необходимый комплект драйверов, превзойдет Windows 98 по всем статьям.

Представители Microsoft утверждают, что Windows 2000 Pro имеет более высокую,

чем Windows 98, производительность на компьютерах с объемом оперативной памяти

64 Мбайт и выше. Этому верить не стоит. Так, в случае работы с типовыми сетевыми

приложениями и пакетом Microsoft Office, на компьютере должно быть не менее 128

Мбайт оперативной памяти. Также следует иметь в виду, что для удовлетворения

своего "аппетита" в отношении аппаратных ресурсов Windows 2000 Pro поддерживает

до 4 Гбайт оперативной памяти и может работать с двумя процессорами. Если

появится такое желание, можно легко добавить в систему второй процессор с

помощью диспетчера устройств. (В Windows NT 4.0 для этого потребуется

воспользоваться соответствующими утилитами из Microsoft Windows NT Server 4.0

Resource Kit.)

Теперь уже вопрос звучит по-другому: а есть ли вообще смысл переходить с Windows

98 на Windows 2000 Pro? При условии, что рабочая станция с Windows 98

удовлетворяет минимальным аппаратным требованиям, ответ -- да. Например, если

компьютер работает на базе как минимум 300-мегагерцевого процессора Pentium II и

имеет не меньше 64 Мбайт памяти, то Windows 2000 Pro отлично на нем приживется.

Кроме того, как ни удивительно, при установке на портативные компьютеры с

указанной минимальной конфигурацией Windows 2000 Pro обгоняет Windows 98 по всем

показателям.

Поддержка мобильных компьютеров

Как вообще может Windows 2000 Pro хорошо работать на переносных компьютерах?

Ведь известно, что Windows NT 4.0 фактически покинула этот рынок из-за слабой

аппаратной поддержки и отсутствия адекватных средств управления электропитанием.

Нормальная работа NT 4.0 с ноутбуками возможна лишь при наличии программных

модулей расширения, поставляемых OEM-производителями. Тем не менее при

использовании Windows 2000 Pro, пользователям не придется обращаться за помощью

к независимым компаниям, поскольку эта операционная система предлагает отличную

технологию управления питанием, в том числе поддержку спецификации Advanced

Configuration and Power Interface (ACPI). При этом необходимо, чтобы в ноутбуке

была установлена совместимая с ACPI микросхема BIOS, выпущенная не позднее 1

января 1999г. Также необходимо отметить, что совместимые со стандартом Advanced

Power Management (APM) компьютеры смогут задействовать ограниченное число

функций ACPI. Например, пользователь ACPI-ноутбука способен перевести его в

режим пониженного энергопотребления, закрыв крышку или нажав кнопку Power, что,

само собой, не удастся сделать на переносных компьютерах, поддерживающих APM.

Изучив порядок работы пользователей портативных компьютеров с данными,

разработчики решили облегчить им доступ к информации в тех случаях, когда

сетевое соединение уже разорвано. Для этого в Windows 2000 Pro были введены два

компонента: мастер Offline Folders и диспетчер Synchronization Manager

(SyncMgr). Предположим, что владельцу ноутбука нужно получить данные из сети уже

после окончания сеанса. Он находит нужный ресурс, щелкает на нем правой кнопкой

мыши, а затем выбирает команду Make Available Offline. В результате запускается

мастер Offline Files, который помогает пользователю выполнить все необходимые

операции. При этом, как показано на Экране 4, можно выбрать режим автоматической

синхронизации файлов при каждом входе в сеть или выходе из нее, либо

использовать SyncMgr для ручной синхронизации. Кроме того, мастер Offline Files

позволяет задействовать окна напоминания уведомления об автономной работе и

ярлыки доступных в автономном режиме ресурсов.

Наследница Windows NT

Если судить по названию, Windows 2000 вполне можно счесть представителем

семейства Windows 9x, но на самом деле она построена на расширенном ядре Windows

NT 4.0. Благодаря этому операционная система характеризуется высокой

отказоустойчивостью и масштабируемостью, а главный залог ее преимуществ --

трехлетняя работа специалистов над ядром Windows NT, включающая развитие системы

защиты, исправление ошибок, выпуск пакетов исправлений, а также постоянное

совершенствование кода Microsoft Internet Explorer (IE), вплоть до версии 5.01.

В результате Windows 2000 Pro стала надежной платформой для разработчиков,

опытных пользователей, инженеров, профессиональных дизайнеров, а также для всех

тех, кому необходимо безотказное операционное окружение, способное работать 24 ч

в сутки.

При работе с Windows 2000 Pro нет необходимости так часто перезагружаться, как в

случае с Windows NT 4.0, где имеется 75 служебных операций, требующих

перезапуска системы (например, изменение сетевой конфигурации). В Windows 2000

Pro таких операций осталось только семь. Чтобы проверить это, я изменил IP-адрес

своей рабочей станции, включил и отключил режим Internet Connection Sharing, а

также выполнил ряд других изменений сетевых настроек. Пользователям Windows NT

или Windows 98 это покажется фантастикой, но перезагрузки не потребовалось. Мало

того, она не нужна и при установке сертифицированных для Windows 2000 Pro

аппаратных драйверов. Такая сертификация, выполняемая Microsoft с помощью

цифровой подписи, обеспечивает максимальный уровень защиты при установке нового

оборудования.

Кроме того, в Windows 2000 Pro реализован целый ряд защитных функций, которых не

было в Windows 98. Например, вводя пароль, можно выбрать режим шифрования

данных, как показано на Экране 5. Эта операционная система обладает

универсальной защитой, поскольку на локальном уровне использует файловую систему

Encrypting File System (EFS), на сетевом уровне -- протокол Kerberos, на уровне

Internet -- защитную инфраструктуру на базе открытых ключей (Public Key

Infrastructure, PKI), а на физическом уровне -- технологию интеллектуальных

карт. Таким образом, Windows 2000 Pro -- самая подходящая операционная система

для тех, кто беспокоится о неприкосновенности своей информации.

Входящий в Windows 2000 Pro модуль System File Protection (SFP) обеспечивает

защиту файлов .sys, .dll, .exe и .ocx. Эта очень полезная функция предотвращает

перезапись приложениями ключевых системных файлов их устаревшими или

модифицированными версиями. А поскольку такая перезапись чаще всего становится

причиной нестабильной работы, то благодаря SFP пользователям не придется

периодически перезагружать компьютер. Что же касается тех приложений, которые

используют Microsoft Installer (MSI), то они получают возможность автоматической

переустановки утраченных или поврежденных файлов.

Для повышения уровня безопасности и обеспечения соответствия приложений заданным

требованиям надежности, специалисты Microsoft разработали программу их

всестороннего тестирования на право получения сертификационных логотипов Windows

2000. При этом, хотя большинство приложений Windows NT 4.0 и Windows 9x

корректно устанавливаются и работают в Windows 2000, подобная сертификация

должна гарантировать безупречное функционирование системы.

Низкая стоимость владения

Поскольку эксплуатация и поддержка сетей Windows обходились довольно дорого,

разработчики Microsoft задались целью снизить стоимость владения Windows 2000.

Для этого в операционной системе был реализован ряд технологий, облегчающих

развертывание, установку, управление и поддержку сетевых конфигураций.

Близость архитектур Windows 2000 и Windows NT дает основания полагать, что

переход с NT на Windows 2000 пройдет успешно, в то время как в результате

миграции с Windows 9x на Windows 2000 Pro может возникнуть несовместимость с

новой ОС используемых программ и утилит. Поэтому, хотя перед началом работы

программа установки Windows 2000 и сообщает, какое оборудование и программное

обеспечение несовместимы с новой операционной системой, лично я не рекомендую

менять клиентские версии Windows 9x на Windows 2000, пока для этого нет веских

причин.

Особый вопрос -- управление Windows 2000 Pro. На первый взгляд разработчики

Microsoft очистили <густонаселенную> Control Panel от различных модулей и

средств администрирования (Windows 2000 Pro по умолчанию не отображает модули

системного инструментария), но фактически они просто перегруппировали различные

приложения, предназначенные для управления ОС. Так, многие функциональные

компоненты Windows NT и Windows 98 обнаруживаются в самых разных местах.

Например, найти панель управления службами теперь можно либо через Computer

Management, либо щелкнув на значке Administrative Tools на Control Panel.

Известно, что в Microsoft планируют выпускать пакеты расширений и другие

варианты обновлений Windows 2000 более упорядоченно, чем это имело место в

случае Windows NT 4.0. Так, пакеты расширений будут использоваться только для

исправления ошибок, а не для ввода в операционную систему новых компонентов. В

отличие от процедур установки Service Pack в Windows NT, администраторы смогут

загрузить из пакетов исправлений обновленные файлы в размещенную на сервере

папку i386, т. е. будет поддерживаться один источник всех системных файлов с

последней версией Service Pack. В результате последующие инсталляции Windows

2000 будут содержать все необходимые исправления, и отдельно загружать пакеты

исправлений не понадобится. Также не придется переустанавливать приложения после

обновления операционной системы. Данная возможность реализована и в пакете

Windows 2000 High Encryption Pack, расширяющем систему усиленным 128-разрядным

алгоритмом шифрования. После того как в папку i386 добавляются необходимые файлы

и каталоги, функция усиленного шифрования будет автоматически включена во все

новые установки Windows 2000.

В целях снижения общей стоимости владения специалисты Microsoft снабдили Windows

2000 Pro рядом других функций, в том числе новой утилитой диагностики при

загрузке, которая запускается нажатием клавиши F8. Подобно Windows 98, новая ОС

предоставляет в процессе загрузки доступ к командной строке Recovery Console, не

требуя при этом перехода в графический режим. Режим консоли восстановления

доступен и при загрузке с установочного компакт-диска.

Работа в Internet

Необходимо сказать несколько слов об интеграции интерфейса Windows 2000 Pro с

Internet. В ходе бета-тестирования Windows 98 разработчики пытались перенести в

Windows Explorer принятый в Internet метод открытия файловых ресурсов

однократным щелчком мышью. Они полагали, что такой подход позволит унифицировать

работу пользователей. Тем не менее многочисленные жалобы заставили Microsoft

отказаться от этого решения и оставить в Windows 2000 и Windows 98 привычный

интерфейс, сохранив, однако, возможность выбора Web-интерфейса в качестве

основного. В Windows 2000 Pro активный рабочий стол также ушел на второй план

(он по умолчанию выключен), хотя доступ к нему весьма прост. Кроме того, из

браузера убрана порядком надоевшая панель доступа к сетевым каналам, ранее

присутствовавшая в Internet Explorer 4.0.

Следует отметить, что функция Personalized Menus в Windows 2000 Pro,

задействованная в меню Start, работает еще и в IE, в меню Favorites. При этом,

хотя я использую персональные меню, должен признать, что добавление этой функции

в Internet Explorer 5.0 было ошибкой. Дело в том, что в Favorites включены те

элементы, которые пользователь всегда хочет видеть перед собой, и операционная

система не должна их прятать. Для отключения функции нужно выбрать

Tools/Internet Options и во вкладке Advanced сбросить флажок Enable Personalized

Favorites Menu.

Как мне кажется, большинство пользователей вполне довольны интеграцией Internet

Explorer в Windows. Тем не менее фундаментальный уровень этой интеграции в

Windows 2000 Pro порой наводит на размышления. В частности, хочется надеяться,

что она не станет источником проблем для пользователя (известно, что в Internet

Explorer 5.0 еще не исправлено несколько ошибок в системе безопасности). Однако

только время покажет, каким образом объединение браузера и Windows 2000 влияет

на стабильность работы и надежность операционной системы.

Некоторые выводы

Хотя выпуск новых версий ОС подобных Windows 2000 Pro всегда влечет за собой

немало проблем, разработчики Microsoft изначально сумели предоставить

пользователям те возможности, которых они ждали, реализовав все нововведения

достаточно логично.

Вместе с тем, необходимо понимать, что Windows 2000 Pro вовсе не является

универсальной операционной системой. Например, любителям игр лучше иметь дело с

Windows 98, которая совместима с куда более широким спектром программного

обеспечения и оборудования, а также устаревших устройств. Что же касается

Windows 2000 Pro, то она отлично проявляет себя в таких недоступных для Windows

98 областях, как защита информации, надежность и масштабируемость.

Я считаю Windows 2000 Pro лучшей настольной операционной системой для

предпринимателей, мобильных пользователей, профессиональных дизайнеров и

разработчиков программного обеспечения. Именно поэтому настоятельно рекомендую

всем, кто располагает необходимым оборудованием, как можно скорее самим оценить

всю мощь этой изящно построенной и функционально богатой операционной среды.

Поль Тюрро - Редактор новостей в Windows 2000 Magazine. Готовит еженедельные

выпуски Windows 2000 Magazine UPDATE (http://www.win2000mag.net/email), а также

ежедневные выпуски новостей WinInfo (http://www.wininformant.com). С ним можно

связаться по адресу: thurott@win2000mag.com


Как укротить Windows ME

Andy Mad, Компьютерная газета

Пользователи компьютеров часто сталкиваются с проблемой: они хотят использовать

самое современное программное обеспечение (там ведь больше функций и наворотов),

играть в самые современные игры (они ведь более реалистичны), но, установив все

это счастье на компьютер, часто не испытывают должного удовлетворения, ибо

действительно качественно новые игрушки и новые операционные системы часто

требуют и нового железа:(.

Windows ME я, пожалуй, не отношу к особо прожорливым, так как свежи еще в памяти

впечатления от работы Windoze 2k на 64 Мб ОЗУ. Нет, система эта в общем ничего:

интерфейс ala Win2k, Media Player 7, Internet Explorer 5.5 и т.д. Но есть и

неприятные моменты: system restore, file protection - в общем, все, что

называется PC Health.

Несмотря на то, что это везде преподносится как самая продвинутая фишка системы

и что это то, что ее качественно отличает, я считаю, что это не более чем

баловство. Я убрал из своей системы PC Health, я довольно часто скачиваю из

Internet'а и устанавливаю различные программки, порой абсолютно бесполезные, но

это уже мои проблемы. Так вот ничего страшного с моим компьютером не происходит,

как не происходило и когда у меня стояла 98-я. Если уж система и "ляжет", то

это, как правило, происходит или из-за собственных кривых ручек (знаете "нечего

на зеркало пенять, коль рожа крива"?), или потому, что вышел срок свежести

системы (характерно для всех систем 9x). В любом случае опытный пользователь

знает единственное 100% лекарство - догадайтесь сами какое:).

Итак, перед нами задача - получить современную систему, но при этом сохранить

контроль над ней и над ее производительностью. Здесь возможны два варианта.

Первый заключается в том, что вы устанавливаете Windows 95 OSR2 (нет, это не

опечатка, именно 95), затем ставите на нее Internet Explorer 5.0 (помимо

довольно мощного браузера, вы обретете и Active Desktop, и Quick Launch-панель)

и Media Player 6.4. Я не шучу - вы действительно получите быструю современную

операционную систему.

Второй случай подходит для тех, кого, как и меня, угораздило поставить на свой

компьютер шедевр программисткой мысли под названием Windows Millennium Edition.

Эта статья как раз для вас.

Первое, что необходимо сделать после установки Windows ME, это щелкнуть правой

кнопкой мыши по My computer, выбрать Properties\Performance\File

System\Troubleshooting и поставить галочку возле Disable System Restore. Заодно

там же щелкните по закладке Floppy Disk и снимите галочку с Search for new

floppy disk drives each time your computer starts, чтобы при загрузке винда не

искала новые дисководы, тормозя тем самым весь процесс.

Дальше нажимайте везде OK, система предложит вам перезагрузиться, с чем

необходимо согласиться.

Отключив System Restore, мы лишь надломили лед, однако до полного ликования еще

далеко. Дело в том, что система PC Health для своего функционирования должна

постоянно собирать информацию о состоянии системы.

Она ее собирает каждые 24 часа или каждые 10 часов непрерывной работы, смотря,

что наступит раньше. А коль в нас жив дух экспериментаторства и мы решили

отказаться от PC Health, то логично было бы отключить этот сбор информации. Во-

первых, направляемся в Control Panel\ Scheduled Tasks, там уже прописаны две

задачи. Нас будет интересовать та, что содержит слова PC Health. Щелкните по ней

правой кнопкой мыши, выберите Properties и на первой же закладке снимите галочку

с Enabled (scheduled task runs at specified time). Можно поступить еще проще:

вместо Properties, выберите Delete:).

Во-вторых, открываем Regedit.exe и идем по такому пути:

HKLM\Software\Microsoft\Windows\CurrentVersion\Run. Там будет находиться

параметр PC Health, значение которого будет "C:\WINDOWS\PCHealth\Support\

PCHSchd.exe -s" (я предполагаю, что винда у вас установлена в директорию

C:\Windows, если нет, то путь будет другим). Щелкаем правой кнопкой по этому

параметру и выбираем Delete. Далее направляемся в HKLM\

Software\Microsoft\Windows\CurrentVersion\RunServices, там расстрелу подвергаем

по крайней мере два параметра: *StateMgr "C:\WINDOWS\System\Restore\

StateMgr.exe" и LoadPowerProfile "Rundll32.exe powrprof.dll,

LoadCurrentPwrScheme". Последний параметр, надо сказать, не имеет отношения к PC

Health, однако аналогичная запись уже имеется по адресу

HKLM\Software\Microsoft\Windows\CurrentVersion\Run, так зачем же два раза

грузить одно и то же? Если вы не используете Планировщик, то удалите также

SchedulingAgent.

Все, закрываем Regedit и перезагружаем компьютер. Могу вас поздравить: вы только

что разделались с System Restore! Переходим к следующему компоненту системы PC

Health - System File Protection (SFP). Если вы все же склонны сохранить SFP, то

можете пропустить несколько абзацев этой статьи и продолжить чтение с того

места, где речь пойдет про возрождение Real DOS Mode. Единственное, что я вам

порекомендую, это повернуть SFP к себе лицом, а к лесу...

Дело в том, что в System File Protection for Windows ME по умолчанию отключен

режим оповещения о том, что SFP производит восстановление файлов. Для того чтобы

включить этот режим, зайдите в реестре по адресу HKLM\SOFTWARE\

Microsoft\Windows\CurrentVersion\SystemFileProtection, там будет находиться

параметр ShowPopups типа dword. Присвойте ему значение 1, закройте Regedit и

перезагрузите компьютер.

Ну, а те, кто, как и я, считают, что SFP нужна грамотному пользователю, как

зайцу стоп-сигнал, открывают любимый Regedit и направляются по адресу

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ VxD\VxDMon. Что мы там

наблюдаем? Параметру SystemRestore присвоено значение N (No). Ясное дело, мы ж

его сами и вырубили в самом начале.

А вот параметру SystemFileProtection по-прежнему присвоено значение Y (Yes). Что

ж, исправим несправедливость: щелкнем два раза по SystemFileProtection и введем

N. Далее, как всегда, закроем Regedit и перезагрузим компьютер.

Вот теперь можем сказать, что мы отключили большую часть системы PC Health. В

таком состоянии находилась моя система примерно несколько месяцев со дня

установки. Но в один прекрасный день мне понадобилось изменить (уж не помню и

зачем) размер Swap-файла.

После перезагрузки системы я с удивлением обнаружил, что на диске

катастрофически уменьшился объем свободного пространства.

Оказалось, что Windows, помимо создания нового Swap-файла, сохранила старый в

папке _Restore\Temp! Какими соображениями вызван столь "умный" поступок системы,

сказать тяжело, но проблема еще усугублена тем, что удалить этот файл из-под

винды невозможно, а так просто перезагрузиться в режиме эмуляции MS-DOS (как это

было в 98-й), чтобы почистить директорию _Restore\ Temp, также затруднительно.

Так что пришлось лезть в BIOS, грузиться с дискеты, исправлять недоразумение

Windows, потом опять лезть в BIOS, опять ставить Boot Sequence=C only... В

общем, было принято решение окончательно деинсталлировать PC Health.

Сделать это достаточно просто. Сначала зайдите в Regedit и удалите этот ключ:

HKEY_ LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VxDMon, после чего

перезагрузите машину. Затем выберите в меню Start команду Run, там введите

rundll.exe setupx.dll,InstallHinfSection Uninstall 132 C:\WINDOWS\

INF\PCHealth.inf (я предполагаю, что винда у вас установлена в папку C:\Windows)

и нажмите ввод. Система пару секунд пошуршит винчестером, мол она Updating

System Configuration - и все, PC Health для вас история:).

Осталось только немного почистить реестр. В частности, удалить такие ключи:

HKEY_ CURRENT_USER\Software\Microsoft\PCHealth, HKEY_CURRENT_USER\

Software\Microsoft\Active Setup\ Installed Components\PerUser_ PCHealth,

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed

Components\PerUser_PCHealth. Также поищите в реестре все ссылки на StateMgr.exe

(скорее всего вы ничего не найдете, но для профилактики желательно поискать) и

удалите их.

Теперь наконецто вы сможете сделать то, о чем вы (я уверен) мечтали уже давно,

но боялись в этом признаться - удалить к такой-то матери папки _Restore со всех

своих дисков. Windoze вам в этом препятствовать отныне не будет.

Но деинсталляция PC Health не проходит бесследно. Есть два последствия, с

которыми, впрочем, легко справиться. Во-первых, вы больше не сможете вызвать

виндозный Help, выбрав соответствующий пункт в главном меню, открывающемся при

нажатии кнопки Start. Проблема в том, что в Millennium система помощи тесно

интегрирована в систему PC Health, которую мы только что сами... Но

расстраиваться нет причины! Ведь Help никуда не делся, он по-прежнему лежит в

C:\Windows\Help. То есть в любой программе вы можете выбрать пункт меню Help

(или нажать F1) и получить доступ к системе справки. В принципе, так и делают

все нормальные люди, и скажите, вы вообще пользуетесь пунктом меню Start\Help?

Так что я предлагаю избавиться от него, чтоб глаза не мозолил. Для этого опять

придется слазить в реестр: по адресу HKEY_CURRENT_USER\Software\

Microsoft\Windows\CurrentVersion\Policies\Explorer создайте новый параметр

(Binary Value) NoSMHelp и присвойте ему значение hex:01,00,00,00.

После этого перезагрузите компьютер.

Второе последствие - вместе с громоздкой системой справки вы больше не сможете

выбрать пункт меню Start\Programs\Accessories\System Tools\ System Information

для того, чтобы ознакомиться с информацией о системе. И опять-таки

расстраиваться нет абсолютно никаких причин.

Вы когда-нибудь запускали System Information в Millennium Edition? Большей

тормознутости и неповоротливости и вообразить нельзя! Не нужна нам такая System

Information, вот то ли было дело в 98-й...

Хм, решение пришло само собой: почему бы не использовать System Information из

Windows 98 в Millennium? Найдите какой-нибудь дистрибутив Windows 98, причем

неважно на каком языке - у меня Windows ME английская, а все дистрибутивы 98-й,

что смог найти на компактах, - русские. Нас интересуют два файла: msinfo32.chm и

msinfo32.exe.

В различных вариантах дистрибутива они могут находиться в разных архивах (в моем

случае msinfo32.chm был в win98_27.cab, а msinfo32.exe - в win98_40.cab), так

что воспользуйтесь какой-нибудь искалкой файлов, которая может копать внутри

архивов, например, встроенным Search в Windows Commander'е. Далее перепишите

файл msinfo32.chm в каталог C:\Windows\Help, а файл msinfo32.exe - в C:\Program

Files\ Common Files\Microsoft Shared\ MSInfo. Затем создайте ярлык на

msinfo32.exe и наслаждайтесь жизнью.

Как-то поставил Windows ME на один компьютер, на котором запускался старый

(досовский еще) редактор/компилятор ассемблера. Ассемблер тот был под один

специфический процессор, и версии редактора под Windows просто не существовало.

Неожиданно возникла проблема: редактор наотрез отказывался набирать русским

шрифтом комментарии к процедурам. Единственное, что могло решить проблему, -

наличие в памяти старого русификатора keyrus (помните такой?:)). А как прикажите

загрузить досовский резидент в Millennium? Любое вмешательство в autoexec.bat

или config.sys в этой операционной системе будет проигнорировано, а

соответствующие файлы исправлены. Что ж, безвыходных ситуаций не бывает, и этой

проблеме также нашлось решение. Все заявления по поводу того, что в Millennium

наконец-то покончено с real MS-DOS режимом, не совсем корректны. На самом деле

real DOS в этой операционной системе есть (да и как могло быть иначе, корни-то

9x), просто по умолчанию он хорошенько запрятан. А коль уж в нем возникла

необходимость, то попытаемся его вернуть.

Для начала сходите сюда - http://www.geocities.com/mfd4life_2000/. Скачайте

небольшой архив, содержащий необходимый patch. Дальше создайте где-нибудь на

диске каталог, скажем, backup, куда скопируйте следующие файлы: c:\io.sys,

c:\windows\command.com и c:\windows\system\regenv32.exe. Храните эти файлы в

сухом и теплом месте на тот случай, если захотите вернуться к первоначальной

конфигурации Windows. Создайте еще одну директорию, например, temp, куда

скопируйте вышеупомянутые три файла, а также скаченный patch (winmedos.com).

Запустите winmedos.com, затем "пропатченные" файлы скопируйте соответственно:

io.sys - в c:\, соmmand.com - в c:\ и в c:\windows, regenv32.exe - в

c:\windows\system. Добавьте в файл config.sys такую строку:

DEVICE=C:\WINDOWS\IFSHLP.SYS, а в файл autoexec.bat - C:\WINDOWS\WIN.COM.

Перезагрузитесь. Отныне вы можете использовать autoexec.bat и config.sys, как в

старые добрые времена, а также при загрузке Windows нажать F8 и выбрать режим

эмуляции MS-DOS:).

Хочу только добавить, что если у вас нет действительно веской причины к возврату

к real DOS mode, то просто так, для интереса делать это все же не стоит.

Еще есть такая штука в новой операционке, как Automatic Update: это когда вы

соединитесь с провайдером, Windoze будет самостоятельно соединяться с

Microsoft'овским сайтом и может даже качать апгрейды. Вы, я надеюсь, в Интернет

выходите не для того, чтобы винду проапгрейдить? Если и появится действительно

стоящая примочка, то вот ее целенаправленно и можно качнуть, а так... Вы, я

думаю, уже поняли намек: Control Panel\Automatic Updates, там поставить галочку

напротив Turn off automatic upgrading и нажать OK.

Следующее, о чем я хочу рассказать, относится к категории "это должен

знать/сделать каждый, кому небезразлична производительность своей системы". В

Windows 98 SE по умолчанию был включен режим, заставляющий операционную систему

сразу выгружать неиспользуемые библиотеки процедур из памяти после закрытия

программы, эти библиотеки загрузившей. Преимущества такого подхода были мной

изложены в статье "Управляем памятью компьютера" (один из декабрьских номеров

КГ). Я же предлагаю включить этот режим в Millennium. Для этого в реестре по

адресу HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Windows\ CurrentVersion\Explorer\

создайте строковой (String) параметр AlwaysUnloadDLL и присвойте ему значение 1.

Кстати сказать, там же создайте еще один строковой параметр Max Cached Icons

(обратите внимание на пробелы) и присвойте ему значение, скажем, 2000. Это

позволит Windows создать больший кэш иконок (файл ShellIconCache в директории

C:\Windows), что в совокупности с предыдущим параметром значительно может

повысить скорость работы GUI.

Если у вас меньше 256 Мб памяти, то вы просто не можете закрывать глаза на

настройки дисковой системы. Во-первых, убедитесь, что ваш винчестер работает в

режиме UDMA, если он, конечно, не очень древний. Во-вторых, настройте размеры

swap-файла и Hard disk кэша, используя информацию, представленную в таблице 1.

Swap-файл настраивается здесь - Control Panel\System\ Performance\Virtual

Memory. Не забудьте только главный принцип, обеспечивающий максимальную

производительность, - swap-файл должен быть постоянен (минимальный и

максимальный размеры должны совпадать) и нефрагментирован (дефрагментируйте его

с помощью Norton Speed Disk, где поставьте галочку напротив Optimize Swap-file).

Таблица 1. Настройки Swap-файла и кэша для диска

Размер ОЗУ MinFile Cache MaxFile Cache Swap File Size

16 МБ:) 1024 4096 40 МБ

32 МБ 2048 8192 128 МБ

64 МБ - 16384 160 МБ

96 МБ - 32768 140-150 МБ

128 МБ - - 128 МБ

160 МБ - - ~100 МБ

192 МБ - - 64 МБ

256 МБ - - Отключить!

Минимальный размер кэша для диска устанавливается так: откройте файл system.ini

и в разделе vcache пропишите параметр MinFileCache=x (где x - количество

килобайт).

Для настройки максимального размера кэша пропишите там же параметр

MaxFileCache=x. Не забудьте перезагрузить компьютер.

Несколько комментариев к таблице 1. Прочерком обозначены те случаи, когда ничего

настраивать не надо. Так, в большинстве случаев не имеет смысла прописывать

параметр MinFileCache=x в файле system.ini.

Если у вас 128 Мб памяти и больше, то вам вообще нет необходимости настраивать

параметры Vcache. При таком объеме памяти Windows ME (а также и 98) вполне

способна самостоятельно управлять размером кэша, обеспечивая наибольшую

производительность.

Что, не верите? Ну, тогда направляйтесь сюда: http://www.

rojakpot.com/Speed_Demonz/Disk_ Cache_Optimization/Disk_Cache_

Optimization_01.htm. Здесь автор сайта проводит ряд тестов с различными

настройками Vcache на 128 Мб RAM (Disk WinMark, Business Winstone, Turok, Half-

Life, 3D Mark 99) и в конечном итоге приходит к выводу, что при таком объеме ОЗУ

настраивать самостоятельно Vcache не имеет смысла.

Часто можно встретить советы по настройке Chunksize - размера блока (в байтах),

на которые разбивается Disk Cache (настраивается все в той же секции vcache

файла system.ini). Да, действительно, этот параметр сказывается на

производительности, хотя и очень незначительно.

Вся соль в том, что виндозное значение по умолчанию - 512 байт - является уже во

многих случаях оптимальным, так что ничего править не нужно. За деталями

отправляйтесь на http://www. rojakpot.com/

Speed_Demonz/Chunksize_Optimization/Chunksize_Optimization_01.htm.

В Windows можно еще настроить и количество файлов (имеются в виду имена файлов)

и директорий, которые будут кэшироваться.

По этому поводу многие советуют выставить Typical Role компьютера как Network

Server. Что ж, мысль здравая, только в этом случае кэшироваться будут лишь 2729

файлов и 64 директории, на что будет выделено всего 40 килобайт ОЗУ. Но нам

никто и ничто не мешает еще больше повысить производительность дисковой системы

и установить размер кэша для имен файлов и директорий, скажем, раза в 3 больше,

то есть 150 килобайт. Это приведет к тому, что Windows сможет кэшировать уже

одновременно 6144 файла и 200 директорий! Открываем Regedit, заходим в

HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\ Windows\CurrentVersion\FS Templates\.

Там уже будут 3 ключа, отвечающие за 3 основные роли вашего компьютера -

Desktop, Server, Mobile. Создаем по аналогии новый ключ, скажем, New cache,

присваиваем ему имя (два раза щелкните по слову Default и введите, например, My

cool cache).

Затем в нашем ключе создаем два параметра (Binary) - NameCache и PathCache.

Присваиваем параметру NameCache значение hex: 00,18,00,00, а параметру PathCache

- hex: c8,00,00,00. Дальше заходим в Control Panel\System\Performance\File

System\Hard Disk и выбираем в выпадающем списке Typical role of this computer

наш "My cool cache".

Вы можете поэкспериментировать и с другими размерами кэша. Насколько мне

известно, максимально возможное значение для NameCache составляет hex:

00,ff,00,00 (65280 файлов), а для PathCache - hex: ff,00,00,00 (255 директорий).

Но учтите, что в последнем случае Windows придется выделить 2,1 Мб под кэш, так

что устанавливайте такие большие значения, только если у вас не менее 128 Мб

памяти.

Пожалуй, это основное, что должен сделать каждый пользователь, чтобы получить

удовольствие от работы в новой операционке от Microsoft.

А посему разрешите откланяться.


Подборка советов по настройке и работе в Windows XP

Данная подборка советов была прислана Vitaly Nevzorov. Если найдется их автор, обращайтесь ко мне, я дам здесь ссылку на ваш сайт.

Наткнулся на одном сайте (уже не помню где) на описания некоторых настроек в XP, некоторые работают и для предыдущих версий, цитирую все, как есть:

1. Если предыдущие версии Windows скрывали, как долго они способны работать без перезагрузки, то ХР в этом плане есть чем гордиться. Войдите в командную строку из меню Accessories, которое вызывается стартовой кнопкой All Programs, и наберите systeminfo. Компьютер выдаст много полезной информации, в том числе время бесперебойной работы. Для сохранения этих данных в файле наберите systeminfo > info.txt.

2. Для того чтобы удалять файлы, не сохраняя их в "мусорной корзине", выберите Run... из меню Start и наберите gpedit.msc, затем выберите User Configuration, Administrative Templates, Windows Components, Windows Explorer и отметьте флажком Do not move deleted files to the Recycle Bin. Покопавшись в gpedit, можно найти массу параметров интерфейса и системы, однако будьте осторожны: некоторые из них могут привести к нежелательному поведению компьютера. (Это работает только в Professional Edition.)

3. Рабочую станцию ХР можно запереть двумя щелчками мыши. Кликнув на рабочем столе правой кнопкой, создайте новый ярлык и введите в поле location строку rundll32.exe user32.dll,LockWorkStation. Присвойте этому ярлыку какое-нибудь имя. Теперь двойным щелчком по нему вы сможете блокировать свой компьютер. Того же эффекта можно добиться сочетанием клавиш Windows + L.

4. XP скрывает отдельные элементы системного ПО, которые кто-то, возможно, захочет удалить. Это может быть, например, Windows Messenger. Пользуясь редактором Notepad или Edit, исправьте текстовый файл /windows/inf/sysoc.inf, найдя и удалив в нем слово hide. Затем войдите в меню Add or Remove Programs на панели управления, выберите Add/Remove Windows Components и вам откроется все, что было сокрыто.

5. Тем, кто владеет искусством работы с пакетными файлами DOS, ХР предлагает ряд интересных новых команд. В их числе eventcreate и eventtriggers для создания системных событий и слежения за ними, typeperf для контроля за производительностью различных подсистем и schtasks для управления запланированными задачами. Как обычно, /? после имени команды выдает список опций - их слишком много, чтобы перечислять здесь все.

6. В ХР есть поддержка IP версии 6 - интернет-протокола нового поколения. К сожалению, такой поддержки нет у вашего ISP, поэтому экспериментировать с ней можно лишь в пределах локальной сети. Введите ipv6 install в поле Run... (не беспокойтесь, текущие сетевые настройки от этого не пострадают), а затем наберите ipv6 /? в командной строке, чтобы получить дополнительную информацию. Если вы не знаете, что такое IPv6, не переживайте и не утруждайте себя.

7. Наконец-то появилась возможность снимать задачи из командной строки. Наберите taskkill /pid и номер задачи или просто tskill и номер процесса. Номер можно узнать, набрав команду tasklist, которая вдобавок сообщит многое о том, что происходит в вашей системе.

8. XP считает файлы Zip папками - это удобно, если у вас быстрая машина. На более медленных системах можно заставить ХР отказаться от такой практики, набрав в командной строке regsvr32 /u zipfldr.dll. Позднее, если вы передумаете, можно все вернуть назад командой regsvr32 zipfldr.dll.

9. В ХР встроена технология сглаживания шрифтов на экране ClearType, но по умолчанию она выключена. Ее стоит попробовать, особенно если вы начинали с DOS и пялились на экран все эти годы, заработав астигматизм. Чтобы включить ClearType, кликните правой кнопкой мыши на десктопе, выберите Properties, Appearance, Effects, затем найдите во втором падающем меню ClearType и разрешите эту опцию. Лучшие результаты получаются на лаптопах. Если вы хотите использовать ClearType и на экране приветствия Welcome, присвойте параметру HKEY_USERS/.DEFAULT/Control Panel/Desktop/FontSmoothingType в реестре значение 2.

10. Вы можете помочь приятелю, который работает в домашней сети и пользуется трансляцией сетевых адресов (NAT), применив механизм удаленного доступа, но не сразу. Сначала попросите друга прислать вам e-mail с приглашением Remote Assistance, предварительно отредактировав файл. В атрибуте RCTICKET указан IP-адрес NAT, например 192.168.1.10. Его надо заменить действительным IP-адресом вашего приятеля - он может определить его, посетив сайт www.whatismyip.com, - и пусть он убедится, что в его брандмауэре порт 3389 открыт и переадресован на проблемный компьютер.

11. Вы можете исполнять программы от имени другого пользователя без выхода из системы и повторной регистрации. Кликните на значке правой кнопкой, выберите Run As... и введите имя пользователя и пароль. Они будут действовать до окончания текущего сеанса работы. Это особенно полезно, когда нужно получить права администратора для установки программы, что случается очень часто. Имейте в виду, что многократно исполнять программы под разными именами - занятие увлекательное, но оно может привести к непредсказуемым эффектам.

12. Windows XP проявляет настойчивость в отношении автоматической проверки апдейтов, регистрации в системе Passport, использования Windows Messenger и т.п. Со временем вы привыкните, но, если чувствуете, что не доживете до этого момента в здравом уме, запустите Regedit, войдите в HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer/Advanced и создайте параметр DWORD с именем EnableBalloonTips и значением 0.

13. Можно начинать работать, не набирая имени пользователя и пароля. Выберите Run... из стартового меню и наберите control userpasswords2, что приведет к открытию приложения, управляющего учетными записями пользователей. На вкладке Users удалите флажок у позиции Users Must Enter A User Name And Password To Use This Computer и кликните ОК. Появится диалоговое окно Automatically Log On; введите имя пользователя и пароль для нужной учетной записи.

14. Internet Explorer 6 можно настроить на автоматическое удаление временных файлов. Запустите браузер, выберите Tools / Internet Options... и Advanced, спуститесь до раздела Security и отметьте позицию Empty Temporary Internet Files Folder When Browser is Closed.

15. К ХР прилагается бесплатный индикатор работы сети на тот случай, если вам не видно светодиодов на сетевой плате. Кликните правой кнопкой на My Network Places на рабочем столе и выберите Properties. Кликните правой кнопкой на ярлыке своей локальной сети или dial-up соединения, выберите Properties и активизируйте значок Show в зоне оповещения о работе в сети. Теперь при наличии сетевого трафика в правой части панели задач вам будет весело подмигивать маленький значок сети.

16. Меню Start, когда оно решит появиться, может показаться медлительным, но этот процесс можно ускорить, уменьшив значение параметра реестра HKEY_CURRENT_USER/Control Panel/Desktop/MenuShowDelay, которое по умолчанию равно 400. Сделайте его, например, нулевым.

17. В Windows Explorer файлы можно переименовывать скопом. Выделите в окне группу файлов, кликните правой кнопкой по одному из них и, если нужно, переименуйте его. Все выделенные файлы получат имя указанного файла с индивидуальными номерами в скобках. Кроме того, значки в папке можно организовать в упорядоченные по алфавиту группы - для этого выберите View, Arrange Icon By... Show In Groups.

18. Windows Media Player в процессе воспроизведения треков отображает обложки альбомов если находит их изображение в Интернете во время копирования трека с CD. В противном случае, а также если у вас большая библиотека музыкальных файлов WMP, вы можете поместить свою собственную копию изображения обложки в тот же каталог, где хранятся записи. Просто назовите ее имя_каталога.jpg, и Windows Media Player найдет и выведет эту картинку.


Настройки Windows с помощью реестра

ПРЕДУПРЕЖДЕНИЕ! Некоректное изменение реестра опасно для здоровья Вашего

компьютера! Будьте бдительны и аккуратны!

Некоторые изменения вступают в силу только после перезагрузки Windows.

1. Как создать команду, применяемую ко всем типам файлов.

В разделе HKEY_CLASSES_ROOT\ *\ Shell\ создать раздел с любым названием, скажем

Command1 (значение строкового параметра "Команда 1"), в это разделе создать

раздел Command. Значение строкового параметра задать равным вашей команде,

например, чтобы создать команду "Открыть блокнотом" строка следующая:

HKEY_CLASSES_ROOT\ *\ Shell\ Command1\ Command = "Notepad "%1"". Проверка:

щелкнуть на любом файле правой кнопкой - в контекстном меню должна появится

команда "Команда1"

2. Как создать команду, применяемую к незарегистрированным типам файлов.

Например: вы частенько сталкивались с файлами типа readme.!!!. Согласитесь

довольно нудно открывать их с помощью диалога "Открыть с помощью:"

HKEY_CLASSES_ROOT\ *\ Shell\ Open\ Command = "Notepad "%1""

3. Как создать команду, применимую к любой папке, диску и т.п.

В разделе HKEY_CLASSES_ROOT\ Folder\ shell создайте новый раздел, назвав его

своим именем (например "Огого"). В параметре "По умолчанию" задайте имя команды

(например "Команда Огого"). Создайте раздел Command в разделе "Огого" и запишите

свою команду.

4. Как заменить программу блокнот на другую программу.

HKEY_CLASSES_ROOT\ Txtfile\ Shell\ Open\ Command = "C:\ Windows\ notepad "%1"" -

так в оригинале. Замените notepad на др. программу, только укажите полный путь к

ней.

5. Как скрыть значки логических дисков.

HREY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создать парметр DWORD NoDrives. Установите следующие значения для

скрытия дисков (значения в шестнадцатеричной системе):

A:+B: = 3

C: = 4

D: = 8

E: = 10

F: = 20

A+B+C=7

A+B+D=b

A+B+E=13

A+B+F=23

C+D=c

D+E=18 и т.д.

Скрыть все значки = 0x03ffffff

6. Как скрыть все значки с рабочего стола.

HREY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создать параметр DWORD NoDesktop =1 (=0 - все значки видны)

7. Как скрыть значок Корзина с рабочего стола.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\

explorerDesktop\ NameSpace\ {645FF040-5081-101B-9F08-00AA002F954E} = (ух !!!

устал писать :-)) = "Корзина". Если удалить раздел {:} - значок Корзина исчезнет

со стола.

8. Как изменить имя значка "Корзина".

HKEY_CLASSES_ROOT\ CLSID\ {645FF040-5081-101B-9F08-00AA002F954E} = "Корзина".

Если изменить слово корзина на другое, например "Отходы", то на рабочем столе

будет соответственно "Отходы", а не "Корзина".

9. Как убрать слова "Ярлык для" из названия ярлыка.

HKEY_USERS\.DEFAULT\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

параметр link должен быть равным 00 00 00 00.

10. Как изменить буквенное обозначение CD-ROM.

Можно обойтись стандартными средствами доступными пользователю. Панель

управления - Система - Устройства - Контролеры компакт дисков. Далее вызвать

свойства и назначить букву.

11. Как скрыть меню Выполнить в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoRun = 1 - включено, 0 - выключено.

12. Как скрыть меню Найти в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoFind = 1 - включено, 0 - выключено.

13. Как скрыть меню Избранное в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoFavoritesMenu = 01 00 00 00 - включено, 00 00 00 00

- выключено.

14. Как скрыть меню Документы в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoRecentDocsMenu = 01 00 00 00 - включено, 00 00 00 00

- выключено.

15. Как скрыть меню Завершение сеанса в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoLogOff = 1 - включено, 0 - выключено.

16. Как скрыть в меню Пуск меню :

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр и задайте значение 1 (включено) или 0 (выключено).

NoSetFolders = 1 в меню Настройка будут скрыты Принтеры и Панель управления.

(аналогично в папке Мой компьютер).

NoSetTaskbar = 1 - в меню Настройка будут скрыты Панель задач и меню Пуск.

17. Как скрыть меню Завершение работы в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте парметр NoClose = 1 - включено, 0 - выключено.

18. Как скрыть имя пользователя в диалоге при загрузке Windows.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Winlogon

создайте парметр DontDisplayLastUserName = 1 - имя пользователя показано не

будет, 0 - будет.

19. Как выключить видеоэффект при сворачивании окон.

HKEY_CURRENT_USER\ Control Panel\Desktop\Windowsmetrics создайте парметр

MinAnimate = 0 - выключено.

20. Как включить в работу третью кнопку мыши (средняя кнопка - double-click).

HKEY_CURRENT_USER\ Software\ Logitech\Version создайте парметр SwapMouseButtons

= 1

21. Как очистить список недавно используемых программ в меню Выполнить.

Список команд из меню Выполнить находится в разделе HKEY_CURRENT_USER\ Software\

Microsoft\ Windows\ CurrentVersion\ Explorer \ RunMRU. Команды хранятся в

строках с названиями a,b,c,d и т.д. В параметре MRUList записан порядок этих

команд. Если очистить параметры a и MRUList, то список очистится.

22. Как вообще не запоминать выполненные команды, адреса и открытые документы.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте параметр ClearRecentDocsOnExit = 01 00 00 00 - включено, 00 00

00 00 - выключено. При выключении компьютера все списки очистятся.

23. Как очистить список меню Документы.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

\RecentDocs Очистите параметр MRUList = "".

24. Как посмотреть список программ, запускаемых в процессе загрузки Windows.

Существует 5 разделов в ветви HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\

CurrentVersion

Run - список программ, которые запускаются при каждой загрузке Windows

RunOnce - список программ, которые запускаются только один раз при загрузке

Windows, потом список очищается

RunOnceEx - то же, что и предыдущий раздел, но здесь можно определять

очередность запуска программ

RunServices - список сетевых или системных программ, которые запускаются при

каждой загрузке Windows

RunServicesOnce - список сетевых или системных программ, которые запускаются

только один раз при каждой загрузке Windows

25. Параметры, определяющие настройки даты, времени, формат чисел, валют.

Эти параметры находятся в разделе HKEY_CURRENT_USER\ Control Panel\

International.

26. Как изменить место часового пояса в "Свойства: Дата и время".

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ TimeZones\

Russian измените значение следующего парметра на нужное Вам. По умолчанию там

стоит: "[GMT+3.00] Москва, Санкт-Петербург, Волгоград". Можно написать, например

ваш адрес. :-)

Запрещение различных установок и настроек Windows с помощью реестра

ПРЕДУПРЕЖДЕНИЕ! Некорректное изменение реестра опасно для здоровья Вашего

компьютера! Будьте бдительны и аккуратны!

Некоторые изменения вступают в силу только после перезагрузки Windows.

Перед изменением параметров постарайтесь предвидеть изменения системы, чтобы не

было мучительно больно потом. !!!

Может возникнуть ситуация, когда вам необходимо каким либо образом ограничить

доступ к компьютеру некоторым пользователям.

1. Как ограничить доступ к программам.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте раздел RestricRun. В этом разделе создайте параметры с именами

1, 2, 3 и т.д., которые должны содержать пути и имена программ. Доступ для

пользователя разрешен будет только к тем программам, которые описаны таким

образом. Для разрешения доступа удалите раздел RestricRun.

Внимание: Будьте внимательны и аккуратны! А еще лучше всего научитесь

восстанавливать реестр в режиме MS-DOS !!! Если в системе существует всего один

пользователь и вы не укажите в списке разрешенных программ редактор реестра, то

вы не сможете запускать больше никакие программы, кроме указанных в списке.

2. Как ограничить доступ к редактору реестра.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

System создайте параметр DisableRegistryTools = 1 - доступ закрыт, 0 - открыт.

3. Как запретить вызов контекстного меню.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer создайте параметр NoViewContextMenu = 1 - контекстное меню запрещено, 0

- разрешено.

4. Как запретить появление всплывающих подсказок.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ Advanced\ создайте параметр ShowInfoTip = 1 - запрещено, 0 - нет.

5. Как запретить команды в меню Пуск.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer если параметр имеет равен 1, то команда запрещена, 0 - разрешена

NoTrayContextMenu - запретить контекстное меню панели задач

NoRecentDocsHistory - не помнить недавно открытых документов

ClearRecentDocsOnExit - очищать список недавно открытых документов при выходе

NoSetActiveDesktop - удалить пункт Рабочий стол Active Desktop из подменю

Настройка

NoChangeStartMenu - запретить контекстное меню в меню Пуск

NoStartMenuSubfolders- скрыть подкаталоги в меню Пуск.

6. Как запретить сеанс MS-DOS.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

WinOldApp создайте параметр Disable = 1 - запрещен, 0 -разрешен.

7. Как запретить перезагрузку в режиме MS-DOS.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

WinOldApp создайте параметр NoRealMode = 1 - запрещен, 0 -разрешен.

8. Как ограничить доступ к настройкам принтера.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer если параметр имеет равен 1, то команда запрещена, 0 - разрешена

NoDeletePrinter - запрет на удаление принтера

NoPrinterTabs - скрыты закладки в диалоге Свойства: принтер

NoAddPrinter - запрет на добавление принтера

9. Как ограничить доступ к настройкам сети.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Network если параметр имеет равен 1, то команда запрещена, 0 - разрешена

NoNetSetup - диалог Сеть недоступен

NoNetSetupSecurityPage - в диалоге Сеть недоступна закладка Управление доступом

NoNetSetupIDPage - в диалоге Сеть недоступна закладка Идентификация

10. Как ограничить доступ к системным настройкам.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

System если параметр имеет равен 1, то команда запрещена, 0 - разрешена

NoDevMgrPage - диалог Свойства: Система недоступен

NoConfigPage - в диалоге Свойства: Система недоступна закладка Профили

оборудования

NoFileSysPage - в диалоге Свойства: Система на закладке Бысродействие надоступна

кнопка Файловая система

NoVirtMemPage - в диалоге Свойства: Система на закладке Быстродействие

надоступна кнопка Виртуальная память

11. Как скрыть в Панели управления какой-либо пункт(или все).

В папке Windows\ System находите файлы с расширением *.cpl, отвечающие за пункты

в Панели управления, удаляете или переносите куда-нибуть соответствующий файл

(или все). После этого в Панели управления пусто (или почти).

12. Как ограничить доступ к настройкам паролей.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ System если параметр имеет равен 1, то команда запрещена, 0 -

разрешена

NoSecCPL - диалог Свойства: Пароли недоступен

NoAdminPage - в диалоге Свойства: Пароли закладка Удаленное администрирование

недоступна

NoPwdPage - в диалоге Свойства: Пароли закладка Смена паролей недоступна

NoProfilePage - в диалоге Свойства: Пароли закладка Профили пользователей

недоступна

13. Как ограничить доступ к настройкам экрана.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ System если параметр имеет равен 1, то команда запрещена, 0 -

разрешена

NoDispCPL - диалог Свойства: Экран недоступен

NoDispBackgroundPage - в диалоге Свойства: Экран закладка Фон недоступна

NoDispScrSavPage - в диалоге Свойства: Экран закладка Заставка недоступна

NoDispAppearancePage - в диалоге Свойства: Экран закладка Оформление недоступна

NoDispSettingsPage - в диалоге Свойства: Экран закладка Настройка недоступна

14. Как удалить меню Файл из папок и проводника.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ создайте параметр NoFileMenu = 1 - удалено, 0 - нет.

15. Как запретить возможность настройки вида папок.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ создайте параметр NoCustomizeWebView = 1 - запрещено, 0 - нет.

16. Как запретить сохранение установок.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\

Explorer\ создайте параметр NoSaveSetting = 1 - запрещено, 0 - нет.


Описание настроек BIOS Setup

Описание ошибок

В процессе старта системы и проведения POST-теста возможны различного рода аппаратные ошибки, сопровождаемые параллельным выводом на экран монитора соответствующих сообщений. Некоторые из приведенных ниже сообщений несколько утратили свою актуальность, некоторые просто отсутствуют. Умышленно выведены, например, из этого перечня сообщения об ошибках с EISA-шиной. В остальном, этот материал будет несомненно полезен.

  • 8042 Gate-A20 Error!
  • Address Line Short!
  • BIOS ROM checksum error - System halted
  • CH-2 Timer Error
  • CMOS Checksum Error, CMOS Checksum Failure
  • CMOS Memory Size Mismatch
  • CMOS System Options Not Set
  • CMOS Time and Date Not Set
  • CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low
  • Cache Memory Bad, Do Not Enable Cache!
  • DMA #1 Error, DMA #2 Error
  • DMA Bus Time-out
  • DMA Error
  • Disk Boot Failure, Insert System Disk And Press Enter
  • Diskette Boot Failure
  • Diskette Drives Or Types Mismatch Error - Run Setup
  • Display Switch Is Set Incorrectly, Display Switch Not Proper
  • Display Type Has Changed Since Last Boot
  • Error Encountered Initializing Hard Drive
  • Error Initializing Hard Drive Controller, Hdd Controller Failure
  • Expansion Board not ready at Slot X
  • FDD Controller Failure
  • Floppy Disk Cntrlr Error Or No Cntrlr Present
  • Floppy disk(s) fail
  • Hard Disk Install Failure
  • Hard Disk(s) fail
  • Hard disk(s) diagnosis fail
This HTML Help has been published using the chm2web software.


8042 Gate-A20 Error!

Линия A20 контроллера клавиатуры (8042) не работает. Заменить контроллер клавиатуры.

Что вы думаете об этой статье? Дайте нам знать.

14/06/2002


Address Line Short!

Проблема со схемой декодирования адреса памяти. Имеет смысл перезагрузиться, подождав секунд 30 до повторного включения. Проблема может разрешиться сама собой.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


BIOS ROM checksum error - System halted

Проверочная сумма при тесте ПЗУ по адресу F0000H-FFFFFH ошибочна. Возможно потребуется восстановление (перепрошивка) микросхемы с Flash BIOS.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Cache Memory Bad, Do Not Enable Cache!

Ошибка кэш-памяти. Возможно потребуется замена. Хотя сначала стоит попробовать просто перезагрузиться.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CH-2 Timer Error

Ошибка второго таймера. Некоторые системы имеют два таймера.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low

Эти сообщения в начале загрузки компьютера свидетельствуют о неисправности батареи или ее разрядке. Необходимо заменить батарею.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CMOS Checksum Error, CMOS Checksum Failure

Неправильная контрольная сумма CMOS, что свидетельствует о повреждении данных в CMOS, возможно из-за сбоя батареи. Если попытка восстановления "BIOS Setup" окажется неудачной, возможно придется обращаться в сервисный центр со своей материнской платой.

Что вы думаете об этой статье? Дайте нам знать.

23/02/2003


CMOS Memory Size Mismatch

Объем физической памяти на материнской плате не сходится с тем, что зафиксировалось в CMOS RAM. Необходимо перезапустить "BIOS Setup", проверить все установки. После перезагрузки ПК ошибка может исчезнуть, иначе потребуется замена компонентов материнской платы.

Что вы думаете об этой статье? Дайте нам знать.


CMOS System Options Not Set

Данные в CMOS повреждены или отсутствуют. Действия пользователя аналогичны вышеприведенным.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CMOS Time and Date Not Set

Нарушены или не установлены параметры даты и времени. Задача сводится к проверке или установке этих параметров в "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Disk Boot Failure, Insert System Disk And Press Enter

Не найден загрузочный диск. Необходимо загрузиться с дискеты и проверить системные файлы на жестком диске.

Что вы думаете об этой статье? Дайте нам знать.

25/06/2002


Diskette Boot Failure

Дискета в дисководе А: не является загрузочной, т.е. невозможно загрузиться с дискеты в процессе запуска ПК. Дискета может не быть загрузочной, либо системные файлы повреждены.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Diskette Drives Or Types Mismatch Error - Run Setup

Типы дисководов, фактически установленных в системе, и их описания в CMOS не сходятся. Необходимо запустить "BIOS Setup" и ввести правильные типы дисководов.

Что вы думаете об этой статье? Дайте нам знать.


Display Switch Is Set Incorrectly, Display Switch Not Proper

Неправильно выставлен тип монитора (монохромный или цветной). Переставить соответствующий джампер на материнской плате в правильное положение или исправить выбор типа монитора в "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Display Type Has Changed Since Last Boot

Изменился тип дисплея со времени последней загрузки. В "BIOS Setup" ввести правильный тип дисплея.

Что вы думаете об этой статье? Дайте нам знать.


DMA #1 Error, DMA #2 Error

Ошибка первого/второго канала DMA. Ошибка может быть вызвана соответствующим периферийным устройством.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


DMA Bus Time-out

Устройство не отвечает в течении 7,8 мкс. Проблема в платах расширения. Необходимо найти плату, которая вызывает эту ошибку и заменить ее.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


DMA Error

Ошибка контроллера DMA. Возможно потребуется замена материнской платы.

Что вы думаете об этой статье? Дайте нам знать.

18/07/2002


Error Encountered Initializing Hard Drive

Не инициализируется жесткий диск. Проверить установку контроллера жестких дисков (для устаревших систем), соединительные кабеля, а также параметры "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Error Initializing Hard Drive Controller, Hdd Controller Failure

Ошибка связи с контроллером жестких дисков, контроллер жестких дисков не инициализируется. Проверить установку контроллера, подсоединение дисковода и параметры жесткого диска в "BIOS Setup". Также стоит проверить установку джамперов на жестком диске.

Что вы думаете об этой статье? Дайте нам знать.


Expansion Board not ready at Slot X

BIOS не может найти плату в слоте номер X. Проверить установку платы в этом слоте.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


FDD Controller Failure

Ошибка связи с контроллером гибких дисков. Проверить подсоединение дисковода и его разрешенность на мультикарте (для устаревших систем).

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Floppy Disk Cntrlr Error Or No Cntrlr Present

Невозможно инициализировать контроллер гибких дисков. Проверить установку контроллера и параметры дисковода, указанные в "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Hard Disk Install Failure

Нельзя найти или инициализировать контроллер или сам жесткий диск. Действия те же, т.е. проверить все механические установки и подключения, а также правильность установок в "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Hard disk(s) diagnosis fail

Ошибка начальной диагностики жесткого диска.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Hard Disk(s) fail

Ошибка инициализации жесткого диска.

Что вы думаете об этой статье? Дайте нам знать.

25/08/2002


Floppy disk(s) fail

Нельзя найти или инициализировать контроллер или сам флоппи-дисковод.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


BIOS Setup

Введение

Полный сборник описаний опций BIOS Setup'а, собранный из разных источников. Сборник оформлен в виде одного CHM-файла, что обеспечивает компактность хранения и встроенный поиск по тексту. Почему сюда встроен надоедливый баннер? Потому что надо как-то отблагодарить бесплатного хостера у которого лежит этот файл.

Оглавление

  • Общая информация
  • Описание настроек
  • Описание ошибок

История изменений

  • 22.02.2002 - версия 1.2. Добавлены новые опции. Введены перекрестные ссылки.
  • 26.10.2001 - версия 1.1. Исправления и дополнения (+ 14 новых опций), переформатированы все статьи.
  • 18.09.2001 - версия 1.0. Первый выпуск.

Авторы и Источники

  • Николай Распопов
    mail: <ryo-oh-ki@narod.ru>
    fido: 2.5015/126.30
    homepage: http://raspopov.dem.ru/
  • Сергей Блохнин
    mail: <spline@glas.apc.org>
  • Виталий Якусевич
  • Денис Матвиец
  • Павел Храпунов
  • fido7.su.hardw.chainik
  • http://www.istc.kiev.ua/~santana/
  • http://tech.stolica.ru/mb/bios1/
  • http://hom.com.ua/hardware/library/mb/iXBT_Setup_BIOS.htm

Что вы думаете об этой статье? Дайте нам знать.


Описание настроек BIOS Setup

Общая информация
  • ACPI
  • ATX
  • BIOS
  • Bus Master
  • CAS
  • DIMM
  • DMA
  • DPMS
  • DRAM
  • ECP
  • EDO
  • EPP
  • FPM
  • I/O
  • IRQ
  • IrDA
  • Plug and Play
  • RAS
  • Refresh
  • SDRAM
  • SE
  • SIMM
  • SPD
  • SPP
  • Зарузка системы
  • ПК


Зарузка системы

При включении ПК автоматически запускается находящаяся в BIOS программа загрузки BOOT-ROUTINE. Эта программа вызывает подпрограмму самопроверки POST (Power-On Self Test), проверяющую оперативную память, процессор, жесткий диск и т.д.Далее программа загрузки разыскивает другие BIOS-чипы, которые могут быть встроены, к примеру, в платы расширения. SCSI- контроллеры при этом будут запускать свои собственные тестовые программы.

После этого BIOS берется уже конкретно за платы расширения и расстановку и проверку распределения ресурсов (IRQ, DMA, I/O).

Далее с загрузочных секторов жесткого диска в дело вступает начальный загрузчик, BOOTSTRAP LOADER, - программа, знающая файловую структуру носителя данных. Начальный загрузчик вызывает загрузку загрузочных программ операционной системы.

Этот стандартный алгоритм значительно дополнился и модернизировался с внедрением PnP-технологии и новой PCI-шины, а позже с появлением операционных систем, разработанных с учетом внедрения новейших технологий. Но более подробно об этом будет сказано ниже.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Bus Master

Bus Master (хозяин шины, задатчик) - возможный режим работы устройства на любой шине, в том числе и на PCI. Для работы в таком режиме устройство выдает запрос арбитру шины, сообщая о своем требовании на получение управления шиной. Арбитр, в соответствии с приоритетом и/или очередностью арбитража на данной шине, через определенное время после запроса отдает запрашивающему устройству управление шиной. Выполнив все необходимые ему операции, устройство сообщает арбитру об освобождении им шины.

На современных шинах, таких как PCI, для получения доступа к шине ВСЕ устройства проходят процедуру арбитража, в том числе и центральный процессор. Возможность быть "master"-устройством реализуется аппаратно при разработке устройства. Реализация механизма "BusMaster" позволяет общаться между собой только тем компонентам компьютера, которым это в данный момент необходимо. Этот механизм используется, например, для передачи данных TV-тюнером на видеокарту, если они обе находятся на PCI-шине, причем без участия центрального процессора, системной памяти и т.п.

Обычно, система управляет доступом к PCI-шине по фундаментальному принципу - "First-Come-First-Served" (первым пришел, первым обслуживается). Но возможности арбитража значительно шире и сложнее. Существуют и различные режимы действия самого механизма арбитража. Может быть установлен т.н. режим ротации устройств, при котором периодично меняется очередность устройств, т.е. их приоритет. Приоритет может оказаться фиксированным, т.е. какое-либо системное устройство "навсегда" получает наивысший приоритет. При "вращении приоритетов" (rotated) устройству, получившему контроль над шиной, присваивается самый низкий приоритет и любое другое устройство перемещается на шаг вверх в "очереди" приоритетов.

Как же все это реализуется? В состав чипсета входит 8-разрядный ARBITRATION CONTROL REGISTER, позволяющий реализовать свойства, связанные с арбитражем на PCI-шине, а также (у достаточно новых чипсетов) с поддержкой спецификации шины PCI 2.1. (см. ниже)

В современных системах механизмы арбитража, можно сказать, интеллектуализированы, что в итоге привело к изъятию из "BIOS Setup" функций, связанных с пользовательскими установками по арбитражу. "Старые" же версии BIOS вполне могут содержать некоторые из приведенных ниже опций, могущих вызвать душевный трепет у пользователя.

Что вы думаете об этой статье? Дайте нам знать.


ACPI

Примерно с конца 1994 г. каждый ПК стал соответствовать спецификации "Energy Star" (наличие функций энергосбережения), а BIOS компьютера обогатился встроенными функциями т.н. "Advanced Power Management" (APM) - совместного стандарта корпораций "Microsoft" и "Intel", первая редакция которого появилась еще в 1992 г. В компьютерную терминологию "Energy Star" вошла от названия одноименной программы правительства США по снижению энергопотребления. Соответствующий логотип могли получить только те продукты, которые выполняли квоту по экономии энергии.

"APM" был первой спецификацией для изготовителей ПК, которая установила взаимодействие между операционной системой и BIOS в задаче управления энергопотреблением (Power Management).

"ACPI" (Advanced Configuration and Power Interface) - интерфейс расширенного конфигурирования и управления питанием, заменяющий стандарт расширенного управления питанием (APM). ACPI - это технология, лежащая в основе разработанного "Microsoft" стандарта энергосбережения и стандарта "Plug-and-Play" - "On Now".

Спецификация разрабатывалась совместно "Intel", "Microsoft" и "Toshiba" и представляла собой новую архитектуру "Microsoft Windows 98". Операционная система взяла на себя управление многочисленными параметрами функционирования ПК. Технология реализует управление состоянием системы, работой компонентов и энергопотреблением на основе модели событий и использования программирования по таймеру.

Все это достигается средствами ОС и представляет собой программируемый вход в режимы энергосбережения, а также выход из "спящего" режима от обращения к "мыши" или клавиатуре, в связи с приходом телефонного звонка или удаленного сетевого управления, т.п. Системный BIOS дополнился и другими многочисленными функциями, о которых будет рассказано далее. Присутствие в этой троице "Toshiba" более чем объяснимо, поскольку проблемы и задачи энергосбережения пришли в мир настольных ПК от ПК-блокнотов.

Спецификация "ACPI" была реализована "Intel" впервые в чипсете 440LX с одновременной реализацией архитектуры AGP.

Параллельно с развитием и совершенствованием технологий энергосбережения, затрагивающих прежде всего производителей чипсетов, материнских плат, BIOS и разработчиков операционных систем, шел процесс совершенствования моделей мониторов. Стандарт "EPA Energy Star VESA DPMS" (DPMS - Display Power Management System) определил унифицированную процедуру энергосбережения и ступенчатого выключения монитора в трех стадиях:

  • "On" (номинальный режим работы) >
  • "Standbye" (режим ожидания). В режиме ожидания изображение на экране пропадает, но внутренние компоненты монитора функционируют в нормальном режиме, а энергопотребление снижается до 80% от рабочего состояния >
  • "Suspend" (режим приостановки). В режиме приостановки, как правило, отключаются высоковольтные узлы, а потребление энергии падает до 30 Вт и менее >
  • "Off" ("сон"). В режиме так называемого "сна" монитор потребляет не более 8 Вт, а функционирует у него только микропроцессор. В этой системной процедуре контроль берет на себя драйвер, посылающий соответствующие сигналы через графическую карту. При нажатии клавиши на клавиатуре или движении "мыши" монитор переходит в нормальный режим работы.

Что вы думаете об этой статье? Дайте нам знать.


RAS

Raw Address Strobe - строб адреса строки - сигнал, используемый при работе с динамической памятью (DRAM), предназначен для запоминания в микросхеме DRAM адреса строки.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


DIMM

Dual In-line Memory Module - двухсторонний модуль памяти - конструктив модуля памяти, ставший с 1997 года фактическим стандартом для компьютеров. Имеет по 84 вывода с каждой стороны. Собственно память, размещенная на модуле, может быть как FPM или EDO так и SDRAM. Память в DIMM имеет разрядность 64 (с четностью 72) бита и может использоваться поодиночке, а не парами, как обычные SIMM.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


SIMM

Single In-line Memory Module - односторонний модуль памяти - конструктив модуля памяти, постепенно уходящие в 1997 году с рынка. Имеет 72 вывода с каждой стороны, но пары выводов с одной и другой стороны замкнуты между собой, поэтому они считаются односторонними. Собственно память, размещенная на модуле, может быть как FPM так и EDO. Память в SIMM имеет разрядность 32 (с четностью - 36) бита и может использоваться в компьютерах с процессорами Pentium только парами.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


FPM

Fast Page Mode DRAM - самый старый вид памяти, который стал применяться еще в 80-х годах. Отличается от стандартной тем, что позволяет сократить чтение/запись данных, расположенных один за другим в памяти, но при этом на каждое слово требуется не менее трех тактов системной шины. На микросхемах Fast Page Mode DRAM указывается время доступа в наносекундах к данным в случайном порядке.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


EDO

Extended Data Output DRAM - при работе на запись не дает никаких преимуществ по сравнению с FPM DRAM, но требует существенно меньше времени при чтении за счет того, что данные удерживаются на выходе микросхемы EDO DRAM дольше, чем в FPM DRAM. EDO (как и FPM) не дает никаких преимуществ при произвольной выборке данных из памяти, но такая ситуация возникает крайне редко. На микросхемах EDO DRAM указывается время доступа в наносекундах к данным в случайном порядке.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


ATX

AT eXtension - расширение формата AT - разработанный несколько лет назад конструктив корпуса персонального компьютера и, соответственно, форм-фактор материнской платы. Начал массово использоваться после появления процессоров Pentium II, так как материнские платы для этого процессора выпускаются только в формате ATX (за очень редким исключением). Основные отличия от классического конструктива:

  • Плата крепится только на винтах, что повышает надежность и жесткость ее крепления.
  • Разъемы всех портов ввода/вывода (принтерный, COM1, COM2 и т.д.) жестко крепятся на материнской плате в ее правом верхнем углу, причем могут устанавливаться друг над другом.
  • Процессор (процессоры) и его "обвязка" устанавливаются справа от интерфейсных разъемов, что позволяет устанавливать полноразмерные платы расширения.
  • Блок питания вырабатывает также напряжение 3.3 V, что избавляет от необходимости формировать это напряжение на материнской плате.
  • Блок питания запускается/выключается от специального сигнала, который может быть выработан как кнопкой включения компьютера, так и BIOS через соответствующую схему на материнской плате. Это позволяет программно выключать блок питания (например, при выходе из Windows 95) и включать его по команде от BIOS или от модема, сетевой карты и т.п.
  • Напряжение 5 V (слаботочное) всегда есть на материнской плате, если 220 V подано на блок питания, для управления запуском блока питания. Поэтому на "правильных" ATX блоках питания всегда есть выключатель 220 V, расположенный на самом блоке питания сзади системного блока. При любых действиях, требующих снятия крышки системного блока, 220 V требуется ОБЯЗАТЕЛЬНО ОТКЛЮЧАТЬ от блока питания.
  • Разъем для подключения ATX блока питания на материнской плате один и имеет 20 контактов.
  • Допускается (но не является обязательным) вывод и подключение на материнскую плату сигналов с датчика скорости вращения вентилятора блока питания.

Что вы думаете об этой статье? Дайте нам знать.


SPP

Standard Parallel Port - стандартный параллельный порт - классический принтерный интерфейс, называемый, как правило, Centronics, по имени давно ликвидированной фирмы, разработавшей этот интерфейс. Интерфейс позволяет передавать данные по байту со скоростью до 80 KB/c. При необходимости приема данных можно использовать четыре линии сигнала от принтера (обрыв бумаги, буфер принтера полон и т.д.).

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


CAS

Column Address Strobe - строб адреса столбца - сигнал, используемый при работе с динамической памятью (DRAM), предназначен для запоминания в микросхеме DRAM адреса столбца.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


DRAM

Dinamic Random Access Memory - динамическая память прямого доступа - память, схемотехнически выполненная в виде двумерной матрицы (строки х столбцы) конденсаторов. Очень дешева, но требует постоянного "освежения" или регенерации (Refresh) заряда на конденсаторах. Регенерация выполняется как "пустое" чтение памяти. Этот процесс отнимает значительное время, так как в этот период никакое устройство не может получить доступ к памяти, кроме контроллера регенерации.

Что вы думаете об этой статье? Дайте нам знать.


ECP

Enhanced Capability Port - порт с расширенными возможностями - отличается от стандартного принтерного порта с интерфейсом Centronics, тем, что передаваемая информация разделяется на команды и данные с поддержкой режима DMA и кодирования по методу RLE (Run-Length Encoding - кодирование повторяющихся последовательностей данных).

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


EPP

Enhanced Parallel Port - расширенный параллельный порт - двунаправленный вариант принтерного порта с максимальной скоростью приема/передачи данных до 2 MB/c. Стало возможным адресация нескольких устройств, ввод 8-ми разрядных данных. Для буферизации данных используется память с FIFO организацией объемом в 16 байт.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


SDRAM

Synchronous DRAM - относительно новый вид памяти, который также показывает свои преимущества только при последовательной выборке данных из памяти. Но при последовательной выборке (или потоке, конвейере - burst) чтение/запись выполняются в два раза быстрее, чем для EDO DRAM На микросхемах SDRAM указывается время доступа в наносекундах к данным при последовательной выборке. Реально же цифры на корпусах микросхем синхронной памяти фактически сообщают максимальную тактовую частоту системной шины, на которой данная память может работать.

SDRAM выпускается сейчас только в 168-ми выводных 64-разрядных модулях DIMM. В отличие от обычных модулей SIMM эти могут устанавливаться на материнской плате поодиночке. В соответствии с JEDEC стандартом на модуле DIMM должна быть установлена специальная микросхема SPD устройства. Некоторые современные материнские платы, например фирмы Intel на наборе 440LX, не запускаются, если установлена планка памяти без SPD. Микросхемы SDRAM так же широко используются в качестве локальной памяти видеокарт.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


SPD

Serial Presence Detect - устройство определения присутствия с последовательным доступом - изготавливается на специальной микросхеме (как правило, это электрически перепрограммируемая память), содержащей информацию о типе устройства и его основных характеристиках. Объем такой памяти - 512 байт.

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


DMA

Direct Memory Access - "прямой доступ к памяти" - режим обмена данными между памятью и устройством ввода/вывода, управляемый специальным устройством (контроллером DMA) и выполняемый без участия центрального процессора. Использование этого режима значительно ускоряет пересылку данных, так как исключает пересылки данных в процессор и обратно.

"Прямой доступ к памяти" осуществляется через DMA-контроллер - специальный чип, получающий первоначальную команду на перенос данных от центрального процессора. Каналы DMA предназначены для передачи массивов информации по 8- или 16-битным шинам одновременно. В отличие от портов ввода/вывода каналы DMA непосредственно не сообщаются с центральным процессором, они работают напрямую с системной памятью. Всего каналов DMA - 8 (от 0 до 7).

Первоначально DMA-контроллер задумывался, прежде всего, для разгрузки CPU от тривиальных задач, например, контроля флоппи- дисководов или жестких дисков. Начиная с компьютеров PC/AT передача данных от жестких дисков и к ним стала осуществляться уже не через каналы DMA, а через программируемый ввод/вывод.

Начиная с Intel 80386, процессоры располагают собственным устройством управления памятью (MMU - Memory Management Unit), которое пересчитывает логические адреса в физические. DMA-контроллеры "ничего не знают" о разрядности адресов. Поэтому, чтобы иметь возможность применять DMA вместе с управлением виртуальной памятью, нужно зарезервировать в качестве DMA-буфера какую-то область памяти в первом мегабайте адресного пространства, где логические и физические адреса совпадают. В эту область DMA-контроллер записывает данные, прежде чем они будут скопированы процессором из этого буфера. Эта технология, называемая двойной буферизацией, неэффективна.

Основными "потребителями" каналов DMA являются звуковые карты, CD-ROM-дисководы более ранних выпусков. В обоих случаях скорость передачи не превышает 500 Кб/с. Максимально возможная скорость передачи данных по DMA-каналам (около 2 Мб/с) значительно перекрывает потребности 8-битной звуковой карты. Если же необходимо осуществить быстрый обмен информацией, то в этом случае DMA не используется - процессор берет на себя управление процессом переноса информации, перекрывая все допустимые способности DMA-каналов.

DMA-канал | Разрядность | Назначение
0 | 8 | свободен (ранее использовался в PC/XT для обновления памяти
1 | 8 | обычно задействуется под звуковые или сетевые карты
2 | 8 | контроллер floppy-дисководов
3 | 8 | свободен (в PC/XT обеспечивал передачу данных от HD), иногда используется EPP-функцией параллельного порта
4 | 16 | каскадирование для 8-разрядного контроллера (координация между "старым" и "новым" чипами DMA)
5 | 16 | свободен (часто задействуется под 16-разрядные звуковые карты)
6 | 16 | свободен
7 | 16 | свободен

Что вы думаете об этой статье? Дайте нам знать.


DPMS

Display Power Management Signaling - сигналы управления энергопотреблением монитора - стандарт, созданный ассоциацией VESA для многостадийного снижения энергопотребления монитора. Для реализации стандарта его должен поддерживать монитор. В стандарте оговорены четыре уровня:

  • 0 - "DPMS Mode On" - Монитор используется как обычно;
  • 1 - "DPMS Mode Standby" - Изображения нет, потребление снижено;
  • 2 - "DPMS Mode Suspend" - Изображения нет, потребление еще более снижено;
  • 3 - "DPMS Mode Off" - Изображения нет, потребление снижено до минимума.

Что вы думаете об этой статье? Дайте нам знать.


IrDA

Аббревиатура от "Infrared Data (иногда как Device) Association". Так же называется интерфейс с использованием инфракрасного порта, обеспечивающего беспроводное подключение периферийных устройств низкого быстродействия, которые расположены в непосредственной близости от ПК.

Что вы думаете об этой статье? Дайте нам знать.


IRQ

IRQ | Устройство | Приор. | Комментарии
0 | Системный таймер | * 15 | Системное прерывание. Генерируется 91 раз за 5 сек. В данном качестве применяется со времени первого PC.
1 | Клавиатура | * 14 | Системное прерывание, генерируемое контроллером клавиатуры.
2 | Контроллер прерываний | * 13 | Каскадировано (связано) с IRQ9. Могут возникнуть конфликты, когда одновременно на IRQ2 и IRQ9 должны работать различные устройства. Его использование системой сохраняется для совместимости.
3 | COM 2 | 4 | Используется вторым коммуникационным адаптером (UART2). Какое же устройство будет его генерировать? Это может быть второй последовательный порт COM2 (интегрирован на материнской плате), внутренний модем, настроенный на COM2 или COM4, или инфракрасный адаптер. Можно отключить UART2, но присвоить IRQ3 ничему не удастся. Делит одно и то же IRQ3 с COM4 (при наличии последнего). Возможен конфликт при одновременном использовании.
4 | COM 1 | 3 | Используется первым коммуникационным адаптером. Все практически идентично: генерируется первым последовательным портом COM1, модемом на COM1 или COM3 (за исключением инфрапорта). Делит одно и то же IRQ4 с COM3 (при наличии последнего). В системах с подключенной к COM1 мышью использовать COM3 не следует.
5 | свободен | 2 | Прерывание изначально предназначалось для использования вторым параллельным портом LPT2. Практического применения такое решение не нашло, поэтому IRQ5 перешло в разряд свободных. В IBM XT на IRQ5 "висел" жесткий диск. Через некоторое время "Creative Labs", создавая звуковую карту "Sound Blaster Pro", нашла применение прерыванию. С тех пор IRQ5 стало излюбленным для большинства звуковых ISA-карт. Звуковые PCI-карты также иногда используют это прерывание для эмуляции "SB Pro". IRQ5 можно привязать к слоту PCI.
6 | Контроллер FDD-дисковода | * 1 | Прерывание используется контроллером флоппи-дисковода, начиная с первых ПК. Ныне его можно отключить, если перейти на совместимый с обычными дискетами накопитель LS-120 с интерфейсом EIDE. Однако прерывание все равно не может быть использовано: ISA-карты на работу с ним не рассчитаны, и к слоту PCI привязать его нельзя. Может быть использовано для привода на на магнитной ленте.
7 | LPT 1 | 0 | По умолчанию прерывание первого параллельного порта LPT1. При отключенном порте (если принтер отсутствует или рассчитан на USB) может использоваться различными устройствами: сетевыми, ISDN-картами. Это также "запасное" место для звуковых карт.
8 | Часы реального времени (RTC) | * 12 | Системное прерывание со времени первых IBM AT.
9 | свободен | 11 | Каскадировано с IRQ2. В остальном может использоваться по усмотрению.
10 | свободен | 10 | Может быть использовано по усмотрению. Устаревшие IDE-контроллеры на старых звуковых картах иногда используют это IRQ.
11 | свободен | 9 | Может быть использовано по усмотрению, часто используется видеокартами. В современных ПК обычно резервируется для шины USB. При отключении последней в BIOS может быть задействовано иначе.
12 | свободен или PS/2-мышь | 8 | Если используется мышь, это IRQ в большинстве случаев выдается лишь по разрешению BIOS. Почти всегда прерывание свободно.
13 | Сопроцессор | * 7 | Системное прерывание. Изначально применялось арифметическим сопроцессором, который в первых ПК являлся отдельной микросхемой. Ныне это прерывание зарезервировано для совместимости со старым ПО.
14 | Первичный EIDE-контроллер | 6 | По разрешению BIOS может быть использовано в SCSI- системах.
15 | Вторичный EIDE-контроллер | 5 | Также может использоваться SCSI-интерфейсом, хотя обычно на него "подгружают" дополнительные EIDE-диски. При отсутствии устройств может применяться в любых целях.

Примечания:
15 - наивысший приоритет,
* - эти системные компоненты жестко зафиксированы и их конфигурация не может быть изменена.

При установке в слоты карт расширения необходимо помнить о следующем:

  • слоту AGP и первому слоту PCI присваивается один и тот же номер прерывания
  • если слотов PCI пять, то один номер разделяют также четвертый и пятый слоты
  • при установке сложного устройства, требующего сразу два IRQ, желательно следующий слот оставлять свободным, иначе возможна достаточно сложная процедура ручного присваивания ресурсов.

Что вы думаете об этой статье? Дайте нам знать.


SE

Single-Ended - технология устройств, передачи данных, разъемов, в которой используются однополярные сигналы в уровнях TTL-логики, что характерно для Ultra Wide SCSI. Внутренние ограничения SCSI-стандартов были в значительной степени преодолены в интерфейсе Ultra2 Wide SCSI, обеспечившем скорость передачи до 80 МБ/с.

Постоянное развитие SCSI-интерфейсов ставило целью повышение частоты, что приводило в итоге к ограничению максимальной длины интерфейсного кабеля. Технология LVD работает, в отличие от SE, с двухполярными сигналами низкого уровня. Каждый сигнал шины Ultra2 Wide передается по двум проводам в противофазе (дифференциально). Это - так называемая низковольтная дифференциальная передача сигналов, или Low Voltage Differential (LVD). Благодаря ей удалось увеличить допустимую длину соединительного кабеля до 12 м.

Что вы думаете об этой статье? Дайте нам знать.

22/06/2002


Plug and Play

В 1993 г. "Compaq", "Intel", "Phoenix" и "Microsoft", стремясь сделать ПК еще более интеллектуальными, разработали концепцию "Plug and Play". Основная ее идея заключается в следующем: при загрузке ПК BIOS опрашивает все карты на предмет их потребности в ресурсах и распределяет их так, чтобы при работе ПК не возникали конфликтные ситуации.

Общение между картой расширения и BIOS можно обеспечить еще эффективнее при использовании PCI-шины. Так, большинство PnP-карт разработаны только для шины PCI. Все PCI-карты отличаются, кроме того, дополнительными способностями. В отличие от своих ISA-родственников они могут работать с переменными ресурсами и посредством точно определенной идентификационной записи отчетливо заявлять о своих ресурсных потребностях.

Соответственно этому BIOS, поддерживающий "Plug and Play", сперва проверяет жестко настроенные ISA-карты, а затем раздает оставшиеся ресурсы PCI-устройствам. В результате формируется список распределения ресурсов ESCD (Extended System Configuration Data), помещаемый BIOS'ом в нечувствительной к отсутствию питания области памяти для того, чтобы при каждом старте иметь возможность сравнения и восстановления последней функционировавшей комбинации.

Что вы думаете об этой статье? Дайте нам знать.


Refresh

Возможны три различных метода регенерации данных:

  • Регенерация одним RAS (RAS Only Refresh - ROR). Этот метод использовался еще в первых микросхемах DRAM. Адрес регенерируемой строки передается на шину адреса и выдается сигнал RAS (точно так же, как при чтении или записи). При этом выбирается строка ячеек, и данные из них поступают на внутренние цепи микросхемы, после чего записываются обратно. Так как далее сигнал CAS не следует, цикл чтения/записи не начинается. Затем передается адрес следующей строки и так далее, пока не будет пройдена вся матрица памяти, после чего цикл регенерации повторяется. К недостаткам этого метода можно отнести то, что занимается шина адреса, и в момент регенерации блокируется доступ к другим подсистемам компьютера.
  • CAS перед RAS (CAS Before RAS - CBR) - стандартный метод регенерации. При нормальном цикле чтения/записи сигнал RAS всегда приходит первым, за ним следует CAS. Если же CAS приходит раньше RAS, то начинается специальный цикл регенерации - CBR. При этом адрес строки не передается, а микросхема использует свой внутренний счетчик, содержимое которого увеличивается на 1 при каждом CBR-цикле (т.н. инкрементирование адреса строки). Этот режим позволяет регенерировать память, не занимая шину адреса, что, безусловно, более экономично.
  • Автоматическая регенерация памяти (Self Refresh - SR, или саморегенерация). Этот метод обычно используется в режиме энергосбережения, когда система переходит в состояние "сна" ("suspend"), и тактовый генератор перестает работать. В таком состоянии обновление памяти по вышеописанным методам невозможно (попросту отсутствуют источники сигналов), и микросхема памяти выполняет регенерацию самостоятельно. В ней запускается свой собственный генератор, который тактирует внутренние цепи регенерации. Такая технология работы памяти была внедрена с появлением EDO DRAM. Необходимо отметить, что в режиме "сна" память потребляет очень малый ток.

Что вы думаете об этой статье? Дайте нам знать.


ПК

Сокращение от - Персональный Компьютер.

Что вы думаете об этой статье? Дайте нам знать.

22/02/2003


BIOS

Базовая система ввода-вывода - набор базовых программ для проверки его оборудования во время запуска для загрузки операционной системы, а также для поддержки обмена данными между устройствами. Базовая система ввода-вывода хранится в постоянном запоминающем устройстве (ПЗУ), и таким образом ее программы могут быть выполнены при включении компьютера. Определяя общую производительность компьютера, программы базовой системы ввода-вывода, как правило, остаются недоступными для пользователей.

Что вы думаете об этой статье? Дайте нам знать.


I/O

Порт ввода-вывода - канал передачи данных между устройством и микропроцессором. Порт представляется в микропроцессоре как один или несколько адресов памяти, из которых можно прочитать или в которые можно записать данные.

Что вы думаете об этой статье? Дайте нам знать.


Описание настроек BIOS Setup

Описание настроек
  • 16 Bit I/O Recovery Time
  • 16 Bit ISA I/O Command WS
  • 16 Bit ISA Mem Command WS
  • 8 Bit I/O Recovery Time
  • AC PWR Loss Restart
  • ACPI Function
  • ACPI Suspend Type
  • AGP
  • AGP-2x Mode
  • ALE During Bus Conversion
  • Above 1 MB Memory Test
  • Arbitration Priority
  • Assign IRQ For USB
  • Assign IRQ For VGA
  • Auto Configuration
  • Automatic Power Up
  • BIOS Update
  • Boot From LAN First
  • Boot Sequence
  • Boot Up Floppy Seek
  • Boot Up Numlock Status
  • Boot Up System Speed
  • Boot Virus Detection
  • BootSector Virus Detection
  • BootSector Virus Protection
  • Burst Refresh
  • Bus Concurrency
  • Bus Mastering
  • CAS Before RAS Refresh
  • CAS to RAS Refresh Delay
  • CAS# Latency
  • CPU Critical Temperature
  • CPU External Cache
  • CPU Fan Speed
  • CPU Fast String
  • CPU Internal Cache
  • CPU L2 Cache ECC Checking
  • CPU Level 1 Cache
  • CPU Level 2 Cache
  • CPU Level 2 Cache ECC Check
  • CPU Level 2 ECC Checking
  • CPU MicroCode Updation
  • CPU Temperature
  • CPU to DRAM Page Mode
  • CPU-to-PCI 6 DW FIFO
  • CPU-to-PCI Buffer
  • CPU-to-PCI IDE Posting
  • CPU-to-PCI Read Buffer
  • CPU-to-PCI Write Buffer
  • CPU-to-PCI Write Latency
  • Chassis Fan Speed
  • Chipset Special Features
  • Concurrent Refresh
  • DMA n Assigned to
  • DMA/ISA Master Before PCI
  • DRAM Burst at 4 Refresh
  • DRAM Data Integrity Mode
  • DRAM ECC/PARITY Select
  • DRAM Idle Timer
  • DRAM Page Idle Timer
  • DRAM Page Mode
  • DRAM Paging
  • DRAM Paging Mode
  • DRAM R/W Leadoff Timing
  • DRAM RAS Only Refresh
  • DRAM RAS to CAS Delay
  • DRAM RAS# Precharge Period
  • DRAM RAS# Precharge Time
  • DRAM Read Burst Timing
  • DRAM Refresh Cycle Time
  • DRAM Refresh Period
  • DRAM Refresh Rate
  • DRAM Slow Refresh
  • Data Integrity (PAR/ECC)
  • Daylight Saving
  • Delay For HDD (Secs)
  • Delay IDE Initial
  • Delayed Transaction
  • Delayed Transaction Optimization
  • Delayed Transaction Timer
  • Deturbo Mode
  • Doze Mode
  • Doze Speed
  • Drive NA before BRDY
  • Duplex Select
  • ECP DMA Select
  • EDO RAS Precharge
  • EDO RAS Precharge Timing
  • EDO RAS# Precharge Time
  • Enable Master
  • Error Halt
  • Extended ROM RAM Area
  • Extended Refresh
  • FPM DRAM RAS# Precharge
  • FPM RAS Precharge
  • FPM/EDO RAS# Precharge Time
  • Fast Gate A20 Option
  • Fast RAS# to CAS# Delay
  • Flash BIOS Protection
  • Floppy Disk Access Control (R/W)
  • Force Update ESCD
  • Gate A20 Option
  • Graphics (AGP) Aperture Size
  • Graphics Adaptor
  • HDD Power Down
  • HDD S.M.A.R.T Capability
  • Halt On
  • Hard Disk Pre-Delay
  • Hi-Speed Refresh
  • Hidden Refresh
  • Hit "Del" Message Display
  • Host Bus Fast Data Ready
  • IDE PIO Mode
  • IR Connector
  • IR Duplex Mode
  • IR Function
  • IR Function Duplex
  • IR Mode Select
  • IR Transfer Mode
  • IRQ n Assigned to
  • IRQ n Used By ISA
  • IRQ to PCI VGA
  • ISA 16-bit I/O Wait States
  • ISA 16-bit Mem Wait States
  • ISA Bus Clock
  • ISA Clock Select Enable
  • ISA MEM Block Base
  • ISA MEM Block Size
  • Infra Red Function
  • InfraRed Duplex Type
  • Init AGP Display First
  • Init Display First
  • KBC Input Clock
  • KBC Input Clock Select
  • Keyboard
  • Keyboard Controller Clock
  • Keyboard Reset Control
  • Keyboard/Mouse Power On
  • LOWA20# Select
  • Latency Timer
  • Latency for CPU to PCI write
  • Local Memory 15-16M
  • MPS 1.4 Support
  • MPS Version Control For OS
  • Master Retry Timer
  • Memory Hole
  • Memory Hole At 15M-16M
  • Memory Hole at 15M Addr
  • Memory Refresh Rate
  • Memory Test Tick Sound
  • Multimedia Mode
  • NA# Enable
  • NA# Pin Assertion
  • Numeric Processor Test
  • ONB AHA BIOS First
  • ONB SCSI LVD Term
  • ONB SCSI SE Term
  • OS/2 Onboard Memory > 64MB
  • On Board PCI/SCSI BIOS
  • Onboard AHA BIOS
  • Onboard IR Function
  • Onboard PCI IDE Enable
  • Onboard PCI SCSI Chip
  • Onboard UART 2 Mode
  • PCI 2.1 Compliance
  • PCI 2.1 Support
  • PCI Arbit. Rotate Priority
  • PCI Arbiter Mode
  • PCI Arbitration Mode
  • PCI Bus Arbitration
  • PCI Bus Parking
  • PCI Bus Time-out
  • PCI Clock Frequency
  • PCI Clocks
  • PCI Concurrency
  • PCI Delayed Transaction
  • PCI Dynamic Decoding
  • PCI IDE IRQ Map to
  • PCI IRQ Activated by
  • PCI Initial Latency Timer
  • PCI Latency Timer
  • PCI Master 0 WS Write
  • PCI Master Latency
  • PCI Passive Release
  • PCI Preempt Timer
  • PCI Preemption Timer
  • PCI master accesses shadow RAM
  • PCI to ISA Write Buffer
  • PCI/VGA Palette Snoop
  • PNP OS Installed
  • PS/2 Mouse Function Control
  • PWR Button less then 4 Secs
  • PWR Lost Resume State
  • PWR Up On Modem Act
  • PWRON After PWR-Fail
  • Paging Delay
  • Parallel Port Mode
  • Passive Release
  • Password Checking
  • Peer Concurrency
  • Pentium II Microcode
  • Power Button Function
  • Preempt PCI Master Option
  • Primary Display
  • Processor Number Feature
  • Processor S/N
  • Quick Boot
  • Quick Power On Self Test
  • RAM Area
  • RAS# Precharge
  • RAS# Precharge Period
  • RAS# Precharge Time
  • RTC Alarm Resume (From Soft)
  • RTC Wake Up Timer
  • RTC Y2K H/W Roll Over
  • Ref/Act Command Delay
  • Refresh Assertion
  • Refresh Cycle Time
  • Refresh During PCI Cycles
  • Refresh RAS Active Time
  • Refresh RAS# Assertion
  • Report No FDD For WIN 95
  • Reset Configuration Data
  • Resources Controlled By
  • Resume On LAN
  • Resume by Ring
  • Ring Resume From Soft Off
  • SDRAM Banks Close Policy
  • SDRAM CAS to RAS Delay
  • SDRAM CAS# Latency
  • SDRAM Configuration
  • SDRAM Page Control
  • SDRAM RAS Precharge Time
  • SDRAM RAS Precharge Time
  • SDRAM RAS# Precharge
  • SYMBIOS (NCR) SCSI BIOS
  • Security Option
  • Single ALE Enable
  • Slow Memory Refresh Divider
  • Slow Refresh
  • Slow Refresh Enable
  • Snoop Ahead
  • Speculative Leadoff
  • Spread Spectrum Modulated
  • Standby Mode
  • Stby Speed
  • Stop CPU at PCI Master
  • Suspend Switch
  • Swap Floppy Drive
  • System Boot Sequence
  • System Boot Up CPU Speed
  • System Boot Up Numlock Status
  • System Keyboard
  • System Thermal
  • Trigger Method
  • Turbo VGA (0 WS at A/B)
  • Turn-Around Insertion
  • Typematic Rate Delay
  • UART 1/2 Duplex Mode
  • UART 2 Mode
  • UART2 Mode Select
  • UR2 Duplex Mode
  • UR2 Mode
  • USB IRQ
  • USB Keyboard Support
  • Use An IRQ for USB
  • VGA 128k Range Attribute
  • VGA BIOS Sequence
  • VGA Frame Buffer
  • VGA Performance Mode
  • Video
  • Video BIOS Area Cacheable
  • Video BIOS Cacheable
  • Video Memory Cache Mode
  • Video Off After
  • Video Off Method
  • Video Off Option
  • Video Palette Snoop
  • Virus Protection
  • Virus Warning
  • Wait for F1 If Any Error
  • Wake On LAN
  • Weitek Coprocessor
  • x IR Transmission Delay
  • x KB Power On Hot Key
  • x KB Power On Password
  • x RxD, TxD Active


16 Bit ISA I/O Command WS

Данная опция используется для компенсации возможной разницы между скоростью работы системных устройств ПК и его периферии. Подобная компенсация необходима, например, если в системе не выделено дополнительное время ожидания/ответа устройства. В таком случае система может решить, что какое-либо неуспевающее ответить устройство вообще не функционирует и перестанет давать запросы на ввод/вывод из этого устройства. Данную опцию можно отключать (Disabled) для повышения быстродействия только в случае, если все ISA-устройства в таком режиме нормально функционируют, в противном случае возможна потеря данных. Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

либо есть возможность установить количество тактов ожидания вручную:

  • 0
  • 1
  • 2
  • 3

Что вы думаете об этой статье? Дайте нам знать.


16 Bit ISA Mem Command WS

Данная опция позволяет нужным образом соотнести скорость работы памяти ISA-устройства с возможностью системы записывать/читать из этой памяти. Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

либо есть возможность задать количество тактов вручную:

  • 0
  • 1
  • 2
  • 3

Что вы думаете об этой статье? Дайте нам знать.


Above 1 MB Memory Test

При выборе опции "Enabled" в процессе тестирования ОЗУ проверяется область памяти свыше 1 Мб (область памяти XMS - Extended Memory Specification). На это расходуется дополнительное время в процессе загрузки, тем более такой тест является излишним, так как драйвер-менеджер памяти HIMEM.SYS сам осуществляет проверку оперативной памяти и предпочтительнее использовать именно этот тест, так как он работает в реальном рабочем окружении.

Что вы думаете об этой статье? Дайте нам знать.


AC PWR Loss Restart

Рестарт после пропадания питания. Разрешение этого параметра позволяет системе включиться автоматически после пропадания питания. В противном случае после восстановления питания система не включится, и необходимо будет снова нажать кнопку подачи питания (Power). Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


ACPI Function

Функционирование ACPI. Разрешается или запрещается поддержка через BIOS стандарта ACPI. Включение этой функции имеет смысл, если только операционная система поддерживает ACPI. Если опция включена, система будет игнорировать установки полей "Suspend Mode", "HDD Power Down" и некоторых аналогичных, поскольку уже операционная система ("Windows 98" и выше) возьмет на себя решение многих вопросов. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено (по умолчанию)

Что вы думаете об этой статье? Дайте нам знать.


ACPI Suspend Type

Возможные значения:

  • "S1(POS)" - включение функции "Power On Suspend"
  • "S3(STR)" - включение функции "Suspend to RAM"

Современные материнские платы все чаще поддерживают режим "Suspend to RAM". При активации этого режима посредством интерфейса ACPI в "Windows 98" (или выше) компьютер полностью выключается, а питание сохраняется лишь для модулей памяти, куда и записывается информация о состоянии системы. После выхода из режима "STR" (путем нажатия клавиши на клавиатуре, по сигналу от модема, т.п.) состояние ПК, в том числе ОС и всех прикладных программ, восстанавливается.

Небольшая рекомендация! Для включения функции ACPI в процессе инсталляции "Windows 98" необходимо добавить следующие параметры в командную строку: setup.exe /pj.

Что вы думаете об этой статье? Дайте нам знать.


AGP

Смысл этой опции интуитивно понятен, а возможных параметров всего два:

  • "Enabled" (разрешено)
  • "Disabled" (запрещено)

Что вы думаете об этой статье? Дайте нам знать.


AGP-2x Mode

По умолчанию устанавливается "Disabled". "Enabled" выбирается лишь в случае, если графическая карта поддерживает режим AGP-2x.

Что вы думаете об этой статье? Дайте нам знать.


CPU Fast String

Быстрые операции со строками. Разрешение этого параметра позволяет использовать некоторые специфические особенности архитектуры семейства Pentium Pro (Pentium II, Deshutes и т.п.), в частности, возможность кэширования операций со строками. Hадо только понимать, что и в самой программе должны быть выполнены условия для включения этого механизма. Эти условия указаны в документации на любой процессор данного семейства. Параметр рекомендуется оставлять в состоянии "Разрешено". Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Auto Configuration

Опция автоматического конфигурирования параметров доступа к основной памяти. Опция обычно находится в разделах "Advanced Chipset Setup" или "Chipset Features Setup" и позволяет настроить время доступа к модулям памяти в автоматическом режиме либо в "ручном" режиме и в соответствии со спецификациями применяемых модулей памяти. Чтобы выйти на режим пользовательской настройки, достаточно установить параметр в "Disabled". Значение "Auto" (автоматическая конфигурация) устанавливается по умолчанию.

Среди возможных фиксированных значений обычно встречаются значения "60 ns" и "70 ns" для модулей памяти с соответствующим быстродействием в наносекундах. Опция может называться также "DRAM Auto Configuration" или "Auto Configure EDO DRAM Tim" ("tim" - это timing). В последней опции параметр "Enabled" заменил "Auto", в остальном отличий нет.

Значительно большие различия оказываются в том случае, когда под опцией "Auto Configuration" "скрывается" настройка параметров доброй половины соответствующего раздела "BIOS Setup". Тогда автоматически конфигурируются параметры кэш-памяти, основной памяти, регенерации и даже скорость ISA-шины.

Что вы думаете об этой статье? Дайте нам знать.


Flash BIOS Protection

Включение опции запрещает доступ к Flash BIOS вирусам и неопытным пользователям. При этом не может быть произведено обновление содержимого Flash BIOS. Для обновления функцию надо отключить. На некоторых материнских платах функция реализована не в виде опции "BIOS Setup", а в виде перемычки, либо не реализована вовсе. Желательно функцию включить. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


BIOS Update

Обновление BIOS. Процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon) имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров, за счет изменения микрокода. Обновления микрокода остаются в BIOS и загружаются в процессор в процессе выполнения инструкций BIOS. Именно поэтому BIOS для материнских плат с указанными выше процессорами необходимо регулярно обновлять. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


CPU Internal Cache

Разрешается/запрещается внутренний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Boot From LAN First

При установке в "Enabled" BIOS предпримет попытку первоначальной загрузки из сетевого загрузочного модуля, прежде чем пытаться загрузиться с локального носителя.

Что вы думаете об этой статье? Дайте нам знать.


Boot Sequence

Последовательность начальной загрузки системы. Определяется последовательность опроса накопителей для загрузки операционной системы. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства, например "CDROM" для накопителей CD-ROM. Поддерживаются устройства LS-120, Iomega ZIP, ATAPI CD-ROM, IDE- и SCSI-диски. Может принимать значения:

  • "A,C" - такой выбор оправдан только для случая загрузки с дискеты и встречается в старых моделях ПК
  • "A,C,SCSI"
  • "C only"
  • "C,A"
  • "C,A,SCSI"
  • "C,CDROM,A"
  • "CDROM,C,A"
  • "D,A,SCSI" (предназначено при использовании минимум двух IDE-жестких дисков)
  • "E,A,SCSI" (аналогично для 3-х дисков)
  • "F,A,SCSI" (аналогично для 4-х дисков)
  • "LS/ZIP,C"
  • "SCSI,A,C"
  • "SCSI,C,A"

В некоторых версиях BIOS опция "Boot Sequence" трансформировалась в несколько самостоятельных опций, естественно с большей возможностью отбора и большей гибкостью. Это выглядит следующим образом:

  • "First Boot Device"
  • "Second Boot Device"
  • "Third Boot Device"
  • "Boot Other Device"

Параметры могут принимать следующие значения:

  • "Floppy"
  • "HDD-0"
  • "HDD-1"
  • "HDD-2"
  • "HDD-3"
  • "LAN"
  • "SCSI"
  • "LS/ZIP"
  • "CDROM"
  • "Enable"
  • "Disable"

А один из вариантов "AMI BIOS" содержит те же опции, но со значениями:

  • "Floppy"
  • "Floptical" (RS 120)
  • "CD ROM"
  • "SCSI Device"
  • "Network"
  • "IDE0"
  • "IDE1"
  • "IDE2"

А опция "Try Other Boot Devices" через значение "Yes" дает возможность дополнительного выбора варианта загрузки, если имеющиеся варианты не устраивают пользователя.

Что вы думаете об этой статье? Дайте нам знать.


Boot Up Floppy Seek

Поиск дисковода при загрузке компьютера. Так можно перевести название этой функции. Но смысл функции значительно шире, поскольку BIOS проверяет, есть ли дисковод для дискет и идет ли речь при этом о 40- или 80-тидорожечном дисководе. При этом обеспечивается проверка работоспособности дисководов гибких дисков. Поскольку все современные дисководы имеют 80 дорожек (с 1993 года дисководы на 40 дорожек не выпускаются. Они поддерживали формат в 360 КБ), то эта функция необязательна.

Необходимо заметить, что BIOS не может определить разницу между 720K, 1.2M, 1.44M или 2.88M типами дисководов, т.к. все они имеют 80 дорожек. Имеет смысл установить эту опцию в "Disabled" (иначе - "Enabled"), что позволит сократить общее время тестирования ПК после включения.

Что вы думаете об этой статье? Дайте нам знать.


Boot Up Numlock Status

Опция, определяющая, в каком режиме после включения компьютера должна работать дополнительная цифровая клавиатура. Разрешение этого параметра включает индикатор "Num Lock", и цифровая клавиатура генерирует коды цифр и знаков, в противном случае генерируются коды стрелок, "Ins", "Del" и т.д. Может принимать значения:

  • "On" (иногда "Enabled") - включено
  • "Off" (иногда "Disabled") - отключено

Режим работы в любой момент времени меняется кнопкой NumLock.

Что вы думаете об этой статье? Дайте нам знать.


Boot Up System Speed

Опция выбора тактовой частоты процессора при загрузке. Значение "Low" переводит процессор в режим работы с половинной тактовой частотой и без использования внутренней кэш-памяти. Естественно, что изначально понижается пропускная способность системной шины. Такой режим может потребоваться при работе со старыми программами или платами расширения, а также при возможных проблемах при запуске системы. По умолчанию всегда устанавливается значение "High".

Что вы думаете об этой статье? Дайте нам знать.


Boot Virus Detection

Определение вируса в загрузочном секторе. Смысл этого параметра отличается от "Virus Warning" и заключается он в следующем. Если этот параметр запрещен ("Disabled"), то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. Но при этом никаких последствий для системы и пользователя не возникает. При установке параметра в "Enabled" BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора будет отличаться от сохраненного в памяти. При этом система выводит сообщение, и пользователю, далее, предоставляется возможность либо загрузить систему с жесткого диска, либо с дискеты.

Что вы думаете об этой статье? Дайте нам знать.


Burst Refresh

При разрешении этой установки чипсет проводит несколько регенераций за один такт. В обычном режиме одна строка регенерируется каждые 15 мкс, в пакетном 4 строки - каждые 60 мкс. Если BIOS позволяет, то рекомендуется конечно установить значение опции в "Enabled". Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Bus Mastering

Эта опция предназначалась еще не так давно для разрешения или запрещения работы устройств в режиме "Bus Master" на шине ISA. Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


CAS Before RAS Refresh

Метод регенерации памяти, когда сигнал CAS устанавливается раньше сигнала RAS. В отличие от стандартного способа регенерации, этот метод не требует перебора адресов строк извне микросхем памяти - используется внутренний счетчик адресов. Однако, этот способ регенерации должен поддерживаться микросхемами памяти (большинство чипов его поддерживает). Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


CAS# Latency

Задержка CAS - CL. Важнейшая характеристика чипа памяти, определяющая минимальное количество циклов тактового сигнала от момента запроса данных сигналом CAS (фактически - команда чтения) до их появления и устойчивого считывания с выводов модуля памяти. Возможные значения параметров:

  • 2
  • 3

или в тактах:

  • 2T
  • 3T

Значение в 3 такта устанавливается по умолчанию. Уменьшение параметра нужно осуществлять крайне осторожно.

Другое название опции - "CAS# Latency Clocks".

Столь важная характеристика памяти сохранила свою "важность" и с внедрением памяти типа SDRAM, а опция стала называться "SDRAM CAS# Latency" (или реже "SDRAM CAS Latency Time").

Отметим, что меньшее значение увеличивает производительность системы (установка в 2 такта в сравнении с 3-мя ускоряет систему на 1-2%). Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 нс или лучше.

Что вы думаете об этой статье? Дайте нам знать.


CAS to RAS Refresh Delay

Действие этой опции возможно при включенном состоянии предыдущей (или аналогичной), так как в данном случае устанавливается время задержки между стробирующими сигналами (в тактах системной шины). Естественно, что установка меньшего значения приводит к снижению времени, затрачиваемого на регенерацию. Большее же значение повышает надежность, т.е. достоверность данных, находящихся в памяти. Оптимальный вариант для данной системы выбирается опытным путем. Может принимать значения:

  • 1T
  • 2T

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


Chipset Special Features

Специальные возможности чипсета. Данный параметр разрешает/запрещает все новые функции, появившиеся в 430-х наборах Intel (HX, VX или TX) по сравнению с FX. Если установлено "Disabled", чипсет функционирует как 82430FX. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Concurrent Refresh

Паpаллельная регенерация. При активизации этой опции как чипсет (т.е. оборудование, требующее регенерации), так и процессор получают одновременный доступ к памяти. При этом процессору не нужно будет ожидать, пока произойдет регенерация. При установке опции в "Disabled" процессор должен будет ждать, пока схема регенерации не закончит работу.

Что вы думаете об этой статье? Дайте нам знать.


CPU Critical Temperature

Задание предельной температуры центрального процессора. При ее превышении BIOS выдаст сообщение. Возможные варианты:

  • Disabled
  • 45 °C
  • 50 °C
  • 55 °C
  • 60 °C
  • 65 °C
  • 70 °C
  • 75 °C

Что вы думаете об этой статье? Дайте нам знать.

17/06/2002


CPU External Cache

Разрешается/запрещается внешний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


PCI 2.1 Support

Поддержка спецификации шины PCI 2.1. При разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от спецификации 2.0: максимальная тактовая частота шины увеличена до 66 МГц и вводится механизм моста PCI-PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. Запрещение этого параметра имеет смысл только при возникновении проблем после установки дополнительной PCI-платы (как правило, проблемы могут возникнуть только с достаточно старыми PCI-устройствами). Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


PCI 2.1 Compliance

См. "PCI 2.1 Support".

Что вы думаете об этой статье? Дайте нам знать.


ISA 16-bit I/O Wait States

См. "16 Bit ISA I/O Command WS".

Что вы думаете об этой статье? Дайте нам знать.


ISA 16-bit Mem Wait States

См. "16 Bit ISA Mem Command WS".

Что вы думаете об этой статье? Дайте нам знать.


System Boot Up CPU Speed

См. "Boot Up System Speed".

Что вы думаете об этой статье? Дайте нам знать.


BootSector Virus Detection

См. "Boot Virus Detection".

Что вы думаете об этой статье? Дайте нам знать.


DRAM Burst at 4 Refresh

См. "Burst Refresh".

Что вы думаете об этой статье? Дайте нам знать.


System Boot Sequence

См. "Boot Sequence".

Что вы думаете об этой статье? Дайте нам знать.


System Boot Up Numlock Status

См. "Boot Up Numlock Status".

Что вы думаете об этой статье? Дайте нам знать.


Pentium II Microcode

См. "BIOS Update".

Что вы думаете об этой статье? Дайте нам знать.


CPU MicroCode Updation

См. "BIOS Update".

Что вы думаете об этой статье? Дайте нам знать.


CPU Level 2 ECC Checking

См. "CPU Level 2 Cache ECC Check"

Что вы думаете об этой статье? Дайте нам знать.


CPU L2 Cache ECC Checking

См. "CPU Level 2 Cache ECC Check"


CPU Level 1 Cache

Разрешается/запрещается кэш первого уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CPU Level 2 Cache

Разрешается/запрещается кэш второго уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CPU Level 2 Cache ECC Check

Опция включения/отключения коррекции ошибок кэша второго уровня у процессоров архитектуры Pentium II и выше, которые поддерживают эту опцию. К примеру, процессоры Pentium II поддерживает коррекцию ошибок, начиная с частоты в 333 МГц. ECC-коррекция несомненно повышает надежность системы, но при этом ее работа, как правило, несколько замедляется. В некоторых процессорах допущены ошибки, и включение этого режима может привести к нестабильной работе системы. К тому же фактор надежности играет значительную роль только в сетевых средах. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Data Integrity (PAR/ECC)

См. "DRAM Data Integrity Mode"


DRAM Page Mode

См. "CPU to DRAM Page Mode"


DRAM Paging

См. "CPU to DRAM Page Mode"


DRAM Paging Mode

См. "CPU to DRAM Page Mode"


SDRAM Page Control

См. "CPU to DRAM Page Mode"


CPU to DRAM Page Mode

Когда опция установлена в "Disabled", контроллер памяти закрывает страницу памяти после доступа к ней. Когда опция включена (по умолчанию), страница памяти остается открытой на случай повторного обращения к ней. Такой режим работы памяти более производителен.

В различных версиях BIOS можно найти опции с одинаковыми названиями, но различными значениями параметров. Например, "CPU to DRAM Page Mode" может предоставить для выбора значения "Use Paging" и "No Paging". Возможны и следующие вариации: "Always Open" и "Closes", "Page Closes", "Stays Open" и "Closes If Idle", "Normal" и "Disabled".

В некоторых случаях усовершенствованный (enhanced) механизм работы чипсета и контроллера памяти позволяет с помощью дополнительной информации об открытой странице памяти сохранять ее некоторое время открытой даже при отключенной опции: "DRAM Enhanced Paging", "Enhanced Page Mode", "Enhanced Paging".

Что вы думаете об этой статье? Дайте нам знать.


CPU-to-PCI Buffer

См. "CPU-to-PCI Write Buffer"


Latency for CPU to PCI write

См. "CPU-to-PCI Write Latency"


CPU-to-PCI 6 DW FIFO

Опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 6-х двойных слов (Double Word). Работа с буфером построена по принципу "первым пришел - первым ушел" (First Input - First Output). Естественно, что буферизация передачи информации повышает быстродействие системы, но в таком виде эта опция встречается уже редко.

Что вы думаете об этой статье? Дайте нам знать.


CPU-to-PCI IDE Posting

Включение данного режима позволяет оптимизировать циклы записи из CPU в интерфейс PCI IDE путем предварительной буферизации. Параметр рекомендуется устанавливать в состояние "Enabled". Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


CPU-to-PCI Read Buffer

Опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 4-х двойных слов, не прерывая при этом работу процессора. Процессор может работать в это время над другой задачей, что повышает общую производительность. Эта опция должна быть включена обязательно. В отключенном же состоянии буфер не будет использоваться, и циклы чтения процессора не будут заканчиваться до тех пор, пока шина PCI не подаст сигнал о готовности получить данные.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


CPU-to-PCI Write Buffer

Во включенном состоянии опции процессор сможет записывать по 4 слова за один такт в буфер записи шины PCI до завершения цикла PCI-шины. При установке параметра в "Disabled" процессор будет находиться в ожидании после каждого цикла записи и до тех пор, пока шина PCI не сообщит процессору о своей готовности к приему данных.

Что вы думаете об этой статье? Дайте нам знать.


CPU-to-PCI Write Latency

Определение времени задержки перед операцией записи данных из процессора в шину (в тактах системной шины). Установка меньшего значения позволяет увеличить производительность, однако при этом возможно увеличение нестабильности работы системы. Тогда необходимо будет вернуться к большему значению. Возможный ряд значений:

  • 1T
  • 2T
  • 3T

Что вы думаете об этой статье? Дайте нам знать.

22/06/2002


Quick Boot

См. "Quick Power On Self Test"


Quick Power On Self Test

Быстрый тест компьютера после включения питания. Разрешение этого параметра приводит к некоторому сокращению времени на начальное самотестирование компьютера POST, особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Сокращение времени тестирования происходит также за счет пропуска некоторых пунктов проверки. Если при работе ПК возникают какие-либо проблемы, то лучше при его включении осуществлять полный тест. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Hard Disk Pre-Delay

См. "Delay IDE Initial"


Delay For HDD (Secs)

См. "Delay IDE Initial"


PCI Delayed Transaction

См. "Delayed Transaction"


Delayed Transaction Optimization

См. "Delayed Transaction"


Delayed Transaction Timer

См. "Delayed Transaction"


Daylight Saving

Во включенном состоянии ("Enabled") эта опция позволяет автоматически добавлять или вычитать один час при весеннем или осеннем переводе времени (последнее воскресенье апреля и аналогично в октябре). Этот параметр можно отключить, если установлена Windows, самостоятельно регулирующая этот процесс.

Что вы думаете об этой статье? Дайте нам знать.


Delay IDE Initial

Задержка инициализации IDE-устройства. В данном параметре устанавливается интервал времени (в секундах), в течение которого IDE-устройство не будет опрашиваться BIOS после включения питания. Ненулевое значение параметра рекомендуется устанавливать только в случае применения старых жестких дисков. Не все старые приводы способны достичь номинальной скорости вращения за время, которое при включении ПК проходит до начала тестирования жесткого диска. Опция была введена первоначально в "AMI BIOS" для использования старых накопителей и позднее была оставлена для совместимости.

Что вы думаете об этой статье? Дайте нам знать.


Delayed Transaction

Специальные возможности чипсета - задержанная транзакция на PCI. Присутствие этого параметра в BIOS означает, что на материнской плате есть встроенный 32-битный буфер с задержанной записью для поддержки удлиненного цикла обмена на PCI-шине. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-разрядным устройствам на шине ISA. Это существенно увеличивает производительность системы, так как цикл такого обращения на ISA-шине занимает 50-60 тактов шины PCI. Если компьютер укомплектован материнской платой, не поддерживающей спецификацию PCI 2.1, этот параметр следует запретить, поскольку данная опция включает режим совместимости со спецификацией PCI версии 2.1 с одновременным включением в "северном" мосте упомянутого выше специального буфера. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Deturbo Mode

При разрешении этого параметра сигнал FLUSH# становится активным и никакие данные после этого не кэшируются процессором в свой внутренний кэш (кэш первого уровня) процессорами архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Разрешение этого параметра следует использовать только при необходимости сознательно замедлить работу компьютера. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

22/06/2002


DMA n Assigned to

Канал DMA с номером n назначен на... Каждому каналу DMA системы может быть назначен один из следующих типов устройств:

  • "Legacy ISA" - Классические ISA-карты. Это стандартные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки Plug&Play. Эти карты требуют назначения каналов DMA в соответствии с документацией на них.
  • "PCI/ISA PnP" - Устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play.

Что вы думаете об этой статье? Дайте нам знать.


Resume On LAN

См. "Wake On LAN"


Virus Protection

См. "Virus Warning"


BootSector Virus Protection

См. "Virus Warning"


Virus Warning

Предупреждение о вирусе. Разрешение этого параметра ("Enabled") запрещает любую запись в загрузочный сектор жесткого диска или таблицу разделов (partition table). При попытке изменения этих областей BIOS останавливает систему с выводом на экран монитора соответствующего сообщения, а также звукового сигнала. При этом пользователь может либо pазpешить запись, либо запpетить ее.

Технически эта задача решается следующим образом. На этапе проведения POST-теста перед входом в процедуру обработки дискового сервиса (INT13h) устанавливается транзитный программный модуль, который анализирует входные параметры функции и детектирует две ситуации: попытку записи в BOOT Sector и попытку форматирования 0-й дорожки. Если система условий выполняется, вместо дисковой операции выдается предупреждающее сообщение и звуковой сигнал. На соответствующем шаге теста выполняется перестановка вектора INT13h на транзитный контролирующий модуль, если в "BIOS Setup" включен данный режим. Данный алгоритм, в зависимости от прошивок, может видоизменяться, но суть останется прежней. Подобным образом BIOS отслеживает ситуацию и при работе операционной системы.

Опция введена для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Стандартные действия при этом - запуск антивирусных программ, прежде всего с защищенных дискет.

Эта опция должна быть обязательно отключена при форматировании жесткого диска, при вводе команды "FDISK /MBR", при инсталляции операционных систем. Кроме того, некоторые диагностические программы при обращении к boot-сектору могут вызвать появление сообщения о "вирусной атаке", что не отражает текущую ситуацию. Применение этой функции не имеет смысла в случае использования SCSI- и ESDI-дисков, поскольку они используют собственный BIOS на контpоллеpе.

Еще одним из возможных вариантов параметра может быть значение "ChipAway", с одной стороны это значение - аналог "Enabled", с другой - это один из варинтов встроенного антивируса. При старте машины выводится надпись "ChipAway Virus Enabled", что не должно пугать пользователя.

Что вы думаете об этой статье? Дайте нам знать.


Wait for F1 If Any Error

Если опция включена, BIOS будет ожидать нажатия клавиши "F1" для продолжения загрузки в случае какой-либо неисправности на стадии тестирования POST, но только в случае нефатальной ошибки. Если установлено в "Disabled", система выводит пpедупреждение и пpодолжает загpузку без ожидания нажатия клавиши. Рекомендуется устанавливать в "Enabled". "Disabled" может быть рекомендовано для серверных систем.

Что вы думаете об этой статье? Дайте нам знать.


Wake On LAN

Пробуждение от сети. При разрешении этого параметра компьютер включается по сигналу от локальной сети. Такое включение возможно только при установке в компьютер сетевой карты, поддерживающей удаленное "пробуждение". Стоит напомнить, что если система находится в режиме "Suspend", то она пробуждается только через активизацию IRQ или DMA. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Weitek Coprocessor

Cопpоцессоp Weitek. Если он имеется в системе, следует установить "Enabled". Интересно, что производительность этого сопроцессора в 2-3 раза превышала производительность стандартных интеловских. Сопроцессор Weitek использует (скорее, использовал) некотоpую часть системного ОЗУ, поэтому память из этой области должна была быть отобpажена где-нибудь в дpугих адpесах. Одна из "древних" опций "AMI BIOS".

Что вы думаете об этой статье? Дайте нам знать.


x RxD, TxD Active

Опция установки полярности сигналов приема/передачи инфракрасного интерфейса. Стоит упомянуть, что "RxD" означает receiver (приемник), а "TxD" - transmitter (передатчик). Для установки параметра необходимо из документации выяснить, в каком режиме должны работать эти сигналы приемо/передатчика. В качестве значений используются комбинации параметров "High" и "Low". Опция может принимать значения:

  • "Hi,Lo"
  • "Lo,Hi"
  • "Lo,Lo"
  • "Hi,Hi"

Что вы думаете об этой статье? Дайте нам знать.


Keyboard Controller Clock

См. "KBC Input Clock Select"


KBC Input Clock Select

Контроль частоты тактового сигнала контроллера клавиатуры. Параметром задается, проще говоря, скорость, с которой центральный процессор связывается с контроллером клавиатуры. Таким образом, параметр служит для изменения скоростных характеристик работы клавиатуры и повышения стабильности ее работы. Значение параметра как "12 MHz" устанавливается по умолчанию. Если возникли проблемы при работе с клавиатурой, необходимо уменьшить значение параметра. Параметр может принимать значения: "8 MHz", "12 MHz", "16 MHz".

Что вы думаете об этой статье? Дайте нам знать.


Doze Mode

Режим засыпания. Устанавливает время перехода или запрещает переход в первую стадию снижения энергопотребления. Может принимать значения:

  • 30 Sec
  • 1 Min
  • 2 Min
  • 4 Мin
  • 8 Min
  • 20 Min
  • 30 Min
  • 40 Min
  • 1 Hour
  • Disabled

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Doze Speed

Частота процессора в режиме Doze. Определяет коэффициент деления тактовой частоты в режиме Doze (засыпание).

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


x KB Power On Password

Когда в базовой опции выбрано значение "Password", активным становится поле "KB Power On Password". За нажатием клавиши "ENTER" следует ввод пароля. При выходе из режима "Suspend" необходимо ввести корректный пароль, иначе не спасет и кнопка включения питания.

Что вы думаете об этой статье? Дайте нам знать.


DRAM Data Integrity Mode

Опция включения/отключения проверки целостности памяти. Включение опции позволит системе отслеживать и корректировать однобитные ошибки. Так же будут обнаруживаться двухбитные ошибки, но без исправления. Использование режима коррекции ошибок обеспечивает увеличение стабильности и целостности данных в системе, правда, при небольшой потере производительности. Если в системе не используются ECC-модули памяти, то опция должна быть отключена. Может принимать значения:

  • "ECC" - разрешена коррекция
  • "Non-ECC" - коррекция запрещена

Что вы думаете об этой статье? Дайте нам знать.


DRAM ECC/PARITY Select

Опция выбора режима коррекции ошибок/проверки по четности. Эта опция появляется только в BIOS тех материнских плат, в которых чипсет поддерживает ECC, и может быть использована только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром "DRAM Data Integrity Mode" или аналогичным. Параметр может принимать значения:

  • "Parity" (по умолчанию) - в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается
  • "ECC" - в случае возникновения одиночной ошибки она исправляется и работа системы продолжается. Если имеет место не одиночная ошибка, то работа компьютера также приостанавливается. Следует только учесть, что, по данным "Intel", скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%.

Что вы думаете об этой статье? Дайте нам знать.


DRAM Idle Timer

См. "DRAM Page Idle Timer"


Paging Delay

См. "DRAM Page Idle Timer"


x KB Power On Hot Key

При выборе значения "Hot Key" активируется поле "KB Power On Hot Key". Пользователю предлагается на выбор один из вариантов для запуска системы с помощью "горячих клавиш" из ряда: "Ctrl-F1" - "Ctrl-F12".

А с "Keyboard 98" объяснение следующее. Это значение будет работать, если ПК укомплектован "Windows 98"-совместимой клавиатурой, на которой есть клавиша "Wake Up" (или просто "Wake"). Тогда для пробуждения системы будет использоваться только эта клавиша.

Что вы думаете об этой статье? Дайте нам знать.


DRAM Page Idle Timer

Таймер пассивного состояния страницы памяти. С помощью этой функции устанавливается время (в системных тактах), в течение которого контроллер DRAM, после перехода процессора в режим ожидания, ждет закрытия всех открытых страниц памяти.

Параметр сохранил свою актуальность со времен FPM. Для увеличения быстродействия устанавливается минимальное значение данного параметра, однако при этом возможна нестабильная работа системы. Оптимальный вариант устанавливается опытным путем. Может принимать значения:

  • 0
  • 2
  • 4
  • 8
  • 10
  • 12
  • 16
  • 32
  • 64
  • 128
  • INFINITE

Что вы думаете об этой статье? Дайте нам знать.

18/07/2002


DRAM RAS Only Refresh

Включение/отключение метода обновления DRAM, альтернативного методу "CAS-before-RAS". Если BIOS содержит другие возможности по регенерации памяти, то эту опцию необходимо отключить. В противном случае придется использовать этот устаревший метод обновления памяти.

Что вы думаете об этой статье? Дайте нам знать.


DRAM RAS# Precharge Time

Время предварительного заряда по RAS. Эта функция позволяет установить время (в тактах системной шины) для формирования сигнала RAS (иногда говорят о накоплении заряда по RAS) до начала цикла регенерации памяти. Уменьшение этого значения увеличивает быстродействие. Но если установлено недостаточное время, регенерация может быть некомплектной, что в итоге приведет к потере данных, находящихся в памяти. Возможные значения могут быть представлены в различном виде: в виде цифровых значений - "3", "4" и т.д.; с указанием системных тактов - "3 Clocks" или "1T". А ряд значений, как правило, следующий:

  • 0T
  • 1T
  • 2T
  • 3T
  • 4T
  • 5T
  • 6T

В новых версиях BIOS стали "встречаться" новые виды значений, например, "Same as FPM" и "FPM-1T", "Fast" и "Normal", "Fast" и "Slow". Для последней пары параметров "Slow" (медленно) равносильно увеличению количества тактов, что повышает стабильность работы системы, поэтому значение "Fast" следует устанавливать в случае уверенности в качестве модулей памяти.

Что вы думаете об этой статье? Дайте нам знать.


DRAM RAS# Precharge Period

См. "DRAM RAS# Precharge Time"


RAS# Precharge Time

См. "DRAM RAS# Precharge Time"


RAS# Precharge Period

См. "DRAM RAS# Precharge Time"


FPM DRAM RAS# Precharge

См. "DRAM RAS# Precharge Time"


FPM RAS Precharge

См. "DRAM RAS# Precharge Time"


RAS# Precharge

См. "DRAM RAS# Precharge Time"


EDO RAS Precharge

См. "DRAM RAS# Precharge Time"


EDO RAS# Precharge Time

См. "DRAM RAS# Precharge Time"


EDO RAS Precharge Timing

См. "DRAM RAS# Precharge Time"


FPM/EDO RAS# Precharge Time

См. "DRAM RAS# Precharge Time"


SDRAM RAS Precharge Time

См. "DRAM RAS# Precharge Time"


SDRAM RAS# Precharge

См. "DRAM RAS# Precharge Time"


Refresh Cycle Time

См. "DRAM Refresh Period"


DRAM Refresh Cycle Time

См. "DRAM Refresh Period"


Memory Refresh Rate

См. "DRAM Refresh Period"


DRAM Refresh Rate

См. "DRAM Refresh Period"


DRAM Refresh Period

Установка периода (частоты повтора), требуемого для регенерации памяти, в соответствии со спецификацией модулей памяти. В новейших версиях BIOS такая опция практически не встречается. Ранее же она предлагала пользователю широкий простор для творчества: в зависимости от версии BIOS и его производителя, чипсета, модулей памяти.

Вот неполный перечень таких вариаций: "For 50 MHz Bus", "For 60 MHz Bus", "For 66 MHz Bus" и даже "Disabled", "50/66 MHz", "60/60 MHz", "66/66 MHz", "Disabled", "15.6 us", "31.2 us", "62.4 us", "124.8 us", "249.6 us", "15.6 us", "31.2 us", "62.4 us", "125 us", "250 us", "15.6 us", "62.4 us", "124.8 us", "187.2 us", "1040 Clocks", "1300 Clocks", "Disabled", "Normal", "Fast", "Slow".

Остается отметить, что чем реже производится регенерация памяти, тем эффективнее работает система. Но если явно наблюдаются нарушения в работе системы, то частоту обновления необходимо повысить.

Что вы думаете об этой статье? Дайте нам знать.


Drive NA before BRDY

Когда выбрано "Enabled", сигнал NA (читай ниже) устанавливается на один такт раньше последнего сигнала BRDY# в каждом цикле чтения/записи, таким образом вызывая генерацию процессором сигнала ADS# в следующем цикле после BRDY#, устраняя один потерянный цикл. С помощью сигнала BRDY# (Bus Ready) чипсет (точнее, т.н. "северный мост") сообщает процессору о том, что данные доступны для чтения или есть готовность для приема данных для их записи.

Что вы думаете об этой статье? Дайте нам знать.


x IR Transmission Delay

При выборе "Enabled" устанавливается режим медленной передачи данных, что может быть рекомендовано при появлении ошибок. Установка в "Disabled" снимает ограничения (задержки) на скоростные характеристики интерфейса.

Что вы думаете об этой статье? Дайте нам знать.


NA# Pin Assertion

См. "NA# Enable"


NA# Enable

Опция включения/отключения сигнала NA (Next Address). Установив "Enabled", мы включаем механизм конвейеризации, при которой чипсет сигнализирует центральному процессору о выдаче нового адреса памяти еще до того, как все данные, переданные в текущем цикле, будут обработаны. Естественно, что включение такого режима повышает производительность системы.

Что вы думаете об этой статье? Дайте нам знать.


Numeric Processor Test

Речь в данной опции идет о проверке математического сопроцессора (FPU - Floating Point Unit). Хотя эта опция и устарела, но тем не менее парк стареньких ПК еще не исчез бесследно. Устанавливается в "Disabled", если сопроцессор отсутствует (386SX, 386DX, 486SX, 486SLC, 486DLC, более низкие модели). Пpи отключении этого теста сопpоцессоp, если он даже и пpисутствует в системе, не pаспознается и считается отсутствующим.

Что вы думаете об этой статье? Дайте нам знать.


Primary Display

См. "Video"


Video

Установка типа видеоадаптера для первичного системного монитора. Хотя вторичный монитор поддерживается и некоторыми ОС, установки в "BIOS Setup" для него отсутствуют. По умолчанию устанавливается "EGA/VGA". Возможны варианты:

  • "Absent" - отсутствует
  • "Mono" (Monochrome) - для монохромных видеоадаптеров
  • "Hercules" - также для монохромных видеоадаптеров
  • "MDA" - для монохромных видеоадаптеров, поддерживающих только текст
  • "CGA 80" (Color Graphics Adapter) - для режима 80 колонок
  • "CGA 40" (Color Graphics Adapter) - для режима 40 колонок
  • "EGA/VGA" (Enhanced Graphics Adapter/Video Graphics Array) - для EGA-, VGA-, SVGA- и PGA-адаптеров мониторов. Последний параметр может называться и "VGA/PGA/EGA"

Необходимо вспомнить и о применении жидкокристаллических дисплеев. Опция может называться "LCD&CRT", а значения параметра могут быть следующие:

  • "LCD" (Liquid Crystal Display) - жидкокристаллический дисплей
  • "CRT" (Cathode Ray Tube) - дисплей с электронно-лучевой трубкой
  • "AUTO" - автоматическое определение устройства
  • "LCD&CRT" - объединенный параметр

Что вы думаете об этой статье? Дайте нам знать.


16 Bit I/O Recovery Time

Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel - порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 16-ти разрядного устройства. Может принимать значения от 1 до 4 тактов.

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


8 Bit I/O Recovery Time

Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel - порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Кроме этого 8-ми разрядные устройства ввода/вывода сами по себе, как правило, медленнее 16-ти разрядных устройств ввода/вывода. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 8-ми разрядного устройства. Может принимать значения от 1 до 8 тактов.

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


Automatic Power Up

Автоматическое включение. Используя этот параметр, можно включать компьютер ежедневно в указанное время или включить его в указанный день и час. Может принимать значения:

  • Everday (ежедневно) - при вводе времени компьютер будет включаться ежедневно в назначенное время. Время вводится в поле "Time (hh:mm:ss) Alarm" в порядке часы:минуты:секунды либо клавишами PgUp, PgDn, либо непосредственным вводом чисел.
  • By Date (по дате) - компьютер включится в заданный день и в заданное время. При выборе этого параметра появляется поле для ввода времени (такое же, как и для Everyday) и поле для ввода дня месяца "Date of Month Alarm" - день месяца - в этом поле вводится число в месяце. Это автоматически означает, что запрограммировать включение компьютера можно только внутри одного месяца.
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Chassis Fan Speed

Наблюдение за скоростью вращения дополнительного вентилятора в корпусе компьютера. Если выбрано "Ignore", то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

Что вы думаете об этой статье? Дайте нам знать.


Fast RAS# to CAS# Delay

См. "DRAM RAS to CAS Delay"


CPU Fan Speed

Наблюдение за скоростью вращения вентилятора охлаждения процессора. Если выбрано "Ignore", то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

Что вы думаете об этой статье? Дайте нам знать.


CPU Temperature

См. "CPU Critical Temperature"


DRAM RAS to CAS Delay

Задержка между RAS и CAS. Во время доступа к памяти обращения к столбцам и строкам выполняются отдельно друг от друга. Этот параметр и определяет отстояние одного сигнала от другого. Параметр может принимать значения:

  • 3 - три такта задержки
  • 2 - два такта задержки

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


DRAM Read Burst Timing

Время пакетного чтения памяти. Запрос на чтение и запись генерируется процессором в четыре раздельные фазы. В первой фазе инициируется обращение к конкретной области памяти, а в оставшихся происходит собственно чтение данных. Параметр может принимать значения:

  • x2222 - два такта задержки
  • x3333 - три такта задержки
  • x4444 - четыре такта задержки

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


DRAM R/W Leadoff Timing

Число тактов при подготовке выполнения операции чтения/записи. Определяет число тактов на шине до выполнения любых операций с DRAM. Параметр может принимать значения:

  • 8/7 - восемь тактов для чтения и семь тактов для записи
  • 7/5 - семь тактов для чтения и пять тактов для записи

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


Error Halt

См. "Halt On"


Halt On

Сразу после включения ПК, во время теста самопроверки POST, при нахождении какой-либо аппаратной ошибки система прекращает загрузку и выводит наименование устройства, вызвавшего сбой. Будет ли произведена остановка, и в каких случаях это произойдет, как раз и определяет параметр команды "Halt On". Возможными параметрами являются:

  • "No Errors" - POST никогда не прерывает работу, какая бы не фатальная для системы ошибка не была обнаружена (нарушение работы устройства или даже его отсутствие)
  • "All Errors" - остановка работы при возникновении любой критической, но не фатальной, ошибки
  • "All, But Keyboard" - остановка при любой критической ошибке, кроме ошибки клавиатуры
  • "All, But Diskette" - аналогично, только с игнорированием ошибок дисководов
  • "All, But Disk/Key" - игнорирование ошибок клавиатуры и дисководов

Что вы думаете об этой статье? Дайте нам знать.


ECP DMA Select

Выбор канала DMA для режима ECP параллельного порта. Параметр появляется только при разрешении режима ECP или ECP+EPP в "Parallel Port Mode". Для нормальной поддержки режима ECP требуется задействовать канал DMA, который выбирается из каналов 1 или 3. Может принимать значения:

  • 1 - канал 1
  • 3 - канал 3
  • Disabled - запрещено использовать DMA

Что вы думаете об этой статье? Дайте нам знать.


Parallel Port Mode

Режим работы параллельного порта. Параметр позволяет задать режимы работы параллельного порта. Следует учитывать, что скорость обмена для некоторых устройств может быть существенно увеличена при правильной установке режима работы порта принтера, например, для внешних устройств хранения информации типа Iomega ZIP Drive LPT. Может принимать значения:

  • Normal - обычный интерфейс принтера, также называется SPP
  • ECP - порт с расширенными возможностями
  • EPP - расширенный принтерный порт
  • ECP+EPP - можно использовать оба режима

Что вы думаете об этой статье? Дайте нам знать.

19/07/2002


RAM Area

См. "Extended ROM RAM Area"


Enable Master

Установка в "Enabled" позволяет системе придать выбранному устройству статус "master"-устройства на PCI-шине, а также проверить, способно ли это устройство контролировать шину.

Что вы думаете об этой статье? Дайте нам знать.


Extended Refresh

Расширенная регенерация. Введение (в свое время) этой опции в BIOS предполагало использование специальных EDO-чипов. Регенерация содержимого ячеек EDO DRAM при этом стала производиться через 125 мкс, а не через каждые 15.6 мкс, как при стандартной регенерации. Это несколько повысило общее быстродействие памяти.

Что вы думаете об этой статье? Дайте нам знать.

25/08/2002


Extended ROM RAM Area

Наличие этой опции характерно для старых версий "AMI BIOS". Пользователю предоставляется выбор, где хранить данные о жестком диске: в верхнем килобайте системной памяти, начиная с 639-го килобайта, или в адресах нижней памяти в области системного BIOS (0:300). Необходимо помнить, что вторая адресная область может также использоваться звуковыми, сетевыми и т.п. картами расширения. В этом случае конфликтов можно избежать, если система через BIOS может использовать механизмы "затенения", которые впрочем могут отсутствовать в очень старых системах.

Что вы думаете об этой статье? Дайте нам знать.


Fast Gate A20 Option

См. "Gate A20 Option"


LOWA20# Select

См. "Gate A20 Option"


Init Display First

См. "Init AGP Display First"


Graphics Adaptor

См. "Init AGP Display First"


VGA BIOS Sequence

См. "Init AGP Display First"


IR Transfer Mode

См. "IR Duplex Mode"


UR2 Duplex Mode

См. "IR Duplex Mode"


UART 1/2 Duplex Mode

См. "IR Duplex Mode"


Duplex Select

См. "IR Duplex Mode"


InfraRed Duplex Type

См. "IR Duplex Mode"


IR Function Duplex

См. "IR Duplex Mode"


Assign IRQ For VGA

См. "IRQ to PCI VGA"


ISA Clock Select Enable

См. "ISA Bus Clock"


ISA MEM Block Size

См. "ISA MEM Block Base"


Floppy Disk Access Control (R/W)

Функция определяет возможность чтения/записи на дискеты. Включение опции как "Read only" позволит защитить информацию от несанкционированного копирования. Некоторые BIOS в качестве значений параметра имеют обычные "Enabled" и "Disabled". В этом случае разрешение этого параметра позволяет записывать информацию на дискету, а в противном случае дискету можно только читать.

Что вы думаете об этой статье? Дайте нам знать.


Gate A20 Option

Вариант включения линии A20. Параметр позволяет управлять способом включения адресной линии A20, которая отвечает за доступ к памяти, физические адреса которой превышают 1 Мбайт. Стоит напомнить, что 20-разрядная адресная шина позволяет адресоваться в пределах первого мегабайта памяти. Если быть более точным, то эта линия отвечает за доступ к первым 64 килобайтам верхней памяти, известным как область HMA (High Memory Area).

Доступ к HMA требует управления специальным аппаратным узлом, работа которого может быть блокирована или активизирована. При установке опции "Gate A20 Option" в состояние "FAST" работа линии как раз и будет контролироваться специальным набором микросхем на системной плате. Если линия А20 деблокирована, то HMA-область доступна для любой программы, работающей в реальном режиме. Обычно эта область памяти отдается под MS-DOS, а для деблокирования линии используется драйвер HIMEM.SYS.

На старых машинах контролем A20 занимался контроллер клавиатуры, теперь это переложено на системную логику. Но есть категория пользователей, использующих старое программное обеспечение. Для таких и предназначена эта опция. Это означает, что наличие такой опции связано с совместимостью со старым ПО. Необходимо также отметить, что некоторые драйверы MS-DOS, например VDISK.SYS, могут блокировать линию А20, входя в конфликт с драйвером HIMEM.SYS.

С другой стороны установка опции в "Fast" может значительно повысить производительность системы под "OS/2" и "Windows". Может принимать значения:

  • "Fast" - управление осуществляется чипсет, что повышает скорость работы
  • "Normal" - управление осуществляется через контроллер клавиатуры

Что вы думаете об этой статье? Дайте нам знать.


Graphics (AGP) Aperture Size

Размер графической апертуры для AGP. Апертурой называется порция адресов памяти PCI, выделенная в адреса графической памяти. Циклы, обращающиеся к этим адресам, не требуют трансляции и передаются напрямую в AGP. Кроме того, размер указывает максимальный объем системной памяти, выделяемый для хранения текстур. Размер апертуры незначительно сказывается на производительности. Но большинство современных адаптеров требует более 8МБ апертуры для нормального функционирования.

Замечено также, что на акселераторах TNT тесты по обработке больших массивов текстур существенно замедлялись в случае выделения менее 64МБ памяти. На текущий момент стандартным размером является значение "64M". Нет смысла увеличивать это число, так как увеличивается размер GART таблицы. Доступный ряд значений графической апертуры:

  • 4M
  • 8M
  • 16M
  • 32M
  • 64M
  • 128M
  • 256M

Что вы думаете об этой статье? Дайте нам знать.


HDD Power Down

Выключение жесткого диска. Устанавливает либо время, через которое при отсутствии обращения жесткий диск будет выключен, либо запрещает такое выключение вообще. Параметр не оказывает влияние на диски SCSI.

Может принимать значения от 1 до 15 минут, Disabled - запрещено.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


HDD S.M.A.R.T Capability

Возможность S.M.A.R.T диагностики. Позволяет разрешать/запрещать возможность диагностики состояния жесткого диска в соответствии с требованиями стандарта S.M.A.R.T. Авторы BIOS, к сожалению, не раскрывают механизма функционирования S.M.A.R.T диагностики в BIOS, поэтому не совсем понятно, каким образом обрабатывается информация от жесткого диска, так как граничные значения параметров жесткого диска зависят от конкретного производителя. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Следует учесть, что разрешение этого параметра снизит производительность компьютера на несколько процентов. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Hi-Speed Refresh

С помощью этой опции чипсет быстрее проведет регенерацию основной памяти. Правда, эффект от этой установки значительно меньше, чем от включения "Slow Refresh". Последний режим регенерации предпочтительнее. К тому же эта функция поддерживается не всеми чипами памяти.

Что вы думаете об этой статье? Дайте нам знать.


Hidden Refresh

Скpытая регенерация. Когда установлено значение "Disabled", память регенерируется по IBM AT методологии, используя циклы процессора для каждой регенерации. Когда "Hidden Refresh" установлен в "Enabled", контроллер "ищет" наиболее удобный момент для регенерации, независимо от циклов CPU. При этом регенерация происходит одновременно с обычным обращением к памяти. Алгоритм регенерации памяти при этом многовариантен: разрешаются циклы регенерации в банках памяти, не используемых центральным процессором в данный момент, взамен или вместе с нормальными циклами регенерации, выполняемыми всякий раз при определенном прерывании (DRQ0 - каждые 15 мс), вызванном таймером.

Для регенерации каждый раз требуется от 2 до 4 мс. В течение этих 4 мс один цикл регенерации примерно каждые 16 мкс регенерирует по 256 строк памяти. Каждый цикл регенерации занимает столько же или чуть меньше времени, чем один цикл чтения памяти, т.к. сигнал CAS для регенерации при этом не требуется.

"Hidden Refresh" отличается максимальной скоростью и эффективностью, наименьшими нарушениями активности системы и наименьшими потерями производительности, также позволяя поддерживать состояние памяти во время нахождения системы в режиме "suspend". Этот режим более быстрый, чем "Burst Refresh". Но наличие в BIOS этой функции еще не означает ее реализации. После установки опции в "Enabled" стоит тщательно проверить работоспособность компьютера. Некотоpые модули памяти позволяют использовать "Hidden Refresh", некоторые - нет. В большинстве случаев рекомендуется установить в "Enabled".

Что вы думаете об этой статье? Дайте нам знать.


Hit "Del" Message Display

Отключение этой опции не позволит вывести на экран монитора сообщение о том, с помощью какой клавиши возможен доступ к "BIOS Setup" во время загрузки системы. Косвенно эта опция может служить в качестве защитной функции, хотя и весьма сомнительной.

Что вы думаете об этой статье? Дайте нам знать.


Host Bus Fast Data Ready

Быстрая готовность данных на шине. Разрешение этого параметра позволит снимать данные с шины одновременно с их выборкой. В противном случае данные будут удерживаться на шине один дополнительный такт. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

25/08/2002


IDE PIO Mode

Выбор режима работы каждого диска. Четыре параметра позволяют устанавливать режимы работы каждого диска индивидуально или разрешить BIOS автоматическую установку самого высокоскоростного режима для диска. Для каждого диска допустимые параметры одинаковы. Hапример, для IDE 0 Master Mode допустимые значения:

  • 0
  • 1
  • 2
  • 3
  • 4
  • AUTO

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Init AGP Display First

При установке в "Enabled" первичным в системе становится дисплей, подключенный к AGP-карте. Если выбрано значение "Disabled", то тон будет задавать PCI-карта или даже ISA.

Аналогично функционирует и опция "Init Display First" с параметрами "AGP" и "PCI" ("PCI Slot"). При наличии в системе одного видеоадаптера эти опции не вызывают проблем. При установке же двух видеоадаптеров, поддерживаемых на уровне операционной системы, необходимо выбрать не только наиболее производительный, но и, что вполне реально, единственный вариант подключения двух дисплеев. Речь идет о ситуациях, когда PCI-адаптер не сможет работать вторым.

Опять таки аналогично функционирует опция "VGA BIOS Sequence" (последовательность загрузки BIOS видеокарт) с параметрами "PCI/AGP" и "AGP/PCI".

Несколько иной вариант выбора предлагает опция "Init Display First" в случае интегрирования видеоадаптера на материнскую плату. Значения могут такие:

  • Onboard
  • PCI Slot

Напоследок более "древний" вариант аналогичной функции под названием "Graphics Adaptor" с параметрами "VL Bus" и "PCI Bus".

Что вы думаете об этой статье? Дайте нам знать.


IR Connector

Разъём для инфракрасного излучателя/приемника. Подключается к одному из встроенных COM-портов (обычно COM2) и позволяет установить беспроводную связь с любым устройством, снабженным подобным излучателем и приемником. Интерфейс работает по тому же принципу, что и пульты управления бытовой радиоаппаратурой.

Протокол последовательного интерфейса IrDA версии 1.0 обеспечивал пропускную способность в пределах от 2,4 до 115,2 Кб/с и позволял работать с клавиатурой, мышью, принтером, динамиками, т.п. Версия протокола 1.1 повысила пропускную способность до 1,152 - 4 Мбит/с.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


IR Duplex Mode

Опция для выбора дуплексного или полудуплексного режима работы инфракрасного порта. По умолчанию устанавливается "Half". Другим значением является естественно "Full" (дуплекс). Стоит напомнить, что под дуплексом понимают двунаправленную передачу данных, которая может происходить в двух направлениях в одно и то же время. При полудуплексе передача данных в некий момент времени происходит только в одном направлении.

Эта опция доступна, если функция "UART2 Mode Select" установлена в "HPSIR" или "ASKIR".

В некоторых версиях BIOS аналогичная функция может называться "IR Transfer Mode", а параметры могут звучать как "Half-Duplex" и "Full-Duplex".

В некоторых случаях в параметрах установки может появиться значение "Disabled", как отказ от использования инфракрасного порта. Присутствие в наименованиях опций конкретного указания на второй последовательный порт может говорить только об одном: соединительный кабель уже опциально подключен ко второму последовательному порту, использование первого последовательного интерфейса в качестве инфракрасного не допускается и т.п.

Что вы думаете об этой статье? Дайте нам знать.


IRQ n Assigned to

Использование этой опции возможно, если установлен "ручной" режим конфигурации устройств. В данной опции каждому прерыванию системы может быть назначен один из следующих типов устройств:

  • "Legacy ISA" (классические ISA-карты) - обычные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки Plug&Play. Эти карты требуют назначения прерываний в соответствии с документацией на них.
  • "PCI/ISA PnP" (устройства для шин PCI или ISA с поддержкой Plug&Play) - этот параметр устанавливается только для карт расширения на PCI- или ISA-шинах с поддержкой Plug&Play.

Что вы думаете об этой статье? Дайте нам знать.


IRQ n Used By ISA

Прерывание n используется на шине ISA. Параметр совпадает с "IRQ n Assigned to" и может принимать значения:

  • No/ICU (нет/конфигурационная утилита для ISA) - если установлено это значение, то BIOS может распоряжаться этим прерыванием по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы "ISA Configuration Utility" от Intel;
  • Yes (да) - означает принудительное освобождение прерывания для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им прерываний, так как в противном случае BIOS может назначить прерывание, жестко используемое какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.

Что вы думаете об этой статье? Дайте нам знать.


IRQ to PCI VGA

Установка этой опции в "Disabled" позволит сэкономить одно прерывание благодаря тому, что графические карты при работе с обычным набором офисных приложений не используют IRQ. Ситуация меняется при установке 3D-акселератора. Выделение аппаратного прерывания для графической карты требуется уже не только для ее корректной работы в системе, а становится необходимым для организации обработки огромных массивов информации, для взаимодействия между центральным процессором, системной памятью и видеопроцессором.

Это же справедливо и для случая, когда карта содержит, например, дополнительный модуль MPEG-декодера. Ведь в этом случае используется режим "Busmastering", при котором карта расширения отбирает у процессора управление потоком данных. Необходимо напомнить, что режим "Busmastering" требует по одному IRQ для каждой из карт, поддерживающих этот режим.

Что вы думаете об этой статье? Дайте нам знать.


ISA Bus Clock

Опция установки тактовой частоты ISA-шины. Стандартное значение скорости ISA-шины составляет около 8,33 МГц. В отличие от устаревших систем, ныне скорость ISA-шины напрямую связана со скоростью PCI-шины через т.н. "южный" мост. Можно установить более высокую скорость шины, выбрав соответствующий параметр (делитель). Этот параметр делит действительную скорость PCI-шины и тем самым задает скорость ISA-шины.

Например, тактовая частота PCI-шины составляет 33 МГц. Если изменить делитель на PCICLK/3, то ISA-шина будет работать с частотой 11 МГц. Но необходимо помнить, что повышение тактовой частоты может привести к перегреву элементов ISA-карты и выходу ее из строя. В лучшем случае может возрасти риск ошибок при работе, особенно это опасно для контроллеров дисков (в случае устаревших систем). И хотя многие ISA-устройства работают на более высоких скоростях, необходимо снизить скорость шины, если какое-либо ISA-устройство функционирует неверно.

Из вышесказанного следует, что для правильной установки тактовой частоты ISA-шины необходимо знать тактовую частоту PCI-шины. В данном случае речь идет о том, что в первых системах с использованием PCI-шины частота самой PCI-шины зависила от системной тактовой частоты и поэтому имела ряд значений: 25, 30 и 33 МГц, т.п. В более "старых" системах частота ISA-шины была "привязана" к системной частоте, которая колебалась от 16 до 50 МГц, тем самым давая простор и для ISA-шины.

Опция в разное время носила и разные названия:

  • ISA Clock
  • ISA Clock Frequency
  • ISA Bus Clock Frequency
  • ISA Bus Clock Option
  • ISA Bus Speed
  • ISA Clock Select
  • ISA Clock Divisor
  • AT BUS Clock
  • AT Bus Clock Frequency
  • AT BUS Clock Selection

Наличие в названиях опций сочетания "AT Bus" свидетельствует о "старости" опций. Стоит напомнить, что 8.33 МГц - это "стаpая" тактовая частота шины IBM AT. Ну и, наконец, ряд возможных параметров для выбора: PCI (или PCICLK, или CLK {для системной шины}) / 2,3,4,5,6,8,10, и даже 12, а также фиксированное значение - "7.159 MHz" (оно может устанавливаться и по умолчанию). Опять необходимо дополнительно отметить, что некотоpые системные интерфейсные ISA-платы разрабатывались для такой фиксированной частоты.

Несколько другое содержание заключено в опции "ISA Clock Select Enable". Установив опцию в "Disabled", мы получаем стандартную частоту ISA-шины (PCI/4), выбрав же "Enabled", получаем возможность поварьировать частотой шины вручную.

Что вы думаете об этой статье? Дайте нам знать.


ISA MEM Block Base

Базовый адрес блока памяти для ISA. Hекоторые карты для шины ISA требуют доступа к памяти, расположенной на такой карте по определенным адресам. Поэтому и возникла необходимость в этом параметре BIOS.

Может принимать значения:

  • No/ICU (нет/ICU) - оставляет управление этим параметром на усмотрение BIOS или программы ICU
  • C800
  • CC00
  • D000
  • D400
  • D800
  • DC00 - указывается адрес блока памяти

Кроме этого, появляется дополнительный параметр "ISA MEM Block Size" (размер блока памяти), который нужен в том случае, если таких ISA карт несколько и этот параметр может принимать значения:

  • 8K
  • 16K
  • 32K
  • 64K

Что вы думаете об этой статье? Дайте нам знать.


System Keyboard

См. "Keyboard"


Memory Hole

См. "Memory Hole At 15M-16M"


Local Memory 15-16M

См. "Memory Hole At 15M-16M"


Memory Hole at 15M Addr

См. "Memory Hole At 15M-16M"


Onboard PCI SCSI Chip

См. "On Board PCI/SCSI BIOS"


KBC Input Clock

См. "KBC Input Clock Select"


Keyboard

Клавиатура. Значение "Installed" (или "Present") не вызывает вопросов. Если установить "Not installed" (или "Absent"), эта опция укажет BIOS на отмену пpовеpки клавиатуpы во вpемя стаpтового теста, что позволяет пеpезапускать ПК с отключенной клавиатуpой без выдачи сообщения об ошибке теста клавиатуpы. Это может оказаться необходимым при работе файл-сервера, сервера печати, в т.ч. из соображений безопасности.

Что вы думаете об этой статье? Дайте нам знать.


Keyboard/Mouse Power On

Для использования этой функц и в некоторых случаях возможно придется переставить в положение "On" соответствующую перемычку на материнской плате, например, под названием "The Wake-On-Keyboard/Mouse". В этом случае при использовании режимов энергосбережения система будет просыпаться при воздействии на "мышь" или клавиатуру. Может принимать значения:

  • Disabled (по умолчанию)
  • Password
  • Hot Key
  • Mouse Left
  • Mouse Right
  • Any Key
  • Keyboard 98

Что вы думаете об этой статье? Дайте нам знать.


Master Retry Timer

Этой опцией устанавливается, как долго центральный процессор, будучи задатчиком PCI-циклов, сможет сохранить свое лидерство. Возможные параметры измеряются в циклах PCI-шины (PCICLKs). Вот этот ряд:

  • 10 (по умолчанию)
  • 18
  • 34
  • 66

Что вы думаете об этой статье? Дайте нам знать.

25/08/2002


Memory Hole At 15M-16M

Буквально - "дырка" в памяти в диапазоне 15-16 МБ. При включенном состоянии параметра система, для повышения производительности, будет копировать более медленную память устройства, подключенного к ISA-шине, в более быструю основную память. Это происходит за счет выделения специальной области памяти и перемещения в нее данных ROM-памяти карты расширения или устройства сопряжения.

Естественно, что действие этой функции представляет собой механизм "затенения", который позволяет обращаться, в данном случае к устройствам ввода/вывода, как к адресному пространству ОЗУ и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования указанной области памяти, что и делает BIOS при разрешении этого параметра. При отсутствии ISA-устройств данная опция должна быть отключена. По умолчанию эта опция включена.

И еще одно уточнение. Разрешать этот параметр следует в том случае, если это требуется в документации на используемую в системе плату. Некоторые старые ISA-карты (например, ранние видеокарты высокого разрешения) требуют выделения для них специального адреса памяти, лежащего в некотором диапазоне. Кроме того, это выделение запрещает доступ в старшие адреса памяти, расположенные выше 16 МБ. Поэтому включение данной опции должно быть оправдано.

По сути, данная функция сохранена в "BIOS Setup" по причине фактора совместимости со старыми картами. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

В других версиях BIOS могут встретиться значения:

  • Disabled
  • 14M-16M
  • 15M-16M

В более "старых" версиях BIOS могут встретиться другое наименование такой функции - "Memory Hole", и значения параметров:

  • None
  • at 512 kB
  • at 15 MB

Действие некоторых параметров уже понятно, а для значения "at 512 kB" стоит указать, что для "затенения" используется часть базовой памяти в пределах 512-639 КБ.

Что вы думаете об этой статье? Дайте нам знать.


Memory Test Tick Sound

Опция, позволяющая сопровождать тест памяти периодическими звуковыми сигналами. Рекомендуется устанавливать в "Enabled" для озвучивания пpоцесса загpузки и дополнительного подтверждения, в частности, правильности установок "CPU clock speed/Turbo switch".

Что вы думаете об этой статье? Дайте нам знать.


MPS 1.4 Support

Поддержка режима MPS 1.4 (Intel Multiprocessor Specification). Этот параметр появляется только в BIOS материнских плат, допускающих установку нескольких процессоров. Параметр указывает операционной системе, какую версию мультипроцессорной спецификации поддерживает плата. В MPS версии 1.4 добавлена поддержка расширенной таблицы, улучшающей работу с несколькими PCI-портами. При запрещении устанавливается режим MPS 1.1. Большинство современных серверных мультипроцессорных ОС поддерживают режим MPS 1.4. Рекомендуется устанавливать режим MPS 1.1 ("Disabled") только при работе со старыми операционными системами, в т.ч. различными версиями ОС "Windows". Для "Windows NT", "Novell Netware" естественно рекомендуется "Enabled".

Что вы думаете об этой статье? Дайте нам знать.


MPS Version Control For OS

См. "MPS 1.4 Support"


On Board PCI/SCSI BIOS

Установка значения "Enabled" (включено) необходима, если на материнской плате имеется встроенный SCSI-контроллер, подключенный к PCI-шине, и используется жесткий диск с интерфейсом SCSI. Стоит напомнить, что в процессе загрузки одновременное нажатие клавиш <CTRL>+<A> вызывает BIOS SCSI. Может принимать значения:

  • "Enabled" - включено
  • "Disabled" - отключено

Что вы думаете об этой статье? Дайте нам знать.


ONB AHA BIOS First

Запуск BIOS контроллера "Adaptec" первым. Параметр разрешает/запрещает запуск BIOS встроенного контроллера "Adaptec" до запуска любого другого SCSI-контроллера. Может принимать значения:

  • "Yes" - разрешено
  • "No" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


ONB SCSI LVD Term

Терминаторы встроенного контроллера SCSI LVD. Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI с LVD-передачей сигналов. Управление этим параметром позволяет значительно увеличить длину соединительного SCSI-кабеля. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


ONB SCSI SE Term

Терминаторы встроенного контроллера SCSI SE. Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном SCSI-контроллере с SE-передачей данных. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Onboard AHA BIOS

BIOS встроенного SCSI-контроллера "Adaptec". Параметр разрешает/запрещает выполнение BIOS-функций встроенного SCSI-контроллера и тем самым разрешает/запрещает его работу. Параметр может принимать значения:

  • "AUTO" - разрешен автоматический поиск SCSI-контроллера "Adaptec" и запуск BIOS для него
  • "Disabled" (запрещено) - выбор этого значения рекомендуется при отсутствии SCSI-карты

Необходимо помнить, что некоторые SCSI-контроллеры той же фирмы "Adaptec", например "AHA-2940AU", не имеют собственного Flash-BIOS, и их конфигурирование осуществляется в BIOS компьютера и средствами ОС.

Что вы думаете об этой статье? Дайте нам знать.


Onboard PCI IDE Enable

Разрешение работы интегрированного контроллера IDE. Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:

  • Primary - разрешена работа только первого канала
  • Secondary - разрешена работа только второго канала
  • Both - разрешена работа обоих каналов
  • Disable - запрещена работа обоих каналов

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


OS/2 Onboard Memory > 64MB

Выбор значения для OS/2, если памяти больше, чем 64 Mb. Требует разрешения при выполнении двух условий - в компьютере установлено больше, чем 64 Mb памяти и используется OS/2 в качестве операционной системы. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

25/08/2002


PCI Passive Release

См. "Passive Release"


Arbitration Priority

См. "PCI Bus Arbitration"


PCI Arbiter Mode

См. "PCI Bus Arbitration"


PCI Arbitration Mode

См. "PCI Bus Arbitration"


PCI Arbit. Rotate Priority

См. "PCI Bus Arbitration"


DMA/ISA Master Before PCI

См. "PCI Bus Arbitration"


PCI Bus Time-out

См. "PCI Latency Timer"


PCI Master Latency

См. "PCI Latency Timer"


Latency Timer

См. "PCI Latency Timer"


PCI Clocks

См. "PCI Latency Timer"


PCI Initial Latency Timer

См. "PCI Latency Timer"


PCI Preemption Timer

См. "PCI Preempt Timer"


Video Palette Snoop

См. "PCI/VGA Palette Snoop"


Multimedia Mode

См. "PCI/VGA Palette Snoop"


PCI Concurrency

См. "Peer Concurrency"


Bus Concurrency

См. "Peer Concurrency"


Passive Release

Пассивное разделение. Эта опция появилась в свое время в "BIOS Setup" одновременно со способностью арбитра чипсетов Intel Triton VX/HX отбирать шину у master-устройств при отсутствии в течение какого-то времени запросов на передачу с их стороны. Эта опция включает/выключает механизм параллельной работы шин ISA и PCI. Если этот параметр разрешен ("Enabled"), то доступ процессора к шине PCI позволен во время "пассивного разделения" или, как говорят иногда, ее "освобождения". Проще говоря, включение данного режима позволяет шине PCI продолжать работу даже тогда, когда происходит передача данных от ISA-устройств, которые в обычном режиме могут тормозить работу более скоростной PCI-шины. Арбитр чипсета как бы выравнивает работу двух шин с учетом задержек ISA-шины. Необходимость же запрещения данного параметра может возникнуть при использовании плат ISA, активно использующих каналы DMA (звуковые карты, устройства "Arwid"). Запрещение также уместно при отсутствии ISA-карт в системе.

Что вы думаете об этой статье? Дайте нам знать.


Password Checking

Опция "AMI BIOS", аналогичная "Security Option" для "Award BIOS", с той лишь разницей, что значению "System" соответствует значение "Always", но только лишь с блокировкой загрузки системы.

Что вы думаете об этой статье? Дайте нам знать.


PCI Bus Arbitration

Параметр может принимать значения:

  • Rotating
  • Fixed

Опция с абсолютно таким же названием встретилась и с параметрами: "Favor CPU" и "Favor PCI". Пользователю остается определить своего фаворита. Если речь идет о потоковом видео, то желательно указать PCI-устройство. Выбор центрального процессора во многих случаях может оказаться более безопасным.

С абсолютно такими же возможностями отбора: "CPU" или "PCI", может встретиться и функция "Arbitration Priority".

В свою очередь, функция с таким же названием может предложить более "изощренный" вариант: "PCI First" и "ISA/DMA First". Здесь возможности выбора зависят от применяемых устройств. "Master"-устройство может находиться и на ISA-шине и желать того же самого, а именно передачи данных напрямую по DMA-каналам.

Аналогичные варианты выбора предлагает и функция "DMA/ISA Master Before PCI". В данном случае значение "Disabled" равносильно "PCI First".

При этом, правда, могут возникнуть и другие сложности. Например, если для выбора предлагаются параметры: "Mode1" и "Mode2". Поскольку идея арбитража заключается и в минимизации времени, требуемого для получения устройством контроля над шиной и передачи данных, то возникает вопрос, в каком из вариантов устройство, например, на той же PCI-шине быстрее получит доступ к ней. В случае "Favor PCI" или с выбором "Favor CPU"? Естественно, что первый вариант более оптимален. В данном случае этому значению соответствует "Mode1", устанавливаемый по умолчанию. При возникновении каких-либо проблем в системе необходимо выбрать режим "Mode2", как более безопасный.

Что вы думаете об этой статье? Дайте нам знать.


PCI Bus Parking

Опция включения/выключения режима "парковки" устройств на PCI-шине. Режим "парковки" - одна из разновидностей режима "Bus-Master". Когда этот режим включен ("Enabled"), "запаркованные" на PCI-шине устройства будут иметь полный контроль над шиной в течение некоторого небольшого промежутка времени. Это повышает производительность данного устройства, однако приостанавливает работу остальных. Данный режим неплохо работает с контроллерами жестких дисков.

Что вы думаете об этой статье? Дайте нам знать.


PCI Clock Frequency

Опция для установки частоты шины PCI. В приведенном виде такая опция была внедрена на первых "пентиумных" машинах, а затем перенесена на 486-е системы с процессорами AMD и PCI-шиной. Частота шины через множитель "привязывалась" к частоте центрального процессора и имела следующий ряд значений:

  • CPUCLK/1.5 (по умолчанию)
  • CPUCLK/2
  • CPUCLK/3
  • 14 Mhz

Что вы думаете об этой статье? Дайте нам знать.


PCI Dynamic Decoding

Установка в "Enabled" позволяет системе запоминать PCI-команду, которая только что была запрошена. Если последующие команды совпадают с некоторой адресной областью, циклы записи будут автоматически интерпретироваться как PCI-команды.

Что вы думаете об этой статье? Дайте нам знать.


PCI IDE IRQ Map to

Прерывания контроллера IDE на PCI отображаются на... Позволяет освободить прерывания, занимаемые контроллером IDE на шине PCI в случае его отсутствия (или запрещения) на материнской плате и отдать их устройствам на шине ISA. Стандартные прерывания для ISA - IRQ 14 для первого канала и IRQ 15 для второго канала. Может принимать значения:

  • PCI IDE IRQ mapping (используется для PCI IDE)
  • PC AT (ISA) (используется для ISA)

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


PCI IRQ Activated by

Прерывания активизируются по ... . Выбор метода, с помощью которого контроллер прерываний будет распознавать запрос на прерывание от устройств на шине PCI. Смысл опции - в минимизации времени "захвата" шины и дальнейшей передачи данных от устройства. По умолчанию предлагается значение "Level", и менять его не следует, если только это не будет необходимо для конкретного случая, о чем должно быть написано в руководстве к устройству. Параметр может принимать значения:

  • "Level" (уровень) - контроллер прерываний реагирует только на уровень сигнала
  • "Edge" (перепад) - контроллер прерываний реагирует только на перепад уровня сигнала

Что вы думаете об этой статье? Дайте нам знать.


PCI Latency Timer

Таймер времени ожидания для шины PCI. Значение этой опции указывает, в течение какого времени (в системных тактах) поддерживающая режим "Busmaster" PCI-карта может сохранять контроль над PCI-шиной, если к шине обращается другая PCI-карта. Фактически это и есть таймер, ограничивающий время занятия PCI-шины устройством-задатчиком шины. По истечении заданного времени арбитр шины принудительно отбирает шину у задатчика, передавая ее другому устройству.

Допустимый диапазон изменения этого параметра - от 16 до 128 с шагом, кратным 8.

Значение параметра необходимо изменять осторожно, так как оно зависит от конкретной реализации материнской платы, и только в случае, если в системе установлены по меньшей мере две PCI-карты, поддерживающие режим "Busmaster", например, SCSI- и сетевая карты. Графические карты не поддерживают режим "Busmaster". Чем меньше устанавливаемое значение, тем быстрее другая PCI-карта, требующая доступа, получит доступ к шине. Если требуется выделить для работы, например, SCSI-карты больше времени, то можно увеличить значение для PCI-слота, в котором она находится. Значение для сетевой карты, например, соответственно необходимо уменьшить или вообще установить равным 0, хотя в некоторых случаях установка 0 не рекомендуется. В общем случае, какое значение параметра пригодно и оптимально для данной системы, зависит от применяемых PCI-карт и проверяется с помощью тестовых программ. Необходимо также учитывать, в какой степени "карты-конкуренты" чувствительны к возможным задержкам.

И еще одно очень важное замечание. В свое время эта опция (и ей подобные) вводились с учетом совместного существования PCI и ISA-шин. ISA-шина позволяла использовать одно "master"-устройство. Это применялось редко как раньше, так и теперь. Зато PCI-шина дала возможность одновременного использования нескольких "master"-устройств. Учитывая различия в скорости шин, а тем более в их пропускной способности, необходимо было решить проблему совместной работы "master"-устройств на PCI-шине и стандартных устройств на более медленной ISA-шине. Особенно это касалось распространенных в то время звуковых и сетевых карт для ISA-шины, обладавших незначительным объемом буферной памяти, т.е. чувствительных к любым задержкам при передаче данных. "AMI BIOS" позволял выбрать значение параметра в диапазоне от 0 до 255 с единичным шагом. Значение "66" устанавливалось по умолчанию, хотя меньшее значение владения шиной PCI-устройством оказывалось более предпочтительным.

Поэтому при конкретном решении стоящей перед пользователем задачи (или проблемы) надо исходить прежде всего из возможностей чипсета, версии BIOS и используемых карт расширения.

Что вы думаете об этой статье? Дайте нам знать.


PCI Master 0 WS Write

Если опция установлена в "Enabled", в системе устанавливается нулевое время ожидания в циклах записи от "master"-устройств на PCI-шине в системную память. Значение "Disabled" устанавливается по умолчанию.

Что вы думаете об этой статье? Дайте нам знать.


PCI master accesses shadow RAM

Опция включения/выключения возможности копирования ПЗУ шины в более быструю оперативную память для повышения быстродействия системы. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


PCI Preempt Timer

Таймер времени вытеснения для шины PCI. На первый взгляд по смыслу эта функция аналогична функции "PCI Latency Timer", возможна даже некоторая путаница, хотя в данном случае кое-что наоборот. Значение этой опции указывает, в течение какого времени (в тактах PCI-шины, или локальных тактах - LCLKs) поддерживающая режим "Busmaster" PCI-карта сможет не контролировать шину, а находиться в состоянии ожидания пока этой шиной владеет другая карта. Арбитр шины отслеживает указанный временной интервал с момента подачи запроса, после чего ожидающее "master"-устройство вытесняет своего товарища. Для выбора предагаются значения из ряда:

  • 5
  • 12
  • 20
  • 36
  • 68
  • 132
  • 260

В цифровом виде или с отображением единицы измерения - "5 LCLKs" и т.д. Обязательным является параметр "No Preemption" (или "Disabled"). Причем последний, как правило, устанавливается по умолчанию. Эта опция в таком виде уже не применяется, так что встреча с ней на старых машинах может вызвать некоторые трудности. Во всяком случае при наличии хотя бы двух "master"-устройств на PCI-шине значение "Disabled" (или аналогичное) должно быть заменено на более оптимальное.

Что вы думаете об этой статье? Дайте нам знать.


PCI to ISA Write Buffer

Во включенном состоянии ("Enabled") система, не прерывая работы процессора, будет временно записывать данные в специальный буфер для последующей передачи данных в наиболее подходящий момент. В противном случае ("Disabled") цикл записи в шину PCI будет направляться далее напрямую в более медленную ISA шину. Необходимость в такой функции, а точнее в таком буфере, связана с тем, что скорости работы ISA- и PCI-шин различны. Включение буферной памяти позволит PCI-шине не ожидать, пока ISA-шина примет все данные.

Что вы думаете об этой статье? Дайте нам знать.


PCI/VGA Palette Snoop

Слежение за палитрой подсистемы видео или корректировка палитры VGA-видеокарты. Эта опция используется только при наличии карты видеозахвата (MPEG-карты) или TV-тюнера, соединенных с графической картой с помощью соединительного шлейфа, и в некоторых других случаях. При установке в "Enabled" функция позволяет корректировать установки VGA-палитры во время прохождения сигналов из MPEG-карты через VGA-коннектор, т.е. в случае некорректного отображения цветов. Собственно суть механизма действия этой функции заключена в способности платы графики в "подсматривании" циклов записи в регистры палитры цветов карты видеозахвата и корректировке цветов в буфере кадров видеоадаптера. VGA-перехват (snooping) используется различными мультимедиа устройствами, например, фрейм-грабберами (захватчиками изображения) или картами MPEG-декомпрессии. В обычном режиме работы опция должна быть запрещена.

Что вы думаете об этой статье? Дайте нам знать.


Peer Concurrency

Параллельная работа или, дословно, - равноправная конкуренция. Этот параметр разрешает/запрещает одновременную работу нескольких устройств на PCI-шине. При включении опции включается дополнительное буферирование циклов чтения/записи в чипсете. Но могут возникнуть проблемы, если не все PCI-карты готовы поддерживать такой режим работы. В этом случае работоспособность системы проверяется опытным путем.

Действие этой опции затрагивает и совместную работу PCI- и ISA-шин. Например, шинные PCI-циклы могут перераспределяться и буферизироваться во время ISA-операций, таких как передача по DMA-каналам в режиме "Bus-Master". Параметр может принимать значения:

  • "Enabled" (по умолчанию) - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Security Option

Опция, позволяющая ограничить доступ к системе и к "BIOS Setup", или только к "BIOS Setup". Выбор "System" блокирует загрузку компьютера и доступ к "BIOS Setup". Вход в систему тогда возможен только при вводе правильного пароля. Выбор "Setup" не ведет к блокировке загрузки ПК, но блокирует вход в "BIOS Setup". По умолчанию - "Setup".

Что вы думаете об этой статье? Дайте нам знать.


PNP OS Installed

Установлена ли операционная система с поддержкой режима Plug&Play?. Установить "Yes", если операционная система поддерживает Plug&Play (например, Windows 95), и "No" в противном случае, тогда BIOS самостоятельно настроит Plug&Play устройства.

Что вы думаете об этой статье? Дайте нам знать.


Power Button Function

Опция отключения системы. Может принимать значения:

  • "On/Off" - в этом случае включение ПК и его отключение производится от кратковременного нажатия кнопки "POWER"
  • "Suspend" - при включенном состоянии ПК кратковременное нажатие кнопки питания активирует режим "Suspend". При более длительном удержании кнопки (более 4 сек.) система отключается.

Что вы думаете об этой статье? Дайте нам знать.


Processor S/N

См. "Processor Number Feature"


Refresh Assertion

См. "Refresh RAS# Assertion"


Refresh RAS Active Time

См. "Refresh RAS# Assertion"


Force Update ESCD

См. "Reset Configuration Data"


PWR Up On Modem Act

См. "Resume by Ring"


Ring Resume From Soft Off

См. "Resume by Ring"


RTC Wake Up Timer

См. "RTC Alarm Resume (From Soft)"


ALE During Bus Conversion

См. "Single ALE Enable"


DRAM Slow Refresh

См. "Slow Refresh"


Slow Memory Refresh Divider

См. "Slow Refresh"


Slow Refresh Enable

См. "Slow Refresh"


UART 2 Mode

См. "UART2 Mode Select"


Onboard UART 2 Mode

См. "UART2 Mode Select"


Infra Red Function

См. "UART2 Mode Select"


IR Mode Select

См. "UART2 Mode Select"


UR2 Mode

См. "UART2 Mode Select"


Onboard IR Function

См. "UART2 Mode Select"


IR Function

См. "UART2 Mode Select"


Assign IRQ For USB

См. "USB IRQ"


Use An IRQ for USB

См. "USB IRQ"


VGA Performance Mode

См. "VGA 128k Range Attribute"


Turbo VGA (0 WS at A/B)

См. "VGA 128k Range Attribute"


VGA Frame Buffer

См. "VGA 128k Range Attribute"


Video BIOS Area Cacheable

См. "Video BIOS Cacheable"


Video Off After

См. "Video Off Option"


Preempt PCI Master Option

Когда опция включена ("Enabled"), операции чтения/записи на PCI-шине, даже в том случае, когда шиной владеет "master"- устройство, могут быть прерваны некоторыми системными операциями, например, такими, как регенерация памяти. В противном случае может вестись "незапланированная" параллельная работа различных системных компонент, что может привести к сбоям системы, в лучшем случае - к потере информации.

Что вы думаете об этой статье? Дайте нам знать.


Processor Number Feature

Опция для установки автоматического считывания и вывода информации о встроенном серийном номере процессора Pentium III в BIOS материнских плат, поддерживающих его установку. Для реализации такой возможности, естественно, требуется значение параметра как "Enabled". Во всех остальных случаях устанавливается значение "Disabled". Оно же устанавливается по умолчанию.

Что вы думаете об этой статье? Дайте нам знать.


Resources Controlled By

Как управляются ресурсы. Если выбрано AUTO, то BIOS сам автоматически назначит прерывания и каналы DMA всем устройствам, подключенным к шине PCI и эти параметры не будут появляться на экране. В противном случае все эти параметры следует установить вручную. В некоторых вариантах BIOS этот параметр может устанавливаться индивидуально для каждого PCI слота и выглядеть так:

  • Slot 1 IRQ
  • Slot 2 IRQ
  • и т.д.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


PS/2 Mouse Function Control

Управление функциями порта мыши PS/2. Разрешение этого параметра отдает IRQ 12 только для порта мыши PS/2. В противном случае, при отсутствии подключенной к компьютеру мыши с интерфейсом PS/2, IRQ 12 свободно для других устройств. Рекомендуется устанавливать значение "Auto". Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено
  • Auto - BIOS определяет присутствие или отсутствие PS/2 мыши

Что вы думаете об этой статье? Дайте нам знать.


PWR Button less then 4 Secs

Кнопка питания нажата менее 4 секунд. Опция управления функциями кнопки "Power" на системном блоке компьютера. Может принимать значения:

  • "Soft Off" - программное выключение. Кнопка работает как обычная кнопка включения/выключения питания компьютера, но при этом разрешается программное выключение компьютера при выходе из "Windows"
  • "Suspend" - временная остановка. При нажатии на кнопку питания на время менее 4 секунд компьютер переходит в состояние "Suspend"
  • "No Function" - функция не задействована. Кнопка "Power" становится обычной кнопкой включения/выключения питания.

Что вы думаете об этой статье? Дайте нам знать.


PWR Lost Resume State

Опция автоматического включения питания. Может принимать значения:

  • "Keep Off" - при потере питания в сети и его восстановлении для включения ПК необходимо нажать кнопку питания
  • "Turn On" - восстановление питания вызывает автоматическое включение системы
  • "Last State" - к автоматическому включению ПК добавляется возможность восстановления системы в том состоянии, в котором она находилась на момент пропадания питания

Что вы думаете об этой статье? Дайте нам знать.


PWRON After PWR-Fail

Функция восстановления питания после его пропадания. Возможные значения параметра:

  • "On" - автоматическое включение питания ПК после его восстановления
  • "Off" - никакая информация о состоянии системы не сохраняется. Обычный перезапуск компьютера
  • "Former-sts" - система возвращается в состояние, которое было перед пропаданием сетевого напряжения, но только через нажатие кнопки "Power"

Что вы думаете об этой статье? Дайте нам знать.


Ref/Act Command Delay

Установка режима работы памяти. Параметром выбирается время задержки между окончанием режима регенерации и началом командного режима. Может принимать значения:

  • 5T
  • 6T (по умолчанию)
  • 7T
  • 8T

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Refresh During PCI Cycles

Опция, разрешающая/запрещающая проведение регенерации памяти во время циклов чтения/записи на шине PCI. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Refresh RAS# Assertion

Установка периода активности сигнала RAS. Этим параметром устанавливается длительность сигнала RAS (в тактах системной шины) для цикла регенерации. Принимаемые значения определяются качеством памяти и чипсетом. Меньшее значение увеличивает производительность системы. Может принимать значения:

  • 4T (или "4 Clks")
  • 5T (или "5 Clks")

Что вы думаете об этой статье? Дайте нам знать.


Report No FDD For WIN 95

Сообщение об отсутствии накопителя на гибких дисках для "Windows 95". Параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе "Yes" и одновременном выборе "Disable" в параметре "Onboard FDC Controller" (обычно в разделе "Integrated Peripherals" "BIOS Setup") "Windows 9x" освободит IRQ 6, занимаемое контроллером флоппи-дисковода, для использования другим устройством. Может принимать значения:

  • "Yes" (или "Enabled") - освободить IRQ6
  • "No" (или "Disabled") - не освобождать (независимо от того, есть ли флоппи-дисковод или нет)

Что вы думаете об этой статье? Дайте нам знать.


Reset Configuration Data

Cброс конфигурационных данных. При установке "Enabled" BIOS очистит область памяти ESCD (Extended System Configuration Data - данные расширенной системной конфигурации), в которой хранятся данные о конфигурировании системы, и перезапишет ее в процессе проведения POST. Затем BIOS автоматически переведет значение параметра в "Disabled", предотвращая систему от ошибок пользователя.

Естественно, что при постоянстве параметра "Enabled" также постоянно происходило бы переконфигурирование распределения системных ресурсов. Опция может быть включена для перенастройки таблицы ресурсов либо при установке новых устройств.

Что вы думаете об этой статье? Дайте нам знать.


Resume by Ring

При установке опции в "Enabled" входящий телефонный звонок приводит к "пробуждению" системы. При входящем звонке прежде всего активизируется линия модема и последовательного интерфейса Ring Indicator. По умолчанию опция устанавливается в "Disabled". Использование опции возможно при наличии внешнего модема, естественно включенного в то время, как система находится в "спящем" состоянии.

Что вы думаете об этой статье? Дайте нам знать.


RTC Alarm Resume (From Soft)

При установке опции в "Enabled" система проснется, а точнее включится, в указанное время, устанавливаемое в следующих 4-х полях:

  • RTC Alarm Date
  • RTC Alarm Hour
  • RTC Alarm Minute
  • RTC Alarm Second

Из этого нетрудно увидеть, что при установке конкретной даты система запустится только один раз в месяц. Поэтому в этом поле предусмотрен и отказ от указания какого-либо числа месяца. Уже из названия функции следует, что за временем зорко следят "часы реального времени" (real-time clock), выводя систему из режима Suspend.

Что вы думаете об этой статье? Дайте нам знать.


RTC Y2K H/W Roll Over

При установке опции в "Enabled" происходит тестирование системы на проблему 2000 года. "Disabled" устанавливается по умолчанию.

Что вы думаете об этой статье? Дайте нам знать.


SDRAM Banks Close Policy

Правила закрытия банков SDRAM памяти. Параметр был введен для плат с набором 440LX из-за того, что память с 2-х банковой организацией некорректно работает в этих платах, если параметры доступа к банкам памяти установлены по умолчанию. В наборе 430TX этого не требовалось, так правила доступа для различной памяти были одинаковы. Изменять установки BIOS по умолчанию для этого параметра следует только в случае нестабильной работы памяти. Может принимать значения:

  • Page Miss - используется для двухбанковой памяти
  • Arbitration - для памяти из 4-х банков

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


SDRAM CAS# Latency

Задержка CAS для SDRAM. Устанавливает значение задержки выдачи сигнала CAS для SDRAM. Меньшее значение увеличивает производительность системы. Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 ns или лучше. Может принимать значения:

  • 2T
  • 3T

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


SDRAM CAS to RAS Delay

Задержка между CAS и RAS. Параметр определяет значение задержки после выдачи сигнала RAS до появления сигнала CAS для синхронной памяти. Чем меньше это значение, тем быстрее доступ к памяти. Тем не менее изменять его следует осторожно. Параметр может принимать значения:

  • 3 - три такта задержки
  • 2 - два такта задержки

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


SDRAM Configuration

Конфигурация SDRAM-памяти. Установкой параметров опции определяется, должен ли BIOS определять временные характеристики доступа к памяти на основании информации из SPD-модуля ("By SPD") или же пользователь проведет конфигурирование доступа самостоятельно (через установку "Disabled").

Нетрудно увидеть схожесть данной опции с "Auto Configuration". В качестве фиксированных значений могут быть предложены параметры: "7 ns (143 Mhz)" и "8 ns (125 Mhz)" как для памяти с временем доступа 7 нс/8 нс и соответственно частотой шины 143 МГц/125 МГц.

Что вы думаете об этой статье? Дайте нам знать.


SDRAM RAS Precharge Time

Cинхронная память - время предварительного заряда. Параметр позволяет определять быстрое или медленное накопление заряда по RAS до начала цикла регенерации памяти. Установка значения Fast увеличивает быстродействие, но Slow повышает стабильность работы компьютера, поэтому значение Fast следует устанавливать в случае уверенности в качестве памяти. Может принимать значения:

  • Fast - быстро
  • Slow - медленно

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Single ALE Enable

Разpешение одиночного сигнала ALE. Немножко информации. Пин B28 на шине ISA - это сигнал BALE (Bus Adress Latch Enable - разрешение защелкивания адреса). Это сигнал стробирования адресных разрядов. Может использоваться устройствами ввода/вывода для заблаговременной подготовки к предстоящему обмену информацией. Эта линия становится активной всякий pаз пpи появлении на шине адpеса. Стоит добавить, что этот сигнал использовался еще во времена 808x-х процессоров. Сигнал этот используется редко.

Устанавливая "Enabled", активизируем одиночный сигнал ALE вместо множественных сигналов-стробов во время ISA-циклов. В какой-то степени выбор параметра был привязан и к скорости системной шины, т.е. пропускной способности системы. Поэтому установка в "Enabled" могла привести к замедлению быстpодействия видеоканала.

Эта функция всегда оставалась достаточно "темной" функцией "BIOS Setup". "Disabled" рекомендовано.

Опция может называться также "ALE During Bus Conversion" с возможными вариантами выбора:

  • "Single" (одиночный)
  • "Multiple" (множественный)

Естественно, что при потоковой работе ISA-шины (т.е. множественных циклов чтения/записи) предпочтительнее была бы установка опции в "Multiple". Но какой правильный выбор должен был сделать пользователь, всегда оставалось загадкой.

Некоторые чипсеты имели поддержку усовершенствованного режима, при котором выдача множественных сигналов ALE производилась во время одиночных циклов шины. Функция BIOS при этом называлась "Extended ALE", а параметрами служили "Disabled" и "Enabled".

В наиболее "древних" версиях BIOS весь смысл сказанного выше был заключен в опции под названием "Quick Mode".

Что вы думаете об этой статье? Дайте нам знать.


Slow Refresh

Медленная pегенеpация. При включении этой опции схема регенерации будет в 4 раза реже регенерировать память (64 мкс против 16), чем в обычном pежиме. При такой установке пpоизводительность системы повышается благодаpя уменьшению конкуpенции между CPU и схемой pегенеpации, однако не все типы динамических ОЗУ могут поддеpживать такие циклы (в этом случае будет получено сообщение об ошибке четности и о сбое системы). Тогда необходимо установить значение "Disabled".

Опция в свое время получила распространение с развитием такого типа ПК, как "laptop" (дорожный ПК), в качестве энергосберегающей функции. В современных системах эта опция встречается все реже.

Что вы думаете об этой статье? Дайте нам знать.


Snoop Ahead

Предвидение. Эта опция применима, если в системе включено кэширование. Когда опция установлена в "Enabled", "master"- устройства на PCI-шине могут контролировать регистры VGA-палитры для непосредственных циклов записи и преобразования их в потоковый протокол PCI-формата с целью повышения скоростных характеристик обмена данными между PCI-шиной и памятью. В итоге значительно увеличивается производительность системы в процессе передачи видеоданных.

Что вы думаете об этой статье? Дайте нам знать.


Speculative Leadoff

Опережающая выдача сигнала чтения. Разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр "Speculative Leadoff" разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Spread Spectrum Modulated

Hаспространение модулированного спектра. При работе тактового генератора может возникать такое явление, как электромагнитная интерференция (ElectroMagnetic Interference - EMI). Физически интерференция есть не что иное, как взаимодействие (наложение) двух или более волновых колебаний. В их появлении, сопровождающемся характерными для таких процессов многочисленными частотными гармоническими составляющими, "виноваты" экстремальные значения (пики) генерируемых тактовых импульсов. Включение опции позволяет сгладить пики и уменьшить интерференцию.

На решение этой задачи направлен целый комплекс средств, следящий за работой тактового генератора и качеством вырабатываемых им сигналов.

Уменьшение электромагнитного излучения, кроме чисто технических задач, затрагивает и экологические проблемы, оно может достигать 6%. Следует заметить, что это может отрицательно отразиться на работе чувствительных к форме сигнала устройств, например, жестких дисков с интерфейсом Fast Wide SCSI. Поэтому параметр рекомендуется разрешать только при испытаниях компьютеров на электромагнитную совместимость.

Кроме того, есть еще режим "Smart Clock". В этом режиме тактовые сигналы шин AGP, PCI и SDRAM отключаются в момент, когда не требуется их использование. В таком случае включение опции не сказывается на стабильности работы. Может принимать значения:

  • Enabled
  • Disabled
  • 0.25%
  • 0.5%
  • Smart Clock

Что вы думаете об этой статье? Дайте нам знать.


Standby Mode

Режим ожидания работы. Устанавливает время перехода или запрещает переход во вторую стадию снижения энергопотребления. Может принимать значения:

  • 30 Sec
  • 1 Min
  • 2 Min
  • 4 Min
  • 8 Min
  • 20 Min
  • 30 Min
  • 40 Min
  • 1 Hour
  • Disabled

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Stby Speed

Частота процессора в режиме Standby. Определяет коэффициент деления тактовой частоты в режиме Standby (ожидания работы).

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Stop CPU at PCI Master

Когда опция включена ("Enabled"), работа центрального процессора может быть приостановлена в момент инициирования PCI-устройством захвата шины. Установка в "Disabled" (по умолчанию) не позволяет прерывать работу CPU как задатчика шины. Для прерывания тогда может потребоваться использование дополнительных функций "BIOS Setup".

Что вы думаете об этой статье? Дайте нам знать.


Suspend Switch

Переключатель режима Suspend. Параметр разрешает или запрещает переход в режим suspend (временной остановки) с помощью кнопки на системном блоке. Для этого необходимо соединить джампер SMI на материнской плате с кнопкой на лицевой панели. Как правило, для этого используется либо специальная кнопка Sleep, либо кнопка Turbo. Режим Suspend является режимом максимального снижения энергопотребления компьютером. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

26/08/2002


Swap Floppy Drive

Перестановка дисководов. Опция, позволяющая "поменять местами" дисководы A: и B: и сделать загрузочным дисковод B: (или наоборот). Опция имеет смысл только при наличии двух дисководов в компьютере и необходимости сделать загрузочным дисковод 5.25". При этом дисководы меняются местами только логически, а не физически. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено (по умолчанию)

Что вы думаете об этой статье? Дайте нам знать.


SYMBIOS (NCR) SCSI BIOS

Параметр устанавливает разрешение на поиск SCSI-контроллера на базе микросхемы NCR 810, используемой, например, в карте "ASUS SC-200". Параметр может принимать значения:

  • "AUTO" - разрешен автоматический поиск SCSI-контроллера и запуск BIOS для него
  • "Disabled" (запрещено) - устанавливается в это значение при отсутствии SCSI-карты

Что вы думаете об этой статье? Дайте нам знать.


System Thermal

Установка режима наблюдения за системной температурой. Выбор вариантов для данной функции невелик. Установка "Ignore" блокирует возможность перевода центрального процессора на безопасный режим работы. Параметр "Monitor" позволяет системе отслеживать возможность появления опасной ситуации.

В данном случае речь идет о достижении CPU критической температуры, устанавливаемой в поле "CPU Critical Temperature". При достижении центральным процессором этой температуры внутренняя частота процессора снижается до величины, устанавливаемой в процентах в поле "Thermal Slow Clock Ratio".

Что вы думаете об этой статье? Дайте нам знать.


Trigger Method

Опция, позволяющая оптимизировать установку IRQ для PCI-слотов и могущая принимать значения "Auto" или "Forced". Для PCI- карты необходимо установить значение "Auto". Эта установка проверяет, нуждается ли PCI-карта в IRQ. Если карта не нуждается в IRQ, то система оставляет его для других ресурсов. Установка "Forced" используется в том случае, если BIOS автоматически не определяет, нуждается ли PCI-карта в прерываниях. Если установлено значение "Forced", то выделенный IRQ может использовать только данная PCI-карта.

Примечание! Если используемый в системе SCSI-контроллер с NCR-чипом не работает, то для этого контроллера необходимо установить прерывание IRQ 15 и опцию "Level Trigger".

Что вы думаете об этой статье? Дайте нам знать.


Turn-Around Insertion

Задержка между циклами. Если этот параметр разрешен (Enabled), то между двумя последовательными циклами обращения к памяти включается один дополнительный такт. Разрешение уменьшает быстродействие, но увеличивает достоверность при операциях чтения/записи. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Что вы думаете об этой статье? Дайте нам знать.

14/06/2002


Keyboard Reset Control

Эта опция позволяет регулировать скорость ввода символов с клавиатуры, но только при включенном состоянии опции "Typematic Rate Setting". С ее помощью устанавливается временная характеристика - количество сигналов повторения нажатой и не отпущенной клавиши за цикл, которое может изменяться от 6 до 30 символов в секунду, т.е. задается частота автоматического повторения символов клавиатуры. Установка большего значения позволяла, например, при работе с "MS-DOS" ускорить передвижение курсора.

Что вы думаете об этой статье? Дайте нам знать.


Typematic Rate Delay

Задержка повторения в мсек. Эта опция регулирует вторую временную характеристику - задержку перед автоповтором нажатой клавиши, которая может меняться от 0,25 до 1 сек., т.е. значение задержки от момента нажатия клавиши до начала повторения символа клавиатурой. Значение может быть выбрано из ряда:

  • 250 мсек
  • 500 мсек
  • 750 мсек
  • 1000 мсек

Опция также функционирует только при включенном состоянии опции "Typematic Rate Setting".

Что вы думаете об этой статье? Дайте нам знать.


UART2 Mode Select

Наличие такой опции в "BIOS Setup" означает, что системная плата поддерживает IrDA-функцию. Если используется последовательный порт COM2, то это поле нужно установить в "Normal". В остальных случаях эта опция служит для установки типа, или можно сказать, спецификаций IrDA-стандарта, поддерживаемого IrDA-периферийным устройством.

Правда, значение "Standard" в разных версиях BIOS может обозначать и стандартный RS-232C-интерфейс, и поддержку последовательного инфракрасного интерфейса. При активировании IrDA-функции становятся доступными пользователю опции "RxD, TxD Active" и "IR Transmission Delay". Приводим почти все множество возможных вариантов используемых значений:

  • "Normal"
  • "Standard" - см. выше
  • "IrDA 1.0" - инфракрасный интерфейс, совместимый со спецификацией 1.0
  • "IrDA SIR" или "SIR" - просто IrDA-совместимый serial infrared порт
  • "IrDA MIR" или "MIR" - инфракрасный порт со скоростью в 1 Мб/сек.
  • "MIR 0.57M" - инфракрасный порт со скоростью в 0,57 Мб/сек.
  • "MIR 1.15M" - инфракрасный порт со скоростью в 1,15 Мб/сек.
  • "IrDA FIR" или "FIR" - просто fast infrared порт
  • "Sharp IR" - стандарт передачи со скоростью до 4 Мб/сек.
  • "HPSIR" - поддержка инфракрасного интерфейса с форматом фирмы "Hewlett-Packard"
  • "ASKIR" - Amplitude Shift Keyed Infrared port
  • "Disabled"

Что вы думаете об этой статье? Дайте нам знать.


USB IRQ

Прерывание шины USB. Параметр разрешает/запрещает назначение прерывания для контроллера шины USB. Поскольку в системе может не хватать свободного прерывания, разрешать этот параметр следует только при наличии устройства на шине USB. Также были замечены конфликты при одновременном использовании USB-устройств и звуковых карт на чипах "Aureal", и это было связано с распределением прерываний. Так что требуется внимательность. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


USB Keyboard Support

Метод поддержки USB-клавиатуры. Таких методов два: либо поддержка USB-клавиатуры операционной системой на уровне драйверов, либо аппаратное определение через BIOS. Если есть необходимость работы в системе, не поддерживающей USB-шину, то необходимо включить поддержку через BIOS. Может принимать значения:

  • "OS" - речь идет, например, о "Windows 98"
  • "BIOS" - такая установка необходима для той же "MS-DOS"

Что вы думаете об этой статье? Дайте нам знать.


VGA 128k Range Attribute

Во включенном состоянии ("Enabled") к адресам VGA-памяти (A0000H-BFFFFH) чипсетом могут быть применены свойства, подобные функциям "CPU-TO-PCI Byte Merge" или "CPU-TO-PCI Prefetch", т.е. стандартным режимам буферизации записи от CPU в PCI- интерфейс. Это повышает быстродействие системы, в противном случае используется стандартный VGA-интерфейс.

Дополнительная информация о видеофункциях содержится в опциях: PCI - "Snoop Ahead".

Что вы думаете об этой статье? Дайте нам знать.


Video BIOS Cacheable

Кэширование области BIOS видекарты. Разрешение этого параметра приводит к возможности кэширования области памяти по адресам BIOS видеокарты (C0000H-C7FFFH) в кэш-память процессора. Параметр будет использован только при включении кэш-памяти в разделе "BIOS Features Setup". Если какая-либо программа попытается выполнить запись в эти адреса, то система выдаст сообщение об ошибке.

Пpи наличии видеокаpты с "ускоpителем" необходимо отключить кэширование видеопамяти, дабы центральный процессор мог "отслеживать" любые изменения, пpоизводимые устpойством ввода в буфеp кадpа изобpажения. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Что вы думаете об этой статье? Дайте нам знать.


Video Memory Cache Mode

Режим кэширования для видеопамяти. Параметр действителен только для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). В процессоре Pentium Pro была предусмотрена возможность изменять режим кэширования в зависимости от конкретной области памяти через специальные внутренние регистры, называемые Memory Type Range Registers - MTRR.

С помощью этих регистров для конкретной области памяти могут быть установлены режимы UC (uncached - не кэшируется), WC (write combining - объединенная запись), WP (write protect - защита от записи), WT (write through - сквозная запись) и WB (write back - обратная запись).

Установка режима USWC (uncached, speculative write combining - не кэшировать, режим объединенной записи) позволяет значительно ускорить вывод данных через шину PCI на видеокарту (до 90 MB/c вместо 8 MB/c). Следует учесть, что видеокарта должна поддерживать доступ к своей памяти в диапазоне от A0000 - BFFFF (128 kB) и иметь линейный буфер кадра. Поэтому лучше установить режим USWC, но в случае возникновения каких-либо проблем (система может не загрузиться) установить значение по умолчанию UC. Может принимать значения:

  • UC (uncached) - не кэшируется
  • USWC (uncached, speculative write combining) - не кэшировать, режим объединенной записи.

Что вы думаете об этой статье? Дайте нам знать.

15/06/2002


Video Off Method

Метод выключения монитора. Устанавливается способ перехода монитора в режим пониженного энергопотребления. Может принимать значения:

  • "Blank Screen" - система очищает только экран, при этом происходит запись пустых кадров в видеобуфер. Видеокарта же работает в обычном режиме, в обычном режиме работает и монитор, с потреблением полной мощности.
  • "V/H SYNC+Blank" - параметр устанавливается по умолчанию и выбирается, если в системе имеется монитор с функциями PM. В добавление к очищенному экрану система отключит вертикальный и горизонтальный синхронизирующие сигналы, идущие от видеокарты.
  • "DPMS Supported" - использование этой опции возможно, если видеоподсистема поддерживает стандарт DPMS. DPMS (Display Power Management Signaling) - стандарт VESA, реализуемый с помощью программных функций операционной системы.

Что вы думаете об этой статье? Дайте нам знать.


Video Off Option

Установка режима погашения монитора. Опция позволяет установить, при каком режиме энергосбережения на мониторе будет "погашен" экран. Может принимать значения:

  • "Always On" (всегда включен) - монитор никогда не будет погашен, даже если система будет находиться в одном из режимов
  • "Suspend - Off" (погашение при включении режима "Suspend")
  • "Susp, Stby - Off" (погашение при включении одного из режимов, "Suspend" или "Standby")
  • "All modes - Off" (погашение во всех режимах)

Что вы думаете об этой статье? Дайте нам знать.


InfoCity
InfoCity - виртуальный город компьютерной документации
www.infocity.kiev.ua
Приглашаем к сотрудничеству авторов книг и статей
компьютерной тематики
Самая большая колекция украинских рефератов.
Постоянно добавляются новые работы.
Загляните : www.referats.kiev.ua
RLE Shop - магазин торгующий за баннеры.
Продайте свой товар или услугу!
www.rle.club.com.ua

Все, что полезно знать о BIOS

Максим Потапов

В отличие от автомобиля, "техобслуживание" ПК не требует познаний в механике, все взаимодействие компьютерных "шестеренок" происходит на программном уровне -- посредством "базовой системы ввода/вывода", т. е. BIOS. Этот материал содержит рекомендации и разъяснения, касающиеся различных настроек BIOS, разобравшись в которых, вы сможете самостоятельно, не прибегая к помощи технического специалиста, настроить свой домашний ПК.

Мы не будем рассматривать все опции, доступные в BIOS, ограничимся лишь теми, которые могут оказать существенное влияние на стабильность или производительность компьютера либо расширить функциональные возможности ПК. Регулировку прочих параметров лучше всего предоставить самой системе, т. е. оставить значения, выставленные "по умолчанию".

В связи с большим количеством производителей аппаратного и программного обеспечения существует множество разновидностей BIOS, отличающихся друг от друга интерфейсом и названием функций, поэтому мы не станем привязываться к конкретным модификациям BIOS, а для настроек приведем их "наиболее вероятные" названия. Мы также ограничимся рассмотрением только современных BIOS, которые имеются в компьютере типичной на сегодняшний день конфигурации: процессор класса Pentium II, память -- PC100 SDRAM, жесткий диск объемом свыше 2 GB, PCI- или AGP-видеоплата, наличие порта USB. В некоторых случаях наше руководство пригодится и для более старых систем.

Прежде чем мы перейдем к практике, хотелось бы предупредить о необходимости соблюдения элементарных мер предосторожности. Так, изменяя параметры в BIOS, записывайте все свои действия -- если возникнет проблема с работой компьютера, вы без труда восстановите первоначальные установки. В любом случае всегда можно вернуться к исходным параметрам, заданным производителем, для чего придется воспользоваться функциями Load BIOS Defaults и Load Setup Defaults. Первая выставит самые безопасные значения параметров BIOS, что будет полезно при восстановлении работоспособности компьютера, вторая -- оптимальные для нормальной работы системы.

Учитывая все эти замечания, перейдем к самой BIOS. При загрузке машины на экране в течение нескольких секунд отображается приглашение, к примеру Hit DEL to enter setup. Нажав в это время на клавишу DEL, вы вызовете меню, с помощью которого осуществляется доступ к настройкам BIOS. Уже по "титульной" странице становится ясно, что обеспечение работы ПК на базовом уровне не является единственным предназначением BIOS. Здесь можно найти много просто полезных опций, например обеспечение управления доступом к компьютеру. В основном меню для этого предусмотрены опции Supervisor Password и User Password. С их помощью можно задать пароли на загрузку системы, причем только Supervisor Password позволит изменять настройки в BIOS. Без знания одного из этих паролей никто не получит доступ к информации, хранящейся на жестком диске или на любом другом носителе, установленном в компьютере. Единственным способом "взломать" систему останется вскрытие корпуса и замыкание специальных контактов на материнской плате (см. ее документацию). Кстати, то же самое придется сделать, если вы забудете пароль. В принципе, можно предотвратить и вскрытие корпуса: опечатать его или установить замок на специальные скобы, если таковые на корпусе имеются.

Еще одной возможностью ограничить доступ к информационному содержимому ПК является включение режима Read Only в меню Floppy Disk Access Control. Это запретит запись файлов на дискеты, так что постороннему человеку скопировать информацию без вашего ведома не удастся. Опять же, в этом случае потребуется установить пароль на доступ к настройкам BIOS.

Другими полезными опциями могут стать автоматическое включение и загрузка компьютера в заданное время, а также его переход в "спящий режим" в случае бездействия. Следует отметить, что настройку энергосберегающих режимов для монитора, жесткого диска и системы в целом можно осуществить и средствами Windows. В BIOS для этого необходимо включить функцию Power Management. Если в корпусе установлен блок питания стандарта ATX, в меню Automatic Power Up можно задать точное время запуска компьютера -- единоразово, каждый день или в определенные дни месяца. Для того чтобы получить удаленный доступ к своему компьютеру и при этом не держать его постоянно включенным (в режиме "сна"), можно использовать режим PWR Up on Modem Act, который позволит BIOS включить компьютер в ответ на входящий телефонный звонок. При этом для загрузки и входа в систему не должны требоваться пароли, и, кроме того, система инициирует работу модема только после своей загрузки, а значит, процедуру соединения придется повторить. Кстати, в таком режиме щелчок тумблера модема сможет инициализировать включение компьютера. Есть и другие способы запуска компьютера -- нажатие на пробел либо на кнопку мыши (если они подключены через порт PS/2), для чего в BIOS имеется опция PWR up on PS2 KB/Mouse.

Продолжая тему загрузки компьютера, мы рассмотрим методы ускорения этого процесса с помощью настроек BIOS. Возможно, каждый раз, когда вы включаете ПК, вам приходится подолгу наблюдать процесс тестирования памяти. Чтобы сократить время, которое требуется для проведения подобных тестовых процедур, следует активизировать опцию Quick Power On Self Test (или POST). Отключить эту опцию потребуется лишь при поиске причины неисправности ПК, так как для ее определения необходимо более тщательное тестирование при загрузке.

Современные материнские платы позволяют использовать для загрузки компьютера практически любой носитель, установленный в ПК. В меню Boot Sequence можно задать последовательность обращения BIOS к системным дискам, при этом возможны комбинации A, C; C only; CD-ROM; LS/ZIP и др. В обычной ситуации рекомендуется выбирать вариант, в котором первым опрашиваемым устройством является жесткий диск, чтобы система не тратила время на опрос других накопителей. С этой же целью следует отключить поиск флоппи-дискеты Boot Up Floppy Seek, что к тому же позволит избавиться от достаточно неприятного звукового сигнала, сопровождающего данную процедуру.

Если в будущем все-таки возникнет необходимость загрузиться с дискеты, то все, что необходимо сделать, это при запуске компьютера войти в BIOS Setup и изменить эту опцию на A, C (перед прошивкой BIOS такой выбор обязателен). В случае, если в компьютере установлены как IDE-, так и SCSI- жесткие диски, может возникнуть потребность включения HDD Sequence SCSI/IDE First. Дело в том, что по умолчанию IDE-диску присваивается значение C и загрузка производится именно с него. При замене этой опции на SCSI пользователь получит возможность разместить различные операционные системы на IDE- и SCSI-дисках либо просто использовать SCSI-диск в качестве загрузочного.

Опция Halt On отвечает за остановку компьютера в процессе начального самотестирования (POST) при обнаружении неисправности или отсутствия необходимого устройства, например клавиатуры. Здесь можно задать компьютеру условия, при которых загрузка будет продолжена: All Errors -- при любых ошибках, All But Disk/Key -- при всех, кроме ошибок клавиатуры и диска, и т. д.

Загрузка компьютера может также быть приостановлена при обнаружении Boot-вируса. Отвечают за данную функцию Virus Warning и Boot Virus Detection. Эти режимы работают по-разному: Virus Warning запрещает любую запись в загрузочный сектор жесткого диска, что в качестве побочного эффекта, кстати говоря, предотвращает и установку операционной системы Windows 9x. Boot Virus Detection же в процессе загрузки выводит на экран предупреждающее сообщение в случае, если содержимое загрузочного сектора отличается от предварительно сохраненного в памяти. Далее, по усмотрению пользователя, можно либо продолжить загрузку, либо перезагрузить ПК, используя системную дискету.

Раздел IDE HDD Auto detection предоставляет возможность автоматического определения параметров жесткого диска и выбора режима, в котором тот будет работать. Обычно пользователю предлагается два или три варианта, из которых в случае современных дисков объемом более 528 MB оптимальным является режим LBA. Полученные после процедуры автоматического определения параметры следует задать явным образом, включив режим USER Type HDD, что ускорит загрузку компьютера на несколько секунд, которые в противном случае будут каждый раз тратиться на автоматическое определение этих же параметров. Режим AUTO, с другой стороны, полезен тем, что не требует изменения настроек BIOS в случае замены диска.

Режим Floppy 3 Mode является японским стандартом для флоппи-дисковода и не используется в других странах, так что в меню Floppy 3 Mode Support этот пункт следует проигнорировать.

Режим UDMA поддерживается всеми современными жесткими дисками и позволяет повысить производительность системы в целом. Отключение его может понадобиться лишь в случае работы системной шины на нештатных частотах, о чем подробнее будет рассказано ниже.

HDD S.M.A.R.T. capability расшифровывается и переводится как "технология самодиагностики и мониторинга состояния диска". С ее помощью можно заранее предотвратить потерю информации при сбое жесткого диска. Система отслеживает нормальную работу механических и электронных элементов накопителя и оценивает его состояние путем сравнения текущих параметров с заложенными пороговыми значениями. Активизация этой функции несколько снижает производительность компьютера, зато гарантирует сохранность данных, что особенно актуально для съемных дисков.

Функция IDE HDD Block Mode Sectors (в других модификациях BIOS может называться Multi-Sector Transfers) позволяет передавать несколько секторов за один такт, что, естественно, повышает быстродействие. Режим Maximum устанавливает количество секторов в блоке равным максимальному значению, что, однако, не всегда является оптимальным режимом для накопителя. Для установки наилучшего значения необходимо обратиться к документации жесткого диска.

Некоторые версии BIOS предоставляют возможность форматирования, однако мы ни в коем случае не рекомендовали бы без крайней нужды "баловаться" с этой опцией.

Разобравшись с оптимизацией загрузки компьютера и работы жесткого диска, перейдем к более "тонким" настройкам. Современные материнские платы позволяют устанавливать частоту, напряжение питания и прочие параметры процессора не с помощью перемычек на самой плате, а через BIOS. Для изменения частоты системной шины необходимо выбрать Manual в меню CPU Speed. Для стабильной работы процессора на нештатных частотах, возможно, потребуется увеличение CPU Vcore -- напряжения питания ядра. Пользователь, однако, должен отдавать себе отчет в том, что установка данного параметра сверх нормативного значения может повлечь за собой выход процессора из строя, причем необязательно сразу. Это связано с увеличением вероятности миграции электронов, т. е. их движения по "непроторенным" дорожкам. Вначале это приводит к ошибкам, а в дальнейшем -- неисправимым повреждениям микроструктуры процессора.

Повышение частоты системной шины, кроме того, может стать причиной зависания системы из-за возникновения проблем с жестким диском, а также платами расширения -- видео, звуковыми и прочими. Частоты, на которых будут работать эти компоненты, приведены в меню CPU Bus/PCI Freq. Значения свыше 37 MHz могут привести к сбоям диска (особенно если тот работает в режиме UDMA) и, возможно, к утере всей информации на нем. Исходя из этого, рекомендуем использовать предложенные значения в меню CPU Speed, а также номинальную частоту системной шины и напряжение CPU Vcore.

Рассмотрим другие параметры, регулирующие работу процессора. BIOS Update (другой вариант названия -- Pentium II Microcode) -- этот механизм необходим для загрузки микрокода, содержащего исправления ошибок в процессорах класса Pentium II. Включение данной опции повысит стабильность работы системы.

Отключать параметр CPU L1 and L2 Cache settings не стоит, так как это приведет к значительному снижению производительности и не даст никакого положительного эффекта.

CPU L2 cache ECC checking: при включении опции стабильность работы системы может повыситься за счет механизма коррекции ошибок в кэш-памяти второго уровня процессора, однако быстродействие при этом снизится.

Чтобы выжать из своей системы дополнительный прирост производительности, следует обратиться к настройкам оперативной памяти. SDRAM Configuration указывает, должна ли BIOS самостоятельно установить временные параметры доступа к памяти на основании информации из блока SPD в модуле памяти (by SPD) или разрешить это сделать пользователю (Disabled). Последний режим мы настоятельно рекомендуем не включать. Максимальное быстродействие памяти достигается при минимальных значениях величин CAS Latency, RAS to CAS delay, которые можно задать, выбрав 7ns (143 MHz) в меню SDRAM Configuration.

Далеко не все микросхемы памяти будут устойчиво работать при такой настройке, поэтому при их покупке следует поинтересоваться у продавца, помимо соответствия модуля памяти стандартам PC100 или PC133, еще и параметром CAS Latency, который обычно обозначается CL=2 и CL=3. Память с CL=2 имеет максимальное быстродействие и стабильно работает на частотах 100--133 MHz.

В случае, если вы используете тип памяти ECC SDRAM, содержащий механизм коррекции ошибок, включение опции DRAM Data Integrity Mode может повысить устойчивость системы.

Теперь перейдем к настройкам, регулирующим работу графической подсистемы. Если в компьютере установлены одновременно и AGP-, и PCI-видеоплаты, VGA BIOS Sequence позволяет выбрать, какая именно будет задействована в первую очередь.

Параметр Graphics Aperture Size имеет смысл установить в размере порядка 50% или 25% от объема оперативной памяти -- оптимальное значение должно быть указано в документации видеоплаты. При разгоне системной шины уменьшение этой величины может решить проблему нестабильной работы видеокарты.

Некоторые нестандартные видеоплаты, такие, как отдельные 3D-акселераторы или платы для проигрывания MPEG-видео, могут некорректно отображать цвета. В этом случае стоит включить функцию PCI/VGA Palette Snoop.

С помощью меню Video Memory Cache Mode активизируется технология кэширования видеопамяти Uncacheable, Speculative Write Combine (USWC), которая ускорит вывод графики на дисплей. Если карта не поддерживает данную функцию, необходимо изменить этот параметр на UC.

Включение режима Video ROM BIOS Shadow может ускорить работу игр под DOS, но никак не скажется на быстродействии Windows-приложений. То же самое относится и к прочим установкам типа Shadow C8000 -- CBFFF.

Для нормальной работы ISA-плат предусмотрено достаточно много установок. В новых компьютерах такие устройства встречаются очень редко, более того, на современных материнских платах ISA-слоты могут вообще отсутствовать. Однако в ПК, собранных два и более лет назад, сетевые и звуковые карты установлены в основном именно в ISA-слоты. Их использование (особенно это касается звуковых плат) существенно снижает производительность в играх и мультимедийных приложениях.

Пока идет обмен данными с ISA-устройством, шина PCI фактически простаивает. Чтобы сократить это время, необходимо включить режим PCI Delayed Transaction. Аналогичное действие оказывает механизм Passive Release, который позволяет шинам ISA и PCI работать параллельно. Как PCI Delayed Transaction, так и Passive Release задействуются только при активизации опции PCI 2.1 Support.

Для оптимизации работы плат ISA используются также установки 8 и 16 bit I/O Recovery Time. Значение 0 или N/A обычно дает прирост производительности, если, конечно, такие параметры приемлемы для платы. Для нормального функционирования некоторых ISA-карт требуется включить опцию Memory Hole at 15M--16M.

Что касается настройки других устройств ввода/вывода и плат расширения, можно дать следующие рекомендации: если ваша система имеет порт мыши стандарта PS/2 и при этом вы используете серийный порт для ее подключения, в меню PS/2 Mouse Function Control выберите Disabled. В противном случае оставьте AUTO. То же самое относится и к устройствам USB: если вы их не используете и BIOS предоставляет такую возможность, порт USB лучше отключить.

Прошивка BIOS

Обновление BIOS может быть полезно как для увеличения производительности и устойчивости системы, так и для корректного распознавания процессоров, совместимости с новыми жесткими дисками, видеоплатами и прочими компонентами.

В разделе Download на официальном Web-сайте производителя материнской платы можно найти специальные утилиты для прошивки BIOS и текущие версии BIOS для каждой конкретной материнской платы. После загрузки необходимо распаковать и сохранить утилиту для прошивки и новый "образ" BIOS в легкодоступной директории, например C:\ABC. Затем запишите на бумаге полные названия исполняемого файла, например aflash.exe, и самого образа, например Bx2i1011.awd. После этого произведите рестарт системы с помощью диспетчера загрузки (для его вызова следует во время запуска удерживать клавишу F8). В меню выберите Safe Mode Command Prompt Only. Когда появится командная строка, перейдите в каталог ABC с помощью команды cd ABC и запустите утилиту, набрав aflash.exe.

Программа прошивки обычно позволяет сохранить предыдущую версию BIOS, что рекомендуется сделать. Для записи новой версии утилита может запросить название и месторасположение нового образа BIOS, в нашем случае это будет С:\ABC\ Bx2i1011.awd. По завершении процедуры обновления и выхода из программы необходимо выключить компьютер и затем, после включения, войти в меню BIOS и активизировать функцию LOAD Setup Defaults, при выходе же из SETUP нужно сохранить изменения. Теперь процедура обновления BIOS завершена.

Крайне важно при обновлении BIOS руководствоваться следующими правилами. Во-первых, производить процедуру в максимально стабильных условиях, особенно это касается энергоснабжения -- желательно использовать источник бесперебойного питания. Если система "разогнана", необходимо вернуть ее в штатный режим.

Когда в процессе обновления BIOS происходят неполадки, ни в коем случае нельзя выключать компьютер. Попробуйте повторить процесс либо прописать старый образ, сохраненный вначале. Если и это не поможет, потребуется обратиться к специалистам, чтобы заменить сам чип, в котором содержится BIOS.

Для подстраховки в случае неудачной прошивки рекомендуется также сохранить саму утилиту и образ на загрузочный диск. Последний лучше всего создать, перезагрузив систему в режиме DOS (Start/Shut Down/Restart in MS DOS Mode) и набрав в командной строке C:\Format A:/S. Не следует копировать на этот диск файлы Autoexec.bat и Config.sys. Если система сможет загрузиться с такой дискеты, попробуйте повторить процедуру заново.

При обновлении BIOS следует учитывать, что вы берете на себя всю ответственность за возможный выход из строя вашей системы. Если материнская плата и установленные устройства работают стабильно, а новые версии BIOS не содержат существенных улучшений, мы не рекомендуем производить эту операцию -- кроме всего прочего, перепрошивка BIOS может повлечь за собой необходимость переустановки операционной системы.

Существуют утилиты, позволяющие изменять параметры BIOS прямо из операционной системы. Наибольшей популярностью пользуется Tweak BIOS, бесплатную версию которой можно загрузить по адресу www.miro.pair.com/tweakbios. Программа предназначена для оптимизации работы чипсета материнской платы, центрального процессора и видеокарты и предоставляет доступ к регулировкам, которые зачастую не "показаны" в BIOS материнских плат. Примечателен тот факт, что утилита способна изменять параметры "на лету", не требуя перезагрузки и не обновляя микрокод в ПЗУ BIOS. Она совместима практически со всеми существующими чипсетами и графическими акселераторами и не зависит от версии BIOS, установленной в компьютере.

Параметры, заданные с помощью бесплатного варианта TweakBIOS, будут действенны до момента перезагрузки либо отключения компьютера. Зарегистрированная версия позволит сохранить эти настройки в файл и загружать каждый раз при запуске ПК.

Внешний вид программы напоминает стандартный интерфейс BIOS от Award Software. Перемещение по меню сопровождается полезными подсказками о том, как повлияет на производительность изменение того или иного параметра. Важно отметить, что "игра" с этими настройками может привести к зависанию компьютера, так что использование утилиты требует от пользователя соответствующего уровня знаний и навыков. В любом случае разработчики предупреждают, что они не несут ответственности за утерю информации либо вышедшие из строя аппаратные компоненты в связи с использованием TweakBIOS.

Автор и координатор проекта: Михаил Пинкус
Дизайн: Tangram Design Studio


Описание настроек Setup BIOS

В этом разделе описываются практически все (по мере создания) параметры, устанавливаемые в программе SETUP для BIOS фирмы AWARD Software International Inc. В конкретной материнской плате каких-то из описываемых параметров может и не быть. Одни и те же параметры могут называться по разному в зависимости от производителя материнской платы, поэтому здесь в некоторых случаях приведено несколько вариантов.

Для просмотра и корректировки установок chipset в BIOS вашего компьютера рекомендуем воспользоваться прелестной программой TweakBIOS. С помощью этой программы можно изменять установки в BIOS "на лету", а также увидеть, правильно ли программа SETUP выполнила установки.

ПРИМЕЧАНИЕ: Программа запускается и под различными Windows, но использовать ее можно только в DOS.

Содержание:

Раздел BIOS FEATURES SETUP

Virus Warning
Boot Virus Detection
 CPU Internal Cache/External Cache
CPU Level 1 Cache/CPU Level 2 Cache
CPU Level 2 Cache ECC Check
 BIOS Update
CPU Fast String
HDD S.M.A.R.T Capability
 Deturbo Mode
Quick Power On Self Test
Boot Sequence
Boot Up System Speed
 Gate A20 Option
Swap Floppy Drive
Boot Up Floppy Seek
Boot Up NumLock Status
Typematic Rate Setting
Typematic Rate (Chars/Sec)
Typematic Delay (Msec)
OS/2 Onboard Memory > 64MB
PS/2 Mouse Function Control
PCI/VGA Palette Snoop
Video ROM BIOS Shadow
Floppy Disk Access Control (R/W)
Report No FDD For WIN 95
Delay IDE Initial
MPS 1.4 Support

Раздел CHIPSET FEATURES SETUP

Установка параметров для FPM DRAM, EDO DRAM и Synchronous DRAM
AUTO Configuration
DRAM RAS# Precharge Time
DRAM R/W Leadoff Timing
 DRAM RAS to CAS Delay
DRAM Read Burst Timing
Speculative Leadoff
Turn-Around Insertion
Data Integrity (PAR/ECC)
DRAM ECC/PARITY Select
Fast RAS# to CAS# Delay
SDRAM Configuration
 SDRAM RAS Precharge Time
 SDRAM (CAS Lat/RAS-to-CAS )
SDRAM CAS# Latency
SDRAM CAS to RAS Delay
 SDRAM Banks Close Policy
 DRAM Idle Timer
 Snoop Ahead
 Host Bus Fast Data Ready
Refresh RAS# Assertion
MA Wait State
SDRAM Speculative Read
Spread Spectrum Modulated

Установка параметров кэширования
System BIOS Casheable
Video BIOS Cacheable

Конфигурирование шин PCI, AGP, портов ввода/вывода и установка параметров IDE контроллера
Video Memory Cache Mode
Graphics Aperture Size
 PCI 2.1 Support
8 Bit I/O Recovery Time
16 Bit I/O Recovery Time
Memory Hole At 15M-16M
Peer Concurrancy
Chipset Special Features
Passive Release
PCI Delayed Transaction
Parallel Port Mode (ECP+EPP)
Parallel Port Mode
ECP DMA Select
 Onboard PCI IDE Enable
Onboard FDC Controller
Выбор режима работы каждого диска

Раздел PnP/PCI Configuration Setup

PNP OS Installed
Resources Controlled By
Reset Configuration Data
IRQ n Assigned to
DMA n Assigned to
 PCI IRQ Activated by
PCI IDE IRQ Map to
PCI Slot IDE 2nd Channel
IRQ n Used By ISA
DMA n Used By ISA
ISA MEM Block BASE
Onboard AHA BIOS
 ONB AHA BIOS First
 ONB SCSI SE Term.
 ONB SCSI LVD Term.
 SYMBIOS SCSI BIOS
PCI Latency Timer
USB IRQ
VGA BIOS Sequence
USB Keybord Support Via

Раздел Power Management Setup

Power Management
ACPI function
Video Off Option
Video Off Method
Suspend Switch
Doze Speed
Stby Speed
HDD Power Down
Doze Mode
Standby Mode
Suspend Mode
IRQ 3 (Wake-up)
IRQ 4 (Wake-up)
IRQ 8 (Wake-up)
 IRQ 12 (Wake-up)
IRQ 3 (COM2)
IRQ 4 (COM1)
IRQ 5 (LPT2)
IRQ 6 (Floppy Disk)
IRQ 7 (LPT1)
 IRQ 8 (RTC Alarm)
IRQ 9 (IRQ2 Redir)
 IRQ 10 (Reserved)
IRQ 11 (Reserved)
IRQ 12 (PS/2 Mouse)
 IRQ 13 (Coprocessor)
 IRQ 14 (Hard Disk)
 IRQ 15 (Reserved)
 PWR Button < 4 Secs (он же Soft-of By PWR-BTTN)
PWR Up On Modem Act (он же Resume by Ring)
IRQ8 Resume by Suspend
ZZ Active In Suspend
Wake On LAN
 AC PWR Loss Restart
Automatic Power Up
 Chassis Fan Speed (xxxxRPM)
CPU Fan Speed (xxxxRPM)
 Power Fan Speed (xxxxRPM)
 CPU Temperature
 MB Temperature
 Voltage Monitor

Раздел BIOS FEATURES SETUP

  • Virus Warning (Предупреждение о вирусе) - разрешение этого параметра запрещает любую запись в загрузочный сектор жесткого диска без разрешения пользователя. Он введен для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Рекомендуется всегда разрешать этот параметр, но следует учесть, что, например, Windows 95 при установке "зависает", если Virus Warning установлен в Enable (при этом на экране появляется черный квадрат).Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Boot Virus Detection (Определение вируса в загрузочном секторе) - смысл этого параметра сильно отличается от Virus Warning. Идея заключается в следующем - если этот параметр запрещен, то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. После установки параметра в значение Enabled BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора отличается от сохраненного в памяти. Далее, по усмотрению пользователя, возможно либо загрузить систему с жесткого диска, либо с дискеты. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • CPU Internal Cache/External Cache (Внутренний/Внешний кэш процессора) - разрешается/запрещается внутренний или внешний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • CPU Level 1 Cache/CPU Level 2 Cache (Кэш процессора первого уровня/Кэш процессора второго уровня) - разрешается/запрещается кэш первого уровня или кэш процессора второго уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • CPU Level 2 Cache ECC Check (Включить ECC для кэш-памяти процессора 2 уровня) - параметр может присутствовать только для плат с процессорами архитектуры Pentium II. Разрешать его есть смысл только в том случае, если установленный процессор класса Pentium II имеет кэш-память второго уровня с возможностью ECC контроля. В некоторых процессорах допущена ошибка и включение этого режима может привести к нестабильной работе компьютера. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • BIOS Update (Обновление BIOS) - процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon и т.д.) имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров за счет изменения микрокода. Обновления микрокода остаются в BIOS и загружаются в процессор после включения компьютера и запуска программы BIOS. Именно поэтому BIOS для материнских плат с Pentium II и выше необходимо регулярно обновлять. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • CPU Fast String (Быстрые операции со строками) - Разрешение этого параметра позволяет использовать некоторые специфические особенности архитектуры семейства Pentium Pro (Pentium II, Deshutes и т.п.), в частности, возможность кэширования операций со строками. Надо только понимать, что и в самой программе должны быть выполнены условия для включения этого механизма. Эти условия указаны в документации на любой процессор данного семейства. Параметр рекомендуется оставлять в состоянии "Разрешено". Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • HDD S.M.A.R.T Capability (Возможность S.M.A.R.T диагностики) - позволяет разрешать/запрещать возможность диагностики состояния жесткого диска в соответствии с требованиями стандарта S.M.A.R.T. Авторы BIOS, к сожалению, не раскрывают механизма функционирования S.M.A.R.T диагностики в BIOS, поэтому не совсем понятно, каким образом обрабатывается информация от жесткого диска, так как граничные значения параметров жесткого диска зависят от конкретного производителя. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Следует учесть, что разрешение этого параметра снизит производительность компьютера на несколько процентов. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Deturbo Mode (Режим deturbo) - при разрешении этого параметра сигнал FLUSH# становится активным и никакие данные после этого не кэшируются процессором в свой внутренний кэш (кэш первого уровня) процессорами архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Разрешение этого параметра следует использовать только при необходимости сознательно замедлить работу компьютера. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Quick Power On Self Test (быстрый тест компьютера после включения питания) - разрешение этого параметра приводит к значительному сокращению времени на начальное тестирование компьютера BIOS'ом, особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Boot Sequence (последовательность загрузки) - параметр устанавливает последовательность опроса устройств, с которых может быть загружена операционная система. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства - CD-ROM для накопителей CD-ROM, LS для накопителей a:drive на 120 Mb или ZIP для накопителей ZIP IDE на 100 Mb. Для современных версий возможные значения могут выглядеть так: A,C; C only; CD-ROM, C; C, A; D, A; LS/ZIP, C.
  • Boot Up System Speed (скорость системы после загрузки) - скорость системной шины и соответственно, процессора после включения компьютера. Параметр используется для искуственного снижения скорости компьютера из-за старых программ и/или плат расширения. Может принимать значения:
    • High - номинальная скорость процессора и номинальная частота системной шины
    • Low - пониженная скорость процессора и частота системной шины
  • Gate A20 Option (вариант включения шины A20) - параметр позволяет управлять способом включения адресной шины A20 и, тем самым, обращаться к памяти за 1 мегабайтом. Этот параметр в современных платах не управляется пользователем и всегда в значении Fast. Может принимать значения:
    • Fast - управление осуществляется chipset, что повышает скорость работы
    • Normal - управление осуществляется через контроллер клавиатуры
  • Swap Floppy Drive (перестановка дисководов) - если разрешен, то дисководы A и B как бы меняются местами. Имеет смысл только при наличии 2-х дисководов в компьютере. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Boot Up Floppy Seek (поиск загрузочного дисковода после включения компьютера) - если этот параметр разрешен, то BIOS обращается к каждому дисководу на предмет распознавания его формата (40 или 80 дорожек он поддерживает). Поскольку уже с 1993 года дисководы на 40 дорожек не выпускаются, не следует разрешать этот параметр, так как BIOS каждый раз будет тратить несколько секунд на выяснение формата дисковода. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Boot Up NumLock Status (включение цифровой клавиатуры по включению компьютера) - разрешение этого параметра включает индикатор NumLock и цифровая клавиатура генерирует коды цифр и знаков, в противном случае генерируются коды стрелок, Ins, Del и т.д. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Typematic Rate Setting (установка скорости ввода символов) - разрешает или запрещает установку скорости повторения ввода символов клавиатурой при нажатой клавише. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Typematic Rate (Chars/Sec) (частота повторения симв/сек) - параметр оказывает действие только в том случае, если разрешен Typematic Rate Setting. Частота повторения имеет ряд фиксированных значений, которые и может принимать этот параметр:
    • 6, 8, 10,12, 15, 20, 24 или 30
  • Typematic Delay (Msec) (задержка повторения в msec) - устанавливает значение задержки от момента нажатия клавиши до начала повторения символа клавиатурой. Оказывает действие только в том случае, если разрешен Typematic Rate Setting. Значение может быть выбрано из ряда:
    • 250, 500, 750 или 1000
  • PS/2 Mouse Function Control (управление функциями порта мыши PS/2) - разрешение этого параметра отдает IRQ12 только для порта мыши PS/2. В противном случае, при отсутствии подключенной к компьютеру мыши с интерфейсом PS/2, IRQ12 свободно для других устройств. Рекомендуется устанавливать значение Auto. Может принимать значения:
    • Enabled - разрешено и IRQ12 занято.
    • Auto - BIOS определяет присутствие или отсутствие PS/2 мыши.
  • OS/2 Onboard Memory > 64MB (выбор значения для OS/2, если памяти больше, чем 64 Mb) - требует разрешения при выполнении двух условий - в компьютере установлено больше, чем 64 Mb памяти и используется OS/2 в качестве операционной системы. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • PCI/VGA Palette Snoop (корректировка палитры VGA видеокарты на PCI) - параметр следует разрешать только в том случае, если на экране некорректно отображаются цвета. Как правило, этот эффект может возникать при использовании таких нестандартных устройств, как MPEG карты, 3D ускорители и т.п. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Video ROM BIOS Shadow (видео BIOS в память) - разрешение этого параметра приводит к переносу видео BIOS из ПЗУ (постоянного запоминающего устройства) на видеокарте в основную память компьютера, что значительно ускоряет работу с видео BIOS (это необходимо и видно в DOS). Ускорение объясняется как и тем, что обращение к ПЗУ намного медленнее, чем к ОЗУ, так и тем, что обращение к ПЗУ, как правило, выполняется в 8-ми разрядной сетке, а к ОЗУ - 32-х или 64-х сетке. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Floppy Disk Access Control (R/W) (управление чтением/записью на гибкий диск) - разрешение этого параметра позволяет записывать информацию на дискету, в противном случае дискету можно читать. Параметр следует использовать для защиты от несанкционированного копирования с компьютера. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Report No FDD For WIN 95 (сообщение об отсутствии накопителя на гибких дисках для Windows 95) - параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе Yes и одновременном выборе Disable в параметре Onboard FDC Controller, Windows 95 освободит IRQ 6, занимаемое контроллером флоппи-дисковода, для использования другими устройствами. Совместное разрешение этих параметров обязательно в компьютерах без дисководов (используемых как сетевые в организациях) для уменьшения времени запуска Windows 95. Может принимать значения:
    • Yes - освободить IRQ 6
    • No - не освобождать (независимо от того, есть ли флоппи-дисковод или нет)
  • Delay IDE Initial (задержка инициализации IDE устройства) - в данном параметре устанавливается значение времени (в секундах) в течении которого IDE устройство не будет опрашиваться BIOS'ом после включения питания или сброса. Ненулевое значение параметра рекомендуется устанавливать только в случае применения каких-либо старых жестких дисков или приводов CD-ROM. Параметр принимает значения в диапазоне от 0 до 30 сек., в зависимости от производителя материнской платы.
  • MPS 1.4 Support(поддержка режима MPS 1.4) - параметр появляется только в BIOS материнских плат, допускающих установку нескольких процессоров. Выбор режима влияет на распределение ресурсов компьютера. При запрещении устанавливается режим MPS 1.1. Строго говоря, для различных Windows можно устанавливать любое значение (даже лучше Disable), а для Novell Netware рекомендуется Enable. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено

Раздел CHIPSET FEATURES SETUP

Установка параметров для FPM DRAM, EDO DRAM и Synchronous DRAM

  • AUTO Configuration (автоматическая конфигурация) - имеет 3 значения
    • 60 ns - устанавливает парамеры доступа для DRAM с быстродействием 60 ns
    • 70 ns - то же для памяти с быстродействием 70 ns
    • Disabled (запрещена) - позволяет установить любые возможные параметры доступа к DRAM памяти
  • DRAM RAS# Precharge Time (время предварительного заряда по RAS) - Эта функция позволяет определить количество тактов системной шины для формирования сигнала RAS. Уменьшение этого значение увеличивает быстродействие, но чрезмерное для конкретной памяти уменьшение может привести к потере данных. Принимает значения:
    • 3
    • 4
  • DRAM R/W Leadoff Timing (число тактов при подготовке выполнения операции чтения/записи) - определяет число тактов на шине до выполнения любых операций с DRAM. Параметр может принимать значения:
    • 8/7 - восемь тактов для чтения и семь тактов для записи
    • 7/5 - семь тактов для чтения и пять тактов для записи
  • DRAM RAS to CAS Delay (задержка между RAS и CAS) - Во время доступа к памяти обращения к столбцам и строкам выполняются отдельно друг от друга. Этот параметр и определяет отстояние одного сигнала от другого. Параметр может принимать значения:
    • 3 - три такта задержки
    • 2 - два такта задержки
      Уменьшение значения увеличивает быстродействие.
  • DRAM Read Burst Timing (время пакетного чтения памяти) - Запрос на чтение и запись генерируется процессором в четыре раздельные фазы. В первой фазе инициируется обращение к конкретной области памяти, а в оставшихся происходит собственно чтение данных. Параметр может принимать значения:
    • x2222 - два такта задержки
    • x3333 - три такта задержки
    • x4444 - четыре такта задержки
      Уменьшение суммарного количества тактов увеличивает быстродействие.
  • Speculative Leadoff (опережающая выдача сигнала чтения) - разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр Speculative Leadoff разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Turn-Around Insertion (задержка между циклами) - Если этот параметр разрешен (Enabled), то между двумя последовательными циклами обращения к памяти включается один дополнительный такт. Разрешение уменьшает быстродействие, но увеличивает достоверность при операциях чтения/записи. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Data Integrity (PAR/ECC) (целостность данных) - разрешает/запрещает контроль памяти на ошибки. Вид контроля устанавливается параметром DRAM ECC/PARITY Select. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • DRAM ECC/PARITY Select(режим коррекции ошибок/проверка по четности) - Параметр появляется только в тех материнских платах, в которых chipset поддерживает ECC и только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром Data Integrity (PAR/ECC). Такие планки часто называют также 36-разрядными. Может принимать значения:
    • Parity - в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается
    • ECC -Error Control Correction- в случае возникновения одиночной ошибки она исправляется и работа продолжается. Если имеет место не одиночная ошибка, то работа компьютера также прекращается. Следует только учесть, что по данным Intel, скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%
  • Fast RAS# to CAS# Delay (интервал между RAS и CAS) - При регенерации памяти строки и столбцы адресуются отдельно, поэтому этот параметр устанавливает интервал между сигналами RAS и CAS.
  • SDRAM Configuration (Конфигурация SDRAM) - параметром определяется, должна ли программа BIOS сама определять временные характеристики доступа к памяти на основании информации из блока SPD или разрешить это сделать пользователю. Может принимать значения:
    • By SPD - параметры доступа устанавливаются по SPD
    • 7 ns (143 Mhz) - параметры доступа устанавливаются BIOS как для памяти с временем доступа 7 ns и частотой шины 143 MHz
    • 8 ns (125 Mhz) - параметры доступа устанавливаются BIOS как для памяти с временем доступа 8 ns и частотой шины 125 MHz
    • Disabled - устанавливаются пользователем
  • SDRAM RAS Precharge Time (Cинхронная память - время предварительного заряда) - параметр позволяет определять быстрое или медленное накопление заряда по RAS до начала цикла регенерации памяти. Установка значения Fast увеличивает быстродействие, но Slow повышает стабильность работы компьютера, поэтому значение Fast следует устанавливать в случае уверенности в качестве памяти. Может принимать значения:
    • Fast -быстро
    • Slow - медленно
  • SDRAM (CAS Lat/RAS-to-CAS ) (Cинхронная память - задержка CAS/От RAS к CAS) - этот параметр позволяет комбинировать между длительностью сигнала CAS и задержкой между сигналами RAS и CAS. Значение этого параметра зависит от характеристик SDRAM, примененной в материнской плате и от быстродействия процессора. Поэтому изменять этот параметр стоит крайне осторожно. Может принимать значения:
    • 2/2
    • 3/3
  • SDRAM CAS to RAS Delay (задержка между CAS и RAS) - параметр определяет значение задержки после выдачи сигнала RAS до появления сигнала CAS для синхронной памяти. Чем меньше это значение, тем быстрее доступ к памяти. Тем не менее изменять его следует осторожно. Параметр может принимать значения:
    • 3 - три такта задержки
    • 2 - два такта задержки
  • SDRAM CAS# Latency (задержка CAS для SDRAM) - Устанавливает значение задержки выдачи сигнала CAS для SDRAM. Меньшее значение увеличивает производительность системы. Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 nc или лучше.Может принимать значения:
    • 2T
    • 3T
  • SDRAM Banks Close Policy (правила закрытия банков SDRAM памяти) - параметр был введен для плат с набором 440LX из-за того, что память с 2-х банковой организацией некорректно работает в этих платах, если параметры доступа к банкам памяти установлены по умолчанию. В наборе 430TX этого не требовалось, так правила доступа для различной памяти были одинаковы. Изменять установки BIOS по умолчанию для этого параметра следует только в случае нестабильной работы памяти. Может принимать значения:
    • Page Miss - используется для двухбанковой памяти
    • Arbitration - для памяти из 4-х банков
  • DRAM Idle Timer (Таймер пассивного состояния памяти) - этим параметром устанавливается время (в тактах) до закрытия всех открытых страниц памяти. Влияет как на EDO так и на SDRAM память. Может принимать значения 0, 2, 4, 8, 10, 12, 16, 32.
  • Snoop Ahead (Предвидение) - разрешение этогопараметра позволяет потоковый обмен данными между PCI и памятью. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Host Bus Fast Data Ready (Быстрая готовность данных на шине) - разрешение этого параметра позволит снимать данные с шины одновременно с их выборкой. В противном случае данные будут удерживаться на шине один дополнительный такт. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Refresh RAS# Assertion (задание RAS для регенерации) - Этим параметром устанавливается количество тактов (т.е. длительность RAS) для цикла регенерации. Принимаемые значения определяются качеством памяти и набором микросхем (chipset). Меньшее значение увеличивает производительность.
  • MA Wait State (такты ожидания до чтения памяти) - параметр позволяет установить или снять дополнительный такт ожидания до начала чтения памяти. Для памяти типа EDO один такт всегда есть по умолчанию и установка значения Slow добавляет еще один такт ожидания. Для SDRAM нет такта ожидания по умолчанию и установка Slow один такт вводит. Может принимать значения:
    • Slow - добавляется один такт
    • Fast - нет дополнительного такта ожидания
  • SDRAM Speculative Read (SDRAM опережающее чтение) - разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр SDRAM Speculative Read разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Spread Spectrum Modulated (Спред модулированного спектра) - разрешение этого параметра позволяет уменьшить электромагнитное излучение от компьютера за счет уменьшения значения выбросов сигнала тактового генератора. Уменьшение может достигать 6%. Следует заметить, что это может отрицательно отразиться на работе чувствительных к форме сигнала устройств, например, жестких дисках с интерфейсом Fast Wide SCSI, поэтому параметр рекомендуется разрешать только при испытаниях компьютеров на электромагнитную совместимость. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено

Установка параметров для кэширования

  • System BIOS Casheable (кэширование области BIOS системы) - Разрешение этого параметра приводит к появлению возможности кэширования области памяти по адресам системного BIOS с F0000H по FFFFFH в кэш-память. Параметр будет использован только в том случае, если использование кэш-памяти разрешено в разделе BIOS Features Setup. Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Video BIOS Cacheable (кэширование области BIOS видекарты) - Разрешение этого параметра приводит к появлению возможности кэширования области памяти по адресам BIOS видеокарты с C0000H по C7FFFH в кэш-память. Параметр будет использован только в том случае, если использование кэш-памяти разрешено в разделе BIOS Features Setup. Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено

Конфигурирование шин PCI, AGP, портов ввода/вывода и установка параметров IDE контроллера

  • Video Memory Cache Mode (Режим кэширования для видеопамяти) - параметр действителен только для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). В процессоре Pentium Pro была предусмотрена возможность изменять режим кэширования в зависимости от конкретной области памяти через специальные внутренние регистры, называемые Memory Type Range Registers - MTRR. С помощью этих регистров для конкретной области памяти могут быть установлены режимы UC (uncached - не кэшируется), WC (write combining - объединенная запись), WP (write protect - защита от записи), WT (write through - сквозная запись) и WB (write back - обратная запись). Установка режима USWC (uncached, speculative write combining - не кэшировать, режим объединенной записи) позволяет значительно ускорить вывод данных через шину PCI на видеокарту (до 90 MB/c вместо 8 MB/c). Следует учесть, что видеокарта должна поддерживать доступ к своей памяти в диапазоне от A0000 - BFFFF (128 kB) и иметь линейный буфер кадра. Поэтому лучше установить режим USWC, но в случае возникновения каких-либо проблем (система может не загрузиться) установить значение по умолчанию UC. Может принимать значения:
    • UC - uncached - не кэшируется
    • USWC - uncached, speculative write combining - не кэшировать, режим объединенной записи.
  • Graphics Aperture Size (размер графической апертуры для AGP) - в этом параметре указывается максимальный размер области памяти для использования видеокартой с интерфейсом AGP. Значение по умолчанию, устанавливаемое по включению питания или сбросу, 4 MB. После инициализации BIOS'ом принимает значение, выбранное производителем материнской платы (как правило, 64 MB). Разрешенный ряд значений графической апертуры 4 MB, 8 MB, 16 MB, 32 MB, 64 MB, 128 MB и 256 MB.
  • PCI 2.1 Support (поддержка спецификации шины PCI 2.1) - при разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от 2.0 - максимальная тактовая частота шины увеличена до 66 MHz и вводится механизм моста PCI - PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. Запрещать этот параметр имеет смысл только при возникновении проблем после установки PCI платы (как правило, они возникают только с достаточно старыми платами). Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • 8 Bit I/O Recovery Time (время восстановления для 8-ми разрядных устройств) - Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel - порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Кроме этого 8-ми разрядные устройства ввода/вывода сами по себе, как правило, медленнее 16-ти разрядных устройств ввода/вывода. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 8-ми разрядного устройства. Может принимать значения от 1 до 8 тактов.
  • 16 Bit I/O Recovery Time (время восстановления для 16-ми разрядных устройств) - Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel - порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 16-ти разрядного устройства. Может принимать значения от 1 до 4 тактов.
  • Memory Hole At 15M-16M ("дырка" в памяти внутри 15-го мегабайта памяти) - Разрешение этого параметра позволяет обращаться к устройствам ввода/вывода как к памяти и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования определенной области памяти (15-ый мегабайт), что и делает BIOS при разрешении этого параметра. Разрешать этот параметр следует в том случае, если это требуется в документации на установленную в данном компьютере плату. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Peer Concurrancy (паралельная работа) - Этот параметр разрешает или запрещает одновременную работу нескольких устройств на шине PCI. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Chipset Special Features (специальные возможности chipset) - Данный параметр разрешает/запрещает все новые функции, появившиеся в наборах HX, VX или TX по сравнению с FX. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Passive Release (пассивное разделение) - Этот параметр включает/выключает механизм паралельной работы шин ISA и PCI. Если этот параметр разрешен, то доступ процессора к шине PCI позволен во время пассивного разделения. Необходимость запрещения данного параметра может возникнуть при использовании плат ISA, активно использующих каналы DMA. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • PCI Delayed Transaction (задержанная транзакция на PCI) - Присутствие этого параметра означает, что на материнской плате есть встроенный 32-битный буфер для поддержки удлинненного цикла обмена на PCI. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-ми разрядным устройствам на шине ISA. Это существенно увеличивает производительность, так как цикл такого обращения на ISA занимает 50-60 тактов шины PCI. При установке в компьютер платы, не поддерживающей спецификации PCI 2.1, этот параметр следует запретить. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Parallel Port Mode (ECP+EPP) (режим работы параллельного порта) - параметр позволяет задать режимы работы параллельного порта в соответствии со стандартом IEEE 1284. Следует учитывать, что скорость обмена для некоторых устройств может быть существенно увеличена при правильной установке режима работы порта принтера, например, для внешних устройств хранения информации типа Iomega ZIP Drive LPT. Может принимать значения:
    • Normal - обычный интерфейс принтера, также называется SPP
    • ECP - порт с расширенными возможностями
    • EPP - расширенный принтерный порт
    • ECP + EPP- можно использовать оба режима
  • Parallel Port Mode (режим работы параллельного порта) - параметр аналогичен Parallel Port Mode (ECP+EPP), но с некоторыми расширениями. Дело в том, что существуют устройства, выполненные с отклонениями от стандарта IEEE 1284, например, некоторые платы от фирмы Xircom. Для совместимости с такими платами в некоторых BIOS существуют параметры установки версии варианта ECP+EPP порта. Какую версию выбрать - необходимо "выловить" из документации на подключаемое устройство или проверить экспериментально. Может принимать значения:
    • SPP - обычный интерфейс принтера, также называется SPP
    • ECP - порт с расширенными возможностями
    • EPP - расширенный принтерный порт
    • EPP 1.9 - версия 1.9 исполнения интерфейса
    • EPP 1.7 - версия 1.7 исполнения интерфейса
  • ECP DMA Select(выбор канала DMA для режима ECP) - параметр появляется только при разрешении режима ECP или ECP+EPP в Parallel Port Mode (ECP+EPP). Для нормальной поддержки режима ECP требуется задействовать канал DMA, который выбирается из каналов 1 или 3. Может принимать значения:
    • 1 - канал 1
    • 3 - канал 3
    • Disabled - запрещено использовать DMA
  • Onboard PCI IDE Enable (разрешение работы интегрированного контроллера IDE) - Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:
    • Primary - разрешена работа только первого канала
    • Secondary - разрешена работа только второго канала
    • Both - разрешена работа обеих каналов
    • Disable - запрещена работа обеих каналов
  • Onboard FDC Controller (разрешение работы контроллера накопителя на гибких дисках) - Этот параметр управляет разрешением/запрещением работы контроллера накопителя на гибких дисках, установленного на материнской плате. Может принимать значения:
    • Enable - контроллер разрешен
    • Disable - контроллер запрещен
  • Выбор режима работы каждого диска - Эти четыре параметра позволяют устанавливать режимы работы каждого диска индивидуально или разрешить BIOS автоматическую установку самого высокоскоростного режима для диска. Для каждого диска допустимые параметры одинаковы. Например, для IDE 0 Master Mode допустимые значения: 0, 1, 2, 3, 4 и AUTO. Параметр UDMA может иметь значение Auto или Disable.

Раздел PnP/PCI Configuration Setup

  • PNP OS Installed (установлена ли операционная система с поддержкой режима Plug&Play?) - Установить Yes, если операционная система поддерживает Plug&Play (например, Windows 95) и No в противном случае.
  • Resources Controlled By (как управляются ресурсы) - Если выбрано AUTO, то BIOS сам автоматически назначит прерывания и каналы DMA всем устройствам, подключенным к шине PCI и эти параметры не будут появляться на экране. В противном случае все эти параметры следует установить вручную. В некоторых вариантах BIOS этот параметр может устанавливаться индивидуально для каждого PCI слота и выглядеть так: Slot 1 IRQ, Slot 2 IRQ и т.д.
  • Reset Configuration Data (сброс конфигурационных данных) - Рекомендуется устанавливать его в Disabled. При установке Enabled BIOS будет очищать область Extended System Configuration Data (Расширенные данные о конфигурации системы - ESCD), в которой хранятся данные о конфигурировании BIOS`ом системы, поэтому возможны аппаратные конфликты у "брошенных" таким образом на произвол судьбы устройств.
  • IRQ n Assigned to (прерывание с номером n назначено на...) - Каждому прерыванию системы может быть назначен один из следующих типов устройств:
    • Legacy ISA (классические ISA карты) - Обычные карты для ISA, такие как модемы или звуковые карты без поддержки Plug&Play. Эти карты требуют назначения прерываний в соответствии с документацией на них.
    • PCI/ISA PnP (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play) - этот параметр устанавливается только для устройств на шине PCI или ISA карт с поддержкой Plug&Play.
  • DMA n Assigned to (канал DMA с номером n назначен на...) - Каждому каналу DMA системы может быть назначен один из следующих типов устройств:
    • Legacy ISA (классические ISA карты) - Обычные карты для ISA, такие как модемы или звуковые карты без поддержки Plug&Play. Эти карты требуют назначения каналов DMA в соответствии с документацией на них.
    • PCI/ISA PnP (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play) - этот параметр устанавливается только для устройств на шине PCI или ISA карт с поддержкой Plug&Play.
  • PCI IRQ Activated by (прерывания активизируются по ...) - Параметр может принимать значения:
    • Level (уровень) - контроллер прерываний реагирует только на уровень сигнала.
    • Edge (перепад) - контроллер прерываний реагирует только на перепад уровня сигнала.
  • PCI IDE IRQ Map to (прерывания контроллера IDE на PCI отображаются на...) - позволяет освободить прерывания, занимаемые контроллером IDE на шине PCI в случае его отсутствия (или запрещения) на материнской плате и отдать их устройствам на шине ISA. Стандартные прерывания для ISA - IRQ 14 для первого канала и IRQ 15 для второго канала. Может принимать значения
    • PCI IDE IRQ mapping (используется для PCI IDE)
    • PC AT (ISA) (используется для ISA)
  • PCI Slot IDE 2nd Channel (2-ой канал контроллера PCI IDE) - разрешает или запрещает 2-ой канал контроллера IDE. Запрещение параметра используется для освобождения прерывания, занятого 2-ым каналом в том случае, если ко второму каналу ничего не подключено.Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ n Used By ISA (прерывание n используется на шине ISA) - Параметр совпадает с IRQ n Assigned to и может принимать значения:
    • No/ICU (нет/конфигурационная утилита для ISA) - если установлено это значение, то BIOS может распоряжаться этим прерыванием по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы ISA Configuration Utility от Intel.
    • Yes (да) - означает принудительное освобождение прерывания для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им прерываний, так как в противном случае BIOS может назначить прерывание, жестко используемое какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.
  • DMA n Used By ISA (канал DMA n используется на шине ISA) - Параметр совпадает с DMA n Assigned to и может принимать значения:
    • No/ICU (нет/конфигурационная утилита для ISA) - если установлено это значение, то BIOS может распоряжаться этим каналом DMA по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы ISA Configuration Utility от Intel.
    • Yes (да) - означает принудительное освобождение канала DMA для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им каналом DMA, так как в противном случае BIOS может назначить канал, жестко используемый какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.
  • ISA MEM Block BASE (базовый адрес блока памяти для ISA) - Некоторые карты для шины ISA требуют доступа к памяти, расположенной на такой карте по определенным адресам. Поэтому и возникла необходимость в этом параметре BIOS. Может принимать значения:
    • No/ICU (нет/ICU) - оставляет управление этим параметром на усмотрение BIOS или программы ICU.
    • C800, CC00, D000, D400, D800 и DC00 - указывается адрес блока памяти. Кроме этого, появляется дополнительный параметр ISA MEM Block SIZE (размер блока памяти), который нужен в том случае, если таких ISA карт несколько и этот параметр может принимать значения 8K, 16K, 32K, 64K
  • Onboard AHA BIOS (BIOS встроенного SCSI контроллера Adaptec) - параметр разрешает/запрещает выполнение BIOS встроенного SCSI контроллера и тем самым разрешает/запрещает работу встроенного SCSI контроллера. Параметр может принимать значения:
    • AUTO (автоматически) - Разрешен поиск SCSI контроллера Adaptec и запуск BIOS для него.
    • Disabled (запрещено) - Устанавливается в это значение при отсутствии SCSI карты.
  • ONB AHA BIOS First (Запуск BIOS контроллера Adaptec первым) - параметр разрешает/запрещает запуск BIOS встроенного контроллера Adaptec до запуска любого другого SCSI контроллера. Может принимать значения:
    • Yes - разрешено
    • No - запрещено
  • ONB SCSI SE Term. (Терминаторы встроенного контроллера SCSI) - параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • ONB SCSI LVD Term. (Терминаторы встроенного контроллера SCSI LVD) - параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI LVD. Управление этим параметром позволяет увеличить длину соединительного SCSI кабеля до 25 метров. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • SYMBIOS SCSI BIOS или NCR SCSI BIOS - Разрешение на поиск SCSI контроллера на базе микросхемы NCR 810, используемого, например, в карте ASUS SC-200. Параметр может принимать значения:
    • AUTO (автоматически) - Разрешен поиск SCSI контроллера и запуск BIOS для него.
    • Disabled (запрещено) - Устанавливается в это значение при отсутствии SCSI карты.
  • PCI Latency Timer (таймер задержки на PCI) - Устанавливает максимальное время (в тактах частоты шины) в течении которого устройство на шине PCI может удерживать шину в том случае, если другое устройство требует доступа к шине. Допустимый диапазон изменения этого параметра - от 16 до 128 с шагом, кратным 8. Значение параметра следует изменять осторожно, так как оно зависит от конкретной реализации материнской платы.
  • USB IRQ (прерывание шины USB) - параметр разрешает или запрещает назначение прерывания для контроллера шины USB. Поскольку в компьютере часто не хватает прерываний, разрешать этот параметр следует только при наличии устройства на шине USB в системе. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • VGA BIOS Sequence (последовательность загрузки BIOS видеокарт) - определяет, BIOS какой видеокарты будет загружаться первым, AGP видеокарта или PCI. Устанавливать значение этого параметра имеет смысл только в случае установки в компьютере нескольких видеокарт. Может принимать значения:
    • PCI/AGP - сначала BIOS PCI видеокарты, затем AGP
    • AGP/PCI - сначала BIOS AGP видеокарты, затем PCI
  • USB Keybord Support Via (поддержка USB клавиатуры через ...) - параметр позволяет установить, на кого возлагается поддержка USB клавиатуры - на BIOS или операционную систему. Поскольку не все операционные системы поддерживают USB, рекомендуется оставлять значение BIOS. Может принимать значения:
    • OS - поддержка через операционную систему
    • BIOS - поддержка через BIOS

Раздел Power Management Setup

  • Power Management (управление энергопотреблением) - позволяет либо разрешать BIOS'у снижать энергопотребление компьютера, если за ним не работают, либо запрещать. Может принимать значения:
    • User Define (определяется пользователем) - при установке этого параметра вы можете самостоятельно установить время перехода в режим пониженного энергопотребления.
    • Min Saving (минимальное энергосбережение) - при выборе этого параметра компьютер будет переходить в режим пониженного энергопотребления через время от 40 мин. до 2 часов (зависит от конкретного BIOS материнской платы)
    • Max Saving (максимальное энергосбережение) - компьютер перейдет в режим пониженного энергопотребления через 10 - 30 с. после прекращения работы пользователя с ним.
    • Disable (запрещение энергосбережения) - запрещает режим энергосбережения.
  • ACPI function (функционирование ACPI) - разрешает или запрещает поддержку BIOS стандарта ACPI. Следует помнить, что по состоянию на конец 1998 года только Windows 98 поддерживает этот стандарт. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Video Off Option (в каком режиме выключать монитор) - позволяет устанавливать, на какой стадии "засыпания" компьютера переводить монитор в режим пониженного энергопотребления. Может принимать значения:
    • Susp, Stby -> Off (выключение в режиме Suspend И Standby) - монитор перейдет в режим пониженного энергопотребления при наступлении либо режима Suspend, либо Standby.
    • All modes -> Off (выключение во всех режимах) - монитор будет переведен в режим пониженного энергопотребления в любом режиме.
    • Always On (всегда включен) - монитор никогда не будет переведен в режим пониженного энергопотребления
    • Suspend -> Off (выключение в режиме Suspend) - монитор перейдет в режим пониженного энергопотребления при наступлении режима Suspend.
  • Video Off Method (способы выключения монитора) - устанавливается способ перехода монитора в режим пониженного энергопотребления. Может принимать значения:
    • DPMS OFF - снижение энергопотребления монитора до минимума
    • DPMS Reduce ON - монитор включен и может использоваться
    • DPMS Standby - монитор в режиме малого энергопотребления
    • DPMS Suspend - монитор в режиме сверхмалого энергопотребления
    • Blank Screen - экран пуст, но монитор потребляет полную мощность
    • V/H SYNC+Blank - снимаются сигналы разверток - монитор переходит в режим наименьшего энергопотребления.
  • Suspend Switch (переключатель режима Suspend) - параметр разрешает или запрещает переход в режим suspend (временной остановки) с помощью кнопки на системном блоке. Для этого необходимо соединить джампер SMI на материнской плате с кнопкой на лицевой панели. Как правило, для этого используется либо специальная кнопка Sleep, либо кнопка Turbo. Режим suspend является режимом максимального снижения энергопотребления компьютером. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Doze Speed (частота процессора в режиме Doze) - определяет коэффициент деления тактовой частоты в режиме Doze (засыпание).
  • Stby Speed (частота процессора в режиме Standby) - определяет коэффициент деления тактовой частоты в режиме Standby (ожидания работы).

PM Timers - в этой секции устанавливаются времена перехода в различные стадии снижения энергопотребления.

  • HDD Power Down (выключение жесткого диска) - устанавливает либо время, через которое при отсутствии обращения жесткий диск будет выключен, либо запрещает такое выключение вообще. Параметр не оказывает влияние на диски SCSI. Может принимать значения:
    • От 1 до 15 минут
    • Disabled - запрещено
  • Doze Mode (режим засыпания) - устанавливает время перехода или запрещает переход в первую стадию снижения энергопотребления. Может принимать значения:
    • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour - время перехода (Sec - секунды, Min - минуты, Hour - час)
    • Disabled - запрещено
  • Standby Mode (режим ожидания работы) - устанавливает время перехода или запрещает переход во вторую стадию снижения энергопотребления. Может принимать значения:
    • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour - время перехода (Sec - секунды, Min - минуты, Hour - час)
    • Disabled - запрещено
  • Suspend Mode (режим временной остановки) - устанавливает время перехода или запрещает переход в третью стадию снижения энергопотребления. Может принимать значения:
    • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour - время перехода (Sec - секунды, Min - минуты, Hour - час)
    • Disabled - запрещено

PM Events - в этой секции указываются те прерывания, от обращения к которым компьютер должен "просыпаться", если к устройствам, использующим эти прерывания, есть обращения.

  • IRQ 3 (Wake-up) - разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM2. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 4 (Wake-up) - разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM1. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 8 (Wake-up) - разрешение этого параметра приведет к "пробуждению" компьютера от часов реального времени. Рекомендуется оставить его запрещенным, так как некоторые программы могут использовать функцию "будильника" часов компьютера для своих целей. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 12 (Wake-up) - разрешение этого параметра приведет к "пробуждению" компьютера от мыши, подключенной к порту PS/2. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено

В следующей секции указываются те устройства, при активности которых компьютер "засыпать" не должен.

  • IRQ 3 (COM2) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 4 (COM1) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM1 устройство используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 5 (LPT2) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту LPT2 устройство (как правило, принтер) используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 6 (Floppy Disk) - при разрешении этого параметра компьютер не "засыпает", если к накопителю на гибких дисках происходит обращение. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 7 (LPT1) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту LPT2 устройство (как правило, принтер) используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 8 (RTC Alarm) - при разрешении этого параметра компьютер не "засыпает", если RTC (часы реального времени) используются как таймер. Рекомендуется оставить его запрещенным, так как некоторые программы могут использовать функцию "будильника" часов компьютера для своих целей. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 9 (IRQ2 Redir) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 10 (Reserved) - при разрешении этого параметра компьютер не "засыпает", если устройство, занимающее 10 прерывание, используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 11 (Reserved) - при разрешении этого параметра компьютер не "засыпает", если устройство, занимающее 11 прерывание, используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 12 (PS/2 Mouse) - при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 13 (Coprocessor) - при разрешении этого параметра компьютер не "засыпает", если сопроцессор используется. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 14 (Hard Disk) - при разрешении этого параметра компьютер не "засыпает", если к жесткому диску на первом канале IDE есть обращения. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ 15 (Reserved) - при разрешении этого параметра компьютер не "засыпает", если к жесткому диску или CD-ROM на втором канале IDE есть обращения. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено

Power Up Control - параметры в этой секции определяют виды управления источником питания и применяются для источников питания в стандарте ATX и материнских плат, допускающих подключение к такому источнику.

  • PWR Button < 4 Secs (он же Soft-of By PWR-BTTN) (кнопка питания нажата менее 4 секунд) - управляет функциями кнопки Power на системном блоке компьютера. Может принимать значения:
    • Soft Off (программное выключение) - кнопка работает как обычная кнопка включения/выключения питания компьютера, но при этом разрешается программное выключение компьютера (например, при выходе из Windows 95).
    • Suspend (временная остановка) - при нажатии на кнопку питания на время менее 4 секунд компьютер переходит в стадию Suspend снижения энергопотребления.
    • No Function (нет функций) - кнопка Power становится обычной кнопкой включения/выключения питания.
  • PWR Up On Modem Act (он же Resume by Ring) (включение питания при звонке на модем) - разрешение этого параметра поволяет включить компьютер при звонке на модем. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • IRQ8 Resume by Suspend (пробуждение по IRQ8) - разрешение этого параметра позволяет "разбудить" компьютер, соответствующим образом запрограммировав Alarm Time (время тревоги) в Real Time Clock (RTC - часы реального времени), так как сигнал от RTC заведен на IRQ8. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • ZZ Active In Suspend (активность сигнала ZZ в режиме Suspend) - контроллер на материнской плате имеет сигнал ZZ, эмулирующий в режиме Suspend (временной остановки) тактовую частоту 8.32 MHz. Как правило, в большинстве материнских плат этот сигнал не используется, но если в SETUP он есть, то следует придерживаться рекомендаций по его установке от производителя материнской платы. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Wake On LAN (Пробуждение от сети) - при разрешении этого параметра компьютер включается по сигналу от локальной сети. Такое включение возможно только при установке в компьютер сетевой карты, поддерживающей этот режим. Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • AC PWR Loss Restart (включить компьютер после пропадания питания) - разрешение этого параметра позволяет включить компьютер после пропадания питания. В противном случае после восстановления питания компьютер не включится и необходимо будет снова нажать кнопку подачи питания (Power). Может принимать значения:
    • Enabled - разрешено
    • Disabled - запрещено
  • Automatic Power Up (автоматическое включение) - используя этот параметр, можно включать компьютер ежедневно в указанное время или включить его в указанный день и час. Может принимать значения:
    • Everday (ежедневно) - при вводе времени компьютер будет включаться ежедневно в назначенное время. Время вводится в поле Time (hh:mm:ss) Alarm в порядке часы:минуты:секунды либо клавишами PgUp, PgDn, либо непосредственным вводом чисел.
    • By Date (по дате) - компьютер включится в заданный день и в заданное время. При выборе этого параметра появляется поле для ввода времени (такое же, как и для Everyday) и поле для ввода дня месяца Date of Month Alarm - день месяца - в этом поле вводится число в месяце. Это автоматически означает, что запрограммировать включение компьютера можно только внутри одного месяца.
    • Disabled - запрещено

В следующих секциях BIOS только сообщает характеристики некоторых устройств компьютера. Разрешение параметров в этих секциях позволяет отслеживать BIOS'у эти параметры и сообщать об их выходе за пределы допустимого.

Секция Fan Monitor (наблюдение за вентиляторами)

  • Chassis Fan Speed (xxxxRPM) (наблюдение за скоростью вращения дополнительного вентилятора в корпусе компьютера) - если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.
  • CPU Fan Speed (xxxxRPM) (наблюдение за скоростью вращения вентилятора охлаждения процессора) - если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.
  • Power Fan Speed (xxxxRPM) (наблюдение за скоростью вращения вентилятора блока питания) - если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы. Использование этого параметра возможно при наличии соответствующего блока питания.

Секция Thermal Monitor (наблюдение за температурой) - параметры изменению не подлежат.

  • CPU Temperature (температура процессора) - показывает темпераратуру процессора в градусах Цельсия и Фаренгейта. При выборе Ignore температура отслеживаться не будет. В противном случае, при критическом повышении температуры, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.
  • MB Temperature (температура материнской платы) - показывает темпераратуру процессора в градусах Цельсия и Фаренгейта. При выборе Ignore температура отслеживаться не будет. В противном случае, при критическом повышении температуры, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

Секция Voltage Monitor (наблюдение за напряжениями питания). В этой секции индицируются как напряжения питания, подаваемые на материнскую плату источником питания, так и вырабатываемые на материнской плате. Разъяснения эти параметры не требуют, кроме VCORE - это напряжение питания ядра процессора. Это напряжение вырабатывается, как правило, на материнской плате.

Сергей Блохнин(spline@glas.apc.org), компания Сплайн

Электронная библиотека InfoCity
Автор и координатор проекта:Михаил Пинкус
У Вас есть документация, которой нет в нашей библиотеке? Присылайте.


- BIOS.RU - FAQ

Добро пожаловать на первый и единственный сайт полностью посвященный BIOS
Главная [image] Новости [image] Матплаты [image] Видеокарты [image] Модемы [image] CDD [image] Программы [image] Документация [image] Конференция
BIOS FAQ

Как определить, что установленный на материнской плате BIOS, прошит во Flash ROM?

Определить тип микросхемы ПЗУ, установленнолй на материнской плате, несложно. Сразу следует сказать, что практически все материнские платы после 1997 года поставляются с Flash ROM, но если Вы не уверенны лучше проверить - для этого необходимо посмотреть на маркировку чипа ROM (28 или 32-контактная микросхема с наклейкой производителя BIOS), отодрав наклейку. Маркировка означает следующее (ххх означает три произвольных цифры):

  • 28Fxxx - 12V Flash память
  • 29Cxxx - 5V Flash память
  • 29LVxxx - 3V Flash memory (раритет)
  • 28Cxxx - EEPROM, почти то же, что и Flash память
  • 27Cxxx - с окошком. EPROM (уже не устанавливается с 1997 года): только для чтения, требует программатор для записи и ультрафиолетовую лампу для стирания
  • PH29EE010: SST ROM Чип - перепрошиваемый
  • 29EE011: Winbond чип - 5V Flash память
  • 29C010: Atmel Chip - 5V Flash память

Любые другие микросхемы, не имеющие окошка с маркировкой, не начинающейся с цифр 28 или 29, являются, скорее всего не Flash-памятью. Если же на микросхеме есть окошко - это верный признак того, что это не Flash.

Зачем необходима перепрошивка новых версий BIOS?

Существует несколько причин, по которым это приходится делать. Основная из них - Windows 95 не всегда хорошо конфигурируется, если используются старые версии BIOS.

В настоящее время используются жесткие диски объемом более 528Мбайт. Для работы такого диска в системе необходимо поддержка LBA со стороны BIOS. Если BIOS не поддерживает LBA, то для работы с большими жесткими дисками приходится применять специальные утилиты. Применение таких утилит вызовет работу Windows 95 в compatible mode, что отрицательно сказывается на быстродействии.

Полная поддержка Plug-and-Play со стороны Windows 95 возможна только в случае применения PnP BIOS. Это очень веская причина для перепрошивки BIOS.

Кроме вышеуказанного, в новых версиях BIOS исправляются мелкие ошибки и недоработки. Новые версии могут содержать новые возможности, как то загрузка с CD ROM, SCSI перед IDE и т.п.

Где можно скачать новые версии BIOS?

Обычно производители материнских плат предлагают BIOSы для своих изделий. Так что, если знать производителя и название материнской платы, проблем не возникнет.

В принципе, название материнской платы можно и не знать. Обычно допускается прошивка BIOS от других плат, если на них установлен такой же чипсет и контроллер ввода-вывода. Однако такой возможностью следует пользоваться только в случае крайней необходимости, так как возможны другие несоответствия, например в количестве слотов и т.п., а прошивка неправильного BIOS может привести к тому, что материнскую плату придется выкидывать.

Что делать, если производителя и название материнской платы определить не удается?

Чаще всего, производителя и название материнской платы можно определить по идентификационной строке, которую выдает BIOS сразу при включении компьютера.

Для AMI BIOS эта строка имеет вид, похожий на
51-0102-1101-00111111-101094-AMIS123-P или 40-01S5-ZZ1124-10101111-060691-OPWBSX-F,
где производитель определяется третьей группой цифр. Далее необходимо найти свой идентификационный номер втаблице соответствия номеров и названий производителей. Определить название материнской платы можно по всей идентификациолнной строке, пользуясь тем же документом.

Идентификационная строка Award BIOS имеет вид
2A59CQ1CC
и позволяет определить чипсет (первые пять цифр и букв - 2A59C), производителя материнской платы (следующие два символа - Q1) и модель материнской платы (оставшаяся часть строки - CC). Далее необходимо посмотреть обозначения чипсетов, производителей и моделей в идентификационных строках.

Как перепрошить Flash BIOS?

Для выполнения этой операции необходимо иметь програму-прошивальщик и файл с BIOS. Программы для перепрошивки обычно поставляются с материнскими платами, в крайнем случае их можно скачать у производителей материнских плат.

Далее, загрузившись под чистым DOS (без драйверов - нажав F8 и выбрав Safe Mode Command Prompt only), запустить программу прошивки:

  • awdflash xxx.bin (для Award BIOS)
  • amiflash xxx.bin (для AMI BIOS)
  • mrflash xxx.bin (для MRBIOS)
Замечания:
  • Большинство программ прошивки при запуске спрашивают, сохранить ли текущую версию BIOS. На этот вопрос рекомендуется ответить положительно, так как новый BIOS может работать не так как хотелось бы.
  • Некоторые производители материнских плат могут предлагать свои собственные программы- прошивальщики. В таком случае лучше пользоваться ими.
  • Перед прошивкой новой версии BIOS выключите опцию System BIOS Cacheable в Setup.
  • Если в Вашей системе процессор разогнан, то на время перепрошивки BIOS поставьте его на штатную частоту.

Почему прошивальщик Award BIOS выдает сообщение "Insufficient memory"?

  1. В Setup в разделе Chipset Features Setup, отключите Video Bios Cacheable.
  2. Выйдете из Setup.
  3. Перезагрузитесь под чистым DOS (нажав F8 и выбрав Safe Mode Command Prompt only)
  4. Перепрошейте BIOS и перезагрузитесь
  5. Войдите в Setup и установите опцию Video Bios Cacheable в Enable.

Что будет, если запортить BIOS или прошить неправильную версию?

Скорее всего, компьютер не будет грузиться, даже не подавая признаков жизни.

Как восстановить поврежденный BIOS?

Метод 1 (универсальный):

  1. Беpем любую pаботающую мать, поддеpживающую флэш (главное, чтоб она была на том же чипсете , на котоpый pассчитан BIOS, котоpый мы хотим записать. Можно попробовать прописать и на другом чипсете, но здесь Вы сильно рискуете). Нужно пpосто найти флэш или ПЗУ от матеpи, аналогичной той, флэш из котоpой мы будем пеpеписывать, и вpеменно поставить его (пеpеставив, если нужно, джампеpа типа флэша), (если есть пpогpамматоp, который поддерживает Ваш флэш - лучше и проще записать через него).
  2. Вынимаем флэш или ПЗУ из этой матеpи, обвязываем его с двух концов двумя кольцами нитки (чтоб можно было его легко извлечь) и неплотно втыкаем назад в панельку.
  3. Загpужаемся в "голый" ДОС, выдеpгиваем за эти два кольца стоящий в матеpи флэш или ПЗУ (все pавно он нужен только пpи загpузке), если нужно, пеpеставляем джампеpа типа флэша, и вставляем флэш, котоpый нужно записать. Главное тут - ничего не замкнуть :)
  4. Запускаем пpогpамму записи, pассчитанную на мать, на котоpой пишем, BIOS с котоpым гpузились и флэш, котоpый нужно записать (пpогpамма должна уметь пеpеписывать флэш целиком, напpимеp, из комплекта mr-bios или asusовский pflash). Пишем, выключаем питание и вынимаем готовый флэш. Все.

Метод 2 (для Award BIOS):

  1. Извлечь PCI-видеокарту (все нижеописанное не будет работать с PCI-видео, так как для инициализации PCI необходим BIOS, хотя судя по отзывам на некоторых платах, в частности на Gigabyte 6va7 получалась загрузка при поврежденном BIOS через PCI и AGP видео карты, но это частные случаи... )
  2. Установить старую ISA-видеокарту и подключить монитор
  3. Вставить загрузочную дискету в дисковод А:
  4. Включить компьютер
  5. Компьютер заработает благодаря Award Boot Block (Может не получиться, зависит от повреждения BIOS.)
  6. Вставить предварительно созданную дискету с прошивальщиком и правильным BIOS
  7. Перепрошить BIOS
  8. Перезагрузиться
  9. Выключить компьютер и поменять видеокарту обратно. Все - теперь можно работать

Метод 3 (для интеловских матерей):

  1. Установить Flash Recovery jumper в положение recovery mode (к сожалению, такую возможность имеют не все платы)
  2. Вставить загрузочную bootable upgrade дискету, которой комплектуется каждая интеловская плата, в дисковод A:
  3. Перезагрузиться
  4. Во время этой процедуры экран будет оставаться темным, так как в непрошиваемой boot block area не содержатся функции работы с видео. Эта процедура может контролироваться только пищанием спикера и миганием лампочки дисковода. Когда компьютер пискнеть и лампочка дисковода загорится, можно считать, что система копирует необходимые данные во Flash ROM. Как только лампочка дисковода погаснет, прошивка закончится.
  5. Выключить компьютер
  6. Вернуть Flash Recovery jumper обратно в положение по умолчанию
  7. Вынуть дискету из дисковода и включить компьютер

Что такое PROM, EPROM и ЕEPROM и чем они отличаются?

PROM (programmable read-only memory - программируемая память только для чтения) - это чип памяти, данные в который могут быть записаны только однажды. То что записано в PROM, не вырубишь топором :) (хранится в нем всегда). В отличии от основной памяти, PROM содержит данные даже когда компьютер выключен.

Отличие PROM от ROM (read-only memory - память только для чтения) в том, что PROM изначально производятся чистыми, в тот время как в ROM данные заносятся в процессе производства. А для записи данных в чипы PROM, применяются специальные устройства, называемые программаторами.

EPROM (erasable programmable read-only memory - стираемая программируемая память только для чтения) - специальный тип PROM, который может очищаться с использованием ультрафиолетовых лучей. После стирания, EPROM может быть перепрограммирована. EEPROM - по сути похожа на PROM, но для стирания требует электрических сигналов.

EEPROM (electrically erasable programmable read-only memory - электрически стираемая программируемая память только для чтения) - специальный тип PROM, который может быть очищен электрическим разрядом. Подобно другим типам PROM, EEPROM содержит данные и при выключенном питании компьютера. Аналогично всем другим типам ROM, EEPROM работает не выстрее RAM.

Специальный тип EEPROM, называемый Flash memory или Flash EEPROM, может быть перезаписан без применения дополнительных устройств типа программатора, находясь в компьютере.

Как сбросить установки BIOS (включая пароль) в значения по умолчанию из DOS?

Так как не все материнские платы оборудованы джампером для сброса установок BIOS или этот джампер может быть недоступен, то существует метод очистки BIOS из DOS, при помощи команды debug. Загрузившись в DOS (не в DOS-box под Windows!) необходимо набрать:

Метод 1 (Award и AMI BIOS):

DEBUG
-O 70 17
-O 71 17
Q

Метод 2 (Phoenix BIOS):

DEBUG
-O 70 FF
-O 71 17
Q

Как подобрать (снять) пароль на Setup (загрузку)?

Если забыт паpоль на Setup, можно воспользоваться pазличными пpогpаммами для снятия паpоля или одним из заводских паролей.

Заводские пассворды для AWARD BIOS следующие:
AWARD_SW, TTPTHA, aPAf, HLT, lkwpeter, KDD, j262, ZBAAACA, j322, ZAAADA, Syxz, %шесть пpобелов%, Wodj, %девять пpобелов%, ZJAAADC, 01322222, j256, ?award
Один из этих паролей должен подойти. Однако в новых AWARD BIOS (версии 4.51) инженерные пароли отсутствуют. Однако существует программка для снятия/определения установленных паролей в таких BIOS.

Для AMI BIOS стандартных паролей нету. Единственный случай: если вы только приобрели материнскую плату то пароль может быть AMI.

Существуют программы для определения установленного на Setup пароля. Вы можете скачать здесь эти утилиты для Award BIOS и AMI BIOS.

Hа некотоpых AMI BIOS можно сpазу после включения деpжать нажатой клавишу Ins - пpи этом в CMOS-память загpужаются стандаpтные паpаметpы.

Как аппаратно сборосить CMOS (вместе с паролями)?

Почти на всех совpеменных системных платах pядом с батаpейкой есть пеpемычка для сбpоса CMOS-памяти (обычно - 4 контакта, ноpмальное положение - 2-3, сбpос - 1-2 или 3-4; иногда - 3 или 2 контакта).

Выпаивать и тем более замыкать батаpейку не имеет смысла - это чаще всего не пpиводит к успеху из-за констpукции схемы питания CMOS-памяти, а замыкание батаpейки сильно сокpащает сpок ее службы.

Если на плате нет батаpейки, нужно поискать пластмассовый модуль с надписью "DALLAS" (это монолитный блок с батаpейкой и микpосхемой CMOS) - пеpемычка может быть возле него.

В случае, если перемычка для очистки CMOS-памяти отсутствует, то сначала попробуйте отключить или отсоединить батарейку. При этом также рекомендуется отключить провода от блоки питания, так как заряд на его конденсаторах может сохраняться и успешно поддерживать питание CMOS RAM (ей очень мало надо) более суток.

Главная [image] Новости [image] Матплаты [image] Видеокарты [image] Модемы [image] CDD [image] Программы [image] Документация [image] Конференция
List Banner Exchange.
Статистика

Каталог "ПИНГВИН" - чуткий и душевный каталог!
be number one


AOpen BIOS'es

.

Добро пожаловать в AOpen!

Сервис:

Руководство по установке

*** ПРОЧТИТЕ ПЕРЕД ОБНОВЛЕНИЕМ BIOS ***

| Материнские платы | Серверные платы |

Обновления BIOS
  • Серверные платы
  • Socket 478 (Pentium 4)
  • Socket 423 (Pentium 4)
  • Socket 370 (Pentium !!! & Celeron)
  • Socket A (AMD Athlon & Thunderbird & Duron K7)
  • Slot 1 (Pentiun II/!!! & Celeron)
  • SlotA (AMD Athlon K7)
  • Socket 7 (Pentium, AMD K6-2 and K6-III)
Серверные платы
VIA 694X Dual Socket 370
  • | DX34 Plus | DX34 |
VIA 694T Dual Socket 370
  • | DX34 Plus-U | DX34-U |
VIA 694T Single Socket 370
  • | Fortress 1100 |
VIA Pro266T Dual Socket 370
  • | DX37 Plus-U | DX37-U |
ServerWorks Server Set III LE Dual Socket 370
  • | DX3R Plus | DX3R-1U |
Socket 478 (Pentium 4)
INTEL 845
  • | AX4BS | AX4BS Pro | AX4BS-V | MX4BS |
INTEL 850
  • | AX4T II |
SiS 645/650
  • | AX45 | MX46 |
Socket 423 (Pentium 4)
INTEL 850
  • | AX4T |
Socket 370 (Pentium !!! & Celeron)
VIA Apollo Pro 266
  • | AX37 Pro / AX37 Plus |
VIA Apollo Pro 133 Plus
  • | MX34 | AX34 | AX34 Pro | AX34 II / AX34 Pro II | AX34-U | MX34-U |
VIA Apollo Pro 133
  • | AX33 | MX33 |
VIA PM 133
  • | MX36 |
VIA PLE 133
  • | MX36LE |
INTEL 815 EP
  • | AX3SP/AX3SP Pro | AX3SP-U | AX3SP Pro-U | MX3SP-U |
INTEL 815
  • | AX3S; AX3S Pro | MX3S | AX3S Pro II/AX3S Plus | AX3S-U | AX3S Pro-U | MX3S-U |
    | MX3S-T | AX3S Max |
INTEL 810
  • | MX3W Pro/MX3W Pro-E/MX3W Pro-V | MX3W/MX3W-L | MX3W-E2/MX3W-E2L/MX3W-V2 |
INTEL 440ZX
  • | MX3ZA | MX3ZA(128) |
INTEL 440LX
  • | AX3L | MX3L |
Socket A (AMD Athlon & Thunderbird & Duron K7)
VIA KT133
  • | AK73/AK73(A)/AK73/Pro/AK73-1394/AK73 Pro(A)/AK73-1394(A) | AK73-V | AK73(A)-V |
    | AK33 | MK33 |
VIA KLE133
  • | MK73LE |
VIA Apollo KT266/KT266A
  • | AK77 Pro / AK77 Pro(A) | AK77 Plus / AK77 Plus(A) |
AMD 761
  • | MK7A |
Slot 1 (Pentium II/!!! & Celeron)
Pentium II/!!!
INTEL 820
  • | AX6C, AX6C-L |
INTEL 440BX
  • | AX6B Plus | AX6B | AX6BC | AX6BC Pro; AX6BC Pro Gold | MX6B |
    | AX6BC Pro II; Millennium Ed. |
INTEL 440ZX
  • | AX6BC EZ | MX6B EZ |
VIA Apollo Pro Plus/Apollo Pro 133
  • | AX63 | AX63 Pro |
VIA Apollo Pro 133 Plus
  • | MX64 | AX64 | AX64 Pro |
Pentium II
INTEL 440BX
  • | NX6B |
INTEL 440LX
  • | AX6L | AX6LC |
INTEL 440EX
  • | MX6E Plus | AX6LC Lite |
INTEL 440FX
  • | AX6F |
Slot A (AMD Athlon K7)
VIA KX133
  • | AK72 |
Socket 7 (Pentium, AMD K6-2 and K6-III)
Pentium Pro
  • | AP65 | AX65 | AP61 |
Pentium
VIA
  • | MX59 Pro; MX59 Pro II | AX59 Pro |
SiS
  • | AP59S | MX58 Plus | AP58 | AP57 | AP5S | AP55CS* | AP5CS |
INTEL 430TX
  • | AX5TC | AX5T | AP5TC | AP5T |
INTEL 430HX
  • | AP5K | AP53 & AX53* |
INTEL 430VX
  • | AP5VM* | AP5V* |
INTEL 430FX
  • | AP5C & AP5C/P* | LP5* |
INTEL 430GX
  • | DP5 |

| Домой | Об AOpen | Продукты | Сервис | Где купить |

Copyright 2001, AOpen Inc., All rights reserved.


Соединение двух компьютеров по телефонной линии

Словоблудие.

На одном форуме был задан вопрос: как соединить два компьютера по телефонной линии? Тема такого соединения стара как мир, но у многих появился ряд вопросов. Черт меня дернул ответить одному пользователю, и понеслись на мой почтовый ящик сообщения о новых вопросах. Многие пользователи стали задавать вопросы, используя электронную почту, как говорится, на прямую. Надоело мне отвечать одно и то же, к тому же я стал путатся в ответах. Поэтому, я и пишу эту статью.

Эта статья написана по материалам сатьи Александра Поляк-Брагинского "Компьютер-Телефон-Компьютер", опубликованной в журнале "Мир ПК" №2 за 2001 год. Много пришлось повозиться, чтобы настроить первое соединение, поэтому, здесь постараюсь изложить все тонкости соединения двух ПК.

Хочу сразу отметить, что здесь будет рассматриваться система Windows 98 или МЕ. Дело в том, что из моих друзей не каждый может перейти на Windows XP и не каждый может работать в Windows 2000. У меня установлены две системы Windows 98 и Windows 2000 из соображений, что Windows 98 стоит у всех моих друзей и знакомых, кто заитересован в обмене информацией между ПК. Нет ничего проще на случай обмена перезагрузить компьютер в Windows 98 и скачать/загрузить нужные файлы.

Пару слов как установить две системы на разные разделы, например Windows 98 и Windows 2000 (для Windows XP порядок установки тот же). Сначала нужно установить Windows 98, об этом подробно написано здесь и загрузиться с нее. Загрузившись с Windows 98 и настроив ее, нужно запустить установку Windows 2000. После нескольких шагов будет предложение перезагрузиться, нужно выбрать перезагрузку для того, чтобы перейти в текстовый режим установки. Когда система будет установлена, появится загрузочное меню с выбором системы и установленным временем ожидания 30 секунд. Это время можно изменить в файле boot.ini в разделе [boot loader] параметр timeout=30. У меня лично установлен параметр timeout=5, т.е. 5 секунд, по истечении которых загрузится Windows 2000. Если нужно загрузиться в Windows 98, то при помощи стрелок на клавиатуре выберается пункт Windows 98, при этом время ожидания остановится, и нажимается ENTER.

Если в вашем городе нет повременной оплаты за телефонные услуги, то этот справочник для вас. Даже если есть повременка, то с помощью этого соединения можно (если очень нужно) обменяться большими файлами, что не каждый может сделать почтовый сервер. Конечно, можно разбить файл на части и каждую часть отправлять, но если вы находитесь в одном населенном пункте, то можно воспользоваться этим способом, т.е. Компьютер – Телефон – Компьютер. Тем более это соединение будет в реальном времени и можно будет использовать для общения чат в то время, пока копируются файлы с одного компьютера на другой. Можно использовать программу qChat, которую можно скачать с ее домашней страницы http://avipage.hypermart.net/.

При должной настройке, на все соединение уходит 1-2 минуты... В общем, следуйте моим указаниям, и, шаг за шагом, вы установите связь двух компьютеров. Итак, начнем.


Соединение двух компьютеров по телефонной линии

Протоколы и службы.

Еще оговорка. Лучше всего иметь какой-нибудь файловый менеджер, имеющий встроенный FTP клиент (о настройке FTP речь пойдет несколько позже). Например, Total Commander (русификатор можно скачать с сайта Clubrus) или другой, но именно в Total Commander можно очень легко сделать нужные настройки (какие именно читайте здесь или спросите на форуме). Иначе, вам придется прыгать от окна к окну. Сейчас вы в этом убедитесь, попробую объяснить на примере Total Commander (TC) и Проводника Windows (Windows Explorer (WE)).

Для установки соединения необходимо иметь модем на соединяемых компьютерах. Все, что будет здесь сказано, нужно проделать на обеих машинах.

Запустите ТС, если он у вас есть, и не закрывайте его до перезагрузки компьютера. Если нет такого файлового менеджера, тогда Пуск - Настройка - Панель управления - Сеть и смотрим рис. 1. В ТС апплет Сеть можно открыть из меню Системные папки - Панель Управления - Сеть.

Рис.1.

Перейдите на вкладку Конфигурация. В окне должно быть ПЯТЬ пунктов. Как правило, при установке операционной системы по умолчанию протокол NetBEUI и «Служба доступа к файлам и принтерам сетей Microsoft» не устанавливается, но это легко исправить. Если нет протокола NetBEUI, то нажмите кнопку Добавить, появится окно Выбор типа компонента (рис. 2).

Рис. 2.

Отметьте пункт Протокол и нажмите кнопку Добавить, в появившемся окне (рис. 3) отметьте пункт NetBEUI и нажмите ОК.

Рис.3.

Затем в окне Выбор типа компонента (рис.2) отметьте пункт Служба и нажмите Добавить. Появится еще окно (рис.4), в нем отметьте Служба доступа к файлам и принтерам сетей Microsoft и нажмите ОК.

Рис.4.

Перейдите на вкладку Идентификация. На этой вкладке посмотрите Имя компьютера и сообщите это имя тому, с кем Вы собираетесь подключиться, а также узнайте Имя его компьютера. На вкладке Управление доступом проверьте переключатель, точка которого должна стоять на пункте На уровне ресурсов. Теперь можно нажать кнопку ОК. Компьютер попросится на перезагрузку, отмените эту операцию и перейдите к шагу 2.


Соединение двух компьютеров по телефонной линии

Установка сервера.

В Панели управления дважды щелкните по ярлыку Установка и удаление программ и перейдите на вкладку Установка Windows (рис.1.). Отметьте в окне пункт Связь.

Рис. 1.

Нажмите кнопку Состав (рис.2). В появившемся окне Связь установите галки в пунктах Сервер удаленного доступа, Телефон, Удаленный доступ к сети (рис.2), нажмите ОК и еще раз ОК. Теперь перезагружайте компьютер. После перезагрузки переходите к шагу 3.


Соединение двух компьютеров по телефонной линии

Установка нового соединения.

Щелкните дважды по значку Мой компьютер, затем дважды по папке Удаленный доступ к сети. Дважды щелкните по значку Новое соединение. Появится мастер нового соединения (рис.1.), в котором назовите соединение и нажмите кнопку Далее.

Рис. 1.

На следующей странице введите код города, в котором находится удаленный компьютер (если Вы находитесь в одном населенном пункте, укажите свой код населенного пункта) и телефон удаленного компьютера, с которым Вы должны соединиться. Нажмите кнопку Далее. Будет создано новое соединение (рис.2), нажмите кнопку Готово.

Рис. 2.

Вернитесь в папку Мой компьютер, правой кнопкой мыши вызовите контекстное меню папки Удаленный доступ к сети, в котором выберите пункт Создать ярлык. Ярлык будет создан на рабочем столе. Снова войдите в папку Удаленный доступ к сети.

В папке Удаленный доступ к сети» появится созданное Вами соединение. Правой кнопкой мыши вызовите контекстное меню Вашего соединения, в котором выберите пункт Создать ярлык. Ярлык будет создан на рабочем столе.

Если вы используете Total Commander, то на диске в другой панели создайте папку, например Connect, и откройте ее. С помощью меню Системные папки выберите пункт Рабочий стол, найдите ярлыки «Удаленный доступ к сети» и Вашего соединения, переместите эти ярлыки в папку Connect.

Если Вы используете Панель инструментов в Total Commander, то мышью перетащите эти ярлыки на нее, создав тем самым кнопки. Поехали далее.


Соединение двух компьютеров по телефонной линии

Свойства соединения.

Дважды щелкните по созданному Вами соединению в папке Connect или вызовите окно этого соединения при помощи кнопки, если Вы создали на Панели инструментов в Total Commander, появится окно соединения (рис.1.), в котором все можно оставить по умолчанию, но по моему опыту бывает так, что нужно указать Имя удаленного компьютера. А если удаленный компьютер не требует пароль, то в поле Пароль ничего вводить не нужно.

Рис. 1.


Untitled

Соединение двух компьютеров по телефонной линии-1

Соединение двух компьютеров по телефонной линии-2

Соединение двух компьютеров по телефонной линии-3

Соединение двух компьютеров по телефонной линии-4

Соединение двух компьютеров по телефонной линии-5


IZONE

Открылась Компьютерная Ярмарка Expo-com.ru на Тульской
6000 кв.м, 20 000 покупателей в день.
Удачное расположение (м. "Тульская"), большой ассортимент, автостоянка, лифты, кафе, туалеты, телефонная связь, интернет.
Арендаторам: 1 месяц бесплатно
Режим работы и проезд см. здесь >>
реклама у нас
***

Win9x/ME FAQ

Ответы, комментарии, рекомендации, советы.

У меня дома 3 компьютера в сети - на 2-х установлена операционная система Windows 2000, а на одном Windows 9x. Так вот именно с этого компьютера не виден сетевой принтер. Никакие перестановки драйверов не помогли, что делать?
Решение здесь очень простое - Windows 9x не видят сетевой принтер, если его имя больше 12 символов и/или содержит пробелы. Достаточно просто переименовать ваш сетевой принтер и все будет нормально.

В связи с удешевлением памяти решил увеличить ее объем в своем компьютере до гигабайта. У меня установлена операционная система Windows 95/98/98SE/Me. Но почему-то после установки дополнительной памяти система отказалась загружаться, сообщив мне, что у нее не хватает (!) памяти. Что делать?
Эта ошибка признана Microsoft, о чем она любезно сообщила в ответе Q253912 своей Базы знаний. Для исправления ситуации возможно использовать три метода:

  • Установить значение размера файлового кэша системы менее 512 MBytes, добавив строку MaxFileCache=128000 (где 128000 - ограничение в 128 MBytes, например) в секции [VCache] файла system.ini. Именно этот способ наиболее правильный - позволяет использовать всю память.

  • Утилитой msconfig установить значение параметра Limit Memory to <x> MB менее 512 MBytes. Понятно, что объем установленной памяти выше указанного значения использоваться системой не будет.

  • Изъять память выше 512 MBytes (не правда, ли достойное решение предлагается фирмой-разработчиком операционной системы)

После подключения USB клавиатуры у меня всегда включается Caps Lock после загрузки Windows 98. Мелочь, но о ней все время забываешь. При подключении обычной клавиатуры все нормально. Как избавиться от этой проблемы?
Этот эффект есть на любой не английской версии Windows 98. Для ликвидации его следует удалить вызов команды keyb из файла autoexec.bat.

После установки ряда программ заметно замедлилась работа компьютера. Я удалил все из папки Автозагрузка (StartUp), но, тем не менее, часть программ (панель управления видеокартой, например) все равно загружаются при старте системы. Как убрать загрузку ненужных программ?
Для удаления ненужных программ следует запустить редактор реестра и в
HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion \Run как раз и можно удалить ненужные для постоянного запуска программы. Следует только четко понимать, что именно может быть безболезненно удалено. В примере ниже можно удалить программу EM_EXEC (панель управления мышью Logitech) и V66SHELL (панель быстрого управления видеокартой от ASUS).

После установки двух дополнительных плат (SCSI контроллера и TV-тюнера) в системе возник конфликт прерываний, который я не могу разрешить - они распределяются BIOS и система их не меняет. Что можно сделать?
В этом случае, скорее всего, Windows 98 лишена возможности (это бывает достаточно часто) распределять прерывания, поэтому следует разрешить операционной системе управление прерываниями следующим образом:

  1. Выбрать иконку Система в Панели управления

  2. Выбрать "Устройства по подключению" (View Devices by type)

  3. Выбрать "Шина PCI" (PCI Bus)

  4. Выбрать закладку "Управление IRQ" (IRQ Steering)

  5. Выбрать параметр "Использовать управление IRQ" (Use IRQ Steering)

  6. После выбора OK следует согласиться с требованием системы на перезагрузку и выключить питание или нажать Reset (так как нормальной перезагрузки не будет).

Как это должно выглядеть, ясно из рисунка:

irq_steering.jpg (31892 bytes)

После замены материнской платы я не могу заставить Windows 98SE выключить питание компьютера, что очень неудобно. Как устранить этот дефект?
У этой проблемы есть два варианта решения:

  • Установить patch от Microsoft, устраняющий этот дефект на большинстве "проблемных" (в этом смысле) компьютеров. Microsoft при этом также предупреждает, что абсолютной гарантии дать не может.

  • Менее трудоемкий способ: запустить под Windows 98 программу msconfig.exe (она входит в комплект W98) и далее в панели Дополнительно (Advanced) поставить галку у параметра Запретить быстрое завершение работы (Disable Fast Shutdown).

Я приобрел себе новый IDE жесткий диск емкостью 36 GBytes. У меня установлена Windows 95 OSR 2.5, но я никакими усилиями не смог заставить систему нормально работать с новым жестким диском. Что делать для исправления этой ситуации?
К сожалению, сделать ничего нельзя. Согласно официальному заявлению Microsoft, Windows 95 в любых своих вариантах не может поддерживать IDE жесткие диски объемом более 32 GBytes. Поэтому единственный способ решения проблемы - установка Windows 98.

Как включить режим ACPI в Windows 98? BIOS моей материнской платы этот режим поддерживает, но, насколько я понимаю, по умолчанию он выключен.
Установить поддержку ACPI можно двумя способами:

  1. Запустить установку Windows 98 так:
    setup /p j

  2. Корректировкой реестра (дистрибутив Windows 98 должен быть на жестком диске) следующим образом:

    1. В раздел реестра HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\Current Version\Detect ввести параметр ACPIOption (как переменную типа DWORD) и присвоить ему значение 1.

    2. Выйти из редактора реестра.

    3. Войти в Установку оборудования Панели управления выбрать автоматический поиск Windows новых устройств, дойдя до автоматического поиска не PnP устройств.

    4. Перезагрузить Windows. Windows добавит все ACPI устройства в систему и режим ACPI будет работать (при условии, что вся начинка компьютера этот режим поддерживает).

У меня компьютер с операционной системой Windows 98. Все работало без каких-либо проблем до тех пор, пока я не поменял процессор на Pentium III 450. После замены у меня виснет любая игра с поддержкой DirectX 3D. Возвращаю старый процессор - все нормально. В чем проблема и как ее исправить?
Проблема в некорректном драйвере VMCPD.VXD, который входит в комплект DirectX 6.1 и устанавливается обычно любой современной видео или аудио картой. Этот драйвер включает поддержку новых команд Pentium III, но делает это не совсем правильно, поэтому возврат к старому процессору исправляет эту ситуацию. Для решения проблемы надо извлечь программой extract файл VMCPD.VXD (обычно он находится в файле win98_45.cab для русской версии) из дистрибутива Windows 98. Извлеченный из архива файл следует положить в директорию \windows\system\vmm32.

Не могу напечатать на принтере русский текст из редактора Microsoft Word 97. Вместо русских букв - квадраты. Установка Service Pack для Office 97 проблему не сняла. Что делать?
Для решения этой проблемы необходимо внести изменения в реестр Windows. Данные изменения зависят от того, установлен ли Service Release 1 или нет. При установленном SR-1 следует:

  • Вызвать программу regedit.

  • Найти в регистре строку HKEY_CURRENT_USER\Software\ Microsoft\Office\8.0\Word\Options

  • Открыть параметр Options дважды щелкнув по нему мышкой.

  • Создать новую строковую (String Value) переменную NoWideTextPrinting.

  • Присвоить ей значение 1.

  • Выйти из программы regedit и перезапустить Word.

Если SR-1 не установлен, то необходимо сделать такие изменения

  • Вызвать программу regedit.

  • Найти в регистре строку HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word

  • Выбрать Ваш принтер

  • Создать новую строковую переменную Flags

  • Присвоить ей значение 8192.

  • Выйти из программы regedit и перезапустить Word.

Информация предоставлена фирмой Seiko Epson.

У меня на компьютере происходят странные вещи - периодически опрашивается флоппи дисковод, несмотря на отсутствие в нем дискеты. Это явление сильно раздражает, но я не смог обнаружить причину. В чем дело и как запретить эти ненужные обращения?
Этот вопрос уже год самый частый из всех вопросов, которые нам задают. Причина несанкционированных обращений очень проста - при установке Microsoft Office 97 в Автозагрузку (Startup) записывается вызов программы Быстрый поиск файлов (Fast find), которая постоянно "пробегается" по всем файлам на всех дисках (в том числе и на гибком) для корректировки своей базы данных по файлам. Если в постоянном поиске и обнаружении файлов нет острой необходимости, нужно просто удалить из Автозагрузки (Startup) вызов этой программы и все прекратится.

У меня была установлена файловая система FAT32, затем я программой FDISK заново разметил диск под файловую систему FAT16 и снова установил Windows 95/98. После этого я не смог нормально работать с системой - постоянные ошибки при загрузке, сбои во время работы и т.п. Я также попытался установить Windows NT - результат практически такой же. Что делать?
Действительно, такой эффект часто бывает при переходе с FAT32 на FAT16. Наиболее простой способ борьбы с таким явлением - переписать с сайта фирмы-производителя жесткого диска программу для полного стирания информации на диске (как правило, во все сектора диска при этом записываются нули), обычно надо ей дать поработать всего пару минут (для стирания начальных секторов диска) и после этого разметить диск так, как требуется. Все должно быть нормально. Это правило следует выдерживать для любых накопителей со съемными носителями, независимо от интерфейса, за исключением обычного дисковода 3.5" и приводов CD-ROM.

Приобрел себе накопитель на магнитооптических дисках со SCSI интерфейсом. Во время работы извлек диск (нажатием кнопки на накопителе) и установил другой. Каково же было мое удивление, когда каталог вновь установленного диска полностью совпал с предыдущим - но при этом ни один файл не читался, а все ранее хранившиеся на этом диске файлы исчезли. Почему это произошло и что делать?
Такие случаи происходят довольно часто. Причина их в том, что операционная система обслуживает магнитооптический диск почти так же как и обычный жесткий. При замене диска по нажатию кнопки система не понимает, что была замена и начинает восстанавливать информацию на диске, считая, что это тот же диск, но с поврежденными файлами. При этом информация на новом диске теряется. Поэтому извлекать диски из подобных накопителей следует ТОЛЬКО с помощью самой операционной системы, установив курсор на имя диска в панели My Computer, Explorer и т.п. и выбрав правой кнопкой мыши Eject (Извлечь).

После установки драйверов Bus Master 3.01 от Intel перестал нормально работать на запись мой пишущий IDE CD-ROM. Что делать?
Действительно, драйвера Bus Master 3.01 от Intel не поддерживают работу с записывающими IDE CD-ROM. Для ликвидации проблемы следует установить драйвера версии 3.02 или заменить операционную систему на Windows 98.

Как установить в версии OSR2 произвольный размер кластера?
В команде format есть недокументированный ключ z, позволяющий установить размер кластера, кратный 512.Синтаксис format <disk>:/z:n, где n - множитель. Например, для создания диска с кластерами 1 Kb команда будет иметь вид: format <disk>/z:2.

Почему OSR2 не ставится на компьютер с установленной ранее версией Windows 95?
Версия OSR2 как в английской так и в русской версии существует только в OEM варианте и должна устанавливаться только на новые компьютеры. Поэтому она может устанавливаться либо на свободный диск, либо на диск, где ранее была установлена OSR2.

Почему "не виден" привод CD-ROM на материнских платах с chipset 430HX, 430VX и 430TX?
Windows 95 версии 950, 950a не распознает контроллеры 82371SB и 82371AB, входящие в эти chipset (подробнее об этих наборах в разделе "Материнские платы"). Если привод CD-ROM подключен ко второму контроллеру IDE, то Windows 95 его может не обнаружить. Самый простой способ правильно "прописать" CD-ROM -установить драйвера Bus Master, автоматически заменяющие обычные драйвера IDE из состава Windows 95. Релиз OSR2 Windows 95 распознает CD-ROM нормально.

Почему жесткий диск с установленной FAT32 от Windows 95 OSR2 может неправильно считываться на другом компьютере?
Если установка OSR2 выполнялась на компьютере с BIOS, который поддерживает расширенную спецификацию INT13 (добавлена поддержка дисков более 8.4 Gb), то после этого диск может считываться неправильно на компьютере, BIOS которого не поддерживает эту спецификацию. Для ASUSTeK P/I-P55T2P4 BIOS, начиная с 02xx, поддерживает расширенный INT13.

Пытаюсь установить драйвер Bus Master от Intel v.3.01, но после установки возникла ошибка защиты Windows 95. Моя звуковая карта - Creative AWE-64. Что делать?
Необходимо загрузиться в Safe mode, затем в панели Ресурсы звуковой карты изменить адрес синтезатора на таблице волн с 620 на 640 и перезагрузить Windows 95. Теперь все должно быть нормально.

Источник: http://www.spline.ru/

***

***
Copyright © "Internet Zone", info@izcity.com. Условия использования материалов


Оптимизация MS Windows XP

Автор: Андрей Радзевич aka VampiR

Здравствуйте, уважаемые пользователи WinXP Pro. После установки родненькой вы, конечно же, заметили, как она похорошела по сравнению с 2000-ной. Но!.. Не все пользователи хотят видеть красивости винды и ее (не)навязчивые сервисы, которые добавляют тормозов в нелегкую жизнь простого юзера. Сегодня я расскажу вам, как избавиться от всего вышеперечисленного. Статья не претендует на оригинальность. Все описанное ниже вы, возможно, встречали в Интернете и печатных изданиях, я хочу лишь собрать все воедино и донести широкой общественности. Воспользоваться или нет моими советами, решать вам.

Часть первая: оформление
Те, кому не по нраву всякие красивости и навороты интерфейса винды, или же компьютер не позволяет их оставить, читают дальше. Остальные переходят ко второй части. Хотя сам я отношусь к остальным, но все же некоторые элементы оформления я отключил. Вам же посоветую, как полностью (ну, или почти полностью;)) избавиться от них.
Первым делом жмем правой кнопкой по таскбару. Свойства — меню Пуск — классическое меню Пуск — ОК.

После этого правой кнопкой мыши щелкаем на пустом пространстве рабочего стола. Выбираем меню Свойства — Рабочий стол — Настройка рабочего стола. Снимаем галочку с Выполнять очистку рабочего стола…, а также с Сетевое окружение (если у вас нет локальной сети). Переходим на закладку Оформление, выбираем Windows Classic style, затем переходим на вкладку Эффекты и снимаем галочку со всего, кроме разве что Отображать содержимое окна при перетаскивании. ОК, Применить. Вуаля! Можно еще зайти на закладку Рабочий стол и поставить Фоновый рисунок в положение Нет.

Запускаем Мой компьютер, в меню Вид ставим Список, в меню Сервис выбираем Свойство папки. В появившемся окне выбираем Использовать обычные папки Windows и избавляемся от лишних украшательств. Переходим на закладку Вид. Ставим галочку в пунктах Не кэшировать эскизы (избавимся от миниатюрных копий графических файлов), Отображать Панель управления в папке Мой компьютер и Показывать Скрытые и системные файлы. После этого жмем Применить ко всем папкам, Да, ОК.

Нажимаем правой кнопкой на иконке Мой компьютер и выбираем меню Свойства (WIN+Break). Выбираем закладку Дополнительно, в меню Быстродействие кликаем по кнопке Параметры. В появившемся окне выбираем Обеспечить наилучшую производительность. После чего нажимаем Применить. Оставить можно только Отображать содержимое окна при перетаскивании, Сглаживание неровностей экранных шрифтов и Отбрасывание теней значками на Рабочем столе.

Часть вторая: службы и сервисы
Уж в отключении служб я поупражнялся;) по максимуму.
Нажимаем магическое сочетание WIN+Break, заходим в меню Восстановление системы и ставим галочку напротив Отключить восстановление системы на всех дисках. Кликаем Применить, идем пить кофе. Восстановление системы — задумка, конечно же, хорошая, но, поверьте, программа Universal Backup справляется с ней намного лучше. После испития целительного напитка возвращаемся и переходим на вкладку Автоматическое обновление и… отключаем его. Кликаем на Удаленное использование и снимаем галочки отовсюду, где они стоят, нажимаем Применить. Далее открываем проводник, кликаем правой кнопкой по иконке диска, на котором стоит система, выбираем меню Свойства и отключаем индексирование диска для быстрого поиска. Снова идем пить кофе. Кстати, возможно, ту же процедуру придется провести отдельно для папок Windows и Program Files.

После этого заходим в папки windows\ Prefetch и windows\system32\dllcash. Зашли? Теперь удаляйте оттуда все. В папке Prefetch лежат запротоколированные файлы для оптимизации расположения наиболее часто вызываемых утилит, но там же хранятся данные о файлах, которых на компьютере днем с огнем не сыскать (удалили вы их). В папке dllcash — резервные копии системных файлов, предназначенных для восстановления системы.
Теперь идем в гости к msconfig (WIN+R). Здесь мы будем отключать ненужные сервисы и службы. Процесс этот подразумевает некоторую степень риска, поэтому будем осторожны. Заходим в меню Автозагрузка и при большом желании отключаем все. Это на любителя, здесь я не советчик.

Теперь переходим на закладку Службы. Поскольку операции, которые мы будем сейчас производить, несут определенную опасность, я постараюсь описать назначение всех служб. Приступим-с.

Оповещатель — посылает инфу о системных событиях определенным лицам. Отключаем.
Служба шлюза уровня приложения — поддержка сторонних расширений для интегрированного брандмауэра Интернета. Поскольку в дальнейшем мы его отключим, то и эта служба нам бесполезна. Отключаем.

Вторичный вход в систему — позволяет запускать специфические процессы с правами другой учетной записи. Отключено.

Уведомление о системных событиях — служба, занимающаяся рассылкой оповещений о системных событиях подписавшимся компонентам. Можем отключить, но тогда в журнале событий при каждой загрузке системы будет появляться немаленькое количество предупреждений. Не трогаем.

Брандмауэр Интернета, Брандмауэр Интернета (ICF)/Общий доступ к Интернету (ICF) — хотите файрвол, ставьте Outpost. Отключаем.

Диспетчер очереди печати — поскольку есть принтер, оставляю. Если данный агрегат отсутствует, смело отключаем.

Управление приложениями — возможно, принимает участие в процессе установки/удаления софта. Запускается вручную. Оставляем.

Windows Audio — по заверениям винды:), без этого звуку придет смерть. Не трогаем.
Фоновая интеллектуальная служба передачи — для передачи асинхронных данных по протоколу HTTP/1.1. Реальных приложений, использующих данную функцию, отмечено не было. Отключаем.

Сервер папки обмена — дает возможность удаленным пользователям просматривать вашу папку обмена. Отключаем.

Система событий СОМ+, Системное приложение COM+ — от отключения этих служб я воздержался. Не трогаем.

Служба криптографии — проверяет файлы на наличие цифровой подписи. Не трогаем.
DHCP-клиент — это служба, позволяющая компьютеру автоматически получать необходимые сетевые настройки (сетевой адрес, шлюз, адреса серверов имен) с DHCP-сервера. Теоретически нужен для подключения через удаленный доступ. Но ХР прекрасно работала в Интернете и без него.

Служба администрирования диспетчера логических дисков — запуск вручную. Не трогаем.
Диспетчер логических дисков — контроль за внезапным появлением новых логических дисков. Может понадобиться для нормальной работы консоли администратора дисков. Кроме того, при подключении дополнительного винчестера в систему с отключенным диспетчером будет наблюдаться несколько неадекватная реакция. Не трогаем.

DNS-клиент — должен кэшировать ответы на DNS-запросы, но, похоже, это имеет отношение только для сервисов Active Directory. Отключаем.

Журнал событий — ведет протоколирование системных событий. Не трогаем.
Совместимость быстрого переключения пользователей — позволяет менять пользователя, не прерывая запущенных задач. Если вы единственный пользователь, смело отключайте.
Справка и поддержка — без этой службы встроенная справка Windows не работает. Отключать по желанию.

Служба СОМ-записи компакт-дисков IMAPI — если у вас нет пишущего привода, то оно вам не нужно. Если у вас есть пишущий привод, то тогда разве мало вам Nero Burning'a и Alcohol'a 120%? Отключаем.

Сервер — обычно компьютер, предоставляющий общие ресурсы пользователям сети. Отключено.

Рабочая станция — воздержусь, т.к. до конца не понял, что он точно делает. Не трогаем.
Модуль поддержки NetBIOS через TCP/IP — обеспечивает работу SMB-протокола. Отключаем.

NetMeeting Remote Desktop Sharing — если вы не пользуетесь специфическими возможностями NetMeeting, то оно вам не надо. Отключаем.

Координатор распределенных транзакций — кажется, имеет отношение к функционированию ODBC. Не трогаем.

Windows Installer — служба, предназначенная для установки .msi-пакетов. Не трогаем.
Диспетчер сетевого DDE, Служба сетевого DDE — Dynamic Data Exchange — звучит солидно, но в целом бесполезно (за исключением некоторых приложений вроде Сервера папки обмена). Отключено.

Сетевые подключения — без этого сервиса воспользоваться службой RAS не получится. Не трогаем.

Служба сетевого расположения (NLA) — уведомляет приложения об изменении сетевых настроек. Без поддержки со стороны приложений бесполезна. Отключаем.
Поставщик поддержки безопасности NT LM — аутентификация на серверах NT и доступ к ним. Отключено.

Съемные ЗУ — USB, ZIP и прочие. Если таковых не имеется, смело отключаем.
Plug and Play — а без него и не туды и не сюды. Не трогаем.

Службы IPSEC — служит для поддержки шифрования IP-трафика (для специфических заданий по обеспечению безопасного соединения). Отключаем.

Защищенное хранилище — служба, сохраняющая локальные и интернет-пароли. ОТКЛЮЧАЕМ.

Диспетчер автоподключений удаленного доступа — представьте себе такую ситуацию: вы открываете свежесохраненную страницу, а на ней присутствует баннер, который ссылается на другую страницу, и ваш explorer рьяно хочет подключиться к нету. Представили? Вам оно надо? Отключаем.

Диспетчер подключений удаленного доступа — нужная функция. Не трогаем.
Диспетчер сеанса справки для удаленного рабочего стола — а если возьмут, да и помогут:). Отключаем.

Удаленный реестр — позволяет удаленно управлять вашим реестром. Отключаем.
Локатор удаленного вызова процедур (RPC), Удаленный вызов процедур (RPC) — базовые службы. Не трогаем.

QoS RSVP — поддержка специфических расширений IP-протокола. Отнимает 20% интернет-трафика. Отключаем.

Диспетчер учетных записей безопасности — участвует в хранении информации о безопасности для локальных пользователей. Необходим для работы IIS, если он не стоит, то отключаем.

Модуль поддержки смарт-карт, Смарт-карты — они у вас есть? Если нет, то отключаем оба сервиса.

Вторичный вход в систему — позволяет запускать специфические процессы с правами другой учетной записи. Отключаем.

Уведомление о системных событиях — служба, занимающаяся рассылкой оповещений о системных событиях подписавшимся компонентам. Не трогаем.

Определение оборудования оболочки — обеспечивает автоматическое подключение memory cards. По некоторым данным, мешает выполнению chkdsk на подмонтированных томах. Отключаем.

Служба восстановления системы — поскольку мы эту службу уже отключили, то и здесь снимаем галочку. Отключаем.

Служба обнаружения SSDP — узел универсальных PnP-устройств. Некоторые утверждают, что это вполне реальная дыра. На ваше усмотрение.

Служба загрузки изображений (WIA) — если у вас нет сканера или камеры, то этот сервис и так неактивен. Отключаем.

MS Software Shadow Copy Provider, Теневое копирование тома — теневое копирование данных. Синхронизация данных на нескольких ЗУ в бэкграунде. Отключено.

Журналы и оповещения производительности, Адаптер производительности WMI — связано с Perfomance Counters — системой предоставления информации о загрузке памяти, ресурсов, различных устройств и пр. Необходимо лишь для специфического софта (типа MB Monitor). Спокойно можно прожить и без него. Отключаем.

Телефония — нужно для RAS'a. Не трогаем.

Служба терминалов — дает возможность работать на вашем компьютере удаленному пользователю при помощи утилиты Remote Desktop. Отключено.

Темы — так как мы отключили оформление, то и темы нам не нужны. Отключаем.

Telnet — Сервер удаленного управления через командную строку. Отключаем.

Клиент отслеживания изменившихся связей — отслеживает перемещение файлов в пределах локальной сети. Как сказал один человек: "Мобуть, автоматически ярлыки корректирует или что-то в этом духе?" Отключаем.

Диспетчер отгрузки — связано с передачей файлов между клиентом и сервером. Экспериментальным путем доказано, что отключение к летальному исходу не привело (да и назад включить всегда можно;)). Отключаем.

Источник бесперебойного питания — т.к. данный агрегат отсутствует, то отключаю. Если у вас ИБП есть, то не трогаете.

Веб-клиент — что-то для веб-паблишинга, полезных функций (как, впрочем, и вредоносных:)) не найдено. Отключаем.

Инструментарий управления Windows — это Управление компьютером в Администрировании. Не трогаем.

Portable Media Serial Number Service — серийный номер переносного медиа-устройства. Для меня осталось загадкой, для чего винде знать номер, к примеру, моего MP3-плейера? Я поразмыслил и решил, что незачем. Отключаем.

Расширения драйверов WMI (Windows Media Instrumentation) — инструментария управления Windows. Т.к. запуск происходит вручную, трогать не будем.

Беспроводная настройка — автоматическая настройка беспроводных сетей. Отключаем.
На этом мы закончим упражнения по отключению служб и сервисов. Поясню, что данные службы были замечены на моем компьютере. У вас их может быть больше (у меня самого их больше;)) за счет установки нового софта (Outpost, Norton System Work, антивирусы и т.д.).

Часть третья: реестр
В этой части мы будем изменять, добавлять, удалять ветки реестра. Это самая ответственная часть оптимизации, поэтому будьте осторожны. Приступим.

Вызываем regedit (WIN+R, regedit). В появившемся окне первым делом идем к HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\WindowsNT\CurrentVersion\AeDebug и меняем значение поля Auto на 0. Так мы избавились от постоянного присутствия Доктора Ватсона (drwatson).

Далее идем в гости к HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom и по желанию изменяем значение поля AutoRun на 0 (отключаем автозапуск CD).

Идем в HKEY_CURRENT_USER\Control Panel\Desktop и изменяем параметр MenuShowDelay с 400 на любое другое число (я поставил 50). Этим действием мы уменьшаем (если число меньше 400) или увеличиваем (если больше) задержку перед раскрытием вложенных меню в Пуске.

Если вам не нравятся всплывающие подсказки Windows (Свернуть, Развернуть, Закрыть,), то там же создаем параметр MinMaxClose (строкового типа) и задаем ему значение 0. Ну, а если вы хотите окончательно расправиться с подсказками, тогда идите в HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\Current Version\Explore\Advancer и создавайте ключ EnableBaloonTips (параметр dword) со значением 0.

В ХР есть функция удаления файла подкачки при выходе из системы. Но если вы не работаете админом сверхсекретной правительственной структуры, то оно вам не надо. Следовательно:
HKEY_LOCAL_MACHINE\SYSTEM\ CurrentCon-trolSet\SessionManager\MemoryManagment и меняем значение ключа ClearPageFileAtShutdown на 0.

Идем в гости к Unix'у. HKEY_LOCAL_ MACHINE\SYSTEM\CurrentControlSet\SessionMa-nager\SubSystem и удаляем ключи Optional и Posix. Обычному пользователю они не понадобятся. Или вы собираетесь запускать Unix-приложения под виндой (которых, кстати, немного)?

Далее направляем мышку в HKEY_CURRENT_USER\Control Panel\Desktop и копируем содержимое ключей UserPreferencesMask и FontSmoothingType в ветку HKEY_USERS\ .DEFAULT\Control Panel\Desktop. Также можно скопировать содержимое ветки HKEY_CURRENT_USER\Colors в HKEY_USERS\.DEFAULT\ Colors. Так мы добьемся единообразия окраски и оформления после загрузки и при входе в систему.

Часть четвертая: последние штрихи
Сейчас мы будем шлифовать систему для придания ей окончательного товарного вида:).
Направляемся в Диспетчер устройств (WIN+ Break — Оборудование — Диспетчер устройств). В меню Вид выбираем Показать скрытые устройства. После этого в меню Драйверы устройств не Plug and Play мы отключим указанные ниже устройства. Для отключения кликаем правой кнопкой мыши по нужному устройству, выбираем меню Свойства, закладку Драйвер и меняем тип автозагрузки на Отключено.

Отключаем mndm (драйвер MS Netmeeting), NetBios через TCP/IP и RDPCDD (драйвер сервиса Remote Desktop). Перезагружаемся. Данные манипуляции не приведут ни к каким последствиям, т.к. сервисы, от которых зависят эти службы, мы отключили во второй части нашей статьи.

После создания подключения к Интернету идем в Панель управления — Сетевые подключения, кликаем правой кнопкой по имени соединения, выбираем меню Свойства. Переходим на закладку Сеть и удаляем все протоколы, кроме TCP/IP. Остальные протоколы потеряли свою работоспособность после манипуляций во второй части. Перезагружаемся.
Заходим в гости к винде Windows\inf и находим там файл sysoc.inf. Открываем его любым текстовым редактором и удаляем из него все слова hide. Заходим в Панель управления — Установка и удаление программ — Установка компонентов Windows. Все удалить не дадут, да оно нам и не надо. С нас хватит удаления MSN Explorer'a, Windows Messenger'a, а также следующих: Автоматическое обновление (удаление;)) Windows, Другие службы доступа к файлам и принтерам сети (ну зачем, скажите мне, вам нужна Служба печати для Unix?), Очереди сообщений, Сервер терминалов, Служба индексирования, Службы факсов, Средства управления и наблюдения — и, пожалуй, все.

Последним штрихом в нашей работе станет выполнение в командной строке (WIN+R) regsvr32 /u zipfldr.dll. того, что избавит нас от представления zip-архивов в виде папок. Вроде неплохая функция, но у нас же есть WinRAR.

Напоследок заходим в Диспетчер устройств (WIN+Break), переходим на вкладку Дополнительно. Выбираем меню Переменные среды и в окне Переменные среды пользователя для… ставим значение %SystemRoot%/Temp. После этого переходим в меню Отчет об ошибках и ставим галочку на Отключить отчет об ошибках. Иначе после каждого не совсем корректного завершения программ (Ctrl+Alt+Del рулит;)) будет выскакивать окошко с ненавязчивым предложением отослать отчет товарищам мягкотелым. Не следует ставить галочку напротив пункта Не уведомлять о критических ошибках. На этом мы с вами закончим путешествие по миру ХР (но только на сегодня:)).

Все возникшие вопросы, а также критику (ну, и благодарности тоже) присылайте мне. В следующей статье я обозрю;) программы-tweak'еры. Засим разрешите откланяться.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
IZ рекомендует | Оргтехника и расходные материалы Ремонт оргтехники , Покупка Б/У оргтехники , Запчасти , Заправка картриджей , Восстановленные картриджи , Расходные материалы
---
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности. Построение разветвленной структуры предприятия, ведение штатного расписания. Ведение учета личных карточек с автоматическим формированием приказов. Возможность стыковки с бухгалтерскими программами. Формирование произвольных отчетов по любым параметрам личной карточки.
***
Copyright © Internet Zone, info@izcity.com


Стоит ли ставить Windows XP?

Не так давно я все-таки решился поставить себе Windows XP Professional SP1 Rus, несмотря на все те слухи, что мол XP очень глючная, отправляет ваши данные компании Microsoft, не распознает драйвера и т.д.

Установка

Устанавливал я ее в качестве второй ОС из Windows Me. Слышал, что возникают проблемы с ее установкой в качестве второй ОС после Linux, не знаю, не проверял. Установка много труда не займет, поэтому описывать ее я не буду, скажу только, что при загрузке она предлагает выбрать файловую систему, FAT32 или NTSF. Я бы посоветовал все-таки переформатировать диск в NTFS, если Вы, как я, хотите поставить ее в качестве второй ОС. Дело в том, что с точки зрения безопасности, FAT32, это не очень хорошо. А файлы на диске с Win9x, Me в ХР будут доступны. А вот Win 9x, Me просто не будут видеть диск в формате NTFS. Но это очень просто исправить, с помощью, специальных программ. При загрузке вы можете оставить диск без форматирования в формате FAT32, тогда, естественно все файлы на обоих дисках будут доступны. После установки, на начальном этапе выпадает меню, в котором можно выбрать ОС, какую Вы хотите запустить, в моём случае Windows XP, или Windows Me. Я, естественно, выбрал Windows ХР. Грузится она дольше Ме.

Внешний вид

Внешний вид ХР, очень впечатляет. Никаких серых скучных окон, все представлено в сине-бело-голубом тоне, можно также переключить тон в серый и в стандартный (как в Win9x). Смотрите скриншоты и зацените сами. Переключать виды можно по адресу: Пуск - Панель управления - оформление и темы - изменить тему оформления - вкладка "Темы". Вообще хочу сказать, что дизайнеры Microsoft потрудились на славу. А вот в организации интерфейса явный минус. Функции, которые в Win9x, можно было включить пару щелчками, тут затратит куда больше времени. Конечно, понятно, что программисты Microsoft старались сделать ХР удобнее для новичков, но не настолько же все ламеры. Отдельно хотел бы отметить завершение работы, теперь когда появляется окошко с завершением работы, все, кроме этого окна медленно принимает однотонный серый цвет. Что и говорить, работать с таким интерфейсом куда приятнее, чем с прежним. <

Крак (crack)

Я устанавливал ХР с пиратского диска, на котором, само собой, был расположен и крак. Он оказался не совсем краком, т.е. он регистрировал ОС, а просто останавливал время на регистрацию, системное время при этом не останавливалось. В целом с краками к продуктам из серии ХР дело обстоит куда хуже, чем с Win9x. Технология защиты от пиратства примененная Microsoft носит гордое названи WPA. Коротко расскажу о ее сути. А состоит она в следующем: в обмене ключами между пользователем ОС и непосредственно Microsoft. На компьютере пользователя генерируется серийный ключ из серийного номера ХР и железа (!) ПК пользователя. В примечании, хочу отметить, что не раз я слышал, что при модернизации, официально зарегистрированная версия Windows XP, отказывалась работать! Еще один повод использовать крак. Короче, сгенерированный на ПК пользователя ключ отсылается Microsoft, где из него генерируется другой ключ. Этот ключ отправляется пользователю, который активирует ХР. Эта технология исключает использование одного ключа на нескольких компьютерах. Теперь о том как решили эту проблему пираты. Дело в том, что Microsoft выпустила специальную версию ХР, которая предназначалась для корпоративных пользователей на десятки тысяч компьютеров. Естественно, что генерировать для них всех свой собственный номер было неудобно, и Microsoft выпустила версию ХР, которая не требовала регистрации. Ну и эта ОС сразу же попала к пиратам. Конечно, с выходом SP1 была предпринена еще одна попытка борьбы с пиратством, но она тоже уже преодолена. Хочу сказать, что большинство генераторов ключей для ХР просто не будут работать, но некоторые вполне рабочие, например, The Blue List XP KeyGen.

Особенности ХР

Первое это размер, который в отличие от своих младших собратьев, занимает у меня аж 1,2 Гб. С ним в комплекте идет последние версии Internet Exploer, Outlook, Windows Media Player, Windows Movie Maker, Picture Viewer. Cреди нововведений нужно отметить совместимость. В каталоге системы появилась новая папочка WinSxS, которая хранит разные версии компонентов библиотек. Как я уже говорил, в Windows XP можно работать с программами от предыдущих версий этой системы, это обеспечивает приложение под названием QFixApp. Также в ХР присутствует защита от ламеров, и "завалить" ее неопытным пользователям стало гораздо сложнее, чем Windows 9x. С точки зрения безопасности ОС стала гораздо лучше.

Требования к железу

Windows XP не предназначен для слабого, медленного компьютера. Минимальный обьём оперативной памяти должен быть 128 Мб. На моей системе: Intel Pentium 4 1500 Гц, 128 DDR 2100, Vidio GeForce 4 MX 64 Mb, 40 Gb HDD Seagate, CD-ROM 52x Acer, 14 дюймовый монитор Panasonic SM 50, Modem US Robotics Courier 3453 ("новый Курьер"). после установки замечались небольшие тормоза, но после настройки все стало в буквальном смысле "летать".

Настройка

Теперь о том, как настроить ХР. Я использовал программу Tweak-XP, найти которую можно здесь: http://www.totalidea.de, http://www.tweak-xp.de/
Поскольку программа русский язык не поддерживает, коротко расскажу как она работает.

System Performance

Memory Optimization - оптимизирует память, и выкидывает от туда все ненужное.

RAM Disk Drive - можно сделать диск в оперативной памяти, если не хватает скорости своего винчестера. Там можно разместить часто используемые приложения, в результате их загрузка будет происходить гораздо быстрее.

Cache Optimization - позволяет увеличить/уменьшить размер кэша, это, если не хватает оперативной памяти.
Hardware Tweaks - Здесь можно отключить autorun, настроить железо, уменьшить/увеличить скорость чтения дисковода.

Tricks and Tweaks

Windows Tweaks - Тут можно настроить внешний вид ХР.

Windows Tweaks II - Опция Specify OEM Info on "System properties" page. Можно поставить любую картинку в System properties.

Folder Icons - Здесь можно изменить внешний вид папок.

Internet Tweaks

Ad Blocker - Тут можно заблокировать показ баннеров из баннерообменных систем.

Pop-Up Blocker - Запрет на выскакивающие окна.

Utilites

Password Generator - Помогает придумать хороший пароль.

File Shredder - Помогает уничтожить файлы, перезаписывая его несколько раз

Заключение

Стоит ли ставить Windows XP? Для себя я однозначно решил, что стоит, конечно, решать Вам, но если железо позволяет, то почему бы и нет?

Андрей, http://ca1.dax.ru/


***

Независимая установка WinXP от WinME/9x

Автор: Поярков Илья (Terabyte)
(xForum team)

Вступление

В этой статье я хочу рассказать, как установить WinXP независимо от WinME/9x, но это не все!!! Еще в этой статье будет рассказано, то чего я не видел больше ни где в интернете, а именно, то как в последующем устанавливать эти оси не зависимо друг от друга после форматирования одной из них (в частности, когда WinXP установлен на файловую систему NTFS). Под словом независимая установка я понимаю, то что загрузочные файла обоих осей будут находиться в разделе, где установлена данная ось (Операционная система или ОС). На написание данной статьи меня поддакнуло множество писем с таким вопрос и личная необходимость установить WinXP независимо от WinME/9x, так как я относительно часто форматирую некоторые диски. Далее под XP будет пониматься - WinXP, а под МЕ - WinME/9x.

Подготовительные работы

Для этой операции вам понадобится следующее:

1. Хорошая программа для разбивки диска. FDISK здесь не подойдет, так как она не умеет создавать более одного первичного раздела и не умеет работать с файловой системой NTFS. Лично я вам советую PartitionMagic, который кроме нужных нам функций имеет множество других (не менее полезных). При подготовки статьи я использовал PartitionMagic 7.0

2. Удобный в настройке и обращении менеджер загрузки компьютере. Менеджер загрузки поставляемы с WinXP очень труден в настройке для обычного пользователя и вам он скорее всего не подойдет. Я советую вам BootMenu (http://www.cnt.ru/~0hacker/download/ bootmenu.rar ), к архиву с программой прилагается понятная справка.

3. И конечно же сами дистрибутивы с операционками :-)

Перед началом работы я еще хочу посоветовать указать при установке PartitionMagic`а, то что бы он скопировал на диск в свою папку еще и свои модули для работы в DOS`е. Эти модули значительно упростят вам жизнь при выполнении нашей задачи (и наверняка помогут вам в будущем). Вам нужно будет создать на дискете загрузочную область (но не загрузочную дискету, так как DOS`овская версия дистрибутива PM (PartitionMagiс) просто не войдет на эту дискету). А далее просто скопируйте на дискету содержимое папки DOS (она лежит в папке с PartitionMagic). Теперь когда вам нужно будет загрузить DOS`овскую версию PM, вы должны будете загрузиться с дискеты и дать команду: pqmagic.exe

Практика

Теперь, если у вас все готово вы можете приступить к независимой установке WinXP и WinME/9x.

Загружаемся с нашей ранее заготовленной дискеты и запускаем с нее DOS`овскую версию PM. Загрузившись в PM вы должны будете создать, как миниму два ПЕРВИЧНЫХ (Primary) раздела. Напомню, что их может быть максимум четыре (из них четвертым будет являться (если будет создан) расширенный (Extended) раздел). Лично я разбил так: превый первичный раздел (NTFS) отпустил под ХР, второй первичный раздел под ME, третий под Linux Mandrake 7.0, а четвртым стал расширенный раздел разделенный еще на четыре логических (для веб-сервера, файлов, программ и etc). Далее делаем активным (Set Active…) тот раздел, на который в начале будете устанавливать ОС. Я в начале сделал активным раздел под ХР.

Теперь я вам советую сначала установить ХР, а уже потом МЕ, так как проблем будет меньше (тем кто хочется установить сначала МЕ, а потом ХР, то читайте как это сделать ниже).

Теперь запусти инсталяцию ХР и откинься на спинку кресла! После установки ХР, можете сразу устанавливать МЕ. Установили? Если да, то наверняка заметили, что МЕ потерла загрузочную область ХР и вы наверно схватились за голову подумав, что час установки ХР - коту под хвост. Погодите, ведь я не зря советовал вам скачать рульную программу BootMenu (надеюсь вы уже изучили справку к ней). Следующие наши действия такие: Загружаемся в ЧИСТЫЙ DOS, заходим в папку с это программой и даем команду:

bmi.com d0 54 WinXP=0 WinME=1

Хоть я надеюсь, вы и прочитали справку, я все таки дам не большое пояснение к команде. d0 - обозначает жесткий диск, на котором производятся все операции (если у вас один жесткий диск вы должны написать именно это). 54 - это время через которое будет гружаться ОС назначенная по умолчанию (она должна быть первой в команде, в данном случае это WinXP). Тайм-аут измеряется в тиках=1/18 секунды (тоесть 54=3 сек.). Далее идет список ОС. Этот список дается в такой последовательности, в которой он должен будет отображаться на экране, причем первая в списке ОС, будет ОС загружаемой по умолчанию по истечению тайм-аута. Хочу заметить, что цифры 0 и 1 обозначают, номер раздела (в данном случае, 0 - это первый раздел, 1 - второй и т.д.).

Теперь если вы все сделали правильно, то при появлении загрузочного меню при загрузке компа у вас при нажатии F1 должен грузиться ХР, а при нажатии F2 - МЕ.

После прочтения выше написано материала вы спросите: "А зачем собственно нужно было создавать все эти первичные разделы и возиться с BootMenu, когда можно было просто установить МЕ, а потом ХР, который создаст свой загрузчик?". Ответ прост: а что бы вы стали делать, если вдруг вам пришлось форматировать ХР и ставить его за ново. ХР бы поместил все свои файлы загрузки на диск к МЕ, а потом в один прекрасный день МЕ бы у вас упал и вам пришлось бы форматировать диск с ним и загрузочной областью ХР??? Вот тогда бы вы и забегали по комнате в поиске возможность загрузиться в ХР установленном на NTFS. Я думаю, смысл вы поняли, а если не поняли, то прочтите заново.

Теперь я хочу поговорить, как правильно установить ХР с уже установленной МЕ (например, когда вы только что форматнули XP). Перед установкой ХР вы должны сделать следующие: удалить загрузчик МЕ с ее раздела (io.sys, command.com), чтобы ХР не нашла МЕ и делаем !!! раздел для ХР АКТИВНЫМ. Сделав это вы можете спокойно устанавливать ХР. После установки ХР, вы должны будете загрузиться в чистый DOS, восстановить загрузчик МЕ (например, командой C:\WINDOWS\COMMAND\sys c: , а потом должны будете опять установить BootMenu.

Вот в принципе и все, что я хотел рассказать. Если у вас возникли вопросы по данной статье, то можете смело задавать их в специально посвященной теме нашего форума. Так же на нашем форуме (forum.web-hack.ru) вы можете задавать ЛЮБЫЕ вопросы посвященные компьютерам, а на сайте от форума (www.web-hack.ru) вы найдете большое количество статей и программ.


Секреты ХР

Как известно, в продуктах корпорации Мicrosoft настройка многих опций, к сожалению, скрыта от пользователя. Однако универсальное средство для изменения параметров системы и программ все же существует. Таковым является обращение к системному реестру Windows. Можно смело утверждать, что многим из читателей (а скорее всего и большинству) это понятие покажется малознакомым. И это вполне естественно: ведь практически все пользователи привыкли работать с операционной системой в ее стандартном исполнении (то есть, с настройками, определенными изготовителем по умолчанию), даже не догадываясь о том, что совершенно элементарным образом можно модифицировать ее под свои индивидуальные вкусы и предпочтения.

Начиная наш разговор о секретах Windows, попробуем разобраться, что же такое системный реестр. Сильно упрощая, термин "реестр" можно понимать как своеобразную нервную систему Windows. То есть, подобно дендритам, аксонам и синапсам в нашем организме, он связывает все компоненты операционной системы воедино. Если говорить более конкретно, то реестр представляет собой базу данных, содержащую информацию о текущих настройках Windows, ее компонентах, службах и сервисах, а также о параметрах установленных приложений.

Приведем несложный пример, который поможет понять, что же вообще происходит с реестром при выполнении разнообразных операций, связанных с изменением настроек системы. Кроме того, покажем, как можно, изменяя ключи реестра, получить результат, аналогичный тому, как если бы мы просто использовали стандартные средства Windows для модификации ее параметров.

Для начала смените обои рабочего стола. Для этого, щелкнув правой кнопкой мыши по рабочему столу, в появившемся меню задействуйте команду "Свойства", затем в диалоговом окне "Свойства: экран" перейдите на вкладку "Рабочий стол", где из списка выберите нужный файл. Например, установите обои "Пузыри". При выполнении этой простой операции Windows изменит в соответствующих местах реестра ключи, прописав путь к выбранному в качестве заднего фона графическому файлу.
Согласитесь, было бы очень интересно узнать, где и какие именно произошли изменения в результате вышеописанной операции. Для этого необходимо открыть редактор реестра. Сделать это можно, задействовав команду "Выполнить" кнопки "Пуск". При этом появится диалоговое окно, в строке ввода которого наберите имя файла, запускающего необходимый нам редактор реестра — "regedit". В результате на экране появится его окно, разбитое (подобно Проводнику Windows) на две панели. Слева в нем расположены корневые разделы реестра, в которые помещены ключи, объединенные по принципу выполняемых ими функций. Пройдясь по разделам, вы обнаружите, что структура реестра напоминает дерево: корневые разделы, дробясь на все более специфические ветви, приводят нас к "листьям" — ключам. Именно в них и содержится информация о текущих настройках.

Например, раздел [HKEY_LOCAL_MACHINE] содержит данные об аппаратной конфигурации и установленном программном обеспечении в системе, а раздел [HKEY_USERS] хранит информацию о загруженных профилях пользователей, включая профиль, заданный по умолчанию (профиль пользователя — это файл, содержащий сведения о настройках для конкретного пользователя, таких как настройки рабочего стола, постоянные сетевые подключения и параметры приложений).

Объем реестра огромен. Потому разыскать необходимый ключ, просто перемещаясь по его ветвям, довольно непросто. По этой причине зачастую оптимальным вариантом выполнения поставленной задачи является использование системы поиска. Так, если мы определили в качестве обоев рабочего стола какой-либо файл (в нашем примере это "Пузыри.bmp" из папки C:\ Windows), то для того чтобы найти ключ реестра, в котором произошли изменения, нам необходимо ввести имя данного файла в строке диалога поиска (вызывается нажатием комбинации [Ctrl]+[F]). В результате этой операции отображаемая информация в панелях изменится. Так, в левой панели вы увидите разделы реестра: среди них будет тот, в котором содержится ключ со значением, заданным в качестве параметра поиска. Имя же нужного раздела появится внизу окна редактора в строке статуса. В правой панели располагаются ключи, соответствующие данному разделу реестра (необходимый нам выделен курсором). Правее названия ключа — значение, ему присвоенное. Естественно, нельзя исключать тот случай, когда ключей с нужными нам данными может быть несколько. Тогда для продолжения поиска с теми же условиями нажмите клавишу [F3]. Итогом этих операций будет выявление всех ключей реестра, содержащих искомую строку поиска.

В нашем случае среди результатов вы можете получить примерно следующее.
Раздел [HKEY_CURRENT_USER\ Control Panel\ Desktop], ключ Wallpaper, значение C:\ Windows\ Пузыри.bmp".
Раздел [HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Desktop\ General], ключ BackupWallpaper, значение "%SystemRoot%\ Пузыри.bmp".
Раздел [HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Desktop\ General], ключ Wallpaper, значение "%SystemRoot%\ Пузыри.bmp".
Становится ясным, что, сменив обои Windows на файл с именем "Пузыри.bmp", ключи реестра тоже соответственно модифицировались.

Теперь же попробуем в этих ключах заменить "Пузыри.bmp" на, скажем, "Паркет.bmp". Для этого снова начните поиск в реестре, и на каждом найденном вами ключе щелкните два раза мышью для вызова диалога редактирования его содержимого. После завершения операции замены значений всех трех ключей закройте редактор реестра. Затем правой кнопкой мыши щелкните по рабочему столу и выберите из меню пункт "Обновить". В том случае, если все было сделано правильно, вы увидите, как сменились обои Windows: вместо изображения из файла "Пузыри.bmp" появится картинка из "Паркет.bmp".

Таким образом, достаточно легко убедиться в том, что системные параметры можно изменять, прибегая к помощи не только стандартных средств Windows, но и используя редактор реестра. Необходимо еще раз отметить, что не все настройки операционной системы удается модифицировать, пользуясь встроенными функциями. Потому многие операции просто невозможно выполнить без помощи редактора реестра.

Довольно интересным было бы все-таки узнать, что же именно можно проделать с системными опциями посредством реестра, чтобы оптимизировать, например, среду под свои вкусы и предпочтения. В этой статье мы рассмотрим наиболее полезные возможности в этой области. Кроме того, приведем несколько примеров модификации операционной системы без использования реестра в расчете на то, что они также покажутся немаловажными для упрощения повседневной работы с Windows.

Изменяем порог выдачи предупреждения о недостатке свободного места на диске

По умолчанию, когда свободными остаются менее 10% пространства на любом из логических разделов жесткого диска, Windows проинформирует вас об этом появлением иконки в области уведомлений (правый нижний угол панели задач — там, где располагаются часы и ярлыки для быстрого запуска программ) вместе с сообщением о нехватке свободного места на винчестере. В том случае, если Windows (излишне перестраховываясь) мешает вашей работе постоянным появлением предупреждений подобного рода, вы можете изменить порог (в процентном отношении) выдачи данного сообщения. Для этого вам необходимо выполнить следующие действия:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_LOCAL_MA-CHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\ Parameters];
3. В меню "Правка" выберите "Создать" — "Параметр DWORD";
4. Введите имя "DiskSpaceThreshold", нажмите [Enter];
5. Дважды щелкнув мышкой на созданном ключе, укажите в нем порог вывода предупреждения как десятичное значение от 0 до 99 (то есть процент от объема диска). Нажмите OK;
6. Закройте редактор реестра и перегрузите систему.

Отключаем сообщение о недостатке свободного места на диске

Для того чтобы вообще отключить появление сообщения о недостатке свободного места на жестком диске (см. выше), выполните следующие действия:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_CURRENT_ USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer];
3. В меню "Правка" выберите "Создать" — "Параметр DWORD";
4. Введите имя "NoLowDiskSpaceChecks", нажмите [Enter];
5. Дважды щелкнув мышкой на созданном ключе, задайте значение "1". Нажмите OK;
6. Закройте редактор реестра и перегрузите систему.

Настраиваем Windows на автоматическое завершение задач, которые повисли и перестали отвечать

Порой так случается, что некоторая программа зависает, то есть не реагирует на обращение к ней. Тогда приходится принудительно завершать данное приложение, например, посредством выбора команды "Закрыть" меню, появляющегося при щелчке правой кнопкой мыши по иконке программы, или используя Диспетчер задач (вызывается сочетанием клавиш [Ctrl]+[Shift]+[Esc]). Однако можно сделать так, чтобы Windows автоматически завершала зависшие приложения. Для этого выполните следующие действия:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_CURRENT_ USER\ Control Panel\ Desktop]. Здесь есть несколько необходимых нам ключей:
— Ключ HungAppTimeout определяет время, по прошествии которого не отвечающее приложение считается зависшим (по умолчанию это 5000 миллисекунд). Измените значение ключа на необходимое.
— Ключ WaitToKillAppTimeout задает время ожидания перед завершением зависшего приложения (по умолчанию 20000 миллисекунд). Измените значение ключа на необходимое.
— Присвоив ключу AutoEndTasks значение "1", вы разрешите системе завершать зависшие процессы автоматически.
3. Закройте редактор реестра и перегрузите систему.
Следует обязательно обратить внимание на то, что при установке слишком малых значений в перечисленных выше ключах могут возникнуть проблемы с автозавершением запущенных задач. Это связано с тем, что приложение на самом деле может длительное время не отвечать на запросы пользователя в случае достаточно большой загруженности процессора его выполнением или работой с другими программами.

Вызываем "синий экран смерти" сами

"Синий экран смерти" (Blue Screen of Death) — это встроенный механизм перехвата ошибок, которые могут привести к повреждению данных или системы в целом. Такая ситуация возникает, когда появляются неполадки в функционировании встроенных служб или программ пользователя. Внешне это проявляется как внезапная остановка работы среды Windows с выдачей на экран технической информации на синем фоне. После этого остается только перегрузить систему.

Оказывается, такую ситуацию можно вызвать вручную, прервав работу Windows. Такая необходимость может возникнуть, если, например, система не реагирует на нажатие знаменитых [Ctrl]+[Alt]+[Del] (при использовании кнопки Reset завершение работы будет грубым). Сочетание клавиш для вызова "синего экрана смерти" следующее: удерживая правый [Ctrl], два раза нажмите на [Scroll Lock]. Для того чтобы система распознавала данную комбинацию, проделайте следующее:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_LOCAL_ MACHINE\ SYSTEM\ CurrentControlSet\ Services\ i8042prt\ Parameters];
3. В меню "Правка" выберите "Создать" — "Параметр DWORD";
4. Введите имя "CrashOnCtrlScroll", нажмите [Enter];
5. Дважды щелкнув мышкой на созданном ключе, задайте любое ненулевое значение, например "1". Нажмите OK;
6. Закройте редактор реестра и перегрузите систему.

Изменяем паузу перед запуском программы CHKDSK

В случае некорректного завершения сеанса работы в Windows (например, при неполадках в электросети) при следующей загрузке операционной системы запускается специальная программа CHKDSK. Она предназначена для создания и отображения отчета о состоянии жесткого диска, составления списка ошибок и их исправления. CHKDSK стартует таким образом, что пользователь может прервать ее работу, если не видит надобности в проверке дисков. Время, в течение которого можно отказаться от запуска этой программы или продолжать дожидаться начала ее работы, представлено в виде таймера с предустановленным значением обратного отсчета в 10 секунд. Если вам хочется изменить это время на другое, например, для ускорения загрузки системы, то в командной строке (Пуск/Программы/Стандартные/Командная строка) следует набрать:

chkntfs /t:n, где n — число секунд времени обратного отсчета.

Решаем проблему установки программ в Windows XP

Довольно часто при работе с Windows XP возникает ситуация, когда некоторые программы не желают нормально устанавливаться. Это выражается в том, что, как и положено, в начале появляется окно контроля за ходом процесса, индикатор которого отображает степень завершенности установки в виде процентной шкалы. Когда же установка доходит практически до конца (это заметно по тому, что индикатор закрашивается до 100%), процесс инсталляции останавливается, несмотря на то, что продолжает активно находиться в памяти компьютера.

Дело все в том, что при установке новой программы запускается ее инсталлятор (устанавливающая приложение программа), которому необходимо место на жестом диске для временного хранения файлов, нужных для успешного завершения процесса установки. Так вот, данная проблема возникает в том случае, если путь для папки хранения временных файлов имеет слишком длинное имя. Это приводит к тому, что инсталлятор успешно помещает их туда, но потом не может найти.
Для решения этой проблемы достаточно указать относительно короткий путь для папки хранения временных файлов. Чтобы это сделать, щелкните правой кнопкой мыши по значку "Мой компьютер". В появившемся меню выберите команду "Свойства", затем, оказавшись в диалоговом окне "Свойства системы", перейдите на вкладку "Дополнительно", где нажмите кнопку "Переменные среды". В верхней части появившегося окна располагается область "Переменные среды пользователя", где можно обнаружить необходимые нам опции. Затем измените значения переменных TEMP и TMP. Для этого введите новый путь к папке хранения временных файлов (достаточно короткий и, желательно, не имеющий русских букв в своем названии), допустим, "C:\ Temp". После того, как вы это сделаете, можно удалить папку, путь к которой был прописан в данном месте до произведенных вами изменений.

Кроме данной проблемы, сохраняется еще одна, заключающаяся в том, что некоторые инсталляторы пытаются устанавливать приложение по конкретному адресу на жестком диске. А именно, "%windir%\ Temp", где "%windir%" — путь расположения папки Windows. Например, адрес может быть таким: "C:\ Windows\ Temp". К счастью, подобные инсталляторы встречаются довольно редко, но если (вдруг) не помогает вышеописанный способ изменения путей для хранения временных файлов, можно попробовать создать данную папку, тем самым разрешив проблему.

Отключаем клавишу Windows

На многих клавиатурах есть специальная клавиша, называемая "Windows", или просто "Win". Ее использование зачастую облегчает выполнение некоторых операций. Однако в некоторых случаях существует необходимость ее отключения (например, эта клавиша может мешать в играх). Для деактивации клавиши Win выполните следующие шаги:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_LOCAL_MA-CHINE\ SYSTEM\ CurrentControlSet\ Control\ Keyboard Layout];
3. В меню "Правка" выберите "Создать" — "Двоичный параметр";
4. Введите имя "Scancode Map", нажмите [Enter];
5. Дважды щелкнув мышью на созданном ключе, определите следующее значение: 0000 0000 0000 0000 0300 0000 0000 5BE0 0000 5CE0 0000 0000. Вводите без пробелов: они здесь только для удобства представления. Нажмите OK;
6. Закройте редактор реестра и перегрузите систему.

Работаем с Internet Explorer в режиме киоска

Обозреватель Internet Explorer, начиная с четвертой версии, умеет работать в полноэкранном режиме. Перейти в него можно, нажав клавишу F11. Однако при этом на экране все равно остаются некоторые управляющие элементы. Оказывается, можно запустить Internet Explorer в специальном режиме (так называемом "режиме киоска" (kiosk mode)), когда на экране не остается вообще никаких управляющих элементов. Это может быть полезным, например, при просмотре изображений, не умещающихся целиком на экране, либо для тех, кто привык эффективно использовать пространство видимой области монитора. Для работы в "режиме киоска" необходимо запустить Interner Explorer с указанием следующих ключей (ключи прописываются в свойствах программы): iexplore -k "страница"
При этом откроется указанный в параметре "страница" адрес либо, в случае только одного параметра "-k", загрузится стартовая страница, принятая по умолчанию, например: iexplore -k http://yandex.ru

Работая в "режиме киоска", вы можете использовать следующие комбинации клавиш для выполнения тех или иных действий:

Ctrl+A — Выделить всю страницу
Ctrl+B — Упорядочить Избранное (Fa-vorites)
Ctrl+C — Копировать в буфер
Ctrl+F — Найти на странице
Ctrl+H — Открыть Журнал (History)
Ctrl+L — Открыть окно ввода адреса (аналогично Ctrl+O)
Ctrl+N — Создать новое окно (открывается в обычном режиме)
Ctrl+O — Открыть окно ввода адреса (аналогично Ctrl+L)
Ctrl+P — Печать
Ctrl+R — Обновить страницу
Ctrl+S — Сохранить страницу
Ctrl+V — Вставить из буфера
Ctrl+W — Закрыть окно (аналогично Alt+F4)
Ctrl+X — Вырезать в буфер
Alt+F4 — Закрыть окно (аналогично Ctrl+W)
Alt+Влево — Назад
Alt+Вправо — Вперед
Esc — Остановить загрузку страницы
F5 — Обновить страницу

Увеличиваем производительность NTFS

Windows XP позволяет использовать NTFS — улучшенную файловую систему, обеспечивающую достаточный уровень быстродействия и безопасности, а также предоставляющую дополнительные возможности, недоступные ни в одной версии файловой системы FAT.

Узнать, есть ли в системе разделы с NTFS, можно, открыв "Мой компьютер" и пройдясь по логическим разделам жесткого диска; посмотреть, какой тип файловой системы сопоставлен с каждым из них — пункт "Подробно" в левой панели окна.

Однако при работе с NTFS может наблюдаться некоторое уменьшение производительности. Это связано с тем, что при открытии любых папок и файлов система обновляет метки последнего доступа к объектам, что при большом их количестве может привести к снижению скорости доступа.

Кроме того, для совместимости со старыми приложениями Windows XP создает в разделе с NTFS специальную таблицу, содержащую все имена файлов и папок (данного логического диска), представленные в формате MS-DOS (8 символов в имени и 3 символа для расширения файла). В настоящее время подобная специфика NTFS не является актуальной, поэтому эту особенность желательно отключить для увеличения производительности.

Теперь перейдем непосредственно к описанию процесса блокировки этих ненужных для большинства пользователей механизмов NTFS:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ FileSystem];
3. В меню "Правка" выберите "Создать" — "Параметр DWORD";
4. Введите имя "NtfsDisableLastAccessUpdate", нажмите [Enter];
5. Повторите п.3;
6. Введите имя "NtfsDisable8dot3NameCreation", нажмите [Enter];
7. Пропишите значение "1" в каждом из созданных ключей. Нажмите OK;
8. Закройте редактор реестра и перегрузите систему.

Отключаем звуки, издаваемые спикером (встроенным динамиком компьютера)

При выполнении некоторых операций в среде Windows XP встроенный динамик компьютера может издавать звуки. В случае, если вам это мешает, можно убрать данное свойство, отключив соответствующие драйверы. Для этого выполните следующие шаги:

1. Щелкнув правой кнопкой мыши по значку "Мой компьютер", выберите в появившемся меню пункт "Свойства"; затем в диалоговом окне "Свойства системы", перейдя на вкладку "Оборудование", нажмите кнопку "Диспетчер устройств".
2. В меню "Вид" поставьте флажок напротив пункта "Показать скрытые устройства".
3. В списке окна "Диспетчер устройств" раскройте ветвь "Драйверы устройств не Plug and Play".
4. Дважды щелкните мышкой по устройству "Beep".
5. В окне "Свойства: Beep" на вкладке "Общие" в ниспадающем списке "Применение устройства" выберите "Это устройство не используется (отключено)". Нажмите OK.

Ускоряем работу интерфейса Windows XP

В том случае, если у вас установлено не слишком много оперативной памяти, то для более комфортной работы может понадобиться функция выключения визуальных эффектов (например, плавное развертывание меню), которые, несомненно, замедляют работу системы. Для этого выполните следующие шаги:

1. Щелкнув правой кнопкой мыши по значку "Мой компьютер", в появившемся меню выберите пункт "Свойства"; затем в диалоговом окне "Свойства системы", перейдя на вкладку "Дополнительно", нажмите кнопку "Параметры" из области "Быстродействие".
2. В окне "Параметры быстродействия" на вкладке "Визуальные эффекты" можете выключать каждый из них по отдельности либо все сразу, отметив пункт "Обеспечить наилучшее быстродействие".
3. Нажмите OK
4. Запустите редактор реестра (regedit.exe).
5. Откройте ветвь [HKEY_CURRENT_ USER\ SYSTEM\ Control Panel\ Desktop].
6. В правой панели редактора реестра выберите ключ MenuShowDelay. По умолчанию его значение равно 400 — время задержки в миллисекундах, по прошествии которого появляются раскрывающиеся меню.
7. Дважды щелкнув мышью по этому ключу, введите значение "0" для устранения задержки. Если же вы зададите значение "1", то будет блокирован эффект анимации при сворачивании/разворачивании окон. Нажмите OK.
8. Закройте редактор реестра и перегрузите систему.

Добиться ускорения запуска приложений, а также освободить немного оперативной памяти можно отключением отладчика Dr.Watson — специальной программы, которая позволяет проводить диагностику ошибок. Для этого сделайте следующее:

1. Запустите редактор реестра (regedit.exe);
2. Откройте ветвь [HKEY_LOCAL_MA-CHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ AeDebug];
3. В правой панели редактора реестра дважды щелкните мышкой по ключу Auto и введите значение "0". Нажмите OK;
4. Закройте редактор реестра и перегрузите систему.

Кроме того, можно отключить загрузку ненужных системных служб, что также скажется на увеличении быстродействия. Хотелось бы заметить, что эта процедура является небезопасной, так как это может привести к неработоспособности системы, потому тщательно проверяйте то, что вы делаете. Для выполнения этой операции проделайте следующие шаги:

1. Откройте "Панель управления" через меню "Пуск". Выберите пункт "Администрирование", затем в появившемся окне перейдите на диалог "Службы". Здесь есть список служб, каждая из которых снабжена пометками о своем текущем состоянии и типе запуска.
2. Дважды щелкните по имени службы, отключить которую вы хотите. При этом вы перейдете в диалоговое окно свойств, в котором есть область "Тип запуска" с ниспадающим меню. Здесь вам необходимо выбрать пункт "Отключено".
3. Нажмите OK.

Службы, которые могут быть отключены (в зависимости от потребностей пользователя), выбираются из следующего, далеко не полного, списка: DHCP-клиент.

Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то служба не нужна.

Журнал событий. Занимается тем, что ведет журнал системных и программных событий, а также событий в системе безопасности. Если вы уверены, что в системе все оптимально настроено, то службу можно отключить.

Защищенное хранилище. Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если у вас нет сети (в том числе Internet) или высокий уровень безопасности не требуется, то данный сервис можно отключить.

Источник бесперебойного питания. Служба управляет работой бесперебойных источников питания (UPS). Если таковых нет, то ее можно отключить.

Обозреватель компьютеров. Обновляет список компьютеров в сети. Если у вас нет локальной сети, то службу можно отключить.

Оповещатель. Принимает и отправляет сообщения, посланные администратором. Если у вас нет сети и администратора, то службу можно отключить.

Планировщик задания. Отвечает за запуск определенных программ в нужное время. Например, можно так его настроить, чтобы каждый день запускалась проверка дисков или их дефрагментация. Если вам подобные функции не нужны, то эту службу можно отключить.

Сервер. Обеспечивает общий доступ к принтерам, папкам и файлам, а также поддержку процедуры удаленного вызова. В случае, если у вас нет ни сетевой карты, ни модема, данный сервис вам не нужен.

Сетевые подключения. Служба занимается управлением объектами в директории "Сеть и удаленный доступ к сети", то есть всеми сетевыми соединениями. Если нет сети, то служба становится не нужной.

Службы IPSEC. Сервис безопасности протокола TCP/IP. Если вы им не пользуетесь, то можно его выключить.

Телефония. Работает с модемом. Если модема нет, то сервис не нужен.

Telnet. Обеспечивает возможность соединения и удаленной работы с компьютерами по протоколу Telnet. Если вы уверены, что служба не пригодится, то данный сервис можно отключить.

Уведомление о системных событиях. Отслеживает системные события. Если вы уверены, что в системе все оптимально настроено, то службу можно отключить.

Удаленный реестр. Позволяет проводить удаленные манипуляции с реестром. Скорее всего, служба может быть полезной только администраторам сети.

Ускоряем работу с памятью Windows XP

реестре есть несколько ключей, модифицируя которые, вы можете ускорить работу подсистемы памяти Windows. Конечно, изменять параметры следует с большой осторожностью, поскольку неправильно введенные значения могут привести к полной неработоспособности системы. Следует заметить, что нижеописанные методики приведут к должному эффекту, только если у вас установлен достаточно большой объем оперативной памяти.

1. Запустите редактор реестра (regedit.exe).
2. Откройте ветвь [HKEY_LOCAL_MA-CHINE\ SYSTEM\ CurrentControlSet\ Control \ Session Manager\ Memory Management]. Здесь есть несколько ключей, модификация значений которых может нам помочь.
3. Ключ DisablePagingExecutive. При включении этого параметра ядро системы и драйверы не будут записываться в файл подкачки Windows (так называемый своп-файл, который представляет собой зарезервированное пространство на жестком диске, служащее временным хранилищем информации из оперативной памяти с целью освобождения последней), а останутся в оперативной памяти. Таким образом, система и приложения будут быстрее реагировать на действия пользователя, поскольку операции ввода/вывода данных из памяти выполняются с большей скоростью по сравнению с обменом данных на жестком диске. Для включения параметра присвойте данному ключу значение "1", чтобы выключить его — значение "0".
4. Ключ LargeSystemCache. Активация данного ключа, подобно предыдущему, заставляет Windows использовать память для хранения ядра системы (и, тем самым, ускоряет доступ к нему). Для включения параметра присвойте данному ключу значение "1", чтобы выключить его — значение "0".
5. Ключ IOPageLockLimit. Установка данной опции ускорит выполнение операций ввода/вывода при большом количестве передаваемых файлов. Оптимальное значение подбирается экспериментально. Цифры, из которых вы можете исходить, приблизительно следующие: если у вас установлено 32 Мб оперативной памяти, то параметр должен быть равен приблизительно 4 Мб, при 64 Мб — 8 Мб, 128 Мб — 16 Мб, 256 Мб и более — 64 Мб. Определять новое значение параметра необходимо в байтах. Потому, если, например, вы хотите установить новое значение в 16 Мб, умножьте 16 два раза на 1024.
6. Закройте редактор реестра и перегрузите систему.

Уменьшаем размер установленной Windows XP

Если у Вас возникает необходимость освободить место на жестком диске, вы можете уменьшить объем уже установленной и настроенной Windows XP удалением либо изменением тех или иных компонентов, которые не являются принципиально важными для пользователя.

Во-первых, можно удалить папку "%SystemRoot%\ DriverCache\ i386\ ", где "%SystemRoot%" есть путь системной директории Windows. Вообще-то, по этому адресу располагается набор необходимых драйверов, но в случае, если система уже установлена и в ближайшем будущем не предполагается изменение аппаратной части компьютера, то можно смело удалять данную папку. Впоследствии, если вам понадобится обновить оборудование компьютера, система просто потребует вставить CD-ROM с установочной копией Windows.

Во-вторых, существует так называемый кэш защищенных системных файлов. Это особая папка, в которой хранятся оригинальные копии важных файлов операционной системы. Если какой-либо из компонентов Windows повреждается, то происходит его автоматическое восстановление из кэша. Размер этой папки по умолчанию составляет примерно 400 Мб. Можно изменить размер кэша при помощи команды "sfc" (вводится в командной строке) с параметром "/cachesize", который и определит его объем. Далее необходимо вручную удалить эту директорию, причем если не задать "/cachesize" равным нулю ("sfc /cachesize=0"), то при следующей проверке защищенных системных файлов Windows вновь наполнит свой кэш до заданного по умолчанию объема.

В-третьих, для устойчивой работы Windows предлагает использовать восстановление системы. В случае появления каких-либо проблем эта функция поможет вернуть операционную систему в то состояние, каким оно было до появления неполадок (хотя, конечно, польза от применения этой возможности довольно-таки сомнительна). Однако, вместе с этим, растет и объем, занимаемый информацией по предыдущим состояниям Windows. Размер данных точек восстановления может достигать 20% от вместимости каждого из логических дисков. Для того чтобы полностью отключить данную функцию системы, вам необходимо проделать следующие шаги:

1. Щелкнув правой кнопкой мыши по значку "Мой компьютер", в появившемся меню выберите пункт "Свойства", затем в диалоговом окне "Свойства системы" перейдите на вкладку "Восстановление системы".
2. Поставьте флажок напротив пункта "Отключить восстановление системы на всех дисках".
3. Нажмите OK.

Попробуйте реализовать описанные выше советы на практике — и автор этой статьи абсолютно уверен, что результаты вас приятно удивят.

23.06.2003


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Новое:
  • Как в Windows XP установить протокол NetBEUI?
  • После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...
  • Как в Windows XP запускать программы как сервисы?
  • Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?
  • Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?
  • Как удалять файлы, минуя "мусорную корзину"?
  • Можно ли в WinXP снимать задачи из командной строки?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
  • Как восстановить повреждённый загрузчик XP?
  • Где хранится код активации Windows XP?
Общие вопросы
  • Что такое Windows XP?
  • Что включает в себя Windows XP Plus Pack?
  • Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?
  • Чем отличается WinXP Professional от WinXP Home?
  • Как русифицировать английскую Windows XP?
  • Есть ли в Windows XP средства для работы с видео?
  • Как в XP обстоят дела с совместимостью со старыми программами (играми)?
  • Как работает шифрование файлов?
  • Что такое Remote Assistance?
  • А Remote Desktop?
  • Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он?
  • Что такое NTFS?
  • В чем отличие NTFS4 от NTFS5?
  • Стоит ли переходить на NTFS? И как это сделать?
  • Что такое boot defrag и для чего это?
  • Можно ли установить WinXP так, чтобы остался и Windows 98?
  • Как корректно удалить WinXP/2K и восстановить Windows 95 или 98?
  • Что за режим выключения компьютера - Hibernate?
  • Что такое иконки Windows XP?
  • Можно ли в WinXP снимать задачи из командной строки"?
  • Как переименовать сразу несколько файлов?
  • Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?
Настройка системы
  • Можно ли уменьшить размер Windows XP?
  • А что это в XP хелп такой урезанный?
  • Что можно предпринять для оптимизации Windows XP?
  • Как удалить "скрытые" компоненты Windows XP?
  • Можно ли самому создать скин для Windows XP?
  • Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?
  • Позволяет ли эта версия Windows вносить изменения в файл config.sys?
  • Какие из драйверов больше подходят для WinXP - от NT или 2K?
  • Для чего нужна вкладка Compatibility в свойствах exe-файла?
  • Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?
  • Где находятся те утилиты, о которых говорится в обзоре Windows XP?
  • Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?
  • Можно ли в XP снимать с аудио-CD цифровой звук?
  • Как запустить дефрагментатор из контекстого меню Проводника?
  • Как выставить права пользователям, работающим на компьютере?
  • Как зайти в систему администратором (пользователь Administrator)?
  • Как включить mp3-кодирование с высоким битрейтом?
  • Как изменить интервал синхронизации системных часов компьютера с time-сервером?
  • Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?
  • Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?
  • А что, в XP нет своего факса?
  • Как удалять файлы, минуя "корзину"?
  • Как переименовать папку аккаунта Administrator?
  • Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?
  • Как мне залочить компьютер? Через Crtl+Alt+Del не получается...
  • Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически
  • Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...
  • Можно ли ввести компьютер в состояние Hibernate из командной строки?
  • Как изменить time-server, используемый для подстройки системного времени?
  • Можно ли отключить сообщение о недостатке свободного места на диске?
  • Как отключить появление предложения об отправке рапорта об ошибке?
  • Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?
  • Как добавить содержимое Рабочего стола в меню Start?
  • Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?
  • Как удалить с рабочего стола все системные иконки, включая корзину?
  • Как отключить автозапуск компакт-дисков?
  • Куда подевалась закладка Security на NTFS-дисках и почему так упростилась закладка Sharing?
  • Как назначить диску другую букву?
  • А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?
  • Можно ли отключить отображение zip-архивов как папок?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
  • Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?
  • Как в Windows XP запускать программы как сервисы?
Windows XP и сеть
  • После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...
  • Как в Windows XP установить протокол NetBEUI?
  • Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?
  • Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?
  • Как включить интернет-защиту?
  • Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?
  • Как включить роутинг?
Разрешение проблем
  • Система стала глючить или пропали системные шрифты
  • Почему вместо русских букв видны какие-то закорючки?
  • DOS: русские буквы видны, а вот раскладка не переключается. Что делать?
  • Для особо забывчивых: как создать дискету для сброса пароля
  • Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти
  • Установка Windows 9*/Me после установки Windows XP
  • Что делать, если после перезагрузки система не находит внешний модем?
  • Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?
Восстановление
  • Что представляет собой система восстановления Windows XP?
  • Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?
  • Система не загружается...
  • Как добавить прав в Recovery Console?
  • Как восстановить повреждённый загрузчик XP?
  • Где хранится код активации Windows XP?
  • Можно ли в WinXP сделать загрузочные дискеты?

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Общие вопросы

Что такое Windows XP?

Windowx XP - это новая операционная система, обьединяющая, по словам Microsoft, две существовавших ранее независимо друг от друга линейки Windows - "домашнюю" Windows 95/98/Me и "профессиональную" NT/2000. О моих первых впечателениях от знакомства с Windows XP можно узнать из заметки, которая так и называется - Windows XP: что это такое и с чем ее едят.

Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?

Конечно, и при этом будут сохранены все существующие настройки. Операционные системы Windows NT/2000 можно обновить до Windows XP Professional, а Windows 98/98SE/Me - до любой из двух редакций Windows XP (Home Edition и Professional). Windows XP, кстати, будет продаваться как в "полном" варианте, так и в виде обновления (стоимостью подешевше). Единственное условие - обновляемая операционная система должна иметь тот же язык интерфейса, что и устанавливаемая Windows XP, иначе обновление будет невозможно.

К сожалению, пользователи Windows 3.1, Windows 95 и Windows NT 3.51 лишены возможности обновить свою систему до Windows XP - установить Windows XP они, конечно, смогут, но имевшиеся настройки не сохранятся, да и ранее инсталлированные программы придется переустанавливать.

Чем отличается WinXP Professional от WinXP Home?

Чего же нет в Windows XP Home Edition? - А вот чего:

  • Отсутствует удаленный доступ к компьютеру, что делает невозможным подключение в удаленном режиме к компьютеру, работающему под управлением Windows XP, с любого другого компьютера под управлением Windows (а ведь эта функция очень полезна в случае необходимости работать с приложениями и данными, если часто находишься вдалеке от "основного" компьютера)
  • Нет доступа к файлам и папкам, хранящимся на общем сетевом диске даже во время отключения компьютера от сервера (эта фича, как я понимаю, нужна только в локальной сети)
  • Удалены функции по работе с серверами Microsoft Windows Server и системами управления предприятиям ("Home" ведь не является предприятием)
  • Еще один минус - отсутствует многоязычный пользовательский интерфейс, позволяющий менять язык интерфейса, чтобы работать с локализованными диалоговыми окнами, файлами справки, словарями, средствами проверки правописания и т.п. Другими словами, в WinXP Pro заложена возможность менять интерфейс самой операционной системы: сел за компьютер, к примеру, китаец, кликнул пару раз, и английская версия XP превратилась в китайскую (но это можно проделывать только в том случае, если будут установлены специальные языковые модули - в инсталляционном CD их нет).
  • Отсутствует возможность использования шифрования данных и управления доступа к ним
  • Нет масштабируемой поддержки процессора (Pro - вплоть до поддержки двусторонней многопроцессорной обработки), но у многих ли из нас многопроцессорные системы?
Обобщая: из Windows XP Home Edition исключены те компоненты, которые, по разумению Microsoft, не нужны при домашнем использовании операционной системы. Насколько верно выбраны те компоненты, что "не нужны", судить не берусь, но разница в стоимости двух редакций Windows XP настолько ощутима, что наверняка стоит задуматься, а так ли уж нужен, к примеру, удаленный доступ к компьютеру...

Как русифицировать английскую WinXP?

Частично (процентов на сорок) русифицировать интерфейс английской версии Windows XP Professional можно патчем, меняющим языковые ресурсы в парочке файлов. Подробности - здесь.

Есть ли в Windows XP средства для работы с видео?

Кроме фирменного медиаплеера (Windows Media Player 8), воспроизводящего локальные и потоковые файлы Windows Media, а также многие другие форматы аудио и видеофайлов, в Windows XP входит новый компонент - Movie Maker, предназначенный для создания и редактирования цифровых видеофильмов. Ну и, конечно, есть возможность пользоваться сканером, а также перегонять фотографии из цифрового фотоаппарата на жесткий диск компьютера.

Как в XP обстоят дела с совместимостью со старыми программами (играми)?

Несмотря на то, что ядро NT, являющееся основой Windows XP, накладывает некоторые ограничения на совместимость со старым программным обеспечением, однако (по сравнению с Windows 2000) положение явно улучшилось. Например, в старых досовских игрушках появился звук. Кроме этого, стоит отметить поддержку эмуляции Sound Blaster 2 и General MIDI, поэтому в Windows XP без проблем будут работать со звуком такие "старички", как, к примеру, Duke Nukem 3D, Warcraft 1/2 или Dune 2. Наконец, не стоит забывать о таком нововведении, как режим совместимости...

Как работает шифрование файлов?

По умолчанию служба шифрования, имеющаяся в Windows XP, запускается автоматически при загрузке операционной системы, поэтому никакого дополнительного ее включения не требуется. А вот для того, чтобы зашифровать конкретный файл или папку, нужно проделать следующее: щелкаем правой кнопкой мыши по файлу/папке, выбираем в меню пункт Properties и нажимаем в появившемся окошке (на вкладке General) кнопку Advanced. После открытия новой вкладки отмечаем там пункт "Encrypt contents to secure data". Маленькое замечание: шифровать допустимо только те файлы и папки, которые размещены на дисках с файловой системой NTFS; необходимо помнить, что шифруются только несжатые данные (в том случае, если зашифровать сжатый файл или папку, они будут разжаты); не допускается шифрование файлов, отмеченных как системные, как нельзя зашифровать и системную директорию (по умолчанию это папка c:/windows). И еще: не удивляйтесь, что внешне после зашифровки файла или папки ничего не изменится - хозяин зашифрованных данных может обращаться с ними точно так же, как и с незашифрованными, а вот для всех остальных, кто войдет в систему под другим логином, зашифрованные данные окажутся недоступными...

Что такое Remote Assistance?

Remote Assistance (удаленная помощь) - еще одно новшество, включенное в Windows XP (по-моему, только в версию Pro). Теперь представители группы техподдержки могут не выезжать к пользователю, чтобы, например, научить, как менять разрешение экрана, а подключиться к его компьютеру и рассказать и, если вы разрешите, показать, как это делается - то есть удаленно настроить компьютер или устранить какую-либо неполадку в операционной системе. Естественно, удаленная помощь может быть оказана не только специалистами техподдержки, но и, например, вашим приятелем, разбирающемся в компьютерах.

А Remote Desktop?

Remote Desktop (удаленный рабочий стол) позволяет получить практически полное управление над удаленным компьютером. Весьма полезная вещь, если вы, находясь, к примеру, дома, решите поработать на компьютере, установленном на работе...

Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он нужен?

WinSxS, или Windows Side by Side (бок о бок), является еще одним новшеством Windows XP. Microsoft, озаботившись криворукостью программистов, создала систему, позволяющую сохранять несколько версий одинаковых библиотек (DLL) и использовать при необходимости именно ту, что требует конкретная программа. Дело в том, что некоторые программы почему-то считают, что только они имеют нужную версию DLL, и перезаписывают при инсталляции даже более новую версию библиотеки, что может привести ко всякого рода неприятностям, поэтому, если какая-нибудь программа вздумает беспричинно заменить уже имеющуюся в системном каталоге DLL, операционная система поместит сомнительную библиотеку в специальную папку (WinSxS), а дурная программа так и останется уверенной, что сделала свое черное дело...

Что такое NTFS?

NTFS - это файловая система, которую не понимает Windows 9*/Me. Учитывая, что NT - это сокращение от английского "новая технология", можно предположить, что в NTFS есть много чего хорошего, и это действительно так. Вот лишь краткий перечень преимуществ NTFS:

- возможность работать с большими дисками, причем с действительно большими - теоретически NTFS поддерживает диски размером до 16777216 терабайт ("теоретически" потому, что диски такого огромного размера вряд ли появятся даже в не очень ближайшем будущем)

- надежность. Не вдаваясь в подробности, подчеркну, что NTFS устроена так, что в случае копирования, перемещения или удаления файлов (папок) гарантируется абсолютная сохранность данных. Проще говоря, чтобы не случилось, будь то сбой питания во время выполнения задачи или какая-то другая напасть вроде кривого пальца, нажавшего в самый неподходящий момент кнопку Reset, операционная система после перезагрузки будет работать без ошибок, а, к примеру, перемещенный только наполовину до момента аварии файл останется целым и невредимым. Кроме этого, NTFS имеет не одну, а две копии аналога FAT (MFT - Master File Table), и при повреждении одной копии система при перезагрузке использует другую - целую - копию MFT, одновременно создавая (с учетом повреждений) ее копию.

Короче говоря, надежность и устойчивость - это главные отличительные черты NTFS. А из "мелочей" - зищищенность, включающая в себя возможность определить каждому пользователю его права буквально на каждый файл (открытие, закрытие, чтение, запись), а также допустимость шифрования файлов.

В чем отличие NTFS4 от NTFS5?

В XP используется файловая система NTFS5. Ее основное отличие от NTFS4, используемой в Windows NT, заключается в дальнейшем расширении функциональности, и прежде всего - в возможности квотирования. Квотирование позволяет ограничить каждому пользователю максимальный обьем дискового пространства, которое он сможет использовать. Выделено ему, к примеру, 50 мегабайт, и больше "захапать" ему никак не удасться.

Полезность этой функции наверняка оценят в крупных организациях /сетях (диски ведь не безразмерные), да и дома такая опция может пригодиться: выделил, например, ребенку столько-то места, и можно быть уверенным, что диск не будет захламлен тоннами мусора.

Другими характерными чертами NTFS5 являются возможность поиска файла по имени его владельца, а также появление функции точки монтирования (junction point), позволяющей присоединить любой диск в любое место файловой системы. Например, можно присоединить диск D в каталог Documents, который находится на диске С, и тогда, зайдя в папку С:\Documents, мы увидим содержимое корневого каталога диска C (что-то я перемудрил с каталогами/папками, поэтому для новичков поясню, что каталог и папка - это одно и то же). Но самое интересное заключается в другом: убрав через Computer management / Disk Management букву, присвоенную этому диску, мы получим один обьединенный диск - диск С. Монтирование / размонтирование производится через меню Change disk letter and path, в которое можно попасть через Administrative Tools / Computer management / Disk Management

Стоит ли переходить на NTFS? И как это сделать?

Вопрос, конечно, интересный... NTFS из-за своей системы безопасности, вернее, из-за необходимости загружать специализированные службы, поддерживающие ее, работает несколько медленнее, чем FAT; кроме этого (и что даже важнее), NTFS занимает больше памяти, поэтому, если оперативной памяти меньше 128 мегабайт, переходить на NTFS не стоит. А вот если оперативки больше, то и впрямь стоит задуматься о преимуществах NTFS...

А теперь - о том, как перейти с FAT на NTFS и при не потерять данные. Во-первых, при установке WIndows XP это можно сделать автоматически - в соответствующий момент ответив утвердительно на соответствующий вопрос. Можно преобразовать FAT16 (или FAT32) в NTFS и позже - воспользовавшись командой CONVERT. Синтаксис этой команды такой:
convert [диск] /fs:ntfs [/v]
где V - параметр, позволяющий не гадать при следующей перезагрузке системы, идет конвертация или нет, а видеть соответствующие сообщения о происходящем процессе на экране.

Кроме встроенных средств Windows XP, для преобразования FAT в NTFS можно воспользоваться замечательной программой Partition Magic, позволяющей к тому же при необходимости выполнить и обратное преобразование - из NTFS в FAT, и тоже без потери данных.

Что такое boot defrag и для чего это?

Суть boot defrag заключается в дефрагментации тех файлов, что нужны для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее... Все равно хотите отключить? - Пожалуйста: открываем реестр, идем в HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Dfrg \BootOptimizeFunction и меняем там значение параметра Enable. Y - дефрагментация включена, N - выключена.

Можно ли установить WinXP так, чтобы остался и Windows 98?

Windows XP такое позволяет - в этом случае в начальной стадии загрузки компьютера можно будет выбирать, какая операционная система должна быть загружена. Для этого следует в начале инсталляции Windows XP отказаться от предложения обновить систему и указать другой каталог для установки Wundows XP - не предлагаемый по умолчанию каталог Windows (где у вас уже стоит Windows 9*), а, например, WinXP.
Несколько замечаний:
- нежелательно устанавливать Windows XP второй системой на тот же раздел жесткого диска, где уже стоит Windows 9*/Me (Windows XP при инсталляции перезапишет некоторые файлы их новыми версиями, в результате чего в Windows 9*/Me кое-что перестанет работать - например, Outlook Express)
- установка Windows XP второй операционной системой возможна только в том случае, если имеющийся у вас инсталляционный CD предназначен для установки Windows XP "с нуля", а не для обновления операционной системы.

Что за режим выключения компьютера - Hibernate?

Hibernate (в русской версии XP - "спящий режим") - это режим "засыпания" операционной системы, заключающийся в том, что все содержимое оперативной памяти сохраняется на жестком диске, монитор и жесткие диски отключаются, после чего компьютер выключается. Главной особенностью этого режима является то, что при перезапуске компьютера состояние рабочего стола полностью восстанавливается, т.е. система полностью восстанавливает свое состояние, имевшееся на момент "засыпания". Проще говоря, на чем вы остановились, выключив компьютер его переводом в спящий режим, с того же самого места и сможете продолжить свою работу или игру: все приложения будут работать точно также, как и до "спячки" - будто ее и не было вовсе.

Можно ли в WinXP снимать задачи из командной строки?

Для этого следует набрать
taskkill /pid и номер задачи или просто
tskill и номер процесса.
Номер можно узнать, набрав команду tasklist - еще одну новую команду, которая к тому же сообщит многое другое о том, что происходит в операционной системе.

Как переименовать сразу несколько файлов?

Выделяем в окне группу файлов, щелкаем по любому из них правой кнопкой и, если нужно, переименовываем. Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках.
Кстати в Windows XP есть еще одна любопытная опция - возможность "разложить" значки в папках по алфавиту: после выбора в меню View -> Arrange Icon By... -> Show In Groups значки окажутся организованными в упорядоченные по алфавиту группы.

Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?

В Windows XP такое предусмотрено, но только в том случае, если известен пароль этого пользователя: щелкаем на исполняемом файле программы (или ее ярлыку) правой кнопкой, выбираем Run As... (Запуск от имени) и вводим имя пользователя и пароль - они будут действовать до окончания текущего сеанса работы. Одно из применений такой опции - получение прав администратора для установки новой программы.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Настройка системы

Можно ли уменьшить размер Windows XP?

В том случае, если уже установлено все оборудование, можно удалить папку %SystemRoot%\Driver Cache\i386\ (т.е. по умолчанию C:\Windows\Driver Cache\i386\). Правда, в этом случае при добавлении любого нового оборудования Windows будет запрашивать установочный CD.
Можно также отключить System Restore, удалив тем самым информацию, которая хранится в папке System Volume Informatiоn.

И еще одну папку можно удалить - %SystemRoot%\system32\dllcache\ (в ней хранятся защищенные системные файлы, используемые для автоматического восстановления оригиналов в случае их повреждения). Кстати, по умолчанию размер этой папки - 400 мб (он задается в реестре параметром SFCQuota (0xFFFFFFFF), находящемся в ключе HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon), но его можно изменить до нуля командой sfc: sfc /cachesize=0 (если поставить, например, 10, то размер папки уменьшится до 10 мб)

А что это в XP хелп такой урезанный?

На самом деле система помощи в Windows XP даже более подробная, чем, например, в NT, но она разделена на несколько частей - та, что появляется через через пункт Help and Support кнопки Start, предназначена, выражаясь помягче, для неквалифицированных пользователей. Этот "главный" хелп не содержит сведений об очень многих аспектах управления операционной системой, поэтому, чтобы почерпнуть действительно важную информацию, придется прогуляться по файлам помощи отдельных апплетов, например тех, что находятся в разделе Computer Management (Start / Control Panel).

Что можно предпринять для оптимизации Windows XP?

Для начала - отключить ненужные системные службы (сервисы), ускорив тем самым работу системы. Заодно и памяти немного освободиться...

Вот список служб, которые, в принципе, можно безбоязненно отключить:

  • Automatic Updates (Автоматичесткое обновление). Учитывая, что обновлять систему можно и вручную, имеет смысл отключить эту службу. Особенно в том случае, если нет постоянного соединения с Интернетом. Следует только не забыть не только отключить службу, но и отменить Automatic Updates в одноименной закладке System Properties.
  • Computer Browser. Занимается обновлением списка компьютеров в сети. При отсутствии сети не нужна.
  • Cryptographic Service. Служба безопасного обмена ключами и шифрования передаваемых данных в локальной сети. Если локальной сети нет, то эту службу можно отключить, если сеть есть - думайте сами...
  • DHCP client. Занимается автоматическим распределением IP-адресов. Если сети нет (ни локальной, ни Интернета - даже через модем), то эта служба не нужна.
  • Event Log. Ведет лог системных, программных событий и событий в системы безопасности. В принципе, можно отключить. Ничего страшного не произойдет.
  • Messenger. Отвечает за прием и отправку сообщений, посланных администратором. При отсутствии сети (и администратора) абсолютно бесполезна.
  • Network Connections. Управление всеми сетевыми соединениями. Если нет сети (в том числе нет и Интернета), то эта служба не нужна.
  • Print Spooler (Спулер печати). Если принтера нет, то он не нужен.
  • Portable media serial number. Отвечает за получение серийного номера переносного музыкального устройства, подключаемого к компьютеру. Лично у меня ничего подобного нет...
  • Protected Storage. Защита важных данных, в т.ч. ключей пользователей; запрещает неавторизированный доступ. Если нет сети (в том числе и Интернета), то эту службу можно отключить (если безопасность не волнует - можно отключить и при наличии сети).
  • Remote Registry Service. Предназначена для удалённого управления реестром (нужна только администраторам сети).
  • System Event Notification. Отслеживает системные события. Если все уже настроено и нормально работает, можно отключить.
  • SSDP Discovery. Обеспечивает работу подключаемых устройств, поддерживающих UPnP (универсальная система Plug & Play, которая, по задумке, должна связывать компьютер с самой различной бытовой техникой, вроде пылесоса или холодильника. Мне такой техники пока не встречалось).
  • Task Scheduler. Запуск приложений в заданное время. Если эта возможность не используется, эту службу можно отключить.
  • Telephony. Взаимодействие с модемом. Нет модема - отключаем службу
  • Telnet. Обеспечивает возможность соединения и удалённой работы по протоколу telnet. Если не знаете (и не хотите знать), что это такое, то эту службу можно отключить.
  • Uninterruptible power supply. Управляет работой бесперебойных источников питания (UPS). Если UPS с обратной связью нет, то не нужна.
  • Terminal Service. Служит для подключения к компьютеру по сети и удаленного управления им. Домашнему пользователю она в общем-то ни к чему.
  • Windows time. Синхронизирует время на локальной машине и сервере; если нет time-сервера, то и служба не нужна.
  • Wireless zero configuration. Служба автоматической настройки беспроводных сетей стандарта 803.11 и 803.11b. Если беспроводной сети нет, то зачем работать этой службе?

    Подчеркну, что этот список - не окончательный, потому что необходимость той или иной системной службы определяется теми задачами, которые выполняются на конкретном компьютере, поэтому каждый должен решать сам, что можно отключить, а что нет. Главное - не переборщить, помня, что последствия необдуманных действий могут быть непредсказуемыми. И еще о последствиях. Для того, чтобы уменьшить риск "запороть" систему, имеет смысл перед началом эксперименетов со службами сделать резервную копию той ветви реестра, что отвечает за запуск системных служб: открываем regedit, идем в HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Serviсes, выбираем в меню File, а там - пункт Export Registry Key.

    Еще один метод, позволяющий ускорить работу системы и несколько освободить занимаемую ею оперативную память, заключается в отключении Dr.Watson'a, отладчика, запускаемого по умолчании при каждом сбое в работе приложений. Чтобы отключить этого "доктора", нужно будет в реестре найти ключ HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows NT \CurrentVersion \AeDebug и изменить в нем значение параметра Auto на 0. После такой модификации реестра при возникновении сбоя в работе приложения система будет предлагать либо закрыть его, либо передать отладчику для отладки (если выбрать второе, то запустится Dr.Watson и создаст лог-файл).

    Следующий этап - оптимизация интерфейса, призванная ускорить его работу. Заходим в System Properties, открываем закладку Advanced, нажимаем в разделе Performance кнопку Settings и в открывшейся вкладке Visual Effects отмечаем пункт Adjust for best performance, отключая тем самым абсолютно все эффекты. А можно отключить их и по отдельности, оставив те, без которых прожить ну никак нельзя...

    Теперь примемся за стартовое меню. Изначально оно открывается с некоторой задержкой (по умолчанию - 400 миллисекунд), регулировать которую можно, изменяя в реестре значение ключа MenuShowDelay, находящегося по адресу HKEY_CURRENT_USER \ControlPanel \Desktop. В случае установки для этого параметра значения 0 меню будет появляться без задержки.

    Там же - в реестре - находится еще один параметр, изменение которого приведет к некоторому ускорению работы интерфейса - MinAnimate, включающий анимацию при сворачивании и разворачивании окон, находится по адресу HKEY_CURRENT_USER \ControlPanel \Desktop \WindowsMetrics. Значение 1 - эффект анимации включен, 0 - выключен. Если этого ключа в реестре нет, то создайте его (тип - String). И не забудьте - для вступления подобных изменений в силу необходимо перезагрузить компьютер.

    Открытие на NTFS-разделе папок с большим количеством файлов происходит довольно медлено, потому что Windows каждый раз обновляет метку последнего доступа к файлам и на это, естественно, тратиться какое-то время. Для отключения этой функции нужно запустить regеdit и по адресу HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \FileSystem cоздать параметр типа DWord, назвав его NtfsDisableLastAccessUpdate и присвоив ему значение 1.

    Кроме всего перечисленного, для оптимизации работы системы можно воспользоваться программами, специально для этого предназначенным, например, Tweak-XP - набором из двух десятков утилит для настройки Windows XP.

    Как удалить "скрытые" компоненты Windows XP?

    В отличие от Windows 9*/NT, в процессе установки Windows XP нет возможности выбирать необходимые компоненты. На мой взгляд, это правильное решение Microsoft - сначала следует установить операционную систему со всеми ее прибамбасами, а уж затем, поработав, можно решать, что следует оставить, а что нет.

    Правда, и в этом случае получается, как сказал бы наш незабвенный Б.Н.Ельцин, в некотором роде заковыка: в окне "Add/Remove Windows Components", что присутствует в апплете "Add or Remove Programs" Контрольной панели, удалять-то практически нечего, потому что многие из составляющих Windows скрыты от шаловливых ручек не слишком опытных юзеров.

    Так что же, у этой проблемы нет решения? - Конечно же, решение есть. Открываем системную папку Inf (по умолчанию - C:\Windows\Inf), находим в ней файл sysoc.inf, открываем его и удаляем во всех строках слово HIDE. Главное при этом - оставить неизменным формат файла, то есть следует удалять только HIDE, оставляя запятые до и после этого слова.

    Для примера - исходная строка и та, что должна получиться:
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7

    Сохраняем файл sysoc.inf, открываем "Add/Remove Windows Components" и видим значительно более длинный список, чем тот, что был на этой страничке до проведения описанной выше операции. Правда, и в этом случае много удалить не получится.
    Кстати, точно также можно поступить и в случае с Windows 2000...

    Можно ли самому создать скин для Windows XP?

    Можно - недавно появилась программа Windowblinds XP, специально предназначенная для самостоятельного изменения внешнего вида Windows XP.

    Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?

    Можно, причем не только на свою фотографию, но и на любой другой графический файл, и сделать это очень просто: после клика по этой картинке выскочит окошко "User Аccount", в правой нижней части которого есть ссылка "Browse for more pictures" (обзор других картинок), с помощью которой и следует найти ту картинку/фотку, которая будет показываться напротив имени пользователя.

    Позволяет ли эта версия Windows вносить изменения в файл config.sys? А то в Миллениуме нельзя заставить компьютер запомнить, скажем, такую строку: files=200

    В Windows XP (как и в WinNT/2K) подобный файл называется config.nt. Он поддается модификации, в том числе и установке числа одновременно доступных файлов во время работы подсистемы MS-DOS. Следует только понимать, что в Windows XP, строго говоря, нет MS-DOS, а есть только ее эмуляция.

    Какие из драйверов больше подходят для WinXP - от NT или 2K?

    Я бы ответил на этот вопрос так: лучше всего подходят драйверы, специально написанные для Windows XP, но такой ответ, скорее всего, мало кого удовлетворит, поэтому продолжу. Как мне кажется, лучший способ подобрать недостающий драйвер - это метод научного тыка, заключающийся в последовательной установке всех драйверов, какие имеются, тем более что в Windows XP предусмотрен очень простой способ возврата к старой версии драйвера - одним нажатием на кнопку "Roll Back Driver", которая находится на вкладке "Driver" окна со свойствами соответствующего устройства.

    Для чего нужна вкладка Compatibility в свойствах exe-файла?

    Эта вкладка предназначена для "обмана" программ.
    Учитывая, что Windows XP является вроде как бы "гибридной" операционной системой, на которую будут переходить пользователи и Windows 98, и Windows NT, и Windows 2000, Microsoft приняла решение не ждать, пока разработчики программного обеспечения выпустят патчи и обновленные версии программ, совместимые с Windows XP, а сама добавила в операционную систему специальную функцию "режим совместимости", который как раз и настраивается на вкладке Compatibility (совместимость).

    Поставив на этой вкладке галку напротив надписи "Run this program in compatibility mode for" и выбрав одну из предложенных операционных систем (Windows 95, 98, Me, NT или 2000), мы тем самым заставим программу поверить, что она работает не в Windows XP, а в выбранной операционной системе. Стоит отметить, что Windows XP не просто сообщает программе, что она - не Windows XP, но и эмулирует структуру системного реестра соответствующей операционной системы, что позволяет заставить нормально работать в Windows XP большинство из программ, формально не предназначенных для работы в этой ОС, и только некоторые из них (те, что проверяют ядро ОС) не поддадутся на эту уловку и откажутся работать.

    На этой же вкладке, кстати, можно изменить и некоторые другие параметры запуска конкретного приложения - установить разрешение экрана 640х480, уменьшить цветность до 256 цветов и отключить общий для всей операционной системы скин.

    Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?

    Не дает - и правильно делает: незачем систему ломать. Это срабатывает система защиты файлов, которая не отключается для загрузочного раздела жесткого диска даже в том случае, если отключить Систему Восстановления (System Restore), убрав соответствующую галку на странице ее настройки.

    С другой стороны, если нельзя, но очень хочется, и при этом вы ясно представляете, что делаете и чем все это дело может закончиться (а итог может быть весьма плачевным), то можно воспользоваться крохотной утилитой по имени SetSfс, позволяющей изменить параметры системы восстановления Windows 2K/XP, а также отключить ее полностью - в том числе и для загрузочного раздела.

    Где находятся те утилиты, о которых говорится в обзоре Windows XP?

    В процессе установки Windows XP они не автоматически не устанавливаются, поэтому их придется инсталлировать уже после установки операционной системы. А находятся они на установочном компакт-диске Windows XP Pro, в папке Support\Tools

    Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?

    Выпущен пакет Powertoys для Windows XP, включающий утилиту для "тонкой" настройки Tweak UI, а также мелкие, но полезные дополнения: Faster User Switcher, Task Switcher, Slide Show Generator, ISO Image Burner и некоторые другие, в том числе графический калькулятор, виртуальный менеджер рабочих экранов и добавочка для управления Windows Media Player из системной панели. Этот пакет уже включен в каталог Softodrom.ru: Powertoys for Windows XP

    Можно ли в XP снимать с аудио-CD цифровой звук?

    Можно - Windows XP допускает передачу аудиоданных с компакт-диска в цифровом виде через IDE-шлейф (без использования проводка, которым обычно соединяют CD-ROM со звуковой картой). Чтобы воспользоваться такой очень полезной возможностью, следует зайти через Control Panel /System на вкладку Hardware, там нажать на кнопку Device Manager и выбрать CD-ROM, в свойствах которого (Properties CD) на одноименной закладке поставить галку напротив "Enable Digital CD-Audio for this CD-ROM device". После этого тот проводок, о котором говорилось выше, можно выбросить.

    Как запустить дефрагментатор из контекстого меню Проводника?

    Загрузите файл context_defrag.vbs. После установки (для этого достаточно щелкнуть по файлу) в контекстном меню Проводника появится пункт defrag, позволяющий быстро запустить дефрагментацию жесткого диска

    Как выставить права пользователям, работающим на компьютере?

    В Windows XP каждому пользователю можно выставить определенные права - что делать разрешается, а что - нет, причем, если пользователей много, их можно распределить по группам, присвоив каждой группе определенные права. Управление пользователями и группами производится через апплет Users Accounts, находящийся в Контрольной панели. Сразу после инсталляции WinXP в этом апплете можно будет увидеть двух пользователей - того, кто был создан в процессе установки (с правами администратора) и второго - гостя (Guest), по умолчанию отключенного. Вообще-то сразу же после установки появляются еще несколько пользователей (например, знакомый еще со времен NT пользователь по имени Administrator), но они не показаны в списке - таков общий принцип построения Windows XP: операционная система предназначена для всех, другими словами - и для чайников тоже, поэтому до "лишнего" можно добраться только после некоторых дополнительных манипуляций. В общем-то, это правильно - меньше дров будет наломано...

    В случае, если вы обладаете правами администратора, апплет Users Accounts даст возможность добавлять или удалять пользователей, менять пользователю пароль или сооветствующую ему картинку-пиктограмму, а также изменять метод входа в систему. По умолчанию при входе в систему показывается экран Welcome screen с пиктограммами и именами пользователей, но, если выбрать пункт "Change the way users log on and off" и убрать в появившемся окне галку с пункта "Use the Welcome screen", вход в систему будет происходить по NT-шному - через окно, в котором предлагается ввести имя пользователя и пароль.

    А где же группы, где возможность редактирования уже существующих пользователей, короче говоря, где все то, что было в NT/2K? - Чтобы получить доступ к контролю над пользователями, который можно назвать "полным", придется заглянуть в апплет Computer Management (Start /Administrative Tools /Computer Management) и кликнуть по плюсику, раскрывающему Local Users and Groups...

    Но и это не все хитрости: есть еще апплет Local Security Setings (он там же, в Administrative Tools), с помощью которого можно, например, изменить время жизни паролей и выставить конкретные права каждой имеющейся группе пользователей.

    Как зайти в систему администатором (пользователь Administrator)?

    Самый простой способ - отключить режим Welcome screen (см. предыдущий вопрос). Кроме этого, залогиниться как Administrator можно, если начать загрузку системы в режиме Safe mode. Наконец, есть и третий, самый хитрый способ: после появления экрана "Welcome screen" дважды нажмите Ctrl+Alt+Del

    Как включить MP3-кодирование с высоким битрейтом?

    Создайте reg-файл (назвав его, например, mp3.reg) следующего содержания:

    Regedit 4
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]
    [HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
    "LowRate"=dword:0000dac0
    "MediumRate"=dword:0000fa00
    "MediumHighRate"=dword:0001f400
    "HighRate"=dword:0002ee00

    и импортируйте его в реестр (щелчок по файлу - установить). После внесения такого изменения в реестр включится встроенный MP3 кодек, но его максимальный битрейт будет ограничен 192 килобитами.
    Второй способ кодирования с высоким битрейтом - использование для кодирования не встроенного, а внешнего MP3-кодека.

    Как изменить интервал синхронизации системных часов компьютера с time-сервером?

    Находим в реестре ключ
    HKEY_LOCAL_MACHINE \SYSTEM \ControlSet001 \Services \W32Time \TimeProviders \NtpClient
    Выбираем параметр SpecialPollInterval и изменяем его значение: оно должно быть равно требуемому интервалу между синхронизациями системного времени, выраженному в секундах (например, 172800 - 2 дня, 43200 - 12 часов)

    Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?

    Режим группирования нескольких открытых окон в одну кнопку - одно из многочисленных не сразу заметных, но очень удобных нововведений. Смысл его заключается в том, что при достижении числа открытых окон определенного значения они группируются и отображаются на панели задач в виде одной кнопки, щелчок по которой вызывает ниспадающее меню со всеми открытыми окнами этой программы. Очень удобная функция, например, при прогулках по Сети с помощью Internet Explorer - уже первый десяток открытых страниц без использования режима группировки донельзя захламляет панель задач.

    Для изменения числа открытых окон программы, которое приводит к включению режима их группировки, нужно запустить Regedit, найти в реестре ключ
    HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Explorer \Advanced
    и изменить параметр TaskbarGroupSize. Если такого параметра нет, то нужно его создать (в виде DWORD) и настроить: щелкаем по параметру правой кнопкой мыши и выбираем в контекстном меню пункт Modify (к примеру, установка для TaskbarGroupSize значения 5 заставит Windows включать режим группировки при пяти открытых однотипных окнах)

    Кстати: а как вообще включить этот режим группировки? Очень просто: щелкаем правой кнопкой по панели задач, выбираем пункт Properties и на вкладке Панель задач ставим галку напротив "Сгруппировать похожие кнопки..."

    Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?

    Элементарно: открываем реестр, находим ключ HKEY_USERS \.DEFAULT \Control Panel \Desktop, находим в нем параметр FontSmoothingType и изменяем его значение на 2. При следующей перезагрузке системы ждем появления экрана "Welkome", после чего наслаждаемся полученным эффектом...

    А что, в XP нет своего факса?

    Есть, но автоматически при инсталляции операционной системы Cлужба факсов не устанавливается. Чтобы воспользоваться ее возможностями, включающими в себя отправку, прием и контроль факсов, следует через Start / Control Panel открыть апплет 'Установка или удаление программ', щелкнуть там по иконке 'Установка/удаление компонентов Windows', отметить пункт 'Fax Services' и нажать кнопку Next (Далее). После этого последует просьба вставить инсталляционный компакт-диск с Windows XP и начнется процесс установки факс-службы.

    Как удалять файлы, минуя "мусорную корзину"?

    Start -> Run и даем команду gpedit.msc
    В открывшейся консоли выбирает User Configuration, Administrative Templates, Windows Components, Windows Explorer и отмечаем "Do not move deleted files to the Recycle Bin" (не уверен, что подобный пункт есть в Windows XP Home Edition)

    Как переименовать папку аккаунта Administrator?

    Сначала входим в систему под аккаунтом Administrator и создаем в директории Documents and Settings папку с нужным именем. Затем через контекстное меню My computer / Properties / Advanced добираемся до User Profiles, где сопируем профиль администратора в созданную папку. После этого открываем в реестре ключ HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList и находим там ветвь, соответствующую профилю администратора (по значению ключа ProfileImagePath) и исправляем в ней этот параметр на нужный. Теперь можно перелогиниться...

    Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?

    Открываем реестр и находим ключ
    HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Memory Management
    где выставляем значение "ClearPageFileAtShutdown"=dword:00000001
    Следует отметить, что этот ключ не стирает файл подкачки, а очищает, т.е. заполняет его нулями, но сам файл на диске остается. Такого же рузультата, ксати, можно добиться и через апплет Local Security Policy, находящийся в Administrative Tools (раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down).

    Как мне залочить компьютер? Через Crtl+Alt+Del не получается...

    Теперь для этого установлена другая комбинация - Win+L. Кроме этого, можно создать *.cmd файл и лочить машину, запуская его. Содержание этого файла должно быть таким:
    rundll32.exe user32.dll,LockWorkStation

    Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически?

    В реестре по адресу HKCU\Control Panel\Desktop находится ключ HungAppTimeout, значение которого определяет интервал (в миллисекундах), через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветви находятся ключи WaitToKillServiceTimeout (задаёт время ожидания перед "убийством" зависшей службы), и AutoEndTasks (при установке его значения в 1 системе дается разрешение убивать зависшие процессы самостоятельно).

    Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...

    При загрузке операционной системы каманды на запуск некоторых программ даются из системного реестра, где имеется специальная ветвь HLKM \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \RUN (и аналогичная ...\RUNONCE). В этих ветвях записаны значения, каждое из которых соответствует одной запускаемой при старте программе...
    Только не стоит спешить - если не уверены, что за программа записана, перед удалением обязательно сохраните выбранные строчки (через пункт редактора реестра "экспорт").
    На закуску - маленький секрет. В Windows XP есть утилитка под названием msconfig, которая позволяет очень комфортно управлять параметрами загрузки. Запустить эта утилиту можно через кнопку Start (Пуск) - Run... (Выполнить).

    Можно ли ввести компьютер в состояние hibernate из командной строки?

    Можно. Делается это такой вот командой:
    %windir%\System32\rundll32.exe powrprof.dll,SetSuspendState

    Как изменить time-server, используемый для подстройки системного времени?

    Это можно сделать через апплет "Date and Time Properties", до которого проще всего добраться с помощью двойного щелчка по времени в системном лотке; изменение адреса time-сервера производится в этом апплете на вкладке Internet Time.

    Можно ли отключить сообщение о недостаточности свободного места на диске?

    Можно. Для блокирования появления такого сообщения следует открыть реестр, найти ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explоrer
    и вписать в него новый параметр NoLowDiskSpaceChecks типа DWORD, присвоив ему значение 1.

    Как отключить появление предложения об отправке рапорта об ошибке?

    Запускаем утилиту msconfig (кнопка Start -> Run -> msconfig), выбираем вкладку Services и снимаем там галку с пункта Error Reporting Service, после чего нажимаем кнопку ОК и утвердительно отвечаем на предложение перезагрузиться. Или отрицательно, но в этом случае отключение службы отправки рапортов об ошибках произойдет только после следующей перезагрузки операционной системы.

    Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?

    Можно, но для этого необходимо, чтобы ярлык от этой папки находился на рабочем столе. Находим папку, которую требуется открывать с помощью горячих клавиш, щелкаем по ней правой кнопкой мыши, выбираем пункт Sent To, а в нем - команду Desktop (create Shortcut); или - "захватываем" папку правой кнопкой, передвигаем ее на рабочий стол, отпускаем и в открывшемся меню выбираем пункт Create Shortcuts Here. После этого щелкаем той же правой кнопкой по созданному ярлыку, выбираем в контекстном меню пункт Properties и на вкладке Shortcut в поле Shortcut key (по-русски это, вероятно, будет звучать как Быстрый вызов) впечатываем ту комбинацию клавиш, которая должна будет открывать папку. Необходимо учесть, что в виде горячих клавиш можно использовать как комбинации CTRL+ALT+буква, так и CTRL+SHIFT+буква.

    Как добавить содержимое Рабочего стола в меню Start?

    Находим в системном реестре ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders. В нем есть параметр Desktop, имеющий по умолчанию значение "%USERPROFILE%\Desktop". Изменяем это значение на "%USERPROFILE%\Start Menu\Desktop". Кроме этого, нужно будет скопировать папку %USERPROFILE%\Desktop (папка %USERPROFILE% находится в папке Documents and Settings) в папку %USERPROFILE%\Start Menu\Desktop и перезагрузиться, после чего в меню, появляющемся при нажатии на кнопку Start, появится раскрывающееся субменю Desktop.

    Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?

    Начнем по порядку. Pagefile.sys - это своп-файл (или виртуальная память), куда система сбрасывает из оперативной памяти временно ненужные данные. Его размер по умолчанию выбирается самой операционной системой, но он может быть изменен через Start -> Control Panel -> System -> Advanced -> Perfomance -> Settings. После нажатия на кнопку Settings появится двухвкладочное окно, выбираем в нем вкладку Advanced, давим на кнопку Change virtual memory и устанавливаем тот размер виртуальной памяти, который считаем достаточным. Там же, кстати, можно выбрать, на каком из разделов жесткого диска должен находиться своп-файл.
    Hyberfil.sys - файл, используемый системой при переходе в "спящий" режим. Его размер равен размеру оперативной памяти; в принципе, если вы не собираетесь использовать для выключения компьютера спящий режим (Hybernate) (хотя лично я считаю этот режим выключения очень удобным), то можно отключить его (Start -> Control Panel -> Power Options -> Hibernate, где снять галку с Enable Hibernation), после чего файл Hyberfil.sys окажется ненужным...

    Как удалить с рабочего стола все системные иконки, включая корзину?

    Для этого придется или вручную вносить изменения в системный реестр, или - что значительно проще и безопаснее - воспользоваться одной из специализировнных утилит, например - бесплатным комплектом Powertoys for Windows XP производства Microsoft. Powertoys - это набор расширений для XP, включающий, кроме всего прочего, TweakUI - утилиту для настройки пользовательского интерфейса, с помощью которой можно много чего изменить или отключить, в том числе и определить, какие из системных иконок должны показываться на рабочем столе.

    Как отключить автозапуск компакт-дисков?

    Настройка реакции системы на вставленный в привод компакт-диск производится через CD Properties, вызываемые щелчком правой кнопки мышки по CD-диску. Правда, в этом случае нельзя определить действие системы при установке data-CD (уж не знаю почему, но пункта data-CD в CD Properties нет), поэтому, если требуется отключить автозапуск таких дисках, следует во время загрузки диска нажать и удерживать левый Shift.
    Другой способ состоит в правке реестра: находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Services \CDRom и присваиваем паpаметpу Autorun (его тип - REG_DWORD) значение 0.

    Куда подевалась закладка Security в свойствах NTFS-томов и почему так упростилась закладка Sharing?

    Учитывая, что Windows XP - система не только для опытных пользователей, но и для всех остальных, ее разработчики сделали все, чтобы не мозолить начинающим пользователям глаза непонятными им понятиями и обозначениями. К таким понятиям отнесены и Security с Sharing, поэтому, чтобы привести вид вкладок свойств диска к тому виду, к которому уже привыкли пользователи Windows 2000, придется заглянуть в свойства папки (Windows Explorer -> Tools -> Folder Options -> View -> Advanced Settings), где необходимо будет убрать галку с пункта "Use simple file sharing (Recommended)"; после этого в свойствах диска не только появится вкладка Security, но и измениться вкладка Sharing - появится возможность выставлять уровни прав доступа.

    Как назначить диску другую букву?

    Для начала - пара слов о том, как происходит в Windows XP присвоение дискам буквенных обозначений, тем более что происходит оно несколько по другому, чем это делается в Windows 9*/Me.

    В процессе инсталляции Windows XP буква C: присваивается загрузочнуму диску, буквы D:, Е: и так далее - всем остальным обнаруженным при инсталляции жестким дискам, а последняя буква присваивается CD-драйву, причем в дальнейшем при установке в систему новых дисков, например, пишущего CD-привода или еще одного винчестера, им будут присвоены следующие из незанятых букв, то есть у уже установленных дисков буквы не меняются.

    Такой принцип назначения дискам букв, естественно, приводит к тому, что у давно стоящего CD-драйва оказывается меньшая буква, чем у только что установленного винчестера, что может смутить пользователей, перешедших на XP с Windows 9* и привыкших, что у CD-драйвов всегда последние буквы. Но ведь безвыходных положений не бывает: в XP, как и в Windows 9*, можно переназначить дискам другие буквы, вот только делается это несколько по-другому - вручную через консоль управления компьютером (Computer Management). Быстренько добраться до нее можно вот так: Start (Пуск) -> Run (Выполнить):
    compmgmt.msc

    Результатом исполнения этой команды станет открытие консоли, в которой следует выбрать пункт Disk Management. Disk Management - это мощный инструмент для управления дисками, позволяющий, кроме много другого, изменять присвоенные дискам буквенные обозначения.

    А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?

    И с этим в XP дела обстоят хорошо. Правда, присвоить другую букву загрузочному/системному диску не так просто, как это делается в случае остальных дисков, но в принципе - ничего особо сложного. В качестве примера возьмем да и поменяем буквы у дисков C: и D:

    Для этого запускаем редактор реестра (обязательно под эккаунтом администратора), находим ключ HKLM\SYSTEM\MountedDevices и разрешаем администратору (то есть себе) полный доступ к этому ключу. Делается это через меню Security (Безопасность) -> Permissions (Разрешения).

    После этого находим в HKLM\SYSTEM\MountedDevices букву диска, которую нужно изменить (в нашем случае - "\DosDevices\C:") и меняем ее на любую из тех, что еще не использованы, например, на Z: (т.е. у нас должно получиться вот так: "\DosDevices\Z:").

    Следующий этап - замена буквы у диска D:
    Выбираем \DosDevices\D: и изменяем D: на C:, в результате чего получаем "\DosDevices\C:"
    Наконец, выбираем параметр \DosDevices\Z: и переименовываем его в \DosDevices\D:, после чего перегружаем компьютер.

    Примечание: в случае, если не требуется менять названия дисков с C: на D: и наоборот, а нужно всего лишь заменить C: на еще неиспользованную букву, достаточно изменить значение \DosDevice\С: на любую неиспользуемую букву.

    Два важных замечания:

  • При смене буквы у диска необходимо учитывать, где окажется своп-файл: в случае исчезновения диска, на котором он должен быть размещен, система при перезагрузке сразу после окна входа в систему сообщит, что своп-файл слишком мал, и вновь вернётся в окно логона, причем этот процесс будет продолжаться до бесконечености, вернее, до тех пор, пока вы не поймете, что - увы и ах - необходимо переустанавливать систему. Единственная от этого радость - систему можно будет поставить поверх той, что была установлена, а это позволит не переустанавливать установленные ранее программы.

  • Изменение буквы диска приведет к тому, что перестанут работать те программы, которые используют абсолютный метод адресации, поэтому придется переинсталлировать их или вручную править все пути в реестре, изменившиеся в связи со сменой буквы диска.

    Можно ли отключить работу с zip-архивами как с папками?

    Вообще-то работа с zip-архивами, как с обычными папками - это очень удобно, и есть, как мне кажется, только одна причина для отключения этой возможности - слабая и тормозящая машина. Отключается эта опция очень просто - набором в командной строке
    regsvr32 /u zipfldr.dll
    (обратное включение - regsvr32 zipfldr.dll).

    Как автоматизировать вход в систему - без ввода логина и пароля?

    Start -> Run, вводим команду
    control userpasswords2
    После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Users флажок напротив "Users Must Enter A User Name And Password To Use This Computer". После нажатия на кнопку ОК появится диалоговое окно "Automatically Log On", где нужно будет указать имя пользователя и пароль.

    Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?

    В Windows 2000 и XP этот режим по умолчанию заблокирован, и для его активаации необходимо сделать некоторые изменения в системном реестре.
    Открываем системный реестр и находим ключ
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\0000
    после чего создаем в нём новый параметр "EnableUDMA66" типа DWORD и установливаем его значение, равное 1 (установка этого параметра в "0" приведет к блокировке режима).
    Обратите внимание: для активизации установки необходимо перезагрузить Windows.

    Как в Windows XP запускать программы как сервисы?

    Самый простой способ установки запуска программы в качестве сервиса (службы) - использование специальной утилиты-мастера srvinstw.exe из комплекта Windows 2000 Server Resource Kit. Эта утилита позволяет без труда как устанавливать новые сервисы, так и удалять ненужные.

    Кроме этого, в Windows 2000 Server Resource Kit входят специально для этого предназначенные консольные программы instsrv.exe и srvany.exe. Для работы с ними нужно будет войти в систему под учетной записью Администратора (Administrator), скопировать эти файлы в папку %SystemRoot%\System32, а потом выполнить следующую команду:
    instsrv new_service %SystemRoot%\system32\srvany.exe
    где "new_service" - это любое удобное для вас наименование нового сервиса (как раз им и будет обозначаться создаваемый сервис). Обратите внимание на то, что в том случае, если придуманное имя сервиса содержит пробелы, то его нужно будет заключить в кавычки.
    После проведения этой "хитроумной" операции в диалоговом окне 'Управление компьютером' -> 'Сервисы' появится новый сервис, и нужно будет в его свойствах установить способ его запуска - Automatic, если сервис должен запускаться при загрузке системы, Manual - если вручную, или Disabled - отключен.
    Но и это еще не все: в разделе реестра, соответствующем имени создаваемого сервиса ( HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ NEW_SERVICE \ Parameters ) необходимо создать строковый параметр "Application" (без кавычек), значением которого должен быть указан полный путь к исполняемому файлу программы, которую необходимо запускать как сервис.

    • О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
    Copyright © 1999-2002 Е.А.Соболев
    Концепция, дизайн, поддержка: Е.А.Соболев
    Программирование:     Янкин Н.В.


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Разрешение проблем

Система стала глючить или пропали системные шрифты

Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит их (шрифты - тоже системные файлы) и при необходимости переустановит недостающие или поврежденные. Если не помогло - запускаем установочный диск Windows XP и выбираем пункт Upgrade to Windows XP (делать это надо из Windows XP).

Вместо русских букв видны какие-то закорючки

Если такое происходит в Фотошопе, то проблема решается так: находим в реестре ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Nls \CodePage и изменяем значение параметра 1252 на c_1251.nls (было c_1252.nls, станет c_1251.nls). Кстати, такая манипуляция помогает иногда и для некоторых других программ.

Если же кракозябры все равно не исчезли, следует проверить правильность установки Languadge Options: запускаем апплет Regional and Languadge Options (он в Контрольной панели) и открываем закладку Regional Options. В разделе Standart and formats имеет смысл выставить "russian", в разделе Location, отвечающем в том числе за системные шрифты - обязательно указать "Russia". Для полного счастья необходимо проверить вкладку Advanced: Language for non-Unicode programs должен быть выставлен в "Russian".

DOS: русские буквы видны, а вот раскладка не переключается

Открываем реестр, находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \KeyboardLayout \DosKeybCodes и изменяем значение 00000409 на "ru". После этого открываем файл autoexec.nt (он находится в папке %SystemRoot%\system32) и добавляем строку
lh %SystemRoot%\system32\kb16.com ru
Перегружаем компьютер и убеждаемся, что теперь в DOS-прилложениях переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift.

Для особо забывчивых: создание дискеты для сброса пароля (Password Reset Disk)

С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует нажать кнопку Start, выбрать Control Panel, а в ней - User Accounts, и щелкнуть по своему эккаунту. В появившемся окошке в левой колонке (под Related Tasks) есть пункт Prevent a forgotten password - после щелчка по нему запустится мастер создания "спасительной" дискеты.

Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем.

Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти

По умолчанию временные папки, используемые инсталляторами для распаковки данных, необходимых для установки программы, размещаются по адресу C:\Documents and Settings\[имя пользователя]\. Для некоторых инсталляторов такой путь оказывается слишком длинным: распаковав данные, они затем не могут их обнаружить. Чтобы избежать этого недоразумения, следует определить временной папке путь покороче: заходим на вкладку Advanced в System Properties и нажимаем там кнопку Environment, после чего на открывшейся вкладке меняем пути к TEMP и TMP на, например, C:\Windows\Temp

Установка Windows 9*/Me после установки Windows XP

Прежде всего, следует помнить, что Windows 95/98/Me не понимают файловой системы NTFS, так что установить Windows 9*/Me можно только на диск с FAT16 или FAT32. Но и это еще не все: при инсталляции Windows 9* затирает загрузочный сектор Windows XP, поэтому перед установкой Win9* придется переконфигурировать инсталлятор этой операционной системы. Для этого открываем дистрибутив Windows 9* и ищем там файл msbatch.inf (в случае, если файла в дистрибутиве нет, нужно будет его создать). В msbatch.inf следует вписать следующие две строки:
[Setup]
CleanBoot=0
В виде ответа на еще не заданный вопрос "Так ведь дистрибутив - на CD, как же туда этот файл запихнуть?":
кладем msbatch.inf, например, прямо в корень диска C: (c:\msbatch.inf), после чего запускаем установку Windows 9* со следующим параметром:
setup.exe c:\msbatch.inf
И последнее: имя файла может быть совершенно другим, главное, чтобы в нем были эти две строчки.

Что делать, если после перезагрузки система не находит внешний модем?

Причина "потери" внешнего модема (если модем исправен) кроется в том, что при загрузке Windows XP он был выключен. Для того, чтобы система его определила, достаточно включить модем и произвести поиск новых устройств (делается это через Start -> Control Panel -> Add Hardware) - модем будет найден и включен в список имеющегося оборудования.
В случае, если такой вариант не очень подходит по причине постоянного забывания включить модем перед загрузкой (или перезагрузкой) системы, можно поставить не PnP-версию драйвера для этого модема (поискать её можно в *.inf файле модема). Если такой версии там не окажется, придётся ограничиться установкой какого-нибудь стандартного драйвера, например - Standart Modem. В этом случае, если ваш модем соответствует понятиям операционной системы о стандартном модеме (а для большинства модемов, подключаемых к COM-порту, так оно и есть), система будет постоянно помнить, что модем установлен, и не будет "забывать" о нем вне зависимости от того, включен модем в момент загрузки системы или нет. Правда, в случае установки стандартного драйвера могут исчезнуть некоторые полезные настройки модема (например, возможность включить аппаратную компрессии данных), но ведь любые настройки можно задать через строку инициализации, нужно лишь повнимательнее прочитать инструкцию к модему...
Наконец, есть еще один способ, позволяющий системе не забывать про внешний модем. Заключается он в выключении компьютера переводом его в режим Hibernate (спящий режим).

Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?

Скорее всего, этому мешает одна из установок BIOS. Попробуйте переключить в BIOS (в разделе Power Management Suspend Mode) ST1 на ST3.
Если это не поможет, следует проверить, включен ли ACPI-режим. Для этого нужно перейти через Control Panel в апплет Power Options. При отключенном ACPI-режиме нижняя часть вкладки Advanced апплета Power Options оказывается пустой, при включенном - на ней присутствует несколько пунктов для изменения характеристик включения/отключения компьютера и монитора. Если ACPI-режим включен, но вентиляторы все равно не выключаются, то это может говорить о том, что BIOS не поддерживает такую функцию.

После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...

Наиболее верояная причина - операционная система пытается управлять всей сетью. Для начала попробуйте поставить на эту машину протокол NetBEUI (если он не был установлен), а затем - если не поможет - измените в системном реестре параметры, отвечающие за "амбиции" операционной системы:
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Browser \ Parameters
IsDomainMaster = FALSE
MaintainServerList = No

Как в Windows XP установить протокол NetBEUI?

Найдите на компакт-диске с дистрибутивом Windows XP папку Valueadd\Msft\Net\Netbeui и скопируйте из нее два файла: nbf.sys в папку %SystemRoot%\System32\Drivers и netnbf.inf в папку % SystemRoot %\Inf. После этого откройте Свойства сети и установите пpотокол NetBEUI.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Восстановление

Что представляет собой система восстановления Windows XP?

В самом общем плане: System Restore производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore апплета System Properties, до которого можно добраться так: Start/Control Panel/System. Хочу обратить внимание на то, что по умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, при этом отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
Кроме этого, с целью дополнительной защиты системы от кривых рук некоторых разработчиков программного обеспечения, в Windows XP имеется система защиты файлов

Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?

Нет, не все. В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...

Система не загружается...

Для того, чтобы упростить восстановление системы после возможного отказа (хоть такое и случается - если сравнивать Windows XP с Windows 9*/Me - крайне редко), нужно будет заранее предпринять некоторые шаги.

Первый способ состоит в резервном копировании всех основных системных файлов: в Properties системного жёсткого диска открываем вкладку Tools и нажимаем на кнопку Backup now... (это же можно проделать через Start -> Programs -> Accessories -> System Tools -> Backup). В открывшемся окне выбираем вкладку Backup и отмечаем галочкой System state, после чего нажимаем кнопку "Start Backup".
Способ этот хорош всем, кроме одного - созданный "резервирующий" файл (*.bkf) будет иметь размер примерно 200 MB, да и восстановить (вернее, исправить возникшие в ее работе ошибки) можно только при работающей системе, так этот способ всего лишь позволяет, восстанавливая системные файлы, не потерять все свои настройки, а значит, кроме прочего, и не переустанавливать заново инсталлирование программы.

Для уменьшения размера создаваемого при резервировании файла до 15-30 MB можно сохранить только содержимое папки \system32\config (полный список файлов реестра можно узнать, если заглянуть реестр: HKEY_LOCAL_MACHINE\System\CotnrolSet\Control\HiveList\ ), причем для этой цели совсем не обязательно проводить все те манипуляции, о которых рассказывалось выше - можно просто скопировать требующиеся для восстановления файлы в другое место, а при возникновении проблем с реестром загрузиться с любой загрузочной дискеты (хотя бы для DOS) и перезаписать сбойный реестр его резервной копией.

Всё это, конечно, прекрасно, но Windows XP может быть установлена не только на FAT, но и NTFS-раздел, и в этом случае обычная дискета не поможет - NTFS-раздел из DOS не виден. Естественно, и в этом случае выход есть, но для решения этой проблемы нужно будет воспользоваться утилитами сторонних разработчиков - например, воспользоваться программой NTFSDOS Pro, позволяющей производить чтение/запись файлов, размещенных на NTFS-разделе, из-под DOS. Кстати, на сайте разратчика NTFSDOS Pro есть подобная же утилита, но для работы с NTFS-разделами из-под Windows 9*.

А если NFSDOS (или какой-нибудь другой подобной утилиты) нет? - Сама Microsoft предумотрела лишь один способ - загрузку с загрузочного компакт-диска Windows XP: в процессе загрузки системы будет предложено два варианта - установить систему заново или восстановить ее с помощью Recovery Сonsole. В случае, если выбрать Recovery Сonsole, поступит предложение ввести пароль Администратора, после чего - если введенный пароль окажется правильным - загрузится интерфейс командной строки. Список всех допустимых команд выводится командой "help", а наиболее важные для них следующие:
перезапись реестра - copy
вывод на экран списка системных служб и драйверов - listsvc
оключение определенной службы - disable (включение - "enable"),
восстановление загрузочных файлов - fixboot
восстановление Master Boot Record - fixmbr

Кстати, загрузить Recovery Соnsole совсем необязательно с CD - ее можно установить на жёсткий диск, м тогда при загрузке можно будет выбирать, загружать ли систему полностью или загружаться в Recovery Console.

Для установки Recovery Console нужно из командной строки в директории i386 дистрибутива Windows XP набрать
winnt32.exe /cmdcons

Учитывая, что набор команд в Recovery Соnsole является очень ограниченным, имеет смысл поставить жесткий диск с неработающей системой на другой компьютер, работающий под управлением Windows XP или 2000, и попытаться спокойно разобраться в причинах краха системы - если и не разберетесь, то уж все данные с NTFS-разделов сможете перенести без проблем...

Как добавить прав в Recovery Console ?

Хорошая мысль - включить максимальные возможности восстановительного инструмента - Recovery Console, только сделать это нужно, не дожидаясь сбоев...
Для разрешения полного доступа к папкам в Recovery Console открываем (под эккаунтом Администратора) Control Panel -> Administrative Tools и запускаем апплет Local Security Policy -> Local Policies -> Security Options, находим там пункт "Recovery Console: Allow floppy copy and access to all drives and folders" и переключаем его в "Enable". Проделав это, перегружаемся в режим Recovery Console и даем команду
SET AllowAllPaths = TRUE

Как восстановить повреждённый загрузчик XP?

Загружаемся в Recovery Console и даем команду
fixboot

Где хранится код активации Windows XP?

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

Можно ли в WinXP сделать загрузочные дискеты?

Можно, но для этого придется прогуляться на сайт Microsoft - уж не знаю почему, но необходимый для этого пакет теперь (в отиличие от W2K) не входит в дистрибутив. Адрес страницы загрузки:
http://support.microsoft.com/support/kb/articles/q310/9/94.asp?ID=310994
Обратите внимание: созданные загрузочные дискеты не будут "аварийными" - они предназначены лишь для установки операционной системы на компьютеры, не поддерживающие загрузку с компакт-диска. При загрузке компьютера с установочных дисков Windows XP будут автоматически загружены драйверы привода компакт-дисков, и начнется установка операционной системы.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.


Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Windows XP и сеть

После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...

Наиболее вероятная причина - операционная система пытается управлять всей сетью. Для начала попробуйте поставить на эту машину протокол NetBEUI (если он не был установлен), а затем - если не поможет - измените в системном реестре параметры, отвечающие за "амбиции" операционной системы:
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Browser \ Parameters
IsDomainMaster = FALSE
MaintainServerList = No

Как в Windows XP установить протокол NetBEUI?

Найдите на компакт-диске с дистрибутивом Windows XP папку Valueadd\Msft\Net\Netbeui и скопируйте из нее два файла: nbf.sys в папку %SystemRoot%\System32\Drivers и netnbf.inf в папку % SystemRoot %\Inf. После этого откройте Свойства сети и установите пpотокол NetBEUI.

Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?

Действительно, служба "Quality of Service" резервирует 20% от пропускной способности канала, причем любого - хоть модемного на 14400, хоть гигабитного Ethernet-канала. Особенностью этой службы является то, что даже при удалении службы QoS из свойств соединения пропускная ширина канала не освобождается...
Освободить канал (или настроить QoS) можно следующим образом: запускаем апплет Group Policy (gpedit.msc), находим там Local Сomputer policy и нажимаем на Administrative templates (Административные шаблоны), а затем выбираем Network - QoS Packet Sheduler. Включаем Limit reservable bandwidth и cнижаем Bandwidth limit с 20%, установленных по умолчанию, до 0, или вообще отключаем его.
Обратите внимание: для вступления внесенных изменений в силу требуется перезагрузка.

Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?

Можно: Start/Control Panel/System, а там на вкладке Automatic Updates следует отметить последний пункт - "Turn off". После этого следить за появлением обновлений операционной системы придется самостоятельно...

Как включить интернет-защиту?

Одна из новых опций, появившихся в WinXP - файрволл для интернет-защиты. Заходим в свойства того соединения, которое нужно защитить: через Start /Control Panel /Network Connections в контекстом меню нужной иконки выбираем пункт Properties, выбираем вкладку Advanced и отмечаем пункт "Protect my computer and..." (ошибиться вряд ли получится - больше галку там поставить негде)

Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?

Эти ресурсы в Windows XP (как и в W2K) существуют по умолчанию (доступ к ним возможен только из под эккаунта администратора), причем, если удалить эти ресурсы через "Управление компьютером" (Computer Management) -> "Общие папки", то после перезагрузки они появятся снова, и полностью отключить их можно только с помощью внесения изменений в реестр.
Открываем
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
и изменениям (или добавляем) следующий параметр:
AutoShareWks (его тип - REG_DWORD) значение 0

Как включить роутинг?

Открываем реестр, ищем ключ
SYSTEM\CurrentControlSet\Services \Tcpip \Parameters и в параметре IPEnableRouter (тип - REG_DWORD) меняем значение 0 на 1.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.