Главная

Дисковый кэш Windows 9x/ME
Вопросы и ответы от Трошина
Вопросы и ответы от Трошина-2
Вопросы и ответы от Трошина-3
Эргономика для браузера: быстрота и комфорт
Я теперь уж и не помню, как надо устанавливать Windows!
Как избежать зависаний компьютера или О прерываниях: маленький ликбез
С чего начинается Windows...
С чего начинается Windows...- 2
Параллельная сеть или зачем компьютеру LPT-порт
Засланец-2 или Как сделать еще проще
Многоосность
"Зачем?", "Почему?", и "Куда?" или Всякое разное про операционные системы.
Не ОС красит веб...
Форматировать дискеты быстро
Полезные советы по реестру
Графические карты:советы по настройке
Полезные советы
Сделай Windows удобнее
C винчестером надо бы поосторожнее
Мусор в Windows
Легкая пластическая XP-рургия

Тематическая подборка. Компилированный html. Выпуск 1, февраль 2003 года


Дисковый кэш Windows 9x/ME

Поярков Илья (Terabyte), terabyte@bk.ru

При загрузке компа, часть оперативки съедает дисковый КЭШ. По умолчанию память для него выделяется динамически, в зависимости от выполняемых в данный момент задач (то есть при интенсивном обращении к жесткому диску памяти дается больше, и наоборот, если какому-либо процессу не хватает памяти, размер дискового КЭШа уменьшается). Самое главное состоит в том, что Windows выделяет ему оперативки свыше половины и даже может переместить некоторые запущенные программы в своп (swap) файл. Из выше сказанного можно сделать вывод: давать Windows самостоятельно регулировать КЭШ нельзя, а надо это делать самостоятельно! Для этого надо залезть в файл System.ini (C:\Windows\System.ini или WIN+R и набрать sysedit), найти раздел [vcache], написать в нем два параметра: minfilecache - минимальный размер КЭШа, maxfilecache - максимальный размер КЭШа и присвоить им необходимые значения.

Для компов с 32 Mb оперативки:

minfilecache=2048
maxfilecache=4096
или
minfilecache=2048
maxfilecache=8192

второй вариант обеспечивает более быструю работу с диском, однако отбирает больше памяти у других процессов.

Для компов с 64 Mb оперативки:

minfilecache=2048
maxfilecache=8192
или
minfilecache=4096
maxfilecache=16384

Для компов с 128 Mb оперативки:

minfilecache=8192
maxfilecache=16384
или
minfilecache=8192
maxfilecache=32768

А при следующей конструкции Windows не будет "дергаться" в поисках оптимального размера КЭШа:

minfilecache=16384
maxfilecache=16384

Если оперативки больше 128 Mb, то желательно установить фиксированный размер КЭШа (можно сделать его и меньше, но больше не стоит, так как больший размер КЭШа нужен только для серверов):

minfilecache=32768
maxfilecache=32768

Все перечисленные значения являются степенью двойки. Если вы поставите иное значение, то ни чего страшного не случится, но все же желательно, чтобы значения были кратны 2048. Еще, в раздел [vcache] можно добавлять следующие значения:

сhunksize - в процессе работы, Windows разбивает КЭШ на части, а с помощью этого параметра мы сами можем определить размер частей. Если сделать части маленькими, то скорость компа уменьшится, а если большими, то КЭШ будет расходоваться неэкономно. Если значение параметра maxfilecache установлено в диапазоне 6144-16384, рекомендуется chunksize=512; при меньшем maxfilecache попробуйте chunksize=256, при большем - chunksize=1024.

namecache - определяет количество файлов отслеживаемых Windows. Для этого параметра лучше установить значение кратное 512 в диапазоне от 1024 до 2600 (больше имеет смысл только для файл-серверов).

directorycache - определяет количество директорий отслеживаемых Windows. Для этого параметра лучше установить значение кратное 16 в диапазоне 32-96.

Вот отрывок из моего System.ini (у меня 128 Mb ОЗУ):

[vcache]
minfilecache=16384
maxfilecache=16384
сhunksize=512
namecache=1536
directorycache=64

Со своими вопросами и критикой пишите сюда: web-hack@mail.ru. Если вы хотите узнать огромное множество других полезных вещей связанных с компьютерами (HACKING, советы, WEB-дизайн, реестр виндов, скрипты, статьи, анекдоты, афоризмы, початиться и т.д.), то идите на мой сайт web-hack.boom.ru. А мой NICKNAME – Terabyte!


Вопросы и ответы

Сергей Трошин
http://stnvidnoye.chat.ru

Не могу сделать загрузочную дискету: опция "Установка и удаление программ"> "Создание загрузочного диска" игнорирует его создание. При нормальной работе в остальном и с приложениями.

Возможно, вами была удалена папка с файлами для загрузочного диска C:\Windows\Command\EBD - поэтому он и не создается.

Вы пишете: "Прописать в system.ini в секцию [386Enh] параметр для своп-файла PagingFile = C:\Windows\win386.swp". А у меня своп в корне - C:\win386.swp. Это нормально?

Нормально. Вернее - для файла подкачки без разницы, где находиться. А еще вернее - файл подкачки, размер которого определяется Windows, находится в папке C:\Windows, а своп фиксированного размера - в корне того диска, на который вы его поместили.

Для работы со сканером фирма-производитель посоветовала перенести корзину и файл подкачки на другой диск! Как это сделать??????

Файл подкачки: "Панель управления">"Система">"Быстродействие">"Виртуальная память" - в появившемся диалоговом окне надо задать путь к другому диску, на котором больше свободного места. Корзину же перенести нельзя, так как папка RECYCLED должна быть на каждом диске, можно только ее очистить, плюс ко всему гораздо больше вам поможет удаление временных файлов из папок C:\Temp и C:\Windows\Temp.

Я не компьютерщик, я архитектор и занимаюсь компьютерами в силу сложившихся обстоятельств. Ваши статьи в журнале и советы на сайте помогли мне решить многие проблемы, но сейчас я столкнулся с вопросом, ответ на который найти не могу. На машину, кажется, достаточно еще мощную по современным меркам (P III 600; ASUS P3B-F; 256 Мб PC100; Matrox G400 32 Мб; Quantum Fireball 20 Гб, подключен через контроллер ATA/100) установили "начисто" Windows 2000 Pro. Установка прошла без сбоев, но в ходе восстановления необходимого ПО выяснилось, что часть программ не устанавливаются с CD. Первое подозрение на неисправность CD-ROM или самих CD пришлось отбросить, так как в ходе многочисленных попыток выяснилось, что не запускаются только какие-то конкретные программы (в частности Photoshop), а другие программы с тех же дисков работают. И не запускаются они с любых дисков, в том числе и после копирования на жесткий диск. У меня создано два пользовательских профиля - один с правами "администратора", второй - "опытный пользователь" с правами установки программ. Если я вхожу в систему как "пользователь" и запускаю Setup, появляется сообщение, что у меня недостаточно прав для установки этой программы. Если вхожу в систему как "администратор", то после появления начальной заставки исполнение программы останавливается, прекращается всякая активность внутри компьютера, в списке исполняемых задач Setup отсутствует. Посоветуйте, что делать? Может быть, я не учел какие-либо настройки или это сказываются "железные" недостатки - именно эта машина отличалась нестабильностью работы под Windows 98, и после замены почти всех комплектующих, кроме процессора, на нее решено было установить Win2k. Те программы, которые удалось установить, работают нормально. На других машинах, сходных конфигураций, тоже все работает, а здесь...?

Возможно, что этим программам "не нравится" то, что у вас локализованная русская версия Windows, но скорее всего, дело в Windows Installer: этой штуке не нравится почему-то принятый по умолчанию путь к папке TEMP - в "Свойствах системы" выберите для нее более короткий путь, например, C:\Temp, а заодно пропишите эту папку в качестве значения переменной PATH.

Почему я не могу из Windows 2000 Pro удалить "Блокнот" - после удаления он опять сразу появляется???

Потому что специальная служба защиты системных файлов его восстанавливает, видимо, как один из самых главных файлов ОС.

Поставил недавно на ПК пакет Office 2000, но из всего пакета использую только Word и Excel. Можно ли удалить остальные программы пакета без ущерба работе Word и Excel и как это сделать?

Запустите с компакт-диска установку Office - в появившемся меню одним из пунктов будет "удаление отдельных компонентов". Ущерба быть не должно.

Обнаружил в папке Windows (ОС W98SErus) файл "pagefile.sys" размером в 603 Мб! Открыв его для просмотра, увидел, что он состоит из многократно повторенного слова "PAGE". Со страху сразу его удалил и очистил корзину. Проверка с другого жеского диска свежеобновленным антивирусом AVP ничего не выявила. Что это за зверь такой? И могло ли от него что-нибудь остаться? Посоветуйте, пожалуйста, как проверить систему, и нет ли достойного, с вашей точки зрения, форума по вирусам, где можно оперативно получить достоверную информацию по случившейся конкретной беде.

Это всего лишь так называемый файл подкачки - виртуальная память операционной системы, он используется, когда Windows не хватает памяти физической. Этот файл у вас, скорее всего, остался либо от Windows 3.11, либо от Windows NT/2000 - в Windows 9х он обычно называется win386.swp, хотя может называться и pagefile.sys при некоторых условиях. Причин для волнения нет - к вирусам он отношения не имеет.

Объясните дремучему следующее: я настроил оптимально MTU со своим провайдером, а дальше по сети длина пакета меняется? Что с пакетом дальше происходит? Каждый сервер может переупаковывать мои данные по своему усмотрению или в Сети бегает мой пакет?

По идее пакет должен сам находить оптимальный путь, при котором не происходит его фрагментация (параметр PathMTU включает эту "фичу"), но если это невозможно, то пакет фрагментируется. То есть любой сервер может фрагментировать пакет (если только в заголовке пакета не установлен запрет на фрагментацию, что делается обычно только в экспериментальных целях). Сами можете посмотреть, если будете пинговать неделимыми пакетами удаленные сайты.

Очень хороша для этого программа TweakDUN (www.pattersondesigns.com/tweakdun), которая всегда очень четко показывает, какой величины пакет может дойти до любого сайта - она удобнее утилиты ping и проще и надежнее, чем CyberKit.

Неоднократно приходилось переставлять ОС, и каждый раз пропадали "избранные сайты" в Internet Explorer. Как заранее скопировать их на дискету? Если они хранятся в папке Temporary Internet Files, то там находятся и все остальные сайты, на которые я когда-либо заходил, но не включал их в "Избранное" - разобраться, кто там есть "who", проблематично.

Нет, они находятся в папке C:\Windows\Favorites(C:\Windows\Избранное) - сохраните ее вместе со всем содержимым на дискете.

Как в Windows 2000 Professional вручную установить прерывания? У меня на одном прерывании 6 устройств: модем, видеокарта, SB, Promise Ultra 100 и 2 USB-контролера. Настройка ресурсов этих устройств стоит автоматическая, и галочку эту снять нельзя. Хотя все вроде бы работает, но на разрешении 600 dpi начинает зависать USB-сканер, причем вешает и программу, из которой запустился.

Боюсь, для этого придется переустановить Windows, предварительно отключив ACPI в CMOS Setup. Либо отключить его так: при установке ОС, в самом начале, когда появится предложение нажать кнопку F6 для установки SCSI-адаптеров, надо нажать вместо этого кнопку F5 и отключить ACPI. Попробуйте также заранее в CMOS Setup поставить PnP OS Installed=NO - распределением ресурсов займется BIOS, а не Windows. Отключение всего этого хозяйства после установки ОС обычно не помогает, но попробуйте - вдруг повезет?

При форматировании винта или при проверке его поверхности все виснет где-то на 30% (винт Seagate Medalist, 2 Гб). Пробовал форматировать, создавать раздел, проверять поверхность следующими программами: fdisk, format, Partition Magic 6.0. От чего это может быть? Есть какая-нибудь классная утилитка для винтов, типа как FFormat для дискеток?

Посмотрите для начала на сайте производителя диска специальную утилиту для форматирования диска - обычно такие программы устраняют многие ошибки, с которыми fdisk не справляется. Попробуйте также запустить стандартные программы с такими ключами: fdisk /mbr и format c:/u. Очень неплохая утилита для разбиения и форматирования диска имеется в комплекте Norton Ghost - GDISK.

Вот тут, после очередной переустановки Windows 98 и, соответственно, всего ПО, появился барабашка на компьютере (в предыдущие глобальные чистки его не было!). Ведет он себя относительно странно (в любом редакторе!) - при вводе с клавиатуры некоторых символов (" ' ^ ~) с первого раза ничего не отображается. Только при вводе второго символа (любого) появляется и этот "спецсимвол". Что бы это значило и как с этим бороться?

У вас стоит дополнительная раскладка клавиатуры (скорее всего, французская - прим. ред.). В свойствах клавиатуры, на закладке "Язык" установите английский язык "United States 101" и русский "Russian", остальные раскладки удалите.

Не подскажете ли, как решить такую проблему: когда щелкаешь правой кнопкой мыши по какому-нибудь файлу, появляется меню: "Открыть", "Печать" и т. д. - как можно его отредактировать? А то некоторые программы при установке помещают туда свои команды, например BestCrypt помещает команду "Delete with wiping", которую хочется удалить. Из самих программ не всегда можно. Я пробовал искать эти команды в реестре, но не нашел.

Команды контекстного меню, выпадающего, если нажать правую кнопку мыши на любой папке или любом файле (то есть общие для всех типов файлов) можно редактировать в разделах реестра:
HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers (для файлов)
HKEY_CLASSES_ROOT\Folder\shell (для папок)
HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers (тоже для папок).

Подскажите, пожалуйста, как сохранить возможно большее количество необходимых настроек Windows при переустановке Windows 98 или ее замене на Windows Me или W2k?

Для переноса старых настроек имеется, например, программа ProFiler 2000 (www.jermar.com/products.htm).

При выключении (перезагрузке) достало постоянное окно "TaskMon совершил недопустимую операцию". В принципе, жить не мешает, но уже давно начинает раздражать. Кто такой этот TaskMonitor и что он делает?

TaskMon - менеджер программ, в его задачи входит, например, создавать лог-файлы хода запуска программ (которые потом использует дефрагментатор в своей полезной работе!). Если он виснет, попробуйте очистить папку C:\Windows\Applog, где хранятся все эти лог-файлы - вероятно, какой-то из них поврежден и не дает программе нормально запуститься.


Вопросы и ответы-2

Сергей Трошин
http://stnvidnoye.chat.ru

Вопрос Жутко раздражает, что в Миллениуме по другому ведет себя мышь - она теперь нелинейно движется, не так как в Windows 98. Как вернуть все к привычному режиму? Помогите - не могу в игрушки играть - все время промахиваюсь!
Ответ В разделе реестра
[HKEY_CURRENT_USER \Control Panel\Mouse]
Установите:
"MouseSensitivity"="13"
"MouseThreshold1"="4"
"MouseThreshold2"="0"
 Мышь будет двигаться по-старому, если эти значения все-равно не понравятся, то поэкспериментируйте сами, изменяя цифры и перегружая ПК.

Вопрос Появился в Windows 95 неожиданно такой "глюк": не полностью прорисовываются значки - видна только часть их изображения, да и то какая-то искаженная. Что делать?
Ответ Такое бывает, если не очень качественный драйвер видеокарты - посмотрите в Интернете - может быть появилось его обновление. Чтобы вернуть значки в норму, надо удалить кэш иконок - скрытый файл C:\WINDOWS\ShellIconCache и перегрузить компьютер. Можно также сделать "Repair Icons" ("Восстановление значков") с помощью программы TweakUI(вкладка "Repair") - результат будет тот же.

Вопрос Вы уже писали в "Upgrade", как сделать плавную прокрутку в Word, а можно ли включить ее и в Excel?

Ответ Я попробовал сделать это для Excel 97 аналогично Word:
[HKEY_CURRENT_USER \SOFTWARE\Microsoft\Office\8.0\Excel\Options]
"LiveScrolling"="1"
Но, к сожалению, не сработало, так что, видимо, это не предусмотрено.

Вопрос У моего друга проблема с выходом из Windows 98SE. Начну я с его системы: корпус - точно так и не разобрались - вроде ATX, но мне кажется что АТ, процессор Intel Celeron 366 под socket 370, материнская плата LS 6LX (ATX, AT), память SDRAM 64 Mb, жеский диск Quantum 8,4 Gb, мышь Microsoft Intel PS/2 c колёсиком, звуковая плата Creative SB AWE 64. Проблема такого рода: когда он выходит из системы у него перестало появляться окно с информацией о выключении компьютера, раньше на Win98 такой "глюк" отсутствовал. Мы что-то установили не так или это как-то связано с Win98SE?
Ответ Если не появляется окно с предложением выключить питание, то для начала проверьте наличие на диске файлов с конечными заставкамиC:\WINDOWS\Logos.sys, C:\WINDOWS\Logow.sys - если эти картинки повреждены, то ПК может даже зависать при выключении. Также заставка может не показываться, если в CMOS Setup установить параметр PnP OS Installed=Yes.

Вопрос Выхожу в Интернет - все нормально, скорость 28800 - но ни с того ни сего вдруг почта при доставке пишет - "поиск узла - узел не найден". Почту не принять. И Explorer 5.0 не загружает ни один адрес. Я нахожусь в сети с нормальной скоростью, а мои программы не находят узлов. Переустанавливала обе программы - бесполезно. Драйвера переустанавливали, протоколы тоже. Помогает только полная переустановка всей системы, форматирование диска. Так у меня было уже два раза, ни с чем конкретным это связать не удается, т.е. ни с новой программой на компьютере, ни с чем иным. Я живу в маленьком городе, у нас один грамотный человек, который переустанавливал мне систему и ничего не может сказать. Может быть, у Вас будет время черкнуть мне пару строк, я уже пожилой человек и так поздно открыла для себя этот прекрасный мир компьютеров. Очень нуждаюсь в совете.
Ответ У меня тоже иногда такое случалось, когда IE вдруг сам по себе устанавливал флажок "НИКОГДА НЕ УСТАНАВЛИВАТЬ ЭТО СОЕДИНЕНИЕ" ("Never dial this connection") в "Свойствах Обозревателя" ("Internet Options") на вкладке "СОЕДИНЕНИЕ" ("Connections") - приходится возвращать все на место вручную. Также, если такое снова произойдет, то установите параметры по умолчанию (Default Settings) на вкладках "БЕЗОПАСНОСТЬ" и "ДОПОЛНИТЕЛЬНО" того же меню свойств обозревателя. Плюс ко всему, часто для нормальной связи обязательно должны быть прописаны адреса DNS - серверов вашего провайдера в свойствах соединения с ним - узнайте их у провайдера. Иногда также выход в интернет возможен только через прокси-сервер провайдера - да и вообще поинтересуйтесь, какие настройки провайдер рекомендует. Если не играете в игрушки, то попросите того знающего человека поставить вам Windows2000 - они гораздо больше подходят для работы и интеренета - "глючат" меньше.

Вопрос На моём компьютере стоит видеокарта ASUS AGP-V3800.То ли после попытки обновления драйверов, то ли после перепрошивки BIOS карты в настройках вывода изображения исчез очень нужный пункт, а именно - "VGA+TV" (осталось только или "TV" или "VGA"). Может дело в VGA BIOSе - чип PRO, драйвер стоит тоже для "PRO", но при попытке заново перепрошить BIOS выдаётся сообщение, что это нельзя сделать.
Ответ Сложно сказать, что тут можно предпринять: попробуйте удалить драйвера видеокарты и поставить заново. Посмотрите еще раз маркировку прямо на плате карты и узнайте поточнее ее название на сайте производителя - может быть для нее другой BIOS нужен, или они пишут что-нибудь по поводу этого "глюка". Установите вторую копию "Виндов", под ними - старый драйвер (с которым было все в порядке) и посмотрите - появилась ли недостающая функция - если не появилась, то дело в BIOS - может в новой версии специально это исключено - напишите разработчику или почитайте форумы у него на сайте, если есть такие.

Вопрос Прочитал статью в "Upgrade"#13 про Windows 2000 и окончательно решился поставить себе Windows 2000 как вторую OС. Но у меня возникло несколько вопросов, и я был бы очень признателен, если бы вы на них ответили:
1. Если я буду ставить на чистый HDD системы в следующем порядке: Windows98 -- Windows2000, причем W98-на диск С, а W2K-на диск D, то нужно ли мне ставить все драйвера дважды (сначала для W98, потом для W2K)??? При проверке оказалось, что практически для всего железа нужны новые "дрова".
2. Если я поставлю W98, все "дрова" к нему, программы для W98, то после установки W2K я смогу использовать эти программы в W2K? И наоборот, если поставлю что-либо под W2K, смогу ли я использовать эти программы в W98?
Ответ Да, драйвера придется ставить два раза - причем, в каждой системе свои собственные, и программы все надо ставить по два раза, если хотите иметь к ним доступ из обоих ОС. Исключение составляют только самые простые программы, которые не требуют записи своих настроек в реестр и конфигурационные файлы. Можно, конечно, исхитриться и иметь одну общую папку Program Files, но все равно надо будет все программы ставить по два раза, чтобы в реестры каждой ОС прописались нужные для работы программ параметры - при этом немного места на диске вы сэкономите, но возможны "глюки", так что очень не советую

Вопрос Не могли бы Вы подсказать - есть ли программы, позволяющие вести учет работы компьютера, а именно - время включения, выключения и запускаемые программы. И, если есть, то где их можно скачать?
Ответ Название одной такой программы - StatWin - она все-все протоколирует и даже позволяет задавать пользовательские привилегии - найдете ее на http://statwin.da.ru.

Вопрос У меня WindowsMe. В удаленном доступе к сети параметр "Сохранить пароль" не работает. Что мне сделать, или где поставить флажок, чтобы он заработал?
Ответ Пароль не сохраняется потому, что в "Свойствах сети" ("Панель Управления" - "Сеть") не установлен "Клиент для сетей Microsoft". После его установки (в Windows98 и 95 потребуется диск с дистрибутивом) пароль будет запоминаться.

Вопрос Я пробовал в Windows ME, следуя Вашим рекомендациям, отредактировать в реестре меню папок и Internet Explorer, но ничего не получилось. Не могли бы Вы подробнее описать эти действия для Windows ME и Exlorer 5.
Ответ К сожалению, подробнее, чем в журнале и на сайте, описывать нет возможности - для этого надо писать книгу о работе с реестром, но вы можете воспользоваться программой FastExplorer
(http://members.xoom.com/_XMCM/sergekol/Download/index.htm), которая дает нормальный удобный интерфейс для редактирования контекстного меню - не надо ковырять реестр. И изучите какие-нибудь книги о реестре Windows - их на рынке достаточно.

Вопрос Хотел Вас спросить, с помощью какой программы можно файл с форматами html, htm превратить в рисунок и мучить, мучить...
Ответ Вероятно, надо скопировать целиком окно IE с этим документом в буфер обмена Windows одновременным нажатием клавиш "ALT" и "Print Screen", затем, запустить редактор Paint или что-нибудь помощнее и вставить полученное изображение в него - меню "Edit" - "Paste". После этого получите картинку - отредактируйте и сохраните в любом формате. То же самое касается и окна любой другой программы. Нажатием же одной кнопки "Print Screen" вы скопируете целиком изображение рабочего стола. Если же вы хотите редактировать код HTML-документа в визуальном редакторе, то используйте, например, программу DreamWeawer - она достаточно простая в работе, но и очень мощная.

Вопрос Прочитал в одном из последних журналов об установке звука на компьютерный динамик и теперь не могу ни удалить его, ни отменить, ни сделать потише. Как быть?
Ответ Громкость "пищалки" предлагают отрегулировать при установке или переустановке драйвера. А удалить его можно так:
В system.ini удалить раздел [speaker.drv]
в папке c:\windows\system - удалить файл speaker.drv
в реестре - удалить раздел
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MediaResources\newdrivers\wave\speaker.drv.
Вообще желательно поискать в реестре другие упоминания этого файла и все их тоже удалить.

Вопрос Не могу включить в Windows ME спящий режим - не появляется пункт "Hibernation" ни в меню "Выключить компьютер", ни в настройках управления питанием. Причем пробовал устанавливать МЕ на двух машинах - результат один и тот же. При установке же Windows 2000 все работает.
Ответ Думаю, ничего не получится, так как "Миллениуму" не нравится какой-то драйвер, обычно видеокарта не поддерживает "гибернацию". Узнать, что не нравится системе можно из файла C:\WINDOWS\NOHIBER.TXT. Если там увидите непонятную строку "PCI: Bad IRQ Holder", то скорее всего виновата видеокарта - так часто бывает - в 2000 "гибернация" работает а в МЕ - нет.

Вопрос В статьях "Вакцина для Windows" ("Upgrade" #9 от 01.10.2000г., стр.41)и "Вопросы о правильной установке Windows" ("Upgrade" #11 от 01.11.2000 г., стр.37) Вы описываете как использовать утилиту System File Checker из пакета Windows 98 в "Миллениуме". Я выполнил все Ваши инструкции по установке System File Checker в "Windows Me" и обновил его базу данных. Затем сознательно удалил системный файл C:\Windows\System\ES.dll. Запустил System File Checker, который обнаружил пропажу файла ES.dll. Однако при попытке его восстановления выдает сообщение, что не может его извлечь из дистрибутива "Windows Me". Объясните, пожалуйста, как заставить System File Checker восстанавливать системные файлы из дистрибутива "Windows Me". Ведь в Windows 98 все работало.
Ответ Да, действительно, SFS иногда не хочет извлекать файлы из дистрибутива (кстати, извлекать файлы можно таким образом и из дистрибутива другой программы, например, Internet Explorer) - но в "Миллениуме" эта функция перенесена в MSCONFIG - там все всегда работает. SFC же используйте в основном для мониторинга, а восстанавливайте файлы с помощью модернизированного MSCONFIG. Главное, чтобы в дистрибутиве не было архива-в-архиве - тогда вообще придется искать попавший в него файл вручную, открывая по очереди каждый вложенный CAB-архив - не поможет даже MSCONFIG.

Вопрос Как в Windows Millennium включить режим "Command prompt only" и "Safe mode command prompt only"? У Windows 98 при загрузке можно держать клавишу Ctrl, тогда появится меню с режимами загрузки, включая и два вышеперечисленных. У Millennium эти режимы отсутствуют.
Ответ Да, эти режимы теперь исключены. Для их возвращения лучше всего воспользоваться патчем с сайтов http://www.sgmvp.freewebsites.com/WinME.htm
http://www.geocities.com/mfd4life_2000/
но обязательно выберите тот патч, который позволяет все вернуть назад на случай непредвиденных "глюков".

Вопрос После установки Windows ME (мат.плата Asus CUSL2 на чипе i815-EP) жесткий диск (IBM-9,11 UDMA-66) системой не идентифицируется. Он определяется как GENERIC IDE DISK TYPE47, но это непонятно, поскольку материнская плата поддерживает UDMA-66,100. Что делать? В принципе это решается, если установить "Intel ULTRA ATA Storage driver", но при этом система начинает работать не стабильно (зависает, ошибки открытия приложений и.т.д.). Замена режима "No Limit" на UDMA-4 ни к чему не приводит.
Ответ Во-первых, посмотрите драйвер контроллера жестких дисков ("Bus Master" или "ULTRA ATA Storage driver") на сайте самого производителя материнской платы - "интеловский" может и не подходить к некоторым платам (но к вашей должен подойти). Или же ищите его на дискете, что давалась с "матерью". В принципе, можно оставить и стандартный драйвер "Виндов" - надо только включить галочки DMA в свойствах дисков - в Windows98, по заверениям Microsoft, поддерживается UDMA, но родной драйвер все же лучше, поскольку им гарантированно поддерживается UDMA 66 и UDMA 100. К тому же такие "глюки" возможны, если вы используете обычный шлейф при подключении диска к контроллеру - замените его на тот, что предназначен для UDMA 66. Иногда можно пойти на небольшую хитрость, укоротив до предела шлейф и подключив к нему только одно устройство - наводок на него будет меньше и стабильность улучшится.

Вопрос При установке драйвера звуковой платы MX-300 установочная программа сообщает, что поскольку карта не установлена в 1 PCI слот, то MPU-401 Sound Blaster, джойстик поддерживаться не будут, хотя карта на самом деле стоит в 1 PCI слоте.
Ответ Возможно, плате не нравится прерывание, или имеется конфликт в распределении ресурсов - назначьте ей вручную IRQ5 - стандарт "саундбластера" и проверьте, чтобы больше ни одно устройство это прерывание не занимало.

Вопрос У меня при загрузке ПК запускается какой-то "Watchdog" - что это, и можно ли его убрать из автозагрузки.
Ответ По-моему, Watchdog - программа мониторинга состояния материнской платы и процессора - температура, вентиляторы и т. п. Если вам это не нужно, то можете ее отключить. Хотя, я встречал еще одну программу с таким названием, отвечающую за родительский контроль при работе детей в Интернете.

Вопрос А как перенести настройки AtGuard с одного ПК на другой?

Ответ На сайте http://members1.chello.nl/~a.m.janssen/index.htm вы найдете программу AtguardNISrules - она позволяет удобно редактировать правила и AtGuard и Norton Internet Security, сохранять их резервную копию и переносить с одного "компа" на другой, но это можно сделать и экспортом из реестра целиком ветвей, относящихся к AtGuard или NIS - установки хранятся именно в реестре найдете их без труда, например, по имени главного файла этих программ IAMAPP.EXE.

Вопрос Как сделать так, чтобы при двойном щелчке по папке открывался не еще один "Проводник", а сама папка?
Ответ В Windows 98 в "Свойствах папок" ("Folder Options") надо задать, чтобы папка открывалась в том же окне, а не открывался еще один "Проводник". В Windows 95 надо в меню "Вид" Проводника выбрать "Параметры", и там на вкладке "Папка" задать требуемый режим открытия папок.

Вопрос На "компе" нет свободных прерываний - все заняты устройствами. Говорят, что можно SB перекинуть на прерывание com-порта, тем самым освободить прерывание. Пройдет ли этот вариант? Есть ли еще какие-нибудь варианты выхода из этого положения?
Ответ В инструкции к Sound Blaster надо посмотреть, какие прерывания он понимает - если там есть те же, что отведены портам, то можно отключить один порт в CMOS Setup и занять его IRQ. Иногда SB умеет делить одно и то же прерывание с портом принтера без конфликтов. Вообще, рекомендую составить табличку, какие платы расширения какие прерывания поддерживают и потом распределить все так, чтобы никто никому не мешался через "Свойства Системы" вручную. Можно еще сделать несколько конфигураций оборудования, что-то отключив в каждой из них, и выбирать их при загрузке системы.

Вопрос Модем Motorola SM56 PCI отказывается работать. Не то чтобы совсем: с интернетом всё в порядке, но поиграть по модему не представляется никакой возможности. При соединение слышен очень короткий набор (1-2 секунды), а затем бесконечный непереставаемый гудок. Что делать?
Ответ Модем скорее всего звонит тоном - надо в свойствах телефонии установить пульсовый тип набора, и в играх необходимо тоже выбирать в опциях пульсовый набор, если это предусмотрено. Если это все равно не поможет, то сначала дозвонитесь до другого ПК с помощью обычного телефона, и в тот момент, когда удаленный модем поднимет трубку, запускайте дозвон у своего модема - он быстро пропищит в трубку тоновый набор и установит связь вне зависимости от того, что сам не может нормально набрать номер.

Вопрос В Windows98 после закрытия окна (крестиком) его изображение частично остается на рабочем столе - кнопка без надписей висит, пока по ней не щелкнешь мышью. Что можно сделать?
Ответ Сделать ничего нельзя - это известная проблема, связанная либо с видео драйвером либо с самой "Виндой" - Microsoft молчит об этом, заявляя, что пользователям этот "глюк" не мешает :(

Вопрос Откуда можно скачать патч, русифицирующий версию ATguard (3.22)?

Ответ Патчи для русификации многих известных программ вы найдете здесь:
http://rusrow.boom.ru/
http://www.siber.com/sib/russify/
http://rus.agava.ru/

Вопрос Как переписать на компьютер музыку с кассеты (с обычного магнитофона)?

Ответ Спаять кабель (или купить) "тюльпан" - "мини джек" (то есть, чтобы с одной стороны подошел к магнитофону, а с другой - к звуковой карте), подключить линейный выход магнитофона к линейному входу звуковой карты и с помощью программы типа "Фонографа" записать wav-файл. Потом перегнать его в MP3.

Вопрос На днях поставил себе Windows Me. Всё вроде бы устраивает, но я что-то не догоняю, как сделать, чтобы отображалось содержимое окна при перетаскивании?
Ответ В "Свойствах дисплея" на вкладке "ЭФФЕКТЫ" - установить флажок "Show windows contents..." ("Показывать содержимое окна при перетаскивании")

Вопрос В "Upgrade" #9-2000, была описана функция System Restore, которая меня заинтересовала, но как её запустить?
Ответ В меню "Start" - "Programs" - "Acsessoriers" - "System Tools" " щелкнуть по значку "System Restore". Запустив эту программу вы можете сделать откат конфигурации системы на несколько дней назад, если вдруг она "заглючила" или задать новую точку отката, если хотите зафиксировать надежно работающую конфигурацию. Впрочем, система и сама делает снимки системы ежедневно автоматически.

Вопрос Я уже давно общаюсь с компьютерами на "ты", и недавно друг принес мне новый винт Fujitsu MPF3102AH 10Gb. И попросил заново разбить и поставить ему Windows. На нем уже была установлена "Винда". Я запустился с системной дискеты, на которой есть PartitionMagic 5.0 - винт он определил правильно. Я заново разбил винт на 1 диск С:, файловая система FAT32, все как надо, сделал "apply" но процесс разбиения занял уж больно много времени. Потом появилось приглашение, и как всегда, я набрал:
format c: /s - не работает
format c: - не работает
Пишет: Invalid drive specification. Я в тупике, никогда с новыми винтами таких проблем не было, а этот поставил меня в тупик. Что делать?
Ответ Попробуйте для начала это:
1. Сделать загрузочную дискету Windows 98
2. В "CMOS Setup" выбрать "HDD AUTO DETECTION" и установить полученные для вашего диска параметры - скорее всего будет режим LBA, но желательно сравнить полученные параметры с теми, что записаны на корпусе диска - надо чтобы в BIOS он был определен совершенно правильно. Кстати, антивирусная защита в БИОСе должна быть отключена.
3. Загрузить ПК с полученной системной дискеты
4. Программой FDISK удалить все разделы, разбить диск заново
5. Сделать "Format" для всех логических дисков, обязательно после перезагрузки ПК.
Если это не поможет, то лучше будет обратиться к специалистам - они восстановят диск прямым редактированием нулевой дорожки. Или посмотрите какие диагностические утилиты есть на сайте разработчика винчестера.

Вопрос По Вашему совету скачал и установил себе FlashGet. Да, действительно, все замечательно: программа, скорость скачивания, поддержка русского и документация на русском. Спасибо за хороший совет. Но с удивлением обнаружил, что одновременно с установкой программы у меня в Главном меню появилась следующая папка: C:\WINDOWS\Главное меню\Programs\Radiate\Advertising, в которой три ссылки и два ярлыка. Ничего не стал с ними делать до выяснения... Не могли бы Вы подсказать что это?
Ответ Надо купить программу (или скачать кряк:)) , зарегистрировать ее, введя имя пользователя и пароль, полученный от разработчиков, и после этого сделать деисталляцию Radiate из меню "Пуск" - это служба закачки баннеров, окупающая разработку программы при ее свободном распространении. После покупки программы баннеры перестают появляться в окне FlashGet - он без нее прекрасно работает (а вот ReGet - не работает). Полностью паразитического паука-баннерососа можно удалить только программой AD-Aware http://www.lavasoft.de/aaw/ - она избавляет от ручного выявления всех его файлов и ключей в реестре.

Вопрос Скачал из Интернета текстовой редактор TextViewer 1.50 (www.freespeesh.org\georgy). Скачал на Рабочий Стол... Открываю... Получаю вопрос: "Открыть с помощью какой программы?"... А я Интернет себе недавно сделал, и незнаком с этой проблемой. Файл обозначен как тип "Файл 50". Как сделать, чтобы программа работала (т.е. какой нужен тип) и как его поменять с "Файл 50".
Ответ Скорее всего, у вас просто файл каким-то образом переименовался и тип 50 - это всего лишь часть названия программы TextViewer 1.50 - вот эта последняя цифра и воспринимается как тип файла, а окончание потерялось. На самом же деле, за ней должна быть еще одна точка и затем уже тип файла ZIP или EXE (чаще всего именно такие типы встречаются при получении программ из Сети). Переименуйте этот файл в "TextViewer 1.50.EXE" - если не запустится, то в "TextViewer 1.50.ZIP" - этот файл уже надо открывать программой архиватором типа WinZIP. Переименовывать, возможно, придется в "Нортоне" - иначе может не отобразиться полное имя файла (этот режим включается в свойствах папок) - тогда дайте ему имя типа TextV.EXE - чтобы было не более 8 букв

Вопрос Недавно сделал я апгрейд железа, и вот сам не рад. Ставил я Win95, 98, теперь установил ME - со всеми одна проблема - "комп" виснет намертво - помогает исключительно RESET (хорошо, хоть он работает). "Комп" разгонял с 533 до 600 шиной - не помогло! Millennium я ставил на форматированный хард (Fujitsu 2.1 Gb), поставил же его только с 13 раза, до этого "комп" вис на этапе копирования файлов - когда 4% копировало, когда и 92... Потом переставил DIMM 64Mb в другой слот и все поставилось с первой попытки (!). Но в остальном по-прежнему виснет. Как правило, зависания возникали на Win 98 обычном и SE при просмотре всякого HTML'a. Теперь же (в МЕ) систему доводит до висящего состояния Media Player 7.0 - что в нормальном виде, что с визуализаторами. Зависания при работе с HTML тоже присутствуют, но редко. Сдается мне, что все дело в железе. Причем в матери. Конфигурация компа такая: MB - Acorp 6VIA85, CPU - Celeron 533, DIMM 64 Mb, Video - ASUS V3800Pro (TNT2 Pro), HDD - Fujitsu 2.1 Gb, SoundBlaster 16(ISA), CD-ROM Creative Infra 4800 (32x). Ни одного устройства под USB или PCI просто нет. Так в чем же дело?!
Ответ Во-первых, можно попробовать установить систему с выдернутыми компонентами - взять у приятеля, например, другую видеокарту, удалить все остальные платы расширения - так можно выявить источник проблемы. Я очень сильно подозреваю, что у вас виновата память - иногда одна и та же микросхема с одной "матерью" работает хорошо, а с другой - сплошное зависание - тоже поменяйтесь с приятелем на время оперативкой и посмотрите что получится. Ну и если глюк не связался ни с одним компонентом - то виновата материнская плата (или напряжение блока питания, а то и сам процессор). Да, а настройки CMOS Setup проверили - "default" пробовали? Разгон убрали?

Вопрос Поставил Windows Me, установил AtGuard - не пошло. Убрал его, очистил реестр, но в панели управления он остался, и более того - он оттуда запускается, хотя на диске я его найти не могу. Что посоветуете?
Ответ Панель управления AtGuard находится в папке windows\system - это файлы iamcpl.cpl, iamlog.dll, iampw.dll - удалите их.

Вопрос Посоветуйте, какой Firewall лучше подойдет для Windows Me.

Ответ В "Миллениуме" можно использовать Norton Internet Security 2001 FE - это почти тот же самый Atguard, только самая последняя версия и уже от Нортона.

Вопрос Во время работы в интернете в Windows Me всплывает окно со следующим текстом: "IE вызвал ошибку "нет данных" и программа будет закрыта", но далее ничего не происходит. Чем это может быть вызвано?
Ответ Скорее всего, виновата какая-то программа, не вполне совместимая с "Миллениумом". Вам надо только найти виновника, выгрузив все программы из памяти - это может быть и NetMedic и E-Type Dialer - они иногда приводят к таким глюкам. К тому же вряд ли и сам IE безошибочен - Microsoft пока качественными продуктами не очень радует.

Вопрос Можно ли безболезненно сменить fat 16 на fat 32. Установлен Windows Me. Если да то как. В Ме такой опции в служебных программах нет.
Ответ Да, как ни странно, в "Миллениуме" нет конвертера для FAT. Конвертировать диск можно используя Partition Magic - но только его последнюю версию - пятая с "Миллениумом" не хочет работать - надо EXE-файл, сгенерированный и прописанный в неиспользуемый теперь Autoexec.bat, запускать вручную из MS-DOS - сам Windows Me его не запустит и диск не будет конвертирован.

Вопрос Как снести Windows Pro 2000, если на С стоит Windows 98, а на D Windows Pro 2000?

Ответ Загрузить Windows 98, очистить диск D, потом загрузиться с дискеты Windows 98 и выполнить команду sys c: - загрузчик Windows 2000 будет удален

Вопрос А почему в Symantec убрали панель Dashboard в Norton internet Security - ведь это была очень удобная "фича"?
Ответ Я спрашивал у технической поддержки Symantec об этом, они мне написали, что вместо DashBoard теперь Norton Integrator, а "дашборд" хоть и можно вернуть, но он не полностью функционирует и вообще - за него они ответственности не несут. Короче говоря - хорошую вещь убрали только ради того, чтобы лишний раз продемонстрировать свою торговую марку на "Интеграторе".

Вопрос Не могли бы вы помочь мне разобраться в следующей проблеме. После того, как я установил Windows ME вместо Win 98, у меня начались проблемы с сетью. Дело в том, сто на моей машине две сетевых карты (обе Realtec), так как мне нужно сидеть в двух разных сетях нашей фирмы. На моей машине стоит виртуальный почтовый сервер VPOP3, и все получают почту с сервера провайдера через меня.
Так вот, после установки ME одна из сетей постоянно теряется через некоторое время, либо вообще не видна. Я использую протокол TCP/IP со следующей конфигурацией:
1 плата: address - 192.168.0.1 255.255.255.0
2 плата: address - 192.168.1.1 255.255.255.0
Может быть, Вы мне подскажете что-нибудь полезное по конфигурации сети. Обе сети одноранговые без выделенного сервера.

Ответ Попробуйте сделать вот что: С помощью деинсталлятора Ashampoo 2000 сделайте снимок конфигурации системы в тот момент когда обе сети видны. Затем делайте снимок в тот момент когда одна сеть пропала. Сравниваете эти снимки тем же деинсталлятором и смотрите, что изменилось в реестре или конфигурационных файлах - надо попытаться что-то из этого извлечь полезное для понимания причины "глюка". В "Миллениуме" сильно изменился стек TCCP\IP - некоторые программы из-за этого не работают правильно - может есть смысл вернуться к 98? Драйверов свежих нет для сетевых карт? Кабели и соединения не могли как-то пострадать в последнее время?


Вопросы и ответы-3

Сергей Трошин
http://stnvidnoye.chat.ru

Вопрос В Windows Millennium начальная заставка появляется только на секунду-две, а все остальное время загрузки -черный экран с курсором. Как избавиться от этого, чтобы заставка была все время на экране?

Ответ Запустите MSCONFIG.EXE и на вкладке "International" очистите все строки, оставив только MS-DOS Code Page 866 и Country Code 007 - заставка будет все время, но могут возникнуть проблемы с некоторыми русскими DOS-приложениями (русский Нортон работает нормально - все его меню на русском).

Вопрос Поставил Norton Utilities 2001 на WindowsME - а дискдоктор не понимает русские названия файлов и хочет их исправить - что делать?
Ответ Запустите MSCONFIG.EXE и на вкладке "International" введите MS-DOS Code Page=866 и Country Code=007 - Нортон станет понимать русский язык.

Вопрос В русской версии Windows'98 в окнах некоторых DOS - приложений не удается переключить клавиатуру на русский язык. При этом из буфера обмена русский текст вставляется нормально.
Ответ Надо в autoexec.bat дописать строку
keyb ru,,C:\WINDOWS\COMMAND\keybrd3.sys

Вопрос Как настроить автоматический вход в сеть Microsoft при загрузке Windows'95, чтобы не вводить каждый раз пароль?
Ответ С помощью программки TweakUI это сделать довольно легко, вручную же в реестре это прописывается так:
[HKLM \SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon]
"DefaultUserName"="Имя Пльзователя"
"AutoAdminLogon"="1"
"DefaultPassword"="Пароль"

Вопрос Как программно отключить CD-ROM под Windows'9x, а затем программно его включить, чтобы дети не баловались? Если удалить устройство в свойствах системы, то при перезагрузке начинает работать Plug&Play, и оно снова появляется.
Ответ С помощью все тех же программ WinBoost2001 или TweakUI вы спрячете от посторонних глаз любой диск.

Вопрос У меня с жестким диском стали происходить какие-то неприятные вещи. Компьютер довольно долго простоял, не работая. После того, как я его включил, при любой перезагрузке запускается scandisk и слышен звук, похожий на удар головки. Поверхность диска, судя по сообщениям scandisk, в порядке, переустановка Windows'98 не помогла. Что это может быть - питание, кластеры или ...?
Ответ Или... Срочно покупайте новый винт - этот, похоже, скоро отойдет в иной мир.

Вопрос При загрузке W'98 появляется сообщение "Windows 98 is now starting your MS-DOS based program". Как избавиться от этого?
Ответ Проверьте файлы Autoexec.bat и Winstart.bat - видимо из них запускается какая-то DOS-программа.

Вопрос После разбиения нового винчестера программой FDisk на три логических диска, появилась следующая проблема - Windows'95 все диски видит, но при перезагрузке в DOS виден только первый диск из трех. Что тут можно сделать?
Ответ Похоже, вы сделали FAT32-диски, и используете DOS версии 6.22 - поэтому и разделы эти не видны. Используйте родной, "виндовый" режим эмуляции MS-DOS либо загрузочную дискету, сделанную в Windows - в этом случае версия DOS будет 7.0 и выше, и разделы FAT32 будут видны.
Также возможен вариант с материнской платой, не поддерживающей винчестеры более 8.4 гигабайта - почитайте инструкцию к ней (и проверьте, кстати, правильно ли заданы настройки в CMOS Setup для винчестера - в большинстве случаев подходит режим AUTO). При таком раскладе остается использовать программу Ontrack Disk Manager, которая позволяет обойти эту проблему с помощью специального драйвера, записываемого в BOOT-сектор диска - найдете ее на сайте производителя винчестера. Универсальный же вариант этой утилиты для всех дисков ищите на сайте Ontrack: http://www.ontrack.com/.

Вопрос Под Windows'98 запускается DOS-приложение, работающее с внешним устройством через СОМ-порт. Обмен весьма критичен по времени. Пока приложение остается на "переднем плане" обмен идет замечательно, но как только я переключаюсь на другую задачу, все глохнет. Можно ли установить приоритет задачи неизменным и в фоновом режиме?
Ответ Правой кнопкой мыши щелкните по ярлыку DOS-приложения и выбирайте страницу "Свойства"-> "Разное". Убирайте флажок "Фоновый режим. Полная остановка" и ниже передвиньте движок, задающий приоритет задачи, на максимум.

Вопрос Как сменить в Windows'98 пароль на свой сервер удаленного доступа если старый пароль неизвестен?
Ответ Попробуйте удалить и вновь поставить сервер удаленного доступа через меню "Установка - Удаление Программ". Другой вариант - поменять тип сервера на любой другой, а потом вернуть все обратно и задать новый пароль

Вопрос Поставил Windows 98 версия 4.10.2222A и не нашел там Exchange (или Входящие). В Windows 95 OSR2 он поставлялся в дистрибутиве. Это такая версия, или его отдельно надо ставить?
Ответ Да, эту утилиту надо ставить отдельно, вы найдете ее на диске Windows98, предыдущей версии (не SE) в каталоге \Tools\Oldwin95\Messаge.

Вопрос Во многих программах MS Office'97 (Word, Excel) очень долго закрываются документы (файлы). Пробовал переинсталлировать MS Office - никакого результата. Чистил реестр regclean-ом - то же. В чем же дело?
Ответ Возможные варианты: отключить режим быстрого сохранения, отказаться от "Быстрого поиска" - удалив ярлык программы findfast.exe из папки "Автозагрузка". Также, если Office установлен полностью, то надо запустить Microsoft Outlook и в меню Сервис/Параметры/Дневник снять флажки в группе "Записывать также файлы из", и отключить функцию "Архивация дневника". Можно еще отключить опцию включения в сохраняемый файл используемых в документе шрифтов.

Вопрос Windows'98 невозможно переустановить с сохранением всех ранее выполненных настроек и установленных приложений. В конце инсталляции выдается сообщение об ошибке диска или чего-то еще. Переустановка становится возможной только при указании новой папки для файлов системы. Но в этом случае все последующие настройки приходится производить заново. Что предпринять?
Ответ Для начала, попробуйте переустанавливать Windows не из нее же самой, а загрузив компьютер в режиме MS-DOS с дискеты - ее можно создать в меню "Установка - Удаление Программ" - часто помогает. Или же подмените файлы реестра, взяв их из предыдущего варианта Windows - часть установок сохранится, но и ошибок в реестре будет немеренно.

Вопрос Какая программа показывает/убирает часы в панели задач?

Ответ Правой кнопкой мыши по часикам ->"Свойства" -> уберите галочку "Отображать часы".

Вопрос При загрузке Windows98 выдается "недопустимая ошибка" с последующим закрытием программы SPOOL32. При работе часты "глюки", например, зависание Word. Несколько раз переустанавливал Windows'98 - никаких результатов. Что это и как с этим бороться?
Ответ Похоже, все дело в драйверах принтера - поищите свежую версию в Интернете, либо удалите принтер и потом переустановите его заново.

Вопрос Где надо указать драйвер speaker.drv - в win.ini или system.ini - и где именно, чтобы заработала "пищалка" на компьютере?
Ответ В файле System.ini, раздел [drivers]:
Wave=speaker.drv
А вообще драйвер этот здесь-
http://download.microsoft.com/../Speak.exe
- надо распаковать этот архив устанавливать драйвер как новое мультимедиа-устройство с помощью мастера Add New Hardware. Воспроизводятся только WAV-файлы.

Вопрос Как в Win98 разложить меню "Пуск -> Программы" в ширину, чтобы каждый раз не пролистывать его верх/вниз?
Ответ Может лучше рассортировать по смысловым разделам все ярлыки, создав несколько новых подпапок? А вообще, это делает утилита WinBoost2001Gold (параметр "Multiple Columns" в настройках кнопки "Пуск"), вручную же в реестре надо записать:
HKLM\SOFTWARE\Microsoft
\Windows\CurrentVersion\explorer\Advanced
 "StartMenuScrollPrograms"=false

Вопрос Пытался сделать так, чтобы при включении компьютера появлялось сообщение, так называемое "Log On Message" - и с помощью WinBoost и вручную писал в реестре:
HKLM\Software\Microsoft\Windows\CurrentVersion\Winlogon
"LegalNoticeCaption"=заголовок
"LegalNoticeText"=сообщение,
но ничего не сработало. В чем дело, я что-то не туда писал?
Ответ Да нет, все вроде бы правильно, только проверьте в свойствах сети, установлен ли Клиент для сетей Microsoft - без него никаких сообщений не выдается.

Вопрос Прочитал на сайте Сергея Трошина о том, как включить предварительный просмотр мультимедийных клипов прямо в окне Проводника, аналогично превью картинок и веб-страниц. Все классно работает в Windows98, но после установки WindowsME обнаружил, что там файл настройки внешнего вида папок при их отображении в окне Проводника Folder.htt совсем другой, и его совет здесь не срабатывает. Можно ли включить предпросмотр клипов в WindowsME, или в Microsoft отказались от такой приятной "фичи"?
Ответ Да, в "Миллениуме" изменися файл Folder.htt, но эту функцию по-прежнему можно включить. Для этого войдите папку, в которой у вас находится архив с музыкальными или видео клипами и в меню Проводника "Вид" выбирайте пункт "Настроить вид папки". Далее переходите к редактированию файла Folder.htt, выбрав шаблон "Стандарт" (кстати, здесь уже есть несколько готовых шаблонов, в частности, посмотрите тот, что предназначен для папок с графическими файлами - он очень интересен) и ищите в нем строки:
"function IsMovieFile(ext) {
// disabled
return false;"
и
"function IsSoundFile(ext) {
// disabled
return false;"
необходимо перед словом "return" поставить два слэша:
"function IsMovieFile(ext) {
//disabled
//return false;"
и
"function IsSoundFile(ext) {
//disabled
//return false;"
- после этого вы сможете смотреть клипы прямо при наведении на них мыши в окне Проводника. Не забудьте, что при этом возникнут проблемы с удалением клипов, так как после того, как вы наведете на такой файл мышь, он откроется в Универсальном проигрывателе, и система удалить его уже не сможет - придется запускать Нортон.

Вопрос Последнее время стал регулярно получать такой привет от "Виндов":
"Программа EXPLORER вызвала ошибку такую-то в модуле таком-то.DLL по адресу такому-то". В чем может быть дело, почему "Эксплорер" взбесился?
Ответ Скорее всего, ему не нравится какая-то программа, драйвер или системная библиотека. Попробуйте провернуть такую манипуляцию: загрузите режим "Safe Mode" и повторите все операции, приводящие к этому "глюку". Если "глюк" не появился, то проблема вполне легко решается. Перегружайте ПК, выбрав теперь режим пошаговой загрузки, и обходите файлы Autoexec.bat и Config.sys - опять повторяйте процедуру вызова сбоя, и если все нормально, то ищите виновника всех проблем в этих файлах. Если же система по-прежнему выдает сообщение об ошибке, то вызывайте утилиту MSCONFIG.EXE и отменяйте автозагрузку всех модулей, прописанных в реестре, а заодно уберите все ярлыки из папки "Автозагрузка", снова перегружайте ПК и повторяйте все ту же процедуру вызова "глюка". Следующий этап - отмена загрузки программ из Winstart.bat, Win.ini. Опять проверяем, не пропал ли сбой. Затем выставляете в том же MSCONFIG.EXE на закладке "Дополнительно" режим VGA- на тот случай, если конфликтует видеокарта. И, наконец, если ничего не помогло, остается искать причину всех несчастий в драйверах виртуальных и не совсем виртуальных устройств. В пошаговом режиме отмените загрузку "виндовых" драйверов - это VXD-файлы, либо файлы с расширениями .386, .DRV, которые грузятся в самом конце. Пропал сбой - отменяйте "глючный" драйвер. В реестре вы найдете его в качестве параметра StaticVXD где-то в разделе
HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\VxD,
либо поищите вызов этого файла в System.ini. Программа конфигурирования системы MSCONFIG.EXE из состава WoindowsME позволяет очень удобно отменять не только всю автозагрузку, но и показывает на одной из своих страниц все VXD-драйвера, в Win98, к сожалению, придется полазать в реестре вручную.

Вопрос В папке "Мой компьютер" появилась какая-то новая папка без названия, при этом она не работает и никак не откликается на нажатия мыши, как её удалить?
Ответ Компоненты, отображаемые в окне "Мой Компьютер" прописаны в разделе реестра
HKLM\SOFTWARE\Microsoft\Windows\
CurrentVersion\explorer\MyComputer\NameSpace.
Просмотрите там все ключи - те, которые соответствуют удаленному доступу и веб-папкам оставьте, а оставшийся (он, наверное, и будет без названия) - удалите (на всякий случай сделайте резерв реестра).

Вопрос Нажимаю: Пуск/Программы/Стандартные/Служебные/Сведения о системе. Появляется сообщение:"Не удалось вывести сведения. Компонент, отображающий эти сведения работает неправильно или отсутствует на компьютере". Как это исправить или дописать с диска?
Ответ Проверьте наличие файла "C:\Program Files\Common Files\Microsoft Shared\Msinfo\Msinfo32.exe", если он отсутствует - извлеките его с дистрибутива Windows с помощью программы SFC.EXE (Проверка системных файлов) - это и есть вызываемая по вашей команде программа "Сведения о Системе". Она, кстати, переустанавливается вместе с MS-Office.

Вопрос У меня после преобразования диска в FAT32 пропал звук, система говорит, что используется неизвестная программа сжатия и предлагает установить необходимые программы аудиосжатия, но такие программы установлены. Сам по себе Проигрыватель работает, а звуковые схемы - нет, если пробуешь, первый звук воспроизводится, а дальше выдает это сообщение.
Ответ Проверьте файлы, которые прописаны в звуковых схемах - может при преобразовании диска что-то повредилось. Попробуйте переустановить драйвера звуковой карты, потом виндовый медиаплеер - он в составе Internet Explorer имеется, а заодно и аудио-кодеки переустановите (тоже в комплект IE входят, либо в Windows Setup удалите и потом поставьте все заново). С помощью утилиты TweakUI, на вкладке "Repair", восстановите файловые ассоциации. Примените технологию устранения "глюка", приведенную на странице http://stnvidnoye.chat.ru/Files/System.htm. В крайнем случае - переустановите Windows поверх себя же - авось поможет

Вопрос Скажите пожалуйста, а утилита TweakUI в Win98 работает или нет? Если ДА, то как её запустить - она у меня ни как не хочет запускаться. На сайте MICROSOFT сказано, что эта утилита только для Win95 и WinNT.
Ответ TweakUI работает и в Win98/98SE/ME и в WinNT/2000. Чтобы ее установить, надо нажать на файле tweakui.inf правую кнопку и выбрать команду "Установить", после этого запускать ее из Панели Управления.

Вопрос Не могли бы вы прислать мне драйвер для принтера Epson-LX 300. У меня с ним проблема, а обратиться не к кому. Работа горит, сегодня начались отчеты. Пробовал поискать по ссылкам в Интернете, но почему-то не устанавливается соединение с сервером. Короче говоря - одно к одному. Если нет такой возможности, то все равно спасибо, что прочитали "крик о помощи".
Ответ Нет, к сожалению, я драйверы не коллекционирую :) (и программы высылать тоже нет возможности). Так что, попробуйте поискать его все-таки в Интернете - введите в "альтависте" (http://www.altavista.digital.com/) слово "driver" - и получите кучу ссылок на сайты с такими коллекциями - там есть все. Очень хороша для поиска информации и файлов в Интернете мощнейшая программа Copernic 2000 Pro (http://www.copernic.com/) - найдет все что угодно, так как сама осуществляет поиск одновременно по нескольким специализированным "поисковщикам". Или ищите на http://www.computery.ru/service/links/printer.htm

Вопрос Прочитал Вашу статью "Мониторинг связи" в Upgrade N5. Захотелось и себе заиметь NetMedic. Зашел, по указанному Вами адресу, перекачал. После запуска оказалось, что многие параметры, описанные Вами, программа не показывает. Посмотрев внимательно на картинку в журнале, увидел, что это не просто NetMedic, а NetMedic Pro. На сайте я его не нашел. Не подскажете, где его можно найти?
Ответ NetMedic Pro - коммерческая версия, и скачать его так просто нельзя (если только поискать по FTP-серверам "крякнутую" версию, но это на вашей совести), но даже при этом нет гарантии, что он будет полностью функционален, так как он совместим только с Internet Explorer 4, а патча для IE5, как я и писал, не существует. У меня он, правда, полностью работает - почему - не знаю. Попробуйте, может и у вас через некоторое время заработает. Появилась, кстати, ему очень интересная и полностью работоспособная замена - VitalAgent IT (http://www.vitalsuite.com) - практически то же самое, так как от того же разработчика, в чем-то даже мощнее, но чуть менее удобный интернет-монитор.

Вопрос У меня проблема :-(( ! Есть недоноски, называющие себя "хацкерами", которые используют такие вещи как NUKE и FLOOD, в следствии чего вешают "комп" и выкидывают из сети. Как от этого уберечься? У меня стоит файервол AtGuard 3.1, но бесполезно, результат один - синий экран смерти и перезагрузка. Я пообщался с этим гадом, он сказал, что ни одна "винда" перед ним не устоит, ведь у него Free BSD Unix 3.52 И поэтому никто ему ничего сделать не может. Он как-то даже CITYLINE на полчаса подвесил. Как видишь, дело серьёзное, как мне быть, я не могу в "инете" спокойно находится, постоянно синий экран! Что мне делать у меня 98SE+atguard=хрен собачий :-(.
Ответ Раз у вас такой "герой" среди друзей имеется, то попробуйте выходить в Интернет через прокси-сервер интернет-провайдера (обычно они имеют неплохую защиту), или через общедоступный анонимный. Да и поставьте себе заодно вместо AtGuard программу Norton Internet Security 2001 Family Edition v2.5 - это самый мощный на сегодня потомок AtGuard. Либо обновите, по крайней мере, AtGuard до версии 3.22 - у вас почему-то старая 3.1.

Вопрос Подскажите, пожалуйста, можно ли присоединить руль от PlayStation к PC, и если да, то как.

Ответ Есть программы, позволяющие подключать джойстики от приставок к параллельному порту ПК, надо только спаять переходник. Найдете вы их на сайтах:
http://www.ziplabel.com/dpadpro/index.html
http://members.tripod.com/~szanella/
http://atlas.bit.net.au/~johnh/index.html
http://www.csc.tntech.edu/~jbyork/.

Вопрос Не подскажете, какой программой можно восстановить случайно стертый каталог. Пробовал Norton Unerase Wizard - не получается. Может, есть еще какие-нибудь хорошие "проги", восстанавливающие целые папки.
Ответ Отличные программы - Directory Snoop (http://www.briggsoft.com/software.htm) - восстановление стертых файлов из-под Windows, она попроще в работе, а также Tiramisu (она же Easy Recovery, она же Tiramisu Desktop Bundle http://www.ontrack.com/) - из-под DOS, посложнее, но и помощнее.

Вопрос У меня в "Виндах" на карте Aureal Advantage почему-то перепутаны левый и правый каналы. Подскажите, пожалуйста, что можно сделать?
Ответ Если в настройках платы или программного обеспечения, в котором наблюдается этот эффект, нет опции перестановки каналов, то поменять местами динамики, либо перепаять провод, идущий к колонкам - чего уж проще?

Вопрос Купил я Windows Millennium eng. Но вот проблема - как я ни стараюсь - русские буквы не хочет понимать. Если ставлю его на голый винт - везде "Россия" и "кириллица" устанавливаю - ничего не выходит. Когда ставлю поверх Windows98 - все в порядке, но страшные глюки с IE. Стоит чего-нибудь с ИЕ сделать - "стоп" нажать, например, тут же выдает "ОШИБКА В МОДУЛЕ kernell32.dll". Но зато русский понимает :-((((((. Как можно исправить (если можно) вот это вот дело?
Ответ На машине, с нормально понимающими русский язык Windows98, через диалог "Windows Setup" сделайте загрузочную дискету, загрузите с нее свою компьютер, при этом должны правильно отработать все команды из сгенерированных на дискете Autoexec.bat и Config.sys, нужные для поддержки русского языка (выбирайте загрузку с поддержкой CD-ROM). Теперь, когда ваш ПК загрузился в DOS 7.0, и кириллические символы отображаются верно, удалите с винчестера все лишнее, в том числе свои старые Autoexec.bat, Config.sys, а заодно и папки Windows и Program Files, и запускайте установку WindowsME. Не забудьте установить регион - "Россия", русскую раскладку (хотя раскладка и не обязательна, но на всякий случай) и в разделе "Multilanguage Support" - поддержку кириллицы. После завершения установки выберите режим загрузки "Step-By-Step Confirmation" и посмотрите, нет ли ошибок, все ли файлы система находит. Все должно работать.

Вопрос В папке C:\WINDOWS\TEMP постоянно создаются временные файлы, которые система и породившие их программы не удаляют автоматически. Вручную же до них добираться очень неудобно. Что посоветуете, как избавиться от всей этой мороки?
Ответ Во-первых, допишите в файл AUTOEXEC.BATтакие строки:
SET TMP=C:\TEMP
SET TEMP=C:\TEMP
 - временные файлы будут создаваться в более доступной папке C:\TEMP. Во-вторых, добавьте туда же строки:
IF NOT EXIST %TEMP%\*.TMP GOTO NO
ATTRIB +A -H -R -S %TEMP%\*.TMP
DEL %TEMP%\*.TMP
:NO
 - временные файлы будут автоматически удаляться при загрузке компьютера.


Эргономика для браузера: Fast Browser

Эргономика для браузера: быстрота и комфорт

По долгу службы мне постоянно приходится висеть в Сети, причем, как можно догадаться, я там занимаюсь самыми разными делами. Естественно, я пытаюсь найти способы так или иначе оптимизировать свою интернет-деятельность, потому что когда дел много, то сопутствующие этим действиям мероприятия - в частности, общение с программами - способны отнимать огромное количество времени.

Вообще говоря, я пользуюсь обычным IE, который при всех его недостатках мне кажется на данный момент единственным возможным вариантом. Я далек от мысли умалять достоинства альтернативных браузеров, но сам факт их альтернативности неизбежно накладывает отпечаток на процесс работы с ними.

Internet Explorer - тоже, кстати, не безупречная программа: я думаю, каждый пользователь, который провел в Сети какое-то время, найдет, что сказать про него "ласкового", а возможно, даже нецензурного.

Эргономичный браузер Добрые люди посоветовали мне найти какую-нибудь оболочку к этому браузеру. К идее я поначалу отнесся скептически, но после того, как у меня в очередной раз глюкнула машина, уничтожив тем самым результаты многочасовой деятельности в Сети, я понял, что дальше так жить нельзя.

И нашел Fast Browser - программу, с которой жить мне стало легко и приятно. Fast Browser - это утилита, которая встраивает себя в IE, снабжая его массой полезных, очевидных, но почему-то до сих пор не реализованных разработчиками функций. Инсталляция программы проста и незайтелива.

Скачиваем архив (www.fastbrowser.net), запускаем его, он совершает несколько неочевидных телодвижений, после чего можно запускать обновленный браузер. Кстати: программа не лишает вас возможности поработать с чистым IE, его можно запустить в любой момент, другой вопрос, что в этом необходимости уже не будет.

Первое, чем отмечается утилита в системе, - довольно сильными изменениями во внешности окна Explorer (смотрим на иллюстрацию). Вообще говоря, Fast Browser еще и скины поддерживает в большом количестве, но ставить я их не стал, ибо практика показывает, что любая "скинизация" негативно сказывается на общей производительности программы. Каждое новое открытое окно IE теперь не появляется на панели задач, а аккуратно возникает в общем окне Fast Browser - снизу (опять-таки внимательно смотрим на иллюстрацию).

Честно говоря, это крайне удобно не только потому, что теперь гораздо проще найти нужное окошко из пятидесяти открытых, но и потому, что отменился как класс известный глюк IE, когда в какой-то момент все окна браузера самопроизвольно вываливаются, а из трея пропадают иконки. Разумеется, это все лечится либо соответствующими патчами, либо утилитами сторонних разработчиков, но согласитесь - так приятнее.

Все стандартные возможности IE после установки Fast Browser никуда не деваются, зато добавляется много новых. Программа поддерживает с десяток европейских языков, в том числе, например, португальский. Для того чтобы программа начала понимать русский язык, необходимо скачать соответствующий плагин с сайта разработчика.

По умолчанию программа сильно интегрирована с сервисом Google, который не только способен выполнять роль переводчика (правда, весьма кривого), но и может помочь в нелегком деле поиска всяких нужных вещей как в Сети в целом, так и на отдельно взятом сайте, что бывает особенно полезно. При желании можно попросить Fast Browser даже подчеркнуть найденные им соответствия критериям поиска на отдельно взятом сайте.

Несмотря на то, что Fast Browser вполне корректно работает с Favorites, он в состоянии создавать и собственные каталоги сайтов. Называется эта штука Groups, и она очень грамотно, на мой взгляд, сделана: возможности по сортировке - велики, описания, которые можно давать ссылкам, - удобны, короче, работать с данной функцией - одно удовольствие.

Удобно устроена и система управления страницами, с которыми пользователь работает в данный конкретный момент. Есть такие полезные опции, как обновить все открытые страницы, прекратить загрузку всех открытых страниц одновременно, произвести какое-либо действие со всеми страницами, кроме активной.

После установки Fast Browser работа в Сети становится заметно безопасней, чем до нее. Дело в том, что в программе есть довольно развитая система управления (вернее, отключения) всякими там ActiveX, JavaScript и прочими гипотетически неприятными вещами, что, разумеется, не гарантирует тепла и сухости, как памперс, но лишним тоже не является.

До кучи Fast Browser еще и говорить умеет! Вернее, он не сам разговаривает (то есть сказку на ночь он вам не расскажет), а зачитывает либо веб-страницы, либо тот текст, которые ему предоставляет пользователь.

Разумеется, до дикции и внушительности Левитана программе далеко, но иногда бывает приятно, к тому же можно выбирать персонажа, который будет говорить.Все эти функции в той или иной степени можно найти и в других сходных программных продуктах, но Fast Browser хорош именно тем, что в нем реализованы только те из них, которые действительно полезны - или становятся полезны со временем.

Он способен заменить собой целую кучку разношерстных программ - и при этом еще сделает работу в Сети весьма комфортной.

Конечно, и у Fast Browser есть недостаток, правда, только один: профессиональная версия программы - платная. Но тут уж ничего не поделаешь - хорошие вещи всегда стоят денег.

Remo


Я теперь уж и не помню, как надо устанавливать Windows!

Степан Плюшкин

Сколько времени потратил на частые переустановки Windows, аж страшно вспомнить. Семья - четыре человека. Каждому надо поставить что-то свое. Поставлено уже столько, что даже бедный антивирус пыхтит при очередной проверке компа. А программы все ставятся и ставятся, ими все пользуются и пользуются, а дети Windows все ломают и ломают. Чистка реестра уже ничего не дает. Остается одно. Пе-ре-ус-та-но-вить. Впереди восемь часов одной только установки - рабочий день, а точнее ночь, т.к. утром на работу, жене компьютер нужен с утра, детям после занятий, а мне после работы надо еще настроить Windows. Вот однажды и решил. Хватит. Посижу один раз подольше, зато сэкономлю время в дальнейшем.Итак:

1. Установил дистрибутивы Windows 98 и Me на диск D.

2. Перенес все нужные файлы (папки) с диска С на диск D.

3. Отформатировал диск С командой FORMAT C: /U /S и при этом не пожалел. Диск хоть и был почти новый, а все же нашлись bad-кластеры.

4. Установил на диск D Windows 98, все драйвера. Файлы с корневой директории диска С перенес на дискету. Получился загрузочный диск для 98-ого.

5. Снова отформатировал диск С той же командой: FORMAT C: /U /S. Спросите почему, да потому, что при дальнейшей установке Windows на диск С система не обнаружит виндовоз диска D и не будет пытаться копировать из него файлы.

6. Установил на диск С Windows ME, драйвера, все нужные программы, включая и Office.

7. Настроил Windows, который поставил на диск С. Как это сделать, я писать не буду. Немало статей, посвященных этой теме, было опубликовано в электронном журнале Internet Zone.Затем почистил реестр.

8. Занялся виндовозом диска D. Создал папку на диске D. Переместил туда папки: Program Files и папку виндовоза диска D, из которой удалил файл подкачки - Win386.SWP. Архиватором сделал из папок один общий архив. Если вы пользуетесь архиватором WinRAR, то можно сделать самораспаковывающийся архив и дописать в него комментарий:

Path=D:\
Silent=2

Чтобы убедиться в работоспособности полученного архива, надо его испытать. Для этого разархивировал его на диск D и перезагрузил компьютер, предварительно вставив загрузочную дискету, созданную в пункте 4. Если у вас загрузится Windows диска D, то значит Ваш архив работоспособен. В противном случае надо повторить операцию по созданию архива. Архив по размеру получается совсем небольшой, если сделать его с максимальным сжатием. Размер моего архива с установленными драйверами составляет всего 90,1 Mb.

9. Так как загружен Windows диска D, то делаю архив виндовоза диска С (аналогично п.8), перед этим удалив файл подкачки: снова создаю папку, переношу туда папки Program Files и Windows диска С, добавляю туда файлы из корневой директории диска C, архивирую их, если у Вас архиватор - WinRAR, можно сделать самораспаковывающийся архив с комментарием:

Path=C:\
Silent=2

Проверяю его работоспособность: разархивирую его на диск С и перегружаю компьютер. Не забудьте вытащить дискету. Она предназначена только для загрузки Windows на диск D. Если загрузился Windows диска С, то все в порядке. Нет, повторите создание архива. Размер архива моего "миллениума" - 505 Mb, при этом, кроме самого "миллениума" стоит Word 2002, Excell 2002, Access2002, FrontPage 2000, программы обслуживания компьютера, программы создания видеороликов и графики, программы для работы с Интернетом и другие.

10. Создал папку для архивов Windows и перенес их туда. Тот, кто имеет программу создания виртуальных дисков, может создать виртуальный диск с архивами или, если это возможно, скиньте их на CD.

Теперь у меня - два Windows на разных дисках. Можно экспериментировать с одним из них, проверять создаваемые программы, а в случае повреждения легко восстановлю и при этом не надо будет заново устанавливать программы. Полетел Windows диска С: вставляю загрузочную дискету 98-ого, загружаюсь, удаляю папки Program Files и Windows диска С, удаляю файлы из корневой директории диска С, восстанавливаю их из архива, перезагружаю компьютер на Windows диска С и при этом не забываю вытащить загрузочную дискету. Полетел Windows диска D: удаляю папки Program Files и Windows диска D, восстанавливаю их из архива.

Этот способ установки Windows позволяет устанавливать винды в разных сочетаниях. Кто из вас тратил на установку Windows+Microsoft Office и кучи программ меньше 20 минут? Никто! Попробуйте. Вам понравится. А я уже и не помню, как надо устанавливать Windows. Будут вопросы, ищите меня на моем сайте.

Домашняя страница автора: http://www.plyushkin.fromru.com/


Как избежать зависаний компьютера или О прерываниях: маленький ликбез

Виктор Куц

Редко какой компьютер, особенно домашний, проживет всю свою жизнь, ни разу не подвергшись или модернизации, или добавлению новых устройств. В большинстве случаев, естественно, при соблюдении самых элементарных правил, такая операция проходит безболезненно, не вызывая никаких особых проблем. Но примерно каждый десятый (или даже двадцатый - не суть важно) компьютер доводится до нерабочего состояния: начинает часто зависать, отказывается выполнять какие-либо функции, а то и просто вываливается в столь любимый всеми нами синий экран смерти. Как правило, наиболее вероятная причина таких неполадок кроется в конфликтах оборудования (нового и старого), не поделивших какие-либо аппаратные ресурсы. Хорошо, если Ваша квалификация позволяет решить возникшие проблемы, или поблизости есть кто-то, который может Вам помочь, а если ничего подобного нет? Однако не боги, как известно, горшки обжигают, посидим, подумаем - глядишь, и прорвемся, ведь не так уж все и сложно, хотя проблема совместимости самого различного оборудования, с момента своего возникновения в середине 80-х годов, до сих пор ни сколько не уменьшилась. Предлагаемая статья поможет пользователю разобраться с одним из видов аппаратных ресурсов, требующихся для оборудования, и чаще всего являющихся первопричиной всевозможных конфликтов - с аппаратными прерываниями (IRQ).

Аппаратные ресурсы системы

Компоненты для своей работы могут требовать три основных вида различных аппаратных ресурсов. Практически любое устройство использует один или несколько портов ввода/вывода. В данном случае имеется в виду не последовательный или параллельный порт, а просто специальный адрес, что-то вроде адреса в оперативной памяти. Работа с этими портами осуществляется специальными командами центрального процессора, с помощью которых в порт или записывается какая-либо информация, или считывается из него. Зачастую обмен информацией между процессором и устройством идет только через порты, причем некоторые устройства берут на себя десяток, а то и более адресов портов, каждый из которых служит для выполнения какой-то определенной функции.

Гораздо реже используются каналы прямого доступа к памяти (DMA - Direct Memory Access). Данный тип взаимодействия предназначен для устройств, обменивающихся большими блоками данных с оперативной памятью, например, дисковые накопители или принтеры. Весь обмен идет в обход центрального процессора, который лишь инициирует операцию обмена и сразу же приступает к выполнению другой работы. Такой подход способен значительно увеличить производительность всей системы.

А третьим видом ресурсов являются аппаратные прерывания, которые являются базовым механизмом реакции системы на внешние события. Аппаратные прерывания, называемые обычно IRQ (Interrupt ReQuest) - это физические сигналы, с помощью которых контроллер устройства информирует процессор о необходимости обработать некоторый запрос. Условно схема обработки прерывания может выглядеть следующим образом:

  • процессор получает сигнал прерывания и его номер;
  • по специальной таблице отыскивается адрес программы, ответственной за обработку прерывания с данным номером - обработчика прерывания;
  • процессор приостанавливает выполнение текущей задачи, сохраняет промежуточные результаты и переключается на выполнение обработчика прерывания;
  • процессор получает доступ к устройству и проверяет причину возникновения прерывания;
  • запускаются запрошенные действия - инициализация, конфигурирование устройства, обмен данными и др.;
  • по выполнению всех необходимых операций процессор возвращается к прерванной задаче.

В отличие от программных прерываний, вызываемых исполняемой прикладной программой, аппаратные прерывания могут происходить в самые неожиданные моменты времени, и, кроме того, могут возникнуть одновременно сразу несколько прерываний. Для того чтобы система не слишком "задумалась", какое прерывание обслуживать в первую очередь, существует специальная схема приоритетов. Каждому прерыванию назначается свой уникальный приоритет. Если приходит одновременно несколько прерываний, то система отдает предпочтение самому высокоприоритетному, откладывая на время обработку остальных, менее важных, прерываний.

Распределение прерываний

Рассмотрим, как обычно распределяются прерывания в стандартном компьютере. Некоторые из номеров жестким образом привязаны к определенным устройствам, некоторые можно освободить и использовать для своих нужд. Начнем по порядку:

  • IRQ 0 - прерывание системного таймера. Генерируется 18,2 раза в секунду. Применяется в данном качестве с момента создания первого компьютера IBM PC (для другого использования этот номер недоступен);
  • IRQ 1 - прерывание клавиатуры. Генерируется контроллером клавиатуры при каждом нажатии на клавишу (для другого использования номер недоступен);
  • IRQ 2 в компьютерах класса XT, использовавших только 8 линий прерываний, был зарезервирован для дальнейшего расширения системы и, начиная с машин класса AT, стал использоваться для подключения второго контроллера. Сегодня IRQ 2 используется системой для совместимости со старым программным обеспечением, для другого использования номер недоступен;
  • IRQ 3 - прерывание асинхронного порта COM 2. Этим же прерыванием пользуются еще и устройства, работающие через порт COM 4. При желании их можно отключить, но присвоить IRQ 3 все равно больше никому не удастся;
  • IRQ 4 по аналогии с предыдущим, это прерывание используется устройствами, занимающими порты СОМ 1/COM 3;
  • IRQ 5 изначально предназначалось для использования вторым параллельным портом LPT2, но потом, когда от второго параллельного порта отказались, IRQ 5 перешло в разряд свободных. Позже активно использовалось большинством звуковых карт ISA. современные PCI-звуковые карты используют это прерывание исключительно для совместимости со старыми играми, подавляющее большинство которых поддерживают SB Pro. IRQ 5 можно использовать для других целей и привязать к слоту PCI;
  • IRQ 6, начиная с первых PC, используется флоппи-контроллером (для другого использования номер недоступен);
  • IRQ 7 - по умолчанию прерывание первого параллельного порта LPT 1. При отключенном порте (если принтер отсутствует или рассчитан на USB) может использоваться различными устройствами. IRQ 7 можно привязать к слоту PCI;
  • IRQ 8 - прерывание часов реального времени, впервые появившихся в IBM AT. Другое использование невозможно;
  • IRQ 9 и IRQ 10 свободны;
  • IRQ 11 обычно резервируется для шины USB, однако может применяться и в других целях (для этого следует отключить поддержку USB в BIOS);
  • IRQ 12 используется для мыши типа PS/2, однако может применяться в других целях (если мышь PS/2 отсутствует или отключена);
  • IRQ 13 изначально применялось арифметическим сопроцессором, и теперь оно зарезервировано для совместимости со старым программным обеспечением (для другого использования номер недоступен);
  • IRQ 14 и IRQ 15 применяются, соответственно, первичным и вторичным IDE-контроллерами.

Узнать, как в данный момент распределены номера прерываний в Вашем конкретном случае можно несколькими способами. При запуске компьютера, еще до начала загрузки Windows, появляется текстовая таблица конфигурации. Сразу после нее идет перечень PCI-устройств с указанием назначенного им номера IRQ.

Или, если Вы все еще работаете с Windows 9x, то в панели управления есть иконка Система, щелкните на ней - и выбирайте закладку "Устройства". В свойствах устройства "Компьютер" можно найти перечень всех устройств с указанием их IRQ. В Windows 2000/ХР у нас нет непосредственного доступа к управлению прерываниями, поэтому для просмотра списка IRQ нужно воспользоваться стандартной информационной утилитой (Панель управления/Администрирование/Управление компьютером/Сведения о системе/Ресурсы аппаратуры). Ну и, наконец, никто не отменял использование утилит, тестирующих аппаратные и программные возможности компьютера.

Среди них, без сомнения, самой популярной является SANDRA, способная предоставить пользователю исчерпывающую информацию, в том числе и о прерываниях.

Конфликты устройств

Не вдаваясь в излишние детали, можно сказать, что конфликт - это ситуация, при которой несколько объектов одновременно пытаются получить доступ к одному и тому же системному ресурсу. Конфликт прерываний возникает в том случае, если несколько устройств используют одну и ту же линию прерывания для посылки сигнала запроса и отсутствует механизм, позволяющий ранжировать эти запросы, в результате чего происходит либо сбой, либо одно из устройств попросту перестает работать. Чтобы четко представлять себе, как можно избежать конфликтов или устранить их, нужно разобраться в механизме управления IRQ.

Как Вы знаете, персональные компьютеры начались с IBM PC ХТ. Его архитектура предусматривала всего восемь линий аппаратных прерываний, которыми управлял специальный контроллер. Каждой из них назначался свой уникальный номер, который определял приоритет прерывания и адрес его обработчика (так называемый вектор прерывания). Следующий вариант архитектуры, IBM PC AT, дополнил существующие линии еще восемью, для управления которыми использовался второй контроллер, подключаемый к одной из линий прерывания первого контроллера. К сожалению, на этом данная архитектура остановилась в своем развитии, поэтому все современные компьютеры, несмотря на значительно возросшее число используемых в них дополнительных устройств, по-прежнему имеют только шестнадцать линий прерываний, одно из которых резервируется для эмуляции второго контроллера.

Изначально у компьютера IBM PC AT была только одна шина, по которой устройства могли общаться с процессором и памятью - ISA. Большинство линий прерываний были закреплены за стандартными ISA-устройствами, поэтому, когда появилась новая универсальная шина PCI, выяснилось, что на ее долю осталось всего четыре свободные прерывания, обозначаемые как INT A, INT B, INT C, INT D, поэтому всего только четыре PCI устройства могут получить в системе независимые прерывания. Но при этом необходимо учитывать, что на особенном положении находится контроллер IDE, который не входит в число тех четырех устройств только потому, что, хотя по способу передачи данных он и является PCI-устойством, но за ним жестко закреплены свои прерывания IRQ 14 и IRQ 15, как для старых устройств ISA. Для шины AGP, которая является разновидностью шины PCI, "пожертвован" INT A, а шина USB, как один из системных компонентов, подключается к PCI, используя INT D, что уменьшает число "честных" PCI устройств всего до двух. Не следует забывать и о подсистеме управления питанием Power Management/System Management, которая так же требует своего прерывания. Таким образом, в реальной жизни, при наличии нескольких устройства PCI, использующих прерывания, невозможно обеспечить им уникальные аппаратные IRQ, и в таких случаях используются аппаратно-программный способ, основанный на базе технологии Plug&Play, что теоретически позволяет избежать возникновения конфликтов. Хотя в реальной жизни может случиться все, что угодно, да и оставшиеся до сих пор устройства ISA не умеют делиться линиями прерываний, потому являются основными провокаторами конфликтов. Таким образом, задача устранения конфликтов сводится к правильному распределению номеров прерываний в случае возникновения проблем с устройствами ISA или "глючными" драйверами.

В системе номера IRQ распределяются между физическими линиями дважды. Первый раз это делает системный BIOS при начальной загрузке системы. Каждому Plug&Play-устройству (а к ним относятся все PCI, современные ISA и все интегрированные на системной плате устройства) назначается один номер из числа доступных. Если номеров не хватает, несколько линий получают один общий. Для устройств PCI это не страшно - при наличии нормальных драйверов и поддержки со стороны операционной системы все должно нормально работать. А вот если один номер получают несколько ISA-устройств или не менее "гремучая" смесь из PCI- и ISA-устройств, то конфликт попросту неизбежен, и тогда придется вмешиваться в процесс автоматического распределения прерываний. В этом случае необходимо отключить все неиспользуемые ISA-устройства (в системах без слотов ISA они, тем не менее, присутствуют: это порты COM1, COM2 и дисковод). Также можно отключить режимы EPP и ECP порта LPT, освободив при этом прерывание IRQ7. Все операции по изменению прерываний в BIOS Setup осуществляются в разделе "PCI/PNP Configuration". Есть два способа повлиять на распределения номеров IRQ: заблокировать конкретный номер и напрямую назначить номер линии. Первый способ доступен для всех BIOS, корректируются пункты меню "IRQ x used by:" (в новых BIOS скрывается в подменю "IRQ Resources"). Тем прерываниям, которые должны быть назначены исключительно ISA-устройствам, нужно поставить "Legacy ISA". Тем самым при раздаче номеров для PCI-устройств данные прерывания будут пропущены. Поступать так следует в том случае, если какое-либо ISA-устройство упорно становится на одно прерывание с PCI-устройством, из-за чего оба они не работают. В таком случае необходимо найти номер этого IRQ и заблокировать его. PCI-устройство переходит на новый номер IRQ, а ISA-устройство остается "при своих". Второй способ управления номерами IRQ - прямое назначение, хотя и несколько сложнее первого, но гораздо более эффективный. Очень прискорбно, что далеко не все современные системные платы позволяют осуществлять эту операцию. В том же подменю BIOS Setup могут быть пункты вида "Slot X use IRQ" (другие названия: "PIRQx use IRQ", "PCI Slot x priority", "INT Pin x IRQ"). Эта опция позволяет устанавливать прерывания индивидуально каждому устройству на PCI и AGP шине. При этом необходимо соблюдать следующие правила:

  • Каждый PCI слот может активизировать до четырёх прерываний - INT A, INT B, INT C и INT D;
  • AGP слот может активизировать два прерывания - INT A и INT B;
  • Нормально когда каждый слот назначен как INT A. Остальные прерывания зарезервированы, если PCI/AGP устройство потребует больше, чем одно прерывание или если запрашиваемое прерывание занято;
  • AGP слот и PCI слот 1 распределяют одинаковые прерывания;
  • PCI слоты 4 и 5 так же распределяют одинаковые прерывания;
  • USB использует PIRQ_4.

Ниже приведена таблица, показывающая связь между PIRQ (Programmable Interrupt Request - программируемый запрос прерывания) и INT (Interrupt - прерывание):

Сигнал | AGP Slot PCI Slot 1 | PCI Slot 2 | PCI Slot 3 | PCI Slot 4 PCI Slot 5
PIRQ_0 | INT A | INT D | INT C | INT B
PIRQ_1 | INT B | INT A | INT D | INT C
PIRQ_2 | INT C | INT B | INT A | INT D
PIRQ_3 | INT D | INT C | INT B | INT A

Обычно следует оставить опцию в положении AUTO. Но, если возникла необходимость установить индивидуальное IRQ устройству на AGP или PCI шине, прежде всего, необходимо определить, в каком слоте установлено устройство. Потом, сверившись с таблицей, можно установить основной PIRQ. Например, если сетевая карта установлена в слот 3, то основной PIRQ будет PIRQ_2, потому как все слоты назначаются, по возможности, на INT A. После этого выбирается желаемое IRQ, присваивая ему соответствующее значение PIRQ. Только необходимо помнить, что BIOS будет пытаться назначить PIRQ в INT A для каждого слота. Так что, для AGP и PCI 1 слотов основной PIRQ это PIRQ_0, тогда как для PCI слота 2 основной PIRQ это PIRQ_1 и так далее. Второй раз номера прерываний распределяются операционной системой, хотя Windows 9х начинает вмешиваться в произведенные BIOS-ом действия только в крайних случаях. В Windows 98 управление системой распределения IRQ осуществляется с помощью стандартного менеджера устройств. В списке системных устройств нужно найти шину PCI.

В ее свойствах есть особая закладка. Если все настроено правильно, там будет упомянут минипорт ("успешно загружен"), а управление шиной PCI (Steering) будет включено. Таким образом, Windows'98 имеет средства для управления распределением номеров прерываний между физическими линиями. Но поскольку и BIOS чаще всего с этим хорошо справляется, этот механизм не задействуется. Но иногда он просто необходим. При использовании устаревших ISA-устройств, не поддерживающих технологию Plug & Play, BIOS может его и не заметить, отдав занятое им прерывание PCI-устройству - опять конфликт. Для его разрешения необходимо нужное прерывание зарезервировать в диспетчере устройств Windows'98.

Кроме резервирования, можно непосредственно задать номер прерывания для устройства. Для этого нужно в его свойствах найти закладку "Ресурсы", отключить автоматическую настройку и попытаться изменить назначенный номер прерывания. Будьте осторожны, такая операция срабатывает далеко не всегда и порой может привести к совершенно непредсказуемым результатам.

А вот о Windows 2000 (а равно и ХР) - разговор отдельный. Если у Вас достаточно современный компьютер, то он наверняка поддерживает интерфейс конфигурирования ACPI. Windows 2000 в таком случае вообще проигнорирует действия BIOS и "повесит" все PCI-устройства на одно логическое прерывание. В общем случае это будет отлично работать (когда нет устройств ISA), но иногда могут возникнуть проблемы. Чтобы получить возможность изменять номера прерываний, нужно либо поменять HAL-ядро, либо переустановить Windows 2000 с отключенным в BIOS ACPI. Замена ядра производится так: в диспетчере устройств выбирается "Компьютер/Компьютер с ACPI", после этого необходимо изменить драйвер на "Стандартный компьютер" и перезагрузиться. Если это не поможет, придется переустановить Windows 2000 заново.

Заключительные советы

Установив новую операционную систему со всеми драйверами устройств и, убедившись в том, что она работает без проблем, стоит записать все настройки компьютера, особенно если осуществлялись какие-либо изменения установок по умолчанию. Надежнее всего такую информацию записать на обычном листке бумаги. Такая информация может быть очень полезна при внесении каких-либо изменений в настроенную систему, а так же поможет решить проблемы, которые могут возникнуть, если при установке нового оборудования все настройки "съедут" (такое иногда тоже бывает). И, самое главное, помните: большинство возникающих проблем связано с низким уровнем компьютерной грамотности хозяина компьютера. Поэтому нужно всегда стремиться к самообразованию, тогда и проблем будет поменьше, а те, что все-таки возникнут - не будут казаться неразрешимыми.

Источник: http://www.4User.ru/


С чего начинается Windows...

Начинается он с двух постулатов: операционная система Windows 9х - не такая простая штука, как многим кажется, а программисты Microsoft не ставят перед собой задачи как следует поиздеваться над пользователями с помощью изощренных сбоев и глюков. Качество и надежность работы Windows зависит от множества факторов, и первый из них, как ни парадоксально (это не парадоксально, а скорее естественно - прим. ред.) - компьютерная грамотность пользователя.

Совершенная система, то есть система, которая ни при каких условиях не будет реагировать на любые разрушительные действия пользователя или некорректно написанной программы, должна попросту не позволять им эти действия совершать, то есть в идеале вообще обходиться без пользователя и стороннего программного обеспечения. Такого результата можно, например, добиться, если запретить пользователю менять какие-либо настройки, скрыть от него как можно больше всевозможных меню и панелей управления и сделать так, чтобы он мог запускать только одно-два проверенных приложения.

В Windows 9x такое в принципе допустимо, утилиты типа WinBoost 2001 Gold или System Policy Editor позволяют спрятать от шаловливых ручонок юзеров почти все элементы управления, хоть сколько-нибудь влияющие на работу и настройки ОС. Но такой подход годится разве что для интернет-кафе или игровых клубов, где админ обязан любой ценой сохранить работоспособность парка машин, невзирая на постоянные атаки вандалов-посететителей. И даже в таких заведениях все равно не удается обоходится без периодического восстановления информации с помощью программ, делающих резервные копии - клоны содержимого жестких дисков. Но дома ведь не станешь сам же от себявсе прятать, даже если знаешь, что временами любимое пиво становится причиной неадекватного поведения!

В таких случаях спасает только доскональное изучение операционной системы и работы по профилактике сбоев в виде резервирования жизненно важных конфигурационных файлов, благо таких файлов не так уж и много. Часто причина "глюка" находится в неприметной строчке одного из тщательно скрытых от глаз пользователя системных файлов. Они хоть и предназначены для настройкиразличных и достаточно важных параметров ОС, но искать документацию по ним в системе помощи Windows практически бесполезно.

Пользователям, желающим повысить живучесть Windows 9x, надо четко знать, какой файл в ОС за что отвечает и какой параметр на что влияет, дабы всегда целенаправленно искать источник возникших проблем. Настройки Windows 9х задаются еще на этапе загрузки операционной системы, в процессе которой один за другим обрабатываются всевозможные "конфиги". Поэтому пользователь, который хочет общаться с системой "на ты", обязан также абсолютно четко знать азы работы операционной системы: как происходит загрузка ОС, в каком порядке она обращается к системным файлам, каким образом можно управлять процессом загрузки и как конфигурировать систему под свои нужды.

Без этих основополагающих знаний причины многих элементарно разрешимых проблем навсегда останутся тайной за семью печатями для пользователей, которые не стараются вникать в работу ОС подчас из-за примитивной лени.

Включение компьютера

Загрузка операционной системы - строго регламентированная процедура, во время которой какие-либо сбои абсолютно недопустимы. Если что-то нежелательное все же происходит, то для того, чтобы устранить причину неполадок, надо выяснить, на каком этапе загрузки ОС они произошли, а для этого необходимо представлять себе, как эта самая загрузка производится.
При включении компьютера в первую очередь происходит загрузка BIOS, самой главной программы, "вшитой" в одну из микросхем ПК, и начальное тестирование памяти и оборудования (так называемый POST - Power-On Self Test).

Bсе происходящие при этом процессы отображаются на экране в виде минимума информации об обнаруженных устройствах и в ряде случаев сопровождается звуковыми сигналами "пищалки" компьютера. Сигналы эти предназначены для оповещения пользователя о проблемах, возникших во время инициализации оборудования, и помогают определить причину неисправности, даже если из-за какой-то поломки отсутствует вывод изображения на экран монитора. Более или менее общепринятая расшифровка этой "азбуки Морзе" приведена в таблице (самую точную информацию по звуковой сигнализации вы найдете, обратившись на сайты производителей ваших материнской платы и BIOS.).

По окончании тестирования и инициализации оборудования осуществляется считывание в память внесистемного, общего для всех ОС загрузчика (Non-System Bootstrap - NSB), расположенного в стартовом секторе физического жесткого диска, в так называемой главной загрузочной записи (Master Boot Record). Загрузчик создается во время разбиения и конфигурирования жесткого диска программой fdisk и является довольно привлекательной целью для деструктивных вирусов.

Звуковые сигналы POST
один длинный непрерывный гудок или очень много коротких | проблемы с блоком питания
один длинный плюс два или три коротких сигнала | проблемы с видеокартой
один длинный и один короткий гудок | проблемы с материнской платой
один короткий | ошибка регенерации RAM либо проблемы с монитором или видеокартой, самая безобидная ошибка
два коротких | ошибка четности памяти
три коротких | неисправна оперативная память (ошибка в первых 64 кб)
четыре коротких | отказ системного таймера
пять коротких | отказ процессора
шесть коротких | отказ контроллера клавиатуры
семь коротких | ошибка при проверке виртуального режима центрального процессора
восемь коротких | неисправна видеокарта
девять коротких | неверная контрольная сумма BIOS
десять коротких | ошибка при считывании или записи CMOS RAM

Восстановить его при повреждении можно, переразбив диск заново (и потеряв информацию на нем). Или использовав утилиту fdisk с недокументированным ключом MBR, предназначенным для восстановления главной загрузочной записи диска: "fdisk /mbr" - но и в этом случае вам для восстановления информации с "убитого" диска придется воспользоваться программами типа Easy Recovery (http://www.ontrack.com/) или Lost & Found (http://www.powerquest.com/).

В обязанности NSB входит уже считывание и запуск системного загрузчика (System Bootstrap - SB), который устанавливается вместе с ОС и находится в стартовом секторе логического диска (Boot Record). В Windows 9x этот загрузчик восстанавливается командой sys C:, вводимой после загрузки ПК с системной дискеты, созданной специально для этого предусмотренным инструментом: "Панель управления" > "Установка и удаление программ" > "Загрузочный диск" (Control Panel >Add/Remove Programs>Boot Disk).

Директивы, которые могут встретиться в разделе [Options] файла msdos.sys
Параметр | Назначение
AutoScan | Управляет режимами запуска ScanDisk после некорректного завершения работы Windows. Полезен, если другими путями от постоянного сканирования диска избавиться не удается.
BootConfig | Недокументированный переключатель позволяет обрабатывать текущие параметры загрузки.
BootDelay | В Windows 95 пауза после выдачи сообщения "Starting Windows 95" (в секундах). Запрещает выдачу этого сообщения.
BootFailSafe | В Windows 95 вызывал загрузку в режиме защиты от сбоев. Теперь следует использовать параметр BootSafe.
BootGUI | Управляет загрузкой графической оболочки, в "Миллениуме" не действует.
BootKeys | Управляет использованием горячих клавиш, применяемых для быстрого выбора отдельных пунктов загрузочного меню
BootMenu | Управляет появлением загрузочного меню
BootMenuDefault | Устанавливает пункт загрузочного меню, который будет выбран системой по умолчанию, даже если меню не открывается
BootMenuDelay | Задержка в секундах при выводе загрузочного меню, по истечении которой автоматически выбирается пункт, установленный по умолчанию
BootMulti | Управляет возможностью двухвариантной загрузки. В Windows Me не используется
BootSafe | Управляет принудительной загрузкой режима защиты от сбоев
BootWarn | Управляет выдачей предупреждающего сообщения при выборе режима защиты от сбоев. Лучше отключить
BootWin | Управляет загрузкой ОС при выборе предыдущего режима MS-DOS
Logo | Управляет графической заставкой Windows, отображаемой при загрузке ОС
DisableLog | Управляет созданием файла протокола загрузки bootlog.txt. Протокол полезен при диагностике причин сбоев. Лучше выключить, чтобы ускорить загрузку ОС
DoubleBuffer | Управляет двойной буферизацией, необходимой некоторым SCSI, старым ESDI/IDE/ATA и большим (более 8 Гб) приводам с FAT32. Если вашему диску не требуется, то лучше выключить
DrvSpace | Управляет загрузкой драйвера сжатия дисков DrvSpace (если он имеется на диске). Если сжатие дисков не используется, то желательно отключить
DblSpace | Управляет загрузкой драйвера сжатия дисков DoubleSpace. Если сжатие дисков не используется, то лучше отключить
LoadTop | Управляет загрузкой файлов command.com и drvspace.bin (dblspace.bin) в область оперативной памяти выше первых 640 кб. Можно использовать для совместимости с некоторыми программами, которым нужны верхние адреса
SystemReg | Управляет сканированием реестра при загрузке ОС
Network | Управляет отображением пункта "Safe Mode with network support" в загрузочном меню
WinVer | Отображает версию ОС

Директивы, которые могут встретиться в разделе [Options] файла msdos.sys
Параметр | Значение по умолчанию | Возможные значения
AutoScan | 1 - выдается запрос на осуществление проверки диска, а если пользователь на него не реагирует в течение минуты, то проверка диска запускается автоматически | 0 - никогда не запускать ScanDisk 2 - сканирование производится автоматически без запроса
BootConfig | 1 - используются текущие параметры загрузки | 0 - используются альтернативные параметры
BootDelay | В Windows 95 - 2 секунды. В Windows 98/Me - 0 с. |
BootFailSafe | 0 - нормальный режим загрузки | 1 - Windows загружается в режиме защиты от сбоев
BootGUI | 1 - загрузка GUI разрешена | 0 - загрузка произойдет только до командной строки MS-DOS
BootKeys | 1 - горячие клавиши разрешены | 0 - запрещены
BootMenu | 0 - для вызова меню надо нажать F8 или Ctrl | 1 - меню появляется автоматически
BootMenuDefault | 1 - нормальная загрузка | 2 - 8 - любой из пунктов меню
BootMenuDelay | 30 секунд | 0 - 99
BootMulti | 1 - в загрузочном меню будет пункт для выбора предыдущей ОС | 0 - пункта "Предыдущий режим MS-DOS" в меню не будет
BootSafe | 0 - загрузка произойдет в нормальном режиме | 1 - система будет загружена в режиме защиты от сбоев
BootWarn | 1 - сообщение будет выдаваться | 0 - предупреждение выдаваться не будет
BootWin | 1 - загружается Windows | 0 - загружается предыдущая ОС (MS-DOS 6.xx)
Logo | 1 - логотип отображается | 0 - логотип отключен
DisableLog | 1 - протокол создается | 0 - протокол не создается
DoubleBuffer | 0 - двойная буферизация запрещена | 1 - двойная буферизация включается при необходимости 2 - двойная буферизация включена всегда
DrvSpace | 1 - DriveSpace включен | 0 - DriveSpace не загружается
DblSpace | 1 - DoubleSpace загружается всегда, даже если не используется | 0 - DoubleSpace не загружается
LoadTop | 1 - файлы загружаются в верхние адреса стандартной памяти, экономя тем самым базовую память | 0 - файлы расположены в первых 640 кб, верхние же адреса достаются требующим их приложени
SystemReg | 1 - реестр сканируется | 0 - реестр не сканируется
Network | 1 - пункт присутствует в меню | 0 - пункт отсутствует в меню
WinVer |  | 4.90.3000 Windows ME, 4.10.2222 Windows 98 SE, 4.10.1998 Windows 98

Загрузка MS-DOS

Далее в Windows 9х начинается этап, называемый в Microsoft "фазой совместимости с операционной системой реального режима". В переводе на нормальный язык это означает загрузку старичка MS-DOS, без которого Windows работать не в состоянии - в дело вступает файл io.sys (ядро DOS), находящийся, как и многие другие системные файлы, в корневом каталоге загрузочного диска. Файл io.sys должен располагаться в строго определенном секторе жесткого диска, и в случае каких-либо повреждений надо переписать его заново командой "sys C:" (так что спасательной загрузочной дискетой пренебрегать ни в коем случае не стоит).

Надо заметить, что помимо загрузки ядра MS-DOS, на которое опирается в своей работе Windows, в функции io.sys входит еще и отображение начальной заставки - логотипа Windows, которая находится в упакованном виде в коде этого файла. Картинка из io.sys выбирается Windows в том случае, если в корневой директории системного диска отсутствует файл logo.sys с альтернативной заставкой.

Модуль io.sys в Windows совмещает в себе функции двух основополагающих файлов из MS-DOS старых версий (по 6.22 включительно) - собственно самого io.sys и файла msdos.sys, который сейчас тоже существует, но уже в несколько другой роли - самого первого конфигурационного файла, обрабатываемого Windows на данном этапе загрузки. В нем содержится несколько базовых параметров, управляющих запуском ОС, и ошибка в этом файле может привести к неэффективному расходованию машинных ресурсов или полной невозможности загрузить ПК.

Файл msdos.sys является обычным текстовым, его можно открыть и отредактировать в каком-нибудь простом текстовом редакторе или даже во встроенном редакторе простейшей DOS-оболочки Norton Commander. Или воспользуйтесь утилитой MSDOS.SYS Editor (http://www.dx21.com/). Она хороша для начинающих пользователей, у нее понятный графический интерфейс для редактирования любых параметров этого файла.

При работе с MSDOS.SYS Editor абсолютно не требуется знание ни параметров msdos.sys, ни правил их написания - программа сама сделает все за вас, лишь флажки ставьте, где нужно. Учтите только, что ввиду важности файла msdos.sys ему присвоены атрибуты "Только чтение", "Системный", "Скрытый", поэтому перед его изменением вам надо будет позаботиться об их снятии. Для этих целей можно использовать все тот же Norton Commander. Или просто снять флажки этих атрибутов в появившемся диалоговом окне, щелкнув по значку файла в "Проводнике" правой кнопкой мыши и выбрав в контекстном меню пункт "Свойства" (разумеется, необходимо, чтобы скрытые файлы отображались в "Проводнике" - этот режим устанавливается в диалоге "Свойства папок").

Не забудьте только потом вернуть все снятые атрибуты на место - устойчивость системы от этого немного повысится. Да и резервная копия этого файла (как и всех остальных конфигурационных файлов), сделанная перед экспериментами по его редактированию, будет совсем не лишней. Однако помните, что если у вас имеются сжатые утилитой DriveSpace диски, то еще один файл msdos.sys должен находиться в корневой директории сжатого диска, причем оба файла должны быть идентичны.

При открытии файла msdos.sys видны два раздела - [Path] и [Options] с набором параметров в каждом из них. Комментарии записаны в строках, начинающихся с точки с запятой - ";". Таких строк в этом файле - пара десятков, а в подавляющем большинстве из них прописан набор крестиков. Это сделано для совместимости с некоторыми программами, дабы файл msdos.sys имел размер не менее килобайта - строки эти удалять не нужно. Кстати, без этого файла некоторые DOS-программы тоже не работают, хотя сама Windows в нем, в принципе, не нуждается.

В разделе [Path] прописаны важнейшие пути к системным папкам и файлам Windows, которые необходимо задавать исключительно в стандарте 8.3, то есть не используя длинные названия - имя папки не должно содержать более 8 букв:
HostWinBootDrv=С - буква диска, с которого следует загружать ОС;
WinBootDir=C:\WINDOWS - путь к папке Windows с системными файлами;
WinDir=C:\WINDOWS - путь к папке, в которую установлена Windows;
UninstallDir=С - диск, на котором расположены файлы w98undo.dat и w98undo.ini, предназначенные для удаления Windows. Этот пункт не появляется при чистой установке системы или при отказе от сохранения системных файлов. Он отображается в том случае, если при установке ОС поверх ее предыдущего варианта вы выбрали сохранение файлов старой ОС для сохранения возможности последующего возврата к ней.

В разделе [Options] уже гораздо больше параметров, которые имеют вид типа "параметр=значение", при этом каждый параметр обязательно располагается в отдельной строке. Если какой-то параметр не записан в вашем файле или записан с ошибками, то система использует то его значение, которое принято по умолчанию. Так что совсем не обязательно прописывать в этот файл все, что только можно. Наиболее подробный перечень параметров msdos.sys приведен на сайте MAX Speed WinDOwS (members.aol.com/axcel216) в разделе MSDOS.SYS, но при желании вы без труда найдете в интернете и другие материалы с расшифровкой этих параметров, в том числе и на русском языке.

Продолжение


С чего начинается Windows...-2

С чего начинается Windows... - 2

Сергей Трошин

Ну вот мы и добрались до момента, когда на экране появилась надпись "Starting Windows 98...". Если в этот момент нажать клавишу "F8" или "Ctrl", то вы получите еще одну возможность управлять загрузкой ОС с помощью специального загрузочного меню, состоящего в Windows 9х из восьми пунктов, а в "Миллениуме" - из четырех.

Normal - продолжение загрузки в обычном режиме, если вы попали в загрузочное меню случайно или не хотите выбирать другие опции.
Logged (/BOOTLOG.TXT) - нормальная загрузка с созданием в корневой директории системного диска файла bootlog.txt с подробным протоколом хода загрузки компонентов ОС. Данный режим чрезвычайно полезен при поиске и анализе возможных причин неполадок, в частности, причин зависания ПК на этапах загрузки или выключения. Удобный интерфейс для анализа протокола загрузки дает утилита BootLog Analizer(www.vision4.dial.pipex.com).

Safe mode - режим защиты от сбоев, при котором в память загружается минимальный набор сверхнадежных драйверов: драйвер сжатых дисков DoubleSpace или DriveSpace, расширенной памяти himem.sys, файловой системы ifshlp.sys, драйверы клавиатуры, мыши, VGA-адаптера. Директивы из конфигурационных файлов config.sys, autoexec.bat и system.ini игнорируются, а автоматически загружаемые программы не запускаются. Если в этом режиме глюк пропадает, то ищите его причину в тех драйверах и программах, которые работают в фоновом режиме при выборе нормальной загрузки ОС. При некоторых сбоях доступ к управлению ОС можно получить только из этого режима, называемого иногда "безопасным".

Safe mode with network support - тоже загрузка в режиме защиты от сбоев, но еще и с сетевой поддержкой (в Windows 98 / Me отсутствует).

Step-by-step confirmation - пошаговая загрузка системы: вы можете выбирать, какую директиву конфигурационных файлов следует выполнять, а какую надо игнорировать. Драйверы виртуальных устройств в этом режиме загружаются также только после вашего подтверждения. Используется, когда надо выяснить, какая конкретно строка в конфигурационных файлах (например, в autoexec.bat) вызывает сбой, или когда необходимо отменить загрузку проблемного драйвера.

Command prompt only - загрузка системы только до командной строки, без графической оболочки Windows. Фактически при этом вы получаете чистый MS-DOS седьмой версии, входящий в состав Windows 9х. Причем игнорируются не только файлы config.sys и autoexec.bat, но и скрытые в io.sys директивы, подменяющие эти файлы в случае их отсутствия. Загружается только драйвер сжатых дисков, если таковые имеются. Чтобы запустить затем GUI (графический интерфейс) надо набрать на клавиатуре команду win. В "Миллениуме" эта возможность была исключена, и теперь для полноценного выхода в MS-DOS надо создавать загрузочную дискету и грузить ПК уже с нее.

Safe mode command prompt only - режим защиты от сбоев без графической оболочки, в Windows Me опять-таки отсутствует.
Previous version of MS-DOS - загрузка предыдущей версии MS-DOS (плюс Windows 3.11, если она у вас стояла). Для того чтобы этот пункт работал, надо сохранить резервные копии системных файлов MS-DOS 6.22 с расширениями .dos в корневой директории системного диска. ОС при выборе данного пункта их переименует так, чтобы они получили нормальные названия, типа autoexec.bat.

А "виндовые" файлы будут временно переименованы в файлы с расширением .w40 (чтобы не запутаться, после выбора предыдущей ОС не удаляйте никакие файлы в корне системного диска, к тому же порой Windows не может вернуть все имена к исходному состоянию и приходится это делать вручную). Учтите, что если в файле msdos.sys прописалась строка BootMulti=0, то этот пункт отображаться в загрузочном меню не будет. В "Миллениуме" он также не предусмотрен.

После того, как вы выберете режим загрузки или проигнорируете вызов загрузочного меню, загрузится драйвер сжатых дисков dblspace.bin или drvspace.bin, (если вы, конечно, ранее не отключили его автоматическую загрузку в файле msdos.sys и он имеется на диске). Но поскольку сегодня мало уже кто использует сжатие дисков (разве что на старых ноутбуках), то весьма рекомендую сэкономить немного памяти и времени, отказавшись от загрузки этих драйверов, для чего следует задать соответствующий параметр в msdos.sys.

Далее будут считаны некоторые параметры из системного реестра, проанализированы аппаратные средства компьютера. И если у вас имеется несколько конфигураций оборудования, заданных в свойствах системы на странице "Профили оборудования", вам будет предложено выбрать нужную конфигурацию.

Затем последует исполнение инструкций файла config.sys, второго конфигурационного файла Windows, опять-таки расположенного в корневой директории системного диска. Этот файл предназначен для задания некоторых ключевых системных параметров и загрузки драйверов реального режима. Он также является обычным текстовым файлом, поэтому для его редактирования достаточно обычного текстового редактора, хотя в Windows 98 появилась и гораздо более удобная и безопасная утилита для редактирования основных конфигурационных файлов - "Программа настройки системы" (System Configuration Utility, исполняемый файл - msconfig.exe).

Главное преимущество этой утилиты в том, что в ней предусмотрена возможность отмены ошибочно введенных изменений. Необрабатываемые комментарии в config.sys также начинаются с точки с запятой либо со слова "rem" (ремарка, комментарий). Но, по большому счету, файл этот операционной системе не очень-то и нужен, так как все необходимые Windows параметры задаются автоматически еще на этапе загрузки файла io.sys. В нем содержатся все нужные системе параметры, используемые в том случае, если в config.sys явно не прописаны альтернативные установки. Получается, что "винды" сами загружают по умолчанию как бы "невидимый" config.sys, содержащий набор параметров "по умолчанию" (см. таблицу 1).

Таблица 1
dos=high | ядро MS-DOS помещается в высокую память, что немного высвобождает базовую память
device=c:\windows\himem.sys | драйвер обеспечивает доступ к расширенной и верхней памяти
device=c:\windows\ifshlp.sys | драйвер поддержки файловых систем, без него Windows обычно не может загрузиться
device=c:\windows\setver.exe | драйвер нужен для того, чтобы устаревшие приложения не отказывались работать с современными реализациями MS-DOS - на запрос старой программы он отвечает, что установлена именно та версия MS-DOS, которая ей нужна
fileshigh=30 | максимальное количество одновременно открытых файлов, для многих DOS-программ требуется увеличить это значение до 100
lastdrivehigh=z | последняя буква, которую можно использовать для обозначения дисков
buffershigh=30 | количество буферов дискового ввода-вывода
stackshigh=9,256 | количество и размер стеков, предназначенных для временного хранения различной системной информации
shell=command.com /p | путь и параметры используемого командного интерпретатора
fcbshigh=4 | количество блоков управления файлами, необходимых старым DOS-программам

Все эти параметры и драйвера грузятся, даже если в вашем config.sys они не прописаны и даже если у вас вообще отсутствует такой файл. Значения, задаваемые командами files, lastdrive, buffers, stacks, fcbs, и драйвер setver.exe нужны только приложениям MS-DOS. И вообще, хотя и параметров, команд, драйверов, задаваемых через config.sys, очень много, чаще всего этот файл используется для загрузки каких-либо специфичных DOS-драйверов.

Windows же обычно все это хозяйство абсолютно не нужно, так как она имеет собственные 32-разрядные драйверы для любого устройства. Исключение составляет, пожалуй, лишь поддержка кириллицы. Чтобы эта самая поддержка кириллицы работала, необходимо, чтобы в config.sys присутствовали следующие строки:
device=C:\Windows\Command\display.sys con=(ega,,1)
country=007,866, C:\Windows\Command\country.sys
- а в файле autoexec.bat, о котором речь пойдет ниже, строки:
mode con codepage prepare=((866)C:\Windows\Command\ega3.cpi)
mode con codepage select=866
keyb ru,, C:\Windows\Command\keybrd3.sys.

В Windows Me, однако, ситуация несколько иная - файлы config.sys, command.com и autoexec.bat уже не обрабатываются системой при загрузке, а переменные среды окружения (Environment Variables) берутся из системного реестра. Так что вписать в него свой драйвер вам не удастся - ОС этого не позволит, перезаписав измененный файл старым вариантом (за это отвечает программа regenv32.exe), так что о его содержимом пользователям "Миллениума" задумываться не надо.

Если же возникла необходимость что-то подправить, то делать это следует с помощью программы msconfig.exe. Вы можете изменить значения некоторых переменных среды окружения либо региональные установки, так как поддержка кириллицы в Windows Me включается тоже только через эту утилиту, которая заносит соответствующие настройки в системный реестр.

В Windows 98 же файл config.sys позволяет создавать даже меню мультиконфигурации, при использовании которого вы получаете шанс при каждой загрузке выбирать нужные в данный конкретный момент параметры, а также соответствующую этим параметрам ветвь в файле autoexec.bat, что просто незаменимо для тех, кто часто использует MS-DOS - получается очень гибкая и удобная система. Подробную документацию о работе и редактировании файла config.sys, о его параметрах и драйверах вы найдете в этом архиве: stnvidnoye.chat.ru/Files/main_files/DOS622.zip.

После обработки config.sys в Windows 98 загружается командный интерпретатор command.com - программа, отвечающая, например, за такие задачи, как прием и выполнение команд; выполнение пакетных файлов (с расширением .bat); загрузка в память DOS-программ. По умолчанию используется command.com, находящийся в корневой директории системного диска, хотя с помощью команды shell в config.sys можно задать любой путь к этому файлу. Файл этот тоже легко восстанавливается командой "sys C:" после загрузки ПК с дискеты.

С помощью только что загруженного command.com обрабатывается файл autoexec.bat, предназначенный для запуска резидентных DOS-программ, для выполнения каких-либо команд или установки некоторых системных параметров. Как и config.sys, файл autoexec.bat не является жизненно необходимым для Windows, поскольку все, что нужно операционной системе, задается в "скрытом" autoexec.bat, также встроенном в файл io.sys (см. таблицу 2).

Таблица 2
@echo off | отключение вывода информации на экран при выполнении команд из autoexec.bat
net start | загрузка сетевых компонентов реального режима, если они установлены
set tmp=C:\Windows\Temp | установка значения переменной TMP - путь к папке временных файлов
set temp=C:\Windows\Temp | установка значения переменной TEMP - опять путь к папке временных файлов
set comspec=C:\command.com | задается значение переменной COMSPEC - путь к командному интерпретатору
prompt $p$g | настройка вида курсора командной строки MS-DOS
path C:\Windows; C:\Windows\Command | пути поиска исполняемых файлов, если при вводе команды путь явно не задавался дискового ввода-вывода

Если вас по какой-то причине не устраивают эти параметры, то отменить автоматическое выполнение всех директив из "невидимых" конфигурационных файлов можно, надо лишь в config.sys добавить строку "dos=noauto" или записать в один из конфигурационных файлов явную команду, изменяющую требуемый параметр.

На этом фаза загрузки компонентов реального режима завершается. Посмотреть, что в результате загрузилось, можно, введя в строке "Выполнить" меню "Пуск" команду "mem /p/c" или "mem /d/p" - перед вами предстанет картина занятости памяти с перечнем всех загруженных DOS-драйверов и резидентных программ. Присутствие каких-либо DOS-драйверов без четко осознанной необходимости, строго говоря, не рекомендуется. Windows не всегда способна их отключить, подменяя своими драйве рами, а это серьезно снижает и быстродействие системы, и ее устойчивость.

Поэтому убедитесь в том, что вы не используете такие драйвера, заглянув еще и на страничку "Быстродействие" свойств системы. Если используется какой-то нежелательный DOS-драйвер, то там будет присутствовать запись "Режим совместимости" вместо "32-битный". В этом случае придется просмотреть еще раз все конфигурационные файлы и удалить строку, вызывающую загрузку старого драйвера.

Загрузка Windows

Теперь начинается загрузка самой Windows. Автоматически запускается стартовый файл win.com, загружается диспетчер виртуальных машин из файла vmm32.vxd и создается системная виртуальная машина. После этого автоматически исполняется еще один недокументированный командный файл - winstart.bat, если он имеется в корневой директории системного диска или в одной из папок, указанных в переменной PATH. Из него можно загрузить в системную виртуальную машину некоторые резидентные DOS-программы так, чтобы они не занимали ценную базовую память, используемую при запуске программ MS-DOS из-под Windows (в "Миллениуме" этот файл не обрабатывается).

Далее загружаются статические (то есть постоянно находящиеся в памяти) драйвера. При этом сначала загружаются статические драйвера виртуальных устройств, прописанные в разделе реестра HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\VxD и имеющие параметр StaticVxD.

Далее загружаются драйвера, упакованные внутри главного файла Windows - vmm32.vxd, формируемого во время установки ОС на этапе определения имеющегося в наличии оборудования. Этот файл уникален для каждого компьютера, поскольку в нем как бы собраны воедино используемые на данной машине драйвера. Собственно именно поэтому при повреждениях этого файла вас спасет только его удаление и переустановка системы, во время которой он будет создан заново. Посмотреть, какие драйвера в vmm32.vxd заключены, вы можете в файле system.ini, в разделе [386Enh] - ищите там строки типа "device=" - это и будет список драйверов vmm32.vxd. И наконец, загружаются драйвера из папки C:\Windows\System\VMM32.

Если какое-то устройство или программа после удаления некорректно подчистила за собой реестр или файл system.ini, то при загрузке ОС иногда выдается сообщение об отсутствии требуемого системе файла. Если ОС говорит, что нет какого-то файла с расширением .386, то "закомментируйте" его вызов в файле system.ini, поставив перед строкой с ним точку с запятой, например:
;device=Example.386.

Если же расширение - .vxd, то придется поискать его вызов в реестре, в ключе HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Services\VxD - удалите здесь упоминание о нем, предварительно сохранив реестр на случай непредвиденных ошибок и сбоев. А если система запрашивает конкретно файл vnetsup.vxd, что бывает часто после удаления компонентов Microsoft Network в свойствах сети, то удалите параметр StaticVxD в ключе HKEY_LOCAL_MACHINE\System\ CurrentControlset\Services\VxD\vnetsup.

Затем доходит очередь до обработки еще одного конфигурационного файла - уже упоминавшегося system.ini - выполняются те его команды, которые не присутствуют в реестре, причем записи в system.ini имеют приоритет перед аналогичными параметрами: если есть какая-то несогласованность system.ini с реестром, то система выбирает запись из system.ini - он для нее главнее. Файл этот, как и Win.ini, является рудиментом, оставшимся от Windows 3.11 и нужен для сохранения совместимости со старыми приложениями. Однако удалять ни тот, ни другой ни в коем случае не стоит, несмотря на утверждения Microsoft о вторичной роли этих файлов - Windows хранит в них множество критичных параметров, без считывания которых во время загрузки ОС не сможет работать.

Расположены они в папке Windows и являются текстовыми файлами, составленными по весьма несложным правилам. Если в этих файлах какой-то обязательный параметр не прописан, то используется значение по умолчанию, ремарки, как обычно - точка с запятой, а максимальный размер этих файлов ограничен 64 кб. Редактировать их удобнее всего с помощью все той же "Программы настройки системы", а почитать о параметрах, используемых в этих файлах, лучше всего на сайте MAX Speed WinDOwS (members.aol.com/axcel216), одном из лучших и наиболее информативных сайтов, посвященных недокументированным настройкам Windows.

Далее процессор компьютера переключается в защищенный режим, и загружаются динамические драйвера виртуальных устройств - их список берется из раздела реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class - там загрузчики этих драйверов прописаны в параметрах DevLoader. И наконец, загружается ядро Windows (файлы krnl386.exe, kernel32.exe, gdi.exe, gdi32.exe, user.exe, user32.exe); шрифты; исполняются команды последнего конфигурационного файла (если не считать реестра) win.ini; загружается графическая оболочка; запрашивается пароль пользователя на вход в Windows; формируются параметры интерфейса в соответствии с установками текущего пользователя; запускаются программы, автозагрузка которых прописана в реестре или задана с использованием папки "Автозагрузка" меню "Пуск".

Кстати, запуск этих программ можно оперативно отменить, если при загрузке графической оболочки Windows держать нажатой кнопку "Shift". Список загруженных динамических и статических драйверов можно проконтролировать, воспользовавшись утилитой "Сведения о системе", которая умеет выдавать целую кучу и других, не менее полезных данных ("Пуск">"Программы">"Стандартные" > "Служебные">"Сведения о системе">"Программная среда"> "Драйверы">"Драйверы ядра", а для англоязычных версий - Start > Programs>Accessories>System tools> System Information > Software Environment > Drivers > Core drivers).

В заключение хочу упомянуть еще один недокументированный файл - dosstart.bat, расположенный в папке Windows. К загрузке операционной системы он, правда, отношения не имеет: команды из него выполняются, когда вы выбираете в меню "Завершение работы" опцию "Перезагрузить компьютер в режиме MS-DOS". С помощью dosstart.bat вы легко обеспечите в этом режиме и автоматический запуск Norton Commander, и поддержку мыши, и кэширование дисков, и работу с CD-ROM, получив тем самым все то, что вам нужно в работе с DOS-программами. В "Миллениуме" он, как и режим MS-DOS, естественно, отсутствует.

Таким образом, для загрузки Windows необходимы следующие файлы: io.sys; command.com (в "Миллениуме" не обязателен); system.ini; win.ini; файлы реестра system.dat;, user.dat (в "Миллениуме" еще и classes.dat). Файлы msdos.sys, config.sys и autoexec.bat требуются только для специфического конфигурирования ОС, и Windows может обходиться и без них. Все эти файлы грамотный пользователь должен регулярно сохранять в специально отведенной для резервного копирования папочке, только в этом случае вы практически без усилий, воспользовавшись системной дискетой, восстановите сбившиеся настройки и вернете систему к жизни.

И уж, по меньшей мере, рекомендуется хотя бы приблизительно представлять, для чего каждый файл необходим и какое влияние на систему в целом оказывают его параметры - это еще больше облегчит выявление причин внезапных сбоев, а в идеале позволит заставить любимые "форточки" работать максимально надежно и быстро.

Источник (оригинальная версия): http://www.computery.ru/upgrade/


Параллельная сеть или зачем компьютеру LPT-порт

Засланец

Параллельная сеть или зачем компьютеру LPT-порт

Георгий Башилов

Вам когда-нибудь доводилось инсталлировать операционную систему на мини-ноутбук без встроенного привода CD-ROM и с девственно чистым (за исключением разве что DOS) жестким диском? Элементарная операция, решаемая для настольного компьютера на раз, в случае с ноутбуком таит ряд неожиданностей и неприятных сюрпризов, особенно для человека, "испорченного" plug'n'play. Подключение привода CD-ROM через PCMCIA-адаптер - задача под DOS нетривиальная (начиная с того, что такой привод еще придется поискать). То же касается и подключения к локальной сети: мне, например, так и не удалось установить Microsoft Network Client для MS-DOS (помещенный на CD-ROM с дистрибутивом NT 4.0 как раз для целей инсталляции) из-за отсутствия подходящего драйвера для сетевой карточки. Теоретически, конечно, можно записать дистрибутив прямо на винчестер, вставив его в съемный рэк для 2,5-дюймовых дисков (и предварительно разобрав ноутбук), но где гарантия, что при обратной процедуре не обнаружатся "лишние детали"?

Перебрав несколько вариантов, какие-то - в уме, какие-то - на практике, и убив на это немало времени, я вспомнил о полузабытом, чуть было даже не выброшенном интерфейсном кабеле, позволявшем соединять два компьютера через параллельные порты. В прайс-листе "Бурого Медведя" он так и называется, "Нортон" (интересно, получает ли Питер лицензионные отчисления?) и стоит, в зависимости от длины, от 3 до 6 долларов: правда, длиннее 6 метров не бывает. Через несколько минут, установив на ноутбук Norton Commander и убедившись что параллельные порты на обоих компьютерах сконфигурированы одинаково (режим ECP, использующий непосредственный доступ к памяти, пожалуй, является лучшим выбором), я предвкушал победу.

Здесь необходимо сделать лирическое отступление. Хотя возможность двунаправленной связи через параллельный порт известна давно, на уровне приложений она до сих пор не стандартизована - по крайней мере, мне не известны программы, которые в описании настроек соединения ссылались бы на общепринятые стандарты или позволяли устанавливать соединения с программами других производителей. Таким образом, из NC можно соединиться только с NC (то же касается любой другой программы), при этом один из "Нортонов" устанавливается в положение client, а другой - в master. В моем случае на ноутбуке NC исполнялся в привычном ему DOSовском окружении, на настольном же компьютере ему пришлось трудиться в сеансе DOS под управлением Windows 2000 - другой ОС под рукой не оказалось.

Признаться, меня ждало глубокое разочарование. Нет, соединение установилось сразу (по зрелом размышлении скорее всего это была просто случайность), но вот скорость передачи данных заставляла задуматься о том, какой же все-таки интерфейс я использую - параллельный или таки последовательный: даже на то, чтобы открыть оглавление директории на другом компьютере, "Коммандеру" требовалось несколько десятков секунд, а попытка открыть в многозадачной Windows 2000 еще одно приложение или даже переключиться между открытыми окнами, как правило, приводила к сообщению об ошибке и разрыву соединения [1]. Нехитрые манипуляции с настройками DOS-сеанса позволили увеличить скорость соединения в несколько раз, так что на перекачку трехсотмегабайтного дистрибутива потребовалось бы, по скромным прикидкам, часов семь. И это через параллельный порт, который в теории обеспечивает скорость передачи данных около 2 Мбит/с!

Ясно, что в происходящем можно было винить либо некорректную работу с параллельным портом в сеансе DOS/Windows 2000, либо слишком быстрый процессор. Либо и то и другое.

Обычно, во избежание таких ситуаций, в одном из разделов диска компьютера под управлением Windows NT/2000 устанавливают Windows 95 или DOS. Свободных разделов, однако, у меня не оказалось, да и держать на одном компьютере две коммерческие ОС - роскошь, наверно, непозволительная, даже в век почти бесплатных гигабайтов.

Пришлось в очередной раз просить у моря погоды и забрасывать сетевой невод. Рыбка, в него попавшая, оказалась хоть и мелкая (zip в 10 Кбайт), но увесистая - сервер параллельного порта для DOS, обеспечивающий клиентские подключения с Windows-компьютеров из файлового менеджера Windows Commander (да простит меня Роман Косячков за любовь к этому выходцу из стана "командиров нортонов"). Как оказалось, сервер этот появился еще в версии 4.50 (сейчас на сайте Гислера доступна 4.53), и в каждой из ОС Wincmd коннектится с ним уникальным способом.

Для целевого компьютера (в нашем случае - ноутбука) потребуется только загрузочная досовская дискетка с программами fdisk, format и lptdos [2]. Если жесткий диск уже отформатирован, то хватит трех файлов: io.sys, command.com и lptdos.exe общим объемом около 320 Кбайт. На источнике под Windows 95/98 драйвер cglpt9x.vxd автоматически загружается в момент инициализации соединения и, выполнив задачу, динамически выгружается. Для Windows 3.1 драйверов не потребуется вовсе. Под Windows NT/2000 используется особый драйвер, cglptnt.sys, или, в терминологии разработчиков Wincmd, Parallel port class driver, разработанный специально для разблокирования прямого доступа к параллельному порту и посимвольной и блочной передачи данных (правда, как утверждается в описании, для его подключения потребуются полномочия администратора).

Дальнейшая процедура проста: на целевом компьютере запускаем сервер параллельного порта lptdos, а на источнике, из Windows Commander, - клиентскую часть (меню Commands/PORT Connection to other PC). Единственное, что не стоит позволять Wincmd, так это проявлять излишнюю интеллектуальность: встроенная процедура тестирования после недолгого раздумья может сообщить не только, что кабель распаян неправильно, но и даже как, по ее мнению, нужно исправить ошибку. Однако у меня и без всяких переделок соединение заработало, и с вполне удовлетворительной скоростью - чуть меньше 100 Кбайт/c, так что перекачка дистрибутива заняла чуть меньше часа - примерно столько же занимает его инсталляция.

Правда, как Microsoft прощается с DOS, так и новые модели ноутбуков постепенно избавляются от параллельных портов. Интересно, что мы будем делать дальше?

[1] - Примерно то же самое случилось и у меня при связи ноутбука под Windows 98 с настольным компьютером под Windows 2000 через стандартный для Windows интерфейс Direct Cable Connection: настольная машина соглашалась быть исключительно клиентом и, судя по скорости, плодотворно эмулировала Intel 386 на двухпроцессорной 500-мегагерцовой конфигурации, а домашняя сеть вообще тихо скончалась и потребовала переустановки.
[обратно к тексту]

[2] - Для нетривиальной задачи установки софта на мини-ноутбук и без флопповода, и без CD-ROM-драйва (как у меня, к примеру), можно сначала таки воспользоваться нортоновским коннектом для перекачки lptdos.exe. - Scout.
[обратно к тексту]


Засланец-2 или Как сделать еще проще

Обсуждение проблемы соединения двух компьютеров по com или lpt-портам получило некоторое развитие, вылившееся в эту статью.

Дмитрий Шарапенко

Эта статья является логическим продолжением материала "Засланец", повествующего о соединении компьютеров посредством параллельных портов (в частности, подключение ноутбука к настольному ПК). Эта тема получила определенный отклик, как в нашей конференции, так и в переписке читателей с автором. Ниже будет приведено одно такое письмо, а также описание одной программки, которой предпочитаю пользоваться я. Оба способа предполагают использование загрузочной дискеты и обычного ДОСовского режима.

Итак, способ первый, с помощью небезызвестного Norton Commander'a. В случае, если на настольном ПК установленно нечто, с ДОСом несовместимое, то предполагается загрузка с компакта, содержащего NC в качестве оболочки.

Предлагаю читателям Софттерры рассмотреть более традиционный способ перекачки информации по lpt-кабелю (очень надеюсь, что этот совет поможет тем, у кого нет возможности забрасывать сетевой невод) взамен предложенному в статье "Засланец".

Начальная ситуация: есть ноутбук (сойдет любая "либретта" от Toshiba). Нет CD-ROM. Есть в данном ноутбуке отформатированный "голый" винт и на нем только системные файлы (io.sys, msdos.sys и command.com - как было указано в статье). Так же в распоряжении имеется любой персональный компьютер с CD-ROM, позволяющий проводить загрузку ОС, можно даже без жесткого диска, а также lpt-кабель для связи двух компьютеров (есть разные способы разводки, значительно влияющие на скорость обмена данными) и загрузочный CD, корректно инициализирующийся CD-ROM. Подойдет любой пиратский диск из серии ABSOLUT или REANIMATOR. Либо диск изготавливается самостоятельно, берется у знакомых и т.д. В случае тотального невезения и отсутствии флопа - потребуется com-кабель (так называемый null-modem) для клонирования Norton Commander.

Итак, приступим.

  • Соединяем нужные кабели. Включаем ноутбук и базовый компьютер (последний с CD).
  • Запускаем NC на ноутбуке. Если его там нет, то клонируем при помощи NC с базового компьютера по com-кабелю.
  • Запускаем на втором компьютере NC (с дискеты или с подходящего раздела жесткого диска).
  • Линкуемся.
  • Спокойно переписываем всё необходимое либо с пиратского, либо с лицензионного диска (я не рассматриваю этические и моральные вопросы). Пьем чай, кофе, пиво, виски (нужное подчеркнуть) и читаем Компьютерру.
  • Инсталлируем систему.

Вот, собственно, и все!

А в качестве постскриптума приведу подробную инструкцию по клонированию NC. Представте себе, что Вам необходимо переписать файлы с одного компьютера на другой, но на одном из них нет Norton Commander. Обычно NC можно переписать с дискеты, но это не всегда может получится - например, на ноутбуке может запросто не быть дисковода. К счастью, NC сам умеет пересылать себя на другой компьютер, если они соединены через последовательные порты. Для пересылки NC на другой компьютер надо:
а) соединить компьютеры друг с другом нуль-модемным кабелем или парой проводов (это надо делать при выключенных компьютерах);
б) на исходном компьютере, находясь в NC, нажать [F9], [L] или [R], затем [К];
в) в выведенном на экран запросе указать порт, через который подсоединен текущий компьютер, выбрать режим "Master", выделить надпись "Clone" и нажать [Enter];
г) в веденном запросе, нажимая клавишу [Пробел], выбрать, через какой порт подсоединен принимающий компьютер;
д) на принимающем компьютере ввести в ответ на приглашение DOS команды, указанные в запросе, выведенном на исходном компьютере;
e) нажать на исходном компьютере [Ctrl][Enter].

(Источник: В.Э.Фигурнова "IBM PC для пользователя", издание 6-е, переработанное и дополненое, 1996 года.)

Г. Иванов

Думаю, что вышеописанный способ никаких вопросов не вызывает. Однако, есть еще более простой подход, который не требует наличия загрузочного компакт-диска (или поддержки загрузки с CD BIOS'ом компьютера). Кроме того, отпадает также нужда в NC. Правда, для удобства навигации все-таки рекомендую использовать какой-нибудь файловый менеджер. Лично мне больше нравится Volkov Commander - как размерами, так и некоторыми дополнительными функциями.

Программка называется Lap2Desk или, сокращенно, l2d. К сожалению, утилитка довольно древняя, а посему сайт производителя мне найти не удалось - нашлось несколько компаний с таким названием, но к делу отношения не имеющих. Все хозяйство состоит из пары файлов - l2d.exe (~70kb) и l2dmap.exe (~134kb). Первый файл и надо запустить на обеих машинах - "ведущей" и "ведомой" и этим, в принципе, можно ограничиться. Разумеется, запускать надо не просто так, а с определенными ключами, узнать о которых можно по простой команде "l2d.exe /?". Используя ключи можно выбрать порт (com или lpt), а также его номер; можно подключить все доступные диски на "ведущей" машине, а также подключить удаленный принтер. Программа висит резидентом в памяти и, в отличие от NC, позволяет использовать во время перекачки вторую машину (правда, желательно чтоб процессор был не ниже P133).

Второй файл - l2dmap - дублирует те же функции, только в графическом виде. Так что если вам неохота возиться с командной строкой, можно просто запустить l2d (надо только помнить, что по умолчанию он инициализирует порт com1) на двух машинах, а потом на "ведущей" запустить оболочку l2dmap и спокойно подключить нужные диски удаленной машины к вашей. После чего оболочку можно покинуть и либо воспользоваться воспоминаниями о ДОСовских командах, либо запустить файл-менеджер, от себя рекомендую VC (дальше объясню почему).

Кстати говоря, часто люди, пользующиеся подобными утилитами, удивляются, почему файлы ползут с черепашьей скоростью, в то время как пропускная способность даже com-порта может быть довольно приличной. А все объясняется довольно просто - по умолчанию для того же com-порта скорость устанавливается всего в 4800 бод (иногда - 9600)! Однако редкая программка предлагает установить скорость вручную. А бороться с этим очень просто, достаточно вспомнить про одну чудную ДОСовскую утилиту, именуемую mode.com. Обычно о ней знают только то, что она инициализирует русскую кодовую страницу при загрузке Windows, дабы в ДОСе все по-русски могло читаться. Однако стоит либо обратиться к документации (что маловероятно), либо к волшебному ключу "/?" и мы узнаем, что с ее помощью можно управлять и портами ввода-вывода. Вот как должна выглядеть строка инициализации для com1, устанавливающая скорость передачи 19200 (насколько я знаю, это максимум, поддерживаемый командой mode):
mode com1:19,n,8,1,p

Если кого-то интересует, что это значит, то советую поискать в сети описание команд MS-DOS - там все подробно расписано. Кстати, в архиве с программой l2d есть bаt-файл, инициализурующий командой mode порт com2 и сразу запускающий Lap2Desk.

Использование lpt-соединения я подробно не рассматривал, так как никаких дополнительных настроек там не требуется.

Подведем итог: для соединения двух компьютеров по com или lpt-портам потребуется две дискеты, соответствующий кабель и программа Lap2Desk. В идеале, на дискетах должно быть следующее:

  • (для "ведомой" машины) io.sys, msdos.sys, command.com, l2d.exe, mode.com, himem.sys, smartdrv.exe;

  • (для "ведущей" машины) io.sys, msdos.sys, command.com, l2d.exe, l2dmap, mode.com, himem.sys, smartdrv.exe, mscdex.exe, а также файловый менеджер и драйвер CD-ROM. Тут и пригодится Volkov Commander - работоспособный вариант занимает всего 150-200Кб (в зависимости от версии). А еще одной полезной функцией, отличающей VC от предка - NC, является возможность "выкидывать" из памяти ненужные резидентные программы (нажав Alt-F5).

Думаю, расписывать содержимое config.sys и autoexec.bat на дискетах не имеет смысла


Многоосность

Установка и загрузка нескольких версий windows и linux в самых различных комбинациях на одной машине. Как пользоваться линуксовым fdisk. Как из DOS загрузить linux.

Денис Колесниченко

Схемы установки:

  • Windows 9x + Linux;
  • Windows 9x + Windows NT + Linux;
  • Windows 98 + Windows 2000 + Linux;
  • Windows 98 + Windows NT + Windows 2000 + Linux;
  • Windows9x + Windows2000;

А также: использование Loadlin и fdisk for Linux

Прежде чем устанавливать несколько операционных систем на одном компьютере, сделайте резервное копирование важной информации, т.к. процесс установки операционной системы включает в себя переразбиение жесткого диска на разделы и форматирование созданных разделов. Переразбиение жесткого диска необходимо потому, что Linux и Windows используют разные файловые системы. Хотя существуют средства устанавливать Linux в раздел FAT/FAT32 - Mandrake Lin4Win - я не рекомендую их использовать, т.к. в этом случае Linux работает крайне нестабильно и медленно.

Для переразбиения диска я бы посоветовал программу Partition Magic v5 (или 6). Если вы устанавливаете Linux Mandrake 7.0 или выше, Partition Magic вам не потребуется - в программу инсталляции встроен отличный конфигуратор разделов на диске. Далее в этой статье будет описано использование программы fdisk для Linux, т.к. она присутствует во всех дистрибутивах Linux.

Windows 9x + Linux

Сначала нужно устанавливать Windows 9x, а затем Linux. Дело в том, что при установке Windows 9x перезаписывает MBR (Master Boot Record) и, если Linux уже установлен, загрузить его вы уже не сможете. Самым оптимальным загрузчиком при данной схеме загрузки является LILO (Linux Loader). Я бы не рекомендовал использование каких-либо посторонних загрузчиков, как стабильно они бы ни работали.

Совет: СОЗДАЙТЕ ЗАГРУЗОЧНЫЙ ДИСК ДЛЯ LINUX! Если вы в очередной раз переустановите Windows, без этой дискеты загрузить Linux вы уже не сможете.

Что делать, если вы переустановили Windows и Linux больше не загружается:

  • У вас есть загрузочный диск для Linux. Загрузитесь с него, авторизуйтесь в системе под root'ом и введите команду lilo. Затем перезагрузите машину (команда reboot)

  • У вас нет загрузочного диска: используйте программу loadlin. Ее описание вы найдете в конце главы.

  • Нет загрузочного диска и loadlin: переустановите Linux, после установки Windows, естественно ;) При установке Linux не форматируйте разделы и тогда ваши данные останутся неповрежденными.

Во время инсталляции Linux программа установки спросит, куда устанавливать LILO - выберите MBR

Win9x + WinNT + Linux

Под Windows NT здесь следует понимать Windows NT 4 Workstation/Server
Порядок установки должен быть следующим: Windows 9x, Windows NT, Linux
Обычно LILO не конфликтует с NTLoader v4, поэтому особых проблем у вас не будет.
Учтите, что при данной схеме вы не должны использовать FAT32, т.к. Windows NT4 не может работать с этой файловой системой.

Загрузка с помощью LILO при данной схеме может показаться неудобной - приходится работать с двухэтажным меню: сначала выбрать загрузку Windows в LILO, а затем выбирать между Windows 9x и Windows NT4. В этом случае для загрузки Linux можно использовать NTLoader. Об этом будет сказано в разделе Win9x+Win2000+Linux

Win98 + Win2000 + Linux

Иногда при установке Win9x, Windows 2000 и Linux могут возникнуть проблемы с загрузкой компьютера. Порядок установки такой же, что и в предыдущей схеме: Windows 9x, Windows 2000, Linux. После установки Windows 9x и Windows 2000 компьютер загружается нормально, но после установки Linux он вообще отказывается загружаться. Причиной этому может быть несовместимоcть данной версии lilo с NTLoader v5.

В данной ситуации следует поступить так: После установки Windows (имеется в виду Windows 9x и Windows 2000) следует установить Linux. Предположим, что вы устанавливаете Linux в раздел hda4 Когда программа инсталляции спросит вас, куда устанавливать LILO, выберите первый сектор раздела hda4

Затем нужно смонтировать чистую отформатированную в Windows дискету: mount -t vfat /dev/fda0 /mnt/floppy и скопировать загрузочный сектор Linux на эту дискету: dd if=/dev/hda4 of=/mnt/floppy/bootsect.lnx bs=512 count=1

Затем перезагрузите машину, загрузите Windows 2000 и скопируйте файл a:\bootsect.lnx в корневой каталог того раздела, из которого загружается Windows 2000 Признаком данного раздела является наличие файлов boot.ini и ntldr в корневом каталоге. Затем добавляем строчку в файл boot.ini: C:\bootsect.lnx="Linux"

Теперь после перезагрузки компьютера вы сможете выбрать Linux из меню NTLoader. Вышеописанный способ применяется и в случае, если вы хотите для загрузки Linux использовать NTLoader v4

Windows 98 + Windows NT + Windows 2000 + Linux

Рекомендуемый порядок установки: Windows 98, NT, Windows 2000, Linux.

Единственное, что здесь следует учесть это то, что Windows 2000 использует файловую систему NTFS5, которая не совместима с NTFS4, поэтому прежде чем устанавливать Windows 2000, установите Service Pack 4 for NT4

Windows9x + Windows 2000

Если вы хотите использовать только эти две операционные системы, то порядок установки следующий:
сначала установите Windows 95, а затем Windows 2000
При установке Windows 98 порядок не имеет значения. Обратите внимание на то, что при установке
Windows 2000 все FAT разделы автоматически конвертируются в FAT32, поэтому если вы хотите использовать Windows 95, обновите ее до версии OSR2

Совет: даже если вы хотите использовать только одну Windows NT(2000), не рекомендуется использовать только разделы NTFS - создайте хотя бы один раздел FAT32 или FAT

Использование loadlin

Loadlin - небольшой загрузчик, который позволяет загружать Linux из-под DOS или Windows 95. Если вы используете Windows 98, loadlin работать у вас не будет - нужно перезагрузиться в режиме MS DOS. Также нужно учесть, что при использовании loadlin могут возникнуть проблемы с разделами FAT32. В этом случае создайте загрузочную дискету DOS: format a: /s и в autoexec.bat этой дискеты пропишите loadlin.

В любом случае, из-под Windows 98 Me или Windows 2000/NT загрузить Linux вам не удастся.

Использовать loadlin я рекомендую лишь в том случае, если при очередной переустановке Windows MBR (а вместе с ним и LILO) оказался "затертым", а системную дискету Linux вы не создали.

Параметры запуска: loadlin kernel root=rootfs options
или
loadlin @param_file

Параметры:
kernel | Ядро, которое вы используете. Если у вас нет именно того ядра, можно взять практически любое (естественно не самое древнее). Обычно ядро можно взять на компакт диске с дистрибутивом Linux. Оно вам потребуется всего один раз - нужно только загрузиться и перезаписать lilo (команда lilo)
root | Корневая файловая система, например root=/dev/hda3
options | Опции, которые будут переданы ядру во время загрузки. Обычно используется ro vga=normal
@param_file | Если параметры, которые вы передаете loadlin (а не ядру!) окажутся слишком длинными, их можно записать в param_file

Примеры

c:\loadlin\loadlin.exe c:\loadlin\kernel\vmlinuz root=/dev/hda3 ro vga=normal
Или
c:\loadlin\loadlin.exe @param.lst

Содержание Param.lst:
c:\loadlin\kernel\vmlinuz root=/dev/hda3 ro vga=normal

Совет: Можно включить загрузку linux в стартовое меню DOS
Отредактируйте свой config.sys следующим образом
[MENU]
MENUITEM=DOS, Load DOS
MENUITEM=LINUX, Load Linux
MENUDEFAULT=DOS,5
[LINUX]
install=c:\loadlin\loadlin.exe c:\loadlin\kernel\vmlinuz root=/dev/hda3 ro vga=normal
[DOS]
; Все остальные команды, которые вы используете в DOS
; т.е. если у вас не было до этого стартового меню, то здесь должны находиться весь ваш предыдущий config.sys

Использование fdisk for Linux

fdisk for Linux используется для создания разделов для Linux. Естественно, его можно использовать для создания разделов других типов. Каждая операционная система имеет свою версию fdisk. Рекомендуется для создания разделов конкретной операционной системы использовать ее "родную" версию fdisk.

Запуск: fdisk <drive> В примере я буду издеваться над старым винчестером на 683 цилиндра

# fdisk /dev/hda
Comamnd (m for help):

Для получения справки можно ввести m:
Command action
a toggle a bootable flag
d delete a partition
l list known partition types
m print this menu
n add a new partition
p print the partition table
q quit without saving changes
t change a partition's system id
u change display/entry units
v verify the partition table
w write table to disk and exit
x extra functionality (experts only)

Нам потребуются только p, n, q, w
Для начала распечатаем таблицу разделов:
Command (m for help): p
Disk /dev/hda: 16 heads, 38 sectors, 683 cylinders
Units = cylinders of 608 * 512 bytes
Device Boot Begin Start End Blocks Id System
/dev/hda1 *1 p; 1 203 61693 6 DOS 16-bit >=32M

Имеется один DOS-раздел приблизительно на 60М (1 блок = 1024 байт). Этот раздел начинается с первого цилиндра и заканчивается на 203-ем. Всего на диске 683 цилиндра, т.е. для создания раздела(ов) Linux у нас осталось 480 цилиндров.
Создаем новый раздел (команда n):
Command (m for help): n
Command action
e extended
p primary partition (1-4)
p

Задаем тип создаваемого раздела (первичный или расширенный). Отличие первичного от расширенного состоит в следующем

  • может существовать только 4 первичных раздела

  • в первичных разделах могут храниться данные, а расширенный раздел содержит информацию о разделах, которые находятся в нем

В нашем примере создадим 2 первичных раздела - один раздел для файловой системы Linux (Linux Native) и раздела для своппинга (подкачки) Linux Swap:
Partition number (1-4): 2
First cylinder (204-683): 204
Last cylinder or +size or +sizeM or +sizeK (204-683): +80M
Номер первичного раздела - 2. Первый цилиндр - 204. Последний цилиндр вычисляется автоматически. Здесь можно ввести непосредственно номер последнего цилиндра, но это неудобно. Проще ввести размер в байтах
+размер, в Кб или в Мб - +размерK +размерМ соответственно.

Теперь создадим второй раздел для своппинга:
Command (m for help): n
Command action
e extended
p primary partition (1-4)
p
Partition number (1-4): 3
First cylinder (474-683): 474
Last cylinder or +size or +sizeM or +sizeK(474-683): +10M

По умолчанию fdisk создаст раздел типа Linux Native (81). Нам нужно изменить его на тип Linux Swap (82). Это можно сделать с помощью команды t, а с помощью команды L можно просмотреть доступные типы разделов.

Теперь распечатаем таблицу разделов:

Command (m for help): p
Disk /dev/hda: 16 heads, 38 sectors, 683 cylinders
Units = cylinders of 608 * 512 bytes
Device Boot Begin Start End Blocks Id System
/dev/hda1 * 1 1 203 61693 6 DOS 16-bit >=32M
/dev/hda2 204 204 473 82080 81 Linux Native
/dev/hda3 474 474 507 10336 82 Linux Swap

Номера цилиндров 508-683 не использованы - здесь можно создать дополнительные разделы.
Теперь нужно ввести команду w:
Command (m for help): w
для того, чтобы записать таблицу разделов на диск. До тех пор, пока вы не введете эту команду, ни одно из сделанных изменений не даст эффекта. Вы можете в любой момент выйти из программы без сохранения изменений, введя команду q.

Теперь, согласно традиции, нужно упомянуть о проблеме 1024-го цилиндра. Старые версии Linux не могут загружаться с разделов на цилиндрах более 1024-го. Поэтому раздел для корневой файловой системы нужно стараться разместить на цилиндрах до 1023-го. Однако Linux может использовать разделы на цилиндрах более 1024-го.


"Зачем?", "Почему?", и "Куда?" или Всякое разное про операционные системы. Часть 2

off

Этот текст был написан автором после того, как в одном из наших форумов я увидел постинг с призывом принять участие в разработке новой ОС и предложил автору выразить свои мысли в форме статьи. Поэтому, если Вы разделяете взгляд автора, то свяжитесь с ним — возможно это приведет к новым интересным разработкам.
wsDmitry

Так чего это я всё про взаимодействие, да взаимодействие? Просто, никому не нужна программа сама в себе. Если она ничего не вводит и ничего не выводит, то следует задуматься, зачем она тратит процессорное время? Раз уж всё идёт к тому, что драйверы выравниваются с обычными программами, то выходит только два типа взаимодействия: программа<—>программа и программа<—>аппаратура. Я, к сожалению, не очень разбираюсь в причинах, побуждающих разработчиков придумывать тот или иной интерфейс для своей аппаратуры, так что остановимся на первом. Принципиально разных способа всего два—передача сообщений с вариациями на тему: вызов удалённых (не deleted, а remote) процедур, передача данных через трубки (pipes) и т.д. (при этом способе ядро копирует предаваемую информацию из адресного пространства одной программы в адресное пространство другой) и общая память, когда приложения напрямую обмениваются информацией, записывая или считывая информацию из одной области памяти.

Передача сообщений—это единственный способ взаимодействия, когда виртуальные адресные пространства приложений изолированы друг от друга, то есть ни одна логическая страница первого адресного пространства не отображается в ту физическую (в ОЗУ, ПЗУ, диске или ещё где) страницу памяти, в которую отображена хотя бы одна логическая страница второго адресного пространства. Есть существенный недостаток этого метода: информацию нужно копировать. Во многих случаях это существенные затраты. Вот пример: есть у меня мой любимый текстовый редактор, любимый графический, и любимый web-браузер. И хочется мне редактировать текст страницы, и рисовать для нее картинки, да так, чтобы стразу видеть результат своих трудов в этом браузере. Уважаемые господа—любители Windows. OLE не подходит, потому что я не хочу редактировать всё в одном месте, а хочу редактировать в местах разных, да ещё не в режиме «отредактировал — посмотрел», а «редактируй и смотри» (WYSIWYG). Если у меня есть только передача сообщений, то с текстовым редактором совладать можно: тексты хорошо архивируются или занимают мало памяти. А вот с картинкой дела обстоят гораздо хуже. Ладно если я поменял немного пикселей, а вот если я применил фильтр какой-нибудь? Браузер-то фильтрами не занимается, поэтому придётся перекачать ему всю картинку. А это несколько мегабайт. Конечно, с точки зрения человека — это мгновенно, но сколько бы уравнений решила бы за это время Ваша любимая seti@home?

В подобных случаях помогает общая память. Чтобы не мучить себя и процессор надо поместить картинку и html-текст в ту память, которая отображена через страницы в адресные пространства всех трёх приложений. Тогда все изменения сделанные редакторами сразу будут заметны браузеру. При этом экономиться память. Браузеру не нужно хранить копию картинки и текста. Но не всё так просто. Хотя Windows и Linux поддерживают этот механизм, делают они это с большой натугой, ибо каждое приложение имеет своё адресное пространство. И когда нужно корректировать те вхождения таблицы страниц, например, при подкачке, которые отображаются в эту общую память, приходится делать это во многих таблицах и постоянно пересчитывать адреса. Это действительно проблематично, поэтому в Windows NT общая память в таких пертурбациях, как подкачка не участвует.

Несмотря на всё это, общая память для локальной машины (как и для кластера) — вещь нужная и важная. Ещё бы — самый быстрый обмен (на локальной машине) и экономия пресловутой субстанции под названием RAM. Поэтому в этом направлении работали. И вот, что выдумали: если у каждого приложения своё адресное пространство, то делать общую память неудобно? Неудобно. Поэтому сделаем одно адресное пространство для всех приложений, то есть пускай логические адреса во всех приложениях одинаково отображаются на физические. Если раньше инструкция "сохрани содержимое регистра X в ячейке памяти с адресом A" для одного приложения означала обращение к ячейке физической памяти B, а для другого — к C, при этом B не обязательно совпадало с C, то в новой архитектуре предполагалось, что в обоих приложениях произойдёт обращение к ячейке с одинаковым физическим адресом. Теперь всё адресное пространство — общая память, надо только научиться его защищать, то есть надо уметь разрешать или запрещать доступ к различным областям памяти различным приложениям. Это оказалось не так уж и сложно. Системы реализованы. Есть два замечательных проекта (их, на самом деле, больше, но эти, по мнению экспертов, наиболее удачные). Один на базе L4 — mungi, второй — на базе mach, имя ему opal. Но это не всё: в обоих системах эта общая память ещё распределённая и является единственным местом, где информацию можно хранить. То есть нет никакой файловой системы, удалённых дисков и прочего добра, есть только память. Связано это горе с тем, что делались системы для машин с 64-разрядным адресом. Давайте немного посчитаем. 2 в степени 64 байт — это столько, что записывай мы по гигабайту в секунду, нам понадобиться 544 года, чтобы израсходовать всё место. Поэтому можно использовать 64-битный указатель для обращения ко всем объектам в локальной сети (в смысле, лимит не будет исчерпан за пять лет, а там и 128 бит появиться). На практике это означает следующее: если по адресу 23425234 у Вас лежит любимая процедура распознавания образов, то можно её вызвать из любой программы, написав инструкцию вроде call 23425234, передав ей загадочное число 63456 — адрес по которому находится Ваша любимая картинка (для любой программы по этому адресу будет лежать эта картинка). Если страница, на которую ссылается этот адрес, у вас в локальной памяти, то произойдёт обычный вызов. Если её нет, если она затерялась в просторах сети или на диске, то механизм подкачки её найдёт и загрузит в память. Примерно то же самое произойдёт при считывании из памяти картинки. И никакой явной загрузки библиотек. Вот так. И это работает. И работает быстрее, чем обычные ОС по словам разработчиков и результатам прогонки бенчмарков. При этом, разработчикам пришлось решить ещё одну проблему: если вы выключили ваш кластер, то включив его, вы должны обнаружить всю вашу любимую картинку всё там же, по адресу 63456. Они эту проблему решили, да так, что для системы почти безразлично, как её выключили. То есть после сбоя система оказывается в том состоянии, в котором она была за несколько секунд до сбоя. Какой именно механизм используется в mungi или opal, я не могу сказать. Разработчики не распространяются, а обещанные исходники mungi до сих пор недоступны, зато один из подобных механизмов — checkpoint persistance— реализован в EROS. Эти чудеса программистского маразма (с уважением и почтением сказано) носят гордое название Single Address Space Operating Systems (SASOS). И похоже, что мир катится именно к ним. Так, Intel в IA-64 предусмотрела специальные механизмы для облегчения тяжкого труда ядер подобных систем (раздел 16, Intel IA-64 Software Developer's Manual, Volume 2, IA-64 System Architecture). А на архитектурах типа PowerPC и Alpha эти ОС живут превосходно. Кроме того, есть проект Sombrero, и, судя по огромному количеству документации в ppt файлах, к которой ведут ссылки со страницы этого проекта, и по тому, что проект выполнен для Windows NT, Microsoft тоже подумывает об обкатке новых идей. Эх! Скоро я буду наслаждаться своим текстовым редактором на тройку с графическим и веб-браузером. Впрочем, мы сами с усами и "мелкуюмяготь" ждать не хотим!

Про кластеры. Как это ни странно, но системы с распределённой памятью оказались более эффективными, чем системы с передачей сообщений. Никто толком не может сказать почему, но проект munin это доказал на практике.

По моему, причина вот в чём. Предположим, вы решает некоторую задачу по физике с некоторым коллективом, сидя в разных комнатах. У вас есть чертёж, на котором необходимо нарисовать все действующие на систему силы. Что проще? Иметь у каждого по чертежу, и когда придёт в голову мысль об очередном векторе, рассказывать о том, как его нарисовать, по телефону, например. Или иметь один чертёж, и когда в голову приходит мысль о новом векторе просто рисовать его на доске, дождавшись, когда её вам принесут? Не знаю. Но на общей доске можно проводить некоторые выкладки, которые будут заметны всем. И если народ понимает о чём идет речь, то Вам не обязательно чётко и до конца сформулировать свою мысль, о ней догадаются по вашим выкладкам. Я к тому, что при использовании общей памяти, не обязательно формулировать конечные сообщения. Более компьютерно: например, при отрисовке 3D сцены при помощи openGL Вам нужно сформировать сцену, а потом, выдать команды драйверу (что вызовет двойное копирование данных сцена—>драйвер—>видеокарта). Но что нам мешает договориться о структуре сцены? Почему не формировать сцену в указанном формате, а драйверу самому решать, что передавать карте, а что нет (при этом исключается столь ненавистное копирование Мне скажут, что вместо него появляется анализ информации, что же, да, но сравните тактовую частоту процессора и памяти!)? Прямо чувствую, что найдётся какой-нибудь ортодоксально настроенный поклонник ООП (чувствую, потому что когда-то был таким сам) и заявит, что связывание по данным — самое страшное преступление в области компьютерных технологий. Что же. Немного пересмотрим наш пример. Путь теперь физики сидят в одной комнате. Что проще? Придумав новый вектор, втихомолку нарисовать его у себя на private-доске, а потом через public-воздух каждому коллеге сообщить о своей гениальной идее. Или просто рисовать на общей доске? Здесь я утверждаю, что последнее не только проще, но и эффективнее.

Третье. Одиночество. Так уж получилось, что раньше у каждого пользователя компьютера была одна программа, просто работать со многими одновременно он не мог эффективно. Поэтому ОС и строились на принципах изоляции одной программы от другой. Строились они строились, программисты ничего другого думать не хотели. Вот так и дожили мы до монстров в виде Ворда, а через монструозные программы дожили мы до ООП.

Принцип изолированности всему причина. Я не говорю, что это плохо. Если у Вас такая ситуация, что Вы обязаны в хакерстве подозревать всех, в том числе и самого себя, а это вполне реальная ситуация (по крайней мере именно такой расклад вещей пытаются внедрить в наши неокрепшие умы преподаватели по компьютерной безопасности), то Вам ничего не остаётся кроме того, чтобы изолировать каждую программу от других. Это норма, потому что информацию можно передавать и через структуру доступного адресного пространства. А что если это не так? Например, сохранять конфиденциальность мне нужно только для пары строчек—логина и пароля для доступа в Интернет, зато мне хочется, да, именно этого — браузера и двух редакторов, для текста и картинок, причём от разных производителей, потому что один всё это одновременно хорошо не напишет. Я уже указал, как это можно сделать. Но то, что я рассказал, невозможно сделать, если приложение будет "думать", что оно одно в системе, потому что нужно будет хотя бы договориться о том, где нужный текст и картинки расположены в памяти. А чтобы об этом договориться надо знать с кем договариваться. Таким образом нужен механизм для того, чтобы программа могла понять, в какое окружение она попала. На самом деле это хоть и даёт скрытый канал утечки информации, но помогает поднять уровень защищённости. Вот пример, если бы программа, работающая с супре-пупер секретными данными могла узнать, существует ли в системе приложение, которое имеет доступ к сети, то она могла бы "испугаться", не запуститься и не начать дешифрование, предполагая, что подобная программа вполне может быть хитрой закладкой, которая может пролезть в память данной программе, и выкачать расшифрованные данные. Вот так. И потом, сможете ли вы эффективно работать с людьми, если можете общаться только с помощью открывания и закрывания век? При чём здесь люди? А вы наблюдали когда-нибудь, как программисты объясняют то, как работает программа? Обычно они говорят о том, что она делает от первого лица! Наверное, это естественно, потому что программирование — это изложение своих мыслей, пусть в контекстно-свободном виде.

В той же Windows можно очень много узнать о компьютере: сколько памяти, какие PCI-карты есть, и т.д. А вот получить информацию о том, сообщения от каких приложений находятся в очереди — нельзя. А ведь это могло бы помочь: проанализировав этот список, можно было бы решить на какие отвечать, а на какие — нет.

Четвёртое. Синхронизация. Единственная область, где менять ничего не надо. Потому что умные люди давно придумали "мутекс" или "простой семафор". С помощью него можно создать любой механизм синхронизации, даже упорядоченный. Поэтому в этой области никто ничего и не меняет, кроме как ускорения работы этих семафоров. Впрочем, они и так уже требуют не более трёх инструкций для своей реализации.

Так что же нас ждёт? Всепланетное единое адресное пространство (когда процессоры станут 512 разрядными), в котором мы будем парить с помощью наноядер (потому, что микроядра предоставляют избыточный интерфейс для реализации SASOS) как птицы и синхронизироваться токмо с помощью мутексов (что, в принципе, возможно — возьмите хотя бы кластеры, кажущиеся прикладному программисту одной машиной и предоставляющие ему возможность обмена информацией между программами) и не будет нигде никаких объектных интерфейсов, потому что не будет самих объектов, потому что структура информации будет известна, потому что всё будет храниться в виде XML...

PS: много ссылок на сайты разработчиков операционных систем можно найти на dmoz.org/Computers/Software/Operating_Systems.

Источник - SoftТерра, http://www.softerra.ru


Не ОС красит веб...
Пара практических занятий. Занятие второе

Сергей Трошин

На прошлом занятии мы с вами по мере сил и возможностей учились задавать фон папок Windows, писать комментарии к ним, а также задавать фон панели предпросмотра. Освоили? Получилось? Приступаем к следующим процедурам.

Предпросмотр медиа-клипов

В действительности, в стандартный шаблон заложен предварительный просмотр не только графических файлов и веб-страничек. Точно так же можно выводить и "превьюшки" видеоклипов или звуковых файлов - при этом на информационной панели появляется уменьшенный вариант всем знакомого Windows Media Player шестой версии.

Но все дело в том, что функция эта изначально отключена, поскольку ее включение создает небольшую проблему с удалением файлов. При попытке подхватить файл с видеоклипом мышкой для перетаскивания в Корзину он одновременно открывается в проигрывателе и становится автоматически заблокированным - открытый файл удалить невозможно. Вот если выделить два файла - то удаляй сколько хочешь, а один - никак (разве что используя другой файловый менеджер, который не направляет клип в проигрыватель при выделении).

Но так было вплоть до выхода седьмой версии Windows Media Player. При использовании данной версии эта функция в Windows Me полностью работает и не создает никаких проблем при удалении файлов! Так что держать ее заблокированной нет более никакого смысла, поскольку работать с мультимедийными файлами, автоматически отображающимися прямо в окне Проводника, чрезвычайно удобно.

Для включения этого режима внутри нашей папки с музыкой найдите в файле folder.htt (напомню, мы используем стандартный шаблон!) строки, которые обеспечивают распознавание типов мультимедийных файлов:
function IsMovieFile(ext)
{
//disabled
return false;
var types=",asf,avi,wmv,wvx,m1v,mov,mp2,mpa,
mpe,mpeg,mpg,mpv2,qt,asx,";

и

function IsSoundFile(ext) {
//disabled
return false;
var types=",aif,aiff,au,mid,midi,
rmi,snd,wav,mp3,m3u,wma,";

Перед словами "return false" нужно установить два слэша (закомментировать их): "//return false;", либо вообще удалить первые две строки функции - это разблокирует предпросмотр клипов. Можете сразу после сохранения изменений это проверить - на информационной панели будет появляться небольшой проигрыватель при выделении любого файла, расширение которого совпадает с теми, что перечислены в вышеобозначенных строках.

При этом для звуковых файлов будет выводиться усеченный вариант плейера - без дисплея. Ничто не мешает внести в этот список и новые типы файлов, главное - чтобы у вас были установлены соответствующие кодеки, расширяющие возможности стандартного проигрывателя. В этом случае вы получите такие строки:
var types=",asf,avi,wmv,wm,wvx,wmx,wmp,m1v,mov,mp2,
mpa,mpe,mpeg,mpg,mpv2,qt,
asx,qm,ivf";
- для видеофайлов и
var types=",aif,aifc,aiff,au,mid,midi,rmi,snd,wav,
mp3,m3u,wma,wax,cda";
- для звуковых.

Но простым включением предварительного просмотра клипов дело не ограничивается, поскольку потенциал у этой технологии не исчерпывается уже готовым стандартным шаблоном. Реализован этот потенциал с помощью так называемых элементов управления ActiveX (ActiveX Control), вносимых в HTML-документ с помощью тега <object>.

Программистам работа с ними должна быть хорошо знакома, простым же пользователям скажу, что за ActiveX отвечают файлы с расширением ocx, конкретно же за внедрение Media Player 6 в HTML-документ - файл msdxm.ocx, а за седьмую версию - wmp.ocx.

А потому ничто не мешает еще сильнее отойти от заданного Microsoft шаблона и заменить, например Media Player 6 на более продвинутый и симпатичный Windows Media Player 7.1, поскольку он тоже поддерживает внедрение в HTML-документ. Этот проигрыватель, как я уже отмечал, не затрудняет удаление файлов.

Давайте сделаем так, чтобы видеоклипы открывались в Windows Media Player 7.1. Для этого найдите во все том же шаблоне folder.htt следующие строки:
Preview.innerHTML= '<p>' +
'<object id=MediaPlayer class=Movie classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95">' + '<param name="ShowDisplay" value="false">' +
'<param name="AutoPlay" value="false">' + '</object>';
MediaPlayer.EnableContextMenu=false;
MediaPlayer.Open(item.Path);

Это полное описание используемого для вывода видео элемента ActiveX, имеющего идентификатор (CLSID) {22D6F312-B0F6-11D0-94AB-0080C74C7E95}, то есть - Media Player 6. Чтобы вместо него оказался проигрыватель седьмой версии, надо сменить этот идентификатор на {6BF52A52-394A-11d3-B153-00C04F79FAA6}, принадлежащий Media Player 7. Но этого мало. Дело в том, что у различных элементов ActiveX различаются и параметры, например, по-другому передается в проигрыватель путь к выбранному файлу (метод ".Open" в шестой версии и метод ".URL" в седьмой), поэтому придется переписать весь этот участок кода:
Preview.innerHTML=
'<p>' + '<object id=MediaPlayer7 classid="clsid:6BF52A52-394A-11d3-B153-00C04F79FAA6" width=
"176" height="167">' + '<param name=
"AutoStart" value="false">' + '</object>';
MediaPlayer7.EnableContextMenu=false;
MediaPlayer7.URL=(item.Path);

Как видите, здесь, помимо изменения некоторых параметров, задается еще и размер окна проигрывателя, чтобы он лучше выглядел в зоне предпросмотра. Аналогично устанавливается прослушивание и аудиофайлов через Windows Media Player 7. Единственное, что нужно для работы с ActiveX, - иметь под рукой документацию со всеми их параметрами.

В случае с WMP7 вы найдете ее на сайте Microsoft: playercontrolguide.asp.

Технология веб-интеграции позволяет вносить в Проводник очень серьезные изменения, вплоть до встраивания в Windows проигрывателей сторонних разработчиков для воспроизведения файлов, которые не понимает Media Player. Например, можно сделать так, чтобы файлы RealMedia открывал в зоне предпросмотра очень популярный RealPlayer.

Из-за особенностей этого проигрывателя сделать это, правда, посложнее, чем в случае с WMP, и код получится несколько больше. Сначала, для того, чтобы система распознавала файлы RealPlayer, надо после блока "function IsSoundFile(ext)" вставить новую аналогичную функцию со списком расширений (следите за правильной расстановкой фигурных скобок):
function IsRealFile(ext) {
var types=",ra,rm,viv,ram,rmm,rmd,swf,smi,smil,rt,rp,";
var temp="," + ext + ",";
return types.indexOf(temp) >-1;
}
Затем рядом с уже имеющимися объектами MediaPlayer7 и MediaPlayer (после них - по аналогии) нужно вставить еще один объект - RealPlayer, вернее, даже два объекта, потому что для этого проигрывателя отдельно идет дисплей, а отдельно - панель управления:
else if (IsRealFile(ext))
{
Preview.innerHTML = '<p>' + '<object id=RealPlayer class=Movie classid="clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA">' + '<param name="controls" value="ImageWindow">' + '<param name="MaintainAspect" value="true">' + '<param name="NoLogo" value="true">' + '<param name="Console" value="Real">' + '</object>' + '<object id=RealPlayerCP classid="clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA" width="176" height="31">' + '<param name="controls" value="ControlPanel">' + '<param name="Console" value="Real">' + '</object>';
RealPlayer.Source=(item.Path);
}

Описывать, что какая строка обозначает, вряд ли есть смысл: если есть желание ознакомиться со всеми многочисленными параметрами RealPlayer как элемента ActiveX, изучите страничку service.real.com/.../activex.htm. Тот же код, что я привожу, вполне достаточен и работоспособен с последними версиями проигрывателя. Разумеется, необходимо, чтобы RealPlayer был установлен в вашей системе.

Ограничение доступа к папкам

Многие пользователи хранят на жестком диске какие-либо личные документы, случайный или намеренный доступ к которым посторонних был бы, по меньшей мере, крайне неприятен. Причем все это особенно касается других членов семьи пользователя, вплоть до кошек и собак, обычно сующих свой нос во все на свете, стоит только немного потерять бдительность.

Бесспорно, если вы хотите иметь четкие гарантии, что никто ни дома, ни на работе не сможет вторгнуться в вашу "прайвеси" и прочитать любовную переписку, передать бухгалтерские документы в соответствующие органы или узнать, какие сайты вас больше всего привлекают в интернете, то придется шифровать диск специальными программами (например, StrongDisk Pro).

Процедура эта, в принципе, не самая приятная - и ресурсы процессора при расшифровке на лету расходуются немалые, и есть риск пароль длиннющий забыть, и в случае сбоя на диске имеется вероятность потерять всю столь старательно скрытую от чужих глаз информацию.

Но если надо защитить папку с не самыми критичными документами от ненамеренного проникновения в нее малолетнего спиногрыза или тренирующейся в удалении файлов жены и вы много не потеряете, если дите все-таки догадается, как взломать все преграды (это, кстати, неплохой стимул для его самообразования - запретный плод и все такое, а уж жена-то точно не догадается), то можно поступить гораздо проще: использовать преимущества, которые дает незаслуженно игнорируемая веб-интеграция.

В качестве примера опять используем нашу папку с музыкой - в файл folder.htt перед строкой
<body scroll=no onload=Load()>
добавьте следующий примитивный код:
<script language="VBScript">
par=InputBox ("Please, enter the password", "Login")
If par="" Then
par=0
End If
If Asc(par)>57 Then
par=Asc(par)
End If
If par=Upgrade Then
pass
Else
err
End If
Sub err
MsgBox "Access Denied!"
Navigate "C:"
End Sub
Sub pass
MsgBox "Welcome!"
End Sub
</script>

Готово, теперь, не зная пароля (который прописан прямо в этом коде: Upgrade), попасть в данную директорию будет несколько затруднительно - в случае ошибки вместо нее откроется диск С:. Впрочем, многого от этого скрипта не ждите - для других файловых менеджеров он, как и все остальные настройки веб-вида, никакого значения не имеет, как и для приложений, способных осуществлять навигацию по папкам.

К тому же он не предохранит от прямого доступа в поддиректории, например в ту же самую папку Folder Settings, в которой без труда можно обнаружить наш пароль. Так что грамотный пользователь такую защиту обойдет минуты за две (а сисадмины, имеющие привычку пользоваться альтернативными менеджерами типа FAR или Windows Commander, и вовсе не заметят - прим. ред.), но как защита "от дурака" и от прочих неприятностей он вполне годится, да и написать более серьезный скрипт вам ничто не мешает.

Главное, что для такого трюка не требуется никаких программ - только две минуты свободного времени на настройку веб-вида!

Мелочь, а приятно

Если вы пробежитесь с помощью Проводника по разным папкам, то заметите еще одну небольшую, но приятную функцию веб-вида - отображение ссылок на часто используемые ресурсы прямо в информационной панели. Обычно это ссылки на папки My Documens, My Network Places и My Computer. Причем ссылки эти динамические и при выделении курсором какого-либо файла они пропадают, чтобы освободить пространство для "превьюшки" файла.

Стоит же щелкнуть мышью на пустом месте (для того, чтобы снять выделение файла), как ссылки эти снова восстанавливаются. К сожалению, при использовании стандартного шаблона вы теряете возможность пользоваться этой удобной функцией - она почему-то из него исключена. Но очень легко сделать так, чтобы на информационной панели постоянно присутствовали статические ссылки на самые востребованные папки или веб-сайты. Найдите в самом конце файла folder.htt такие строки:
<span id=Info>
%THISDIRPATH%
</span>
сразу после них вставьте:
<p>
<class=Links>
<a href="http://upgrade.computery.ru/">Upgrade</a>
<p>
<br>
- и в нашей экспериментальной папке вы увидите ссылку на сайт журнала Upgrade. Точно так же добавляются и ссылки на локальные папки и диски (<a href=file://C:\>Диск С:</a>). Оформить эти ссылки можно как угодно, даже поместить в таблицу - опять с помощью HTML.

В принципе, можно вернуть и динамические ссылки, но описание этой процедуры сюда уже не поместится, поэтому я предлагаю вам получить уже готовый мой собственный шаблон folder.htt
(stnvidnoye.chat.ru/.../FOLDER.ZIP), в котором помимо динамических ссылок и парольной защиты есть и все остальные описанные здесь функции - включен предпросмотр медиа-клипов, видео и аудио воспроизводится в Windows Media Player 7, а файлы RealMedia - в RealPlayer.

Единственное ограничение этого шаблона заключается в том, что в папке, настроенной с его помощью, не отображаются комментарии, о которых шла речь на первом занятии. Так что на досуге можете заняться этим вопросом. Читайте также мои заметки внутри этого шаблона - возможно, я еще внесу туда какие-то изменения.

Впрочем, существует немало и других возможностей дать разгуляться фантазии при редактировании шаблона folder.htt. В частности, в самом начале этого файла после строки //THIS SCRIPT IS COMMON FOR ALL CUSTOM WEB VIEWS идет список переменных, среди которых нетрудно заметить и строковые, являющиеся, по сути, тем текстом, который отображается на информационной панели в различных ситуациях.

Например, при открытии какой-либо папки в верхней части информационной панели появляется строка: "Select an item to view its description", приглашающая выбрать какой-либо файл. При наличии определенной степени здорового юмора можно изменить значение отвечающей за эту строку переменной "var L_Prompt_Text" так, чтобы вместо нейтрального приглашения выводилось что-нибудь смешное - например, так: "Нижайше пресмыкаясь, система умоляет своего драгоценного повелителя указать перстом хоть на что-нибудь".

Но больше всего параметров, над которыми допускается поэкспериментировать, расположено чуть выше - сразу после строк
</head>
<style>,
где задаются стили нашего шаблона. В частности, владельцам больших мониторов я бы посоветовал увеличить ширину инфо-панели, изменив в строке, описывающей эту панель, -
#Panel {position: absolute; width: 200px; height: 100%; visibility: hidden}
- значение параметра "width". Все остальные строки этого раздела тоже более или менее понятны: например, ясно, что шрифт, которым выводится название папки, описан в строке "#FolderName", размер видеопроигрывателя - в ".Movie", размеры миниатюр графических файлов - в "#Thumbnail" и так далее.

На больших мониторах будет полезно вместе с инфо-панелью увеличить и размер эскизов.
Как видите, если хорошенько разобраться с веб-видом папок, то зайти можно очень далеко...

Ничто, например, не запрещает применить фреймы внутри окна Проводника! Просто надо сделать обычную веб-страничку с несколькими фреймами, назвать ее folder.htt, а в одном из фреймов задать отображение документа, содержание которого идентично исходному шаблону standard.htt - в нем и будут производиться операции с файлами. В остальные же фреймы вставляйте все, что душе угодно - кнопки, скрипты, бегущие строки, графику, анимацию - все, что как-то может быть вам полезно.

Если же вы хотите, чтобы изменения коснулись абсолютно всех папок на диске, то измените сам глобальный файл C:\Windows\Web\folder.htt, предварительно сделав его резервную копию. В этой же папке вы найдете и другие системные шаблоны, применяющиеся для настройки внешнего вида и оформления отдельных системных папок, несколько графических изображений, используемых в этих шаблонах, а также те самые четыре предустановленных шаблона, что предлагает мастер настройки веб-вида (см. врезку).

Редактируя их, можно радикально изменить лицо "виндов", вдоволь над ними поглумившись, или же добавить некоторые полезные и удобные функции. Очень рекомендую по максимуму поприкалываться над файлом C:\Windows\Web\safemode.htt - в нем запрограммирована заставка, которая отображается на активном Рабочем столе в случае сбоя оболочки Windows. Если скопировать такой файл знакомому "чайнику", то его будет ждать немалое потрясение, когда вместо очередного предложения восстановить Рабочий стол появится что-нибудь типа "А теперь пора попить пивка!" с картинкой соответствующего содержания.

О главном

Самым же важным и одновременно хуже всего документированным элементом шаблона веб-вида папки является объект FileList - его упоминание найдете в разделе стилей и в конце шаблона. Именно он отображает папки и файлы в правой части окна Проводника. К сожалению, с ним мало что можно придумать, просто если вы вдруг захотите полностью переписать "виндовый" шаблон, то не забудьте внедрить в него этот объект, иначе доступа к файлам не будет.

Правда, можно немного поиграть с его размерами, которые по умолчанию выставлены как 100% ширины и 100% высоты из-за чего панель с файлами занимает всю площадь правой части Проводника. Если же его размеры задать жестко, в пикселях, то в Проводнике окажется дополнительное место для размещения еще какого-либо управляющего элемента, графики или текста.

Если же задать размер в процентах, но так, чтобы FileList занимал не 100% высоты, а, допустим, 70%, то его размер по-прежнему будет изменяться вместе с изменениями размеров окна Проводника, при этом сохранится и свободный участок площади для опытов.

На медленных компьютерах, чтобы не загружать систему сопутствующими прибамбасами, можно пойти на такой трюк: оставить в шаблоне только один объект FileList, а остальной код добавить самостоятельно, сделав так, чтобы в Проводнике отображалось, например, несколько постоянно используемых ссылок.

Этому спартанскому идеалу ближе всего соответствует упрощенный шаблон C:\Windows\Web\starter.htt, в котором кроме FileList присутствует только отображение значка папки, но можно убрать и его, если удалить из HTML-кода все, что касается объекта FolderIcon.

Использование такого минималистского шаблона пригодится и в том случае, если вы будете делать шаблон с фреймами, в котором все нужные вам элементы управления создадите сами.

Значки

Ну что ж, мы провели огромную работу и использовали интеграцию Internet Explorer с операционной системой почти на всю катушку. Не хватает последнего штриха. Windows позволяет задавать для каждой папки индивидуальный значок, выделяющий ее среди прочих безликих собратьев.

Пока на диске всего пять системных папок имеют свой собственный значок (например, папка C:\My Documents\My Pictures). Почему бы таким же образом не подчеркнуть уникальность и нашей папки с музыкой? Помещаем в нее файл иконки, называющийся, скажем, "icon.ico", снова открываем файл desktop.ini и в раздел [.ShellClassInfo] добавляем строки:
IconFile=icon.ico
IconIndex=0

После сохранения изменений радуемся полученному результату. Старайтесь только, чтобы все такие значки имели разные названия, иначе Проводник их путает. Кстати, не обязательно копировать значок прямо в папку, иконку которой вы хотите изменить, не обязательно и использование ico-файла - можно просто указать путь к DLL-библиотеке с несколькими значками и задать идентификатор нужного значка "IconIndex".

Именно так и сделаны иконки системных папок, например, для папки My Pictures эти строки выглядят следующим образом:
IconFile=C:\Windows\System\mydocs.dll
IconIndex=-101

Помимо индивидуального значка можно назначить и всплывающую подсказку, появляющуюся при наведении курсора на папку, - для этого надо в этот же раздел поместить еще одну строку:
InfoTip=Это папка с моей любимой музыкой
Правда, управлять значками лучше всего не ручным редактированием файлов desktop.ini, а, например, с помощью программы Microangelo (www.impactsoft.com/muangelo/download/muadnld.html) - она добавляет в контекстное меню каждой папки новую команду "Appearance", воспользовавшись которой, вы за пару минут сделаете из стройных рядов одинаковых иконок разноцветный винегрет (главное - заранее позаботиться о нужном количестве оригинальных значков).

Эта программа способна менять и текст всплывающей подсказки. Учтите только, что некоторые системные значки она поменять, увы, не сумеет - для этого лучше применить известную программу WinBoost 2001 Gold (www.magellass.com), которая полностью восполнит этот пробел.

Интегрируемся?

Вот, собственно, и все, что я хотел рассказать о такой полезной и в то же время практически никем не используемой функции Windows Me, как настройка веб-вида папок. Консерваторам же, все еще использующим Windows 98, могу лишь подсказать, как включить предпросмотр медиа-файлов. Для этого надо изменить всего один параметр в уже известном файле C:\Windows\Web\folder.htt. В строке, начинающейся с "var wantMedia=false;" - поменяйте "false" на "true". Остальное же я предоставляю вам сделать самостоятельно.

Вообще, было бы замечательно, если бы пользователи и веб-дизайнеры наконец обратили внимание на эту особенность современных операционных систем, ведь точно так же можно настраивать и Windows 2000, и даже Windows XP, тем более что начиная с Internet Explorer 5.0 в качестве шаблона можно использовать XML-файлы, имеющие более мощный потенциал, нежели HTML. Но пока в интернете мы имеем горы обоев для Рабочего стола, всяческие заставки-скринсейверы и ни одного продвинутого folder.htt.

Кстати, ведь благодаря веб-интеграции на Рабочий стол можно помещать не только статичные графические файлы, но и HTML-документы со ссылками, Java-скриптами, объектами ActiveX - гораздо более функциональные и полезные, чем обычная графика.

При этом не нужны никакие "Талисманы", поглощающие половину ресурсов процессора ради нескольких анимированных кнопок на Рабочем столе, - все делается штатными средствами самой ОС.

DataFile
brfcase.htt | папка Портфель
classic.htt | шаблон "классический"
controlp.htt | папка Панель управления
default.htt | Temporary Internet Files, Downloaded Program Files, Subscriptions, History
deskmovr.htt | активный Рабочий стол
dialup.htt | Удаленный доступ к Сети
folder.htt | глобальный файл (отвечает за оформление всех обычных папок Windows)
fsresult.htt | поиск файлов
ftp.htt | обзор FTP-сервера
imgview.htt | папка My Pictures
nethood.htt | Сетевое окружение
printers.htt | Принтеры
recycle.htt | Корзина
safemode.htt | оформление активного Рабочего стола в случае сбоя оболочки Windows
shedule.htt | Назначенные задания
standard.htt | шаблон "стандартный"
starter.htt | упрощенный шаблон
sysroot.htt | корневая директория системного диска
wiacam.htt, wiadev.htt, wiastream.htt | камеры и прочие мультимедиа-устройства

Может, восполним и этот пробел? Наверняка ведь среди наших читателей найдутся гораздо более квалифицированные программисты, чем я, скромный сисадмин. Жду писем!


Авторам

У вас наверное есть интересные заметки, публикации или просто дельные советы, а также информация, которой нет ни в одной книге или журнале по работе с программами и ПК. Так вот. Я, с сохранением всех ваших прав и букв, в удобной форме, предоставлю это большому кругу пользователей, у которых возможно есть еще больше вопросов или они еще появятся в процессе работы с ПК.

Статьи, размещенные на сервере будут доступны для чтения в течение 60 календарных дней (если Вам этот период кажется небольшим, пишите на какое время размещать статью), по истечении данного периода времени статья будет подключена в компилированный справочник, по тематике.

При размещении статьи у меня, Вы имеете возможность дать ссылку на сайт с использованием предоставленных баннеров на сайте.

Форма предоставления информации

Так как у многих существуют некоторые проблемы или даже отвращение к MS Word, я советую статьи для правильной передачи и последующего воспроизведения составлять в Блокноте (есть альтернативы - Патриот, Иероглиф, Bred). Кодировка исходных текстов - Windows-1251. При подкреплении текста иллюстрациями, в тексте указывать местоположение изображения (напр."Рисунок-file_1.gif"). Требования к изображению: размеры - максимально высота и ширина (300х600 пикселей), объем - не более 20Кб. Желательно готовить иллюстрации в формате GIF, но если не получится приму такие форматы: PNG, JPG, BMP, TIFF, WMF.

При ссылках на другие источники указывать полностью название и адрес в Сети, если это отдельный автор - его электронный адрес e-mail.

При комплектации статьи и всех прилагающихся к ней материалов упаковывать архиватором ZIP или RAR (самораспаковывающиеся архивы будут сразу удаляться!)

Успехов Вам, удачных статей и разработок!

ОСТАВЬТЕ ВАШ СЛЕД В ИНТЕРНЕТЕ!


Форматировать дискеты быстро

Если у вас бывает мало времени на форматирование дискет, то стоит прочитать эту статью. А речь пойдет о том, как сократить время на форматирование дискет примерно в 2 раза.

И так, всем известна операционная система Windows98 и многие используют её для форматирования дискет. Вставляем нужную дискету в дисковод [-А-]. Наводим курсор мыши на диск [-A-] и нажимаем правую клавишу мыши. Далее выбираем пункт [форматировать]. Появится окно "форматирование", затем в разделе [Способ форматирования] поставим полное и нажмем [Начать]. Форматирование будет длиться примерно 115 секунд, почти 2-е минуты.

Далее для сравнения зайдем в окно MSDOS и напишем в командной строке format a: и нажмем клавишу Enter. Процесс форматирования продлится примерно 45 секунд. Меньше минуты. Сделаем вывод! По времени выгоднее использовать для форматирования MSDOS чем Windows. Причем различие по времени форматирования значительно.

Для примера возьмём 10 дискет для форматирования. Чтобы отформатировать их под Windows98 нам потребуется, грубо говоря, 120 секунд на каждую, если учитывать, что надо достать предшествующую дискету, вставить следующую и нажать Enter. То есть на все 10 дискет потратим около 1200 секунд - примерно 20минут.

Рассчитываем форматирование под MSDOS. Ну, где-то по 50 секунд на каждую дискету, а на все 10 - 500 секунд - не более 9-и минут. Следовательно, рациональнее использовать форматирование под MSDOS, так как тратится в 2 раза меньше времени.

Но я подскажу ещё одну вещь. Ведь для того чтобы начать форматировать под MSDOS, нужно загрузить окно и затем в командной строке набрать команду. А я советую создать файл с расширением BAT и в нем написать:
format a:
И уже потом запускать этот файл для форматирования. Преимущества явные: сразу же загружается окно DOS и предлагает вам отформатировать дискету вставив её в дисковод. Также можно это проделать и если вам нужно очистить только оглавление диска. Создать файл с расширением BAT и написать в нем:
format a: /q

Такой способ создания BAT-файлов можно использовать в различных целях. Например, для восстановления системного реестра написав в файле следующие строки:
CD\
CD WINDOWS
attrib -h -r -s system.dat
attrib -h -r -s system.da0
attrib -h -r -s user.dat
attrib -h -r -s user.da0
copy system.dao system.dat
copy user.da0 user.dat

Скоростных вам форматирований!

Константин Хантер
huntpm@mail.ru
huntpm.narod.ru


Полезные советы по реестру

Поярков Илья (Terabyte)

Данная статья предназначена только для опытных пользователей. Не опытной обращение с реестром может повлечь за собой выход компьютера из строя! На данной странице под словом "указанный ключ" понимается адрес, написанный в самом конце совета. Почти все примеры, приведенные здесь в которых присутствует создание нового параметра подразумевают, что данный параметр является строковым (String), а где нужно создать иной параметр (двоичный (Binary) или DWORD) я буду об этом упоминать. К некоторым советам прилагается *.reg файл, при запуске которого совет сам инсталлируется в реестре и вам нужно только проверить произошло ли изменение. Запускаются REG-файлы двойным кликом, а качаются из Рунета почти за 1 сек. Если после редактирования реестра ни чего не изменилось, то перезагрузите ваш компьютер и проверьте правильность внесенных изменений!

Удаляем PC Health (ME)

Если вас задолбал PC Health, который жрет много места, то его можно легко удалить. Создаем строковый параметр displayname и присваиваем ему имя PC Health, потом идем в Установка и удаление программ, находим там PC Health и ... .

Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\ Uninstall]\PC Health

Контекстное меню IE

Переименовать или удалить некоторые команды из контекстное меню IE вызываемого кликом по ссылке можно в следующем ключе.

Ключ: [HKEY_CURRENT_USER\SOFTWARE\ Microsoft\Internet Explorer\MenuExt]

Чистим главное меню

В ключе, который хранит информацию о порядке расположения папок и ярлыков в главном меню всегда бывает очень много мусора. А именно, когда вы сами удалите или переместите любую папку, деинсталлируете прогу и т.д. Короче, несуществующие разделы вы можете смело удалять!

Ключ:[HKEY_CURRENT_USER\SOFTWARE\ Microsoft\Windows\CurrentVersion\ Explorer\MenuOrder\Start Menu\Programs]

Включение Num Lock при запуске Windows (2000/XP)

Для включения клавиши Num Lock при запуске Windows присваиваем строковому параметру InitialKeyboardIndicators значение 2, а чтобы она не включалась, присваиваем параметру 1 .

Ключ: [HKEY_CURRENT_USER\ Control Panel\Keyboard]

Автоисправление в Scandisk`е (ME)

После неправильного выключения компьютера и при следующей загрузке автоматически запускается Scandisk с установленной галочкой "Исправлять ошибки автоматически", которую нельзя снять! Для того, чтобы галочка отсутствовала по умолчанию надо установить двоичный параметр AutoChk в значение 02,00,00,00, а чтобы ее вернуть в 00,00,00,00 .

Ключ: [HKEY_USERS\.DEFAULT\SOFTWARE\ Microsoft\Windows\CurrentVersion\ Applets\Check Drive]

Анимация для окон

Для того, чтобы можно было включать или отключать "Видеоэффекты для меню и подсказок" через реестр, нужно попасть в указанный ключ реестра и создать новый параметр (если его там еще нет) MinAnimate и присвоить ему значение 1, если хотите чтобы анимация была включена или 0, чтобы она была отключена.

Ключ: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics\]

Изменение скорости открытия главного меню

Для тех кто забыл: главное меню - это меню вызываемое при нажатии кнопки "Пуск" на панели задач. Идем по указанному ключу и создаем новый строковый параметр MenuShowDelay и присваиваем ему значение от 1 до 10, что соответствует скорости открытия меню. Изменения должны вступить в силу после перезагрузки.

Ключ: [HKEY_CURRENT_USER\Сontrol Panel\Desktop\]

Установка путей к системным папкам

Для того, чтобы изменить пути к системным папкам, нужно залезть в указанный ключ реестра и изменить следующие параметры:

  • "ProgramFilesDir" - папка Program Files
  • "CommonFilesDir" - папка Common Files
  • "SystemRoot" - папка Windows
  • "MediaPath" - папка Media
  • "ConfigPath" - папка Config
  • "DevicePath" - папка INF
Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\ ]

Имя рядом с часами

В указанном ключе создаём 3 строковых параметра (порядок следует соблюдать). Пример:

  1. "s1159" со значением "Ваше имя" (не более 8 символов).
  2. "s2359" со значением "такое же, как и у первого".
  3. "sTimeFormat" со значением "HH:mm:ss tt" или "tt HH:mm:ss", где tt обозначает введенный вами текст.
Ключ: [HKEY_CURRENT_USER\Control panel\international\]

Изменение заголовка окна Internet Explorer (9x/NT)

Используя ключ указанный ниже, вы можете изменить заданный по умолчанию заголовок окна "Microsoft Internet Explorer", на что ни будь вроде "Хакеры всех стран объединяйтесь!". Используя RegEdit, откройте этот ключ, создайте в нем новый строковый параметр под названием "Window Title", установите его значение равным строке, которую вы хотели бы видеть в области заголовка. Для сброса к значению по умолчанию, удалите параметр "Window Title".

Ключ: [HKEY_CURRENT_USER\SOFTWARE\ Microsoft\Internet Explorer\Main\]
Параметр: Window Title

Как избавиться от имени в окне "Установка и удаление программ"

В указанном ниже ключе хранятся все 32-разрядные программы. Чтобы удалить объект из списка, надо кликнуть по нему и нажать на клавишу "DEL".

Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\Current Version\ Uninstall\]

Где находятся команды, введенные в окне выполнить

Они находятся под ниже указанным ключом в столбце против букв "a", "b", "c" и т.д. И их можно спокойно удалять!

Ключ: [HKEY_CURRENT_USER\SOFTWARE\ Microsoft\Windows\CurrentVersion\ Explorer\RunMRU\]

Как изменить имя владельца и название организации

Заходим в ниже указанный ключ. Находим строковый параметр Registered Owner и изменяем его значение на ваше имя. Registered Organization - на название вашей организации.

Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\Current Version\]

Создание ярлыка к системным папкам

Следующие действия позволяют вам создать своеобразный ярлык к многим системным папкам вашего компьютера и разместить его где угодно. Для этого надо создать папку и назвать её, например "Корзина.{645FF040-5081-101B-9F08-00AA002F954E}". После этих действий должен появиться значок (не ярлык) «Корзины». С этим объектом можно проводить любые действия. Тот же самое можно сделать и для других системных папок, изменив значения на:

Удаленный доступ к сети - «Удаленный доступ к сети.{992CFFA0-F557-101A-88EC-00DD010CCC48}»
Принтеры - «Принтеры.{2227A280-3AEA-1069-A2DE-08002B30309D}»
Панель управления - «Панель управления.{21EC2020-3AEA-1069-A2DD-08002B30309D}»
Мой компьютер - «Мой компьютер.{20D04FE0-3AEA-1069-A2D8-08002B30309D}»
Сетевое окружение - «Сетевое окружение.{208D2C60-3AEA-1069-A2D7-08002B30309D}»
Входящие - «Входящие.{00020D75-0000-0000-C000-000000000046}»
Корзина - «Корзина.{645FF040-5081-101B-9F08-00AA002F954E}»

Для получения информации по другим папкам посмотрите ключ HKEY_CLASSES_ROOT\CLSID
Ключ: [HKEY_CLASSES_ROOT\CLSID\]

Убираем все надписи

Идём по ниже указанному ключу. Именно там Must Die и хранит информацию о цвете кнопок, надписей, о цвете ползунков и т.п. Теперь меняем значения строковых параметров на:

У "Button text" на "192 192 192"
У "Window text" на "256 256 256"
У "Menu Text" на "192 192 192"
У "Info Text" на "192 192 192"
После этих действий перезагрузитесь и почти всех надписей уже не будет.
Ключ: [HKEY_CURRENT_USER\ Control Panel\Colors\]

Меняем протокол в IE, заданный по умолчанию

Заходим в ниже указанный ключ и меняем значение параметра "По умолчанию" с http:// на ftp:// или на gopher:// .

Ключ: [HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\Current Version\ Url\DefaultPrefix\]

Меняем стандартные значки

Для этого идем по ниже указанному ключу и создаем следующие параметры:

  • "1" - Default Document
  • "2" - Приложение
  • "3" - Закрытая папка
  • "4" - Открытая папка
  • "6" - 3.5 Дюймовый дисковод
  • "7" - Сменный жесткий диск
  • "8" - Жесткие диски
  • "9" - Сетевые диски
  • "11" - CD-ROM Drive
  • "12" - RAM Drive
  • "19" - Программы
  • "20" - Документы
  • "21" - Настройка
  • "22" - Найти
  • "23" - Поиск
  • "24" - Выполнить
  • "27" - Завершение работы
  • "25" - Приостановить работу
  • "36" - Программная группа
  • "29" - Ярлык
  • "34" - Desktop
  • "40" - Audio CD
  • [HKEY_CLASSES_ROOT\CLSD\ {21EC2020-3AEA-1069-A2DD-08002B30309D}\ DefaultIcon]
    "По умолчанию" - Панель управления
  • [HKEY_CLASSES_ROOT\CLSD\ {2227A280-3AEA-1069-A2DE-08002B30309D}\ DefaultIcon]
    "По умолчанию" - Принтеры
Нужно не забывать ставить в адресе к иконке двойной слеш (\\) и в случае *.ICO - файла в конце адреса через запятую ставить 0. Пример "C:\\Files\\icon.ico,0".
Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\ explorer\Shell Icons\]

Изменение многоцветности иконок

Для изменения способности отображать многоцветность иконок, изменяем значение параметра с 16 на 24 или даже на 32bit!

Ключ: [HKEY_CURRENT_USER\ControlPanel\ desktop\WindowMetrics\]
Параметр: shell icon bpp

Версия над системная часами

Чтобы над системными часами отображалась версия Windows 98, надо в Реестре изменить(создать) строковый параметр "PaintDesktopVersion" со значения "0"(нет) на "1"(есть картинка).

Ключ: [HKey_Current_User\ Control Panel\Desktop\]

Охлаждение процессора

Вы знаете, что в Windows (начиная с 98SE) встроена программа охлаждения процессора (CPU) под названием CPUCool? Если нет, тогда читайте дальше! Проблема состоит в том, что по умолчанию она отключена. Идем по указанному ниже ключу. Создаем в нем новый раздел - CPUCool, а в нем новый строковый параметр типа DWORD - "Idle" со значением "1".

Ключ: [HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control\]

Приписка к версии Windows

Идем по указанному ниже ключу. Находим параметр SubVersionNumber и изменяем его значение (например на WEB-HACK). Только не забудьте поставить впереди пробел, а то фраза прилипнет к версии Windows. Теперь вы получите, что то вроде "4.10.1998 WEB-HACK". Теперь можете любоваться (Панель управления\Система). Строковый параметр Version показывает, что за Windows у вас стоит, а параметр VersionNumber его версию.

Ключ: [HKEY_LOCAL_MACHINE\SOFTWARE\ MICROSOFT\ WINDOWS\CURRENTVERSION\]

Автозагрузка

Если при запуске Windows у вас запускаются разные программы которые вам не нужны при загрузке, а в меню Пуск\Программы\Автозагрузка их нет, то ищите проги по следующим ключам:

  • HKEY_CURRENT_USER\Software\ Microsoft\Windows\CurrentVersion\ Run
  • HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\ Run
  • HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\ RunServices
  • HKEY_USERS\.DEFAULT\Software\ Microsoft\Windows\CurrentVersion\ Run

Со своими вопросами и критикой пишите сюда: web-hack@mail.ru. Если вы хотите узнать огромное множество других полезных вещей связанных с компьютерами (HACKING, советы, WEB-дизайн, реестр виндов, скрипты, статьи, анекдоты, афоризмы, початиться и т.д.), то идите на мой сайт web-hack.boom.ru. А мой NICKNAME – Terabyte!


Графические карты:советы по настройке

Современные графические карты предлагают высокое разрешение, мультипликацию без "дерганий" и реалистичное представление трехмерных объектов всех видов. При этом речь идет, в первую очередь, о новых графических SD-картах. Ниже показано, как наиболее полно использовать возможности графической карты благодаря оптимальной настройке драйвера.

Быстрое изменение изображения на экране монитора дает преимущества не только при запуске новейших игр, но и при расчете сложных текстур или создании мультипликации. Это всегда предполагает согласованность между графической картой, драйвером, операционной системой и монитором. Если у вас, например, высококачественный монитор, то Windows должна обеспечить корректное управление экраном. Только в этом случае можно извлечь пользу из высокой частоты регенерации или других рабочих характеристик монитора.

Совет 1. Согласование графической карты с монитором

Windows 95 и Windows NT 4.0 оснащены модулем, с помощью которого можно согласовать монитор и графическую карту. Вы найдете его после щелчка правой кнопкой мыши на пустом поле Desktop и на Свойства в окне Параметры/Дополнительно/Монитор (Windows 95B OSR2). Внимание: соответствующее меню может и отсутствовать на этом месте, в этом случае графическая карта вызывает его через свой драйвер. В окне Свойства вы найдете специальную опцию для монитора, функции которой соответствуют монитору Windows.- Windows получает информацию о мониторе через INF-файл, в котором записаны все основные параметры экрана. Windows не может превысить параметры, приведенные там в пояснительном тексте. Поэтому при высоком разрешении 1280 х 1024 точки для большинства моделей она предлагает лишь частоту регенерации 60 или 70 Гц. Если операционная система настроена как Windows 95 и NT 4.0 на Plug&Play -экран и графическая карта работает с VESA DDC (VESA-Video Electronic Standart Association, DDC - Display Data Channel), то Windows через этот канал автоматически определяет рабочие характеристики монитора и настраивается на них.
Современные мониторы поставляются изготовителями со своими собственными INF-файлами, которые можно воспроизвести в Windows. При отсутствии DDC информация INF-файла обеспечивает оптимальное согласование графической карты с монитором.

Совет 2. Традиционные установки в стандартных мониторах

Используйте стандартные установки Windows, такие как разрешение 1024х768 или 800х600 точек, только в том случае, если вы работаете со старым монитором, который не совместим ни с одной из указанных моделей. Вы быстро узнаете, почему: стандартные мониторы, перечисленные Windows, чаще всего предусматривают очень низкую частоту регенерации. В этом случае даже в самом простом режиме графическая карта работает только с частотой 60 Гц - мерцание неизбежно.

НЮАНСЫ

Offscreen-Memory
Современные графические карты имеют рабочую память от 2 до 8 МБ, часть которой используется для промежуточного хранения графических данных. Другая область этой оперативной памяти - это "Offscreen-Memory". В ней сохраняется информация, которая не выводится непосредственно на экран монитора. Процессор также заполняется данными, которые используются им для ускорения графики и расчета 3D-объектов. Это происходит гораздо быстрее, чем запрос через шину и использование основной памяти компьютера. При расчете 3D-объектов большей популярностью пользуются те алгоритмы, которые сначала создают объекты, лежащие в основе искомых, а затем покрывают их другими объектами. Это построение осуществляется в Offscreen. Если эти объекты перемещаются на передний план, то их сдвигают в видимую область памяти. Объем Offscreen-памяти является решающим фактором для качества воспроизведения изображения. Расчет видеоизображения страдает при памяти до 2 МБ, а начиная с 4 МБ качество повышается. Подобные эффекты были установлены при расчете фильтров, графических карт с высоким цветовым режимом работы (16,7 млн. цветов) и стандартным разрешением: эффективность повышается, начиная с объема Offscreen-памяти 4 МБ - обычно вследствие текстуры изображения графические 3D-карты требуют как минимум 4 МБ.

Совет 3.Графическая карта полностью использует настройку

Драйверы таких графических карт, как Matrox Millenium, предлагают собственную вкладку Монитор, в которой можно индивидуально сконфигурировать рабочие параметры монитора. Здесь можно найти VESA-характеристики, которые должны соответствовать частоте регенерации, горизонтальной частоте и тактовой частоте пиксельного вывода графического изображения на монитор. По этим параметрам драйвер рассчитывает профиль, который затем можно сохранить под своим собственным названием. Технические характеристики монитора, необходимые для этих установок, можно найти в инструкции на монитор. Типичными являются такие параметры, как частота воспроизведения (75), горизонтальная частота (60), тактовая частота пиксельного вывода графического изображения (78). Действительно ли соответствуют найденные вами параметры оптимальным значениям, можно проверить с помощью меню с командой Test. Из этого теста сразу видны характеристики монитора и эти параметры можно корректировать до тех пор, пока они не будут соответствовать заданным установкам.

Совет 4.Защита старых мониторов от неправильных установок

Новые мониторы оснащены защитой от перегрузки, которая предохраняет электронные схемы устройства. Во многих мониторах на передней панели начинает мигать светоизлучающий диод, если монитор работает в критической области. В старых моделях мониторов такая защита отсутствует. Поэтому они могут получить повреждения и даже полностью выйти из строя. Однако, вы можете своевременно определить критическую область работы монитора, если обратите внимание на следующее: когда вы устанавливаете разрешение монитора в Windows NT, всегда щелкайте на кнопке Test. Если при этом монитор начинает "зуммировать", то просто выключите его. Через десять секунд процесс тестирования автоматически переключается на предыдущее значение разрешения. Таким образом, примерно через десять секунд можно снова включить монитор и продолжать работать со "старым" разрешением монитора. Точно так же пользователи Windows 95 должны пользоваться автоматическим тестированием. Если монитор не синхронизируется, то необходимо отключить компьютер и после этого запустить Windows в режиме защиты, который обычно можно установить с помощью функциональной клавиши [F8]. Затем через Старт/Настройка/Панель управления/Монитор во вкладке Параметры можно выбрать невысокое разрешение. После нового запуска компьютера Windows 95 будет работать с этими установками.

Совет 5.3D-карты различных поколений

Современные графические 3D-карты называются "картами второго поколения". Отличие от карт первого поколения налицо: мощность графической схемы в плане 3D-ускорения значительно повышена. Очень хорошо это показывает тестирование графических карт. Это означает, что до недавнего времени господствующие на рынке классические микросхемы, например S3, уже уходят со сцены. Причина этого в том, что в настоящее время S3 уже не соответствует мощности схем других изготовителей. S3-схема не настолько быстрая. Поэтому, "начиная с сегодняшнего дня", изготовители 3D-карт используют другие микросхемы.
Драйверы играют решающую роль для 3D-изображения. Хотя карты второго поколения обеспечивают очень хорошую скорость при воспроизведении 3D-изображений, но наилучшее качество можно получить только при использовании самых новейших драйверов. В настоящее время они очень быстро сменяются на рынке. Поэтому на Web-страницах вы можете найти адреса изготовителей самых последних версий. Таким образом, регулярная связь с Internet имеет смысл прежде всего для фанатов компьютерных игр.

Совет 6. Устранение нечеткого изображения

Если тактовая частота пиксельного вывода графического изображения у графической карты значительно превышает характеристики монитора, то, как правило, изображение получается размытым. Как уже упоминалось в первой части этой статьи, для многих современных графических карт эту тактовую частоту можно снизить. Обратитесь по этому вопросу к инструкции по вашей графической карте. Однако лучше всего перед покупкой новой графической карты поинтересуйтесь рабочими характеристиками монитора.

Совет 7. Устранение "подвижного изображения" на мониторе

Не так уже редко случается, что по экрану монитора "бежит" мелкая рябь, которая мешает в работе. В некоторых мониторах есть такая функция, как "Anti-Moire", с помощью которой можно ослабить или даже устранить этот эффект. Правда, одновременно не мешает посмотреть на кабель: недорогие D-подканалы имеют очень низкую ширину полосы пропускания и поэтому допускают такого рода помехи. В дорогих мониторах можно использовать более качественно экранированные BNC-кабели (коаксиальные), которые одновременно предотвращают возникновение теней на экране.

Совет 8.Отсутствие красок при использовании VESA DDC

Уже упомянутый VESA DDC дает возможность операционной системе через графическую карту обмениваться данными с монитором. Благодаря этому, например, можно избежать перегрузки электронных схем монитора. Правда, DDC-экран может показать отсутствующие функции, например несуществующие краски, если вы подсоедините его к графической карте без DDC.
Если шрифты размером 12 и 15 пунктов не поддерживают ожидаемый уровень графической карты, то при определенных обстоятельствах это может привести к возникновению помех. В таких случаях обычно может помочь только одно: приобрести новую графическую карту.

Совет 9.Если MPEG-видео работает очень медленно

MPEG (Motion Pictures Expert Group) используется довольно часто, например в системах видеоконференций. Однако, если в соответствующем окне видео появляется с помехами или даже вообще не появляется, то причина этого не обязательно связана с драйвером или программным обеспечением. Если графическая карта в системе не оснащена Display Control Interface (DCI), то чаще всего ничего не происходит. Поэтому при покупке обратите внимание на то, какие требования предъявляет аппаратное видеообеспечение, например, к основной памяти графической карты. Для получения требуемого цветового разрешения карта должна быть оснащена оперативной памятью в 2-4 МБ.

Совет 10. Необходимые установки для Windows NT 4.0

При запуске Windows NT 4.0 предлагает альтернативный выбор, с помощью которого можно устранить нарушения графического изображения. Вы можете выбрать между "VGA-режимом", который в плане графики соответствует режиму защиты Windows 95, и обычным запуском NT 4.0.
VGA-режим можно определить по строке "Windows NT, version 4.0(VGA)", при которой запускается NT с опцией \basevideo. Такую графику, соответствующую разрешению 640 х 480 точек и 16 цветам, может обеспечить любая карта, даже если драйвер работает некорректно.

Совет 11.Ускорение помогает при помехах

Если графические драйверы в Windows 95 внезапно перестают надежно работать, то перед их заменой можно попробовать простую уловку: "смазанное" изображение и подобные дефекты можно устранить, щелкнув справа на рабочем месте, а затем левой кнопкой мыши на Свойствах. После этого перейдите во вкладку Параметры/Дополнительно/Быстродействие и переместите регулятор в этом окне. После этих изменений заново запустите Windows. После этого, как правило, все дефекты должны исчезнуть.

Совет 12.Выделение помехи на экране

Некоторые графические карты из серии Winner фирмы Elsa склонны к изображению курсора вокруг помех типа "вспышка", если перемещать указатель мыши по графическому объекту на экране монитора. Фирма Elsa рекомендует отредактировать файл ELSA.INI и встроить раздел под названием [Setting]. После этого нужно ввести следующую командную строку: "TI-Snow=l".

Совет 13.Сокращение времени при инсталляции DirectX

Некоторые игры настроены таким образом, что могут работать только вместе с ЗО-картой или с DirectX. Поэтому для них обязательно требуется инсталляция DirectX. Если DirectX уже инсталлирован, а игра не имеет новых версий, то от повторной инсталляции можно отказаться.Кроме того, большинство игр требуют повторного запуска, хотя DirectX не инсталлирован. Это совершенно не обязательно, так как в большинстве игр не предпринимаются никакие системные изменения. Таким образом, можно просто отказаться от нового запуска и сразу же начать игру.

Совет 14. Проблемы со скоростью при использовании DirectX

Всегда после инсталляции DirectX графика в Windows начинает работать гораздо медленнее. Причина этого проста: если вместо специально подобранного драйвера фирмы-изготовителя графической карты использовать драйвер Windows 95 фирмы Microsoft, то карта будет работать не в оптимальных условиях. Поэтому инсталлируйте только специальный драйвер для графической карты.

Совет 15. DirectX не работает после инсталляции

У многих пользователей возникает проблема, связанная с тем, что при повторной инсталляции DirectX не заменяет файлы на их оригиналы, а просто проверяет, все ли файлы в наличии. Эту проблему можно обойти с помощью простой уловки. Для этого поступите следующим образом: запустите заново компьютер. Когда появится сообщение о запуске Windows 95, нажмите клавишу [F8]. В открывшемся меню с помощью клавиш управления курсором выберите режим защиты. После запуска Windows можно без проблем начать инсталляцию DirectX.

Совет 16.Если внезапно пропадает звук при работе с DirectX

Если после инсталляции DirectX у вас нет звука в DirectX-играх, то причина этого, возможно, в том, что при запуске Windows 95 вы загрузш. DOS-драйвер вашей звуковой карты. Удалите этот драйвер из стартовых файлов AUTOEXEC.BAT и CONFIG.SYS. Для этого перед соответствующими строками поставьте "Rem". О каких строках при этом идет речь, вы узнаете в руководстве по вашей звуковой карте.

Совет 17. Какая версия DirectX инсталлирована?

Для выяснения вопроса, какая у вас инсталлирована версия, найдите файл DDRAW.DLL. Он находится в системном каталоге Windows. Щелкните на файле правой кнопкой мыши и выберите из контекстного меню команду Свойства. В раскрывшемся окне выберите вкладку Version.
Теперь просто сравните указанный там номер версии с данными, приведенными ниже в таблице. Для выяснения вопроса, инсталлирована ли у вас версия DirectX 3 или За, вам нужно поступить с файлом D3DRGBXF.DLL так же, как с файлом DDRAW.DLL.
4.02.95 - DirectX версия 1
4.03.00.1096 - DirectX версия 2
4.04.00.68 - DirectX версия 3
4.04.00.70 - DirectX версия За
4.05.00.155 - DirectX версия 5

Совет 18. Устранение зависания программы при работе DirectX

Определенные версии DirectX в сочетании с некоторыми специальными элементами аппаратных средств могут вызвать зависание прикладных программ. Обычно эту ошибку можно устранить, вызвав еще раз DirectX-Setup и деактивировав там опцию ускорения работы.

Совет 19. Согласование параметров графической карты в Linux

Linux работает без сбоев со всеми графическими картами; в ядре не надо ничего конфигурировать. Правда, это касается только режима работы, основанного на вводе текста с пульта управления. Иначе обстоит дело в X-Window: в этом случае обращение происходит непосредственно к графическим картам. В отличие от Windows З.х и 95 графическая карта запрашивается не через драйвер, а через собственный Х-сервер, зависящий от аппаратных средств. Вне конкуренции здесь бесплатные ХFrее86-серверы. Самые последние версии вы всегда найдете по адресу http://www.xfree86.org. В Readme-файлах указано соответствие Х-сервера графическому чипу. Неускоренный VGA16-cepвep работает практически с каждой графической картой. Несмотря на это, лучше взять один из Х-серверов, который соответствует набору микросхем вашей графической карты. Кроме более высокой скорости вы получите лучшее разрешение и большую глубину цвета. Сейчас в процессе работы по интеграции 3D-ускорения в отдельные XFree-серверы (например для Virge 3D). Х-инсталляция и Х-конфигурация частично зашифрованы. Если ваша графическая карта не поддерживается XFree или для вас обязательна специальным образом оптимизированная работа графической карты, то вам нужно обратить внимание на коммерческие Х-серверы. В первую очередь здесь следует назвать Metro-X фирмы Metrolink (http://www.metrolink.com) и Accelerated-X фирмы X Inside (http://www.xinside.com).

Совет 28. Работа DirectX в Windows NT 4.0

Если вы хотите запустить в Windows NT 4.0 DirectX-программы, то прежде нужно инсталлировать пакет Service Pack 3, поскольку программа нуждается в Direct Sound-поддержке. Вы найдете этот пакет в Internet на Microsoft-Homepage (http://www.microsoft.com).


Полезные советы

Поярков Илья (Terabyte) terabyte@bk.ru

В данной статье вашему вниманию представлены полезные советы для работы с компьютером. Некоторые вас удивят, а некоторые позволят ускорить или упростить работу. Все совета проверены в ОС (Операционной системе) Windows 98SE и работают в ней, но вполне возможно, что они будут действовать и в Windows 95/98/ME. Во всех советах предполагается, что ваш Windows находится по адресу: C:\WINDOWS\!

  1. Когда вы посылаете письмо адресату в том же домене, в котором находитесь сами, достаточно в поле адреса записать только первую часть адреса (например, web-hack вместо web-hack@mail.ru).
  2. Этот совет поможет вам импортировать данные из reg-файла в реестр БЕЗ вывода подтверждений на это. Делается это с помощью командной строки (или из bat-файла). Она должна быть следующего типа:
    regedit /s <registry file>.reg
    Тот кто умный, сразу поймет какие это дает возможности! Например, незаметный запуск bat-файла у знакомого, может сделать ТАКОЕ! после перезагрузки компа, что знакомому даже не снилось.
  3. Если у вас возникли проблемы в WinXP с переключением на русскую кодировку, то идите в реестр по ключу:
    [HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\ Control\Keyboard Layout\DosKeybCodes]
    и измените значение параметра 00000409 на ru. Потом откройте файл %windir%\system32\autoexec.nt и вставьте в него строчку
    ih %SystemRoot%\system32\kb16.com ru
  4. Если у вас на компьютере несколько Windows, то можно назначить им использовать один СВОП-файл! NT/2000/XP указываем диск, где он создаст в корне свой СВОП-файл (pagefile.sys), а 9x/ME пишем в файле SYSTEM.INI в разделе [386Enh] :
    PagingDrive=C:
    PagingFile=C:\pagefile.sys
    В примере предполагается, что NT/2000/XP вы указали диск С: для СВОП-файла.
  5. В папке Windows\System есть утилита MKCOMPAT.EXE, которая позволяет запускать программы написанные под Win 3.1x в Win 9x более лучше.
  6. Если вы работаете через прокси-сервер, то вполне возможно, что на WEB-странице которую вы загрузили информация уже устарела (иногда попадаю и вообще призраки), а вам нужна последняя информация, то в IE нажмите "Ctrl" + кнопку "обновить", а в NN "Shift " + кнопку "обновить"!
  7. Для того, чтобы убрать иконку из Панели управления надо удалить или переместить соответствующий файл с расширением cpl из папки Windows/System. А можете просто внести в раздел [don't load] файла control.ini записи следующего вида: *.cpl=no
    Комментарий: файл находящийся по адресу Windows/System/control.exe открывает Панель управления.
  8. В составе домашних виндов (9x/ME), есть очень полезная утилита hwinfo.exe, которая выкладывает ВСЮ информацию о вашем железе и конфликтах. При простом ее запуске она вам ничего не выложит и надо добавить ключ /ui. Для ее удобного запуска можете в "Пуск/Выполнить..." написать hwinfo /ui Вот только есть одна проблема! Одни утверждают, что она у них есть, а другие (с той же ОС), что ее нет по адресу WINDOWS\hwinfo.exe . Я предполагаю, что это из-за того, что некоторые делают неполную установку Windows.
  9. Если вы хотите, чтобы все временные файлы создавались в назначенной вами папке, то добавьте в Autoexec.bat следующие строки:
    SET TEMP=H:\TEMP
    SET TMP=H:\TEMP
  10. В меню "Пуск/Выполнить..." или в командной строке ярлыка (здесь лучше еще задать "Быстрый вызов" например, F11 или F12) пишем одну из следующих строк:
    rundll.exe user.exe,exitwindowsexec - перезагрузится только Windows (работает только в Windows 9x).
    rundll.exe user.exe,restartwindows или rundll.exe user.exe,restart - комп должен перезагрузиться (правда у меня в ME это не прошло!!!).
    rundll.exe user.exe,exitwindows или rundll32 krnl386.exe,exitkernel - комп совершенно легально выключится.
    rundll32.exe keyboard,disable - отключается клавиатура.
    rundll32.exe mouse,disable - отключается мышь.
    rundll32.exe user,disableoemlayer - отключается экран.
    Комментарии: расширение exe я писал для наглядности и его писать не обязательно. Для выключения NTY2K, есть утилита shutdown.exe, которая встречается на лицензионных дисках. Для прикола над другом можно поместить ярлык с одной из выше приведенных фич (а можно и несколько ярлыков) в автозагрузку! Судя по моим тестам, в примерах можно использовать rundll32.exe или rundll.exe, а эффект будет один.
  11. Если вы установили пароль в BIOS`е и забыли его, то можете воспользоваться утилитой DEBUG. Она хранится по адресу Windows\Command\debud.exe и запускать ее надо только в DOS`е. После ее запуска вводите следующее:

    -o 70 17
    -o 71 17
    -q     После этой операции в BIOS`е сотрутся все ваши установки и установятся те, которые были назначены производителем по умолчанию!

  12. Заставки, которые отображаются при выключении компьютера лежат в папке с Windows, под именем logos.sys и logow.sys, а открываются они обычным Paint`ом. Однако заставку при запуске Windows приходится создавать самому в том же Paint`е (256 цветов, 320x400) под названием logo.sys и сохранив её в корневую директорию с вашим Windows`ом, например C:\logo.sys!
  13. Заходим в папку Windows\Web, находим там файл folder.htt и копируем его в папку Windows\ и Windows\System\. Теперь Windows95/98 не будет возникать при открытии этих папок!
  14. Кликнув на пустом месте папки или рабочего стола и выбрав из контекстного меню пункт "Создать" можно создать папку или другой объект, но как добавить туда собственный объект? Этим мы сейчас и займёмся! Для этого надо, чтобы формат файла был зарегистрирован. Если это файл, например текстового редактора который вы проинсталлировали, то скорей всего его формат уже зарегистрирован. Но если нет, это вы сможете сделать сами открыв МОЙ КОМПЬЮТЕР и выбрав пункт ВИД\СВОЙСТВА ПАПКИ…\ТИПЫ ФАЙЛОВ, а дальше НОВЫЙ ТИП… . Итак, я отвлекся, пойдём дальше. Допустим, что это файл текстового редактора и вам надо при каждом его запуске иметь определённые поля и определённый шрифт. Далее надо:
    • Открыть данное приложение и установить нужный шрифт и нужное расстояние полей.
    • Сохранить этот файл в папке Windows/ShellNew.
    • Запустить редактор реестра RegEdit из пункта ВЫПОЛНИТЬ главного меню.
    • Открыть ветвь HKEY_CLASSES_ROOT и найти там расширение созданного файла.
    • Выберите в нём раздел ShellNew, если его нет, создайте его - ПРАВКА\СОЗДАТЬ\РАЗДЕЛ.
    • Далее создаём в нём новый строковый параметр - ПРАВКА\СОЗДАТЬ\СТРОКОВЫЙ ПАРАМЕТР. И назвав его "FileName" делаем его значением полное (с расширением) имя созданного нами файла.
    • Теперь осталось только перезагрузиться!

    Если нажать кнопку "Пуск"(Start), выбрать пункт "Выполнить"(Run) и напечатать в строке точку, то откроется папка "Рабочий стол"(desktop), а если напечатать две точки, то откроется папка Windows.

    В Windows\Web находятся различные файлы отвечающие за оформление Windows, а также некоторые другие файлы которые нам не нужны. Файлы с расширением .htt можно открыть с помощью Notepad'а. Например:

    • folder.htt - Отвечает за оформление папок Windows
    • mycomp.htt - Отвечает за оформление папки "Мой Компьютер"
    • printers.htt - Отвечает за оформление папки "Принтеры"
    • controlp.htt - Отвечает за оформление папки "Панель Управления"
    • efault.htt - Отвечает за оформление папок "Temporary Internet Files", "Downloaded Program Files", "Subscriptions", "History", "Портфель"
    • safemode.htt - Отвечает за оформление рабочего стола , при ошибке Windows 98
    • recycle.htt - Отвечает за оформление папки "Корзина"
    • shedule.htt - Отвечает за оформление папки "Назначенные Задания"
    • nethood.htt - Отвечает за оформление папки "Nethood"
    • dialup.htt - Отвечает за оформление папки "Удаленный Доступ к Сети"
    • deskmovr.htt - Отвечает за оформление активного рабочего стола
    • wvleft.bmp - Отвечает за графическое оформление папки Windows. Можно открыть с помощью Paint'a
    • wvline.gif - Отвечает за графическое оформление папок
    • wvlogo.gif - Отвечает за графическое оформление папок
  15. Перед изменением реестра скопируйте файлы system.dat и user.dat из корневой папки Windows.
  16. Для того, чтобы убрать заставку при запуске Windows, надо в файле msdos.sys подредактировать параметре [OPTIONS], изменив строку Logo=1 на Logo=0.
  17. Для того, чтобы сделать быстрый (теплый) перезапуск компьютера, надо зайти в окно "Завершение работы..." и удерживая клавишу Shift нажать на пункт "Перезагрузка компьютера".
  18. Чтобы скопировать в буфер обмена содержимое всего экрана нажмите на клавишу PRINT SCRN, а чтобы только активное окно ALT+PRINT SCRN.
  19. Чтобы быстро открыть зарегистрированный тип файла другим приложение, надо выделить объект, а затем удерживая клавишу Shift, кликнуть по нему правой кнопкой мыши.
  20. Если вы хотите скопировать дискету, то кликнув по ее значку правой кнопкой мыши, выберите пункт "Копировать диск...".
  21. Если вам хочется изменить значок диска, то создайте в его главной директории файл Autorun.inf. А в нем напишите:
    [Autorun]

Icon=Путь к иконке

    А после этих действий перезагрузитесь!
  22. Если вы хотите из командной строки MS-DOS загрузить программу с именем более восьми символов или открывать папку с названием более восьми символов, то перед и после имени ставьте кавычки (" "). Например:
    "abcdefghij.exe"
    СD\"PROGRAM FILES"
  23. Если вы хотите создать загрузочную дискету в Windows 98/98SE, а у вас нет от нее диска, то делаем следующее. Заходим в папку C:\WINDOWS\COMMAND\EBD, находим файл Bootdisk.bat, запускаем его и следуем дальнейшим указаниям!
  24. Вам интересно, как редактировать контекстное меню Отправить, которое вызывается щелчком правой кнопки мыши на объекте? Если да, то читайте дальше! Создаем ярлык нужного вам объекта (программы, папки и т.д.). Идем по адресу C:\WINDOWS\COMMAND\SendTo\ и кидаем туда это ярлык. Все хранящиеся в этой папке ярлыки можно удалять, переименовывать, создавать здесь новые папки и тд.
  25. Если создать ярлык и в командной строке написать C:\Windows\EXPLORER.EXE /ROOT, (с запятой), то он будет открывать рабочий стол (desktop).
  26. Для того, чтобы быстро запускать скринсэйвер или хранитель экрана (*.scr) не дожидаясь определенного количества времени вы можете создать для него ярлык в удобное для вас место, а если вы хотите просмотреть новый (не установленный или установленный), то в контекстном меню выберите "Тест". Но а если хотите его теперь установить, то скопируйте его в папку C:\Windows\System\ или выберите в контекстном меню пункт "Установить", а потом нажмите на "Ok".
  27. Некоторую полезную информацию по Windows вы найдете в файле по адресу C:\WINDOWS\Readme.htm.
  28. Если хотите проиграть музыку "Универсальным проигрывателем" из BATCH файла (*.bat), то в нем напишите "mplayer.exe имя_файла.*", а если вы хотите просто запустить "Универсальный проигрыватель" с выбором файла, то в BATCH файле напишите "mplayer.exe /play /close".
  29. Если вы работаете в DOS`е и у вас работает программа которою необходимо закрыть, то нажмите на клавиатуре <CTRL>+<BREAK(PAUSE)>/<CTRL>+<C>.
  30. При удерживании клавиши ALT в Microsoft Word и наборе любого числа (в десятичной форме) соответствующего любому знаку из кодовой таблиц ASCII, отобразится этот знак. Например, при наборе числа 87, отобразится заглавная буква W!

    Если вы хотите узнать огромное множество других полезных вещей связанных с компьютерами (hacking, советы, web-дизайн, реестр виндов, скрипты, статьи, анекдоты, афоризмы, початиться и т.д.), то идите на мой сайт whg.chat.ru (старый адрес web-hack.boom.ru). Мой nickname – Terabyte!


Сделай Windows удобнее

Сергей Уваров

Давайте-ка в очередной раз "поломаем":-) Windows. Если точнее, наш сегодняшний обзор вновь посвящается улучшению работы с этой операционной системой, и на сей раз мы затронем тему контекстных меню "Окон".

В качестве альтернативы строке меню или панелям инструментов мы довольно часто пользуемся так называемыми контекстными меню, вызываемыми правой кнопкой мыши. Благодаря этому способу можно производить операции с файлами и каталогами, получать информацию об объектах и т.д. Однако факт остается фактом - контекстные меню названы так потому, что команды, отображаемые в этих меню, "привязаны" лишь к тому объекту, на который указывает мышь после выполнения щелчка правой кнопкой. Что же касается дополнительных удобств при использовании контекстных меню, их, мягко говоря, мало . Что ж, на помощь обреченному юзеру вновь спешат альтернативные продукты. На этот раз мы рассмотрим программы, позволяющие увеличить функциональность контекстных меню, внешний вид и возможности работы самого «Проводника», а заодно обеспечить вам дополнительные удобства в Windows. Начнем-с.

Acloon VideoViewer 3.35

Разработчик: S-Typy (http://www.s-typy.com/videoviewer.html)
Статус: shareware, $19.95
Интерфейс: английский
ОС:Win 9x/Me/2000/XP
Размер:1Mб

А начнем мы с программы, которая в мгновенье ока:-) облегчит существование уставшего от различных телодвижений юзера. Acloon VideoViewer - профессиональная утилита для просмотра и проигрывания аудио, видео и графических файлов (включая анимационные), а также библиотек иконок (*.dll). После установки программа интегрируется в контекстное меню «Проводника» и при выборе соответствующих файлов нажатием правой клавиши мышки позволяет просмотреть или прослушать выбранный документ. Причем Acloon VideoViewer может даже обойтись и без правой клавиши, достаточно просто подвести курсор мыши к звуковому файлу и слева отобразятся его свойства и панель воспроизведения.

Поддержка файлов программой просто впечатляет:

видео и анимация: mpg, mpeg, mpe, mlv, mp2, mpv2, mpa, mov, avi, fli, flcm cel, gif, dat, asf, asx, wm, wmv, wvx, ivf;
аудио: mp3, m3u, wav, snd, av, aif, iaff, aifc, mov, at, wma, wax, voc, mid, midi, rmi;
графика: bmp, dib, rle, jpg, jpeg, gif, ico, cur, wmf, emf, pcx;
библиотеки иконок: icl, il, nil, exe, dll, cpl, ocx, drv, vbx.
Возможности настройки различных параметров представлены также очень широко. Все опции разделены на соответствующие закладки, где можно отрегулировать следующие параметры воспроизведения:
видео - в окне или во весь экран, скорость воспроизведения, использование стандартных или поставляемых с программой иконок (для всех видов воспроизводимых программой файлов);
аудио - выбор между 2-мя интерфейсами воспроизведения (DirectShow service или DirectX 7.0);
графика - выбор между размерами окон воспроизведения, отображение свойств файлов и настройка показа иконок, в частности параметров конвертирования иконок в формат *.bmp, выбор папки для сохранения конвертированных файлов, а также настройка воспроизведения иконок.

Кроме этого, программа позволяет установить поддержку Windows 2000 по умолчанию или же провести настройки самостоятельно.

Скачать эту замечательную утилиту можно с http://www.s-typy.com/download/Acloon_VideoViewer.zip.

Mp3ListShellEx

Разработчик: Шахин Гасанов

Статус:freeware
Интерфейс:английский
ОС:Win 9x/Me/NT/2000
Размер:57Kб

Mp3ListShellEx - еще одна музыкальная утилита, дополняющая стандартные возможности «Проводника». При своем скромном размере в 57Kб программа позволяет создать в «Проводнике» плейлист, предварительно выделив каталог с mp3-файлами и кликнув на нем правой кнопкой мышки. Имеется возможность работы с вложенными папками. Mp3ListShellEx создает плейлисты следующих форматов: Windows media Player playlist, таблица Excel или простой html-файл. Они могут сохраняться на рабочем столе, в папке с искомыми mp3-файлами или временной папке. Позволяет включать почти все секции mp3-тэгов (название трека, исполнитель, альбом и т.д.), определяющие свойства каждого конкретного файла.

Скачать программу можно с ftp://ftp.ware.ru/win/pub/Mp3ListShellExSetup.zip.

CMenu Extender 1.2.1.2

Разработчик: Revender Inc. (http://www.geocities.com/revenger_inc/cmext.html)
Статус:freeware
Интерфейс: английский
ОС:Win 9x/Me/2000
Размер: 207Kб

Уж эту программу, как мне кажется, ждали многие. CMenu Extender позволяет включать в контекстное меню «Проводника» любые дополнительные пункты меню, в том числе и команды на копирование/перемещение в любимую папку, открытие документов, web-сайтов и т.п. Не требует инсталляции. В поставку входят больше десятка предустановленных пунктов меню:

Move to named folder;
Copy to named folder;
Move/copy to browsed folder;
Explore folder;
Open file/program;
Path information;
Properties info;
Start program;
Webpage: open default browser;
E-mail: open default e-mail client;
Custom command (любая команда на ваше усмотрение);
и другие

Каждое из пунктов меню можно модернизировать и изменять по своему усмотрению. Модификации мгновенно отражаются в контекстном меню «Проводника». Программа очень удобна при интенсивной работе с файлами, позволяет сократить время на различные операции. Скачать CMenu Extender можно отсюда: http://www.geocities.com/revenger_inc/cmext121.zip.

ZANS Renaming files 1.0

Разработчик: ZANS (http://www.zans.narod.ru)
Статус:freeware
Интерфейс: русский
ОС:Win 9x/Me
Размер:189Kб

Иногда случается, что необходимо в срочном порядке переименовать большое количество файлов по однотипному шаблону (например, коллекцию картинок). Работа затягивается на долгие часы. С помощью ZANS Renaming files 1.0 этого можно избежать. Данная программка позволяет переименовывать файле опять-таки(!) в окне "Проводника" и к тому же одной командой! Интегрируясь в оболочку "Проводника" и добавляя в контекстное меню свою команду, утилита избавляет Вас от необходимости использования сторонних программ. Инсталляция/деинсталляция полуавтоматическая, поддерживается английский и русский языки интерфейса. ZANS Renaming files позволяет переименовывать как имя, так и расширение файла, поддерживаются шаблонные операции [*] типа:

a.jpg - все выделенные файлы примут имя a.jpg, a1.jpg, a2.jpg и т.д.;
s*.bmp - имя файлов будет начинаться с буквы s, далее добавляется исходное имя файла;
H.*- расширение файла останется исходным, имена - h1, h2, h3 и т.д.

Производительность ZANS при переименовании просто поражает:-). Могу смело рекомендовать для домашнего применения. Качать с http://www.zans.narod.ru/product/files/zrfiles.zip.

FolderBox 1.1

Разработчик: BaxBEx Software (http://www.baxbex.com)
Статус:freeware
Интерфейс: английский
ОС:Win 9x/Me/NT/2000
Размер:796Kб

Очень, скажу вам, полезная программка. FolderBox является дополнением к стандартному "Проводнику" и представляет собой еще одну панель в нижней части экрана, в которой могут отображаться выбранные вам диски или папки. Все это благотворно влияет на скорость работы, когда приходится долго мучаться, прежде чем доберешься до необходимой папки. FolderBox изначально не отображается в "Проводнике" и подключается через меню "Вид">"Панели обозревателя", где и нужно выбрать строку FolderBox. Программа позволяет установить до пяти таких вот "ящиков" и настроить каждый из них, в том числе и панель инструментов программы для каждого конкретного box’а.

Кроме того, удовольствие пользоваться преимуществами FolderBox доступно также и при работе с Internet Explorer, там прога вызывается также через меню.

А скачать это чудо-творение можно по адресу http://www.baxbex.com/files/folderbox.exe.

Dirkey 1.0

Разработчик: Dirk T. Manders
Статус:freeware
Интерфейс: английский
ОС: Win 9x/Me/NT/2000/XP
Размер: 104Kб

"Малыш":-) Dirkey чем-то напоминает предыдущую прогу FolderBox, вот только «обязанности» у него несколько другие. Работает программа совместно с "Проводником" и служит для быстрого доступа к заранее выбранным папкам. С ее помощью можно активировать доступ аж к 9 необходимым папкам! Для доступа к выбранной папке используется сочетание клавиш Ctrl+1...9. Основные возможности программы:
автоматическая активация при загрузке системы;
вызов главного окна через иконку в трее;
генерирование звуковых сигналов при ошибках;
использование как стандартного ряда цифр, так и цифровой части клавиатуры при доступа к папкам;
поддержка консоли и командной строки в 32-битном режиме.

К недостаткам следует отнести:
невозможность установки ссылки на URL или файл - только папки;
невозможность работы в окнах Открытие файла/Сохранение файла в Office 97/2000/XP;
невозможность настройки доступа к папкам через Explorer (при нажатии Ctrl+0) при работе под Windows 9x/Me.

Однако, несмотря на небольшие ограничения, как для своего маленького размера (104Кб) Dirkey довольно функциональна и подойдет большинству пользователей, активно работающих с папками. Она позволит не тратить время, разгребая дерево каталогов в надежде выйти к нужной папке:-), а сделать это одним нажатием клавиши на клавиатуре.

Скачать Dirkey можно с http://www.protonfx.com/download/DIRKEY10.EXE.

И в завершение небольшой бонус - программа Print Pilot 1.0. Данная софтина послужит прекрасным инструментом для всех пользователей, которым в срочном порядке необходимо распечатать графические изображения, а перед ними - "голая" Windows. И даже, невзирая на то, что программа представлена читателю в виде бонуса, она все же имеет прямое отношение в нашей теме - Print Pilot позволяет увеличит возможности "Проводника", поскольку работает непосредственно с ним в режиме drag-and-drop. Итак, характеристики ее следующие: shareware, Win 9x/Me/2000, русскоязычный интерфейс, размер - 976Kб, разработчик - Invention Pilot (http://www.colorprint.ru).

Основные возможности программы:

поддержка графических форматов файлов bmp, jpj, ico, wmf, pcx, png, tif;
вставка графики, масштабирование, работа с несколькими изображениями на листе и создание подписей под каждой картинкой;
вставка изображений из буфера обмена в двух форматах: растровом и векторном;
оперирование несколькими рабочими листами сразу.

Print Pilot позволяет создавать небольшие макеты из изображений и текста, превращаясь по сути в небольшую домашнюю печатную студию.

Наличие русского интерфейса только способствует более удобной работе с программой, скачать которую можно с http://www.colorprint.ru/load/print.exe.

Вот, дорогие юзеры мои, и все. Бегите проги качайте, свои меню расширяйте :-). Как, не можете определиться? Выбор за вами - меню подано!

Источник: http://www.mycomp.com.ua/


C винчестером надо бы поосторожнее

Вы когда-нибудь задумывались, что на компьютере самое ценное? Процессор, монитор, память? Да, это дорогостоящие компоненты, но порой не самые важные для пользователя. Самое главное - это информация, а значит на первое место выходит проблема надежного ее хранения.

Суть проблемы

Современный винчестер - сложное электронно-механическое устройство. Громадная емкость, высочайшая скорость работы привода, сложнейшие методы записи и считывания данных... Распространяться обо всем этом, наверное, не стоит. Даже школьник представляет, как это устройство работает и насколько оно сложно. Правда, не всегда пользователи, как, впрочем и сборщики компьютеров, до конца отдают себе отчет в том, насколько точная механика используется в современных винчестерах и как она уязвима.

Поэтому, оставив в стороне электронику, давайте поговорим только о механике. Из физических воздействий в основном угрозу для нее представляют удары. Они характеризуются, во-первых, ударной нагрузкой, которую принято измерять в величинах ускорения свободного падения g. Говорят, например, что сила удара составила 100g. Во-вторых, ударные воздействия бывают разной продолжительности. Кроме того, ударные нагрузки, испытываемые винчестерами, бывают повторяющимися (вибрация) и однократными.

Во время работы на винчестер чаще всего воздействует вибрация, характеризующаяся не самыми большими ускорениями и продолжительностью воздействия. От нее современные диски более или менее защищены. Помогает и сам принцип парения головок над поверхностью пластины. Возможны, конечно, и толчки, и удары по корпусу компьютера, но, как оказалось, есть и другие, не менее опасные, неприятности.

Оказывается, можно причинить непоправимый вред еще при распаковке винчестера или его установке. Серьезные ударные нагрузки винчестер испытывает при падениях с очень малой высоты на сборочный стол или в упаковочную тару. Его часто ударяют о другой винчестер или о направляющие корпуса при монтаже. Даже столкновение с отверткой переносится им не так уж легко. Эти воздействия характеризуются небольшой продолжительностью и и довольно высоким ускорением. Но одной из самых серьезных опасностей, подстерегающих жесткий диск на пути от производителя к пользователю, - это ужасные условия транспортировки. Будь то выбоина на дороге или неаккуратные действия при разгрузке - диску может быть нанесен непоправимый вред.

Оставаясь совершенно невредимым внешне, винчестер может оказаться серьезно поврежденным внутри. И если он после сборки компьютера работает как будто нормально, это еще ни о чем не говорит

Что происходит

В нерабочем состоянии головки винчестера лежат на его дисках в специально отведенной зоне, запись данных в которую не производится. Что такое парковка головок, вы, конечно, в курсе. Но знаете ли вы, что она далеко не всегда защищает накопитель от повреждений при неосторожном обращении? Даже когда головки запакованы, возможно повреждение винчестера из-за явления, которое получило название "шлепок головки" (head slap).

При случайном ударе пластины винчестера приходят в движение, и мирно лежавшие в зоне парковки головки, снабженные гибкой аэродинамической подвеской, отрываются от поверхности дисков. Затем все возвращается в исходное состояние, но головки "шлепаются" на пластины. Разумеется, ударные нагрузки, о которых сейчас идет речь, и близко не сравнимы с ударом кувалдой. Все описанное происходит на микроскопическом уровне. Однако от поверхности пластин при этом отделяются столь же микроскопические частицы, которые впоследствии и становятся причиной выхода винчестера из строя или его ненадежной работы.

Аэродинамический зазор между головками и пластинами при работе чрезвычайно мал, и существует тенденция к его сокращению, что связано с ростом поверхностной плотности записи. Даже самые мелкие частички магнитного слоя, находящиеся внутри корпуса накопителя, способны физически повредить головки или поверхность пластин. Сталкиваясь при вращении с магнитной головкой, частички вызывают новый шлепок, вследствие чего их количество увеличивается.

И это не единственная беда. Сегодня во всех винчестерах применяются магниторезистивные головки и каналы чтения PRML. При прохождении над намагниченными участками пластин в таких головках под воздействием меняющегося магнитного поля происходит изменение сопротивления тончайшего пленочного покрытия, фиксируемое электроникой привода. На сопротивление не меньшее влияние оказывает и температура этого покрытия.

При столкновении с отколовшимися при шлепке частичками головка мгновенно нагревается, и электроника получает искаженный сигнал. Происходит ошибка чтения. Ее, конечно, удается исправить при последующем обращении, но с точки зрения надежности это, согласитесь, недопустимо. И ведь со временем частиц становится все больше - опасность нарастает в геометрической прогрессии. Понятно, чем это может кончиться?

Вот и получается, что не один пользователь несет ответственность за надежность хранения информации, даже если получил от продавца работающий компьютер.

Как с этим бороться

Первое, что приходит в голову, - застращать персонал, отправить его на курсы, выдать всем резиновые отвертки... Это, конечно, наш метод, но проблема существует и в других странах. Компания Quantum всерьёз занялась ее решением. Хотя она всегда ориентировалась в основном на крупных производителей компьютеров,тем не менее, порядка трети выпускаемых ею винчестеров устанавливаются мелкими сборщиками или вообще самими пользователями.Если у крупных производителей условия для сборки близки к идеальным, то у остальных дела обстоят отнюдь не блестяще. В наших условиях, конечно, и того хуже.

В общем, Quantum забеспокоилась. Проведенные исследования показали то, о чём говорилось выше. Определив проблему, компания взялась за разработку решения, которое позволило бы избежать катастрофических последствий даже при не слишком тщательном соблюдении рекомендаций по распаковке и установке винчестеров.

И такое решение было найдено. Причём оно оказалось очень эффективным с точки зрения цены и не привело к подорожанию накопителей. В новых винчестерах Quantum применена система защиты от ударов - Shock Protection System (SPS). Этой системой оснащены, в частности, массовые АТА - винчестеры серий Fireball EL и Fireball EX, а также все SCSI-накопители последних серий, такие, например, как Viking11, Atlas 111, Atlas 10K и Atlas 1Y.

Исследования позволили детально разобраться с тем, как ведут себя при ударе все механические компоненты винчестера. Благодаря полученным сведениям удалось оптимизировать механику таким образом, что бы ударная нагрузка максимально эффективно поглощалась всем корпусом и от неё не страдали наиболее чувствительные детали.

В частности. SPS практически полностью устраняет шлепок головок. Quantum разработала подвеску, не позволяющую головкам оторваться от поверхности пластин, после чего, собственно, и следует шлепок. Когда установлена SPS, удар эффективно гасится всей механикой винчестера, и головки остаются неподвижными отноистельно магнитного слоя пластин. Микроскопические частицы не отскакивают от поверхности, угроза надежной работе накопителя отсутствует

Современный рынок жестких дисков находится в состоянии войны. По мнению Qаuntum, защита винчестеров от ударов стала серьезным конкурентным преимуществом перед другими производителями.

Алексей Кириллов


Мусор в Windows

Сергей Трошин, stnvidnoye@chat.ru, http://stnvidnoye.chat.ru

Если у вас есть проблемы со свободным пространством на винчестере, вы можете смело почикать кучу лишних файлов. Для этого, во-первых, найдите на диске текстовые файлы с расширениями .txt, .doc, .nfo, файлы типа ReadMe.1st, Files_id.diz и просмотрите их содержание на предмет полезности вам лично. Если эти файлы всего лишь лицензии на программы, или прочая бредятина, нужная только авторам программы, тащите их в корзину. Туда же отправьте файлы с расширениями .old, .---, .bak, .tmp, ._mp, .syd, .chk, .dos (возможных расширений для временных файлов довольно много: .000, .001, .002, .B~K, .BMK, .DA1, .DAT, .FTG, .FTS, .INK, .LHX, .OUT, .PAR, .PRV, .$$$, .SYK, но с некоторыми из этих расширений могут быть и нужные файлы (например .DAT часто не является лишним!), поэтому удалять их надо осторожно), временные файлы MSCREATE.DIR и директории ~MSSETUP.TMP. Правда, файлы AUTOEXEC.DOS, CONFIG.DOS и т.п. могут пригодиться, если вы захотите удалить Windows и вернуться к MS-DOS, а также, файлы с расширением .dos из корневой директории системного диска используются, когда в загрузочном меню (вызывается кнопкой F8 при загрузке) выбирается пункт "Загрузить предыдущую версию DOS", но вряд ли вы ей когда-нибудь воспользуетесь. Смело трите файлы из корневой директории системного диска System.1st, BootLog.txt, Suhdlog.dat, SetupLog.txt, - все это, в основном, старые и ненужные сохраненные системные файлы и протоколы загрузки или установки системы. В идеале остаются только AUTOEXEC.BAT, CONFIG.SYS, IO.SYS COMMAND.COM, MSDOS.SYS (установите им атрибуты "скрытый", и в окне эксплорера они не будут мозолить вам глаза) и файлы, нужные некоторым программам (Norton SpeedDisk, например, всегда создает файл в корне диска SD.INI, его надо оставить, плюс ко всему NU архивируют системные файлы с расширением типа .nu, .nud или .nu4, если вы их где найдете - сносите). Найдите файлы с расширением .gid - это файлы помощи, они автоматически появляются, когда вы обращаетесь к этой самой помощи в какой-нибудь программе. Больше всего их в папке C:\Windows\Help, они скрытые, поэтому поставьте в меню Folder Options (Свойства Папки) функцию отображения всех файлов, или используйте Norton Commander. А если вы никогда и нигде не нажимаете кнопку "HELP" то снесите к едрене фене весь каталог C:\Windows\Help (мегабайт 13 примерно). Но учтите, что некоторые прграммы отказываются работать без файлов помощи - эти файлы придется вернуть на место. Просмотрите содержимое файлов .log, .ini - некоторые из них также можно удалить (например, WS_FTP.LOG), но будьте осторожны, это надо делать с умом. Файлы .ini надо удалять, только если они пустые или относятся к программам, которые уже не стоят на вашем компьютере. А некоторые файлы типа .log необходимы для корректного удаления программ, их также надо оставить.

Во-вторых, удалите все файлы из папок C:\Windows\Sysbckup (кроме rb000.cab, rb001.cab и т. д.) и C:\Windows\Inf\Infback- это старые системные файлы, которые MustDie сохранил просто на всякий случай (Некоторые инсталляторы программ, особенно служебного характера, любят записывать туда заменяемые ими библиотеки. При дальнейшей деинсталляции они используют этот архив для обратной перезаписи. Если обратной замены на родной виндовый файл не будет - могут быть глюки! Желательно проверять версии установленных файлов с помощью System File Checker после инсталляции каждой новой программы, чтобы вовремя заметить подмену системного файла более старой версией). Можно также сократить количество файлов rb00х.cab (в них Винды сохраняют при запуске самые главные системные файлы), изменив строку в файле C:\Windows\Scanreg.ini "MaxBackupCopies=5" -поставьте вместо 5,например 3 и экономия места составит почти 3 мегабайта. Можно почистить папку C:\Windows\Applogот файлов, относящихся к потертым программам, папку C:\Windows\Cursors от неиспользуемых курсоров, а C:\Windows\Media -от ненужных звуков (нужные звуки конвертируйте в формат MP3 с помощью программки mp3.Producer, и они уменьшатся раз в десять, правда, нужно чтобы был установлен формат МР3 в списке аудио кодеков меню "Свойства Мультимедиа"). Тащите в корзину папку C:\Windows\Oobe, нужную только при наличии выхода в Microsoft Network. Поищите в папке Program Files пустые папки типа ...\Chat, ...\Hyper Terminal (даже если вы не ставили себе эти программы, винды все равно создают эти папки), их тоже чикаем. Там же можно снести папки ...\Uninstall Information, (Она содержит файлы данных для корректного удаления Internet Explorer5, чем вы вряд ли воспользутесь). ...\Online Services, ..\Common Files\Stationery (эти Stationery используются программой Outlook Express для создания фона писем).

В-третьих, можно удалить из директории C:\Windows\System ненужные экранные заставки (расширение .scr), а из C:\Windows\ -лишние образцы фона для рабочего стола (расширение .bmp).

И, наконец, очистите папки временных файлов C:\WINDOWS\TEMP, C:\TEMP, переместите временные интернет-файлы, используя меню Internet Options, на диск, где больше места. С помощью Internet Tweak 2000 можно переместить на свободный диск и другие интернетовские папки. Очистите меню History (для Win'95 можно удалить старые письма в папке C:\Windows\Application\Microsoft\Outlook Express\Mail\ - расширения .idx, .mbx и старые новости в C:\Windows\Application\Microsoft\Outlook Express\News - расширение .nch, для Win'98 - лучше сделать это через опции Outlook Express, в Win'98 старые письма хранятся в папке C:\WINDOWS\Application Data\Identities\{D1D4B7C0-572D-11D3-BF3B-A26182F20266}\Microsoft\Outlook Express, можно очистить папку C:\Windows\Cookies\, если не хотите использовать эти самые Cookies). Теперь вас гораздо реже будет раздражать приглашение очистить диск программы Disc Cleanup, если вы не запретили это приглашение в опциях программы (кстати, эта программа создает файл C:\ProgramFiles\Plus!\Cleanup\files.dtb размером больше мегабайта, который тоже можно смело чикать). Программы WinBoost 2000 и Tweak UI настраивают винды на автоматическую очистку многих меню и папок при выключении компьютера. Можно поэкспериментировать и с другими утилитами очистки дисков, таких предостаточно.

В Windows Me можно без последствий удалить файлы дистрибутива из папки С:\WINDOWS\OPTIONS\INSTALL - в этом случае система просто будет требовать компакт диск при некоторых изменениях конфигурации. Далее, удалите папку C:\PROGRAM FILES\ONLINE SERVICES - эти службы не для России. Удаляйте бесполезный рекламный "мультик" в C:\WINDOWS\APPLICATION DATA\MICROSOFT\INTRO\ и файлы, необходимые для подключения к Microsoft Network в C:\WINDOWS\SYSTEM\OOBE. Очистите папку C:\WINDOWS\SYSBCKUP от зарезервированных системных файлов. Естественно, всевозможные клипы, звуки и т.п. Отведите меньше места под хранение временных файлов службы System Restore.

Если системная папка уже капитально засорена, и нет информации о том, какие файлы остались от удаленных программ то придется поискать неиспользуемые .DLL - файлы с помощью утилиты Clean System Directory. Она переместит все неиспользуемые системные файлы в специальную папку, после чего вам придется некоторое время тестировать систему, так как среди перемещенных могут оказаться и необходимые файлы, их придется вернуть в директорию C:\WINDOWS\SYSTEM.

Очень часто программы, которые вы удалили оставляют после себя в папке C:\WINDOWS файлы типа IsUn0411.exe, IsUn0419.exe или Unistb32.exe, короче анинсталлеры со значком, обычно в виде мусорного ведра и частичкой слова Uninstall в названии екзешника, предназначенные именно для этого самого их удаления, и не попадающие сами, почему-то в корзину вместе с породившей их программой. Ссылки на эти анинсталлеры находятся в реестре в разделе HKEY_LOCAL_MACHINE \Software\Microsoft\Windows\CurrentVersion\Uninstall. Можно попробовать осторожно удалить те из них, которые вы не обнаружите в этом разделе, проверить систему WinDoctor' ом, и если он не покажет ошибок, то вытряхнуть корзину.

В папку C:\WINDOWS\amc и в C:\WINDOWS\amcdl всякие дурные шароварные программы, которые закачивают баннеры, помещают всю эту рекламную дрянь, поэтому регулярно очищайте эти папки.

System File Cheker помещает резервные копии файлов в папку C:\WINDOWS\Helpdesk\SFC, не забывайте и ее регулярно чистить.

В папке C:\WINDOWS\ShellNew содержатся непонятного предназначения образцы документов, которые можно попробовать удалить (она содержит шаблоны оффисовских документов, создаваемых как новые в контекстном меню, причем даже если у вас не стоит Офис эти шаблоны присутствуют в папке).

И главное! Если вы не уверены, что можно что-то удалить, попробуйте, сначала, просто перенести это на другой диск, проверьте систему WinDoctor'ом, поработайте недельку, только потом удаляйте.

Если, несмотря на все ухищрения, винды постоянно переполняют диск файлом подкачки, то можно добавить в раздел [386Enh] файла System.ini параметр MinUserDiskSpace=количество_килобайт, который ограничит разрастание свап-файла.

P.S. Если у вас винчестер разбит на несколько разделов, очень рекомендую инсталлировать все программы не в папку C:\Program Files, как это хочет делать MustDie, а на другой диск, например, в D:\Program Files, иначе диск C:, где обычно находится саморазрастающаяся папка C:\Windows, очень скоро переполнится.


Легкая пластическая XP-рургия

Сергей Трошин

Любят пользователи персональных компьютеров всяческие аудиовизуальные примочки - эротические обои для Рабочего стола с какой-нибудь пластмассово-силиконовой Памелой Андерсон, озвучивание системных событий крылатыми фразами из фильма "Иван Васильевич меняет профессию", курсоры и иконки из любимого мультика для взрослых "Симпсоны".

Юморной народ даже придумал заменить финальную заставку Windows на "Теперь вы можете выбросить свой компьютер". А уж если вы работаете сисадмином, то все секретарши и бухгалтерши за скринсейвер с трехмерным виртуальным аквариумом тут же отдадут вам и душу и тело (если сможете унести, конечно). Не знаю, с чем это связано - возможно, человеку быстро надоедает однообразие серого интерфейса операционной системы, и он хочет каких-то ярких красок, чтобы было на чем задержать взгляд.

Возможно, это просто попытка проявить свою индивидуальность, сродни кольцу в носу или ирокезу на макушке подростка, не умеющего обратить на себя внимание окружающих другим способом. А может, людям на работе просто делать нечего, ведь тот, кто компьютером действительно зарабатывает себе на жизнь, довольно быстро перестает обращать внимание на всю эту мишуру (которую за окнами прикладных программ и не видно) и больше беспокоится о производительности своей машины, на коей негативно сказывается даже применение красочных обоев, не говоря уж о всем известных программах типа Talisman или Window Blinds.

Но все, что до сих пор было возможно в плане перелицовки интерфейса Windows, по большому счету, было детскими игрушками. Сама Windows не давала особенно разгуляться фантазии, а программы, круто меняющие внешний вид окошек и десктопа, либо безбожно глючили, либо "прихватизировали" большую часть системных ресурсов, либо и то и другое одновременно.

Это, кстати, давало серьезный аргумент поклонникам Linux с его многочисленными интерфейсами в абсолютно бестолковом и некорректном споре "что лучше - Windows или Linux". Так было до дня "икс", вернее - дня "XP", 25 октября 2001 года, когда официально увидела свет новая операционная система - Windows XP, имеющая встроенную поддержку сменных "шкурок".

С выходом новой ОС у всех пользователей, рискнувших на нее перейти, появилась возможность не только менять цветовую гамму интерфейса, но и перерисовывать по своему вкусу практически любой элемент GUI - начиная от внешнего вида кнопки Start и заканчивая скромным "чекбоксом".

Но самое главное, что вся эта благодать осуществляется на уровне операционной системы, а не какими-то приблудными программами, поэтому и системных ресурсов на подобный макияж Windows тратится самый минимум, и глюки, по идее, не должны превышать обычного для "маздая" уровня. И все бы было замечательно, если б в дистрибутив системы или, что более логично, в дополнительный пакет MS Plus! XP были бы включено хотя бы с полдюжины неординарных "скинов", но, к величайшему разочарованию, создатели Windows об этом почему-то не позаботились.

Максимум, чем можно насладиться после инсталляции ОС, - это два типа интерфейса: классический и в стиле XP. Конечно, когда Windows XP победным маршем в полный рост зашагает по свету, то и темы для нее расплодятся на просторах интернета, как поганки под Чернобылем, но уже сегодня имеется неплохой задел, позволяющий издеваться не только над расцветкой "форточек", но и полностью менять некоторые другие элементы интерфейса - об этом я и постараюсь рассказать.

Начальная заставка

Начнем мы издалека, с изменения стартовой картинки. Это, конечно, никоим образом не касается новых возможностей Windows XP по управлению интерфейсом, но для многих будет очень интересно. Учтите только, что все это - недокументированные и несанкционированные трюки с довольно глубоким вторжением в системные файлы, а потому гарантий, что после ваших экспериментов Windows будет работать так же хорошо, как и раньше (ха-ха!) никто не даст, а потому заранее позаботьтесь о путях отхода - резервируйте все и вся.

Заставка эта "зашита" в одном из главных системных файлов - Windows\System32\ntoskrnl.exe и без специальных утилит изменить ее невозможно. А потому первым делом качаем из интернета программку Resource Hacker (rpi.net.au/~ajohnson/resourcehacker) - это одна из самых простых в употреблении утилит редактирования ресурсов выполнимых файлов, к тому же бесплатная.

Те, кто уже знаком с подобными "хакерами", могут воспользоваться, например, своим любимым "шароварным" Restorator. Вторая программа, которая нам будет непременно нужна - графический редактор, но не простой "виндовый" Paint, который нам не подойдет ввиду отсутствия у него некоторых функций, а продвинутый - Adobe Photoshop или гораздо более доступный Jasc Paint Shop Pro (www.jasc.com).

Для начала сделаем резервную копию файла ntoskrnl.exe и еще одну копию, которую, собственно, и будем редактировать. Запускаем Resource Hacker и открываем этот последний файл - удобнее всего будет, если вы поместите его в папку самого Resource Hacker. В левой части интерфейса "хакера" видим дерево ресурсов, и в первой его ветви "Bitmap" - 12 картинок.

Сочетание изображений с номерами 1, 8 и 10 складывается в заставку версии XP Pro, а 1, 7 и 9 - варианта Home Edition. Мы будем работать с профессиональной Windows. Выбираем номер 1 - это и есть сама заставка, остальные картинки - лишь ее сопутствующие элементы. Но она гораздо больше напоминает "Черный квадрат" Малевича, а не "виндовый" логотип, - скажете вы!

Терпение, сейчас все станет ясно. В меню "Action" нашего "хакера" выбираем команду "Save Bitmap" и указываем для "выдранного" из ntoskrnl.exe bmp-файла удобную директорию, назвав его так же, как он обозначен и в самом ntoskrnl.exe, то есть 1.bmp, чтобы не запутаться. Повторяем такую же процедуру с картинками 8 и 10.

Теперь нам нужно их отредактировать в Paint Shop Pro - рассматриваем эту программу, поскольку она немного попроще. Когда вы откроете в нем эти изображения, то увидите только сплошную черноту - для того чтобы "проявился" настоящий логотип, нужно загрузить из интернета специальные палитры. Для Paint Shop Pro это файл www.thetechguide.com/howto/xpbootlogo/16.pal, а для Adobe Photoshop - www.thetechguide.com/howto/xpbootlogo/16.act. После этого в Paint Shop нажимаем клавиши Shift+O и выбираем в появившемся окне файл 16.pal - опция Maintain Indexes в этом диалоге ОБЯЗАТЕЛЬНО должна быть включена.

Теперь мы наконец-то видим вместо черноты привычный логотип Windows XP, редактируем и изменяем его и остальные изображения как вашей душе угодно, главное - соблюсти изначальные размеры этих картинок и работать с заданной палитрой.

После сохранения переделанных картинок снова переключаемся в Resource Hacker и в меню "Action" выбираем команду "Replace Bitmap" - в новом диалоге указываем, какой ресурс следует заменить и чем. То есть в диалоге замены изображения выделяем bitmap-ресурс номер 1, щелкаем кнопку "Open file with new bitmap" и указываем путь к измененному логотипу, после чего давим кнопку "Replace".

То же самое делаем для картинок 8 и 10 и не забываем в меню "хакера" сохранить все изменения (File->Save). Осталось заменить "родной" ntoskrnl.exe на "хакнутый". Из-под Windows сделать это не удастся - нужно загрузить другую ОС, если Windows XP установлена на диске FAT32. Если же вас угораздило выбрать файловую систему NTFS, то доступ к диску из DOS или Windows 9x становится невозможным без применения специальных программ, поэтому оптимальным будет не искать их по всей Сети, а заменить файл таким образом:

1. Перегрузить ПК.
2. Во время загрузки держать нажатой кнопку F8 для входа в загрузочное меню Windows XP.
3. Выбрать режим командной строки (Command Prompt).
4. Снова нажать F8.
5. Войти в систему под именем Администратора.
6. Так же, как в MS-DOS, перейти в папку с измененным файлом (лучше всего, если вы его поместите в корень системного диска) и ввести команду "copy ntoskrnl.exe c:\windows\system32\".
7. Вновь перегрузить ПК. Вот теперь можно "тащиться" от собственноручно нарисованного логотипа.

Есть правда, более элегантный и грамотный способ замены логотипа, вплоть до ручной или автоматической смены нескольких различных заставок, с полным сохранением оригинала ntoskrnl.exe. Для того чтобы им воспользоваться, сделайте несколько "хакнутых" файлов ntoskrnl.exe с разными логотипами, добавляя к названию каждого файла порядковый номер, например: logo1.exe, logo2.exe, logo3.exe и так далее.

Обратите только внимание, что название файлов должно соответствовать стандарту 8.3 (8 букв - название и 3 - расширение). В корне системного диска найдите скрытый файл boot.ini и откройте его в Блокноте. Если у вас две ОС, то вы увидите примерно такие строки:
[boot loader]
timeout=5
default=C:\
[operating systems]
C:\="Windows Millennium Edition"
multi(0)disk(0)rdisk(0)partition(2)\WINNT=
"Windows XP Professional" /fastdetect
Допишите после последней строки:
multi(0)disk(0)rdisk(0)partition(2)\WINNT=
"Windows XP Professional 1" /fastdetect /kernel=
logo1.exe
multi(0)disk(0)rdisk(0)partition(2)\WINNT=
"Windows XP Professional 2" /fastdetect /kernel=
logo2.exe
multi(0)disk(0)rdisk(0)partition(2)\WINNT=
"Windows XP Professional 3" /fastdetect /kernel=
logo3.exe

Теперь нужную заставку можно будет выбирать прямо в расширившемся загрузочном меню, по соответствующему номеру. А если вы вместо номеров проставите названия, соответствующие темам заставок, то их выбор еще более облегчится.

При этом сохранится возможность загрузки и нетронутого рукой мастера ntoskrnl.exe. Автоматизировать же выбор заставок, вернее, изменение файла boot.ini, поможет небольшая утилита LWD Kernel Selector, которую можно взять по адресу www.littlewhitedog.com/.../lwdkernel.zip. Для случайной смены заставок достаточно поместить в папку Windows\System32 побольше пронумерованных "хакнутых" файлов ntoskrnl.exe, саму программу LWDKernel.exe и закинуть в автозагрузку ярлык на запуск LWDKernel.exe с ключом "-random". Правда, программа эта сыровата и в случае с мультизагрузочными системами редактирует файл boot.ini неверно, так что не забывайте о резервировании.

Экран входа в систему

Сразу после начальной заставки пользователя встречает экран регистрации - Welcome Screen. Если за компьютером работает несколько человек, то именно здесь нужно выбрать свою учетную запись и ввести пароль. Если же пользователь один, то операционная система лишь поприветствует его и регистрация произойдет автоматически.

Кстати, если вам очень хочется, чтобы помимо учетной записи пользователя предлагалось еще войти в систему и под именем Администратора, то просто добавьте в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
CurrentVersion\Winlogon\SpecialAccounts\UserList параметр "Administrator"=dword:00000001, и на экране появится еще одно поле - "Administrator". Но лучше не нарушать приятный дизайн этого диалога, а "логиниться" админом, вызвав обычный диалог входа в Windows.

Для этого, когда появится Welcome Screen, просто дважды нажмите клавиши Ctrl+Alt+Del - появится старое доброе окно для ввода имени и пароля пользователя.Но мы отвлеклись от главного - как перерисовать Welcome Screen? А перерисовать его тоже не очень просто и даже сложнее, чем начальную заставку, поскольку и он хитрым образом закодирован внутри одного из системных файлов, а именно - Windows\System32\logonui.exe.

Tехнология его изменения такова. Опять копируем файл в две разных папочки - в одной сохраняем его исходный вариант, чтобы без проблем вернуть на место в случае неудачи, а в другой оставляем файл, который и будем препарировать. Берем уже известную программу Resource Hacker и открываем в нем подготовленный к экзекуции logonui.exe. Да! совсем забыл!

Прежде чем приступать к операции, надо представить, что же вы хотите получить, а еще лучше - сделать скриншот этого диалога и изменить его в каком-нибудь графическом редакторе так, как вы задумали. Учтите только, что для начала никаких серьезных переделок не стоит планировать - общая структура картинки должна сохраниться. А это - широкая полоса сверху, отделенная от основного фона узкой разноцветной ленточкой и такая же полоса с ленточкой снизу, плюс картинка в верхнем левом углу экрана - в исходном варианте это что-то типа слабой засветки.

Именно эти элементы мы и попробуем изменить. Потом, когда вы досконально разберетесь, как все это закодировано в logonui.exe, сможете уже более заметно отойти от первоначального шаблона, в том числе изменить стандартные надписи в диалоге регистрации пользователя и выключения компьютера - найдете их в ветви "String Table" программы Resource Hacker. Итак, в Resource Hacker открываем ветвь \UIFILE\1000\1033 (последняя цифра может отличаться) и в правой части окна программы двигаем полосу прокрутки вниз до тех пор, пока вместо белого поля не появятся первые строки кода:
<style resid=framess>
element
{
background: argb(0,0,0,0);
}
element [id=atom(contentcontainer)]
{
background: rgb(90,126,220);
и так далее.

Последняя строка - это как раз цвет основного фона нашей картинки, выраженный в виде RGB (то есть тремя цифровыми индексами - красного, зеленого и синего цветов). Откройте "виндовый" редактор Paint и в меню Colors>Edit Colors>Define Custom Colors введите эти значения в соответствующие поля "Red", "Green" и "Blue" - получите тот самый голубой цвет, который наблюдаете при каждой загрузке ОС.

Теперь откройте в Paint подготовленную заранее картинку-черновик и определите новые значения RGB, используя элемент управления "пипетка", - они отобразятся в окне "Define Custom Colors" - или определите их вручную, двигая курсор по цветовой карте. Теперь, когда мы знаем RGB-значения нового цвета основного фона, вводим их вместо старых, например, "background: rgb(23, 16, 24)" для темно-серого цвета.
Следуем дальше - ищем строки
element [id=atom(toppanel)]
{
background: rgb(0,48,156);
То, что это описание вида верхней темно-синей полосы можно догадаться по фразе "[id=atom(toppanel)]". Меняем ее цвет - вместо "background: rgb(0,48,156)" вводим новые значения. Еще чуть ниже видим параметры нижней панели:
element [id=atom(bottompanel)]
{
background: gradient(argb(0,57,52,173),
argb (0,0,48,156), 0);

Для нее задан не просто равномерный цвет, а небольшой градиент, то есть плавное изменение гаммы от одного края к другому - пары экспериментов будет достаточно, чтобы подобрать оптимально соответствующее замыслу сочетание этих двух цветов.

Просмотрев весь код, думаю, вы найдете описания и других элементов диалога регистрации пользователя, мы же пока на этом остановимся и перейдем к редактированию картинки, отображаемой в его углу, попутно позволяя программе сохранить внесенные нами изменения.

Раскроем теперь ветвь Bitmap\100\1033 - увидим тот самый мутно-голубой блик света, который, если присмотреться, можно заметить в левом верхнем углу заставки. Для того чтобы его заменить на другое изображение, нужно, чтобы оно было в формате BMP. В меню "Action" Resource Hacker выбираем команду "Replace Bitmap", в появившемся диалоге вновь находим ресурс за номером 100 и указываем путь к файлу с картинкой, которая его заменит, - проще пареной репы. Осталось еще только указать размеры новой картинки, чтобы при ее отображении не было никаких искажений. Для этого опять возвращаемся в ветвь \UIFILE\1000\1033 и, нажав клавиши Ctrl+F, находим строку, начинающуюся с <element id=atom(contentcontainer). Ее надо изменить следующим образом:
<element id=atom(contentcontainer) layout
=flowlayout(1,3,2,3) layoutpos=client сontent=
rcbmp(100,0,0,XXXrp,YYYrp,1,0)>, где XXX и YYY - новые значения длины и ширины картинки (узнать их можно из свойств bmp-файла). Желательно, чтобы картинка не заползала на ту область, где размещены кнопки с именами зарегистрированных в системе пользователей, иначе будут наблюдаться неприятные эффекты при отображении нашего диалога.

Вот, все и готово, осталось только заменить исходный файл logonui.exe на тот, что мы получили после нашего получасового эксперимента. Проще всего это сделать из-под другой операционной системы, либо из режима защиты от сбоев, поскольку служба защиты системных файлов Windows XP не позволит этого, пока мы работаем в этой ОС. Предусмотрен и другой, более легитимный способ смены заставки - внесение в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
\Windows NT\CurrentVersion\Winlogon параметра "UIHost", значением которого является путь к альтернативному файлу logonui.exe.

При этом исходный "виндовый" logonui.exe остается на своем законном месте в неприкосновенности и возврат к нему осуществляется простым удалением параметра "UIHost". Преимущество такого подхода - в отсутствии необходимости замены системного файла из-под другой ОС.

Если же весь процесс редактирования заставки показался вам не столько увлекательным, сколько чересчур сложным и нудным, то можете воспользоваться уже готовыми чужими дизайнерскими опытами, если посетите, например, сайты boomgames.com/xpthemes/browse.php?type=logon, home.wanadoo.nl/web.wacker/index2.htm, www.digital-assassin.com/~xp/, www.lakerscenter.com/xp/, www.themexp.org/view.php?type=login, на которых уже собрано немало неплохих заставок. Думаю, на первых порах они окажутся куда лучше нашей с вами самодеятельности.

Недостаток же применения скачанных из интернета logonui.exe один - отсутствие уникальности. Используя то, что выложено на всеобщее обозрение вы, естественно, всегда будете знать, что точно так же выглядит Windows и у тысяч других пользователей. Да и нет гарантии, что какой-то недоброжелатель не прикрепил к файлу хитрый троянский вирус.

Хотя, благодаря огромному числу уже готового материала заставку можно менять хоть каждый день. Утилиты для визуального редактирования экрана регистрации, насколько мне известно, пока не существует, а вот программка, которая предельно упрощает управление этими заставками и их смену, есть - XP Logon UI (xplogonui.stormpages.com).

С ее помощью вы не только сможете оперативно переключаться между разными заставками, но и просматривать их прямо в окне программы, что очень удобно. Нужно только в директории D:\WINNT\Resources создать папку Logonui, а внутри ее - собственные подпапки для каждого logonui.exe - XP Logon UI сама внесет нужные данные в реестр, и при следующей перезагрузке вас будет радовать новая необычная картинка.

Стили интерфейса

А как же знаменитые стили Windows XP? Как сделать, чтобы "Форточки" сияли всеми цветами радуги? А очень просто - взять уже готовые на сайтах boomgames.com/xpthemes/browse.php?type=theme, www.themexp.org/view.php?type=vs - там этого добра как собак нерезаных. Новая оболочка устанавливается несложно.

Качается ZIP-архив с файлами темы, файлы распаковываются в папку D:\WINNT\Resources\Themes, запускается диалог "Display Properties", и на вкладке "Themes" устанавливается только что полученный свежий и, соответственно, пока еще не опостылевший макияж Windows. Иногда нужно еще вручную выставить нужный стиль на вкладке "Appearance" того же диалога свойств дисплея. Выбор тем в интернете более чем богатый.

Что, тоже хочется все сделать самостоятельно, чтобы ни у кого и никогда не было ничего похожего? Тогда разбирайтесь с мощнейшей программой StyleBuilder (www.tgtsoft.com) - она предназначена как раз для создания своих собственных уникальных стилей.

Правда, вас ждет серьезное потрясение, когда вы увидите, как много элементов интерфейса позволяет полностью перерисовывать эта утилита. Любой шрифт, любой цвет, любая форма любого элемента, начиная от окон и заканчивая меню Start. Например, с ее помощью легко изменить цвет и размер шрифта, которым выводятся часики в системной области Панели задач или вид кнопки выключения компьютера в меню Start. Так что, программа эта для настоящих дизайнеров-фанатиков.

Есть и еще одна интересная утилита, которая напрямую предназначена для работы с "фейсом" Windows - Window Blinds XP (www.windowblinds.net). Применительно к этой ОС очередная вариация популярной Window Blinds оказывается вполне приемлемым решением и не стоит бояться, что она вместе с ОС потребует для нормальной работы процессор гигагерц на десять.

Дело в том, что технологии Windows Blinds напрямую интегрированы в операционную систему. Компания Stardock, создатель Window Blinds, помогала Microsoft разрабатывать Windows XP в части поддержки сменных оболочек, а потому можно вполне считать эту программу самым мощным и почти "родным" средством управления внешним видом Windows XP. Тем более что с этой программой поставляются несколько дополнительных "шкурок", которые приятно разнообразят ваш Рабочий Стол.

Еще больше стилей вы найдете на сайте www.wincustomize.com/index.asp, так что - флаг вам в руки (и барабан на шею)!

Полезная мелочь

Ну и на сладкое несколько интересных трюков, относящихся в какой-то мере и к пользовательскому интерфейсу, и к удобству работы с ним. В Windows XP заложена возможность делать Панель задач прозрачной, но, к сожалению, от пользователя она скрыта и для того, чтобы ей воспользоваться нужно обращаться к программам сторонних разработчиков.

Если есть желание не останавливаться на достигнутом, а индивидуализировать еще и Панель задач, то самым оптимальным решением, полагаю, будет микроскопическая программка AlphaTrayXP (tts.by.ru), которая хороша тем, что при старте Windows изменяет свойства Панели задач и сразу же выгружается из памяти, не отнимая ресурсы у более важных приложений.

Тем, кто работает на компьютере в офисе, или просто хочет быть уверенным, что никто не залезет на диск, пока вы на минутку отошли от машины, советую создать на Рабочем столе такой ярлык: rundll32.exe user32.dll,LockWorkStation.

Назовите его "Блокировать компьютер" и присвойте соответствующую тематике иконку. Теперь, чтобы не волноваться за сохранность приватных файлов, достаточно будет одного щелчка мыши по новому ярлыку и Windows выдаст то самое окно регистрации пользователя, которое мы сегодня пытались извратить и которое, не зная пароля, пройти невозможно.

Если вас раздражает новая системная папка "Shared Documents" в окне Проводника, и вы не собираетесь в ближайшем будущем предоставлять в общее пользование эти самые документы, поскольку локальной сети нет и не предвидится, то попробуйте удалить раздел реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Windows\CurrentVersion\Explorer\MyComputer\
NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee} - папки "Shared Documents" после перезагрузки исчезнут. Желательно предварительно экспортировать эту ветвь реестра в reg-файл, чтобы можно было легко ее восстановить.

На этом, думаю, пора остановиться, иначе весь журнал заполонит одна статья, тем более что нам никто не мешает продолжить тему борьбы с уникальным интерфейсом Windows XP в будущем.

Пока же будет полезным на досуге прогуляться в интернет за самой свежей информацией по этой системе - ссылки на сайты, соответствующие рассмотренной нами проблеме вы найдете где-то поблизости. Их там достаточно много, так что шансов на то, что потеряетесь практически нет.

Ссылки по теме:
www.themexp.org
http://www.tgtsoft.com
www.mavrick.co.uk/xpthemes.htm
www.msnskins.nl
www.deviantart.com
www.neowin.net
www.planetnexiz.com
www.teknidermy.net
www.tweakxp.com
www.wintuning.net
www.windowsxp.nu
www.win-xp.cc
http://deskmod.com

Источник: http://www.computery.ru/upgrade/